Está en la página 1de 16

OBJETIVO

El objetivo de la presente sesin es:

Conocer las herramientas para el manejo de las


estructuras de control anidadas (Diagrama de flujo y
Pseudocodigo)
Codificar en C++ el algoritmo planteado en estas
herramientas.
Resolver en cada caso ejemplos

ING. FLIX HUARI 1


ESTRUCTURA DE CONTROL REPETITIVA ANIDADA

Es posible insertar un bule dentro de otro, a esto se


llama anidamiento de bucles.
La estructura interna repetitiva debe estar incluida
totalmente dentro de la estructura repetitiva externa.
Por cada vuelta del bucle externo, el bucle interno
debe dar todas sus vueltas.

ING. FLIX HUARI 2


ESTRUCTURA DE CONTROL REPETITIVA ANIDADA

Si No
No

ING. FLIX HUARI 3


ESTRUCTURA DE CONTROL REPETITIVA ANIDADA
La representacin de la instruccin desde/para anidada
esta dado por:

Desde I a hasta N [Incremento./Decremento c] Hacer


Desde Jb hasta M [incremento/Decremento d] Hacer
Sentencias2(s)


Fin_Desde_J
Fin_Desde_I

ING. FLIX HUARI 4


ESTRUCTURA DE CONTROL REPETITIVA ANIDADA

Ia, I<=N

Jb, J<=M

Sentencia(s)

I
ING. FLIX HUARI 5
ESTRUCTURA DE CONTROL REPETITIVA ANIDADA

Pseudocodigo

Mientras(<condicion1>) Hacer
Sentencia(s)
Mientras(<condicion2>) Hacer
Sentencias2(s)
FinMientras
Sentencias1(s)
FinMientras

FUNDAMENTOS DE
ING. FLIX HUARI 6
PROGRAMACION
ESTRUCTURA DE CONTROL REPETITIVA ANIDADA
Diagrama Flujo

No
Condicin1

Si
No
Condicin2

Si
Sentencia2(s)

Sentencia1(s)
FUNDAMENTOS DE
PROGRAMACION
ING. FLIX HUARI 7
ESTRUCTURA DE CONTROL REPETITIVA ANIDADA

Pseudocodigo

Hacer
Sentencia1(s)
Hacer
Sentencia2(s)
Mientras(<condicion2>)

Mientras(<condicion1>)

FUNDAMENTOS DE
PROGRAMACION
ING. FLIX HUARI 8
ESTRUCTURA DE CONTROL REPETITIVA ANIDADA
Diagrama Flujo

Sentencia1(s)

Sentencia2(s)
Si
Condicin2

No
Si
Condicin1

FUNDAMENTOS DE No ING. FLIX HUARI 9


PROGRAMACION
ESTRUCTURA DE CONTROL REPETITIVA ANIDADA
Inicio
Declaracion de variable k,i,n
Dado un numero
n10
entero n=10, se pide
i1
disear un algoritmo
Mientras(i<=n) hacer en pseudocodigo
k1 para mostrar un
Mientras(k<=i) hacer |triangulo, la figura
Escribir(k) debe dibujar con
kk+1 numeros.
FinMientras
iI + 1
FinMientras
Fin

FUNDAMENTOS DE
PROGRAMACION
ING. FLIX HUARI 10
ESTRUCTURA DE CONTROL REPETITIVA ANIDADA

#include<iostream>
using namespace std;
int k, i, n;
n=10; i=1;
while(i<=n)
{ k=1;
while(k<=i)
{ cout<<k;
k=k + 1;
}
i=i + 1;
cout<<endl;
}
}
FUNDAMENTOS DE
PROGRAMACION
ING. FLIX HUARI 11
ESTRUCTURA DE CONTROL REPETITIVA ANIDADA

Dado un grupo de numeros enteros, se pide por


cada numero ingresado mostrar los enteros del 1 al
numero dado. Disear un algoritmo en pseudocodigo
y luego codificar en C++.

FUNDAMENTOS DE
PROGRAMACION
ING. FLIX HUARI 12
ESTRUCTURA DE CONTROL REPETITIVA ANIDADA
Inicio
Declaracion de variable k,i,n,a
Escribir (Cantidad de numeros a procesar:)
Leer(n)
i1
Hacer
k1
Escribir (Ingrese numero:)
Leer(a) i i+1
Hacer Mientras(i<=n)
Escribir(k) Fin
k k+1
Mientras(k<=a)

FUNDAMENTOS DE
PROGRAMACION
ING. FLIX HUARI 13
ESTRUCTURA DE CONTROL REPETITIVA ANIDADA

#include<iostream>
using namespace std;
int main()
{ int k,i,n,a;
cout<<"Cantidad de numeros a procesar:";
cin>>n;
cout<<endl;
i=1;
do
{ k=1;
cout<<"Ingrese numero:";
cin>>a;

FUNDAMENTOS DE
PROGRAMACION
ING. FLIX HUARI 14
ESTRUCTURA DE CONTROL REPETITIVA ANIDADA

do
{ cout<<k<<" ";
k=k+1;
}while(k<=a);
i=i+1;
cout<<endl<<endl;
}while(i<=n);
}

FUNDAMENTOS DE
PROGRAMACION
ING. FLIX HUARI 15
PROBLEMAS DE ESTRUCTURA REPETITIVA ANIDADA
Disee una algoritmo en pseudocdigo para mostrar
la tabla de multiplicar del 1 al 12 y luego codifique en
C++.
Dado un numero entero positivo mayor que 10, se
pide disear un algoritmo en diagrama de flujo para
calcular y mostrar el factorial de cada digito del
numero dado, luego codificar en C++.
Disee un algoritmo en pseudocodigo para dibujar
un cuadrado o un rectngulo, en cada caso debe
escribir el mensaje respectivo y mostrar el dibujo. La
figura a dibujar debe estar relleno con un carcter
ingresado por el usuario. Finalmente codificar en
C++.

ING. FLIX HUARI 16