Está en la página 1de 50

Repblica de Panam

Universidad Tecnolgica de Panam (UTP)

Portafolio digital de programacin

Profesora: Dra. Marlenis Pimentel

Estudiante: Morales Cruz, Elas Daniel

Cdula: 4-802-2334

Grupo: 2IT701

Ao: 2017
ndice
Presentacin de la asignatura

Carta de presentacin

Asignaciones y Bitcora de aprendizaje


Diario metacongnitivo
Sesiones
Datos de inters
Tareas
Laboratorios
Charlas
Parciales
UNIVERSIDAD TECNOLGICA DE PANAM
FACULTAD DE INGENIERIA ELECTRICA
CARRERA: ING. ELECTRICA Y ELETRONICA / ING. TELECOMUNICACIONES
ASIGNATURA: PROGRAMACIN (0862)

CRONOGRAMA DE ACTIVIDADES
SEMANAS DA FECHA TEMAS / ACTIVIDAD
1 Martes 21-mar Bienvenida, Dinmica La Vaca, Presentacin del curso
Martes 21-mar Diseo general del computador y sus unidades funcionales
Dinmica de Lgica El Puente Frgil
Mircoles 22-mar Diseo general del computador y sus unidades funcionales
Dinmica de Lgica El Puente Frgil
Jueves 23-mar Trabajo en grupo: Lectura y discusin sobre Componentes
bsicos del computador
2 Martes 28-mar continuacin de la discusin sobre Componentes bsicos
del computador Sopa de Letras
Martes 28-mar Lab A Introduccin, Fases de creacin de un programa,
Reglas para la escritura de algoritmos, Operaciones bsicas
en seudo cdigo y diagrama de flujo. Introduccin al PSeInt.
Laboratorio 1
Mircoles 29-mar Lab B - Introduccin, Fases de creacin de un programa,
Reglas para la escritura de algoritmos, Operaciones bsicas
en seudo cdigo y diagrama de flujo. Introduccin al PSeInt.
Laboratorio 1
Jueves 30-mar Operaciones bsicas en seudo cdigo y diagrama de flujo
Entrada y Salida de Informacin, Operaciones de clculo,
Operaciones Relacionales, Operaciones Lgicas
3 Martes 04-abr Charla - Grupo 1 Sistemas Operativos
Tarea 1: Estructuras de control: definiciones y ejemplos de
cada una de las estructuras
Martes 04-abr Lab A - Resolucin de problemas sencillos utilizando tcnicas
de diagrama y algoritmos.
Laboratorio 2
Mircoles 05-abr Lab B - Resolucin de problemas sencillos utilizando tcnicas
de diagrama y algoritmos
Laboratorio 2
Jueves 06-abr Charla - Grupo 2 Lenguajes de Programacin
Estructuras de control - Estructura condicional simple:
4 Martes 11-abr Estructuras de control Estructura condicional doble: IF
ELSE y Estructura condicional mltiple
Martes 11-abr Lab A - Resolucin de problemas - Laboratorio 3
Mircoles 12-abr Lab B - Resolucin de problemas - Laboratorio 3
Jueves 13-abr Libre Viernes Santo
5 Martes 18-abr Charla - Grupo 3 Computacin en nube
Martes 18-abr Lab A - Resolucin de problemas - Laboratorio 4
Mircoles 19-abr Lab B - Resolucin de problemas - Laboratorio 4
Jueves 20-abr Charla - Grupo 4 Virtualizacin
Tarea 2: Solucin de problemas
Repaso del material para el Parcial 1
6 Martes 25-abr Charla - Grupo 5 Inteligencia Artificial
Charla - Grupo 6 Realidad Aumentada
Martes 25-abr Lab A - Parcial 1 Primera Parte del Portafolio
Mircoles 26-abr Lab B - Parcial 1 Primera Parte del Portafolio
Jueves 27-abr Estructura de repeticin
7 Martes 02-may Estructura de repeticin indexada: FOR
Martes 02-may Lab A - Resolucin de problemas - Laboratorio 5
Mircoles 03-may Lab B - Resolucin de problemas - Laboratorio 5
Jueves 04-may Estructura repetitiva condicional: WHILE
8 Martes 09-may Estructura de eleccin entre varios casos: SWITCH
Martes 09-may Lab A - Resolucin de problemas - Laboratorio 6
Mircoles 10-may Lab B - Resolucin de problemas - Laboratorio 6
Jueves 11-may Arreglos unidimensionales
9 Martes 16-may Arreglos bidimensionales
Martes 16-may Lab A - Resolucin de problemas - Laboratorio 7
Mircoles 17-may Lab B - Resolucin de problemas - Laboratorio 7
Jueves 18-may
Teora Programacin Modular, Procedimientos y Funciones
Tarea 3: Solucin de problemas
10 Martes 23-may Repaso del material dado a la fecha
Martes 23-may Lab A - Parcial 2 Segunda Parte del Portafolio
Mircoles 24-may Lab B - Parcial 2 Segunda Parte del Portafolio
Jueves 25-may Introduccin al Dev-C++
11 Martes 30-may Introduccin al Dev-C++
Martes 30-may Lab A - Resolucin de problemas - Laboratorio 8
Mircoles 31-may Lab B - Resolucin de problemas - Laboratorio 8
Jueves 01-jun Estructuras de control - Estructura condicional simple en
Dev-C++
12 Martes 06-jun Estructura condicional doble: IF ELSE y Estructura
condicional mltiple en Dev-C++
Martes 06-jun Lab A - Resolucin de problemas - Laboratorio 9
Mircoles 07-jun Lab B - Resolucin de problemas - Laboratorio 9
Jueves 08-jun Estructura de repeticin en Dev-C++
13 Martes 13-jun Estructura de repeticin en Dev-C++
Martes 13-jun Lab A - Resolucin de problemas - Laboratorio 10
Mircoles 14-jun Lab B - Resolucin de problemas - Laboratorio 10
Jueves 15-jun Arreglos unidimensionales en Dev-C++
14 Martes 20-jun Arreglos bidimensionales en Dev-C++
Martes 20-jun Lab A - Resolucin de problemas - Laboratorio 11
Mircoles 21-jun Lab B - Resolucin de problemas - Laboratorio 11
Jueves 22-jun Tarea 4: Solucin de problemas
15 Martes 27-jun Repaso del material dado a la fecha
Martes 27-jun Lab A - Parcial 3
Mircoles 28-jun Lab B - Parcial 3
Jueves 29-jun Repaso del material dado a la fecha
16 Martes 04-jul Repaso del material dado a la fecha
Martes 04-jul Lab A - Semestral parte prctica
Mircoles 05-jul Lab B - Semestral parte prctica
Jueves 06-jul Cierre Afectivo del Curso
Entrega de Portafolio Final
17 Semestral Teora (Fecha asignada por la Sec. Acad.)
UNIVERSIDAD TECNOLGICA DE PANAM
FACULTAD DE ELECTRICA

PROGRAMA DE LA MATERIA: PROGRAMACIN (0862)


ELABORADO POR: Dra. Marlenis Pimentel
PRIMER SEMESTRE - 2017

1. IDENTIFICACIN DE LA ASIGNATURA.

DENOMINACIN DE LA
Programacin
ASIGNATURA:
CDIGO DE CANTIDAD DE N. DE HORAS HORAS DE
0862
ASIGNATURA: CRDITOS: 5 TERICAS: 4 LABORATORIO: 2
TOTAL DE HORAS: 6 PRERREQUISITOS: FUNDAMENT LTIMA REVISIN:
AL

2. DESCRIPCIN DE LA ASIGNATURA.
La asignatura de Programacin es un curso terico/prctico que permite al alumno sentar las bases para
entender el proceso de desarrollo de programas de software, separando los diversos elementos de un problema
y posteriormente generar soluciones algortmicas. Dichas soluciones sern implementadas en un lenguaje de
programacin de alto nivel, preferentemente Visual Basic, ya que es necesario que aprenda los conceptos
bsicos de algn lenguaje de programacin que le permita desarrollar aplicaciones de software en cursos
posteriores.
Se inicia el curso con una introduccin al proceso de programacin y las ideas de algoritmo. Se prosigue con
la presentacin de los elementos de diagramas de flujos y la construccin de algoritmos basados en la fsica y
en las matemticas. Se prosigue con los fundamentos del DevC: tipos de datos y su manejo, declaraciones,
expresiones numricas, incluyendo las funciones intrnsecas, operadores aritmticos. Progresivamente se van
tratando problemas ms elaborados hasta incluir vectores y matrices.
Una vez adquiridos los conocimientos y tcnicas los estudiantes estarn en capacidad de resolver, siguiendo
correctamente la metodologa de programacin y el desarrollo de algoritmos, una diversidad de problemas
relacionados a la manipulacin de datos en la computadora, utilizando una herramienta de programacin.

3. OBJETIVOS.

Generales:
Analizar, disear y desarrollar soluciones de problemas reales utilizando algoritmos computacionales
para implementarlos en un lenguaje de programacin.
Especficos
Manejar los componentes bsicos del computador.
Aplicar las funciones bsicas de ciertos software de aplicacin.
Conocer las estructuras fundamentales de la programacin.
Resolver problemas sencillos utilizando tcnicas de algoritmos.
Resolver problemas sencillos sobre la base de un lenguaje de programacin.

4. CONTENIDOS DE LA ASIGNATURA.
Mdulo I: COMPONENTES BSICOS DEL COMPUTADOR Duracin: 2 semanas

CONTENIDO ESTRATEGIAS EVALUACIN RECURSOS

1.1. Introduccin Anlisis de Formativa - Libros


1.2. Diseo general del computador y Lectura Responsabilidad Archivos en PDF
sus unidades funcionales Discusin en Trabajo en equipo Proyector
1.1.1. Hardware grupo Multimedia
1.1.2. Software Sopa de Letra Sumativa Computadora
sobre
1.3. Clasificacin de las conceptos Ejercicio corto
computadoras segn el tamao sobre el tema
1.1.1. Microcomputadoras
1.1.2. Minicomputadoras
1.1.3. Macrocomputadoras
1.1.4. Supercomputadoras
1.1.5. Estaciones de Trabajo

1.4. Clasificacin de las


computadoras segn la forma en
que representa sus datos
1.1.1. Analgicas
1.1.2. Digitales
1.1.3. Hbridas

Mdulo II: PROGRAMACIN Duracin: 7 Semanas

CONTENIDO ESTRATEGIAS EVALUACIN RECURSOS

2.1 Introduccin Anlisis de Formativa - Libros


2.2 Reglas para la escritura de ejemplos de un Responsabilidad Archivos en PDF
algoritmos algoritmo Proyector Multimedia
2.3 Operaciones bsicas en seudo Explicacin de Computadora
cdigo y diagrama de flujo cada parte de
2.3.1 Entrada y Salida de Sumativa Laboratorio
un algoritmo
Informacin Practica de Ejercicios prcticos Lenguaje de
2.3.2 Operaciones de clculo solucin de Parcial Programacin
2.3.3 Estructura de control en problemas con
seudo cdigo y diagrama algoritmo
de Flujo
2.3.4 Prueba de Escritorio
2.3.5 Resolucin de problemas
sencillos utilizando tcnicas de
diagrama y algoritmos
2.4 Programacin Modular
2.4.1 Procedimientos
2.4.2 Funciones
2.4.3 Problemas resueltos y
prueba de escritorio
2.5 Arreglos

2.5.1 Introduccin
2.5.2 Conceptos de Arreglos
2.5.2.1 Definicin
2.5.2.2 Reglas
2.5.3 Tipos de Arreglos
2.5.3.1 Arreglos
Unidimensionales
2.5.3.2 Arreglos
Bidimensionales
2.5.4 Problemas resueltos y
prueba de
escritorio

Mdulo III: LENGUAJE DE PROGRAMACIN Duracin:

CONTENIDO ESTRATEGIAS EVALUACIN RECURSOS

3.1 Introduccin al C Anlisis de Formativa - Libros


3.2 Reglas generales del C ejemplos de Responsabilidad Archivos en PDF
3.3 Elementos bsicos del C desarrollados en Proyector
3.3.1Identificadores y el lenguaje de Multimedia
palabras reservadas programacin
Sumativa Computadora
3.3.2 Tipos de datos bsicos Explicacin de
3.3.3 Constantes cada parte del Ejercicios prcticos Laboratorio
3.3.4 Variables cdigo fuente, Parcial Lenguaje de
3.3.5 Declaraciones compilacin y Programacin
ejecucin
3.4 Entrada y salida de datos Practica de
3.5 Operaciones y expresiones solucin de
3.6 Sentencias de Control problemas en el
3.7 Funciones laboratorio
3.7.1 Introduccin
3.7.2 Definicin de una
funcin
3.7.3 Acceso a una
funcin
3.7.4 Laboratorio

3.8 Arreglos
3.8.1 Introduccin
3.8.2 Definicin de un
arreglo
3.8.3 Procesamiento de
un arreglo
3.8.4 Laboratorio
5. EVALUACIN SUGERIDA.

CRITERIOS DE EVALUACIN PORCENTAJE


Asistencia y participacin en clases 5%
Parciales (*) 30%
Semestral (*) 30%
Trabajos de Investigacin, presentaciones orales, portafolio 15%
Laboratorios 20%
Total : 100%

6. REFERENCIAS BIBLIOGRFICAS.

Gottfried, B. (2005). Programacin en C. Schaum. McGraw-Hill,


Joyanes, L., Zahonero, I. (2005). Programacin en C, metodologa, algoritmos y estructura de datos.
McGraw-Hill
Deitel H., Deitel, P. (2008). Cmo programar en C++. 6ta Edicin. McGraw-Hill
Carta de presentacin

Nac el 7 de mayo de 1999, en la Clnica Hospital Cattan, David,


Chiriqu. Viv mi infancia en La Concepcin, Bugaba, a la edad de 5
aos empec mis estudios primarios en la Escuela Adventista de la
Concepcin, posteriormente estuve en la Escuela Santa Catalina, en La
Concepcin, donde estudi hasta el quinto grado, el sexto grado lo
curs en la Escuela Justo Abel Castillo.
Durante ese tiempo mi familia se traslad Coquito, David, donde
resido actualmente.
Luego de culminar mis estudios primarios, comenc la secundaria en
el Colegio Daniel Octavio Crespo, Bachiller en Ciencias.
Estudi en un curso por un ao, sobre programacin, diseo grfico, y
manejo de Microsoft Office.
Actualmente Estudio en la Universidad Tecnolgica de Panam,
Licenciatura en Ingeniera Electrnica y Telecomunicaciones.
Entre mis gustos puedo mencionar, la composicin musical, msica, cine, gastronoma, ciencia, cubos de
rubik.
Identifica por lo menos 4 vacas
- Pereza
- Juegos
- Televisin
- Falta de voluntad

Metas a corto plazo (1 ao)


- Completar con buenas calificaciones todas las asignaturas del ao.

A largo plazo (5 aos)


- Graduarme, trabajar, obtener un buen salario, cumplir mis sueos.
Razn de la existencia de las computadoras

En la antigedad utilizaban sistemas muy rudimentarios para realizar clculos.


El ms eficaz fue la utilizacin del baco: dispositivos de conteo mecnico hace 5000 aos.

Sus Razones de existencia de la computadora:

Avance de la electrnica
Existencia de una teora matemtica para describir combinaciones de variables lgicas
Disponibilidad de grandes capitales para la investigacin del desarrollo

La primera computadora surge como respuesta a resolver en forma prctica y rpida para la toma
oportuna de decisiones. Es una mquina capaz de realizar y controlar a gran velocidad clculos
complejos y complicados que requieren una toma rpida de decisin.

Antecedentes

Eniac I (1951): John Pascalna (1642):


Mauchly construy Creada por Blas
esta primera Pascal, era una
computadora de mquina para
serie puesta en sumar basada en
venta.
engranes

Mquina Analtica (1ra Telar de Jacquard


mitad del siglo XIX): (1801): Creado por
Charles Babage Joseph Jacquard,
desarroll la mquina consista en el
diferencial y analtica, movimiento de las
considerado el padre de agujas realizando
la informtica patrones elaborados.
Mquina tabuladora
de Hollerith (1940):
John Mauchly y John
Presper construyeron
la primera
computadora
electrnica, llamada
ENIAC
Generaciones de las Computadoras

Primera Generacin (1951-1958)

En esta generacin haba un gran desconocimiento de las capacidades de las computadoras,


puesto que se realiz un estudio en esta poca que determin que con veinte computadoras se
saturara el mercado de los Estados Unidos en el campo de procesamiento de datos. Esta
generacin abarco la dcada de los cincuenta. Y se conoce como la primera generacin. Estas
mquinas tenan las siguientes caractersticas:

Usaban tubos al vaco para procesar informacin.


Usaban tarjetas perforadas para entrar los datos y los programas.
Usaban cilindros magnticos para almacenar informacin e instrucciones internas.
Eran sumamente grandes, utilizaban gran cantidad de electricidad, generaban gran cantidad de calor y
eran sumamente lentas.
Se comenz a utilizar el sistema binario para representar los datos.

Segunda Generacin (1958-1964)

En esta generacin las computadoras se reducen de tamao y son de menor costo.


Aparecen muchas compaas y las computadoras eran bastante avanzadas para su poca
como la serie 5000 de Burroughs y la ATLAS de la Universidad de Manchester. Algunas
computadoras se programaban con cinta perforada y otras por medio de cableado en un
tablero. Caractersticas de esta generacin:

Usaban transistores para procesar informacin.


Los transistores eran ms rpidos, pequeos y ms confiables que los tubos al vaco.
200 transistores podan acomodarse en la misma cantidad de espacio que un tubo al vaco.
Usaban pequeos anillos magnticos para almacenar informacin e instrucciones. Cantidad de calor y
eran sumamente lentas.
Se mejoraron los programas de computadoras que fueron desarrollados durante la primera
generacin.
Se desarrollaron nuevos lenguajes de programacin como COBOL y FORTRAN, los cuales eran
comercialmente accesibles.
Se usaban en aplicaciones de sistemas de reservaciones de lneas areas, control del trfico areo y
simulaciones de propsito general.
La marina de los Estados Unidos desarrolla el primer simulador de vuelo, "Whirlwind I".
Surgieron las minicomputadoras y los terminales a distancia.
Se comenz a disminuir el tamao de las computadoras.
Tercera Generacin (1964-1971)

La tercera generacin de computadoras emergi con el desarrollo de circuitos integrados


(pastillas de silicio) en las que se colocan miles de componentes electrnicos en una
integracin en miniatura. Las computadoras nuevamente se hicieron ms pequeas, ms
rpidas, desprendan menos calor y eran energticamente ms eficientes. El ordenador
IBM-360 domin las ventas de la tercera generacin de ordenadores desde su
presentacin en 1965. El PDP-8 de la Digital Equipment Corporation fue el primer
miniordenador. Caractersticas de esta generacin:

Se desarrollaron circuitos integrados para procesar informacin.


Se desarrollaron los "chips" para almacenar y procesar la informacin. Un "chip" es una pieza de silicio
que contiene los componentes electrnicos en miniatura llamados semiconductores.
Los circuitos integrados recuerdan los datos, ya que almacenan la informacin como cargas elctricas.
Surge la multiprogramacin.
Las computadoras pueden llevar a cabo ambas tareas de procesamiento o anlisis matemticos.
Emerge la industria del "software".
Se desarrollan las minicomputadoras IBM 360 y DEC PDP-1.
Otra vez las computadoras se tornan ms pequeas, ms ligeras y ms eficientes.
Consuman menos electricidad, por lo tanto, generaban menos calor.

Cuarta Generacin (1971-1988)

Aparecen los microprocesadores que es un gran adelanto de la microelectrnica, son


circuitos integrados de alta densidad y con una velocidad impresionante. Las
microcomputadoras con base en estos circuitos son extremadamente pequeas y baratas,
por lo que su uso se extiende al mercado industrial. Aqu nacen las computadoras
personales que han adquirido proporciones enormes y que han influido en la sociedad en
general sobre la llamada "revolucin informtica". Caractersticas de esta generacin:

Se desarroll el microprocesador.
Se colocan ms circuitos dentro de un "chip".
Cada "chip" puede hacer diferentes tareas.
Un "chip" sencillo actualmente contiene la unidad de control y la unidad de aritmtica/lgica. El tercer
componente, la memoria primaria, es operado por otros "chips".
Se reemplaza la memoria de anillos magnticos por la memoria de "chips" de silicio.
Se desarrollan las microcomputadoras, o sea, computadoras personales o PC.
Se desarrollan las supercomputadora
Quinta Generacin (1983 al presente)

En vista de la acelerada marcha de la microelectrnica, la sociedad industrial se ha


dado a la tarea de poner tambin a esa altura el desarrollo del software y los sistemas
con que se manejan las computadoras. Surge la competencia internacional por el
dominio del mercado de la computacin, en la que se perfilan dos lderes que, sin
embargo, no han podido alcanzar el nivel que se desea: la capacidad de comunicarse
con la computadora en un lenguaje ms cotidiano y no a travs de cdigos o
lenguajes de control especializados.

Japn lanz en 1983 el llamado "programa de la quinta generacin de computadoras", con los objetivos
explcitos de producir mquinas con innovaciones reales en los criterios mencionados. Y en los Estados Unidos
ya est en actividad un programa en desarrollo que persigue objetivos semejantes, que pueden resumirse de
la siguiente manera:

Se desarrollan las microcomputadoras, o sea, computadoras personales o PC.


Se desarrollan las supercomputadoras.
Tarea # 1
Estructuras de Control

Antecedentes
El trmino "estructuras de control" viene del campo de la ciencia computacional. Cuando se presentan
implementaciones de Java para las estructuras de control, nos referimos a ellas con la terminologa de la
Especificacin del lenguaje Java, que se refiera a ella como instrucciones modernas.

Ejecucin secuencial
Pero, por lo general, las instrucciones se ejecutan una despus de la otra, en el orden en que estn escritas,
es decir, en secuencia. Este proceso se conoce como ejecucin secuencial.

Transferencia de control
En Java, como en otros lenguajes de programacin por excelencia como C y C++, el programador puede
especificar que la siguiente instruccin a ejecutarse tal vez no sea la siguiente en secuencia. Esto se conoce
como transferencia de control. Hay que tener en cuenta que la instruccin goto es una palabra reservada pero
no se utiliza ni se recomienda. Un programa bien estructurado no necesita esta instruccin.

De seleccin
Las estructuras de control de seleccin ejecutan un bloque de instrucciones u otro, o saltan a un subprograma
o subrutina segn se cumpla o no una condicin.
Estructura de control
Las estructuras de control, denominadas tambin sentencias de control, permiten tomar decisiones y realizar
un proceso repetidas veces. Se trata de estructuras muy importantes, ya que son las encargadas de controlar
el flujo de un programa, segn los requerimientos del mismo.
Seleccin if simple
Se trata de una estructura de control que permite redirigir un curso de accin segn la evaluacin de una
condicin simple, sea falsa o verdadera.
Si la condicin es verdadera, se ejecuta el bloque de sentencias 1; de lo contrario, se ejecuta el bloque de
sentencias 2.

IF (Condicin) THEN
(Bloque de sentencias 1)
ELSE
(Bloque de sentencias 2)
END IF

Se pueden plantear mltiples condiciones simultneamente: si se cumple la (Condicin 1) se ejecuta (Bloque


de sentencias 1). En caso contrario se comprueba la (Condicin 2); si es cierta se ejecuta (Bloque de
sentencias 2), y as sucesivamente hasta n condiciones. Si ninguna de ellas es cumple se ejecuta (Bloque de
sentencias else).

IF (Condicin 1) THEN
(Bloque de sentencias 1)
ELSEIF (Condicin 2) THEN
(Bloque de sentencias 2)

.....

ELSEIF (Condicin n) THEN


(Bloque de sentencias n)
ELSE
(Bloque de sentencias else)
END IF

Select-Case
Art
Esta sentencia permite ejecutar una de entre varias acciones en funcin del valor de una expresin. Es una
alternativa a if then else cuando se compara la misma expresin con diferentes valores.

Se evala la expresin, dando como resultado un nmero.


Luego, se recorren los "Case" dentro de la estructura buscando que el nmero coincida con uno de los
valores.
Es necesario que coincidan todos sus valores.
Cuando se encuentra la primera coincidencia, se ejecuta el bloque de sentencias correspondiente y se
sale de la estructura Select-Case.
Si no se encuentra ninguna coincidencia con ningn valor, se ejecuta el bloque de sentencias de la
seccin "Case Else".

Select (Expresin)
Case Valor1
(Bloque de sentencias 1)
Case Valor2
(Bloque de sentencias 2)
Case Valor n
(Bloque de sentencias n)
Case Else
(Bloque de sentencias "Else")
End Select
Estructuras de control iterativas
Las estructuras de control iterativas o de repeticin, inician o repiten un bloque de instrucciones si se cumple
una condicin o mientras se cumple una condicin.
Do-While
Mientras la condicin sea verdadera, se ejecutarn las sentencias del bloque.

Do While (Condicin)
(Bloque de sentencias)
Loop

Que tambin puede expresarse:

While (Condicin)
(Bloque de sentencias)
wend

Do-Until
Se ejecuta el bloque de sentencias, hasta que la condicin sea verdadera

Do
(Bloque de sentencias)
Loop Until (Condicin)

For-Next
La sentencia For da lugar a un lazo o bucle, y permite ejecutar un conjunto de sentencias cierto nmero de
veces.

Primero, se evalan las expresiones 1 y 2, dando como resultado dos nmeros.


La variable del bucle recorrer los valores desde el nmero dado por la expresin 1 hasta el nmero dado
por la expresin 2.
El bloque de sentencias se ejecutar en cada uno de los valores que tome la variable del bucle.

For (Variable) = (Expresin1) To (Expresin2) STEP (Salto)


(Bloque de sentencias)
Next
Tarea #2
Desarrollo
1.

2.
3.

4.
5.

6.
7.

8.
Laboratorio 1

Problema 1: Suma
1 Proceso suma
2 Escribir "introduzca el n1"
3 Leer n1
4 Escribir "introduzca el n2"
5 Leer n2
6 s=n1+n2
7 Escribir "Resultado:"
8 Escribir s
9 Fin Proceso

Problema 2: Promedio
1 Proceso Promedio
2 Escribir 'introduzca el n1'
3 Leer n1
4 Escribir 'introduzca el n2'
5 Leer n2
6 Escribir 'introduzca el n3'
7 Leer n3
8 Escribir 'introduzca el n4'
9 Leer n4
10 s <- n1+n2+n3+n4
11 Escribir 'la suma es'
12 Escribir s/4
13 Fin Proceso

Problema 3: rea
Proceso rea
Escribir "introduzca la base del rectngulo"
Leer B
Escribir "introduzca la altura del rectngulo"
Leer H
Escribir "la multiplicacin es"
A=B*H
Escribir A
Fin Proceso
Laboratorio 2

Problema 1: Realizar un seudocdigo para calcular su estatura de cm a pulg y a pies.


1 Proceso Estatura
2 Escribir "introduzca cm";
3 Leer cm;
4 Pulg=cm/2.54;
5 Pies=pulg/12;
6 Escribir "mi estatura en pulgadas es ", Pulg, " y en pies es ",
Pies;
8 Fin Proceso

Problema 2: una empresa constructora vende terrenos con las siguientes formas. Se necesita saber las
medidas del rea.
1 Proceso rea
2 Escribir "introduzca a"
3 Leer a
4 Escribir "introduzca b"
5 Leer b
6 Escribir "introduzca c"
7 Leer c
8 Escribir "el rea del tringulo es"
9 At= (a-c)*b/2
10 Escribir At
11 Escribir "el rea del rectngulo es"
12 Ar= (a-c)*b
13 Escribir Ar
14 Escribir "el rea total es"
15 Atotal=At+Ar
16 Escribir Atotal
17 Fin Proceso
Problema 3: un productor de leche lleva el registro de lo que produce en litros pero cuando entrega le
pagan en galones. Realice un seudocdigo que ayude a saber cunto recibir?
1 Proceso Conversin
2 Escribir "introduzca L"
3 Leer L
4 Escribir "introduzca PxG"
5 Leer PxG
6 G=L/3.785
7 Escribir "la venta en galones fue"
8 Escribir G
9 PxG=G*2
10 Escribir "la ganancia del dia fue"
11 Escribir PxG
12 Fin Proceso
Laboratorio 3

Problema 1: La cafetera de UTP ofrece tres tipos de hamburguesa; sencilla (3.00), doble (5.00) y triple
(8.00). Si usted paga con tarjeta de crdito se cobra adicional el 10%. Disee un algoritmo para resolver
este problema.
1 Proceso Hamburguesas
2 Escribir "Bienvenidos a Choveca Burguer"
3 Escribir "tipo de hamburguesa"
4 Escribir "Cuantas hamburguesas quiere?"
5 Leer cant
6 Escribir "Escoja entre sencilla, doble, triple"
7 Leer Tipo
8 si Tipo="sencilla" entonces
9 pago= cant*3
10 sino
11 si tipo="doble" Entonces
12 pago= cant*5
13 sino
14 si tipo="triple" Entonces
15 pago= cant*8
16 sino
17 Escribir "introdusca el tipo de hamburguesa correct"
18 FinSi
19 FinSi
20 FinSi
21 Escribir "tipo de pago"
22 Escribir "Efectivo o tarjeta?"
23 Leer tp
24 si tp= "efectivo" Entonces
25 pagoT= pago
26 sino
27 si tp="tarjeta" Entonces
28 pagoT= (pago*0.10)+pago
29 sino
30 Escribir "introdusca el tipo de pago correcto"
31 FinSi
32 FinSi
33 Escribir "El total es XD"
34 Escribir pagoT
35 FinProceso
Laboratorio 4:
Problema 1: Cierta empresa proporciona un bono mensual a sus trabajadores por su antigedad de la
siguiente forma cuando la antigedad es mayor a 2 aos pero menor 5 aos se otorga el 20 % de su
sueldo. Cuando antigedad es de ms de 5 aos se otorga el 30% de sueldo. Cunto recibe de bono el
trabajador?
Proceso Bono
1 Escribir "introduzca Salario"
2 Leer S
3 Escribir "Introduzca Antigedad"
4 Leer A
5 si A>=2 Entonces
6 si A>=5 Entonces
7 B=S*0.30
8 Escribir B
9 Sino
10 B=S*0.20
11 Escribir B
12 FinSi
13 Sino
14 Escribir "No hay bono"
15 FinSi
16 Fin Proceso
Problema 2: La policlnica Gustavo A. Ros requiere un diagrama de flujo que represente el algoritmo que
permita saber que vacuna aplicar (a,b,c) a una persona considerando que si P>70 sin importar el sexo se
aplica c, si tiene entre 16-69 y es mujer se aplica la b, si es hombre se aplica la a. Si P<16 se le aplica la a
sin importar el sexo.
Proceso Vacunas
1 Escribir "Introdusca sexo M O F"
2 Leer S
3 Escribir "introdusca Edad"
4 Leer E
5 si E>=16 Entonces
6 si E>=70 Entonces
7 Escribir "Vacuna C"
8 sino
9 si S="M" Entonces
10 Escribir "Vacuna a"
11 Sino
12 Escribir "Vacuna b"
13 FinSi
14 FinSi
15 Sino
16 Escribir "Vacuna a"
17 FinSi
18 FinProceso
Problema 3: La fbrica El Chiricano produce artculos con claves 1, 2, 3 se requiere un algoritmo para
calcular los precios de venta para esto hay que considerar lo siguiente:
Costo de produccin=materia prima + mano de obra + gasto de fabricacin
Precio de venta=costo de produccin + 35% de CP
Costo de mano de obra=para los productos con clave 1 se carga el 65% del costo de materia prima; para
los de clave 2 se carga el 80% del CMP; para los de clave 3 se carga el 90% del CMP.
Para calcular el gasto de fabricacin se considera que si el artculo es clave 1 o 2 el gasto de fabricacin
es de 30% sobre el costo de la materia prima; si la clave es 3 representa el 35% de la materia prima.

1 Proceso Precio_de_venta
2 Escribir "introduzca costo de materia prima"
3 Leer MP
4 Escribir "introduzca clave de artculo"
5 Leer Clave
6 si Clave=1 Entonces
7 CP=MP+(MP*0.65)+[(MP*0.30)+MP]
8 PV=CP+(CP*0.35)
9 Escribir "El precio de venta es"
10 Escribir PV
11 Sino
12 Si Clave=2 Entonces
13 CP=MP+(MP*0.80)+[(MP*0.30)+MP]
14 PV=CP+(CP*0.35)
15 Escribir "El precio de venta es"
16 Escribir PV
17 Sino
18 Si Clave=3 Entonces
19 CP=MP+(MP*0.90)+[(MP*0.35)+MP]
20 PV=CP+(CP*0.35)
21 Escribir "El precio de venta es"
22 Escribir PV
23 Sino
24 Si Clave != 1 Entonces
25 Escribir "introduzca clave correcta"
26 Sino
27 Si Clave<>2 Entonces
28 Escribir "introduzca clave correcta
29 Sino
30 si Clave<>3 Entonces
31 Escribir "introduzca clave correcta"
32 FinSi
33 FinSi
34 FinSi
35 FinSi
36 FinSi
37 FinSi

FinProceso
Laboratorio 5:
Problema 1:
1. Proceso Suma_mientras
2. SU <- 0
3. C <- 1
4. Mientras C<=10 Hacer
5. Leer VA
6. SU <- SU+VA
7. C <- C+1
8. FinMientras
9. Escribir SU
10. FinProceso

Problema 2:
1. Proceso Suma_repetir
2. SU <- 0
3. C <- 1
4. Repetir
5. Leer VA
6. SU <- SU+VA
7. C <- C+1
8. Hasta que C<=10
9. Escribir SU
10. FinProceso
Problema 3:
1. Proceso Suma_Para
2. SU=0
3. Para C=1 Hasta 10 Con Paso 1 Hacer
4. Leer VA
5. SU=SU+VA
6. FinPara
7. Escribir SU
8. FinProceso

Problema 4:
1. Proceso promedio_mientras
2. SU=0
3. C=1
4. Escribir 'Introducir las edades'
5. Mientras C<=15 Hacer
6. Leer E
7. SU=SU+E
8. C=C+1
9. FinMientras
10. P = SU/15
11. Escribir "El promedio es"
12. Escribir P
13. FinProceso

Problema 5:
1. Proceso Promedio_repetir
2. SU=0
3. C=1
4. Escribir 'Introducir las edades'
5. Repetir
6. Leer E
7. SU=SU+E
8. C=C+1
9. Hasta que C>15
10. P = SU/15
11. Escribir "El promedio es"
12. Escribir P
13. FinProceso
Problema 6:
1. Proceso promedio_para
2. Escribir "Introduce la Edad"
3. Para C=1 Hasta 15 Con Paso 1 Hacer
4. Leer E
5. SU=SU+E
6. Fin Para
7. P=SU/15
8. FinProceso

Problema 7:
1. Proceso Piscina
2. Escribir "Introduce la cantidad de agua"
3. Para C=1 Hasta 9 Con Paso 1 Hacer
4. Leer A
5. SU=SU+A
6. Fin Para
7. Escribir "Su cantidad de agua es de: "
8. Escribir SU
9. FinProceso
Laboratorio 6
Problema 1:
1. Proceso ventas
2. escribir "introducir cantidad de ciudadess"
3. leer x
4. Para c=1 Hasta x Con Paso 1 Hacer
5. escribir " introducir cantidad de sucursales"
6. leer s
7. Para r=1 Hasta s Con Paso 1 Hacer
8. escribir " introducir cantidad de vendedores"
9. leer e
10. Para g=1 Hasta e Con Paso 1 Hacer
11. escribir "introducir ventas por vendedor"
12. leer vent
13. Ve=Ve+Vent
14. Fin Para
15. Vt=Vt+Ve
16. Ve=0
17. Fin Para
18. Vti=Vti+Vt
19. Vt=0
20. escribir "total vendido por ciudades es:"
21. escribir Vti
22. Fin Para
23. FinProceso
Laboratorio 7
Problema 1:
1. Proceso Hamburguesas
2. Escribir "Bienvenidos a Choveca Burguer"
3. Escribir "Cuantas Sencillas"
4. Leer A
5. Escribir "Cuantas dobles"
6. Leer B
7. Escribir "Cuantas triples"
8. Leer C
9. Z=A+B+C
10. S=A*3
11. D=B*5
12. T=C*8
13. P=S+D+T
14. Escribir "Efectivo o tarjeta?"
15. Leer TP
16. si TP="Efectivo" Entonces
17. PT=P
18. sino
19. si TP="Tarjeta" Entonces
20. PT=(P*0.10)+P
21. sino
22. Escribir "introdusca el tipo de pago correcto"
23. FinSi
24. FinSi
25. Escribir "El total es"
26. Escribir PT
27. FinProceso

Problema 2
1. Proceso Mesnualidad
2. Escribir "Introduzca Pago mensual"
3. Leer A
4. Para C=1 Hasta 20 Con Paso 1 Hacer
5. A=A*2
6. Escribir "El total es de:"
7. P=A+A
8. Escribir P
9. Fin Para
10. FinProceso
Laboratorio 8:
Problema 1:
1. Proceso Banco
2. Escribir "Introduzca su tipo de tarjeta
(1,2,3)"
3. Leer TIPO
4. Escribir "Introduzca limite"
5. Leer L
6. Segun TIPO Hacer
7. 1:
8. CT=L+(L*0.25)
9. 2:
10. CT=L+(L*0.35)
11. 3:
12. CT=L+(L*0.40)
13. De Otro Modo:
14. CT=L+(L*0.50)
15. Fin Segun
16. Escribir "Su nuevo limite de crdito es de: "
17. Escribir CT
18. FinProceso

Problema 2:
1. Proceso Focos
2. Escribir "Introduzca Cantidad de bombillos"
3. Leer S
4. C=1
5. Repetir
6. Escribir "Introduzca el color del bombillo Rojo(R) Verde(V)
Blanco(B) "
7. Leer COLOR
8. Segun COLOR Hacer
9. "R":
10. CR=CR+1
11. "V":
12. CV=CV+1
13. "B":
14. CB=CB+1
15. De Otro Modo:
16. Escribir "Introduzca uno de los 3 colores indicados (R,V,B)"
17. Fin Segun
18. C=C+1
19. Hasta Que C>S
20. Escribir "El total de focos de cada color es :"
21. Escribir "Rojo : " CR
22. Escribir "Verde : " CV
23. Escribir "Blanco : " CB
24. FinProceso
Problema 3:
1. Proceso Menu
2. Escribir "Cuantas operaciones desea
realizar?"
3. Leer N
4. C=1
5. Mientras C<=N Hacer
6. Escribir "Men"
7. Escribir "1: Suma"
8. Escribir "2: Resta"
9. Escribir "3: Multiplicacin"
10. Leer X
11. Segun X Hacer
12. 1:
13. Escribir "Introduzca dos cifras para sumar"
14. Leer A
15. Leer B
16. S=A+B
17. 2:
18. Escribir "Introduzca dos cifras para restar"
19. Leer A
20. Leer B
21. S=A-B
22. 3:
23. Escribir "Introduzca dos cifras para multiplicar"
24. Leer A
25. Leer B
26. S=A*B
27. De Otro Modo:
28. Escribir "Escriba 1, 2 o 3 :v"
29. Fin Segun
30. C=C+1
31. Escribir "La respuesta es"
32. Escribir S
33. FinMientras
34. FinProceso
Problema 4:
1. Proceso Menu
2. Escribir "Men"
3. Escribir "1: Suma"
4. Escribir "2: Resta"
5. Escribir "3: Multiplicar"
6. Leer X
7. Segun X Hacer
8. 1:
9. Escribir "Introduzca dos cifras para
sumar"
10. Leer A
11. Leer B
12. S=A+B
13. 2:
14. Escribir "Introduzca dos cifras para
restar"
15. Leer A
16. Leer B
17. S=A-B
18. 3:
19. Escribir "Introduzca dos cifras para multiplicar"
20. Leer A
21. Leer B
22. S=A*B
23. De Otro Modo:
24. Escribir "Escriba 1, 2 o 3 :v"
25. Fin Segun
26. Escribir "La respuesta es"
27. Escribir S
28. FinProceso

Problema 5:
1. Proceso Salario
2. S=1500
3. C=1
4. Mientras C<=6 Hacer
5. S=S+(S*0.10)
6. Escribir "Su Incremento este ao es de : "
7. Escribir S
8. C=C+1
9. FinMientras
10. FinProceso
Problema 6:
1. Proceso Envio
2. Escribir "Zona a enviar el pack (America del Norte(1), America del Sur(2), America Central(3), Europa(4), Asia(5))"
3. Leer Z
4. Escribir "Peso del Paquete"
5. Leer P
6. Si P<=5 Entonces
7. Segun Z Hacer
8. 1:
9. C=P*10
10. 2:
11. C=P*12
12. 3:
13. C=P*14
14. 4:
15. C=P*20
16. 5:
17. C=P*25
18. De Otro Modo:
19. Escribir "Introduzca el numero correcto correspondiente a la zona"
20. Fin Segun
21. Sino
22. Escribir "No se envian paquetes con un peso mayor a 5Kg"
23. FinSi
24. Escribir "El costo por el paquete es de :"
25. Escribir C
26. FinProceso
Laboratorio 9
Problema 1:
1. Proceso Impuestos
2. C=1
3. Escribir "Introduzca cantidad de vehiculos"
4. Leer CA
5. Repetir
6. Escribir "Introduzca su tipo de Vehiculos (1,2,3)"
7. Leer TIPO
8. C=C+1
9. Segun TIPO Hacer
10. 1:
11. C1=(15000*0.15)
12. T1=C1+T1
13. 2:
14. C2=(8000*0.10)
15. T2=C2+T2
16. 3:
17. C3=(5000*0.05)
18. T3=C3+T3
19. De Otro Modo:
20. Escribir "Introduzca Codigo Correcto"
21. Fin Segun
22. Hasta Que C>CA
23. T2=T2+200
24. CT=T1+T2+T3
25. Escribir "El Precio de la Categora 1 es : "
26. Escribir T1
27. Escribir "El Precio de la Categora 2 es : "
28. Escribir T2
29. Escribir "El Precio de la Categora 3 es : "
30. Escribir T3
31. Escribir "El total es de :"
32. Escribir CT
33. FinProceso
Problema 2:
1. Proceso Tabla
2. Escribir "Introduzca Numero para saber su tabla"
3. Leer K
4. C=0
5. Mientras C<=11 Hacer
6. C=C+1
7. T=K*C
8. Escribir K " x " C " = " T
9. FinMientras
10. FinProceso

Problema 3:
1. Proceso Calificaciones
2. Escribir "Nmero de Estudiantes?"
3. Leer N
4. C=1
5. Mientras C<=N Hacer
6. C=C+1
7. Escribir "Introduzca Calificacion"
8. Leer F
9. Si F<=61 entonces
10. A=1+A
11. Sino
12. Si F>61 entonces
13. B=1+B
14. Sino
15. Escribir "Introduzca Correctamente R o A"
16. FinSi
17. FinSi
18. FinMientras
19. Escribir "El Total de Reprobados es de : " A
20. Escribir "El Total de Aprobados es de : " B
21. FinProceso
Diario meta cognitivo

Martes 21/Mar: Iniciamos nuestra primera clase con una dinmica llamada La vaca que
se basa en una historia, acerca de eliminar nuestras cargas, que no nos permiten darlo
todo en las cosas ms importantes. Tambin se explic sobre el concepto bsico de un
computador, perifricos y redes. Resolvimos un pequeo problema acerca de un puente
que nos enseaba a analizar de forma eficiente, el cmo resolver un problema.

Jueves 23/Mar: Realizamos un resumen acerca del concepto de la computadora y su


cronologa la cual explicamos y discutimos en clase junto a los dems grupos. Nos hizo
enfocarnos en que se basa una computadora, para hacer la toma oportuna de decisiones
en un momento determinado.

Martes 28/Mar: Aprendimos conceptos bsicos para las fases de creacin de un


programa, a travs de un diagrama de flujo y utilizamos la herramienta PSint para escribir
seudo cdigos bsicos de suma, rea, etc.

Jueves 30/Mar: Resolvimos problemas en el saln de clases, con sus reglas de escritura y
entrada salida de informacin.

Martes 4/Abr: El grupo uno, hizo su presentacin acerca de los sistemas operativos, la
base para la comprensin del usuario en un ordenador, y el que se relaciona con el
hardware para mayor eficiencia; Seguimos utilizando conceptos bsicos para la
resolucin de problemas en el laboratorio como transformacin de unidades de medida
con operaciones mltiples.

Jueves 6/Abr: Se present el grupo dos para hablarnos acerca de los lenguajes de
programacin y sus diferentes ventajas y desventajas a la hora de programar, tambin se
explicaron algunas estructuras de control.

Martes 11/Abr: Resolvimos algunos problemas en el cuaderno para posteriormente


hacerlos en el laboratorio.
Martes 18/Abr: El grupo 3 expuso su tema acerca de la computacin en la nube, ventajas
desventajas y caractersticas, los servicios que ofrece y los tipos de nube que existen;
Resolvimos algunos problemas en el cuaderno para posteriormente hacerlos en el
laboratorio.

Jueves 20/Abr: El grupo cuatro expuso su tema acerca de la virtualizacin, una tcnica
utilizada para ejecutar y desplegar mltiples sistemas operativos en el mismo ordenador.
La profesora entreg una pgina con 8 problemas de prctica para el parcial.

Martes 25/Abr: Escuchamos las exposiciones y luego realizamos el parcial #1 en el


laboratorio

Jueves 27/Abr: Empezamos con las estructuras de control, Repetir, Mientras y Para
Posteriormente vimos cmo se aplicaba a tres problemas de suma de 10 cantidades, en
el laboratorio resolvimos otros problemas, como edad promedio de 15 personas y
cantidad de agua en una tina.

Martes 2/Mayo: En esta clase diseamos un algoritmo que nos permitiera determinar el
salario de un trabajador, incluyendo la estructura de decisin dentro de la de repetir, para
posteriormente en el laboratorio pasarlo a pseudocdigo.

Jueves 4/Mayo: Reforzamos las estructuras de repeticin, con diversos problemas como
calcular lo que ahorra una persona cada mes y obtener lo que ahorra anualmente,
calcular cuntos nmeros de una cantidad son mayores a 0, y el ultimo el total de ventas
de una empresa.

Martes 9/Mayo: Diseamos un algoritmo para saber cunto se vendi en cada sucursal
de cada ciudad, a travs de mltiples estructuras de repeticin.

Jueves 11/Mayo: Diseamos un algoritmo para saber cundo pagar un artculo x, si paga
el doble de lo que pag antes cada mes, empezando desde 10, en 20 meses

Martes 16/Mayo: Aprendimos a utilizar la estructura de repeticin Segn que nos


facilita la toma de decisiones, ya que se pueden tomar 2 o ms caminos para una variable.
Desarrollamos un algoritmo para saber el costo de un paquete que puede ser enviado a
4 zonas diferentes, y si su peso era mayor a una cantidad determinada no se enviara,
tambin desarrollamos un pseudocdigo para contar la cantidad de focos de cada color
que se inventariaba en una ferretera.

Jueves 18/Mayo: La profesora nos facilit una pgina con 4 problemas para resolverlos
con las estructuras aprendidas, para hacerlos de forma eficiente y funcional.

Martes 23/Mayo: Observamos las nuevas estructuras, matrices y vectores,


Charlas
Exposicin 1: Sistemas operativos
Integrantes: Juan De Gracia, Alexi Galemore, Jonathan Ramos.

Un Sistema operativo (S.O.) es un software que


acta de interfaz entre los dispositivos de
hardware y los programas usados por el usuario
para manejar un computador. Es responsable
de gestionar, coordinar las actividades y llevar
a cabo el intercambio de los recursos y acta
como estacin para las aplicaciones que se
ejecutan en la mquina.

El sistema operativo es el programa ms


importante de un ordenador. Para que
funcionen los otros programas, cada ordenador
de uso general debe tener un sistema
operativo. Los sistemas operativos realizan
tareas bsicas, tales como reconocimiento de la
conexin del teclado, enviar la informacin a la
pantalla, no perder de vista archivos y
directorios en el disco, y controlar los dispositivos perifricos tales como impresoras, escner, etc. Tambin se relaciona
estrechamente con el Hardware para su correcto funcionamiento a travs de pequeos software de instrucciones
llamados Drivers, o Controladores.

Los sistemas operativos proporcionan una plataforma de software encima de la cual otros programas, llamados
aplicaciones, puedan funcionar. Las aplicaciones se programan para que funcionen encima de un sistema operativo
particular, por tanto, la eleccin del sistema operativo determina en gran medida las aplicaciones que puedes utilizar.

Funciones del Sistema Operativo:

Proveer una mquina virtual, es decir, un ambiente en el cual el usuario pueda ejecutar programas de manera
conveniente, protegindolo de los detalles y complejidades del hardware. Administrar eficientemente los recursos del
computador.
Exposicin 2: Lenguaje de programacin
Integrantes: Samuel Rodrguez, Daniel Ballesteros, Keneth Acosta, Alexis Cerrut.

Para que la computadora entienda nuestras instrucciones debe


usarse un lenguaje especfico conocido como cdigo mquina, el
cual la mquina comprende fcilmente, pero que lo hace
excesivamente complicado para las personas. De hecho slo
consiste en cadenas extensas de nmeros 0 y 1.

Para facilitar el trabajo, los primeros operadores de computadoras


decidieron hacer un traductor para reemplazar los 0 y 1 por palabras
o abstraccin de palabras y letras provenientes del ingls; ste se
conoce como lenguaje ensamblador. Por ejemplo, para sumar se usa
la letra A de la palabra inglesa add (sumar). El lenguaje ensamblador
sigue la misma estructura del lenguaje mquina, pero las letras y
palabras son ms fciles de recordar y entender que los nmeros.

La necesidad de recordar secuencias de programacin para las acciones usuales llev a denominarlas con nombres fciles
de memorizar y asociar: ADD (sumar), SUB (restar), MUL (multiplicar), CALL (ejecutar subrutina), etc. A esta secuencia de
posiciones se le denomin "instrucciones", y a este conjunto de instrucciones se le llam lenguaje ensamblador.
Posteriormente aparecieron diferentes lenguajes de programacin, los cuales reciben su denominacin porque tienen
una estructura sintctica similar a los lenguajes escritos por los humanos, denominados tambin lenguajes de alto nivel.

La primera programadora de computadora conocida fue Ada Lovelace, hija de Anabella Milbanke Byron y Lord Byron.
Anabella introdujo en las matemticas a Ada quien, despus de conocer a Charles Babbage, tradujo y ampli una
descripcin de su mquina analtica. Incluso aunque Babbage nunca complet la construccin de cualquiera de sus
mquinas, el trabajo que Ada realiz con stas le hizo ganarse el ttulo de primera programadora de computadoras del
mundo. El nombre del lenguaje de programacin Ada fue escogido como homenaje a esta programadora.
Exposicin 3: Computacin en nube
Integrantes: Carlos Rios, Yohansi Leones, Luis rtiz, Erica Montenegro.

La computacin en la nube es un trmino general para


denominar cualquier cosa que tenga que ver con la
provisin de servicios de hospedaje a travs de
Internet. Estos servicios se dividen en tres grandes
categoras: Infraestructura como servicio (IaaS),
plataforma como servicio (PaaS) y software como
servicio (SaaS). El nombre de computacin en la nube
fue inspirado por el smbolo de nube que se utiliza a
menudo para representar a Internet en imgenes y
diagramas de flujos.

Los servicios en la nube tienen tres caractersticas bien


diferenciadas que los desmarcan del hosting
tradicional. Por un lado, la tarificacin se realiza en funcin del uso, normalmente por minuto o por hora; el servicio es
elstico, ya que el usuario puede usar tanto como quiera y en el momento que lo desee; finalmente, el servicio es
gestionado en su totalidad por el proveedor (el consumidor no necesita nada salvo una computadora personal y acceso a
Internet).

Las importantes innovaciones en virtualizacin y computacin distribuida, los grandes avances en la velocidad de acceso
a Internet y la debilidad econmica generalizada han dado un gran impulso a la computacin en nube.

Las nubes pueden ser privadas o pblicas. Nube pblica es la que vende servicios en Internet a cualquier usuario.
(Actualmente, Amazon Web Services es el principal proveedor en una nube pblica). Las nubes privadas son una red o
centro de datos que pertenece a una organizacin y que ofrece servicios de hosting a un nmero limitado de personas.
Cuando el proveedor de servicios usa recursos de nubes pblicas para crear su nube privada, el resultado se denomina
nube privada virtual. Sea privada o pblica, el objetivo de la computacin en la nube es ofrecer acceso a recursos de
computacin y servicios de TI de forma sencilla y escalable.
Exposicin 4: Virtualizacin
Integrantes: Eileen Owens, Emma Torres, Ricardo Caballero, Yaryns Rodrguez.

Virtualizacin es la tcnica empleada sobre las


caractersticas fsicas de algunos recursos
computacionales, para ocultarlas de otros sistemas,
aplicaciones o usuarios que interacten con ellos.
Esto implica hacer que un recurso fsico, como un
servidor, un sistema operativo o un dispositivo de
almacenamiento, aparezca como si fuera varios
recursos lgicos a la vez, o que varios recursos fsicos,
como servidores o dispositivos de almacenamiento,
aparezcan como un nico recurso lgico. Esta
tecnologa permite la separacin del hardware y el
software, lo cual posibilita a su vez que mltiples
sistemas operativos, aplicaciones o plataformas de
cmputo se ejecuten simultneamente en un solo
servidor o PC segn sea el caso de aplicacin.

La virtualizacin consiste en crear una versin simulada de una plataforma de hardware, sistemas operativos, sesiones
de usuario, aplicaciones, dispositivo de almacenamiento u otros recursos por medio de una aplicacin de control
denominada hypervisor o VMM (Virtual Machine Monitor).

Tipos de virtualizacin

Virtualizacin de servidor.
Virtualizacin de redes.
Virtualizacin de escritorios.
Almacenamiento definido por software.

Formas de catalogar la virtualizacin:

Virtualizacin de ko0
Virtualizacin completa
Virtualizacin parcial
Virtualizacin por S.O o Semiparcial
Exposicin 5: Inteligencia Artificial
Integrantes: Elas Morales, Cesar Osta, mbar Beitia, Alan Camargo.
Exposicin 6: Realidad aumentada
Integrantes: Luis Gutierrez, Publio Cedeo, Javier Rivera, Jose Montenegro.