Está en la página 1de 12

1. REALIZAR UNA TORTA.

Entrada: Mantequilla, azúcar, harina de trigo, huevo, leche.


Proceso: 1. Unir la mantequilla con el azúcar.
2. Batir hasta lograr la consistencia.
3. Agregar los huevos, harina de trigo, leche.
4. Batir hasta que quede esponjosa.
5. Precalentar el horno a 270°C
6. Preparar el molde para agregar la mezcla.
7. Agregar la mezcla al molde
8. Introducir al horno
Salida: Torta

2. CALCULE LA BONIFICACIÓN DE LOS EMPLEADOS DEL


NÚCLEO COL, SI EL EMPLEADO YA CUMPLIÓ 18 AÑOS
PERTENECE A LOS EMPLEADOS FIJOS, Y SE CALCULA EL
MONTO DEL INCENTIVO EN BASE AL 50%. DE LO CONTRARIO,
NO SE CUMPLA LA CONDICIÓN ANTERIOR, SE TRATA DE UN
APRENDIZ Y SE LE CALCULA LO PREVISTO PARA ESTO 40%.
CALCULAR EL MONTO TOTAL Y SE IMPRIMEN LOS
RESULTADOS; ES DECIR CÉDULA, NOMBRE, SUELDO
ANTERIOR, INCENTIVO Y SUELDO NUEVO.
INICIO
Leer Var Cedula, nombre, edad
SI Edad > 18
Incentivo = Sueldo * 0,50
DE LO CONTRARIO
Incentivo = Sueldo * 0,40
FIN SI
Monto total = sueldo + incentivo
Imprimir resultado
FIN

3. DESARROLLE UN ALGORITMO QUE PERMITA LEER DOS


VARIABLES DISTINTAS. DETERMINAR CUAL DE LOS DOS
VALORES ES MAYOR Y ESCRIBIRLOS.
INICIO
Leer A,B
SI A > B ENTONCES
Escribir A, “El número mayor es:”
DE LO CONTRARIO
Escribir B, “El número mayor es:”
FIN SI
FIN
4. DESARROLLE UN ALGORITMO QUE REALICE LA SUMATORIA
DE LOS NÚMEROS ENTEROS DEL 1 AL 10.
INICIO
Leer suma = Ø, N=Ø, A,B
N=N+1
Suma = suma + N
SI N = 10 ENTONCES
Escribir suma
DE LO CONTRARIO
N=N+1
FIN SI
FIN

5. ELABORE EL ALGORITMO PARA INTRODUCIR UN NÚMERO


POR TECLADO QUE NOS DIGA SI ES PAR O IMPAR.
INICIO
Escribir Introduce un número
Leer num
SI num = int (num/2) * 2 ENTONCES
Escribir “Es par”
SINO
Escribir “Es impar”
FIN SI
FIN

6. REALICE UN ALGORITMO QUE SOLICITE TRES NÚMEROS


DISTINTOS: A,B Y C, Y DIGA CUAL ES EL MAYOR DE ELLOS
INICIO
Leer A,B,C
SI (A>B) ENTONCES
SI (A>C) ENTONCES
Escribir (“A es el mayor”)
SINO
Escribir (“C es el mayor”)
SINO
SI (B>C) ENTONCES
Escribir (“B es el mayor”)
SINO
Escribir (“C es el mayor”)
FIN SI
FIN
7. SOLICITE 3 NÚMEROS CORRESPONDIENTES A LAS MEDIDAS
DE LOS LADOS DE UN TRIANGULO Y DETERMINE MEDIANTE
CONDICIONES SI SE TRATA DE UN TRIANGULO EQUILÁTERO,
ISÓSCELES O ESCALENO.
INICIO
Leer A,B,C.
SI (A=B y B=C) ENTONCES
Escribir “el triángulo es equilatero”
SINO
(A=B Y B<>C) ENTONCES
Escribir “es isósceles”
SINO
Escribir “es escaleno”
FIN

8. HACER UN PSEUDOCÓDIGO QUE IMPRIMA LOS NUMEROS


DEL 1 AL 100, QUE CALCULE LA SUMA DE TODOS LOS
NUMEROS PARES POR UN LADO Y POR OTRO LA DE TODOS
LOS IMPARES.
INICIO
Leer i=1
Suma par=Ø
Suma impar= Ø
MIENTRAS: i < 101 hacer
SI s=int (i/2) * 2 ENTONCES
Suma par=sumapar + 1
SINO
Suma imp=sumimp + 1
FIN SI
i=i+1
FIN MIENTRAS
Escribir (“la suma par es:”, suma par)
Escribir (“la suma es impar es:”, sumimp)
FIN

INICIO
A, B, C

A=B SI EQUILÁTER
Y O
B=C

NO

A<>
B SI ISÓSCELES
Y
A=C

NO
ESCALENO

FIN
9. IMPRIMIR Y CONTAR LOS NÚMEROS QUE SON MÚLTIPLOS
DE 2 Ó DE 3 QUE HAY ENTRE 1 Y 100
INICIO
Leer i 1
c 0
MIENTRAS; <101 HACER;
SI i= int (i/2) * 2 ó i = int (i/3) * 3
ENTONCES
c c+1
Escribir;
FIN SI
i i+1
FIN MIENTRAS
Escribir “El número de múltiplos es de:”
Escribir c
FIN
10. IMPRIMIR 10 VECES LAS SERIES DE NÚMEROS DEL 1
AL 100.
PROGRAMA diez
INICIO
Leer serie <- 0
MIENTRAS serie <= 10 HACER
numero <- 1
MIENTRAS numero <= 10 HACER
ESCRIBIR numero
numero <- numero + 1
FINMIENTRAS
serie <- serie + 1
FINMIENTRAS
FINPROGRAMA

11. HACER UN PSEUDOCÓDIGO QUE SIMULE EL


FUNCIONAMIENTO DE UN RELOJ DIGITAL Y QUE PERMITA
PONERLO A LA HORA.
PROGRAMA reloj
horas <- 0, minutos <- 0, segundos <- 0, res <- "S"
ESCRIBIR "Horas: "
LEER horas
ESCRIBIR "Minutos: "
LEER minutos
ESCRIBIR "Segundos: "
LEER segundos
MIENTRAS res = "S" HACER
MIENTRAS horas < 24 HACER
MIENTRAS minutos < 60 HACER
MIENTRAS segundos < 60 HACER
ESCRIBIR horas
ESCRIBIR minutos
ESCRIBIR segundos
segundos <- segundos + 1
FINMIENTRAS
minutos <- minutos + 1
segundos <- 0
FINMIENTRAS
horas <- horas + 1
minutos <- 0
FINMIENTRAS
horas <- 0
FINMIENTRAS
FINPROGRAMA

12. HACER UN PSEUDOCÓDIGO QUE IMPRIMA LOS


NUMEROS PARES ENTRE 0 Y 100.
Programa Pares
INICIO
Leer num
c 2
MIENTRAS C < 101 HACER
Escribir c
C c+2
FIN MIENTRAS
FIN

13. REALIZAR UN PSEUDOCÓDIGO Y UN DIAGRAMA DE


FLUJO PARA CALCULAR LA SUMATORIA DE DOS
NÚMEROS.

Inicio

Suma n1,
n2

Suma <- n1 + n2

Suma

Fin

INICIO
Leer n1, n2
Suma <- n1 + n2
Mostrar suma
FIN

14. ELABORE DIAGRAMA DE FLUJO Y PSEUDOCÓDIGO QUE LEA


DOS NÚMEROS ENTEROS Y MUESTRE VALORES
INTERCAMBIADOS.
Variables A,B: Enteras
INICIO
Leer A,B
Calcular
Aux A
A B
B Aux
Salida A,B
FIN

Inicio

Leer A,B

Aux A
A B
B Aux

A,B

Fin

15. ELABORE DIAGRAMA DE FLUJO Y PSEUDOCÓDIGO QUE LEA


DOS NÚMEROS ENTEROS (BASE Y EXPONENTE) Y QUE
MUESTRE LA POTENCIA.
Variables b,e: Enteras
INICIO
Leer b,e
Calcular
P b^e
Salida P
FIN

Inicio

Leer b,e
P b^e

Fin

16- ELABORE UN PROGRAMA QUE MUESTRE EL SIGUIENTE


MENÚ DE OPCIONES DE CÁLCULO DE ÁREA:
- ÁREA DE UN CÍRCULO (pi * r2)
- ÁREA DE UN TRIÁNGULO (b*h/2)
- ÁREA DE UN RECTÁNGULO (b*h)
INICIO
Variables A,r,b,h,pi: flotantes
opc: entero
constante: Pi 3,14
Mostrar (“Calculo de área”)
Mostrar 1: “ÁREA DE UN CIRCULO”
Mostrar 2: “ÁREA DE UN TRIANGULO”
Mostrar 3: “ÁREA DE UN RECTÁNGULO”
Leer opc

SEGÚN_SEA_CASO (opc)
CASO 1:
Mostrar “Ud. Está calculando el área de un círculo”
Mostrar “Ingrese el radio de un círculo”
Leer r
A pi * r^2
Mostrar “área del circulo”, A
Caso 2
Mostrar “Ud. Está calculando el área de un triangulo”
Mostrar “Ingrese base”
Leer b
Mostrar “ingrese altura”
Leer h
A (b * h) / 2
Mostrar “área del triángulo”, A
Caso 3
Mostrar “Ud. Está calculando el área de un rectángulo”
Mostrar “Ingrese base”
Leer b
Mostrar “ingrese altura”
Leer h
A b*h
Mostrar “área del rectángulo”, A
FIN SEGÚN_SEA_CASO
FIN

17- ELABORE UN PROGRAMA QUE DADO EL PRECIO AL


ARTÍCULO, CALCULE Y MUESTRE UN RECARGO A PRECIO Y EL
MONTO A PAGAR.

INICIO
Variables descuento, recargo, monto final, precio
LEER precio
SI ((precio > 100) Y (precio <200)) entonces;
Descuento =0,20*precio
SI NO
Si (precio > = 200)
Descuento: 0,10 *precio
SI NO
Monto final < precio --- descuento
Mostrar descuento, moto final
FIN SI
SINO
Rec = 0,00* precio
Mostrar rec, monto final
FIN

INICIO

Precio

(precio > si
100) Y
Descuento =0,20*precio
(precio
<200)

si
Precio Descuento: 0,10 *precio
>
=200

Rec = 0,00* precio

Mostrar rec, monto final


FIN SI

18. HACER UN PROGRAMA QUE EL 30 CONSUMO EN UNA


CAFETERÍA, SI EL CONSUMO EXCEDE LOS 30BS, EL
DESCUENTO SERÁ DE UN 7 %. MOSTRAR TODOS LOS PAGOS Y
EL PAGO TOTAL ACUMULADO.

INICIO
X 1
Pago acumulado 0
MIENTRAS X <=30hacer
LEER cons
SI cons > 50 entonces
SI NO
Des< 0
FIN SI
Pago < const – descuento
Pago acumulado pago acumulado + pago
ESCRIBIR pago
X x–1
FIN MIENTRAS
ESCRIBIR PAGO ACUMULADO
FIN

19. ELABORE UN PROGRAMA QUE PERMITA DETERMINAR EL


PROMEDIO DE UN ALUMNO Y VERIFICAR SI ESTE ESTA
APROBADO O REPROBADO

Inicio
Var a,b,c,d, promedio
Leer (a,b,c,d)
Escribir “promedio = (a + b+ c + d) / 4”
Si promedio > = 10
Escribir “aprobado”
Sino
Escribir “reprobado”
Fin Si
Fin

Inicio

A,B,C,D

Prome SI
dio =
(a,b,c, Aprobado
d) / 4

NO

Reprobado

FIN