Está en la página 1de 3

Se hace un pedido de X piezas que habitualmente cuestan Y pesos cada pieza (ambos datos se

introducen X, Y)

Un pedido de 10 piezas cuesta el precio normal.

Si pasan de 10 piezas tienen un 10% de descuento nicamente las piezas que pasen de 10.

Si la compra es de ms de 25 piezas se obtiene un 15% de descuento.

No se aplica descuento sobre descuento

DATOS DE ENTRADA

EL NUMERO DE PIEZAS
EL PRECIO DE LAS PIEZAS

DATOS DE SALIDA
EL PRECIO DE LAS PIEZAS.
SI EL PEDIDO PASA DE 10 PIEZAS QUE DE EL RESULTADO APLICANDO EL DESCUENTO CORRECTO.
SI EL PEDIDO PASA DE 25 PIEZAS QUE DE EL RESULTADO APLICANDO EL DESCUENTO CORRECTO.
EL PRECIO DEL PEDIDO DE MENOS DE 10 PIEZAS.

Proceso DESCUENTO
definir cantidad,compra,precio,descuento,total como real;
escribir "Digite el precio de las piezas: ";
leer precio;
escribir "Digite la cantidad de piezas: ";
leer cantidad;
compra=precio*cantidad;
Si cantidad >10 Entonces
descuento=compra*0.10;
total=compra-descuento;
Sino
compra=precio*cantidad;
Si cantidad>25 Entonces
descuento=compra*0.15;
total=compra-descuento;

fin si
cantidad<-10;

fin si
Escribir "El valor de la compra es: ",total;
FinProceso
Alejandro, la lgica para el cculo esta invertida, primero tienes que verificar si el pedido es mayor
a 25 piezas por la razon que si de entrada tu pedido es de 26, automticamente bajo tu algoritmo
estaras aplicando el 10% cosa que no es correcta, tienes que aplicar el 15%.

Entonces, tu primer condicional es cantidad > 25 para calcular el 15%, en caso contrario preguntar
si es cantidad > 10 corrige tu algoritmo y el pseudocodigo por favor.

Una vez corregido, procedes a realizar la conversina cdigo fuente:

Para sta actividad tienes al menos que utilizar una sentencia repetitiva y una sentencia selectiva,
la sentencia selectiva es la que utilizas al decidir el descuento, te sugiero incorporar a tu programa
que pregunte si desea realizar el cculo de otro producto para incorporar el uso de una sentencia
repetitiva, hasta que el usuario indique que quiere salir. En este caso ser tu trabajo definir cual
ser le maejor forma terminar la ejecucin.

Para trasladarlo a cdigo en lenguaje C, debes ir transformando instruccin por instruccin,


primero declarar las librerias que vas a utilizar, despues declarar todas las variables que utilizas
con la sintaxis que te define el lenguaje, solicitas los datos de entrada con la funcin scanf, los
guardas en las variables destinadas para ello. Cuando ya tienes los valores en las variables usas la
sentecia if, cuya sintaxis es la siguiente

If (cantidad > 25 )
{
descuento=compra*0.15;
total=compra-descuento;
}