Está en la página 1de 4

Un algoritmo que lea 5 numeros dados por un usuario y luego muestra el resultado de la suma.

INICIO
ENTERO: N, i, SUMA
SUMA=0
PARA(i= 1 HASTA ,5 , 1)
MOSTRAR ('DIGITE UN NUMERO')
LEER (N)
SUMA= SUMA+N
FIN PARA
MOSTRAR ('LA SUMA ES:', SUMA)
FIN

Donde 5 son las veces que quiero que se repita la pregunta y 1 de cuanto en cuanto se incrementa, en este casa
de 1 en 1.

EJEMPLOS:

Un algoritmo que muestre los pares que hay entre 1 y N.

INICIO
ENTERO: N, i
MOSTRAR ('DIGITE NUMERO')
LEER (N)
PARA( i= 2 HASTA N, 2)
MOSTRAR (LOS NUMERO PARES SON:', i)
FIN PARA
FIN.
Un algorimo que reciba un dato y lo calcule y mustre el factorial.

INICIO
ENTERO: N,i, FACTORIAL
MOSTRAR ('DIGITE UN NUMERO')
LEER(N)
FACTORIAL=1
PARA( i= 1, HASTA , N, 1)
FACTORIAL= FACTORIAL* i
FIN PARA
MOSTRAR ('EL FACTORIAL ES:', FACTORIAL)
FIN
Un algoritmo que permita mostrar los numeros primos existentes entre 1 y N.

INICIO
ENTEROS:N,i,PRIMO,j
MOSTRAR('DIGITE HASTA Q NUMEERO DESEA VER NUMEROS PRIMOS')
LEER:(N)
PARA(i=1, N,1)
PRIMO:1
SI ((i=1)OR(i=2)OR(i=3))
MOSTRAR(i,' ES NUMERO PRIMO')
SINO
PARA(j=2,i-1,1)
SI((i MOD j)!=0)
PRIMO=PRIMO+1
SI(PRIMO=i-1)
MOSTRAR(i,' ES NUMERO PRIMO')
FIN SI
FIN SI
FIN PARA
FIN PARA
FIN

Un algoritmo que permita ingresar N datos correspondientes al genero de N, numero de personas y determine
el porcentaje de hombres y mujeres que hay.

INICIO
ENTEROS:N,i,SEXO
REALES:M,F
MOSTRAR:('DIGITE N DE PERSONAS')
LEER:(N)
M=0
F=0
PARA(i,1,N,1)
MOSTRAR:('DIGITE SEXO 1 MASCULINO, 2 PARA FEMENINO')
LEER:(SEXO)
SI (SEXO=1)
M=M+1
SINO
F=F+1
FIN PARA
F=(F*100)/N
M=(M*100)/N
MOSTRAR:('EL PORSENTAJE DE MUJERES ES: ',F)
MOSTRAR:('EL PORSENTAJE DE HOMBRES ES: ',M)
FIN