Está en la página 1de 5

Cmo hacer un TEST AUTOCORREGIBLE con Microsoft Excel

Un test auto-corregible es una herramienta que, enfocada de un modo adecuado, permite


al alumno evaluar su progreso en la asignatura y detectar aquellos conceptos que han sido
menos asimilados o que presentan mayor dificultad.
La forma ms sencilla de realizar un test autocorregible es mediante una batera de
preguntas, con sus correspondientes mltiples respuestas, que despus se comparan con una
plantilla. Sin embargo, esto supone la creacin, cada vez que queremos realizar un nuevo test,
de las preguntas, las respuestas y la plantilla.
Lo que vamos a conseguir utilizando una herramienta TIC como Microsoft Excel es crear
una plantilla de test que posteriormente podremos modificar de forma rpida y sencilla para
crear nuevos tests.

1. Creacin de la batera de preguntas y respuestas.


Esta es la parte ms sencilla. Se trata de escribir las preguntas y las respuestas distribuidas en
celdas. Por ejemplo, como en la siguiente figura:

En esta plantilla, las celdas A1:G1 se han combinado para crear una sola celda de ttulo. Los
pasos son los siguientes:
a) Seleccionar el rango A1:G1.
b) Pulsar el boton derecho y, en el cuadro de dilogo seleccionar Formato de celdas.
c) Seleccionar la pestaa Alineacin y elegir Combinar celdas.
Las preguntas se escriben en las celdas B (B10; B17 y B18; etc.). Hasta un total de 10
preguntas (no se muestran todas). Para escribir las preguntas no se han combinado celdas,
simplemente se escribe y el texto aparecer sobre las celdas siguientes. Hay que tener cuidado
de no extenderse demasiado en una lnea para que no desaparezca de la primera pgina. Se
puede comprobar pulsando el icono:

En cualquier caso, se puede utilizar el modelo test_autocorregible.xls y modificarlo.


Las celdas coloreadas de rojo y verde, son las que nos indicarn si la respuesta es correcta o
falsa.

2. Funciones lgicas
Una vez hemos escrito las preguntas y las respuestas hemos de introducir las funciones
adecuadas para que Excel nos corrija el test.
Empezamos escribiendo FALSO en la casilla I4 y CORRECTO en la casilla I5, tal y como se
muestra en la figura:

No es necesario que sean las celdas I4 e I5, podran ser cualesquiera otras. Slo tienen que
cumplir una condicin: tienen que estar suficientemente separadas de las preguntas y
respuestas para que luego podemos ocultarlas sin deshacer el test.
Lo siguiente que tenemos que hacer es escribir en la celda I12 (tambin la eleccin es
opcional, pero es aconsejable nos permite visualizar las preguntas y no se nos monta con el
test) la siguiente frmula:
=SI(D14="x";I$5;I$4)
Esta es una funcin condicional que nos devuelve el valor de I5 si en D14 hay una x y el valor
de I4 en caso contrario. Los smbolos $ se utilizan para que, ms tarde, al copiar y pegar no se
modifiquen las celdas a las que hacemos referencia (I4 e I5). En el lugar en el que hemos
puesto D14, debe ir la celda que corresponde a la respuesta correcta. Se debe cambiar si en
nuestro test la respuesta esta en otra celda (D12, D13 o D15).
A continuacin escribimos en I13 la siguiente frmula:
=SI(E$82="comprobar";CONTAR.SI(D12:D15;"x");"")
Aqu tenemos dos funciones condicionales: SI y CONTAR.SI. Adems se encuentran anidadas.
Esta frmula hace lo siguiente: si el valor de E82 es el texto comprobar entonces ejecuta la
siguiente funcin y en caso contrario, la celda permanece en blanco. Si se ejecuta la funcin
CONTAR.SI, sta cuenta las celdas en el rango D12:D15 que cumplen la condicin asignada, en
este caso contener una x.
El siguiente paso es escribir en I14:
=SI(I13=1;SI(I12=I$5;1;-0,33);0)
De nuevo encontramos dos funciones condicionales anidadas. El funcionamiento es el siguiente:
el SI ms externo, cuando la celda I13 tiene el valor 1 (lo que sucede cuando hemos
respondido), entonces ejecuta el SI ms interno y en caso contrario nos devuelve el valor 0. El
SI ms interno nos devuelve el valor 1 si I12 es igual a I5 (correcto) y -0,33 en caso contrario.
Ahora, en la celda F14 (la verde) escribimos:
=SI(I13=1;SI(I12=I$5;I12;"");"")
El SI ms externo ejecuta el interno cuando I13=1, es decir, cuando se ha respondido. De lo
contrario deja la celda en blanco. El SI interno, devuelve el valor de I12 cuando I12=I5, es
decir, slo si es correcto, de lo contrario deja la celda en blanco.
En la celda F15 (roja):
=SI(I13=1;SI(I12=I$4;I12;"");"")
El SI ms externo ejecuta el interno cuando I13=1, es decir, cuando se ha respondido. De lo
contrario deja la celda en blanco. El SI interno, devuelve el valor de I12 cuando I12=I4, es
decir, slo si es falso, de lo contrario deja la celda en blanco.
Una vez hecho esto, hemos de copiar las frmulas para poder corregir las preguntas siguientes.
Por ejemplo, copiamos el rango I12:I14 en I20:I22 (o en el correspondiente rango de cada
pregunta). De forma que nos en estas celdas nos quedan las frmulas:
I20: =SI(D20="x";I$5;I$4)
I21: =SI(E$82="comprobar";CONTAR.SI(D20:D23;"x");"")
I22: =SI(I21=1;SI(I20=I$5;1;-0,33);0)
Al copiar la frmula en I20, aparece =SI(D22=x . pero esta celda se debe cambiar por la
que corresponda a la respuesta correcta. Este es el nico cambio que debemos hacer para el
resto de preguntas o cuando queramos realizar un nuevo test.
Tambin hemos de copiar el rango F14:F15 en F22:F23 para que nos de el resultado de la
segunda pregunta (para la tercera, cuarta y sucesivas, en el rango correspondiente a las celdas
coloreadas).
=SI(I21=1;SI(I20=I$5;I20;"");"")
=SI(I21=1;SI(I20=I$4;I20;"");"")
En este caso no hemos de realizar ningn cambio.
Por ltimo, nos falta calcular la nota de la prueba. Esto lo hacemos escribiendo en E84:
=SI(E82="comprobar";I78+I71+I64+I57+I50+I43+I36+I29+I22+I14;"")
El valor que nos devuelve esta frmula es la suma de las puntuaciones de cada pregunta
cuando hemos escrito comprobar en E82 y en caso contrario, la celda se queda en blanco.
3. Ocultar las celdas que sobran y las lneas de divisin
Ya slo nos resta ocultar todas las celdas que nos sobran y quitar las lneas de divisin para dar
una apariencia ms profesional.
Para ocultar las columnas que sobran o que no queremos que se vean, el rango de columna H
hasta la ltima, IV, las seleccionamos y apretando el botn derecho, elegimos Ocultar.
Hacemos lo mismo para ocultar las filas de la 105 hasta la ltima. Aqu hemos de tener un
poquito de calma, ya que llegar a seleccionar hasta la fila 65536 puede llevarnos un par de
minutos.
Para ocultar las lneas de divisin, en el men Herramientas seleccionamos Opciones y en el
cuadro que nos sale seleccionamos la pestaa Ver y desactivamos la opcin Lneas de
divisin.
Al final, queda as de bonito: