Está en la página 1de 7

FUNCIONES CONDICIONALES EN EXCEL

FORMATO CONDICIONAL, 2 FUNCION SUMAPRODUCTO, 4


FUNCION CONTAR.SI, 3 FUNCION SUMAR.SI, 5
FUNCION SI, 1
1. FUNCION SI

La funcin SI permite evaluar una condicin, en el caso de que esa condicin sea
verdadera el la celda tendr un valor, y en el caso de que sea falsa tendr otro valor.

Para entender esta funcin vamos a realizar una pequea planilla donde tendremos por
cada registro o fila el nombre, y 3 notas para cada persona. En la cuarta columna
calcularemos el Promedio de estas tres notas.

La quinta columna nos servir para indicar la situacin del alumno, la cual ser
aprobado en el caso de que su promedio sea mayor o igual a 4.0, o reprobado en el
caso de que sea menor que 4.

2. FORMATO CONDICIONAL

Las planillas de clculo nos permiten tambien formatear los datos tabulados en base a
alguna condicin. Por ejemplo podemos hacer que si cualquiera de las 3 notas o el
promedio es menor que 4 se escriba con color rojo o que si es mayor o igual que 4 se
escriba con color azul. Para ello primero seleccionaremos todas las celdas que tienen
formato numrico

Luego vamos al men Formato, seleccionamos la opcin Formato condicional tras lo


cual aparecer la ventana Formato Condicional.
La Condicin 1 la ajustaremos para que el valor de la celda sea mayor o igual que 4.
Luego presionaremos el botn formato correspondiente a la Condicin 1 y ajustaremos
el color de fuente para que sea azul.

Aceptamos, y de vuelta en la ventana Formato Condicional agregamos una segunda


condicin mediante el botn Agregar. La condicin ser que el valor de la celda sea
menor que 4, y el formato ser el color rojo.

Finalmente nuestro archivo debera verse as:


Hay que notar que si cambiamos alguna de las notas, automticamente cambiar el
promedio, y si la nota pasa de ser mayor o igual que 4 a ser menor que 4, cambiar de
color y viceversa.

Esta planilla podra servirnos para saber que nota debemos sacarnos para aprobar una
asignatura conociendo previamente 2 de las 3 notas.

3. FUNCION CONTAR.SI

La frmula CONTAR.SI cuenta el nmero de celdas de un rango que cumplan con una
nica condicin.

Sintaxis: =CONTAR.SI(RANGO; CRITERIO)

Por rango se entiende la celda o el grupo de celdas en donde se pretende contar,


pudiendo estas contener nmeros, nombres, cadenas de texto, matrices o referencias.

Por criterio se entiende la condicin lgica que se emplear para identificar cuales
celdas sern contadas en el rango seleccionado. Puede ser un nmero, expresin,
referencia de celda o cadena de texto.

En esta funcin podemos incluir dentro de la sintaxis los siguientes operadores de


comparacin:
Siguiendo con el ejemplo del punto anterior, si quisiramos contar cuntos alumnos
estn aprobados la frmula a ingresar sera:

=CONTAR.SI(F1:F5;Aprobado)

Si quisiramos contar cuntos alumnos tienen nota inferior a 3 la frmula sera:

=CONTAR.SI(D2:D5;<&3)

4. FUNCION SUMAPRODUCTO

Aplicar dos condiciones a la frmula CONTAR.SI es un poco complicado. Por eso es


ms fcil recurrir a la frmula SUMAPRODUCTO.

Si bien Excel tiene funciones como CONTAR.SI y SUMAR.SI, la ventaja de


SUMAPRODUCTO es que nos permite realizar estos clculos cuando tenemos varios
filtros simultneamente.

Vamos a trabajar con la siguiente tabla donde utilizaremos esta funcin para calcular la
cantidad de hombres aprobados, hombres suspensos, mujeres aprobadas y mujeres con
suspenso (la cantidad de hombres y mujeres las dejo como ejercicio)

A B C D
1 SEXO NOTA
2 h 9
3 m 5,3
4 h 9,8
5 h 10
6 m 2
7 m 0,2
8 h 0
9 m 8,5
10
11 Total Aprobados Suspenso
12 Hombres
13 Mujeres

Para calcular la cantidad de hombres aprobados (observen que tenemos dos


condiciones), usaremos:

=SUMAPRODUCTO((A3:A10="h")*(B3:B10>6))

Si queremos saber la cantidad de mujeres en suspenso:

=SUMAPRODUCTO((A3:A10="m")*(B3:B10<6))
5. FUNCION SUMAR.SI

La funcin SUMAR.SI permite sumar valores de un rango de acuerdo a un criterio o


condicin.

La funcin SUMAR.SI tiene 3 parmetros:

El primero es la referencia o el rango que contiene los valore sobre los que se evaluar
la condicin.

El segundo es el que contiene el criterio a aplicar con el objeto de determinar que se


suma y que no

El tercero es opcional, esto quiere decir que si la condicin est en el mismo rango
donde se efecta la suma, no hace falta el tercer parmetro, pero si el criterio est en un
rango y donde se hace la suma en otro (u otros) rangos, entonces tiene que colocarse el
tercer parmetro.

Veamos un ejemplo: Supongamos que una inmobiliaria tiene un listado con el valor de
las propiedades que se vendieron en Enero y quiere saber la suma de aquellas que
superaron los $160.000, para obtener la respuesta se emplea la funcin SUMAR.SI
como se muestra en el grfico

En este caso con dos parmetros alcanza puesto que el criterio est en el rango E2:E5,
que el mismo rango donde se efecta la suma con la condicin dada y no hace falta
poner =SUMA(E2:E5;">160000";E2:E5). Si en cambio tenemos esta otra tabla
aqu s hace falta el tercer parmetro ya que el rango donde se efecta el criterio
(D2:D5) no es el mismo que el rango donde se efecta la suma (E2:E5).

Dejo como ejercicio averiguar las comisiones que se cobran al vendedor por
propiedades cuyo costo es inferior a $ 400.000.