Está en la página 1de 2

Departamento de Ingeniera de Sistemas

Pensamiento Algortmico
Material de Apoyo Condicionales

Problema 01 Nota Definitiva El profesor de la asignatura de Pensamiento Algortmico ha decidido que si el


alumno obtiene una nota superior a 4.5 en el primer parcial su nota definitiva
Condicionales de este parcial ser de 5.0, en caso contrario no se modifica la nota.
Simple
Se desea realizar un algoritmo en pseudocdigo que pregunte al profesor cul
Pseudocdigo - psicoder es la nota obtenida por un estudiante y de acuerdo a las condiciones
anteriores la modifique si se requiere e imprima la nota.

Antes de escribir el algoritmo es necesario identificar las variables que se requiere para resolver el problema:

Datos de Entrada:
Llamemos a una variable nota de tipo real (la nota puede tener cifras decimales), donde se va a almacenar la nota
digitada por el profesor.

Datos de salida:
La variable nota que puede quedar igual si la nota es inferior o igual a 4.5 queda en 5.0 en caso contrario.

Condicin:
Si (nota > 4.5 ) entonces la nota queda en 5.0 en caso contrario no se modifica la nota.

Una ayuda en estos primeros ejercicios de condicionales es hacer una representacin grfica de la solucin del
problema, nos vamos a centrar en la condicin.

falso verdadero
nota > 4.5

nota = 5.0

Esta solucin grfica representada en pseudocdigo (psicoder) ser:

si (nota > 4.5) entonces


nota = 5.0;
fin_si

Ing. Jos Hernando Hurtado Rojas Condicionales Pgina 1


En este ejercicio por verdadero se modifica la nota y por falso no se hace ninguna accin. Este es un ejemplo de
condicional simple.

El algoritmo completo que da solucin al problema en pseudocdigo (psicoder) :

funcion_principal Declaracin de variables


real nota;

imprimir ("Digite la nota obtenida por el estudiante"); Antes de una lectura colocar un
leer (nota); mensaje solicitando la informacin

si (nota > 4.5) entonces


nota = 5.0; Condicional simple
fin_si

imprimir ("La nota definitiva es : ", nota);


fin_principal

Todos los algoritmos que se van a trabajar en el curso tienen una funcin principal.
Como se observa en los algoritmos se deben declarar las variables al inicio, tipo de dato y el nombre de la
variable, si es ms de una se separan con comas. Los nombres de las variables se deben colocar sin espacios y en
minsculas, se sugiere que se coloquen nombres que ayuden a identificar que es lo que va a almacenar la
variable.
Antes de una lectura se coloca una impresin de un mensaje para que el usuario conozca que es lo que debe
digitar. Como es un texto para orientar al usuario se debe colocar entre comillas dobles.
La pregunta que se hace va entre parntesis y no se debe olvidar cerrar la pregunta con un fin_si.
La impresin de la nota final lleva un mensaje entre comillas dobles porque es un texto y se separa con una coma
del valor contenido en la variable nota. Uno de los errores ms comunes en encerrar la palabra nota entre
comillas lo cual imprimir la palabra nota y no el valor de la nota que es lo que se debe imprimir.
No todas Las lneas del problema llevan punto y coma al final, slo aquellas que ejecutan accin. En el programa
anterior la instruccin real nota, est creando una variable de tipo real que se llama nota, luego hay una accin.
En la pregunta la accin es cambiar la nota a 5.0 si la condicin se cumple.
No olvidar que asignacin es con un igual (=) y cuando comparamos si dos datos son iguales se har con dos
iguales (==).
Los algoritmos deben cerrar la funcin principal con la instruccin fin_principal
Las palabras reservadas que no se pueden utilizar en el programa como nombres de variables se han resaltado en
color azul.

El algoritmo en pseudocdigo (piscoder) que da solucin a este problema se anexa. (nota.psi)

Ing. Jos Hernando Hurtado Rojas Condicionales Pgina 2