Está en la página 1de 9

ALGORITMOS

Ejercicio de Ejemplo Nº 1

Desarrolle un algoritmo que permita leer dos valores distintos, determinar cuál de los dos valores es el mayor y escribirlo.

Pseudocódigo Diagrama de Flujo 1. Inicio Inicio 2. Inicializar variables: A = 0, B =
Pseudocódigo
Diagrama de Flujo
1. Inicio
Inicio
2. Inicializar variables: A = 0, B = 0
3. Solicitar la introducción de dos valores
distintos
A=0
B=0
4. Leer los dos valores
5. Asignarlos a las variables A y B
6. Si A = B Entonces vuelve a 3 porque los
valores deben ser distintos
7. Si A>B Entonces Escribir A, “Es el mayor”
Num1 num2
8. De lo contrario: Escribir B, “Es el mayor”
9. Fin_Si
10. Fin
A=num1 B=num2
NO
SI
A=B
NO
A=num1
SI
A>B
B=num2
B es el
mayor
A es el
mayor
Inicio

Actividades:

1.a. Realizar un algoritmo que permita leer dos valores, determinar cuál de los dos valores es el menor y escríbalo

1.b. Realizar un algoritmo que sume dos números.

1.a

 

1.

Inicio

2.

Declarar 2 variables e inicializarlas: A=0 y B=0

3.

Solicitar la introducción de dos valores distintos por teclado

4.

Leer los dos valores.

5.

Si A es menor que B

6.

Imprimir en pantalla B

7.

Si no, repetir paso 3

8.

Fin_Si

9.

Fin

1.b

 

1.

Inicio

2.

Declarar 3 variables e inicializarlas: A=0 y B=0 y suma=A+B

3.

Solicitar la introducción de dos valores por teclado y asignarlas a variable A y B

4.

Leer los dos valores.

5.

Sumar los dos valores

6.

Imprimir en pantalla: suma

7.

Fin.

Ejercicio de Ejemplo Nº 2

Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A, B y C respectivamente. El algoritmo debe imprimir cual es el mayor y cuál es el menor. Recuerde constatar que los tres valores introducidos por el teclado sean valores distintos. Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales.

Pseudocódigo Diagrama de Flujo Inicio 1. Inicio 2. Inicializar variables: A = 0, B =
Pseudocódigo
Diagrama de Flujo
Inicio
1. Inicio
2. Inicializar variables: A = 0, B = 0,
C=0
A=0
B=0 C=0
3. Solicitar la introducción de tres
valores distintos
4. Leer los tres valores
5. Asignarlos a las variables A, B, C
num1 num2 num3
6. Si A,B y C son iguales Entonces
volver a paso anterior porque los
valores deben ser distintos
7. Si A>B y C Entonces Escribir A, “Es
el mayor”
NO
SI
A>B y A>C
8. Si B>A y C Entonces Escribir B, “Es
el mayor”
9. De lo contrario: Escribir C, “Es el
mayor”
SI
10. Fin_Si
B>A y B>C
A es el
mayor
11. Fin
NO
B es el
mayor
C es el
mayor
Fin
Actividades: 2.a. ¿Es este algoritmo la solución perfecta al ejercicio anterior? Razone su respuesta. 2.b.
Actividades: 2.a. ¿Es este algoritmo la solución perfecta al ejercicio anterior? Razone su respuesta. 2.b.

Actividades:

2.a. ¿Es este algoritmo la solución perfecta al ejercicio anterior? Razone su respuesta.

2.b. De ser necesario ¿qué cambios deberá realizar? Indíquelos.

2.c. Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A, B, y C respectivamente. El algoritmo debe indicar cuál es el menor. Asumiendo que los tres valores introducidos por el teclado son valores distintos.

2.d. Desarrolle un algoritmo que lea cuatro números diferentes y a continuación imprima el mayor de los cuatro números introducidos y también el menor de ellos.

2.b Los cambios que realice fueron cambiar la entrada de los números (estaba por impresora) y hacer el ingreso de los números por teclado. También cambiar la salida del resultado de impresora a pantalla.

2c.

1. Inicio

2. Inicializar variables: A = 0, B = 0, C=0

3. Solicitar la introducción de tres valores distintos

4. Leer los tres valores

5. Asignarlos a las variables A, B, C

6. Si A,B y C son iguales Entonces volver a paso anterior porque los valores deben ser distintos

7. Si A<B y C Entonces Escribir A, “Es el menor”

8. Si B<A y C Entonces Escribir B, “Es el menorr”

9. De lo contrario: Escribir C, “Es el menor

10. Fin_Si

11. Fin

2.d

1. Inicio

2. Inicializar variables: mayor=0 menor=99999999999999 Num

3. Ingresar el numero por pantalla

4. Leer N

5. Para (I=1; I=N; I++)

6. Escribir leer numero

7. Si(num>mayor) mayor =Num

8. Si no

9. Si (num<menor) then menor = Num

10. Fin Si

11. Fin Si

12. Fin Para

13. Imprimir en pantalla el número mayor es mayor; Imprimir en pantalla el número menor es menor;

14. Fin

Ejercicio de Ejemplo Nº 3

Desarrolle un algoritmo que realice la sumatoria de los números enteros comprendidos entre el 1 y el 10, es decir, 1 + 2 + 3 + …. + 10.

Pseudocódigo

Diagrama de Flujo

1. Inicio

1. Inicio

2. Declaración de variables: N= 0, Suma = 0

3. Asignación Contador : N = N + 1

4. Asignación Acumulador: Suma = Suma + N

5. Si N = 10 Entonces

6. Escribir Suma

7. De lo contrario, Repetir desde el paso 3

8. Fin_Si

9. Fin

Actividades:

3.a. Desarrolle un algoritmo que realice la sumatoria de los números enteros múltiplos de 5, comprendidos entre el 1 y el 100, es decir, 5 + 10 + 15 +…. + 100. El programa deberá imprimir los números en cuestión y finalmente su sumatoria

3.b. Desarrolle un algoritmo que realice la sumatoria de los números enteros pares comprendidos entre el 1 y el 100, es decir, 2 + 4 + 6 +…. + 100. El programa deberá imprimir los números en cuestión y finalmente su sumatoria

3.c. Desarrolle un algoritmo que lea los primeros 300 números enteros y determine cuántos de ellos son impares; al final deberá indicar su sumatoria.

3.a

1. Inicio

2. Declaración de variables: Suma = 0

3. Para (I=5; I<=100; I++)

4. Asignación Acumulador: Suma = Suma + N

5. Actualizamos el valor de Sum, agregándole el valor de i, mostramos los valores de i,

6. Fin para

7. Mostrar en pantalla Suma

8. Fin

3.b.

 

1. Inicio

2. Declaración de variables: Suma = 0

3. Para (I=2; I<=100; I++)

4. Asignación Acumulador: Suma = Suma + N

5. Actualizamos el valor de Sum, agregándole el valor de i, mostramos los valores de i,

6. Fin para

7. Mostrar en pantalla Suma

8. Fin

3.c.

1. Inicio

2. Declaración de variables: num1=0

3. Para (I=1; I<=299; I++)

4. Si (i/2=1)

5. Mostrar i

6. Fin si

7. Fin para

8. Mostrar en pantalla Suma

9. Fin

num2=299 Suma = 0

Ejercicio de Ejemplo Nº 4

Desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor, si es el caso.

Pseudocódigo Diagrama de Flujo 1. Inicio Inicio 2. Variables A=0 B=0 C=temporal 3. Si A
Pseudocódigo
Diagrama de Flujo
1. Inicio
Inicio
2. Variables A=0 B=0 C=temporal
3. Si A es mayor que B A =temporal
si no B=temporal
A=0
4. Imprimir A, B
B=0
5. finSi
Temporal=0
6. fin.
A, B
SI
A>B
NO
Temporal=B
B=A
A=Temporal
“Orden= “, A, B
Fin

Actividades:

4.a. Desarrolle un algoritmo que permita realizar la escritura de los primeros 100 números naturales utilizando la estructura Mientras (While).

4.a.

1. Inicio

2. Variables: n, i

3. Mientras:(i=<100)

4. mostrar 'digite un numero' leer:n

5. fin