Está en la página 1de 20

GUIA BASICA IOS CISCO

Los routers tienen varios Modos y Submodos de configuracin:


Modo Exec Usuario: Este modo solo permite ver informacin limitada de la configuracin del router y
no permite modificacin alguna de sta.
Modo Exec Privilegiado: Este modo permite ver en detal le la configuracin del router para hacer
diagnsticos y pruebas. Tambin permite trabajar con los archivos de configuracin del router
Modo de Configuracin Global: Este modo permite la configuracin bsica de router y permite el
acceso a submodos de configuracin especficos.

CAMBIO ENTRE MODOS


router>
router> enable (pasa al Modo Exec Privilegiado)
router#
router# exit router#disable (vuelve a al Modo Exec Usuario)
router> enable
router#
router# configure terminal (pasa al Modo Configuracin Global)
router(config)#
router(config)# exit CTRL+Z (vuelve al Modo Exec Privilegiado)
router#

NOMBRAR AL ROUTER
router> enable
router# configure terminal
router(config)# hostname RouterA
RouterA(config)#

CONFIGURAR CONTRASEAS ENABLE SECRET Y ENABLE PASSWORD


RouterA>
RouterA> enable
RouterA#configure terminal
RouterA(config)#enable secret xxxxxxxxx (configura contrasea Enable Secret)
RouterA(config)#enable password xxxxxxxxx (configura contrasea Enable Password)
RouterA(config)#exit
RouterA#exit
RouterA>
*Es recomendable configurar enable secret , ya que esta contrasea est cifrada desde la vi sta de configuracin

ENCRIPTAR CONTRASEAS
RouterA>
RouterA> enable
RouterA#configure terminal
RouterA(config)#service password-encryption
RouterA(config)#exit
RouterA#exit

RIG P gi na 1 de 20
GUIA BASICA IOS CISCO
* Pa ra i ncrementar l a seguridad del a cceso, las contraseas s e deben ci frar para evitar s er vistas cuando los paquetes s e
exa minan mediante analizadores de protocolos
**** EN OCASIONES, CIERTOS COMANDOS SE SOBREENTIENDEN
EJ:
RouterA> enable RouterA# configure terminal
RouterA(config-if)# exit RouterA(config)#

CONFIGURACION LINEAS
Router#show line

.Tty TypTx/Rx .A Modem.Roty AccO AccI Uses Noise Overruns Int


*.0..CTY....... - ..- - .. - .. - .. 0 .0 .. 0/0 .. -
..1..AUX 9600/9600 - ..- .- - .. - .. 0 .0 .. 0/0 .. -
..2..VTY .......- ..- .- .. - .. - .. 0 .0 .. 0/0 .. -
..3..VTY .......- ..- .- .. - .. - .. 0 .0 .. 0/0 .. -
..4..VTY .......- ..- .- .. - .. - .. 0 .0 .. 0/0 .. -
..5..VTY .......- ..- .- .. - .. - .. 0 .0 .. 0/0 .. -
..6..VTY .......- ..- .- .. - .. - .. 0 .0 .. 0/0 ..

*De a cuerdo a l o que se muestra en esta presentacin, el dispositivo cuenta con un puerto consola (CTY) a ctualmente en
us o (lo marca el asterisco), un puerto a uxiliar (AUX) y 5 puertos vi rtuales (VTY).

CONFIGURAR LINEA DE CONSOLA (ACCESO POR PUERTO DE CONSOLA)


RouterA> enable
RouterA# configure terminal
RouterA(config)# line con 0 (ingresa al submodo de la Consola 0)
RouterA(config-line)#password xxxxxxxxx (configura contrasea xxxxxxxxx)
RouterA(config-line)# login (habilita la contrasea)
RouterA(config-line)# exit
RouterA(config)#

CONFIGURAR LINEA VTY (TELNET)


RouterA> enable
RouterA# configure terminal
RouterA(config)# line vty 0 4 (habilita 5 lneas VTY, de la 0 a la 4)
RouterA(config-line)# password contrasea (contrasea para las 5 lneas en este caso)
RouterA(config-line)# login (habilita la contrasea)
RouterA(config-line)# exit

REDIRIGIR MENSAJES A TERMINAL REMOTA


RouterA# terminal monitor
*Si s e utiliza una sesin por telnet para examinar el router, entonces, permite redirigir el resultado y l os mensajes del
s i stema hacia a terminal remota

RIG P gi na 2 de 20
GUIA BASICA IOS CISCO
CONFIGURAR LINEA AUX (MODEM DIAL-UP o CABLE CONSOLA)
RouterA> enable
RouterA# configure terminal
RouterA(config)# line aux (habilita puerto aux)
RouterA(config-line)# password contrasea (contrasea)
RouterA(config-line)# login (habilita la contrasea)
RouterA(config-line)# exit

ELIMINAR LA AUTENTICACION EN EL ACCESO POR UNA LINEA


Router(config)#line aux 0
Router(config-line)#no login
Router(config-line)#exit

BLOQUEAR ACCESO POR UNA LINEA


Router(config)#line aux 0
Router(config-line)#login
Router(config-line)#no password
Router(config-line)#exit

CONFIGURAR USUARIO LOCAL


Router(config)#username usuario password clave
*Recuerde que esta clave s e guarda en el archivo de configuracin en texto plano, por l o que si se desea cifrar esta cl ave
debe utilizarse el servicio de encriptacin de claves de Cisco IOS.

CONFIGURAR LINEA CON CLAVE DE ACCESO DE USUARIO LOCAL


Router(config)#line console 0
Router(config-line)#login local
Router(config-line)#loggin synchronous
Router(config-line)#exec-timeout 5 0
Router(config-line)#exit

CONFIGURAR LINEA CON TIEMPO DE INACTIVIDAD SSH


SINCRONIZACION DE MENSAJES SYSLOG
Router(config)#crypto key generate rsa (genera un par de claves para el router)
Router(config)#line vty 5 20
Router(config-line)#login local
Router(config-line)#logging synchronous (corrige la interrupcin de los mensajes de syslog)
Router(config-line)#exec-timeout 5 0 (tiempo de inactividad para logout [mm ss])
Router(config-line)#transport input ssh (Desactiva Telnet y solo permite SSH)
Router(config)#ip authentication-retries 2 (n de intentos de autenticacin)
Router(config-line)#exit

RIG P gi na 3 de 20
GUIA BASICA IOS CISCO
CONFIGURAR LISTA DE ACCESO
Router(config)#access-list 1 permit 10.0.0.0 0.0.0.7
Router(config)#access-list 2 permit host 10.0.0.10

CONFIGURAR LINEA CON LISTA DE ACCESO


Router(config)#line vty 0 4
Router(config-line)#access-class 1 in
Router(config-line)#^Z
Router#

CONFIGURAR INTERFACES
RouterA(config)# interface fastethernet 0/0 (ingresa al Submodo de Config de Interfaz)
RouterA(config-if)# ip address 192.168.0.1 255.255.255.0 (configura la IP en la interfaz; IP+MASK)
RouterA(config-if)# no shutdown (levanta la interfaz, habilita la interfaz)
RouterA(config-if)# description lan (asigna un nombre o ccess cin a la interfaz)
* La i nterfaz puede s er Ethernet, Fast Ethernet, Gigabit Ethernet, Serial, VLAN, s eguido de slot/subslot/puerto

CONFIGURAR INTERFACES SERIAL

DTE
RouterA(config)# interface serial 0/0/0 (ingresa al Submodo de Config de Interfaz)
RouterA(config-if)# ip address 10.0.0.1 255.0.0.0 (configura la IP en la interfaz)
RouterA(config-if)# no shutdown (levanta la interfaz)
RouterA(config-if)# description red (asigna un nombre a la interfaz)

DCE
RouterB(config)# interface serial 0/0/1 (ingresa al Submodo de Config de Interfaz)
RouterB(config-if)# ip address 10.0.0.2 255.0.0.0 (configura la IP en la interfaz)
RouterB(config-if)# clock rate 56000 (configura la sincronizacin entre los enlaces ;
<1200-4000000> bits por segundo)
RouterB(config-if)# no shutdown (levanta la interfaz)
RouterB(config-if)# description red (asigna un nombre a la interfaz)

CONFIGURAR INTERFACE ROUTER CON DHCP


RouterA(config)# interface fastethernet 0/0
RouterA(config-if)# ip address dhcp (configura dhcp en la interfaz)
RouterA(config-if)# no shutdown

RIG P gi na 4 de 20
GUIA BASICA IOS CISCO
CONFIGURAR RELAY DHCP
RouterA(config)# interface fastethernet 0/0
RouterA(config-if)# ip helper-address 192.168.1.1 (direccin IP del servidor dhcp)
RouterA(config-if)# no shutdown

CONFIGURAR MENSAJES
RouterA(config)#banner login #Solo Personal Autorizado!# (mensaje para acceso por Telnet)
RouterA(config)#banner motd #Mantenimiento previsto para hoy# (mensaje del da)
RouterA(config)# banner login #Solo Personal Autorizado!# (mensaje para inicio de sesin)
RouterA(config)#banner exec #Solo Personal Autorizado!# (mensaje acceso a modo privilegiado)

OTROS COMANDOS UTILES


RouterA# boot system flash [nombre_imagen_IOS] (Especifica que cargue el IOS desde la Flash)
RouterA#boot system rom (Especifica que cargue el IOS desde la ROM)
RouterA# boot system tftp [nombre_imagen_IOS] [dir_IP_server_tftp] (Carga IOS desde un TFTP)
RouterA# clock set hh:mm:ss mes da ao (Modificar la fecha y hora del router)
RouterA# config-register valor_registro_configuracin (Cambia el registro de configuracin)
RouterA# copy running-config startup-config (Guarda la configuracin activa en la NVRAM)
RouterA# copy running-config tftp (Almacena la configuracin activa en un
servidor TFTP)
RouterA# copy flash tftp (Copia la imagen del sistema desde la memoria
Flash a un servidor TFTP)
RouterA# write memory (Guarda la configuracin activa en la NVRAM)
RouterA# copy tftp flash (Descarga una nueva imagen desde un servidor
TFTP en la memoria Flash)
RouterA# copy tftp runnig-config (Carga la configuracin desde un servidor TFTP)
RouterA(config)#ip domain lookup (Habilita resolucin DNS en el router)
RouterA(config)#no ip domain lookup (No habilita resolucin DNS en el router)
RouterA# erase flash (Borra el contenido de la memoria Flash (IOS))
RouterA# erase startup-config (Borra el contenido de la NVRAM)
RouterA# setup (Inicia el Dilogo de configuracin inicial)
RouterA# reload (Reinicia el router)
RouterA# disable (Sale del modo EXEC Privilegiado)
RouterA>terminal history size <0-256> (Tamao del buffer del historial de comandos
<n de lneas>)

RIG P gi na 5 de 20
GUIA BASICA IOS CISCO
COMANDOS SHOW PRINCIPALES
Router>show interfaces (estadsticas completas de todas las interfaces del router)
Router>show interfaces serial 0/1 (estadsticas de una interfaz especfica
Router>show controllers serial 0/1 (informacin especfica de la interfaz de hardware)
Router>show clock (Muestra la hora fijada en el router)
Router>show hosts (lista en cach de los nombres de host y sus direcciones )
Router>show users (Muestra todos los usuarios conectados al router)
Router>show history (Muestra un historial de los comandos ingresados)
Router>show memory (Muestra estadsticas de la memoria del router)
Router>show processes (Muestra informacin acerca de los procesos activos)
Router>show protocols (Muestra los protocolos de capa 3 configurados )
Router>show sessions (Muestra las conexiones Telnet establecidas en el router)
Router>show flash (Muestra informacin de la memoria flash)
Route>show version (informacin hardware y software router)
Router>show ARP (Muestra la tabla ARP del router)
Router#show startup-config (Muestra el archivo de configuracin almacenado en la NVRAM)
Router#show running-config (Muestra el contenido del archivo de configuracin activo)
Router#show Acess-lists (Muestra las listas de acceso configuradas)
Para ver todos los comandos show en cada modo, teclee show

COMANDOS DE EDICIN Y ATAJOS


Ctrl+A Permite desplazarse al principio de la lnea de comandos
Esc+B Permite desplazarse una palabra hacia atrs
Ctrl+B (o Flecha Izqui erda) Permite desplazarse un carcter hacia atrs
Ctrl+E Permite desplazarse hasta el final de la lnea de comandos
Ctrl+F (o Flecha Derecha) Permite desplazarse un carcter hacia delante
Ctrl+P (o Flecha Arriba) Muestra el ltimo comando ingresado
Ctrl+N (o Flecha Abajo) Muestra el comando ms reciente
<Tab> (tecla Tabulador) Completa el comando ingresado parcialmente
Ctrl+Z (o end) Regresa al modo EXEC Privilegiado
Ctrl+C Cancela la ejecucin del Dialogo de configuracin inicial o Setup
Ctrl+Shift+6 Interrumpe intentos de ping, traceroute y traducciones de nombres
Exit Modo anterior.Desde EXEC Usuario o EXEC Privilegiado, cierra la sesin
Router#wr Salva al configuracin actual en la NVRAM; no pide confirmacin)

RIG P gi na 6 de 20
GUIA BASICA IOS CISCO
NIVELES DE ACCESO
La interfaz de lnea de comando de Cisco IOS utiliza una lgica de niveles jerrquicos:
acceso de nivel usuario
acceso de nivel privilegiado.
El acceso a modo privilegiado puede ser bloqueado utilizando una clave denominada clave de
modo enable que puede ser encriptada (MD5) o no

Router(config)#enable password [clave]


Router(config)#enable secret [clave]

El acceso a modo usuario se asegura utilizando claves de acceso en la diferentes lneas: consola, auxiliar o
terminal virtual.

CLAVE SIMPLE
Router(config)#line vty 0 4
Router(config-line)#password [clave] (define una clave)
Router(config-line)#login (indica al dispositivo que debe requerir el ingreso de la
clave)
La clave se guarda en el archivo de configuracin en formato de texto plano.

ACCESO UTILIZANDO USUARIO Y CLAVE


Router(config)#username [user] secret [clave]

Router(config)#line vty 0 4
Router(config-line)#login local

ASIGNACIN DE NIVELES DE PRIVILEGIO POR USUARIO


Router(config)#privilege exec level [nivel] [comando]
Router(config)#username [user] privilege [level] password [clave]

Usuario nivel 0 Slo accede a modo usuario


Usuario nivel 1 a 14 Se pueden asignar diferentes comandos para cada nivel
Usuario nivel 15 Acceso a modo privilegiado completo

COMANDOS RELACIONADOS
Router(config)#service password-encryption (Cifrar las claves que estn en texto plano)
Router(config)#security password min-length [long] (Longitud mnima en las claves)
Router(config-line)#exec-timeout [min] [seg] (Lmite de tiempo de inactividad al final, para
cerrar la sesin)

RIG P gi na 7 de 20
GUIA BASICA IOS CISCO
PRCTICAS SUGERIDAS
Claves robustas de al menos 10 caracteres alfanumricos, incluir maysculas, minsculas y
smbolos.
Las claves no deben ser palabras de diccionario.
Para asegurar el acceso a modo privilegiado utilice siempre la enable secret.
Active el servicio de encriptacin de claves para asegurarse que no queden claves en texto plano
visibles en el archivo de configuracin.
Cambie las claves peridicamente.
Incluya un mensaje de acceso (banner login, motd, incoming, exec)

RECUPERACION DE CONTRASEAS
1. Detener el boot con ctrl+espacio ctrl+pause(break)
2. Dentro del modo Rommon cambiamos la configuracion del registro
a. Rommon1>confreg 0x2142 (para que el router inicie sin archivo de configuracion)
3. Reinciamos el router
a. Rommon2>reset
4. Al iniciarse el router seleccionamos no utilizar el asistente de Setup
5. Entramos en el modo privilegiado
a. Router>enable
6. Copiamos el startup-cofig en la configuracion activa (running-config)
a. Router#copy startup-config running-config
7. Entramos en el modo configuracion
a. Router#configure terminal
8. Modificamos la/s contraseas
9. Salvamos la nueva configuracin
a. Router#wr
10. Cambiamos la configuracin del registro
a. Router(config)#configure terminal
b. Router#config-register 0x2102 (router inicia con el archivo de configuracin)
11. Reiniciamos el router con la nueva configuracin
a. Router#reload

RIG P gi na 8 de 20
GUIA BASICA IOS CISCO
ENRUTAMIENTO ESTTICO
Router(config)#ip route <red destino> <mascara> <siguiente salto/interfaz de salida> <DA><permanent>
Router(config)#ip route 0.0.0.0 0.0.0.0 <siguiente salto/interfaz de salida> <DA>:
Define una ruta esttica. Se puede manipular la distancia administrativa (DA) de una ruta esttica.
La opcin permanent crea y mantiene la ruta aunque la interfaz de salida o el siguiente salto no estn
disponibles.

Router#show ip route
Ver la tabla de enrutamiento

RIP (V1 Y V2)


Router(config-router)#auto-summary
Restaura la conducta por default de sumarizacin automtica de rutas de subredes, a redes con clase.

Router(config-router)#default-information originate
Distribuye a travs del protocolo la ruta esttica predeterminada .

Router(config-router)#default-metric [number]
Modifica los valores de mtrica perdeterminados de RIP

Router(config-router)#ip rip authentication key-chain [name-of-chain]


Habilita la autenticacin de paquetes para RIP Versin 2 (RIPv2 o RIP2).

Router(config-router)#ip rip receive version {1| 2}


Especifica la versin de RIP para recibir en una interfaz.

Router(config-router)#ip rip send version {1| 2}


Especifica la versin de RIP para enviar por una interfaz.

Router(config-router)#ip split-horizon
Habilita el mecanismo de Horizonte Dividido.

Router(config-router)#maximum-paths [valor]
Modifica el mximo de rutas sobre las que balancear la carga. "valor" puede ser entre 1 y 6 (1 deshabilita el
balanceo de carga que por default es 4).

Router(config-router)#neighbor [ip-address]
Define un router vecino con el que se intercambiar informacin de enrutamiento.

Router(config-router)#network [network- ip-address]


Especifica una lista de redes directamente conectadas al equipo por las cuales queremos que nuestro router
enrute con el protocolo RIP.

RIG P gi na 9 de 20
GUIA BASICA IOS CISCO

Router(config)#redistribute static
Permite la publicacin de las rutas estticas a travs del protocolo.

Router(config)#router rip
Configura el Protocolo de Informacin de Enrutamiento (RIP) en un router.

Router(config-router)#timers Basic {update | invalid | holddown |flush}


Ajusta los relojes de red del protocolo RIP.
- update: Es el rango en segundos en el cual sern enviadas las actualizaciones. Este el parmetro
fundamental del timing de este protocolo de enrutamiento.
- invalid: Intervalo de tiempo en segundos despus del que una ruta ser declarada invlida; este debe ser
por lo menos tres veces el valor de update. Una ruta se convierte en invlida cuando hay una au sencia de
actualizaciones que actualicen a la misma. La ruta es marcada como inaccesible y responde como
inalcanzable. Sin embargo la ruta es utilizada para reenviar paquetes. El valor por default para este
parmetro es 180.
- holddown: Intervalo en segundos durante el cual una informacin de enrutamiento espera rutas ms
convenientes se suprimen. Este debe ser por lo menos tres veces el valor de update. La ruta entra en un
estado de holddown cuando un paquete recibido indica que el destino de esa ruta es i naccesible. La ruta es
marcada como inaccesible y responde como inalcanzable. Sin embargo la ruta es utilizada para reenviar
paquetes. Cuando expira el holddown, las rutas descubiertas por otros dispositivos son aceptadas y la ruta
anterior es marcada como inaccesible. El tiempo por default es de 180 segundos.
- flush: Cantidad de tiempo en segundos que debe pasar antes de que la ruta sea removida de las tablas de
enrutamiento; el intervalo especificado debe ser mayor al valor de invalid. Si este es menor, el valor de
holddown no puede llegar a pasar, por lo que resultar que se aceptaran nuevas rutas antes de que este
ltimo contador finalice. El valor por defecto es 240 segundos.

RIP.Router(config-router)# version {1|2}


Especifica la versin de RIP que deseamos usar en el router.

RIG P gi na 10 de 20
GUIA BASICA IOS CISCO
EIGRP
Router(config)#router eigrp <SA>
Define EIGRP como el protocolo de enrutamiento y asigna el numero de Sistema Autonomo <SA>
El SA puede estar en el rango [1-65535].

Router(config-router)#network <red>
Identifica las redes que participan en EIGRP y habilita las interfaces configuradas en dichas redes para
participar en EIGRP.

Router(config-router)#no auto-summary
Desactivar la sumarizacin automatica, necesario cuando hay redes discontinuas.

Router(config-router)#network <red> <wilcard>


Especifica que subredes se publican en EIGRP, si no se quieren publicar todas las subredes de una red con
clase.

Router(config-router)#redistribute static:
Redistribuir las rutas estticas creadas en el router dentro de EIGRP.

Router(config-router)#passive-interface <interfaz>
Declarar una interfaz pasiva en EIGRP, no envi actualizaciones EIGRP por esa interfaz, no envia hellos.

Router(config-router)#metric weights 0 <K1> <K2> <K3> <K4> <K5>:


Modificar la mtrica default de EIGRP, cambiando los valores K de la formula para la mtrica.

Router(config-router)#distance <DA Interna> <DA Externa>


Modificar la distancia administrativa de EIGRP, tanto para redes internas (EIGRP) como externas (no EIGRP)
por defecto son 90 y 170 respectivamente.

Router(config-if)#ip hello-interval eigrp <SA> <segundos>


Modificar el intervalo de hello (cada cuanto enva paquetes de saludo), se realiza por interfaz, el valor puede
estar en el rango [1-65535].

Router(config-if)#ip hold-time eigrp <SA> <segundos>


Modificar el tiempo de espera para considerar un vecino down, se realiza por interfaz, el valor puede estar
en el rango [1-65535].

Router(config-if)#ip summary-address eigrp <SA> <red> <mascara> <DA>


Sumarizacin manual en la interfaz, DA = Distancia Administrativa.

Router(config-if)#bandwidth <kilobits>
Especificar el ancho de banda del enlace.

Router#show ip eigrp neighbors


Muestra la tabla de vecinos EIGRP.

Router#show ip route eigrp


Muestra la tabla de enrutamiento, nicamente con las rutas EIGRP.

RIG P gi na 11 de 20
GUIA BASICA IOS CISCO
Router#show ip protocols
Muestra informacin sobre todos los protocolos de enrutamiento dinmico ejecutndose en el router.

Router#show ip eigrp interfaces


Muestra informacin de la interfaces configuradas para EIGRP.

Router#show ip eigrp topology


Muestra el contenido de la tabla topolgica.

Router#show ip eigrp traffic


Muestra estadsticas de trafico EIGRP.

Router#debug eigrp fsm


EIGRP Dual Finite State Machine events/actions.

Router#debug eigrp neighbors


EIGRP neighbors.

Router#debug eigrp packets


EIGRP packets.

Router#debug eigrp transmit


EIGRP transmission events

RIG P gi na 12 de 20
GUIA BASICA IOS CISCO
OSPF
R1(config)#router ospf id_proceso
Activar OSPF

Router(config-router)#network direccin_red mscara_wildcard rea ID del rea


Publicar las subredes especificadas en OSPF

R1(config-router)#default-information originate
Distribuir la ruta predeterminada como ruta externa en OSPF

R1(config-router)#auto-cost reference-bandwidth 10000


% OSPF: Reference bandwidth is changed.
Please ensure reference bandwidth is consistent across all routers.
Modificar ancho de banda de referencia (Mbps). Valor entre 1 y 4294967

R1(config)#interface serial0/0/0
R1(config-if)#ip ospf hello-interval 5
R1(config-if)#ip ospf dead-interval 20
Configurar los intervalos de Hello y Dead de OSPF. Pueden modificarse de forma manual por medio de los
comandos de la interfaz ip ospf hello-interval e ip ospf dead-interval. El temporizador Dead y el
temporizador Hello deben estar configurados de forma idntica en cada lado del enlace serial entre R1 y R2.

R1(config)#interface serial0/0/0
R1(config-if)#ip ospf cost 1562

R1(config)#interface serial0/0/0
R1(config-if)#bandwith 64
Utilizar el comando ip ospf cost para configurar el costo de OSPF en el router. Un mtodo alternativo al uso
del comando bandwidth es utilizar el comando ip ospf cost, que permite configurar el costo en forma
directa.

R1(config)#router ospf 1
R1(config-router)#router-id 10.4.4.4
Utilizar el comando router-id para cambiar el ID del router en el router R1.
Nota: Algunas versiones de IOS no admiten el comando router-id.
Es importante ejecutar el comando Reload o clear ip ospf process" para forzar el cambio de ID

Router(config-if)#ip ospf priority {0 - 255}


Configurar la prioridad de una interface en redes multiacceso para influir en el proceso de DR y BDR
Valor entre 0 y 255

Comandos de verificacin
show ip route
show ip ospf interface
show ip ospf neighbor
show ip protocols
show ip ospf

RIG P gi na 13 de 20
GUIA BASICA IOS CISCO
COMANDOS CONFIGURACION SWITCH
Comandos generales
Switch(config)#hostname S1
Switch (config)#enable secret class
Switch (config)#no ip domain-lookup

Switch (config)#line console 0


Switch (config-line)#password cisco
Switch (config-line)#login

Switch (config-line)#line vty 0 15


Switch (config-line)#password cisco
Switch (config-line)#login
Switch config-line)#end

Buffer historial
Switch#show history

SSH en vez de Telnet


Switch(config)#ip domain-name mydomain.com
Switch(config)#crypto key generate rsa
Switch(config)#ip ssh version 2
Switch (config-line)#line vty 0 15
Switch (config-line)#transport input ssh
Switch (config-line)#password cisco
Switch (config-line)#login
Switch config-line)#end

Guardar Configuracin Activa - Copiar/Sobrescribir Configuracin de Inicio


Switch #copy running-config startup-config
Switch #copy startup-config flash:filename
Switch #copy flash:config.bak1 startup-config

Borrar el contenido de la configuracin de inicio


Switch #erase nvram
Switch #erase startup-config

Borrar la configuracion de las Vlan


Switch #delete flash:vlan.dat

Administracion del switch


Switch (config)#interface vlan 99
Switch (config-if)#ip address 172.17.99.11 255.255.255.0
Switch (config-if)#no shutdown
Switch (config)#interface id interface
Switch (config-if)#switchport mode access

RIG P gi na 14 de 20
GUIA BASICA IOS CISCO
Switch (config-if)#switchport access vlan 99
Switch (config-if)#end

Gateway
Switch (config)#ip default-gateway 172.17.99.1

Enlace
Switch (config)#mdix auto Establece a automatico la gestion del cable (directo o cruzado) a utilizar.

Velocidad y Modo de la interface


Switch (config)#interface id interface
Switch (config-if)#duplex auto
Switch (config-if)#speed auto
Switch (config-if)#end

Tabla MAC del switch - Asignacin esttica


Switch (config)#show mac-address-table
Switch (config)#clear mac-address-table dynamic
Switch (config)#[no]mac-address-table static <MAC> vlan <1-4096, ALL> interface <id de la interfaz>

Deshabilitar todos los puertos.


Switch(config)#interface range fa0/1-24
Switch(config-if-range)#shutdown
Switch(config-if-range)#interface range gi0/1-2
Switch(config-if-range)#shutdown

Configurar las VLAN


Switch (config)#vlan id Vlan
Switch (config-vlan)#name management
Switch (config-vlan)#exit

Switch (config)#no vlan id Vlan

Configurar los puertos de usuario en modo de acceso.


Switch (config)#interface id interface
Switch (config-if)#switchport mode access
Switch (config-if)#switchport access Vlan

Switch (config)#interface id interface


Switch (config-if)#no switchport access Vlan

Configurar los puertos de voz y datos.


Switch (config)#interface id interface
Switch (config-if)#mls qos trust cos
Switch (config-if)#switchport voice vlan id vlan
Switch (config-if)#switchport mode access
Switch (config-if)#switchport access id Vlan

RIG P gi na 15 de 20
GUIA BASICA IOS CISCO

Configurar Puerto Troncales y Vlan Nativa


Switch (config)#interface fa0/1
Switch (config)#switchport mode trunk

Switch(config-if)# switchport trunk encapsulation {isl | dot1q | negotiate}


Switch(config-if)# switchport trunk allowed vlan {vlan-list | all | {add | except | remove} vlan-list}
Switch(config-if)# switchport mode {trunk | dynamic {desirable | auto}}

Switch (config-if)#switchport nonegotiate

Switch (config)#interface range fa0/1-5


Switch (config-if-range)#switchport mode trunk
Switch (config-if-range)#switchport trunk native vlan 99
Switch (config-if-range)#no shutdown
Switch (config-if-range)#end

Seguridad de Puerto
Switch (config)#interface fa0/6
Switch (config-if)#switchport port-security (direccion MAC dinamica)
Switch (config-if)#switchport port-security mac-address MAC (direccion MAC estatica)

Switch (config-if)#switchport port-security mac-address sticky (direccion MAC sticky dinamica)


Switch (config-if)#switchport port-security mac-address sticky MAC (direccion MAC sticky esttica)

Switch (config-if)#switchport port-security maximum 1


Switch (config-if)#switchport port-security violation [restrict | shutdown | protect]

VTP - Configurar Modo operativo, Nombre de dominio y Contrasea


Switch (config)#vtp mode server
Switch (config)#vtp mode client
Switch (config)#vtp mode transparent
Switch (config)#vtp domain Lab4
Switch (config)#vtp password cisco
Switch (config)#end

VTP - Configurar la depuracin


Switch (config)#vtp pruning

RIG P gi na 16 de 20
GUIA BASICA IOS CISCO
Snooping
(config-if)# ip dhcp snooping Habilita el Snooping de DHCP.
(config-if)# ip dhcp snooping vlan number [vlan] Habilitar snooping para una VLAN especifica
(config-if)# ip dhcp snooping trust Define los puertos como confiables o no confiables.
(config-if)# ip dhcp snooping limit rate <velocidad> Limitar la tasa a la que un atacante puede enviar
solicitudes de DHCP bogus de manera continua a travs
de puertos no confiables al servidor

SPT
Switch# show spanning-tree [detail | active | summary]
Switch# show spanning-tree vlan <vlan>
Switch# debug spanning-tree events
Switch (config)# spanning-tree vlan <vlan>priority <0-65536>
Switch(config)# spanning-tree vlan <vlan>root <primary | secondary>
Switch (config-if)# spanning-tree cost <1-200.000.000>

Switch (config-if)# spanning-tree port-priority <0-240>


Switch (config-if)# [no]spanning-tree portfast

Switch (config)# spanning-tree vlan <vlan>root primary diameter <valor>

Configuracion PVST+ Fast


Switch# clear spanning-tree detected-protocols
Switch (config)# spanning-tree mode rapid-pvst
Switch (config-if)# spanning-tre link-type point-to-point

RIG P gi na 17 de 20
GUIA BASICA IOS CISCO
Configuracion EtherChannel
Podemos configurar un EtherChannel de 3 formas diferentes:
PAgP (Port Aggregation Protocol): es un protocolo propietario de Cisco. El switch negocia con el
otro extremo qu puertos deben ponerse activos.
LACP (Link Aggregation Control Protocol): igual que PAgP.
Mode ON: no se realiza ningn tipo de negociacin, todos los puertos se ponen activos.

Antes de configurar nuestro EtherChannel tener en cuenta las siguientes recomendaciones:


No se debe configurar un puerto en dos grupos diferentes.
No se debe configurar un puerto en dos modos diferentes, LACP y PAgP.
No configurar Switched Port Analyzer (SPAN) como parte de un EtherChannel.
No configurar securizacin de puertos.
Asignar todos los puertos del EtherChannel a la misma VLAN o configurar todos como troncales.
Verificar que todos los puertos del grupo estn en un mismo modo de encapsulacin, ISL o 802.1Q

Comandos Etherchannel
# configure terminal
(config)# interface range fa0/0-2
(config-if-range)# switchport mode trunk
(config-if-range)# switchport access vlan 10
(config-if-range)# channel-group 1 mode on
(config-if-range)# exit
#wr

RIG P gi na 18 de 20
GUIA BASICA IOS CISCO
Comandos show
Switch#show flash:
Switch#show mac-address-table
Switch#show port-security interface id interface
Switch#show port-security address

Switch#show interfaces [id interface | vlan id vlan | switchport]


Switch#show interface id interface switchport
Switch#show interface id interface trunk
Switch#show dtp interface id interface

Switch#show vlan [brief | id id vlan | name nombre vlan | summary]

Switch#show vlan brief


VLAN Name Status Ports
1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig1/1, Gig1/2
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active

Switch #show vtp status


VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 255
Number of existing VLANs : 5
VTP Operating Mode : Server
VTP Domain Name :
VTP Pruning Mode : Disabled
VTP V2 Mode : Disabled
VTP Traps Generation : Disabled
MD5 digest : 0x57 0xCD 0x40 0x65 0x63 0x59 0x47 0xBD
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00
Local updater ID is 0.0.0.0 (no valid interface found)

RIG P gi na 19 de 20
GUIA BASICA IOS CISCO
Recuperacin del password en un switch CISCO
Primero Reiniciamos el switch y mientras reinica pulsamos el boton Mode hasta que el led se pone ambar.
1. Iniciar el sistema de archivos flash
switch#flash_init
2. Paso siguiente escribimos (Cargar archivos de cualquier ayuda )
switch#load_helper
3. Mostrar el contenido de la memoria Flash:
Switch# dir flash:
3 drwx 10176 Mar 01 2001 00:04:34 HTML
6 -rwx 2343 Mar 01 2001 03:18:16 config.text
171 -rwx 1667997 Mar 01 2001 00:02:39 c2950-i6q412-mz.121-14.EA1.bin
7 -rwx 3060 Mar 01 2001 00:14:20 vlan.dat
172 -rwx 100 Mar 01 2001 00:02:54 env_vars
7741440 bytes total (3884509 bytes free)
4. Cambie el nombre del archivo de configuracin para config.text.old. (Este archivo contiene la
contrasea definida)
Switch# rename flash: config.text flash: config.text.old
5. Boot al sistema
Switch# boot
6. Se le pedir que inicie el programa de instalacin. Introduzca el N en el smbolo del sistema:
Continue with the configuration dialog? [yes/no]: N
7. Ingrese el modo EXEC privilegiado:
Switch> enable
8. Cambie el nombre del archivo de configuracin a su nombre original:
Switch# rename flash:config.text.old flash:config.text
9. Copie el archivo de configuracin en la memoria:
Switch# copy flash:config.text system:running-config
Source filename [config.text]?
Destination filename [running-config]?
10. Entre en el modo de configuracin global
Switch# configure terminal
11. Cambie la contrasea
Switch (config)# enable secret password
12. Retornamos al modo exec privilegiado
Switch (config)# exit
Switch#
13. Escriba la direccin a la configuracin de inicio archivo de configuracin:
Switch# copy running-config startup-config

RIG P gi na 20 de 20