Está en la página 1de 12

INSTITUTO TECNOLGICO SUPERIOR DE LIBRES

Organismo Pblico Descentralizado del Gobierno del Estado de Puebla

INGENIERA EN SISTEMAS COMPUTACIONALES

MATERIA: FUNDAMENTOS DE PROGRAMACIN

PROFESOR: SAUL ORTIZ BAEZA

PRACTICA: ALGORITMOS RESUELTOS

ALUMNA: ANDREA VALADEZ FLORES

No.DE CONTROL: 11940199


Hacer un programa que pida la hora, minutos, segundos y muestre este en
un formato estndar y calcule la hora cada 2 segundos durante un minuto.

Proceso sin_titulo
Escribir "hora:"
Leer hora;
Escribir "minutos:";
Leer minutos;
Escribir "segundos:";
Leer segundos;
Si "((hr<=24),(min<=60),(seg>60))" Entonces
seg<-seg+2;
Si seg=60 Entonces
seg<-0;
min<-min+2;
Si min=60 Entonces
min<-0;
hr<-hr+2;
Si hr=24 Entonces
hr<-0;
FinSi
FinSi
FinSi
FinSi
Para seg<-2 Hasta 60 Con Paso 2 Hacer
Escribir hora,seg;
FinPara
Fin Proceso

Hacer un programa que lea 2 nmeros y deducir si estn en orden creciente


o decreciente.

Proceso sin_titulo
Escribir "ingresa 2 numeros";
Leer a,b;
Si a<=b Entonces
Escribir "orden creciente";
Sino
Escribir "orden decreciente";
FinSi
FinProceso
Calcular el nmero mayor de una lista de n nmeros

Proceso sin_titulo
mayor<-0;
Para mayor<-1 Hasta 10 Con Paso 1 Hacer
Escribir "introduce el numero que desees";
Leer numero;
Si (numero>mayor) Entonces
mayor<-numero;
FinSi
FinPara
resultado<-(mayor);
Escribir "el numero mayor es:",+resultado;
FinProceso

De una lista de 10 numeros determinar simultneamente el numero mayor y


el numero menor.

Proceso sin_titulo
mayor<-0;
Para mayor<-1 Hasta 10 Con Paso 1 Hacer
Escribir "introduce el numero que desees";
Leer numero;
Si (numero>mayor) Entonces
mayor<-numero;
FinSi
FinPara
resultado<-(mayor);
Escribir "el numero mayor es:",+resultado;
menor<-0;
Para menor<-1 Hasta 0 Con Paso 1 Hacer
Escribir "introduce el mismo numero de nuevo";
Leer numero;
Si (numero<menor) Entonces
menor<-numero;
FinSi
FinPara
resultado<-(menor);
Escribir "el numero menor es:",+resultado;
FinProceso
Realizar un programa donde pida 5 calificaciones de un alumno e imprimir
las 2 calificaciones ms bajas.

Escribir "cuantas calificaciones quieres?";


Leer limite
Dimension V(5)
i<-0;
contadorcalificacionesaltas<-0;
contadorcalificacionesbajas<-0;
calificacion<-0;
Para num<-1 Hasta 5 Con Paso 1 Hacer
Escribir "primera";
Leer calificacion;
Escribir "segunda";
Leer calificacion;
Escribir "tercera";
Leer calificacion;
Escribir "cuarta";
Leer calificacion;
Escribir "quinta";
Leer calificacion;
resultado<-calificacion;
FinPara
Escribir "las 2 calificaciones mas bajas son:",+resultado;
FinProceso

Calcular la raz de la ecuacin de segundo grado siguiente (a+bx+c=0)

Proceso sin_titulo

Escribir "ingrese valores para el problema";

variable=resultado

a<-variable;

b<-variable;

c<-variable;

Leer variables;

Si aexp2+b*x+c Entonces

Escribir "el resultado es:";


Sino

Escribir "fallastes intenta de nuevo";

FinSi

FinProceso

Dada la duracin en minutos de una llamada telefnica calcular el costo,


considerando las siguientes reglas:

*Hasta tres minutos el costo es de 5 pesos.

*Despus de tres minutos es de 5 pesos ms 50 centavos por cada minuto a


los tres primeros.

Proceso sin_titulo

Leer minutos;

Leer costo;

(i)<-minutos;

(j)<-costo;

Leer variables;

Para (i)<-1 Hasta 3 Con Paso 1 Hacer

Si (minutos<3) Entonces

Escribir "hasta 3 minutos el minuto te costara 5 pesos";

Para (j)<-1 Hasta limite Con Paso 1 Hacer

Si (minutos>3) Entonces

Escribir costo=(0.50+0.1*(min-3));

FinSi

FinPara

FinSi
FinPara

Escribir "la llamda te costara ";

Si (minutos<3) Entonces

Escribir "la llamada te costara 15 pesos";

Si (minutos>3) Entonces

Escribir "la llamada te costara 0.50 mas";

FinSi

FinSi

FinProceso

Dado 3 nmeros calcular el mayor

Proceso sin_titulo

Escribir "ingresa 3 numeros";

Leer a,b,c;

resultado<-mayor;

Si a>b y a>c Entonces

Escribir "a es mayor";

Si b>a y b>c Entonces

Escribir "b es mayor";

Sino

Escribir "c es mayor";

FinSi

FinSi

Escribir "el numero mayor es:"+resultado;

FinProceso
Dado el monto total de una compras calcular el descuento, considerando las
siguientes reglas:

*Descuento del 10%si el monto es menor a $100.00 pesos.

*Descuento de 20% si el monto es mayor a $100 y menor o igual a $500.00


pesos.

*Descuento del 30% si el monto en mayor a $500.00 pesos.

*No hay descuento si el monto es menor a $50.00 pesos.

Proceso sin_titulo

i<-monto;

j<-descuento;

Escribir "ingresa la cantidad que comprastes?";

Leer monto;

Si monto<100 Entonces

descuento<-monto*0.1;

Si (monto>100)(monto<500) Entonces

descuento<-monto*0.2;

Si monto>500 Entonces

descuento<-monto*0.30;

Si monto<50 Entonces

Escribir "no hay descuento";

FinSi

FinSi

FinSi

FinSi

FinProceso
Dadas tres longitudes imprimir un mensaje que diga que si se forma un
triangulo o no.

Proceso sin_titulo
Escribir "escribe 3 longitudes";
Leer a,b,c;
Si "(a+b)<a(c+a)<b(a+b)<c" Entonces
Escribir "si se forma un triangulo";
Sino
Escribir "no se forma un triangulo" ;
FinSi
FinProceso

A una fiesta asistieron personas de diferentes edades y ambos sexos,


construir un programa que dadas las edades y sexo de las personas,
calcular lo siguiente:

*Cuntas personas asistieron a la fiesta?

*Cuntos hombres?

*Cuntas mujeres?

*Promedio de edades por sexo.

*Edad de la persona ms joven que asisti.

Proceso sin_titulo
Escribir "introduce el numero de personas invitadas";
Leer limite;
Dimension Vedad(10)
Dimension Vsexo(10)
i<-0;
contadorhombre<-0;
contadormujer<-0;
contadorm<-0;
contadorf<-0;
Para i<-1 Hasta limite Con Paso 1 Hacer
Escribir "introduce tu edad";
Leer edad;
Si (edad<18) Entonces
Escribir "no tienes edad para entrar";
Sino
Vedad(i)<-edad;
Escribir "eres hombre o mujer?";
Leer sexo;
Si sexo="hombre" Entonces
contadorhombre<-contadorhombre+1;
contadorm<-contadorm+edad;

FinSi
Si sexo="mujer" Entonces
contadormujer<-contadormujer+1;
contadorf<-contadorf+edad;
FinSi

Vsexo(i)<-sexo;
FinSi

FinPara
promedioh<-contadorm/contadorhombre;
promediom<-contadorf/contadormujer;

Escribir "escribe el numero de personas que asistieron a la fiesta ", limite;


Escribir "mujeres que asistieron: ",contadormujer;
Escribir "hombres que asistieron: ",contadorhombre;
Escribir "el promedio de edad de hombres es: ",promedioh;
Escribir "el promedio de edad de mujeres es:",promediom;

Para i<-1 Hasta limite Con Paso 1 Hacer


Escribir Vsexo(i);
Escribir Vedad(i);
FinPara

temp<-Vedad(1);
Para j<-1 Hasta limite Con Paso 1 Hacer
Si Vedad(j)<temp Entonces
temp<-Vedad(j);
FinSi
FinPara
Escribir "la menor edad de los asistentes es: ",temp;
FinProceso

Dada las horas trabajadas de 20 personas y la tarifa de pago calcular el


salario?

Proceso sin_titulo
(i)<-horas trabajadas;
j<-tarifa;
k<-salario;
Mientras i<=20 Hacer
Escribir "cuantas horas trabajastes?";
Leer (horas trabajadas);
tarifa (j<-$100);
Mientras horas trabajadas Hacer
Escribir salario=(horas trabajadas*tarifa);
FinMientras
FinMientras
Escribir "tu salario es de:",+salario;
FinProceso

De una lista de 10 nmeros calcular la media y determinar cuntas son


mayores que 10.5, cuantas son iguales y cuantas son menores de la lista de
nmeros.

Proceso sin_titulo
num<-0;
m<-10;
Escribir "ingresa 10 numeros";
Leer numeros;
Para i<-1 Hasta 10 Con Paso 1 Hacer
Leer numero;
Para j<-1 Hasta 10 Con Paso 1 Hacer
Leer numero;
Si num>10.5 Entonces
num<-media;
Escribir "cuantos numeros son menores que 10.5
Escribir "dame el resultado";
FinSi

FinPara
FinPara
FinProceso

Realizar un programa que lea de una lista de nmeros enteros, los imprima
en pantalla y deber pedir si se desea ordenar en sentido decreciente o
creciente.

Proceso sin_titulo
num<-entero;
Repetir
Escribir "ingresa los numeros que quieras";
Leer numeros;
Repetir
Escribir "ingresa primer numero";
Para i<-1 Hasta 5 Con Paso 1 Hacer
Hasta Que
Hasta Que FinPara
Para i<-1 Hasta 10 Con Paso 2 Hacer
FinPara
Para i<-1 Hasta 5 Con Paso 3 Hacer
FinPara
Para i<-1 Hasta 5 Con Paso 4 Hacer
FinPara
Escribir "ingresar numero";
Escribir "dseas que se orden en forma decreciente o
creciente";
Si creciente Entonces
Escribir "odenar los numeros de mayor a menor";
Sino
Escribir "ordenar los numeros de menor a
mayor";
FinSi

FinProceso

Se tiene un arreglo "A" donde se encuentra 10 nmeros ordenados en forma


ascendente, y se pide que el algoritmo me permita el ingreso de un nmero y
lo coloque en la posicin donde debera de estar con respecto al orden del
arreglo.

Proceso sin_titulo
Dimension : Arreglo(entero);
Para i<-1 Hasta 10 Con Paso 1 Hacer
Escribir "ingresa los numeros que desees";
Si entero Entonces
Escribir "ingresa numero adicional";
Escribir "quieres que se coloque en una posicion!";
num<-decreciente;
num<-decreciente;
FinSi
FinPara
FinProceso
Cuadricula de (5) (5).

Proceso sin_titulo
Dimension vector (5,5);
Para i<-1 Hasta 5 Con Paso 1 Hacer
Para j<-1 Hasta 5 Con Paso 1 Hacer
Escribir "introduce un valor para el arreglo";
Leer valor;
vector (i,j)<-valor;
FinPara
FinPara
Para i<-1 Hasta 5 Con Paso 1 Hacer
Para j<-1 Hasta 5 Con Paso 1 Hacer
Para k<-1 Hasta 4 Con Paso 1 Hacer
Si (vector(i,k)<vector(j,k+1)) Entonces
temp<-vector(j,k);
vector(j,k)<-vector(j,k+1);
vector (j,k+1)<-temp;
FinSi
FinPara
FinPara
FinPara
Para i<-1 Hasta 5 Con Paso 1 Hacer
Para j<-1 Hasta 5 Con Paso 1 Hacer
Para k<-1 Hasta 4 Con Paso 1 Hacer
Si (vector(k,j)<vector(k+1,j)) Entonces
temp<-vector(k,j);
vector(k,j)<-vector(k+1,j);
vector(k+1,j)<-temp;
FinSi
FinPara
FinPara
FinPara
Para i<-1 Hasta 5 Con Paso 1 Hacer
Para j<-1 Hasta 5 Con Paso 1 Hacer
Escribir vector(i,j);
FinPara
FinPara
FinProceso