Está en la página 1de 4

Algoritmos para la programacin estructurada.

Robert Leal Cofr

INTRODUCCIN A LOS LENGUAJES DE PROGRAMACIN

Instituto IACC

23 de enero de 2017
Desarrollo

1. Escriba un pseudocdigo en PSeInt que calcule el promedio de notas de un grupo de 250

alumnos.

Proceso Promedio_250_alumnos_IACC

Escribir "Ingrese la cantidad de datos:"

Leer n

acum<-0

Para i<-1 Hasta n Hacer

Escribir "Ingrese el dato ",i,":"

Leer dato

acum<-acum+dato

FinPara

prom<-acum/n

Escribir "El promedio es: ",prom

FinProceso
2. Dibuje el DDF asociado.

Clculo de Promedio

Escribir
"Ingrese la cantidad de datos:"

Leer n

Acum<-0

Para i<-1 Hasta n Hacer

Escribir "Ingrese el dato ",i,":"

Leer dato

acum<-acum+dato

Leer dato

acum<-acum+dato

Escribir "El promedio es: ",prom

FIN PROCESO
3. Determine qu constantes, variables y operadores estn presentes en el pseudocdigo escrito.
En este caso no hay ningn dato numrico o alfanumrico, por lo tanto la constante es

distinta. Aunque se podra asignar como constate el dato 250, los datos para realizar

el clculo.
Las variables presentes son: Q de datos, Ing. De datos.
Los operadores son: Suma, Promedio

Bibliografa

Contenido de la semana: http://online.iacc.cl/mod/resource/view.php?

inpopup=true&id=2436316
http://es.slideshare.net/BorisSalleg/algoritmo-variables-constantes-tipos-de-datos-y-

asignacion
https://www.youtube.com/watch?v=kimpqs3YeVY&feature=youtu.be
http://aprenderaprogramar.com/index.php?option=com_content&view=article&id=287:como-

escribir-programas-o-algoritmos-en-pseudocodigo-ejemplos-ejercicios-resueltos-

cu00135a&catid=28:curso-bases-programacion-nivel-i&Itemid=59