Está en la página 1de 12

Ejercicios secuenciales

1.- Elabore un algoritmo que dados como datos de entrada el radio y la altura de un cilindro, calcular el área lateral y el volumen del cilindro. A = 2 π radio*altura V = π radio2*altura

Proceso AREALATERAL_VOLUMEN_CILINDRO Definir altura como real; Definir radio como real; Definir volumen como real; Definir area como real; Definir Phi como real; Phi <-3.141592655; //ENTRADA Escribir "ingrese altura del cilindro en cm: "; Leer altura; Escribir "Ingrese radio del cilindro en cm"; Leer radio; //PROCESO volumen =( Phi*radio*radio*altura) area =( Phi*(radio*radio + 2*radio*altura)) //SALIDA Escribir "El volumen del cilindro es ", volumen, " cm3"; Escribir "El area del cilindro es ", area, "cm2";

FinProceso

cilindro es ", volumen, " cm3"; Escribir "El area del cilindro es ", area, "cm2"; FinProceso

2.- Un maestro desea saber que porcentaje de hombres y que porcentaje de mujeres hay en un grupo de estudiantes.

Proceso PORCENTAJE_ALUMNOS_ALUMNAS Definir AH,AM,T como entero; Definir PAH,PAM como real; //ENTRADA Escribir "ingrese cantidad de alumnos: "; Leer AH; Escribir "Ingrese cantidad de alumnas: "; Leer AM; //PROCESO T=AH+AM

PAH=(AH*100)/T

PAM=(AM*100)/T

//SALIDA Escribir "El Porcentaje de alumnos es: ", PAH, "%"; Escribir "El Porcentaje de alumnas es: ", PAM, "%"; FinProceso

de alumnos es: ", PAH, "%"; Escribir "El Porcentaje de alumnas es: ", PAM, "%"; FinProceso

3.- Queremos conocer los datos estadísticos de una asignatura, por lo tanto, necesitamos un algoritmo que lea el número de desaprobados, aprobados, notables y sobresalientes de una asignatura, y nos devuelva:

a. El tanto por ciento de alumnos que han superado la asignatura.

b. El tanto por ciento de desaprobados, aprobados, notables y sobresalientes de la asignatura.

Proceso ALUMNOS_APROBADOS_DESAPROBADOS_SOBRESALIENTES Definir desaprobados Como Entero; Definir aprobados Como Entero; Definir notables Como Entero; Definir sobresalientes Como Entero; Definir alumnos Como Entero; Definir aptos Como real; Definir p_des Como real; Definir p_ap Como real; Definir p_not Como real; Definir p_sob Como real;

//ENTRADA Escribir"Ingrese alumnos desaprobados: "; Leer desaprobados; Escribir"Ingrese alumnos aprobados: "; Leer aprobados; Escribir"Ingrese alumnos notables: "; Leer notables; Escribir"Ingrese alumnos sobresalientes: "; Leer sobresalientes; //PROCESO alumnos=(desaprobados +aprobados+notables+sobresalientes)

aptos=(aprobados+notables+sobresalientes)*100/alumnos

p_des <-100*desaprobados/alumnos p_ap <- 100*aprobados/alumnos p_not <- 100*notables/alumnos p_sob <- 100*sobresalientes/alumnos //SALIDA Escribir "Valor de porcentaje de aptos: ", aptos,"%"; Escribir "Valor de porcentaje de aprobados: ",p_des,"%"; Escribir "Valor de porcentaje de notables: ", p_not,"%"; Escribir "Valor de porcentaje de sobresalientes: ",p_sob,"%"; FinProceso

4.- Un departamento de climatología ha realizado recientemente su conversión al sistema métrico. Diseñar un algoritmo para realizar las siguientes conversiones:

a. Leer la temperatura dada en la escala Celsius e imprimir en su equivalente Fahrenheit (la fórmula de conversión es “F=9/5 ºC+32”).

b. Leer la cantidad de agua en pulgadas e imprimir su equivalente en milímetros (25.5 mm =

1pulgada.

Proceso SISTEMA_METRICO Definir grados_c como real;//temperatura definir pulgadas como real;//Cantidad de agua en pulgadas definir grados_f como real; definir milimetros como real; //ENTRADA Escribir "Ingrese una temperatura en grados Celsius: "; LEER grados_c Escribir "Ingrese una cantidad de agua en pulgadas: "; LEER pulgadas //PROCESO grados_f =((9/5)*grados_c+32) milimetros = (pulgadas*25.4)

//SALIDA Escribir "Grados Fahrenheit: ", grados_f ,"°F"; Escribir "Milimetros: ", milimetros,"mm"; FinProceso

Fahrenheit: ", grados_f ,"°F"; Escribir "Milimetros: ", milimetros,"mm"; FinProceso

5.- El precio de un automóvil nuevo para un comprador es la suma total de: el costo del vehículo, porcentaje de la ganancia del vendedor y de los impuestos aplicables. Suponer una ganancia del vendedor del 12% en todas las unidades y un impuesto del 6% y diseñar un algoritmo para mostrar el precio para el comprador.

Proceso PRECIO_FINAL_AUTO Definir Costo_auto como entero; Definir ganancia_vendedor como entero; Definir impuesto como entero; definir Precio_auto_final como entero; //ENTRADA Escribir "Ingrese el valor de costo del vehiculo: "; Leer Costo_auto; //PROCESO ganancia_vendedor =(Costo_auto*0.12); impuesto =(Costo_auto*0.06); Precio_auto_final =(Costo_auto+ganancia_vendedor+impuesto); //SALIDA Escribir "Valor de ganancia del vendedor: ", ganancia_vendedor,"$"; Escribir "Valor de impuesto: ", impuesto,"$"; Escribir "Valor de precio del automovil: ", Precio_auto_final,"$"; FinProceso

", impuesto,"$"; Escribir "Valor de precio del automovil: ", Precio_auto_final,"$"; FinProceso

6.- Convertir una cantidad de segundos a su equivalente en días, horas, minutos y segundos.

Proceso CONVERTIR_SEGUNDOS Definir segundos como entero; //ENTRADA Escribir "Ingrese el valor de cantidad de segundos: "; Leer segundos; //PROCESO horas =(segundos/3600); segundos_out =(segundos MOD 3600); minutos =(segundos/60); segundos_out=(segundos MOD 60); //SALIDA Escribir "Valor de horas: ", horas,"h" Escribir "Valor de minutos: ", minutos,"m" Escribir "Valor de segundos: ", segundos_out,"s" FinProceso

de minutos: ", minutos,"m" Escribir "Valor de segundos: ", segundos_out,"s" FinProceso

7.- Calcular la fuerza de atracción entre dos masas, separadas por una distancia, mediante la siguiente fórmula:

F = G*masa1*masa2 / distancia2 Donde G es la constante de gravitación universal: G = 6.673 * 10-8 cm3/g.seg2

Proceso FUERZAS_ATRACCION Definir masa_1 como real;//temperatura definir masa_2 como real;//Cantidad de agua en pulgadas definir distancia como real; //ENTRADA G <-0.0000006673 Escribir "Ingrese primera masa: "; LEER masa_1 Escribir "Ingrese segunda masa: "; LEER masa_2 Escribir "Ingrese distancia entre masas: "; LEER distancia //PROCESO Fuerza= G*masa_1*masa_2/distancia^2 //SALIDA Escribir "Valor de la fuerza gravitacional: ", Fuerza; FinProceso

Fuerza= G*masa_1*masa_2/distancia^2 //SALIDA Escribir "Valor de la fuerza gravitacional: ", Fuerza; FinProceso

8.- Un millonario excéntrico tenía tres hijos: Carlos, José y Marta. Al morir dejó el siguiente legado:

A José le dejó 4/3 de lo que le dejó a Carlos. A Carlos le dejó 1/3 de su fortuna. A Marta le dejo la mitad de lo que le dejó a José. Preparar un algoritmo para darle la suma a repartir e imprima cuanto le tocó a cada uno.

Proceso DIVISION_HERENCIA Definir herencia como entero; Definir centimetros Como Entero //ENTRADA Escribir "Ingrese herencia:"; Leer herencia; //PROCESO Herencia_Carlos =herencia/3; Herencia_Jose =((Herencia_Carlos)/3)*4; Herencia_Marta =(Herencia_Jose)/2; //SALIDA Escribir "Herencia para Carlos: ", Herencia_Carlos,"$"; Escribir "Herencia para Jose: ", Herencia_Jose,"$"; Escribir "Herencia para Marta: ", Herencia_Marta,"$"; FinProceso

Jose: ", Herencia_Jose,"$"; Escribir "Herencia para Marta: ", Herencia_Marta,"$"; FinProceso

9.- Hacer un algoritmo para ingresar una medida en metros, y que imprima esa medida expresada en centímetros, pulgadas, pies y yardas. Los factores de conversión son los siguientes:

1 yarda = 3 pies

1 pie = 12 pulgadas

1 metro = 100 centímetros

1 pulgada = 2.54 centímetros

Proceso MEDIDAS Definir metros como entero; //ENTRADA Escribir "Ingrese el valor de metros:"; Leer metros; //PROCESO centimetros <- metros/100; pulgadas <-centimetros/2.54; pies <-pulgadas/12; yardas <-pies/3; //SALIDA Escribir "Valor de centimetros: ", centimetros; Escribir "Valor de pies: ", pies; Escribir "Valor de pulgadas: ", pulgadas; Escribir "Valor de yardas: ", yardas; FinProceso

", pies; Escribir "Valor de pulgadas: ", pulgadas; Escribir "Valor de yardas: ", yardas; FinProceso

10.- Escriba un programa para calcular el tiempo transcurrido, en minutos, necesario para hacer un viaje. La ecuación es tiempo transcurrido = distancia total/velocidad promedio. Suponga que la distancia está en kilómetros y la velocidad en kilómetros/hora.

Proceso TIEMPO_TRANSCURRIDO Definir distancia como entero; //ENTRADA Escribir "Ingrese el valor de distancia en km: "; Leer distancia; Escribir "Ingrese el valor de la velocidad km por h: "; Leer Velocidad; //PROCESO tiempo_minutos =(distancia/Velocidad*60); //SALIDA Escribir "Valor de tiempo en minutos: ", tiempo_minutos; FinProceso

=(distancia/Velocidad*60); //SALIDA Escribir "Valor de tiempo en minutos: ", tiempo_minutos; FinProceso

12.- Calcular la velocidad de un auto en Km/h, ingresando la distancia recorrida en metros y el tiempo en minutos.

Proceso VELOCIDAD Definir Distancia Como Entero; Definir Tiempo Como Entero; //ENTRADA Escribir "Ingrese el valor de distancia en m: "; Leer Distancia; Escribir "Ingrese el Tiempo en minutos : "; Leer Tiempo; //PROCESO V_auto =(Distancia/1000/(Tiempo/60)); //SALIDA Escribir "Valor de Velocidad: ", V_auto,"Km*h"; FinProceso

V_auto =(Distancia/1000/(Tiempo/60)); //SALIDA Escribir "Valor de Velocidad: ", V_auto,"Km*h"; FinProceso