Está en la página 1de 15

UNIVERSIDAD TECNICA

DE AMBATO
FACULTAD DE INGENIERIA EN

SISTEMAS, ELECTRONICA
E
INDUSTRIAL

INGENIERIA EN ELECTRONICA
Y
COMUNICACIONES
GESTION DE REDES (B)

Tema:

CONFIGURACION DE ROUTERS CON OSPF E IPV6

REALIZADO POR:
Orosco Angel - Zambrano Erick
PROFESOR:
Santiago Manzano
Ambato, 10 de 11 del 2016

Indice general
Indice general . . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
i
Indice de figuras . . . . . . . . . . . . . . . . . . . . . . . . . . . . ii
Indice de cuadros . . . . . . . . . . . . . . . . . . . . . . . . . . . . iii
1. CONFIGURACION DE ROUTERS CON OSPF E IPV6
1.1. Objetivo General . . . . . . . . . . . . . . . . . . . . . . . .
1.1.1. Objetivos Especficos . . . . . . . . . . . . . . . . . .
1.2. Resumen . . . . . . . . . . . . . . . . . . . . . . . . . . . . .
1.3. Palabras clave . . . . . . . . . . . . . . . . . . . . . . . . . .
1.4. Materiales . . . . . . . . . . . . . . . . . . . . . . . . . . . .
1.4.1. Hardware . . . . . . . . . . . . . . . . . . . . . . . .
1.4.2. Software . . . . . . . . . . . . . . . . . . . . . . . . .
1.5. Marco Teorico . . . . . . . . . . . . . . . . . . . . . . . . . .
1.5.1. Linux . . . . . . . . . . . . . . . . . . . . . . . . . .
1.5.2. Quagga (Router virtual) . . . . . . . . . . . . . . . .
1.5.3. Moodle . . . . . . . . . . . . . . . . . . . . . . . . .
1.5.4. GNS3 . . . . . . . . . . . . . . . . . . . . . . . . . .
1.6. Procedimiento . . . . . . . . . . . . . . . . . . . . . . . . . .
1.6.1. Configuracion de Quagga . . . . . . . . . . . . . .
1.6.2. Configuracion para GNS3 OSPF IPV6 . . . . . . .
1.6.3. Configuracion de Moodle . . . . . . . . . . . . . . . .
1.7. Resultados y discusion . . . . . . . . . . . . . . . . . . . . .
1.8. Conclusiones . . . . . . . . . . . . . . . . . . . . . . . . . . .
1.9. Recomendaciones . . . . . . . . . . . . . . . . . . . . . . . .
Bibliografa

.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.
.

1
1
1
1
2
2
2
2
2
2
3
3
3
4
4
5
6
9
9
9
10

Indice de figuras
1.1.
1.2.
1.3.
1.4.
1.5.

Configuracion del router en GNS3 .


Configuracion del router en GNS3 .
Configuracion maquina de windows
Ping a la maquina de windows . . .
Ping al router . . . . . . . . . . . .

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

.
.
.
.
.

6
6
7
7
7

ii

Indice de cuadros
1.1. Materiales tipo Hardware . . . . . . . . . . . . . . . . . . . . .
1.2. Materiales tipo Software . . . . . . . . . . . . . . . . . . . . .

2
2

iii

Captulo 1
CONFIGURACION DE
ROUTERS CON OSPF E IPV6
1.1.

Objetivo General

Realizar la configuracion y la instalacion de los diferentes dispositivos


en el software Quagga , GNS3 y Moodle en el sistema operativo Linux
con enrutamiento OSPF e IPV6.

1.1.1.

Objetivos Especficos

Inveztigar la informacion detallada de los pasos necesarios para la correctaa instalacion y configuracion de los dispositivos.
Reforzar los conocimientos adquiridos ademas de observar el funcionamiento de protocolo OSPF con IPV6.
Analizar los diferentes comandos para el enruamiento IPV6 ya que estos
varian con relacion al enrutamiento IPV4.

1.2.

Resumen

El siguiente trabajo tiene como objetivo configurar una red mediante la


herramienta de linux la cual nos permitir`a instalar los software de Quagga
,GNS3 y Moodle en las PCs para luego pasar a configurar a cada uno de los
dispositivos dependiendo de la topologia a realizar. Hablaremos sobre Ubuntu, es una distribucion Linux basada en Deban GNU/Linux, cuyo nombre
proviene de la ideologa sudafricana Ubuntu (humanidad hacia otros). Proporciona un sistema operativo actualizado y estable para el usuario promedio,
1

1.3 Palabras clave


con un fuerte enfoque en la facilidad de uso y de instalacion del sistema. Al
igual que otras distribuciones se compone de m
ultiples paquetes de software
normalmente distribuidos bajo una licencia libre o de codigo abierto.

1.3.

Palabras clave

Quagga, Moodle, linux, Configuracion, GNS3, OPSF, IPV6

1.4.
1.4.1.

Materiales
Hardware
Cuadro 1.1: Materiales tipo Hardware
Cantidad Descripci
on
2
PC
2
Cable de red

1.4.2.

Software
Cuadro 1.2: Materiales tipo Software
Cantidad Descripci
on
2
UBUNTU
1
GNS3
1
MOODLE

1.5.
1.5.1.

Marco Te
orico
Linux

Un sistema operativo consiste en varios programas fundamentales que


necesita el ordenador para poder comunicar y recibir instrucciones de los
usuarios; tales como leer y escribir datos en el disco duro, cintas, e impresoras;
controlar el uso de la memoria; y ejecutar otros programas. La parte mas
importante de un sistema operativo es el n
ucleo. En un sistema GNU/Linux,
Linux es el n
ucleo. El resto del sistema consiste en otros programas, muchos
de los cuales fueron escritos por o para el proyecto GNU. Dado que el n
ucleo
2

1.5 Marco Te
orico

de Linux en s mismo no forma un sistema operativo funcional, preferimos


utilizar el termino GNU/Linux para referirnos a los sistemas que la mayor
parte de las personas llaman de manera informal Linux.[1]

1.5.2.

Quagga (Router virtual)

Es un paquete de software de enrutamiento avanzado que proporciona


un conjunto de protocolos de enrutamiento basada en TCP / IP. , tiene la
capacidad de simular un router normal, y, mediante las configuraciones dadas,
puede producir que, la computadora se comporte como un router, en la cual,
se pueden modificar las entradas virtuales y, realizar las programaciones con
los comandos propios de un router para establecer una interconexion dentro
de una red, seguramente se comporte como una simulacion virtual, pero,
a pesar de ello, la funcionalidad es la misma, todos los comandos de un
router son funcionales, y pueden tener aplicaciones conjuntas en programas
de simulacion, como es el GNS3.[1]

1.5.3.

Moodle

Es un programa de tipo virtual que va dirigido a un entorno p


ublico
educativo libre, a los educadores a crear un ambiente de educacion de manera
ordenada y bien distribuida en la web. Esta aplicacion fue creada pensando
en la innovacion pedagogica para el estudiante actual, ya que con el dominio
del internet en la vida de las personas y sobre todo la influencia de este en
el aprendizaje, tener una comunidad virtual en la que se pueden compartir
archivos, contenidos, informacion actualizada, libros, opiniones, etc. Es una
idea innovadora orientada al beneficio y facilidad de comunicacion tanto para
alumnos y docentes.

1.5.4.

GNS3

GNS3 es un simulador grafico de red que permite dise


nar topologas de
red complejas y poner en marcha simulaciones sobre ellos. Para permitir
completar simulaciones, GNS3 esta estrechamente vinculada con: Dynamips,
un emulador de IOS que permite a los usuarios ejecutar binarios imagenes
IOS de Cisco Systems. Para nuestro caso vamos a vincular con una maquina
de ubuntu server.

1.6 Procedimiento

1.6.
1.6.1.

Procedimiento
Configuracion de Quagga

Para configurar OSPF6d con IPV6 seguimos los siguientes comandos:


password whatever
adapter setup
interface br0
ipv6 ospf6 cost 1
ipv6 ospf6 hello-interval 10
ipv6 ospf6 dead-interval 40
ipv6 ospf6 retransmit-interval 5
ipv6 ospf6 priority 1
ipv6 ospf6 transmit-delay 1
ipv6 ospf6 instance-id 1
interface bond0
ipv6 ospf6 cost 1
ipv6 ospf6 hello-interval 10
ipv6 ospf6 dead-interval 40
ipv6 ospf6 retransmit-interval 5
ipv6 ospf6 priority 2
ipv6 ospf6 transmit-delay
ipv6 ospf6 instance-id 2
router setup
router ospf6
router-id 0.0.0.1
redistribute static
redistribute connected
area 0.0.0.1 range 2001:db8:beef:1::/64
area 0.0.0.1 range 2001:db8:beef:2::/64
interface br0 area 0.0.0.1
interface bond0 area 0.0.0.0
Para configurar Zebra seguimos los siguientees comandos con las direcciones IPV6 asignadas:
interface br0
link-detect no ipv6 nd suppress-ra
ipv6 nd ra-interval 10
ipv6 address 2001:db8:beef:1::ffff/64
ipv6 address 2001:db8:beef:2::ffff/64
ipv6 nd prefix 2001:db8:beef:1::/64
ipv6 nd prefix 2001:db8:beef:2::/64
4

1.6 Procedimiento

interface bond0 link-detect


ipv6 address 2001:db8:beef:0::1/64
ipv6 address 2001:db8:beef:0::2/64
interface lo link-detect ! ipv6 forwarding
ipv6 route 2001:db8:beef:1::/64 br0
ipv6 route 2001:db8:beef:2::/64 br0
[1].

1.6.2.

Configuracion para GNS3 OSPF IPV6

Para el enrutamiento OSPF con IPV6 seguimos los siguientes pasos:


Lo primero que se debe hacer en cada router es habilitar el ruteo para
ipv6, esto se hace con el comando:
ipv6 unicast-routing
Una vez hecho esto podemos empezar a configurar las interfaces con sus
respectivas direcciones ip y lo que siga. Hay que tener en cuenta que el proceso
OSPF para ipv6 se debe hacer a nivel de interfaz. El comando utilizado es el
siguiente:
Ipv6 ospf IDENTIFICADOR area #AREA
INDENTIFICADOR: puede ser un nombre o un n
umero. Para este caso

el identificador del proceso utilizare el n


umero de Router; #AREA: Area
a
la que se asociara la red.
Antes de todo es necesario tener un ID de proceso con la forma A.B.C.D,
para configurarlo es necesario ingresar al proceso OSPF a nivel global, tal
como se muestra a continuacion.
Router(config)# ipv6 unicast-routing
Router(config)# ipv6 router ospf PROCESO
Router(config-rtr)# router-id ID PROCESO
Router(config-rtr)# exit
Por comodidad los router-id se colocaran seg
un n
umero de Router, tambien puedes colocar tu direccion lookback ipv4 si lo deseas. Ahora veamos
las configuraciones completas de cada router
Router(config)# ipv6 unicast-routing
Router(config)# ipv6 router ospf 1
Router(config-rtr)# router-id 1.1.1.1
Router(config-rtr)# exit
Router(config)# interface FastEthernet 1/0
Router(config-router)#ipv6 address 2001:db8:1::1/64
Router(config-router)#ipv6 ospf 1 area 0
Router(config-router)#no shutdown
Router(config-router)#exit
5

1.6 Procedimiento

Figura 1.1: Configuracion del router en GNS3

Figura 1.2: Configuracion del router en GNS3


Router(config)# interface FastEthernet 1/1
Router(config-router)#ipv6 address 2001:db8:2::1/64
Router(config-router)#ipv6 ospf 1 area 0
Router(config-router)#no shutdown
Router(config-router)#exit
Configuracion del router en GNS3 int 0
Configuracion del router en GNS3 int 1
Configuracion ipv6 de maquina de windows
Ping a la maquina de windows
Ping al router

1.6.3.

Configuracion de Moodle

1. Instalar Apache/MySQL/PHP
sudo apt-get update sudo apt-get install apache2 mysql-client mysqlserver php7.0
libapache2-mod-php7.0
2. Instalar Software Adicional
sudo apt-get install graphviz aspell php7.0-pspell php7.0-curl php7.0-gd
php7.0-intl php7.0-mysql php7.0-xmlrpc php7.0-ldap php7.0-zip
sudo service apache2 restart
sudo apt-get install git
3. Descargar Moodle
6

1.6 Procedimiento

Figura 1.3: Configuracion maquina de windows

Figura 1.4: Ping a la maquina de windows

Figura 1.5: Ping al router


7

1.6 Procedimiento

cd /opt
sudo git clone git://git.moodle.org/moodle.git
cd moodle
sudo git branch -a
sudo git branch --track MOODLE 31 STABLE origin/MOODLE 31 STABLE
sudo git checkout MOODLE 31 STABLE
4. Copiar el repositorio local a /var/www/html/
sudo cp -R /opt/moodle /var/www/html/
sudo mkdir /var/moodledata
sudo chown -R www-data /var/moodledata
sudo chmod -R 777 /var/moodledata
sudo chmod -R 0755 /var/www/html/moodle
5. Configurar MySQL Server
sudo vi /etc/mysql/my.cnf
default storage engine = innodb
innodb file per table = 1
innodb file format = Barracuda
sudo service mysql restart
6. Creacion de la base de datos
mysql -u root -p
mysql>CREATE DATABASE moodle DEFAULT CHARACTER SET
utf8 COLLATE utf8 unicode ci;
mysql> create user moodledude@localhost IDENTIFIED BY passwordformoodledude;
mysql>GRANT SELECT,INSERT,UPDATE,DELETE,CREATE,CREATE
TEMPORARY TABLES,DROP,INDEX,ALTER ON moodle.* TO moodledude@localhost IDENTIFIED BY passwordformoodledude;
mysql>quit;
7. Completar la configuracion
sudo chmod -R 777 /var/www/html/moodle
sudo chmod -R 0755 /var/www/html/moodle
Abrir la pagina con la direccion de red asignada: http://IP DEL SERVIDOR/moodle
Cambiar la ruta para moodledata: /var/moodledata
8. Base de Datos
Escojemos: mysqli
Host server: localhost
Database: moodle
User: moodledude (usuario que creamos)
Password: passwordformoodledude (contrase
na)
Tables Prefix: mdl
8

1.7 Resultados y discusi


on

1.7.

Resultados y discusi
on

Se puede distinguir que la red funciona correctamente debido a que se


ha utilizado los comandos y parametros necesarios para su funcionamiento
correcto, tanto el simulador GNS3 como el router virtual quagga de Linux.
Para la utilizacion del GNS3 se debe tener claro cuales son las caractersticas mas relevantes que dicho software, ya que de ello depende la efectividad
de la realizacion de las pruebas en el proyecto, donde este involucrado el uso
de simuladores de red, es de gran importancia invertir tiempo y estudio para
obtener mejores resultados.

1.8.

Conclusiones

Como el router virtual (quagga) es una simulacion exacta a la realidad,


se puede ver todos los puertos y configuraciones activas de todos los
puertos e interfaces virtuales para su uso.
Antes de comenzar a instalar los programas se debe actualizar la lista
de paquetes de los repositorios e instalar las actualizaciones con los
comandos: apt-get update para que la b
usqueda e instalacion sea mas
rapida y que al mismo tiempo se actualice el sistema operativo y las
aplicaciones de los repositorios
La instalacion de moodle se la puede hacer usando internet como sin el
de forma manual y se debe tomar en cuenta que en el vim tenemos que
tener cuidado con los cambios que realicemos ya que de caso contrario
el mysql no funcionara correctamente.

1.9.

Recomendaciones

Para un mejor rendimiento del emulador y por ende de la red emulada es necesario que el software se ejecute en un equipo con buenas
caractersticas.
Tener en cuenta los dispositivos a utilizar y revisar la configuracion de
cada uno para una mayor seguridad.

Bibliografa
[1] Ishiguro,
Kunihiro.
(2005,
Mayo,
11).
QUAGGA
(Copyright)[En
linea].
Disponible:
http://www.nongnu.org/quagga/docs/quagga.html#OSPF6-interface
[2] Manzano, Santiago.(2016,Octubre,28).Servidor LAMP[En linea]. Disponible:https://prezi.com/ 047vqwarba1/servirdor-lamp/
[3] IArana, Oswaldo. (2013, Febrero, 11). Configuracion de
OSPF en CISCO en ipv4 e ipv6 (Copyright)[En linea].
Disponible:
http://www.taringa.net/post/hazlo-tumismo/16887987/Configuracion-de-OSPF-en-CISCO-en-ipv4-eipv6.html

10