Está en la página 1de 12

Realice un diagrama de flujo que pida al usuario que

ingrese 2 nmeros (uno a la vez) y luego los imprima


junto con un mensaje.
Algoritmo lectura
Escribir Ingrese el primer nmero
Leer n1
Escribir Ingrese el segundo nmero
Leer n2
Escribir El primer nmero ingresado fue: ,n1
Escribir El segundo nmero ingresado fue: ,n2
FinAlgoritmo

Realizar un diagrama de flujo que lea el nmero de


cedula y el salario bruto de un empleado, que calcule su
salario neto sabiendo que si gana ms de $500.000 se le
hace un descuento del 10%, caso contrario del 5%. Debe
imprimir cdula, salario bruto, descuento y salario neto.
Algoritmo Descuento
Escribir Ingrese la cdula
Leer cc;
Escribir Ingrese el salario
Leer sb
Si sb>500000 entonces
Des=0.05*sb
Sino
Des=0.1*sb
FinSi
Sn=sb-des
Escribir Cdula: ,cc,, Salario bruto: ,sb,, descuento : ,
Salario neto: ,sn
FinAlgoritmo

Realizar un diagrama de flujo que calcule e imprima la


sumatoria de los primeros 20 trminos de la serie:
nn 1
2 n1

Algoritmo Descuento
Sum=0
Para i<-1 hasta 20 Con Paso 1 Hacer
t=(n^(n-1))/(2*n+1)
Sum=sum+t
FinPara
Escribir La suma es: ,sum
FinAlgoritmo

Realizar un programa que permita entrar el valor de una


variable en grados Fahrenheit y al final realice la
conversin a grados Centgrados y a grados Celsius e
imprima las conversiones respectivas.
#include<iostream>
using namespace std;
int main(){
float fahrenheit, kelvin, celsius;
cout<<"Ingrese la temperatura en grados Fahrenheit: ";
cin>>fahrenheit;
kelvin= (5/9)*(fahrenheit-32)+273;
celsius= fahrenheit - (32 / 1,8);
cout<<fahrenheit<<" fahrenheit equivalen a
"<<kelvin<<" Kelvin\n";
cout<<fahrenheit<<" fahrenheit equivalen a
"<<celsius<<" Celsius\n";
}

Realizar un programa que permita entrar el nmero


entero, finalmente imprimir si el nmero capturado es
par positivo, par negativo, impar positivo o impar
negativo. Recuerde definir el nmero 0 como par
positivo.

#include<iostream>
using namespace std;
int main(){
int num;
cout << "Ingrese el numero: ";
cin>>num;
if(num>=0){
if(num%2==0)
cout<<num<<" es par positivo";
else
cout<<num<<" es impar positivo";
} else{
if(num%2==0)
cout<<num<<" es par negativo";
else
cout<<num<<" es impar negativo";

}
}

Realizar un programa que permita entrar el nombre del


estudiante y pueda escoger cul es su color preferido:
Blanco, Azul o Rojo; y al final imprimir un informe.

#include<iostream>
using namespace std;
int main(){
int num;
string nombre;
cout <<"Ingrese su nombre: ";
cin >> nombre;
cout << "\n1-Blanco\n2-Azul\n3-Rojo";
cout << "\nSeleccione su color preferido: ";
cin >> num;
cout << "\n***** Informe *****";
cout << "\nNombre: "<<nombre;
cout << "\nSu color favorito es: ";
switch(num){
case 1:
cout<<"Blanco";
break;

case 2:
cout<<"Azul";
break;
case 3:
cout<<"Rojo";
break;
}
}

Realizar un programa que permita entrar el nmero de


identificacin del estudiante, la estatura y pueda
seleccionar el gnero del estudiante. Al final imprimir
cuntos fueron seleccionados para el Equipo de
Bsquetbol Femenino (requisito estatura mayor o igual a
160) y cuntos para el Equipo de Bsquetbol Masculino
(requisito estatura mayor o igual a 170). No se sabe
cuntos estudiantes van a venir a participar por lo cual
finaliza cuando el nmero de identificacin es cero.
#include<iostream>
using namespace std;
int main(){
string genero;
long int nroIden, estatura, cantFeme=0, cantMas=0;
do{
cout<<"\nIdentificacion: "; cin>>nroIden;
cout<<"Estatura [cm]: "; cin>>estatura;
cout<<"\Genero [m/f]: "; cin>>genero;
if(genero=="f" && estatura>=160)
cantFeme++;
if(genero=="m" && estatura>=170)
cantMas++;
}while(nroIden>0);
cout<<"\nSeleccionados basquetbol femenino: "<<cantFeme;
cout<<"\nSeleccionados basquetbol masculino: "<<cantMas;
}