Está en la página 1de 31

LABORATORIO PRÁCTICO

ALGORITMOS

PRESENTADO A:
ING.DIEGO FERNANDO MEDINA SOTO

PRESENTADO POR: ENRIQUE ANDRES PLATA
C.C. 11.367.343
GRUPO: 301303_12

UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA (UNAD)
FUNZA, NOVIEMBRE 2013

PRACTICA 1
1-determinar cuál es el cuadrado, de un determinado número

2-Elaborar un diagrama de flujo que permita determinar si un número es
Positivo o Negativo

3.-Ejercicio de conversión, desarrollar un diagrama, que perita ingresar una
cantidad en metros y la convierta a Centímetros, Kilómetros, Pies, pulgadas.

4-Leer una determinada temperatura en grados centígrados y convertirla a
Fahrenheit

menor de 25 años. 6-Elabore un diagrama de flujo que teniendo como datos de entrada el radio y la altura de un cilindro calcule el área total y el volumen del cilindro .5. Realizar un diagrama que permita determinar si una persona es apta o no par prestar el servicio militar. nacionalidad Colombiana y género masculino.-una persona es apta para prestar el servicio militar obligatorio (presente). cuando: es mayor de 18 años.

. que permita ingresar 3 valores y los imprima en forma descendente .7.Elaborar un diagrama de flujo.8% mensual.Una persona recibe un préstamo de un banco por un año y desea saber cuánto pagará de interés al terminar el préstamo si se sabe que el banco le cobra una tasa del 1. Realice un diagrama de flujo que permita determinar este monto 8.

tarifa + 0. los cuales se deben llevar preparados y solucionados en papel para luego proceder a codificar en la Herramienta Pseint la que permite comprobar si el diagrama funciona de manera adecuada 1-A un trabajador le pagan según sus horas y una tarifa de pago por horas.50 * tarifa horas_extras <-. . La tarifa se incrementa en un 50% para las horas extras.salario.tarifa_e inicio leer: horas_trabajadas.horas_extras * tarifa_extra + 40 * tarifa fin_si imprimir: salario. cada estudiante en forma individual desarrollara los supuestos polémicos presentados para ser solucionados. Si la cantidad de horas trabajadas es mayor a 40 horas.horas_trabajadas – 40 salario <-. variables: horas_trabajadas.tarifa si: horas_trabajadas <= 40 entonces salario <-.horas_extras. Calcular el salario del trabajador dadas las horas trabajadas y la tarifa.tarifa.PRACTICA 2 Teniendo como punto de partida los ejemplos propuestos en el módulo y consultas de las diferentes fuentes documentales ahí presentadas y apoyados con el tutor de prácticas.horas_trabajadas * tarifa si_no tarifa_extra <-.

de acuerdo al reglamento UNAD.tiempo_seg mod 60 fin_si imprimir: minutos.00 pesos se debe realizar un descuento del 5%.fin 2-Dado un tiempo en segundos.05 . c) El promedio de notas. El IVA es del 16% y si el precio bruto (precio venta más IVA) es mayor de 50.16 Si valor_a_pagar > 50000 entonces descuento = valor_a_pagar * 0. cantidad=0. Inicio notas[].segundos. i Para i=0 / **/ 4-Se trata de escribir el algoritmo que permita emitir la factura correspondiente a una compra de un artículo determinado. valor_a_pagar=0 leer valor_articulo. valor_total=0.000. calcular los segundos restantes que le correspondan para convertirse exactamente en minutos. del que se adquieren una o varias unidades. Fin 3-Dado N notas de un estudiante calcular: a) Cuantas notas tiene desaprobados.segundos inicio leer: tiempo_seg si minutos <-. notas_aprobadas. cantidad valor_total = valor_articulo * cantidad valor_a_pagar = valor_total * 1. d) El promedio de notas aprobadas y desaprobadas. b) Cuantos aprobados. promedio. variables: tiempo_seg.tiempo_seg div 60 entonces segundos <-.minutos. descuento=0. Inicio valor_articulo=0. notas_desaprobadas.

Escribir ''."+". Se deben realizar los cálculos.tabla:entero. inicio para(k=1 hasta 9)hacer para(j=1hasta 9)hacer tabla=k*j. 10% a los que ganan entre 1 y dos salarios mínimos y 5% a quienes gana más de 3 salarios mínimos.num. cuanto aumentará la nómina mensual si se hace incrementos así.j.valor_a_pagar = valor_a_pagar .descuento FinSi Imprimir valor_a_apagar Fin 5-Se desea desarrollar un algoritmo que permita. para (k=1 hasta 9) hacer tabla =num* k. escriba("k. desarrollar la tabla de multiplicar de un determinado número (la tabla básica va de 1 a9). se debe desarrollar un algoritmo que permita mostrar las tablas del 1 al 9 Var k. fin_para fin_para fin. teniendo en cuenta el valor del salario mínimo legal vigente Nomina_2 Escribir 'Programa de nomina empresa Aurora'.j. cuantos tienen un salario entre uno y dos salarios mínimos y cuantos ganan más de tres salarios mínimos. salario<-0 . escriba("k. 7-Una empresa con 20 empleados desea saber cuántos ganan menos de un salario mínimo. lea(num). además cual es el valor actual de la nómina de la empresa."=".tabla)."*". tabla). 20% a aquellos que gana menos de un salario mínimo.tabla:entero. inicio escriba("ingrese el numero que desea hacer tabla ").k. fin_para fin 6-Variación del ejercicio anterior. Var num."=".

acu3<-acu3+1 FinSi suma<-suma+salario nn<-nn+acu an<-nn*100/suma-100 f<-nn-suma FinPara Escribir ''. Leer salario. acu1<-acu1+1 Sino Escribir 'La cantidad de salario debe ser superior a 0'. Si salario>1178328 Entonces acu<-salario*0.10+salario Escribir 'El nuevo salario para el empleado '.acu<-0 acu1<-0 acu2<-0 acu3<-0 suma<-0 an<-0 nn<-0 Escribir 'Ingrese el salario de cada empleado'. Para i<-1 Hasta 20 Con Paso 1 Hacer Escribir 'Ingrese el salario del empleado '. Escribir ''.acu1.i ' es: '.i ' es: '. FinSi Escribir ''. . Escribir ''.20+salario Escribir 'El nuevo salario para el empleado '. Escribir 'El total de empleados que gana menos del mínimo es de: '.acu. Si salario>=589164 & salario<=1178328 Entonces acu<-salario*0.i ' es: '. acu2<-acu2+1 FinSi Escribir ''.acu.acu2.5+salario Escribir 'El nuevo salario para el empleado '. Si salario>0 & salario<=589163 Entonces acu<-salario*0. Escribir 'El total de empleados que ganan entre 1 y 2 salarios minímos es de: '.acu. Escribir ''.i.

k. 34..suma. Escribir ''.55. fin 9-Para las elecciones presidenciales que se realizarán en Colombia. inicio a = 0. 5. escriba(“ingrese numero a calcular”). FinProceso 8-la serie Fibonacci es un ejercicio interesante. lea (num).Escribir 'El total de empleados que gana más de 2 salarios minímos es de: '. para ( k = 0 hasta num ) hacer c = a + b. Escribir ''.1. Desarrollar un algoritmo que permita.f.acu3. Escribir 'El incremento porcentual de la nomina mensualmente es de: '. 3. 2. el cual se construye a partir de los dos primeros números que son el 0 y 1. Uno de estos ha decidido realizar una consulta (encuesta) a un cierto . b = c. 1. c.. 2. c). 0. Escribir ''. 1.' pesos'. fin_para escriba (“el valor de la serie es:”. b = 1.'%'. b. 8. num: entero.3). Escribir 'El incremento en pesos de la nomina mensualmente es de: '. 13. y a partir de ahí se construye la serie ejemplo: 0. Escribir 'El total de la nomina actual es de: '. c = 0.an. a = b. 21. existen tres partidos Políticos aspirando con sus candidatos (1. calcular n números de esta serie var a.

fin . para determinar las preferencias de los electores A cada persona se le pregunta: Si va a votar. En caso de que la respuesta se afirmativa. inicio Pedir el costo (C) pedir el precio del metro cuadrado (Pm2) pedir el ancho y largo del terreno en metros cuadrados (A. para llevar un control de la información y así obtener unos resultados con prontitud Nota: el dato partido solamente se lee si la persona entrevistada ha contestado que sí votará.L) multiplicar el numero de metros cuadrados del terreno por el precio por metro para sacar su costo total (C=Pm2*(A*L)) mostrar resultados (C). Elaborar un algoritmo. teniendo como datos la anchura y longitud en metros. teniendo en cuenta. El algoritmo imprimirá la siguiente información:  ¿Cuál es el partido que está repuntando?  ¿cuál es % de abstención?  ¿Cuál es % a favor de cada partido. y el costo del metro cuadrado. las entrevistas validas?  ¿cuál es el % de personas que SI votaran? 10-Hacer un algoritmo que calcule e imprima el costo de un terreno rectangular.número de personas. se le preguntará por qué partido votará.

da + 29 sino da <. Nota: Un año se considera bisiesto cuando es divisible por 400 o bien es divisible por 4 pero no por 100.da + 28 finsi sino si mi = 4 O mi = 6 O mi = 9 O mi = 11 entonces da <.da + 31 finsi FinSi FinPara da <.1584 Mientras avi <= (a . Proceso dia escribir 'Diganos la fecha y sabra que dia de la semana cayo o caera' escribir ' ' Escribir 'Digite el anio' Leer A Escribir 'Digite el numero del Mes' Leer M Escribir 'Digite el numero del dia' Leer D da<-(A .avi + 4 FinMientras para mi<.1583) * 365 avi <.1) Hacer si (avi Mod 100) <> 0 o (avi Mod 400) = 0 Entonces da <.1 hasta m-1 Hacer si mi = 2 Entonces si (a Mod 4) = 0 y ((a Mod 100) <> 0 o (a Mod 400) = 0) entonces da <.1) .da + (d .11-Sabiendo que el día 1 de enero de 1.da + 30 sino da <.583 fue sábado y que desde entonces no se han producido modificaciones en el calendario.583. elaborar un algoritmo para calcular el día de la semana en que cayó o caerá una fecha cualquiera posterior al 1 de enero de 1.da + 1 FinSi avi <.

" FINSI si r = 1 entonces Escribir "Es domingo." FINSI si r = 6 entonces Escribir "Es viernes." FINSI si r = 3 entonces Escribir "Es martes." FINSI si r = 4 entonces Escribir "Es miercoles.Considérense tres soluciones al problema "Pelar un número suficiente de papas que hay en un cesto". teniendo en cuenta que el cesto puede estar vacío en un momento dado." FINSI si r = 2 entonces Escribir "Es lunes.r <.da Mod 7 si r = 0 entonces Escribir "Es sabado." FINsi FinProceso 12." FINSI si r = 5 entonces Escribir "Es jueves. inicio mientras número insuficiente de patatas peladas hacer si cesto no vacío entonces pelar una patata fin_si fin_mientras fin algoritmo pelar2 .

inicio mientras (número insuficiente de patatas peladas) o (cesto no vacío) hacer pelar una patata fin_mientras fin algoritmo pelar3 inicio si cesto no vacío entonces mientras número insuficiente de patatas peladas hacer pelar una patata fin_mientras si_no comprar una patata fin_si fin 13-Realizar un algoritmo que permita calcular la hora un segundo después de un valor dado. para darle ubicación y presentación a los programas. día…) PRACTICA 3 Lenguaje de programación Teniendo como punto de partida los ejemplos propuestos en el módulo y consultas de las diferentes fuentes documentales ahí presentadas y apoyados con el tutor de prácticas.y). los cuales se deben llevar preparados y solucionados en papel para luego proceder a codificar en con C# o C++ Para los siguientes ejercicios si se desarrollan en C++ debe Consultar la directiva de posicionamiento gotoxy(x. hora. (Tenga en cuenta el cambio de minuto. en los casos que ustedes crea necesarios . cada estudiante en forma individual desarrollara los supuestos polémicos presentados para ser solucionados.

printf("Introduzca mes (m):").bis. int digito. //verificar si el año es bisiesto if ((aaaa%4 == 0 && aaaa%100 != 0)||aaaa%400==0) { bis = 2.h" int main() { int dd. while(numero>0){ digito=numero%10.&numero). el segundo. de penúltimo. scanf("%d".aaaa. } getch().h" #include "stdio.h" #include "conio.&aaaa).&dd). printf("Introduzca ano (aaaa):"). scanf("%d". printf("%d". numero/=10. el último pasa a ser primero: ejemplo: Ejemplo: Sea 7458.mm. printf("DIGITTE LOS CUATRO NUMEROS DE SU CONTRASENA\t "). clrscr(). scanf("%d".&mm). long numero.h" #include "stdlib. printf("Introduzca dia (d):"). aaaa ) e imprimirla. utilizando el siguiente criterio. se debe enviar como 8547 #include "stdio.1-Un banco ha solicitado se diseñe un programa que permita encriptar la información de las contraseñas (4 números) digitada por teclado (como un único numero) hasta el servidor principal. mm. el primer número se envía de último. } else . return(0). (Tenga en cuenta los años bisiestos.digito). scanf("%ld". } 2-Escribir un programa para calcular la fecha del siguiente día a partir de una fecha digitada desde el teclado por el usuario ( dd.) #include "conio. el tercer número pasa a la segunda posición.ddmax.h" int main() { clrscr().

} else {} // maximo dias de cada mes if (mm==1||mm==3||mm==5||mm==7||mm ==8||mm==10||mm==12) { ddmax = 31. return 0. return 0.{ bis = 1. } else if (mm==4||mm==6||mm==9||mm==11) { ddmax = 30. } else if (((mm==2)&&(bis==2))&&(dd>29)||mm>12) { printf("La fecha es invalida"). getch(). getch(). getch(). return 0. return 0. getch(). } ///VERIFICARMOS SI LA FECHA QUE SE INGRESO ES VALIDA if ((mm==1||mm==3||mm==5||mm==7||mm ==8||mm==10|| mm==12)&&(dd>31)||mm>12) { printf("La fecha es invalida"). } . } else if ((mm==2)&&(bis==1)) { ddmax = 28. } else{} if ((mm==2)&&(bis==2)) { ddmax = 29. } else if ((mm==4||mm==6||mm==9||mm==11)&&(dd>30)||mm>12) { printf("La fecha es invalida"). } else if (((mm==2)&&(bis==1))&&(dd>28)||mm>12) { printf("La fecha es invalida").

mm = 1. numero = nu.dd. printf("Ingresa un numero:\t "). . } 3-Se lee un número de máximo tres dígitos (verifique que efectivamente sea de máximo tres dígitos) y se debe determinar si es un número capicúa.aaaa). } else{} getch().mes:%d. #include #include int main () { int nu. mm = mm + 1.&nu).ano:%d". scanf("%d". printf("\nla fecha siguiente es:"). printf("\ndia:%d. } /// VERIFICAMOS SI ES EL ULTIMO DIA DEL AÑO else if (dd == ddmax && mm == 12) { dd = 1. } /// VERIFICAMOS SI ES EL ULTIMO DIA DE UN MES else if (dd == ddmax && mm != 12) { dd = 1. res. res = nu%10.mm. aaaa = aaaa. aaaa = aaaa + 1.ano:%d". Por ejemplo: 727. clrscr().mm. mm = mm.else{} /// CUALQUIER DIA DISTINTO A FIN DE MES O ANO if (dd < ddmax) { dd = dd + 1. numero.mes:%d. printf("\ndia:%d.mes:%d.ano:%d".mm. es decir. aaaa = aaaa. printf("\nla fecha siguiente es:"). printf("\nla fecha siguiente es:"). etc.dd. while (nu > 0) { capi = capi*10.aaaa). printf("\ndia:%d. 343. capi=0.aaaa).dd. que leído de izquierda a derecha es igual que leído de derecha a izquierda.

los de categoría 3. sueldo=sueldo+sub. } } if(ca==2) { des=(sueldo*DE)/100.000. Se quiere un algoritmo que permita determinar cuánto debe pagarse a un empleado si se conoce el número de horas que trabajó durante el mes y la categoría a la que pertenece. printf("su sueldo es:%d". los de categoría 2. $10.sueldo).nu = nu/10. scanf("%d". } 4-En una organización se tiene a los empleados agrupados por categoría.h> #include<stdlib. $7.sueldo. los de categoría 1 ganan $20. printf("\nmarque 2 categoria 2"). #include<stdio.2% por concepto de salud.ca.sub. if(sueldo<1000000) . scanf("%d". else printf("No es capicua "). int main() { printf("\ingrese numero de horas que trabaja"). se le da un subsidio del 15% sobre su salario mensual (sin descuentos). capi = res + capi.des. sueldo=(hora*20000)-des. printf("\nmarque 3 categoria 3"). printf("\nmarque 4 categoria 4"). getch().000. printf("\nmarque 1 categoria 1"). if(sueldo<1000000) { sub=(15*sueldo)/100.h> #define DE 7. } if (numero == capi) printf(" es capicua"). if(ca==1) { des=(sueldo*DE)/100.500. $15. sueldo=(hora*15000)-des.&ca). Se sabe que a todos se les descuenta un 7.phora.000. return(0).&hora). y si el salario total devengado (mensual) es menos de 1 ´000.2 int hora. printf("\ningreae la categoria a la que pertenece").000 y los de categoría 4.

sueldo=sueldo+sub. } } system("pause"). if(sueldo<1000000) { sub=(15*sueldo)/100.h> using namespace std. if(sueldo<1000000) { sub=(15*sueldo)/100. int ct. return 0. sueldo=sueldo+sub.sueldo). } } if (ca==3) { des=(sueldo*DE)/100. sueldo=(hora*10000)-des. } 5. sueldo=(hora*7500)-des.h> #include <conio. si el usuario logra ingresar imprimir el mensaje "Bienvenido". printf("su sueldo es:%d".sueldo). . #include <iostream> #include <math.sueldo). en caso contrario imprimir "Error clave" y el nivel del error.{ sub=(15*sueldo)/100. printf("su sueldo es:".Elabore un programa que tenga cuatro niveles de seguridad (documéntese sobre niveles de seguridad) para un programa. int main() { char ca [100]. printf("su sueldo es:%d".h> #include <stdio. } } if (ca==4) { des=(sueldo*DE)/100. sueldo=sueldo+sub. int ct1.

} if (cont == 3) { cout<<endl<<"Ultima oportunidad de ingresar contraseña correcta: "<<endl. if (ct==ct1) { sw=1. } } cin. int cont = 0. sw=1. } else { cont = cont + 1.get(). cout<<endl<<"Guardar una contraseña: ". cin>>ct1. while (sw == 0) { cout<<endl<<"Ingrese contraseña: ". } if (cont == 4) { cout<<endl<<"ERROR NIVEL DE ERROR: "<<cont.Escriba un programa para calcular si un número es primo o no. int lcont = strlen(ca). cout<<endl<<"Su cuenta ha sido bloqueada por seguridad ". 17 .int sw = 0. ct = atoi(ca). } 6. cout<<endl<<"Error en la contraseña : ". recuerde que los números primos son aquellos que solo son divisibles por la unidad y por ellos mismos: ejemplo 5. cin>>ca.get(). 11. cout<<endl<<"-----.BIENVENIDO ------". cout<<"Tiene 4 intentos despues se bloquera su cuenta". cin. cout<<endl<<"Intento No : "<<cont<<endl.

Lea los valores de los lados de un triángulo.Num.h> using namespace std. cin>>a. else printf("t%ld NO ES PRIMO .h> #include<stdlib. scanf("%ld". O ESCALENO) #include<iostream> #include<cmath> #include<stdlib. cin>>c.&Num). } system("pause"). int main() { cout<<"INGRESE EL LADO A DEL TRIANGULO"<<endl. if(Num== divisor) printf("t %ld es PRIMO n".divisor=2.Num). ISÓSCELES.#include<stdio. Detecte y muestre un mensaje correspondiente a su tipo (EQUILÁTERO.pues ES multiplo de %ld n". cout<<"iNGRESE EL LADO B DEL TRIANGULO"<<endl. int b. 7. while(divisor<Num) { while( Num % divisor != 0) divisor=divisor+1. return 0. break. int a. . if (a==b && b==c) { cout<<"TRIÁNGULO EQUILÁTERO"<<endl.h> int main() { long Num. } else { cout<<"TRIÁNGULO ESCALENO"<<endl. printf("\t Introducir el Numero = "). } else { if (a==b || b==c || a==c) { cout<<" TRIÁNGULO ISOCELES"<<endl.divisor). cout<<"INGRESE EL LADOC DEL TRIANGULO"<<endl. int c. cin>>b.

} } else { for(x=15. if(ne<0) { err: printf("Ha introducido un numero negativo.x. intonum: printf("Introduzca el numero entero positivo que desea convertir a binario:").&swi).x>=0.h> #include<stdlib. goto intonum. menor a 257 a sistema binario #include <stdio. printf("Este progrograma esta diseñado para convertir un numero entero positivo decimal a binario."). goto err. getch().swi. } else if(swi==2) { printf("fin").h> #include <conio.} } system("pause"). } 8. int ne. si desea intentar nuevamente presione 1 o si desea salir del programa presione 2\n"). scanf("%i". scanf("%i". printf("\n\nPara continuar con el programa presione ENTER").&ne). return 0.h> main() { float a[16].x=x-1) { if(ne<257) . } else { printf("Error de entrada").Elaborar un programa que convierta un número entero positivo. if(swi==1) { printf("\n").

h> int dia. printf("\nfebrero=2").x<=15. scanf("%d". scanf("%d". } 9. if(mes==4||mes==6||mes==9||mes==11) . printf("\nenero=1"). printf("\njunio=6"). int mes. día. printf("\ningrese el numero del año completo de nacimiento"). año) indicar cuantos días (exactos) han transcurrido desde ese año.h> #include<stdlib. printf("\nseptiembre=9"). } else { a[x]=0.a[x]). int ano. scanf("%d".0f".x++) { printf("%.Dada tu fecha de nacimiento (mes. int cad1. printf("\nabril=4"). } ne=ne/2. printf("\nnobiembre=11"). printf("\ndiciembre=12").&dia). printf("\nmarzo=3"). printf("\nagosto=8"). } } system("pause").&ano). int cad. return 0. int main() { printf("\ningrese el numero del dia de nacimiento"). printf("\ningrese el numero del mes de nacimiento"). #include<stdio. } for(x=0.{ a[x]=ne%2. printf("\nmayo=5").&mes). printf("\noctubre=10"). printf("\njulio=7").

el algoritmo debe pedir el número de partidas. printf("los dias vividos son:%d". /** Jugador 1 **/ int j2=0.h> int main() { int p=0.cad).h> #include <stdlib. cad=(2009-ano)*cad1. cad=(2009-ano)*cad1. /** Variable que almacena un número aleatorio entre 0 y 100 para el jugador 1 **/ int b=0. return 0. /** Número de partidas **/ int j1=0. } else { if (mes==1||mes==3||mes==5||mes==7||mes==8||mes==10||mes==12) cad1=(31-dia)+(30*4)+(31*6)+(28).{ cad1=(30-dia)+(30*3)+(31*7)+(28). cad=(2009-ano)*cad1. /** Variable que almacena el puntaje obtenido por el jugador 1 **/ int pj2=0. /** Variable que almacena el puntaje obtenido por el jugador 2 **/ srand(time(NULL)). printf("los dias vividos son:%d". (Use la función random. } 10.Elabore un programa que genere un número aleatorio y que les dé la posibilidad a dos jugadores de adivinar dicho número.cad). } system("pause"). intercalar los turnos para adivinar. El número debe estar entre 0-100. /** Número aleatorio que indica quién de los dos jugadores parte adivinando **/ int a=0. . printf("los dias vividos son:%d". /** Número aleatorio entre 0 y 100 que hay que adivinar **/ int i=0. } if(mes==2) { cad1=(28-dia)+(30*4)+(31*7). mostrar el ganador por partida y el ganador final. /** Variable que almacena un número aleatorio entre 0 y 100 para el jugador 2 **/ int pj1=0.cad). int s=0. /** Jugador 2 **/ int n=0.) #include <stdio.

if(a == n) { pj1 = pj1 + 1.i).pj1). i<=p. i++) { s = 1 + rand() % 2.pj1). s = 2. scanf("%d".pj2). } . } else { printf("\nGanador final: Jugador 2 con %d victorias\n". } } else /** Jugador 2 **/ { b = rand() % 101. break.i). s = 1. n = rand() % 101. } else if(pj1 == pj2) { printf("\nEmpate. Jugador 1 y 2 obtienen %d victorias cada uno\n". } } } } if (pj1 > pj2) { printf("\nGanador final: Jugador 1 con %d victorias\n". while(!0) { if(s == 1) /** Jugador 1 **/ { a = rand() % 101. printf("Jugador 1 gana la partida %d\n". break. printf("Jugador 2 gana la partida %d\n". if(b == n) { pj2 = pj2 + 1.printf("Partidas:").&p). for(i=1. no hay ganador.

nipc=0.return 0. float suma. float nipc. float vmv.h> using namespace std. float nipe. D y C). $2345. $3876. float vtpd. int VENTAS[200]. float vtpc. float ntp. el vendedor que más ventas realizó #include<iostream> #include<cmath> #include<stdlib. float vtpb. float vtpe. float ptv. vtpa=0. float A. int n. el promedio total de ventas. float nipb. float pmv. nipe=0. int main() { int nipa=0. float pmev. nipd=0. int c. float nipd. el menos vendido. el producto mas vendido. int d. float vtpa. . $1235 y $550) respectivamente. calcule el número individual y total de productos vendidos. int e. float a. si los precios de los productos son ($1000. las ventas totales por producto. C. } 11. int f. int b.Elabore un programa que lea las ventas de (n) número de vendedores. B. nipb=0. ntp=0. para los productos (A.

nipc=suma+d. vtpe=550*f. ptv=(vtpa+vtpb+vtpc+vtpd+vtpe)/5. ntp=suma+b+c+d+e+f. if (nipa>nipb && nipa>nipc && nipa>nipd && nipa>nipe) { cout<<"el producto mas vendido es el a"<<endl. suma=0. cin>>c. vtpd=1235*e. cout<<"cantidad del producto a vendida?"<<endl. cout<<"cantidad del producto c vendida?"<<endl. vmv=0. nipd=suma+e.vtpb=0. ptv=0. vtpb=2345*c. for (a=1. nipa=suma+b. a=0. vtpa=100*b. nipb=suma+c. nipe=suma+f. vtpd=0.a<=n. pmv=0. cin>>f. cout<<"ingrese la cantidad de vendedores que va a nalizar"<<endl. vtpe=0. cin>>n. . } else { if (nipd>nipa && nipd>nipb && nipd>nipc && nipd>nipe) { cout<<"el producto mas vendido es el d"<<endl. } else { if (nipb>nipa && nipb>nipc && nipb>nipd && nipb>nipe) { cout<<"el producto mas vendido es el b"<<endl. pmev=0. cout<<"cantidad del producto e vendida?"<<endl. } else { if (nipc>nipa && nipc>nipb && nipc>nipd && nipc>nipe) { cout<<"el producto mas vendido es el c"<<endl. cout<<"cantidad del producto b vendida?"<<endl. cout<<"cantidad del producto d vendida?"<<endl. cin>>d. vtpc=0. } else { if (nipe>nipa && nipe>nipb && nipe>nipc && nipe>nipd) { cout<<"el producto mas vendido es el e"<<endl.a++) { cout<<"vendedor"<<a<<endl. vtpc=3876*d. cin>>e. cin>>b.

cout<<"las ventas totales por producto a es:"<<vtpa<<endl. cout<<"las ventas totales por producto d es:"<<vtpd<<endl. } else { if (nipb<nipa && nipb<nipc && nipb<nipd && nipb<nipe) { cout<<"el producto mas vendido es el b"<<endl. } 13. cout<<"el numero total de productos e vendidos es:"<<ntp<<endl. cout<<"el numero de productos b vendidos es:"<<nipb<<endl. cout<<"el numero de productos d vendidos es:"<<nipd<<endl. permita la utilización de por lo menos cinco (5). cout<<"el numero de productos c vendidos es:"<<nipc<<endl. cout<<"el promedio total de ventas es:"<<ptv<<endl.h #include<iostream> #include<cmath> #include<stdlib. } else { if (nipe<nipa && nipe<nipb && nipe<nipc && nipe<nipd) { cout<<"el producto mas vendido es el e"<<endl. } else { if (nipd<nipa && nipd<nipb && nipd<nipc && nipd<nipe) { cout<<"el producto mas vendido es el d"<<endl.} } } } } if (nipa<nipb && nipa<nipc && nipa<nipd && nipa<nipe) { cout<<"el producto menos vendido es el a"<<endl. } } } } } } cout<<"el numero de productos a vendidos es:"<<nipa<<endl.Desarrolle un programa que mediante la construcción de un menú. funciones de la librería math. cout<<"las ventas totales por producto e es:"<<vtpe<<endl. #define SIN_TIPO float . system("pause"). return 0. cout<<"las ventas totales por producto b es:"<<vtpb<<endl. } else { if (nipc<nipa && nipc<nipb && nipc<nipd && nipc<nipe) { cout<<"el producto mas vendido es el c"<<endl.h> using namespace std. cout<<"el numero de productos e vendidos es:"<<nipe<<endl. cout<<"las ventas totales por producto c es:"<<vtpc<<endl.

float r.5)<<endl.Seno.Hallar Factorial"<<endl. cout<<"5 . ArcoTangente"<<endl. cout<<"Func Expon.Separar parte entera y decimal"<<endl. cout<<"1 . cout<<"9 . . case 2: if (n<=0) { cout<<"El numero debe ser mayor a cero!"<<endl. cout<<"Presione Enter para continuar"<<endl. cout<<"8 . case 3: cout<<"Turncar:"<<floor(n)<<endl.Raiz Cuadrada"<<endl.float salir. int opcion. cout<<"0 . Coseno. cout<<"2 .Valor Absoluto"<<endl. cout<<"Ingresar Numero:"<<endl. cout<<"3 . cout<<"4 . cout<<"Redondear:"<<ceil(n+.:"<<exp(n)<<endl.Lograritmo Natural. } else { cout<<"Log Nat. cin>>opcion. Redondear"<<endl. } break. cout<<"6 . string primo. cin>>n. cout<<"Coseno:"<<cos(n)<<endl.Ingresar Otro Numero"<<endl. float n. break. cout<<"ArcTangente:"<<atan(n)<<endl.:"<<log(n)<<endl. cout<<" "<<endl.Averiguar si es primo"<<endl.Truncar. switch (opcion) { case 1: cout<<"Seno:"<<sin(n)<<endl. Funcion Exponencial"<<endl.para Salir"<<endl. cin>>x. case 4: cout<<"Raiz Cuad. int main() { salir=0.:"<<sqrtf(n)<<endl. cout<<" "<<endl. float nu. float f. cout<<"7 . float x. break. do { cout<<" "<<endl.

} cout<<"Factorial:"<<r<<endl. } else { if (abs(n)>50) { cout<<"Resultado muy grande!"<<endl. } else { primo="Si". } if (n<0) { nu=n*-1. break. cout<<"Parte Decimal:"<<n-floor(n)<<endl.:"<<abs(n)<<endl. } } break. if (n/2==floor(n/2)) { primo="No". f=3. f=1. case 5: cout<<"Valor Abs. } else { r=1. case 7: if (n!=floor(n)) { cout<<"El numero debe ser entero!"<<endl. } f=f+1. while (f<=abs(n)) { if (n<0) { r=(-f)*r. } else { r=f*r. } nu=sqrtf(nu). . case 6: cout<<"Parte Entera:"<<floor(n)<<endl. } else { nu=n.break. case 8: if (n!=floor(n)) { cout<<"El numero debe ser entero!"<<endl. break.

default: cout<<"Opcion No Valida!"<<endl. break. } . system("pause"). cin>>n. } f=f+2. break. case 0: salir=1. break. } } while (salir==1). return 0.while (f<=nu && primo=="Si") { if (n/f==floor(n/f)) { primo="No". } if (primo=="No") { cout<<n<<"="<<f-2<<"x"<<n/(f-2)<<endl. case 9: cout<<"Ingrese Numero:"<<endl. } } break. } cout<<"Numero Primo:"<<primo<<endl. if (f==3) { f=4.