LABORATORIO PRÁCTICO

ALGORITMOS

PRESENTADO A:
ING.DIEGO FERNANDO MEDINA SOTO

PRESENTADO POR: ENRIQUE ANDRES PLATA
C.C. 11.367.343
GRUPO: 301303_12

UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA (UNAD)
FUNZA, NOVIEMBRE 2013

PRACTICA 1
1-determinar cuál es el cuadrado, de un determinado número

2-Elaborar un diagrama de flujo que permita determinar si un número es
Positivo o Negativo

3.-Ejercicio de conversión, desarrollar un diagrama, que perita ingresar una
cantidad en metros y la convierta a Centímetros, Kilómetros, Pies, pulgadas.

4-Leer una determinada temperatura en grados centígrados y convertirla a
Fahrenheit

6-Elabore un diagrama de flujo que teniendo como datos de entrada el radio y la altura de un cilindro calcule el área total y el volumen del cilindro . menor de 25 años.5. Realizar un diagrama que permita determinar si una persona es apta o no par prestar el servicio militar.-una persona es apta para prestar el servicio militar obligatorio (presente). nacionalidad Colombiana y género masculino. cuando: es mayor de 18 años.

7..Elaborar un diagrama de flujo.8% mensual. Realice un diagrama de flujo que permita determinar este monto 8.Una persona recibe un préstamo de un banco por un año y desea saber cuánto pagará de interés al terminar el préstamo si se sabe que el banco le cobra una tasa del 1. que permita ingresar 3 valores y los imprima en forma descendente .

.salario. Si la cantidad de horas trabajadas es mayor a 40 horas.horas_extras.horas_extras * tarifa_extra + 40 * tarifa fin_si imprimir: salario.tarifa si: horas_trabajadas <= 40 entonces salario <-.horas_trabajadas – 40 salario <-.PRACTICA 2 Teniendo como punto de partida los ejemplos propuestos en el módulo y consultas de las diferentes fuentes documentales ahí presentadas y apoyados con el tutor de prácticas.horas_trabajadas * tarifa si_no tarifa_extra <-.50 * tarifa horas_extras <-. variables: horas_trabajadas.tarifa_e inicio leer: horas_trabajadas. los cuales se deben llevar preparados y solucionados en papel para luego proceder a codificar en la Herramienta Pseint la que permite comprobar si el diagrama funciona de manera adecuada 1-A un trabajador le pagan según sus horas y una tarifa de pago por horas. cada estudiante en forma individual desarrollara los supuestos polémicos presentados para ser solucionados. La tarifa se incrementa en un 50% para las horas extras.tarifa. Calcular el salario del trabajador dadas las horas trabajadas y la tarifa.tarifa + 0.

minutos. notas_desaprobadas. Inicio valor_articulo=0. de acuerdo al reglamento UNAD. notas_aprobadas.fin 2-Dado un tiempo en segundos. Inicio notas[]. cantidad valor_total = valor_articulo * cantidad valor_a_pagar = valor_total * 1.00 pesos se debe realizar un descuento del 5%.segundos. El IVA es del 16% y si el precio bruto (precio venta más IVA) es mayor de 50.segundos inicio leer: tiempo_seg si minutos <-.tiempo_seg mod 60 fin_si imprimir: minutos. c) El promedio de notas. promedio.000. d) El promedio de notas aprobadas y desaprobadas. calcular los segundos restantes que le correspondan para convertirse exactamente en minutos.16 Si valor_a_pagar > 50000 entonces descuento = valor_a_pagar * 0.tiempo_seg div 60 entonces segundos <-. Fin 3-Dado N notas de un estudiante calcular: a) Cuantas notas tiene desaprobados. i Para i=0 / **/ 4-Se trata de escribir el algoritmo que permita emitir la factura correspondiente a una compra de un artículo determinado. del que se adquieren una o varias unidades. descuento=0. valor_total=0. cantidad=0.05 . valor_a_pagar=0 leer valor_articulo. variables: tiempo_seg. b) Cuantos aprobados.

inicio escriba("ingrese el numero que desea hacer tabla ").k. desarrollar la tabla de multiplicar de un determinado número (la tabla básica va de 1 a9). escriba("k. salario<-0 . lea(num)."+". Escribir ''. 10% a los que ganan entre 1 y dos salarios mínimos y 5% a quienes gana más de 3 salarios mínimos."=". escriba("k.valor_a_pagar = valor_a_pagar .descuento FinSi Imprimir valor_a_apagar Fin 5-Se desea desarrollar un algoritmo que permita.j."=".tabla). se debe desarrollar un algoritmo que permita mostrar las tablas del 1 al 9 Var k. inicio para(k=1 hasta 9)hacer para(j=1hasta 9)hacer tabla=k*j. para (k=1 hasta 9) hacer tabla =num* k."*". Var num. fin_para fin_para fin.tabla:entero.j. 7-Una empresa con 20 empleados desea saber cuántos ganan menos de un salario mínimo. Se deben realizar los cálculos. cuanto aumentará la nómina mensual si se hace incrementos así. fin_para fin 6-Variación del ejercicio anterior. además cual es el valor actual de la nómina de la empresa. teniendo en cuenta el valor del salario mínimo legal vigente Nomina_2 Escribir 'Programa de nomina empresa Aurora'. cuantos tienen un salario entre uno y dos salarios mínimos y cuantos ganan más de tres salarios mínimos. 20% a aquellos que gana menos de un salario mínimo.num. tabla).tabla:entero.

acu.acu. Si salario>0 & salario<=589163 Entonces acu<-salario*0. acu3<-acu3+1 FinSi suma<-suma+salario nn<-nn+acu an<-nn*100/suma-100 f<-nn-suma FinPara Escribir ''. Escribir ''. Si salario>=589164 & salario<=1178328 Entonces acu<-salario*0. Escribir 'El total de empleados que gana menos del mínimo es de: '. acu1<-acu1+1 Sino Escribir 'La cantidad de salario debe ser superior a 0'.i.10+salario Escribir 'El nuevo salario para el empleado '. .5+salario Escribir 'El nuevo salario para el empleado '.acu2. Si salario>1178328 Entonces acu<-salario*0. Escribir ''. Para i<-1 Hasta 20 Con Paso 1 Hacer Escribir 'Ingrese el salario del empleado '. acu2<-acu2+1 FinSi Escribir ''.i ' es: '.acu<-0 acu1<-0 acu2<-0 acu3<-0 suma<-0 an<-0 nn<-0 Escribir 'Ingrese el salario de cada empleado'.i ' es: '.i ' es: '. FinSi Escribir ''. Leer salario.acu.20+salario Escribir 'El nuevo salario para el empleado '. Escribir 'El total de empleados que ganan entre 1 y 2 salarios minímos es de: '.acu1. Escribir ''.

5. Escribir ''. Escribir ''. fin_para escriba (“el valor de la serie es:”. calcular n números de esta serie var a. c = 0. FinProceso 8-la serie Fibonacci es un ejercicio interesante.' pesos'. c. 13. b. 1. inicio a = 0. 8. para ( k = 0 hasta num ) hacer c = a + b. k. b = 1. y a partir de ahí se construye la serie ejemplo: 0. num: entero. 34. 1. el cual se construye a partir de los dos primeros números que son el 0 y 1. lea (num).Escribir 'El total de empleados que gana más de 2 salarios minímos es de: '. b = c.suma.1.f.acu3...'%'. 2.3). existen tres partidos Políticos aspirando con sus candidatos (1. Escribir 'El total de la nomina actual es de: '. Desarrollar un algoritmo que permita. fin 9-Para las elecciones presidenciales que se realizarán en Colombia. Escribir 'El incremento en pesos de la nomina mensualmente es de: '.55.an. 0. Escribir ''. 2. 21. 3. a = b. Escribir 'El incremento porcentual de la nomina mensualmente es de: '. c). Uno de estos ha decidido realizar una consulta (encuesta) a un cierto . escriba(“ingrese numero a calcular”).

y el costo del metro cuadrado. para determinar las preferencias de los electores A cada persona se le pregunta: Si va a votar. teniendo en cuenta. teniendo como datos la anchura y longitud en metros. En caso de que la respuesta se afirmativa. El algoritmo imprimirá la siguiente información:  ¿Cuál es el partido que está repuntando?  ¿cuál es % de abstención?  ¿Cuál es % a favor de cada partido. para llevar un control de la información y así obtener unos resultados con prontitud Nota: el dato partido solamente se lee si la persona entrevistada ha contestado que sí votará. Elaborar un algoritmo.número de personas. inicio Pedir el costo (C) pedir el precio del metro cuadrado (Pm2) pedir el ancho y largo del terreno en metros cuadrados (A. fin .L) multiplicar el numero de metros cuadrados del terreno por el precio por metro para sacar su costo total (C=Pm2*(A*L)) mostrar resultados (C). las entrevistas validas?  ¿cuál es el % de personas que SI votaran? 10-Hacer un algoritmo que calcule e imprima el costo de un terreno rectangular. se le preguntará por qué partido votará.

1) Hacer si (avi Mod 100) <> 0 o (avi Mod 400) = 0 Entonces da <.da + 30 sino da <.da + 29 sino da <.1) .da + 31 finsi FinSi FinPara da <.583 fue sábado y que desde entonces no se han producido modificaciones en el calendario.avi + 4 FinMientras para mi<.1584 Mientras avi <= (a . elaborar un algoritmo para calcular el día de la semana en que cayó o caerá una fecha cualquiera posterior al 1 de enero de 1.583.1 hasta m-1 Hacer si mi = 2 Entonces si (a Mod 4) = 0 y ((a Mod 100) <> 0 o (a Mod 400) = 0) entonces da <.11-Sabiendo que el día 1 de enero de 1. Proceso dia escribir 'Diganos la fecha y sabra que dia de la semana cayo o caera' escribir ' ' Escribir 'Digite el anio' Leer A Escribir 'Digite el numero del Mes' Leer M Escribir 'Digite el numero del dia' Leer D da<-(A . Nota: Un año se considera bisiesto cuando es divisible por 400 o bien es divisible por 4 pero no por 100.1583) * 365 avi <.da + (d .da + 28 finsi sino si mi = 4 O mi = 6 O mi = 9 O mi = 11 entonces da <.da + 1 FinSi avi <.

" FINSI si r = 5 entonces Escribir "Es jueves." FINSI si r = 4 entonces Escribir "Es miercoles." FINSI si r = 2 entonces Escribir "Es lunes." FINSI si r = 6 entonces Escribir "Es viernes." FINSI si r = 1 entonces Escribir "Es domingo." FINSI si r = 3 entonces Escribir "Es martes. inicio mientras número insuficiente de patatas peladas hacer si cesto no vacío entonces pelar una patata fin_si fin_mientras fin algoritmo pelar2 .da Mod 7 si r = 0 entonces Escribir "Es sabado. teniendo en cuenta que el cesto puede estar vacío en un momento dado." FINsi FinProceso 12.r <.Considérense tres soluciones al problema "Pelar un número suficiente de papas que hay en un cesto".

(Tenga en cuenta el cambio de minuto. día…) PRACTICA 3 Lenguaje de programación Teniendo como punto de partida los ejemplos propuestos en el módulo y consultas de las diferentes fuentes documentales ahí presentadas y apoyados con el tutor de prácticas. cada estudiante en forma individual desarrollara los supuestos polémicos presentados para ser solucionados.inicio mientras (número insuficiente de patatas peladas) o (cesto no vacío) hacer pelar una patata fin_mientras fin algoritmo pelar3 inicio si cesto no vacío entonces mientras número insuficiente de patatas peladas hacer pelar una patata fin_mientras si_no comprar una patata fin_si fin 13-Realizar un algoritmo que permita calcular la hora un segundo después de un valor dado. en los casos que ustedes crea necesarios . hora. los cuales se deben llevar preparados y solucionados en papel para luego proceder a codificar en con C# o C++ Para los siguientes ejercicios si se desarrollan en C++ debe Consultar la directiva de posicionamiento gotoxy(x. para darle ubicación y presentación a los programas.y).

aaaa. clrscr(). return(0).&aaaa). el primer número se envía de último. long numero.digito). el tercer número pasa a la segunda posición.mm. utilizando el siguiente criterio.h" #include "stdio.) #include "conio. } getch(). scanf("%d".ddmax.h" #include "stdlib. scanf("%d".bis. //verificar si el año es bisiesto if ((aaaa%4 == 0 && aaaa%100 != 0)||aaaa%400==0) { bis = 2. int digito. scanf("%d".&dd). printf("Introduzca dia (d):"). numero/=10.h" #include "conio. } else . printf("DIGITTE LOS CUATRO NUMEROS DE SU CONTRASENA\t "). se debe enviar como 8547 #include "stdio. while(numero>0){ digito=numero%10.h" int main() { clrscr(). (Tenga en cuenta los años bisiestos. de penúltimo.h" int main() { int dd. printf("Introduzca ano (aaaa):").&numero). el segundo. el último pasa a ser primero: ejemplo: Ejemplo: Sea 7458. mm.&mm). printf("%d". aaaa ) e imprimirla. printf("Introduzca mes (m):"). } 2-Escribir un programa para calcular la fecha del siguiente día a partir de una fecha digitada desde el teclado por el usuario ( dd.1-Un banco ha solicitado se diseñe un programa que permita encriptar la información de las contraseñas (4 números) digitada por teclado (como un único numero) hasta el servidor principal. scanf("%ld".

return 0. } else if ((mm==2)&&(bis==1)) { ddmax = 28. } else if (((mm==2)&&(bis==2))&&(dd>29)||mm>12) { printf("La fecha es invalida"). getch(). } . return 0. } else if ((mm==4||mm==6||mm==9||mm==11)&&(dd>30)||mm>12) { printf("La fecha es invalida"). } else if (((mm==2)&&(bis==1))&&(dd>28)||mm>12) { printf("La fecha es invalida").{ bis = 1. } else if (mm==4||mm==6||mm==9||mm==11) { ddmax = 30. return 0. } ///VERIFICARMOS SI LA FECHA QUE SE INGRESO ES VALIDA if ((mm==1||mm==3||mm==5||mm==7||mm ==8||mm==10|| mm==12)&&(dd>31)||mm>12) { printf("La fecha es invalida"). return 0. } else{} if ((mm==2)&&(bis==2)) { ddmax = 29. getch(). } else {} // maximo dias de cada mes if (mm==1||mm==3||mm==5||mm==7||mm ==8||mm==10||mm==12) { ddmax = 31. getch(). getch().

mes:%d.aaaa).aaaa). printf("\ndia:%d. scanf("%d".mm. aaaa = aaaa.mm. aaaa = aaaa. numero.dd.mm. #include #include int main () { int nu. printf("\nla fecha siguiente es:"). mm = mm. capi=0. printf("\nla fecha siguiente es:"). } else{} getch().ano:%d". printf("Ingresa un numero:\t "). printf("\ndia:%d. . res. } /// VERIFICAMOS SI ES EL ULTIMO DIA DEL AÑO else if (dd == ddmax && mm == 12) { dd = 1. mm = mm + 1.else{} /// CUALQUIER DIA DISTINTO A FIN DE MES O ANO if (dd < ddmax) { dd = dd + 1.ano:%d". numero = nu.mes:%d.mes:%d. } 3-Se lee un número de máximo tres dígitos (verifique que efectivamente sea de máximo tres dígitos) y se debe determinar si es un número capicúa. clrscr(). 343. res = nu%10.&nu). aaaa = aaaa + 1. Por ejemplo: 727.ano:%d". while (nu > 0) { capi = capi*10. que leído de izquierda a derecha es igual que leído de derecha a izquierda. printf("\ndia:%d. etc.aaaa). mm = 1. es decir.dd.dd. } /// VERIFICAMOS SI ES EL ULTIMO DIA DE UN MES else if (dd == ddmax && mm != 12) { dd = 1. printf("\nla fecha siguiente es:").

$15.ca.000. } } if(ca==2) { des=(sueldo*DE)/100. } 4-En una organización se tiene a los empleados agrupados por categoría. int main() { printf("\ingrese numero de horas que trabaja"). #include<stdio. printf("\ningreae la categoria a la que pertenece"). sueldo=sueldo+sub.&hora).500.&ca).2 int hora.h> #include<stdlib. return(0). scanf("%d". los de categoría 3. Se quiere un algoritmo que permita determinar cuánto debe pagarse a un empleado si se conoce el número de horas que trabajó durante el mes y la categoría a la que pertenece. los de categoría 1 ganan $20. los de categoría 2. printf("\nmarque 3 categoria 3"). sueldo=(hora*15000)-des.sueldo). scanf("%d". getch().sueldo. se le da un subsidio del 15% sobre su salario mensual (sin descuentos).nu = nu/10.h> #define DE 7.000 y los de categoría 4.000.000. $7. else printf("No es capicua "). y si el salario total devengado (mensual) es menos de 1 ´000. Se sabe que a todos se les descuenta un 7.2% por concepto de salud. printf("\nmarque 1 categoria 1"). if(sueldo<1000000) . if(sueldo<1000000) { sub=(15*sueldo)/100. sueldo=(hora*20000)-des.des.sub. capi = res + capi. if(ca==1) { des=(sueldo*DE)/100. printf("\nmarque 4 categoria 4"). $10.phora. } if (numero == capi) printf(" es capicua"). printf("\nmarque 2 categoria 2"). printf("su sueldo es:%d".

. return 0. sueldo=(hora*10000)-des. int main() { char ca [100].sueldo).Elabore un programa que tenga cuatro niveles de seguridad (documéntese sobre niveles de seguridad) para un programa.h> #include <stdio. sueldo=(hora*7500)-des. if(sueldo<1000000) { sub=(15*sueldo)/100. } } system("pause"). sueldo=sueldo+sub. printf("su sueldo es:%d". printf("su sueldo es:%d".h> using namespace std.h> #include <conio.sueldo). printf("su sueldo es:". } 5. sueldo=sueldo+sub. if(sueldo<1000000) { sub=(15*sueldo)/100. #include <iostream> #include <math. en caso contrario imprimir "Error clave" y el nivel del error. } } if (ca==4) { des=(sueldo*DE)/100.sueldo). si el usuario logra ingresar imprimir el mensaje "Bienvenido". } } if (ca==3) { des=(sueldo*DE)/100.{ sub=(15*sueldo)/100. int ct1. sueldo=sueldo+sub. int ct.

cout<<endl<<"-----.Escriba un programa para calcular si un número es primo o no. int cont = 0.get(). } 6. cout<<endl<<"Intento No : "<<cont<<endl. } else { cont = cont + 1. ct = atoi(ca). cin>>ct1. cout<<endl<<"Guardar una contraseña: ". 11. } if (cont == 4) { cout<<endl<<"ERROR NIVEL DE ERROR: "<<cont. cout<<endl<<"Error en la contraseña : ".int sw = 0.BIENVENIDO ------". sw=1. recuerde que los números primos son aquellos que solo son divisibles por la unidad y por ellos mismos: ejemplo 5. cout<<endl<<"Su cuenta ha sido bloqueada por seguridad ". if (ct==ct1) { sw=1. cout<<"Tiene 4 intentos despues se bloquera su cuenta".get(). } } cin. } if (cont == 3) { cout<<endl<<"Ultima oportunidad de ingresar contraseña correcta: "<<endl. 17 . cin>>ca. int lcont = strlen(ca). cin. while (sw == 0) { cout<<endl<<"Ingrese contraseña: ".

Lea los valores de los lados de un triángulo.h> using namespace std. int c. printf("\t Introducir el Numero = "). 7. Detecte y muestre un mensaje correspondiente a su tipo (EQUILÁTERO. ISÓSCELES. cin>>c.h> #include<stdlib. O ESCALENO) #include<iostream> #include<cmath> #include<stdlib. while(divisor<Num) { while( Num % divisor != 0) divisor=divisor+1. if (a==b && b==c) { cout<<"TRIÁNGULO EQUILÁTERO"<<endl.h> int main() { long Num. break. .pues ES multiplo de %ld n". } else { if (a==b || b==c || a==c) { cout<<" TRIÁNGULO ISOCELES"<<endl.Num. cin>>b. cin>>a. return 0.divisor). cout<<"INGRESE EL LADOC DEL TRIANGULO"<<endl. else printf("t%ld NO ES PRIMO . int b. } system("pause"). int main() { cout<<"INGRESE EL LADO A DEL TRIANGULO"<<endl.&Num). int a. } else { cout<<"TRIÁNGULO ESCALENO"<<endl. if(Num== divisor) printf("t %ld es PRIMO n". cout<<"iNGRESE EL LADO B DEL TRIANGULO"<<endl.divisor=2.Num).#include<stdio. scanf("%ld".

if(ne<0) { err: printf("Ha introducido un numero negativo.&ne). } else if(swi==2) { printf("fin"). if(swi==1) { printf("\n"). scanf("%i". int ne. intonum: printf("Introduzca el numero entero positivo que desea convertir a binario:"). } 8.h> #include <conio.swi. scanf("%i". goto intonum.} } system("pause"). menor a 257 a sistema binario #include <stdio.Elaborar un programa que convierta un número entero positivo. si desea intentar nuevamente presione 1 o si desea salir del programa presione 2\n").x=x-1) { if(ne<257) . } } else { for(x=15.x. printf("Este progrograma esta diseñado para convertir un numero entero positivo decimal a binario. goto err. getch().x>=0."). return 0.h> #include<stdlib.h> main() { float a[16]. } else { printf("Error de entrada"). printf("\n\nPara continuar con el programa presione ENTER").&swi).

printf("\nseptiembre=9"). int cad. return 0. int main() { printf("\ningrese el numero del dia de nacimiento").0f". } ne=ne/2. printf("\ningrese el numero del mes de nacimiento").a[x]).&dia). año) indicar cuantos días (exactos) han transcurrido desde ese año. } for(x=0.x++) { printf("%. printf("\nabril=4"). } else { a[x]=0. printf("\noctubre=10"). } } system("pause").&mes).x<=15. printf("\njulio=7"). if(mes==4||mes==6||mes==9||mes==11) . printf("\nagosto=8"). scanf("%d".Dada tu fecha de nacimiento (mes. printf("\nenero=1"). } 9. printf("\njunio=6").h> #include<stdlib.h> int dia. printf("\ndiciembre=12"). int ano. printf("\nnobiembre=11"). scanf("%d". día. printf("\nmarzo=3"). #include<stdio.&ano).{ a[x]=ne%2. int mes. printf("\ningrese el numero del año completo de nacimiento"). scanf("%d". printf("\nfebrero=2"). int cad1. printf("\nmayo=5").

El número debe estar entre 0-100. /** Número aleatorio que indica quién de los dos jugadores parte adivinando **/ int a=0.) #include <stdio.cad). int s=0. /** Variable que almacena el puntaje obtenido por el jugador 2 **/ srand(time(NULL)). cad=(2009-ano)*cad1. printf("los dias vividos son:%d". el algoritmo debe pedir el número de partidas.cad).h> #include <stdlib. intercalar los turnos para adivinar. /** Jugador 1 **/ int j2=0. printf("los dias vividos son:%d". /** Número de partidas **/ int j1=0. printf("los dias vividos son:%d".Elabore un programa que genere un número aleatorio y que les dé la posibilidad a dos jugadores de adivinar dicho número. . cad=(2009-ano)*cad1. return 0. /** Variable que almacena un número aleatorio entre 0 y 100 para el jugador 2 **/ int pj1=0. /** Jugador 2 **/ int n=0. /** Variable que almacena un número aleatorio entre 0 y 100 para el jugador 1 **/ int b=0. (Use la función random.cad). /** Variable que almacena el puntaje obtenido por el jugador 1 **/ int pj2=0. } system("pause").h> int main() { int p=0. /** Número aleatorio entre 0 y 100 que hay que adivinar **/ int i=0. cad=(2009-ano)*cad1. } if(mes==2) { cad1=(28-dia)+(30*4)+(31*7). } 10.{ cad1=(30-dia)+(30*3)+(31*7)+(28). } else { if (mes==1||mes==3||mes==5||mes==7||mes==8||mes==10||mes==12) cad1=(31-dia)+(30*4)+(31*6)+(28). mostrar el ganador por partida y el ganador final.

n = rand() % 101. break.pj2). } } else /** Jugador 2 **/ { b = rand() % 101. } else if(pj1 == pj2) { printf("\nEmpate.&p).i).pj1). printf("Jugador 1 gana la partida %d\n". Jugador 1 y 2 obtienen %d victorias cada uno\n". } } } } if (pj1 > pj2) { printf("\nGanador final: Jugador 1 con %d victorias\n". s = 2. scanf("%d". for(i=1. if(a == n) { pj1 = pj1 + 1. if(b == n) { pj2 = pj2 + 1.pj1). i<=p. s = 1. i++) { s = 1 + rand() % 2. no hay ganador. } . break. while(!0) { if(s == 1) /** Jugador 1 **/ { a = rand() % 101. printf("Jugador 2 gana la partida %d\n". } else { printf("\nGanador final: Jugador 2 con %d victorias\n".i).printf("Partidas:").

float vtpa. float nipc. float ptv. int n. $2345. int d. } 11. int c. float pmv. float suma. D y C). int e. el promedio total de ventas. int main() { int nipa=0. float nipd. C.return 0. float vmv. las ventas totales por producto. float ntp. float nipe.Elabore un programa que lea las ventas de (n) número de vendedores.h> using namespace std. el menos vendido. calcule el número individual y total de productos vendidos. nipe=0. int VENTAS[200]. si los precios de los productos son ($1000. nipb=0. nipd=0. ntp=0. float a. vtpa=0. el vendedor que más ventas realizó #include<iostream> #include<cmath> #include<stdlib. int b. para los productos (A. $3876. nipc=0. float nipb. $1235 y $550) respectivamente. float vtpd. float pmev. float vtpe. B. float vtpc. . int f. float A. el producto mas vendido. float vtpb.

cout<<"cantidad del producto c vendida?"<<endl. a=0. cout<<"cantidad del producto b vendida?"<<endl. ptv=0. } else { if (nipb>nipa && nipb>nipc && nipb>nipd && nipb>nipe) { cout<<"el producto mas vendido es el b"<<endl. pmev=0. cin>>n.vtpb=0.a<=n. cout<<"cantidad del producto d vendida?"<<endl. } else { if (nipd>nipa && nipd>nipb && nipd>nipc && nipd>nipe) { cout<<"el producto mas vendido es el d"<<endl. vtpe=0. vtpb=2345*c. nipa=suma+b. cout<<"cantidad del producto e vendida?"<<endl. ptv=(vtpa+vtpb+vtpc+vtpd+vtpe)/5. vtpa=100*b. nipe=suma+f. ntp=suma+b+c+d+e+f. vtpe=550*f. if (nipa>nipb && nipa>nipc && nipa>nipd && nipa>nipe) { cout<<"el producto mas vendido es el a"<<endl. cin>>c. cin>>e. for (a=1. cout<<"cantidad del producto a vendida?"<<endl. vtpd=1235*e. vmv=0. cin>>b. suma=0. cin>>d. cout<<"ingrese la cantidad de vendedores que va a nalizar"<<endl. } else { if (nipe>nipa && nipe>nipb && nipe>nipc && nipe>nipd) { cout<<"el producto mas vendido es el e"<<endl. .a++) { cout<<"vendedor"<<a<<endl. nipc=suma+d. pmv=0. vtpc=3876*d. } else { if (nipc>nipa && nipc>nipb && nipc>nipd && nipc>nipe) { cout<<"el producto mas vendido es el c"<<endl. vtpd=0. nipb=suma+c. nipd=suma+e. cin>>f. vtpc=0.

cout<<"el numero total de productos e vendidos es:"<<ntp<<endl.} } } } } if (nipa<nipb && nipa<nipc && nipa<nipd && nipa<nipe) { cout<<"el producto menos vendido es el a"<<endl. return 0. cout<<"el numero de productos e vendidos es:"<<nipe<<endl. system("pause"). cout<<"las ventas totales por producto d es:"<<vtpd<<endl. cout<<"las ventas totales por producto c es:"<<vtpc<<endl. cout<<"el numero de productos c vendidos es:"<<nipc<<endl. permita la utilización de por lo menos cinco (5).h #include<iostream> #include<cmath> #include<stdlib. cout<<"el promedio total de ventas es:"<<ptv<<endl. cout<<"el numero de productos d vendidos es:"<<nipd<<endl. cout<<"las ventas totales por producto a es:"<<vtpa<<endl. cout<<"las ventas totales por producto e es:"<<vtpe<<endl.Desarrolle un programa que mediante la construcción de un menú. #define SIN_TIPO float . } 13. cout<<"el numero de productos b vendidos es:"<<nipb<<endl. } else { if (nipb<nipa && nipb<nipc && nipb<nipd && nipb<nipe) { cout<<"el producto mas vendido es el b"<<endl. } else { if (nipd<nipa && nipd<nipb && nipd<nipc && nipd<nipe) { cout<<"el producto mas vendido es el d"<<endl. } else { if (nipe<nipa && nipe<nipb && nipe<nipc && nipe<nipd) { cout<<"el producto mas vendido es el e"<<endl. } } } } } } cout<<"el numero de productos a vendidos es:"<<nipa<<endl. } else { if (nipc<nipa && nipc<nipb && nipc<nipd && nipc<nipe) { cout<<"el producto mas vendido es el c"<<endl. funciones de la librería math. cout<<"las ventas totales por producto b es:"<<vtpb<<endl.h> using namespace std.

do { cout<<" "<<endl. cin>>opcion. case 3: cout<<"Turncar:"<<floor(n)<<endl. Funcion Exponencial"<<endl. cin>>x. break. int opcion. cout<<"1 . } break. int main() { salir=0. cout<<"5 . cout<<"2 . float f. switch (opcion) { case 1: cout<<"Seno:"<<sin(n)<<endl. } else { cout<<"Log Nat.:"<<log(n)<<endl.Ingresar Otro Numero"<<endl. ArcoTangente"<<endl.Lograritmo Natural. cout<<"ArcTangente:"<<atan(n)<<endl. cout<<"6 . Redondear"<<endl. cout<<"4 . case 4: cout<<"Raiz Cuad. float x. cout<<"7 . break.para Salir"<<endl. float nu. cout<<"Ingresar Numero:"<<endl. cout<<" "<<endl. case 2: if (n<=0) { cout<<"El numero debe ser mayor a cero!"<<endl.float salir. string primo. Coseno. . cout<<" "<<endl.Hallar Factorial"<<endl.Valor Absoluto"<<endl. cin>>n. cout<<"8 . cout<<"Func Expon. cout<<"3 .Seno. cout<<"Presione Enter para continuar"<<endl. cout<<"Coseno:"<<cos(n)<<endl.Separar parte entera y decimal"<<endl.Truncar. cout<<"9 .Raiz Cuadrada"<<endl.:"<<sqrtf(n)<<endl. float n. cout<<"0 .:"<<exp(n)<<endl. cout<<"Redondear:"<<ceil(n+. float r.Averiguar si es primo"<<endl.5)<<endl.

break. } else { primo="Si". f=1. f=3.break. cout<<"Parte Decimal:"<<n-floor(n)<<endl. } else { if (abs(n)>50) { cout<<"Resultado muy grande!"<<endl. . } nu=sqrtf(nu). } else { nu=n. } else { r=1. while (f<=abs(n)) { if (n<0) { r=(-f)*r. } if (n<0) { nu=n*-1. } } break. } cout<<"Factorial:"<<r<<endl. } else { r=f*r. if (n/2==floor(n/2)) { primo="No". break. } f=f+1. case 8: if (n!=floor(n)) { cout<<"El numero debe ser entero!"<<endl. case 7: if (n!=floor(n)) { cout<<"El numero debe ser entero!"<<endl.:"<<abs(n)<<endl. case 5: cout<<"Valor Abs. case 6: cout<<"Parte Entera:"<<floor(n)<<endl.

break. cin>>n. } cout<<"Numero Primo:"<<primo<<endl. } if (primo=="No") { cout<<n<<"="<<f-2<<"x"<<n/(f-2)<<endl. case 9: cout<<"Ingrese Numero:"<<endl. system("pause"). } } while (salir==1). } } break. case 0: salir=1. return 0. } . if (f==3) { f=4. break. default: cout<<"Opcion No Valida!"<<endl.while (f<=nu && primo=="Si") { if (n/f==floor(n/f)) { primo="No". break. } f=f+2.