LABORATORIO PRÁCTICO

ALGORITMOS

PRESENTADO A:
ING.DIEGO FERNANDO MEDINA SOTO

PRESENTADO POR: ENRIQUE ANDRES PLATA
C.C. 11.367.343
GRUPO: 301303_12

UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA (UNAD)
FUNZA, NOVIEMBRE 2013

PRACTICA 1
1-determinar cuál es el cuadrado, de un determinado número

2-Elaborar un diagrama de flujo que permita determinar si un número es
Positivo o Negativo

3.-Ejercicio de conversión, desarrollar un diagrama, que perita ingresar una
cantidad en metros y la convierta a Centímetros, Kilómetros, Pies, pulgadas.

4-Leer una determinada temperatura en grados centígrados y convertirla a
Fahrenheit

Realizar un diagrama que permita determinar si una persona es apta o no par prestar el servicio militar. menor de 25 años.-una persona es apta para prestar el servicio militar obligatorio (presente). nacionalidad Colombiana y género masculino. cuando: es mayor de 18 años.5. 6-Elabore un diagrama de flujo que teniendo como datos de entrada el radio y la altura de un cilindro calcule el área total y el volumen del cilindro .

Realice un diagrama de flujo que permita determinar este monto 8. que permita ingresar 3 valores y los imprima en forma descendente .Una persona recibe un préstamo de un banco por un año y desea saber cuánto pagará de interés al terminar el préstamo si se sabe que el banco le cobra una tasa del 1.8% mensual.Elaborar un diagrama de flujo..7.

horas_extras.horas_trabajadas * tarifa si_no tarifa_extra <-. Si la cantidad de horas trabajadas es mayor a 40 horas.horas_extras * tarifa_extra + 40 * tarifa fin_si imprimir: salario.50 * tarifa horas_extras <-.horas_trabajadas – 40 salario <-. Calcular el salario del trabajador dadas las horas trabajadas y la tarifa.tarifa + 0. . variables: horas_trabajadas. cada estudiante en forma individual desarrollara los supuestos polémicos presentados para ser solucionados.PRACTICA 2 Teniendo como punto de partida los ejemplos propuestos en el módulo y consultas de las diferentes fuentes documentales ahí presentadas y apoyados con el tutor de prácticas.tarifa si: horas_trabajadas <= 40 entonces salario <-. los cuales se deben llevar preparados y solucionados en papel para luego proceder a codificar en la Herramienta Pseint la que permite comprobar si el diagrama funciona de manera adecuada 1-A un trabajador le pagan según sus horas y una tarifa de pago por horas.salario. La tarifa se incrementa en un 50% para las horas extras.tarifa_e inicio leer: horas_trabajadas.tarifa.

descuento=0. El IVA es del 16% y si el precio bruto (precio venta más IVA) es mayor de 50. promedio.minutos.16 Si valor_a_pagar > 50000 entonces descuento = valor_a_pagar * 0. del que se adquieren una o varias unidades.00 pesos se debe realizar un descuento del 5%.000. cantidad=0. de acuerdo al reglamento UNAD. d) El promedio de notas aprobadas y desaprobadas.05 . notas_aprobadas.tiempo_seg div 60 entonces segundos <-.fin 2-Dado un tiempo en segundos. cantidad valor_total = valor_articulo * cantidad valor_a_pagar = valor_total * 1. notas_desaprobadas. valor_total=0. variables: tiempo_seg.segundos.segundos inicio leer: tiempo_seg si minutos <-. Inicio valor_articulo=0. Fin 3-Dado N notas de un estudiante calcular: a) Cuantas notas tiene desaprobados. Inicio notas[]. i Para i=0 / **/ 4-Se trata de escribir el algoritmo que permita emitir la factura correspondiente a una compra de un artículo determinado.tiempo_seg mod 60 fin_si imprimir: minutos. c) El promedio de notas. calcular los segundos restantes que le correspondan para convertirse exactamente en minutos. b) Cuantos aprobados. valor_a_pagar=0 leer valor_articulo.

cuantos tienen un salario entre uno y dos salarios mínimos y cuantos ganan más de tres salarios mínimos.descuento FinSi Imprimir valor_a_apagar Fin 5-Se desea desarrollar un algoritmo que permita. fin_para fin 6-Variación del ejercicio anterior. cuanto aumentará la nómina mensual si se hace incrementos así.j."=". lea(num). fin_para fin_para fin. teniendo en cuenta el valor del salario mínimo legal vigente Nomina_2 Escribir 'Programa de nomina empresa Aurora'. Se deben realizar los cálculos. desarrollar la tabla de multiplicar de un determinado número (la tabla básica va de 1 a9).valor_a_pagar = valor_a_pagar . para (k=1 hasta 9) hacer tabla =num* k.tabla)."*". se debe desarrollar un algoritmo que permita mostrar las tablas del 1 al 9 Var k. escriba("k. inicio escriba("ingrese el numero que desea hacer tabla "). Var num. además cual es el valor actual de la nómina de la empresa. salario<-0 . 20% a aquellos que gana menos de un salario mínimo. Escribir ''. escriba("k. 10% a los que ganan entre 1 y dos salarios mínimos y 5% a quienes gana más de 3 salarios mínimos.tabla:entero.j. 7-Una empresa con 20 empleados desea saber cuántos ganan menos de un salario mínimo. tabla).num.tabla:entero. inicio para(k=1 hasta 9)hacer para(j=1hasta 9)hacer tabla=k*j.k."+"."=".

Si salario>=589164 & salario<=1178328 Entonces acu<-salario*0. Escribir ''. Escribir ''.i ' es: '.10+salario Escribir 'El nuevo salario para el empleado '. FinSi Escribir ''. Escribir 'El total de empleados que gana menos del mínimo es de: '.acu1. acu1<-acu1+1 Sino Escribir 'La cantidad de salario debe ser superior a 0'. Si salario>0 & salario<=589163 Entonces acu<-salario*0. Leer salario.acu.5+salario Escribir 'El nuevo salario para el empleado '. . Escribir 'El total de empleados que ganan entre 1 y 2 salarios minímos es de: '. Si salario>1178328 Entonces acu<-salario*0. acu2<-acu2+1 FinSi Escribir ''.20+salario Escribir 'El nuevo salario para el empleado '.acu2.i ' es: '.i ' es: '. Escribir ''.acu. Para i<-1 Hasta 20 Con Paso 1 Hacer Escribir 'Ingrese el salario del empleado '.i. acu3<-acu3+1 FinSi suma<-suma+salario nn<-nn+acu an<-nn*100/suma-100 f<-nn-suma FinPara Escribir ''.acu<-0 acu1<-0 acu2<-0 acu3<-0 suma<-0 an<-0 nn<-0 Escribir 'Ingrese el salario de cada empleado'.acu.

suma. calcular n números de esta serie var a. 0. Escribir ''. k. b.f. y a partir de ahí se construye la serie ejemplo: 0. num: entero. lea (num).1.Escribir 'El total de empleados que gana más de 2 salarios minímos es de: '. FinProceso 8-la serie Fibonacci es un ejercicio interesante.3). Escribir 'El incremento en pesos de la nomina mensualmente es de: '. a = b. Uno de estos ha decidido realizar una consulta (encuesta) a un cierto . fin 9-Para las elecciones presidenciales que se realizarán en Colombia. Escribir ''. c = 0. c. 5. para ( k = 0 hasta num ) hacer c = a + b.' pesos'. b = c. Escribir 'El total de la nomina actual es de: '. 13. el cual se construye a partir de los dos primeros números que son el 0 y 1. inicio a = 0.. 1. 8. Desarrollar un algoritmo que permita. existen tres partidos Políticos aspirando con sus candidatos (1..'%'.an. fin_para escriba (“el valor de la serie es:”. 1.55. b = 1. 2. c). 3. escriba(“ingrese numero a calcular”). 2. Escribir ''. 21. 34. Escribir 'El incremento porcentual de la nomina mensualmente es de: '.acu3.

teniendo en cuenta. inicio Pedir el costo (C) pedir el precio del metro cuadrado (Pm2) pedir el ancho y largo del terreno en metros cuadrados (A. teniendo como datos la anchura y longitud en metros.L) multiplicar el numero de metros cuadrados del terreno por el precio por metro para sacar su costo total (C=Pm2*(A*L)) mostrar resultados (C). El algoritmo imprimirá la siguiente información:  ¿Cuál es el partido que está repuntando?  ¿cuál es % de abstención?  ¿Cuál es % a favor de cada partido. y el costo del metro cuadrado. para llevar un control de la información y así obtener unos resultados con prontitud Nota: el dato partido solamente se lee si la persona entrevistada ha contestado que sí votará. se le preguntará por qué partido votará. Elaborar un algoritmo.número de personas. En caso de que la respuesta se afirmativa. las entrevistas validas?  ¿cuál es el % de personas que SI votaran? 10-Hacer un algoritmo que calcule e imprima el costo de un terreno rectangular. para determinar las preferencias de los electores A cada persona se le pregunta: Si va a votar. fin .

avi + 4 FinMientras para mi<.583.1584 Mientras avi <= (a .da + 31 finsi FinSi FinPara da <.da + 1 FinSi avi <.da + 30 sino da <. Proceso dia escribir 'Diganos la fecha y sabra que dia de la semana cayo o caera' escribir ' ' Escribir 'Digite el anio' Leer A Escribir 'Digite el numero del Mes' Leer M Escribir 'Digite el numero del dia' Leer D da<-(A .11-Sabiendo que el día 1 de enero de 1.1) .1 hasta m-1 Hacer si mi = 2 Entonces si (a Mod 4) = 0 y ((a Mod 100) <> 0 o (a Mod 400) = 0) entonces da <. elaborar un algoritmo para calcular el día de la semana en que cayó o caerá una fecha cualquiera posterior al 1 de enero de 1.1) Hacer si (avi Mod 100) <> 0 o (avi Mod 400) = 0 Entonces da <.1583) * 365 avi <.da + (d .da + 29 sino da <. Nota: Un año se considera bisiesto cuando es divisible por 400 o bien es divisible por 4 pero no por 100.da + 28 finsi sino si mi = 4 O mi = 6 O mi = 9 O mi = 11 entonces da <.583 fue sábado y que desde entonces no se han producido modificaciones en el calendario.

teniendo en cuenta que el cesto puede estar vacío en un momento dado. inicio mientras número insuficiente de patatas peladas hacer si cesto no vacío entonces pelar una patata fin_si fin_mientras fin algoritmo pelar2 ." FINSI si r = 1 entonces Escribir "Es domingo." FINSI si r = 6 entonces Escribir "Es viernes." FINSI si r = 5 entonces Escribir "Es jueves." FINSI si r = 2 entonces Escribir "Es lunes." FINSI si r = 4 entonces Escribir "Es miercoles." FINsi FinProceso 12.r <.da Mod 7 si r = 0 entonces Escribir "Es sabado.Considérense tres soluciones al problema "Pelar un número suficiente de papas que hay en un cesto"." FINSI si r = 3 entonces Escribir "Es martes.

inicio mientras (número insuficiente de patatas peladas) o (cesto no vacío) hacer pelar una patata fin_mientras fin algoritmo pelar3 inicio si cesto no vacío entonces mientras número insuficiente de patatas peladas hacer pelar una patata fin_mientras si_no comprar una patata fin_si fin 13-Realizar un algoritmo que permita calcular la hora un segundo después de un valor dado.y). (Tenga en cuenta el cambio de minuto. para darle ubicación y presentación a los programas. los cuales se deben llevar preparados y solucionados en papel para luego proceder a codificar en con C# o C++ Para los siguientes ejercicios si se desarrollan en C++ debe Consultar la directiva de posicionamiento gotoxy(x. hora. día…) PRACTICA 3 Lenguaje de programación Teniendo como punto de partida los ejemplos propuestos en el módulo y consultas de las diferentes fuentes documentales ahí presentadas y apoyados con el tutor de prácticas. en los casos que ustedes crea necesarios . cada estudiante en forma individual desarrollara los supuestos polémicos presentados para ser solucionados.

printf("Introduzca dia (d):"). el tercer número pasa a la segunda posición. el primer número se envía de último. aaaa ) e imprimirla.1-Un banco ha solicitado se diseñe un programa que permita encriptar la información de las contraseñas (4 números) digitada por teclado (como un único numero) hasta el servidor principal.&mm).h" #include "conio. int digito.aaaa. el segundo. printf("DIGITTE LOS CUATRO NUMEROS DE SU CONTRASENA\t "). de penúltimo. } else . while(numero>0){ digito=numero%10. scanf("%ld". se debe enviar como 8547 #include "stdio.h" int main() { clrscr().h" #include "stdlib. numero/=10. long numero.) #include "conio. printf("Introduzca ano (aaaa):"). //verificar si el año es bisiesto if ((aaaa%4 == 0 && aaaa%100 != 0)||aaaa%400==0) { bis = 2. clrscr(). (Tenga en cuenta los años bisiestos.h" #include "stdio. utilizando el siguiente criterio. mm.digito).&numero). printf("Introduzca mes (m):"). return(0). printf("%d".bis.ddmax. scanf("%d".&aaaa). el último pasa a ser primero: ejemplo: Ejemplo: Sea 7458. } 2-Escribir un programa para calcular la fecha del siguiente día a partir de una fecha digitada desde el teclado por el usuario ( dd. scanf("%d". } getch().&dd).mm.h" int main() { int dd. scanf("%d".

{ bis = 1. getch(). return 0. } else if ((mm==4||mm==6||mm==9||mm==11)&&(dd>30)||mm>12) { printf("La fecha es invalida"). } else if ((mm==2)&&(bis==1)) { ddmax = 28. return 0. } else if (mm==4||mm==6||mm==9||mm==11) { ddmax = 30. } ///VERIFICARMOS SI LA FECHA QUE SE INGRESO ES VALIDA if ((mm==1||mm==3||mm==5||mm==7||mm ==8||mm==10|| mm==12)&&(dd>31)||mm>12) { printf("La fecha es invalida"). getch(). } else {} // maximo dias de cada mes if (mm==1||mm==3||mm==5||mm==7||mm ==8||mm==10||mm==12) { ddmax = 31. } . return 0. getch(). } else{} if ((mm==2)&&(bis==2)) { ddmax = 29. return 0. } else if (((mm==2)&&(bis==2))&&(dd>29)||mm>12) { printf("La fecha es invalida"). } else if (((mm==2)&&(bis==1))&&(dd>28)||mm>12) { printf("La fecha es invalida"). getch().

ano:%d". aaaa = aaaa + 1. capi=0. aaaa = aaaa. clrscr().aaaa).ano:%d". numero = nu. Por ejemplo: 727.&nu). printf("Ingresa un numero:\t ").mes:%d. printf("\ndia:%d.dd.dd.mm.mm. printf("\nla fecha siguiente es:"). etc. } 3-Se lee un número de máximo tres dígitos (verifique que efectivamente sea de máximo tres dígitos) y se debe determinar si es un número capicúa.dd.aaaa). . while (nu > 0) { capi = capi*10. mm = mm. printf("\nla fecha siguiente es:"). } /// VERIFICAMOS SI ES EL ULTIMO DIA DE UN MES else if (dd == ddmax && mm != 12) { dd = 1. printf("\nla fecha siguiente es:"). res. numero. que leído de izquierda a derecha es igual que leído de derecha a izquierda.mes:%d.ano:%d". #include #include int main () { int nu.else{} /// CUALQUIER DIA DISTINTO A FIN DE MES O ANO if (dd < ddmax) { dd = dd + 1.aaaa). 343. aaaa = aaaa. es decir. mm = 1. printf("\ndia:%d. res = nu%10.mes:%d. printf("\ndia:%d. } /// VERIFICAMOS SI ES EL ULTIMO DIA DEL AÑO else if (dd == ddmax && mm == 12) { dd = 1.mm. } else{} getch(). scanf("%d". mm = mm + 1.

nu = nu/10. int main() { printf("\ingrese numero de horas que trabaja"). scanf("%d". printf("\nmarque 1 categoria 1"). sueldo=(hora*15000)-des. se le da un subsidio del 15% sobre su salario mensual (sin descuentos). } } if(ca==2) { des=(sueldo*DE)/100.sueldo).&ca). sueldo=(hora*20000)-des. } if (numero == capi) printf(" es capicua"). } 4-En una organización se tiene a los empleados agrupados por categoría.ca. y si el salario total devengado (mensual) es menos de 1 ´000. if(sueldo<1000000) . printf("\nmarque 3 categoria 3").000. #include<stdio. $15. printf("\nmarque 4 categoria 4"). return(0). los de categoría 1 ganan $20.000 y los de categoría 4.phora. los de categoría 3.des. else printf("No es capicua "). if(ca==1) { des=(sueldo*DE)/100.h> #include<stdlib.000. if(sueldo<1000000) { sub=(15*sueldo)/100. los de categoría 2. getch(). scanf("%d".&hora). Se sabe que a todos se les descuenta un 7. $7.sub. printf("\nmarque 2 categoria 2").500.sueldo.h> #define DE 7.2 int hora. printf("\ningreae la categoria a la que pertenece").2% por concepto de salud. $10. Se quiere un algoritmo que permita determinar cuánto debe pagarse a un empleado si se conoce el número de horas que trabajó durante el mes y la categoría a la que pertenece. capi = res + capi. sueldo=sueldo+sub.000. printf("su sueldo es:%d".

} } if (ca==3) { des=(sueldo*DE)/100.sueldo). } } system("pause"). en caso contrario imprimir "Error clave" y el nivel del error. int ct. return 0. printf("su sueldo es:%d".h> #include <conio. sueldo=sueldo+sub. sueldo=sueldo+sub. sueldo=(hora*7500)-des. si el usuario logra ingresar imprimir el mensaje "Bienvenido". } } if (ca==4) { des=(sueldo*DE)/100. } 5. int ct1.{ sub=(15*sueldo)/100.h> using namespace std.h> #include <stdio. sueldo=sueldo+sub. if(sueldo<1000000) { sub=(15*sueldo)/100. printf("su sueldo es:%d". printf("su sueldo es:". . sueldo=(hora*10000)-des. int main() { char ca [100]. if(sueldo<1000000) { sub=(15*sueldo)/100.sueldo).sueldo). #include <iostream> #include <math.Elabore un programa que tenga cuatro niveles de seguridad (documéntese sobre niveles de seguridad) para un programa.

recuerde que los números primos son aquellos que solo son divisibles por la unidad y por ellos mismos: ejemplo 5. cin>>ct1. cout<<endl<<"Error en la contraseña : ".int sw = 0.BIENVENIDO ------". cin. } if (cont == 4) { cout<<endl<<"ERROR NIVEL DE ERROR: "<<cont. if (ct==ct1) { sw=1. cout<<endl<<"Guardar una contraseña: ". } if (cont == 3) { cout<<endl<<"Ultima oportunidad de ingresar contraseña correcta: "<<endl.get(). while (sw == 0) { cout<<endl<<"Ingrese contraseña: ". } else { cont = cont + 1. int cont = 0. ct = atoi(ca). cout<<"Tiene 4 intentos despues se bloquera su cuenta". cin>>ca. 11. cout<<endl<<"Intento No : "<<cont<<endl. } } cin. cout<<endl<<"Su cuenta ha sido bloqueada por seguridad ".Escriba un programa para calcular si un número es primo o no. sw=1. 17 .get(). cout<<endl<<"-----. } 6. int lcont = strlen(ca).

divisor=2. 7. else printf("t%ld NO ES PRIMO . } else { if (a==b || b==c || a==c) { cout<<" TRIÁNGULO ISOCELES"<<endl. } system("pause"). while(divisor<Num) { while( Num % divisor != 0) divisor=divisor+1. int a. O ESCALENO) #include<iostream> #include<cmath> #include<stdlib. if (a==b && b==c) { cout<<"TRIÁNGULO EQUILÁTERO"<<endl. return 0. int main() { cout<<"INGRESE EL LADO A DEL TRIANGULO"<<endl.Lea los valores de los lados de un triángulo. cin>>c.Num). } else { cout<<"TRIÁNGULO ESCALENO"<<endl.pues ES multiplo de %ld n". cin>>b. cout<<"iNGRESE EL LADO B DEL TRIANGULO"<<endl.h> int main() { long Num.divisor). scanf("%ld". int c.Num. int b. . Detecte y muestre un mensaje correspondiente a su tipo (EQUILÁTERO. cout<<"INGRESE EL LADOC DEL TRIANGULO"<<endl.h> #include<stdlib. if(Num== divisor) printf("t %ld es PRIMO n". break. cin>>a. printf("\t Introducir el Numero = "). ISÓSCELES.&Num).#include<stdio.h> using namespace std.

swi. } else { printf("Error de entrada").x>=0. scanf("%i".h> main() { float a[16]. if(swi==1) { printf("\n").&swi). scanf("%i". } else if(swi==2) { printf("fin"). return 0. } } else { for(x=15. printf("Este progrograma esta diseñado para convertir un numero entero positivo decimal a binario.x=x-1) { if(ne<257) ."). int ne.x. menor a 257 a sistema binario #include <stdio.Elaborar un programa que convierta un número entero positivo. goto err.&ne). getch(). printf("\n\nPara continuar con el programa presione ENTER").h> #include<stdlib. intonum: printf("Introduzca el numero entero positivo que desea convertir a binario:"). if(ne<0) { err: printf("Ha introducido un numero negativo.h> #include <conio. } 8.} } system("pause"). goto intonum. si desea intentar nuevamente presione 1 o si desea salir del programa presione 2\n").

0f". return 0. printf("\nseptiembre=9"). printf("\ningrese el numero del mes de nacimiento").x++) { printf("%. printf("\nenero=1"). int cad1.h> #include<stdlib. scanf("%d". printf("\noctubre=10"). printf("\njunio=6"). if(mes==4||mes==6||mes==9||mes==11) . scanf("%d". printf("\nmarzo=3").&dia). } for(x=0. } } system("pause"). printf("\nnobiembre=11").x<=15. } else { a[x]=0. día. printf("\ndiciembre=12"). printf("\nabril=4"). año) indicar cuantos días (exactos) han transcurrido desde ese año. printf("\nfebrero=2").h> int dia.&mes). } ne=ne/2.&ano). scanf("%d". #include<stdio. printf("\njulio=7"). int main() { printf("\ningrese el numero del dia de nacimiento"). int mes. printf("\nmayo=5"). int ano.a[x]).Dada tu fecha de nacimiento (mes. printf("\nagosto=8"). int cad.{ a[x]=ne%2. } 9. printf("\ningrese el numero del año completo de nacimiento").

/** Número aleatorio entre 0 y 100 que hay que adivinar **/ int i=0. /** Jugador 1 **/ int j2=0.h> int main() { int p=0. } 10. } system("pause"). mostrar el ganador por partida y el ganador final. el algoritmo debe pedir el número de partidas. intercalar los turnos para adivinar. cad=(2009-ano)*cad1. int s=0.cad). return 0. /** Número de partidas **/ int j1=0.cad). printf("los dias vividos son:%d". } else { if (mes==1||mes==3||mes==5||mes==7||mes==8||mes==10||mes==12) cad1=(31-dia)+(30*4)+(31*6)+(28).) #include <stdio. /** Variable que almacena un número aleatorio entre 0 y 100 para el jugador 2 **/ int pj1=0. /** Variable que almacena el puntaje obtenido por el jugador 1 **/ int pj2=0. printf("los dias vividos son:%d". cad=(2009-ano)*cad1. /** Número aleatorio que indica quién de los dos jugadores parte adivinando **/ int a=0.cad). cad=(2009-ano)*cad1. /** Jugador 2 **/ int n=0.h> #include <stdlib. (Use la función random.Elabore un programa que genere un número aleatorio y que les dé la posibilidad a dos jugadores de adivinar dicho número. El número debe estar entre 0-100. printf("los dias vividos son:%d". . /** Variable que almacena el puntaje obtenido por el jugador 2 **/ srand(time(NULL)).{ cad1=(30-dia)+(30*3)+(31*7)+(28). } if(mes==2) { cad1=(28-dia)+(30*4)+(31*7). /** Variable que almacena un número aleatorio entre 0 y 100 para el jugador 1 **/ int b=0.

scanf("%d". i++) { s = 1 + rand() % 2.pj1). no hay ganador.&p).i). } else { printf("\nGanador final: Jugador 2 con %d victorias\n". } } else /** Jugador 2 **/ { b = rand() % 101. s = 2. } . break. if(b == n) { pj2 = pj2 + 1. break. if(a == n) { pj1 = pj1 + 1.printf("Partidas:"). printf("Jugador 1 gana la partida %d\n". i<=p. Jugador 1 y 2 obtienen %d victorias cada uno\n". for(i=1. } } } } if (pj1 > pj2) { printf("\nGanador final: Jugador 1 con %d victorias\n".pj2). n = rand() % 101.i). s = 1. printf("Jugador 2 gana la partida %d\n". } else if(pj1 == pj2) { printf("\nEmpate.pj1). while(!0) { if(s == 1) /** Jugador 1 **/ { a = rand() % 101.

nipe=0. $3876. el vendedor que más ventas realizó #include<iostream> #include<cmath> #include<stdlib. } 11. el promedio total de ventas. vtpa=0. float vmv. float pmv.h> using namespace std. D y C). B. int n. el menos vendido. float vtpa. si los precios de los productos son ($1000. ntp=0. el producto mas vendido. int b. float vtpb. calcule el número individual y total de productos vendidos. float A. int f. float nipc. nipd=0. float pmev. float ntp.Elabore un programa que lea las ventas de (n) número de vendedores. float vtpc. $2345. float ptv. nipb=0. int d. float nipd. int main() { int nipa=0. float suma. las ventas totales por producto. float vtpe. float vtpd. C. int c. int e. . float nipe. float nipb. float a. int VENTAS[200]. $1235 y $550) respectivamente.return 0. nipc=0. para los productos (A.

vtpc=0.a<=n.vtpb=0. nipd=suma+e. vtpc=3876*d. } else { if (nipe>nipa && nipe>nipb && nipe>nipc && nipe>nipd) { cout<<"el producto mas vendido es el e"<<endl. ptv=0. cout<<"cantidad del producto b vendida?"<<endl. a=0. cout<<"cantidad del producto c vendida?"<<endl. cout<<"cantidad del producto d vendida?"<<endl. cin>>f. ptv=(vtpa+vtpb+vtpc+vtpd+vtpe)/5. suma=0. . vtpe=0. } else { if (nipb>nipa && nipb>nipc && nipb>nipd && nipb>nipe) { cout<<"el producto mas vendido es el b"<<endl. cin>>n. cin>>c. pmv=0. nipe=suma+f. cin>>d. vmv=0. } else { if (nipc>nipa && nipc>nipb && nipc>nipd && nipc>nipe) { cout<<"el producto mas vendido es el c"<<endl. vtpe=550*f. cin>>b. nipc=suma+d. cout<<"ingrese la cantidad de vendedores que va a nalizar"<<endl. } else { if (nipd>nipa && nipd>nipb && nipd>nipc && nipd>nipe) { cout<<"el producto mas vendido es el d"<<endl. cout<<"cantidad del producto e vendida?"<<endl. pmev=0. vtpb=2345*c. vtpa=100*b.a++) { cout<<"vendedor"<<a<<endl. cin>>e. for (a=1. nipa=suma+b. cout<<"cantidad del producto a vendida?"<<endl. vtpd=0. if (nipa>nipb && nipa>nipc && nipa>nipd && nipa>nipe) { cout<<"el producto mas vendido es el a"<<endl. ntp=suma+b+c+d+e+f. nipb=suma+c. vtpd=1235*e.

} } } } } if (nipa<nipb && nipa<nipc && nipa<nipd && nipa<nipe) { cout<<"el producto menos vendido es el a"<<endl. cout<<"el numero total de productos e vendidos es:"<<ntp<<endl. } else { if (nipd<nipa && nipd<nipb && nipd<nipc && nipd<nipe) { cout<<"el producto mas vendido es el d"<<endl.h #include<iostream> #include<cmath> #include<stdlib. } } } } } } cout<<"el numero de productos a vendidos es:"<<nipa<<endl. #define SIN_TIPO float . cout<<"las ventas totales por producto d es:"<<vtpd<<endl. cout<<"el numero de productos d vendidos es:"<<nipd<<endl.h> using namespace std. } else { if (nipc<nipa && nipc<nipb && nipc<nipd && nipc<nipe) { cout<<"el producto mas vendido es el c"<<endl. return 0. cout<<"el numero de productos b vendidos es:"<<nipb<<endl. system("pause"). cout<<"las ventas totales por producto b es:"<<vtpb<<endl. funciones de la librería math. cout<<"las ventas totales por producto a es:"<<vtpa<<endl. } else { if (nipb<nipa && nipb<nipc && nipb<nipd && nipb<nipe) { cout<<"el producto mas vendido es el b"<<endl.Desarrolle un programa que mediante la construcción de un menú. } 13. permita la utilización de por lo menos cinco (5). } else { if (nipe<nipa && nipe<nipb && nipe<nipc && nipe<nipd) { cout<<"el producto mas vendido es el e"<<endl. cout<<"el numero de productos c vendidos es:"<<nipc<<endl. cout<<"el numero de productos e vendidos es:"<<nipe<<endl. cout<<"las ventas totales por producto c es:"<<vtpc<<endl. cout<<"las ventas totales por producto e es:"<<vtpe<<endl. cout<<"el promedio total de ventas es:"<<ptv<<endl.

cout<<"9 . Redondear"<<endl. cout<<"4 .float salir. float n. case 2: if (n<=0) { cout<<"El numero debe ser mayor a cero!"<<endl. int opcion.Ingresar Otro Numero"<<endl. cout<<"Presione Enter para continuar"<<endl. cout<<"6 . cout<<"2 . . cout<<"Redondear:"<<ceil(n+. Funcion Exponencial"<<endl. case 4: cout<<"Raiz Cuad. float r.5)<<endl.:"<<exp(n)<<endl. cout<<"1 . cout<<"3 . do { cout<<" "<<endl. cout<<"7 . cin>>opcion. Coseno. break.Seno. } break.Valor Absoluto"<<endl.para Salir"<<endl. cout<<"Ingresar Numero:"<<endl.Separar parte entera y decimal"<<endl. float f. cin>>x.:"<<log(n)<<endl. float x. cout<<"Coseno:"<<cos(n)<<endl. case 3: cout<<"Turncar:"<<floor(n)<<endl. break.Averiguar si es primo"<<endl. cout<<"5 . cin>>n. ArcoTangente"<<endl.Raiz Cuadrada"<<endl. int main() { salir=0. cout<<" "<<endl. cout<<"ArcTangente:"<<atan(n)<<endl. } else { cout<<"Log Nat. cout<<" "<<endl.Truncar. cout<<"Func Expon. float nu.Lograritmo Natural.Hallar Factorial"<<endl.:"<<sqrtf(n)<<endl. switch (opcion) { case 1: cout<<"Seno:"<<sin(n)<<endl. cout<<"8 . cout<<"0 . string primo.

:"<<abs(n)<<endl. case 6: cout<<"Parte Entera:"<<floor(n)<<endl. f=3. while (f<=abs(n)) { if (n<0) { r=(-f)*r. if (n/2==floor(n/2)) { primo="No". } else { nu=n. f=1. case 5: cout<<"Valor Abs. } else { r=1.break. break. case 8: if (n!=floor(n)) { cout<<"El numero debe ser entero!"<<endl. . case 7: if (n!=floor(n)) { cout<<"El numero debe ser entero!"<<endl. } nu=sqrtf(nu). } } break. } if (n<0) { nu=n*-1. } f=f+1. break. cout<<"Parte Decimal:"<<n-floor(n)<<endl. } cout<<"Factorial:"<<r<<endl. } else { if (abs(n)>50) { cout<<"Resultado muy grande!"<<endl. } else { primo="Si". } else { r=f*r.

while (f<=nu && primo=="Si") { if (n/f==floor(n/f)) { primo="No". break. default: cout<<"Opcion No Valida!"<<endl. cin>>n. break. } f=f+2. } } break. case 0: salir=1. } . case 9: cout<<"Ingrese Numero:"<<endl. return 0. } if (primo=="No") { cout<<n<<"="<<f-2<<"x"<<n/(f-2)<<endl. break. system("pause"). } } while (salir==1). } cout<<"Numero Primo:"<<primo<<endl. if (f==3) { f=4.