Está en la página 1de 31

LABORATORIO PRÁCTICO

ALGORITMOS

PRESENTADO A:
ING.DIEGO FERNANDO MEDINA SOTO

PRESENTADO POR: ENRIQUE ANDRES PLATA
C.C. 11.367.343
GRUPO: 301303_12

UNIVERSIDAD NACIONAL ABIERTA Y A DISTANCIA (UNAD)
FUNZA, NOVIEMBRE 2013

PRACTICA 1
1-determinar cuál es el cuadrado, de un determinado número

2-Elaborar un diagrama de flujo que permita determinar si un número es
Positivo o Negativo

3.-Ejercicio de conversión, desarrollar un diagrama, que perita ingresar una
cantidad en metros y la convierta a Centímetros, Kilómetros, Pies, pulgadas.

4-Leer una determinada temperatura en grados centígrados y convertirla a
Fahrenheit

5.-una persona es apta para prestar el servicio militar obligatorio (presente). Realizar un diagrama que permita determinar si una persona es apta o no par prestar el servicio militar. menor de 25 años. nacionalidad Colombiana y género masculino. cuando: es mayor de 18 años. 6-Elabore un diagrama de flujo que teniendo como datos de entrada el radio y la altura de un cilindro calcule el área total y el volumen del cilindro .

Una persona recibe un préstamo de un banco por un año y desea saber cuánto pagará de interés al terminar el préstamo si se sabe que el banco le cobra una tasa del 1.Elaborar un diagrama de flujo.8% mensual.7.. que permita ingresar 3 valores y los imprima en forma descendente . Realice un diagrama de flujo que permita determinar este monto 8.

horas_trabajadas * tarifa si_no tarifa_extra <-.tarifa + 0. variables: horas_trabajadas.tarifa si: horas_trabajadas <= 40 entonces salario <-.PRACTICA 2 Teniendo como punto de partida los ejemplos propuestos en el módulo y consultas de las diferentes fuentes documentales ahí presentadas y apoyados con el tutor de prácticas. Calcular el salario del trabajador dadas las horas trabajadas y la tarifa.horas_trabajadas – 40 salario <-.salario. cada estudiante en forma individual desarrollara los supuestos polémicos presentados para ser solucionados.horas_extras * tarifa_extra + 40 * tarifa fin_si imprimir: salario. los cuales se deben llevar preparados y solucionados en papel para luego proceder a codificar en la Herramienta Pseint la que permite comprobar si el diagrama funciona de manera adecuada 1-A un trabajador le pagan según sus horas y una tarifa de pago por horas.tarifa_e inicio leer: horas_trabajadas.horas_extras.tarifa. . La tarifa se incrementa en un 50% para las horas extras.50 * tarifa horas_extras <-. Si la cantidad de horas trabajadas es mayor a 40 horas.

cantidad valor_total = valor_articulo * cantidad valor_a_pagar = valor_total * 1. Inicio valor_articulo=0. notas_desaprobadas. valor_total=0.tiempo_seg mod 60 fin_si imprimir: minutos.16 Si valor_a_pagar > 50000 entonces descuento = valor_a_pagar * 0. b) Cuantos aprobados. notas_aprobadas.segundos inicio leer: tiempo_seg si minutos <-. variables: tiempo_seg.000. del que se adquieren una o varias unidades. promedio. i Para i=0 / **/ 4-Se trata de escribir el algoritmo que permita emitir la factura correspondiente a una compra de un artículo determinado.05 .segundos. Inicio notas[]. Fin 3-Dado N notas de un estudiante calcular: a) Cuantas notas tiene desaprobados. calcular los segundos restantes que le correspondan para convertirse exactamente en minutos. cantidad=0. descuento=0.minutos.00 pesos se debe realizar un descuento del 5%. de acuerdo al reglamento UNAD. c) El promedio de notas. valor_a_pagar=0 leer valor_articulo.tiempo_seg div 60 entonces segundos <-. El IVA es del 16% y si el precio bruto (precio venta más IVA) es mayor de 50. d) El promedio de notas aprobadas y desaprobadas.fin 2-Dado un tiempo en segundos.

tabla:entero. lea(num). escriba("k. escriba("k. cuantos tienen un salario entre uno y dos salarios mínimos y cuantos ganan más de tres salarios mínimos. 20% a aquellos que gana menos de un salario mínimo. Se deben realizar los cálculos."=". fin_para fin_para fin.tabla)."=". desarrollar la tabla de multiplicar de un determinado número (la tabla básica va de 1 a9). inicio para(k=1 hasta 9)hacer para(j=1hasta 9)hacer tabla=k*j. Escribir ''. Var num. además cual es el valor actual de la nómina de la empresa.descuento FinSi Imprimir valor_a_apagar Fin 5-Se desea desarrollar un algoritmo que permita. para (k=1 hasta 9) hacer tabla =num* k. se debe desarrollar un algoritmo que permita mostrar las tablas del 1 al 9 Var k. 10% a los que ganan entre 1 y dos salarios mínimos y 5% a quienes gana más de 3 salarios mínimos. inicio escriba("ingrese el numero que desea hacer tabla "). fin_para fin 6-Variación del ejercicio anterior. teniendo en cuenta el valor del salario mínimo legal vigente Nomina_2 Escribir 'Programa de nomina empresa Aurora'.j.tabla:entero. tabla).num."+".valor_a_pagar = valor_a_pagar . cuanto aumentará la nómina mensual si se hace incrementos así."*". 7-Una empresa con 20 empleados desea saber cuántos ganan menos de un salario mínimo.k. salario<-0 .j.

Si salario>0 & salario<=589163 Entonces acu<-salario*0. Para i<-1 Hasta 20 Con Paso 1 Hacer Escribir 'Ingrese el salario del empleado '.acu. acu2<-acu2+1 FinSi Escribir ''. acu3<-acu3+1 FinSi suma<-suma+salario nn<-nn+acu an<-nn*100/suma-100 f<-nn-suma FinPara Escribir ''.i ' es: '.10+salario Escribir 'El nuevo salario para el empleado '. Escribir 'El total de empleados que ganan entre 1 y 2 salarios minímos es de: '.acu<-0 acu1<-0 acu2<-0 acu3<-0 suma<-0 an<-0 nn<-0 Escribir 'Ingrese el salario de cada empleado'.i ' es: '. .acu1. Escribir ''.acu2. acu1<-acu1+1 Sino Escribir 'La cantidad de salario debe ser superior a 0'. Si salario>1178328 Entonces acu<-salario*0. Escribir ''. Escribir 'El total de empleados que gana menos del mínimo es de: '.acu.20+salario Escribir 'El nuevo salario para el empleado '.i ' es: '.acu. Si salario>=589164 & salario<=1178328 Entonces acu<-salario*0.5+salario Escribir 'El nuevo salario para el empleado '.i. Leer salario. Escribir ''. FinSi Escribir ''.

f. escriba(“ingrese numero a calcular”). c). c = 0. c. 21. b = c. k. fin_para escriba (“el valor de la serie es:”.an.acu3. para ( k = 0 hasta num ) hacer c = a + b. Desarrollar un algoritmo que permita.Escribir 'El total de empleados que gana más de 2 salarios minímos es de: '.3).suma. 0. Escribir 'El incremento en pesos de la nomina mensualmente es de: '. el cual se construye a partir de los dos primeros números que son el 0 y 1. FinProceso 8-la serie Fibonacci es un ejercicio interesante. existen tres partidos Políticos aspirando con sus candidatos (1. b. calcular n números de esta serie var a. 3. fin 9-Para las elecciones presidenciales que se realizarán en Colombia. num: entero. Escribir ''. Escribir ''. 1. inicio a = 0. 5. 13. a = b. 2. 34.'%'. lea (num).. Uno de estos ha decidido realizar una consulta (encuesta) a un cierto .' pesos'. Escribir 'El total de la nomina actual es de: '.. Escribir 'El incremento porcentual de la nomina mensualmente es de: '. 1.1.55. 8. 2. b = 1. Escribir ''. y a partir de ahí se construye la serie ejemplo: 0.

inicio Pedir el costo (C) pedir el precio del metro cuadrado (Pm2) pedir el ancho y largo del terreno en metros cuadrados (A. El algoritmo imprimirá la siguiente información:  ¿Cuál es el partido que está repuntando?  ¿cuál es % de abstención?  ¿Cuál es % a favor de cada partido. y el costo del metro cuadrado. se le preguntará por qué partido votará. las entrevistas validas?  ¿cuál es el % de personas que SI votaran? 10-Hacer un algoritmo que calcule e imprima el costo de un terreno rectangular. teniendo en cuenta. En caso de que la respuesta se afirmativa. teniendo como datos la anchura y longitud en metros.número de personas. para determinar las preferencias de los electores A cada persona se le pregunta: Si va a votar. Elaborar un algoritmo. fin . para llevar un control de la información y así obtener unos resultados con prontitud Nota: el dato partido solamente se lee si la persona entrevistada ha contestado que sí votará.L) multiplicar el numero de metros cuadrados del terreno por el precio por metro para sacar su costo total (C=Pm2*(A*L)) mostrar resultados (C).

Nota: Un año se considera bisiesto cuando es divisible por 400 o bien es divisible por 4 pero no por 100.da + (d .11-Sabiendo que el día 1 de enero de 1.1) Hacer si (avi Mod 100) <> 0 o (avi Mod 400) = 0 Entonces da <.avi + 4 FinMientras para mi<.1 hasta m-1 Hacer si mi = 2 Entonces si (a Mod 4) = 0 y ((a Mod 100) <> 0 o (a Mod 400) = 0) entonces da <.da + 30 sino da <.1583) * 365 avi <.583 fue sábado y que desde entonces no se han producido modificaciones en el calendario.583.da + 28 finsi sino si mi = 4 O mi = 6 O mi = 9 O mi = 11 entonces da <.da + 29 sino da <.da + 1 FinSi avi <.1584 Mientras avi <= (a .1) .da + 31 finsi FinSi FinPara da <. elaborar un algoritmo para calcular el día de la semana en que cayó o caerá una fecha cualquiera posterior al 1 de enero de 1. Proceso dia escribir 'Diganos la fecha y sabra que dia de la semana cayo o caera' escribir ' ' Escribir 'Digite el anio' Leer A Escribir 'Digite el numero del Mes' Leer M Escribir 'Digite el numero del dia' Leer D da<-(A .

teniendo en cuenta que el cesto puede estar vacío en un momento dado.Considérense tres soluciones al problema "Pelar un número suficiente de papas que hay en un cesto"." FINSI si r = 3 entonces Escribir "Es martes." FINsi FinProceso 12." FINSI si r = 6 entonces Escribir "Es viernes.r <. inicio mientras número insuficiente de patatas peladas hacer si cesto no vacío entonces pelar una patata fin_si fin_mientras fin algoritmo pelar2 ." FINSI si r = 4 entonces Escribir "Es miercoles.da Mod 7 si r = 0 entonces Escribir "Es sabado." FINSI si r = 1 entonces Escribir "Es domingo." FINSI si r = 2 entonces Escribir "Es lunes." FINSI si r = 5 entonces Escribir "Es jueves.

(Tenga en cuenta el cambio de minuto.inicio mientras (número insuficiente de patatas peladas) o (cesto no vacío) hacer pelar una patata fin_mientras fin algoritmo pelar3 inicio si cesto no vacío entonces mientras número insuficiente de patatas peladas hacer pelar una patata fin_mientras si_no comprar una patata fin_si fin 13-Realizar un algoritmo que permita calcular la hora un segundo después de un valor dado.y). los cuales se deben llevar preparados y solucionados en papel para luego proceder a codificar en con C# o C++ Para los siguientes ejercicios si se desarrollan en C++ debe Consultar la directiva de posicionamiento gotoxy(x. cada estudiante en forma individual desarrollara los supuestos polémicos presentados para ser solucionados. hora. para darle ubicación y presentación a los programas. día…) PRACTICA 3 Lenguaje de programación Teniendo como punto de partida los ejemplos propuestos en el módulo y consultas de las diferentes fuentes documentales ahí presentadas y apoyados con el tutor de prácticas. en los casos que ustedes crea necesarios .

digito). int digito. } else . scanf("%d". el tercer número pasa a la segunda posición. long numero. el último pasa a ser primero: ejemplo: Ejemplo: Sea 7458.h" #include "stdio. //verificar si el año es bisiesto if ((aaaa%4 == 0 && aaaa%100 != 0)||aaaa%400==0) { bis = 2. scanf("%d".1-Un banco ha solicitado se diseñe un programa que permita encriptar la información de las contraseñas (4 números) digitada por teclado (como un único numero) hasta el servidor principal. (Tenga en cuenta los años bisiestos.) #include "conio. clrscr().&aaaa).h" int main() { clrscr(). se debe enviar como 8547 #include "stdio.&numero).h" #include "conio.aaaa. aaaa ) e imprimirla. scanf("%ld". } getch().ddmax. while(numero>0){ digito=numero%10.h" int main() { int dd. printf("Introduzca ano (aaaa):"). printf("%d".h" #include "stdlib. return(0).&dd). de penúltimo. printf("Introduzca mes (m):"). numero/=10. el segundo. utilizando el siguiente criterio.bis. printf("DIGITTE LOS CUATRO NUMEROS DE SU CONTRASENA\t "). scanf("%d".&mm).mm. mm. el primer número se envía de último. printf("Introduzca dia (d):"). } 2-Escribir un programa para calcular la fecha del siguiente día a partir de una fecha digitada desde el teclado por el usuario ( dd.

} . } else if ((mm==4||mm==6||mm==9||mm==11)&&(dd>30)||mm>12) { printf("La fecha es invalida").{ bis = 1. } else if ((mm==2)&&(bis==1)) { ddmax = 28. getch(). return 0. } else if (mm==4||mm==6||mm==9||mm==11) { ddmax = 30. getch(). return 0. } else{} if ((mm==2)&&(bis==2)) { ddmax = 29. getch(). } else if (((mm==2)&&(bis==2))&&(dd>29)||mm>12) { printf("La fecha es invalida"). return 0. getch(). return 0. } else if (((mm==2)&&(bis==1))&&(dd>28)||mm>12) { printf("La fecha es invalida"). } else {} // maximo dias de cada mes if (mm==1||mm==3||mm==5||mm==7||mm ==8||mm==10||mm==12) { ddmax = 31. } ///VERIFICARMOS SI LA FECHA QUE SE INGRESO ES VALIDA if ((mm==1||mm==3||mm==5||mm==7||mm ==8||mm==10|| mm==12)&&(dd>31)||mm>12) { printf("La fecha es invalida").

que leído de izquierda a derecha es igual que leído de derecha a izquierda. printf("Ingresa un numero:\t "). printf("\nla fecha siguiente es:").mm. . aaaa = aaaa. etc.ano:%d". printf("\ndia:%d. capi=0.mm. 343. while (nu > 0) { capi = capi*10.aaaa).ano:%d". scanf("%d". } 3-Se lee un número de máximo tres dígitos (verifique que efectivamente sea de máximo tres dígitos) y se debe determinar si es un número capicúa.dd.aaaa). clrscr().dd. es decir.mes:%d.mes:%d. numero. aaaa = aaaa + 1. mm = mm + 1. } /// VERIFICAMOS SI ES EL ULTIMO DIA DEL AÑO else if (dd == ddmax && mm == 12) { dd = 1. mm = 1. Por ejemplo: 727.dd. aaaa = aaaa. } else{} getch(). res = nu%10. printf("\ndia:%d. printf("\nla fecha siguiente es:"). #include #include int main () { int nu. mm = mm.mes:%d. } /// VERIFICAMOS SI ES EL ULTIMO DIA DE UN MES else if (dd == ddmax && mm != 12) { dd = 1.&nu).mm. printf("\nla fecha siguiente es:"). numero = nu.ano:%d". res. printf("\ndia:%d.aaaa).else{} /// CUALQUIER DIA DISTINTO A FIN DE MES O ANO if (dd < ddmax) { dd = dd + 1.

int main() { printf("\ingrese numero de horas que trabaja").500.000. } if (numero == capi) printf(" es capicua").2 int hora. scanf("%d". $7.sueldo. los de categoría 3. Se quiere un algoritmo que permita determinar cuánto debe pagarse a un empleado si se conoce el número de horas que trabajó durante el mes y la categoría a la que pertenece.000.h> #define DE 7.ca. else printf("No es capicua ").h> #include<stdlib. printf("\nmarque 4 categoria 4").sub. $15. scanf("%d". capi = res + capi.000. if(ca==1) { des=(sueldo*DE)/100. y si el salario total devengado (mensual) es menos de 1 ´000.&ca).2% por concepto de salud. } } if(ca==2) { des=(sueldo*DE)/100.000 y los de categoría 4. printf("\nmarque 3 categoria 3"). getch(). los de categoría 1 ganan $20. printf("\ningreae la categoria a la que pertenece"). return(0).nu = nu/10. printf("\nmarque 1 categoria 1"). printf("\nmarque 2 categoria 2").phora.sueldo). sueldo=sueldo+sub. #include<stdio. sueldo=(hora*15000)-des. printf("su sueldo es:%d". sueldo=(hora*20000)-des. Se sabe que a todos se les descuenta un 7. se le da un subsidio del 15% sobre su salario mensual (sin descuentos).des. if(sueldo<1000000) .&hora). $10. if(sueldo<1000000) { sub=(15*sueldo)/100. los de categoría 2. } 4-En una organización se tiene a los empleados agrupados por categoría.

int main() { char ca [100]. if(sueldo<1000000) { sub=(15*sueldo)/100.h> using namespace std.sueldo). en caso contrario imprimir "Error clave" y el nivel del error. printf("su sueldo es:%d". int ct1. if(sueldo<1000000) { sub=(15*sueldo)/100. printf("su sueldo es:%d". sueldo=sueldo+sub. return 0. sueldo=(hora*10000)-des.Elabore un programa que tenga cuatro niveles de seguridad (documéntese sobre niveles de seguridad) para un programa. si el usuario logra ingresar imprimir el mensaje "Bienvenido". int ct.h> #include <stdio. #include <iostream> #include <math.{ sub=(15*sueldo)/100. } } system("pause"). sueldo=sueldo+sub. } 5.sueldo). } } if (ca==4) { des=(sueldo*DE)/100. } } if (ca==3) { des=(sueldo*DE)/100. . sueldo=sueldo+sub. sueldo=(hora*7500)-des.sueldo).h> #include <conio. printf("su sueldo es:".

} 6. cin.Escriba un programa para calcular si un número es primo o no. if (ct==ct1) { sw=1. } else { cont = cont + 1. } if (cont == 3) { cout<<endl<<"Ultima oportunidad de ingresar contraseña correcta: "<<endl. cout<<endl<<"Error en la contraseña : ". cout<<endl<<"Su cuenta ha sido bloqueada por seguridad ". cin>>ct1.get(). int cont = 0. cout<<endl<<"Guardar una contraseña: ".BIENVENIDO ------". cin>>ca. recuerde que los números primos son aquellos que solo son divisibles por la unidad y por ellos mismos: ejemplo 5. ct = atoi(ca).int sw = 0. while (sw == 0) { cout<<endl<<"Ingrese contraseña: ". sw=1. } } cin. 17 . 11. int lcont = strlen(ca). cout<<endl<<"-----.get(). cout<<"Tiene 4 intentos despues se bloquera su cuenta". cout<<endl<<"Intento No : "<<cont<<endl. } if (cont == 4) { cout<<endl<<"ERROR NIVEL DE ERROR: "<<cont.

if (a==b && b==c) { cout<<"TRIÁNGULO EQUILÁTERO"<<endl. cin>>b.pues ES multiplo de %ld n". if(Num== divisor) printf("t %ld es PRIMO n". int a.h> int main() { long Num. cin>>a. cout<<"INGRESE EL LADOC DEL TRIANGULO"<<endl. O ESCALENO) #include<iostream> #include<cmath> #include<stdlib. else printf("t%ld NO ES PRIMO . return 0. } else { cout<<"TRIÁNGULO ESCALENO"<<endl.Num). 7.#include<stdio. break.h> #include<stdlib.divisor). printf("\t Introducir el Numero = "). cin>>c.&Num). } else { if (a==b || b==c || a==c) { cout<<" TRIÁNGULO ISOCELES"<<endl.Num. ISÓSCELES. scanf("%ld".Lea los valores de los lados de un triángulo. int c.divisor=2. while(divisor<Num) { while( Num % divisor != 0) divisor=divisor+1. Detecte y muestre un mensaje correspondiente a su tipo (EQUILÁTERO. .h> using namespace std. int main() { cout<<"INGRESE EL LADO A DEL TRIANGULO"<<endl. } system("pause"). int b. cout<<"iNGRESE EL LADO B DEL TRIANGULO"<<endl.

} } system("pause"). menor a 257 a sistema binario #include <stdio. intonum: printf("Introduzca el numero entero positivo que desea convertir a binario:"). } } else { for(x=15. } else { printf("Error de entrada").swi. } 8. int ne.h> #include<stdlib. scanf("%i". getch().&swi).x.h> main() { float a[16].x=x-1) { if(ne<257) . scanf("%i".&ne). if(ne<0) { err: printf("Ha introducido un numero negativo. if(swi==1) { printf("\n"). printf("Este progrograma esta diseñado para convertir un numero entero positivo decimal a binario. goto intonum. } else if(swi==2) { printf("fin"). return 0. printf("\n\nPara continuar con el programa presione ENTER").x>=0.Elaborar un programa que convierta un número entero positivo. si desea intentar nuevamente presione 1 o si desea salir del programa presione 2\n").").h> #include <conio. goto err.

int cad1. printf("\nmarzo=3").h> #include<stdlib.&dia). printf("\nabril=4").Dada tu fecha de nacimiento (mes. } ne=ne/2. printf("\njunio=6").x<=15.&mes). printf("\nseptiembre=9"). printf("\ndiciembre=12"). } for(x=0. scanf("%d". printf("\njulio=7").0f". printf("\nnobiembre=11"). printf("\ningrese el numero del mes de nacimiento"). día.x++) { printf("%. if(mes==4||mes==6||mes==9||mes==11) . } } system("pause"). #include<stdio. printf("\nagosto=8").{ a[x]=ne%2. int cad.h> int dia. int mes. int ano.a[x]). printf("\nfebrero=2"). } 9. printf("\nenero=1"). return 0. scanf("%d". } else { a[x]=0. scanf("%d". año) indicar cuantos días (exactos) han transcurrido desde ese año. printf("\nmayo=5"). int main() { printf("\ningrese el numero del dia de nacimiento"). printf("\noctubre=10").&ano). printf("\ningrese el numero del año completo de nacimiento").

{ cad1=(30-dia)+(30*3)+(31*7)+(28). printf("los dias vividos son:%d". /** Número aleatorio que indica quién de los dos jugadores parte adivinando **/ int a=0. cad=(2009-ano)*cad1. printf("los dias vividos son:%d".Elabore un programa que genere un número aleatorio y que les dé la posibilidad a dos jugadores de adivinar dicho número. /** Variable que almacena el puntaje obtenido por el jugador 1 **/ int pj2=0. El número debe estar entre 0-100. /** Jugador 2 **/ int n=0. /** Variable que almacena un número aleatorio entre 0 y 100 para el jugador 2 **/ int pj1=0. intercalar los turnos para adivinar. /** Número de partidas **/ int j1=0. /** Número aleatorio entre 0 y 100 que hay que adivinar **/ int i=0. cad=(2009-ano)*cad1. } 10. int s=0. mostrar el ganador por partida y el ganador final. } system("pause"). printf("los dias vividos son:%d". el algoritmo debe pedir el número de partidas. (Use la función random. /** Jugador 1 **/ int j2=0.cad). . /** Variable que almacena el puntaje obtenido por el jugador 2 **/ srand(time(NULL)). /** Variable que almacena un número aleatorio entre 0 y 100 para el jugador 1 **/ int b=0.h> int main() { int p=0.) #include <stdio. cad=(2009-ano)*cad1.h> #include <stdlib. } if(mes==2) { cad1=(28-dia)+(30*4)+(31*7).cad).cad). } else { if (mes==1||mes==3||mes==5||mes==7||mes==8||mes==10||mes==12) cad1=(31-dia)+(30*4)+(31*6)+(28). return 0.

while(!0) { if(s == 1) /** Jugador 1 **/ { a = rand() % 101.pj1).i). break. for(i=1. s = 1. break.&p). } } else /** Jugador 2 **/ { b = rand() % 101. i<=p. n = rand() % 101.pj2). } } } } if (pj1 > pj2) { printf("\nGanador final: Jugador 1 con %d victorias\n". if(b == n) { pj2 = pj2 + 1. no hay ganador. if(a == n) { pj1 = pj1 + 1. Jugador 1 y 2 obtienen %d victorias cada uno\n". } else if(pj1 == pj2) { printf("\nEmpate. } else { printf("\nGanador final: Jugador 2 con %d victorias\n".printf("Partidas:").pj1). i++) { s = 1 + rand() % 2. s = 2. scanf("%d". printf("Jugador 1 gana la partida %d\n".i). printf("Jugador 2 gana la partida %d\n". } .

float nipc. float vtpc. calcule el número individual y total de productos vendidos. para los productos (A. si los precios de los productos son ($1000. nipc=0. nipe=0. nipb=0. int b. float pmv. float a. float vtpb. C. float vmv. int f. ntp=0. el producto mas vendido. float ntp. float vtpd. $3876.return 0. int d. float nipb.h> using namespace std. float vtpe. int VENTAS[200]. } 11. $1235 y $550) respectivamente. B. el menos vendido. float pmev. el vendedor que más ventas realizó #include<iostream> #include<cmath> #include<stdlib. int n. float suma. vtpa=0. float A.Elabore un programa que lea las ventas de (n) número de vendedores. int main() { int nipa=0. int c. las ventas totales por producto. float vtpa. $2345. int e. D y C). el promedio total de ventas. nipd=0. float ptv. float nipe. . float nipd.

nipd=suma+e. cout<<"ingrese la cantidad de vendedores que va a nalizar"<<endl. nipa=suma+b. cin>>n. vmv=0. cout<<"cantidad del producto b vendida?"<<endl. vtpa=100*b.a++) { cout<<"vendedor"<<a<<endl. for (a=1. ptv=(vtpa+vtpb+vtpc+vtpd+vtpe)/5. } else { if (nipb>nipa && nipb>nipc && nipb>nipd && nipb>nipe) { cout<<"el producto mas vendido es el b"<<endl. cin>>f. vtpe=550*f. nipe=suma+f. vtpe=0. vtpd=1235*e. cin>>e. vtpd=0. suma=0. pmev=0. cout<<"cantidad del producto e vendida?"<<endl.a<=n.vtpb=0. vtpc=0. } else { if (nipc>nipa && nipc>nipb && nipc>nipd && nipc>nipe) { cout<<"el producto mas vendido es el c"<<endl. ntp=suma+b+c+d+e+f. nipc=suma+d. cin>>c. cout<<"cantidad del producto d vendida?"<<endl. } else { if (nipd>nipa && nipd>nipb && nipd>nipc && nipd>nipe) { cout<<"el producto mas vendido es el d"<<endl. cout<<"cantidad del producto c vendida?"<<endl. nipb=suma+c. a=0. cin>>d. } else { if (nipe>nipa && nipe>nipb && nipe>nipc && nipe>nipd) { cout<<"el producto mas vendido es el e"<<endl. vtpb=2345*c. cout<<"cantidad del producto a vendida?"<<endl. cin>>b. . ptv=0. if (nipa>nipb && nipa>nipc && nipa>nipd && nipa>nipe) { cout<<"el producto mas vendido es el a"<<endl. vtpc=3876*d. pmv=0.

} else { if (nipe<nipa && nipe<nipb && nipe<nipc && nipe<nipd) { cout<<"el producto mas vendido es el e"<<endl. cout<<"las ventas totales por producto b es:"<<vtpb<<endl. cout<<"las ventas totales por producto c es:"<<vtpc<<endl.} } } } } if (nipa<nipb && nipa<nipc && nipa<nipd && nipa<nipe) { cout<<"el producto menos vendido es el a"<<endl. cout<<"el numero de productos c vendidos es:"<<nipc<<endl. cout<<"el numero total de productos e vendidos es:"<<ntp<<endl.Desarrolle un programa que mediante la construcción de un menú. return 0. cout<<"el promedio total de ventas es:"<<ptv<<endl. cout<<"el numero de productos d vendidos es:"<<nipd<<endl. } else { if (nipd<nipa && nipd<nipb && nipd<nipc && nipd<nipe) { cout<<"el producto mas vendido es el d"<<endl. } } } } } } cout<<"el numero de productos a vendidos es:"<<nipa<<endl. funciones de la librería math. system("pause"). cout<<"las ventas totales por producto e es:"<<vtpe<<endl. cout<<"las ventas totales por producto d es:"<<vtpd<<endl. } 13. } else { if (nipb<nipa && nipb<nipc && nipb<nipd && nipb<nipe) { cout<<"el producto mas vendido es el b"<<endl. #define SIN_TIPO float .h #include<iostream> #include<cmath> #include<stdlib. permita la utilización de por lo menos cinco (5).h> using namespace std. cout<<"el numero de productos b vendidos es:"<<nipb<<endl. cout<<"el numero de productos e vendidos es:"<<nipe<<endl. } else { if (nipc<nipa && nipc<nipb && nipc<nipd && nipc<nipe) { cout<<"el producto mas vendido es el c"<<endl. cout<<"las ventas totales por producto a es:"<<vtpa<<endl.

float nu. cout<<"2 . cout<<"Redondear:"<<ceil(n+. do { cout<<" "<<endl. Funcion Exponencial"<<endl. ArcoTangente"<<endl. cout<<"Presione Enter para continuar"<<endl. cout<<"8 .Seno.Raiz Cuadrada"<<endl. cout<<" "<<endl. case 3: cout<<"Turncar:"<<floor(n)<<endl. Redondear"<<endl. cin>>x. int opcion. float x.:"<<exp(n)<<endl. case 2: if (n<=0) { cout<<"El numero debe ser mayor a cero!"<<endl. cout<<"6 . . cin>>opcion. cout<<" "<<endl. cout<<"9 . cout<<"Func Expon.para Salir"<<endl. } break. cout<<"Ingresar Numero:"<<endl. float r. cout<<"5 . cout<<"ArcTangente:"<<atan(n)<<endl.:"<<log(n)<<endl. Coseno.:"<<sqrtf(n)<<endl. string primo. cout<<"1 . cout<<"3 . float n.Hallar Factorial"<<endl. break. cout<<"7 . break. int main() { salir=0. cin>>n.Valor Absoluto"<<endl. cout<<"4 . float f.float salir.Ingresar Otro Numero"<<endl.Truncar.Separar parte entera y decimal"<<endl. cout<<"0 . } else { cout<<"Log Nat.5)<<endl.Lograritmo Natural.Averiguar si es primo"<<endl. case 4: cout<<"Raiz Cuad. cout<<"Coseno:"<<cos(n)<<endl. switch (opcion) { case 1: cout<<"Seno:"<<sin(n)<<endl.

case 6: cout<<"Parte Entera:"<<floor(n)<<endl. } f=f+1. break. case 8: if (n!=floor(n)) { cout<<"El numero debe ser entero!"<<endl. f=3. } else { r=f*r. } nu=sqrtf(nu). } if (n<0) { nu=n*-1. } cout<<"Factorial:"<<r<<endl. . while (f<=abs(n)) { if (n<0) { r=(-f)*r.:"<<abs(n)<<endl. f=1. } else { if (abs(n)>50) { cout<<"Resultado muy grande!"<<endl. } else { primo="Si". break. } else { r=1. case 5: cout<<"Valor Abs. cout<<"Parte Decimal:"<<n-floor(n)<<endl. case 7: if (n!=floor(n)) { cout<<"El numero debe ser entero!"<<endl. if (n/2==floor(n/2)) { primo="No".break. } else { nu=n. } } break.

cin>>n. } if (primo=="No") { cout<<n<<"="<<f-2<<"x"<<n/(f-2)<<endl. return 0. case 9: cout<<"Ingrese Numero:"<<endl. case 0: salir=1.while (f<=nu && primo=="Si") { if (n/f==floor(n/f)) { primo="No". break. break. } } while (salir==1). } } break. if (f==3) { f=4. } . default: cout<<"Opcion No Valida!"<<endl. } f=f+2. } cout<<"Numero Primo:"<<primo<<endl. break. system("pause").