Está en la página 1de 21

UNIVERSIDAD MARIANO GALVEZ DE GUATEMALA

CAMPUS JUTIAPA
Nombre: Guerin Steven Colocho Chacn
Nmero de Carnet: 0905-16-4002.
Curso: Algoritmo.

Imgenes de niveles del juego Swap, diagramas y pseudocdigos

Ingeniero. Ruldin Ayala.


Jornada: Sabatina.
Seccin: A
Guatemala, Jutiapa, Sbado 16 de julio de 2016

Secuencia de pasos:
derecha+derecha+derecha+derecha+espacio+izquierda+izqeruida+izquierda+izquierda+esp
acio+derecha+derecha+espacio+izquierda+izquierda+espacio+arriba+arriba+arriba+arriba
+arriba+arriba+arriba+arriba+arriba+espacio+derecha+derecha+derecha+derecha+espacio
+izquierda+izquierda+izquierda.

Sentencia de pasos:
arriba+arriba+arriba+arriba+arriba+rriba+ariba+arriba+arriba+arriba+arriba+arriba+izquier
da+izquierda+izquierda+izquierda

Sentencia de pasos :
derecha+drecha+espacio+derecha+derecha+arriba+arriba+arriba+arriba+arriba+arriba+de
recha+derecha+derecha+derecha+arriba+arriba+arriba+arriba+arriba+izquierda+izquierda
+izquierda+espacio+espacio+derecha+derecha+ espacio+arriba

Ejercicios de diagramas de flujo y pseudocdigos


1. Hacer el diagrama de flujo para sumar dos nmeros ledos por teclado y escribir el
resultado.
Pseudocdigo
Algoritmo suma
Definir A, B como real
Escribir "Ingrese sus nmeros"
Leer A, B
Total= A+B
Escribir "El total de su suma es:" Total

FinAlgoritmo

Diagrama de flujo
Algoritmo Suma

Definir A, B Como Real

Ingrese sus nmeros

A, B

Total = A+B

El total de su
suma es: Total

FinAlgoritmo

2. Modificar el anterior pero para sumar 100 nmeros ledos por teclado.
Pseudocdigo

Algoritmo ejercicio2
Contador = 1
Escribir "Ingrese los datos"
Mientras Contador <= 100 Hacer
Leer num1
Total= Total+num1
Escribir "Total" Total
Contador = Contador + 1
FinMientras

FinAlgoritmo
Diagrama de flujo

Ejercicio 3
Algoritmo ejercicio3
Contador = 1
Escribir "Ingrese la cantidad de datos a sumar"
leer A
escribir "Ingrese los datos"
Mientras contador <= A hacer
leer num1
total = contador + 1
FinMientras
Escribir "El total es:" total
FinAlgoritmo

Ejercicio 4
Algoritmo ejercicio4
contador= 1
Escribir "Ingrese los numeros pares"

Mientras contador <=4 hacer


leer a
nu=num1%2
si nu!=0 entonces
escribir "el numero no es par"
sino
total = total + num1
contador = contador + 1
FinSi
FinMientras

FinAlgoritmo

Ejercicio 5 Numero par


Algoritmo trabajo
Escribir "ingrese los numeros a sumar "
leer a
total = a*a+a
escribir " la suma de los numeros pares es:" total

FinAlgoritmo

Ejercicio 5 nmero impar


Algoritmo ejercicio5
Escribir "Ingrese los numeros impares a sumar"
leer A
total = A*A
escribir "la suma de los numeros impares es:" total

FinAlgoritmo

Mltiplos de 3
Algoritmo ejercicio5
Escribir "ingrese los numeros multiplos"
leer a
total = ((a*a*3)+(n*3))/2
escribir "el total es:" total
FinAlgoritmo