Está en la página 1de 10

6.

La ENEE requiere de la lectura anterior en kilovatios y la lectura actual en


kilovatios de un medidor de luz para determinar el consumo de electricidad de
una vivienda. Teniendo como datos de entrada la lectura inicial y la lectura final
en kilovatios de un medidor, determine el consumo el kilovatios y el monto a
pagar por dicho consumo sabiendo que cada kilovatio tiene un valor de Lps. 5
Adicionalmente cobran el 10% del monto del consumo por concepto de aseo
urbano, determine el monto total a pagar.

Algoritmo_ENEE
Variable
Real Lectora_final, lectura_inicial, consumo, pago_consum, total_pagar,
aseo_urbano.
Inicio
Escribir ingrese la lectura final
Leer

lectura_final

Escribir ingrese la lectura inicial


Leer

lectura_inicial

Consumo

(lectura_final - lectira_inicial)

Escribir total de consumo:,:consumo


Pago_consumo

consumo * 5

Escribir total pago consumo:, pago_consumo


Aseo_urbano

pago_consumo * 0.10

Escribir total aseo urbano:


Total_pagar

( pago_consumo aseo_urbano)

Escribir total a pagar es:, total_pagar


Fin

Inicio
ingrese la lectura final

Lectura_final

ingrese la lectura inicial

Lectura_inicial

Consumo=(lectura_final - lectira_inicial)

total de consumo:, consumo

Pago_consumo=(consumo * 5)

total pago consumo:, pago_consumo

Aseo_urban=(pago_consumo * 0.10)
total aseo urbano:

Total_pagar =(pago_consumo + aseo_urbano)

total a pagar es:, total_pagar

Fin

7. Se desea realizar una estadstica de los pesos de los alumnos de un colegio


de acuerdo a la siguiente tabla:
a. Alumnos de menos de 40 kg.
b. Alumnos entre 40 y 50 kg.
c. Alumnos de ms de 50 kg y menos de 60 kg.
d. Alumnos de ms o igual a 60 kg.
Algoritmo Estadstica
Variable
Entero cant_alum, peso_tot, p, pt
Inicio
Escribir Cantidad de Alumnos
Leer cant_alum
Escribir Peso total
Leer peso_tot
p= (pt/ cant_alum)
Si (p<=40) entonces
Escribir Peso abajo d elo normal
Si No Si (p>40) y (p<=50) entonces
Escribir Peso normal
Si No Si (p>50) y (p<=60) entonces
Escribir Tiene Sobrepeso
Si No Si (p>60) entonces
Escribir Tiene Obesidad
Finsi
Finsi
Finsi
Finsi
Fin

8. CLARO tiene un plan por Lps. 500 mensuales denominado PLAN ILIMITADO
el cual consiste 1500 segundos libres para llamadas y 1 Lps. por cada mensaje
de texto. Las llamadas adicionales tienen un costo de 2 Lps. por cada minuto.
Suponiendo que una persona se excedi en las llamadas y se tiene como dato
de entrada la cantidad total de mensajes y la cantidad total de segundos
consumidos en el mes, realice un algoritmo que determine el monto total pagar
a CLARO en el mes.

Algoritmo _CLARO
Variable
Real total_llamadas, total_mensajes, tiempo_lempiras, tiempo_minutos,
total_pagar,tiempo_llamadas
Inicio
Escribir consumo de mensajes en el mes
Leer

total_mensajes,

Escribir total tiempo de llamada


Leer

total_llamadas

Tiempo_llamadas = (total_llamadas / 60)


Tiempo_minutos = (total _llamadas * 2)
Total_pagar = (total_minutos+ total_mensajes)
Escribir total a pagar en el mes:; total_pagar
Fin

Inicio

consumo de mensajes en el
mes
Total_mensajes,

total tiempo de llamada

Total_llamadas

Tiempo_llamadas = (total llamadas / 60)

Tiempo_minutos = (total llamadas * 2)

Total_pagar = (total minutos+total_mensajes)

total a pagar en el mes:

Total_pagar

Fin

9. Escribir un programa que acepte dos nmeros reales de un usuario y un


cdigo de seleccin. Si el cdigo introducido de seleccin es 1, entonces el
programa suma los dos nmeros introducidos previamente y se visualiza el
resultado; si el cdigo de seleccin es 2, los nmeros deben ser multiplicados y
visualizado el resultado; y si el cdigo seleccionado es 3, el primer nmero se
debe dividir por el segundo nmero y visualizarse el resultado.
Algoritmo_NUMEROS
Variable
Real nmero 1, nmero 2, nmero 3, respuesta.
Inicio
Escribir primer nmero
Leer numero1
Escribir segundo nmero
Leer numero2
Escribir tercer nmero
Leer numero3
Escribir 1 para suma
Escribir 2 para multiplicar
Escribir 3 para dividir
Leer opcin
Si (opcin = 1) entonces
Respuesta= numero 1+ numero 2
Escribir respuesta de la suma:
Sino si (opcin = 2) entonces
Respuesta= numero 1 * numero 2
Escribir respuesta de la multiplicacin:
Sino si (opcin = 3) entonces
Respuesta= nmero 1 / numero 2
Escribir respuesta de la divisin:
Fin si
Fin si
Fin si
Fin

Inicio
primer nmero
numero1
segundo nmero

numero2
tercer nmero
numero3
1 para suma
2 para multiplicar
3 para dividir
Opcin
no

(Opcin = 1)

si

(Opcin = 2)

Respuesta= numero 1 * numero 2

si

Respuesta= numero 1+ numero 2


respuesta de la suma:

no

respuesta de la suma:
(Opcin = 3)
Respuesta= nmero 1 / numero 2
respuesta de la divisin:

10. En la asignatura Metodologa de la programacin se realizaron 5


evaluaciones. Las evaluaciones tienen una calificacin del 1 al 20. LaFin
primera
evaluacin tiene un peso del 15%, la segunda tiene un peso del 30%, la tercera
tiene un peso de 25%, la cuarta tiene un peso de 10% y la ltima tiene un peso
del 20%. Realice un algoritmo que determine la calificacin final de un
estudiante sabiendo que se tiene como datos de entrada la nota (en la escala
del 1 al 20) de cada evaluacin.
Algoritmo ASIGNATURA
Variable

Real evaluacin1, evaluacin2, evaluacin3, evaluacin4, evaluacin5,


respuesta1, respuesta2, respuesta3, respuesta4, respuesta5, puntos_total
Inicio
Escribir calificacin obtenida del 1 al 20 en su primera evaluacin de
15%
Leer evaluacin 1
Escribir calificacin obtenida del 1 al 20 en su segunda evaluacin de
30%
Leer evaluacin 2
Escribir calificacin obtenida del 1 al 20 en su tercera evaluacin de
25%
Leer evaluacin 3
Escribir calificacin obtenida del 1 al 20 en su cuarta evaluacin de
10%
Leer evaluacin 4
Escribir calificacin obtenida del 1 al 20 en su quinta evaluacin de
20%
Leer evaluacin 5
Respuesta1 = (100/20*evaluacin 1)*0.15
Respuesta2 = (100/20*evaluacin 2)*0.30
Respuesta3 = (100/20*evaluacin 3)*0.25
Respuesta4 = (100/20*evaluacin 4)*0.10
Respuesta5 = (100/20*evaluacin 5)*0.20
Puntos_total= (respuesta 1+ respuesta 2+ respuesta 3 +
respuesta 4 + respuesta 5)
Escribir calificacin final es: ;puntos_total
Fin

Inicio
calificacin obtenida del 1 al 20 en su primera evaluacin de 15%
evaluacin1
calificacin obtenida del 1 al 20 en su segunda evaluacin de 30%
evaluacin2
calificacin obtenida del 1 al 20 en su tercera evaluacin de 25%
evaluacin3

calificacin obtenida del 1 al 20 en su cuarta evaluacin de 10%


evaluacin4
calificacin obtenida del 1 al 20 en su quinta evaluacin de 20%
evaluacin5
Respuesta1 = (100/20*evaluacin 1)*0.15
Respuesta2 = (100/20*evaluacin 2)*0.30
Respuesta3 = (100/20*evaluacin 3)*0.25
Respuesta4 = (100/20*evaluacin 4)*0.10
Respuesta5 = (100/20*evaluacin 5)*0.20
Puntos_total= (respuesta 1+ respuesta 2+ respuesta 3 + respuesta 4 + respuesta 5)
calificacin final es:; puntos_total
totales;
Fin