Está en la página 1de 5

1. Un granjero desea preparar una frmula alimenticia para engordar ganado.

Dispone de maz, desperdicios, alfalfa y cebada, cada uno con ciertas unidades de
ingredientes nutritivos, de acuerdo con la tabla siguiente
Unidades de ingredientes nutritivos por Kg de cada alimento disponible
Ingrediente nutritivo Maz
Desperdicio
Requerimiento diario Unidades / kg
Carbohidrato
230
Protena
180
Vitaminas
80
Celulosa
160
Costo $

80

Alfalfa

Cebada

15

35

60

28

72

57

25

20

20

12

20

10

20

60

50
18

20

a) Determine los kilogramos necesarios de cada material para satisfacer el requerimiento


diario (presentado en la ltima columna).
b) Determine el costo de la mezcla.
NOTA: La frmula alimenticia debe contener los cuatro alimentos.

Determine las concentraciones molares de una mezcla de cinco componentes en solucin


a partir de los siguientes datos espectrofotomtricos.
Longitud
Absorbancia total observada
de onda j
1
0.1100
2
0.2235
3
0.2800
4
0.3000
5
0.1400

Absorbancia molar del componente


1

98

0.5

11

118

0.88

27

27

85

17

142

25

17

118

Asmase que la longitud de la trayectoria ptica es unitaria y que el solvente no absorbe


a estas longitudes de onda.
Si se considera que se cumple la ley de Beer, entonces a una longitud de onda dada, i

1)
A.
Proceso KGingredientes
Escribir Sin Saltar "ingrese el numero de ingredientes nutritivos(n):"
Leer n
Dimension M[n,n+1]
Dimension literales[n]
Para i<-1 hasta n con paso 1 hacer
Escribir sin saltar "ingrese nombre del ingrediente", i, ":"
Leer literales[i]
FinPara
Para i<-1 hasta n con paso 1 hacer
Para j<-1 hasta n con paso 1 Hacer
Escribir Sin Saltar "ingrese el valor de la variable"," " literales[j] " ",
"del renglon", i, ":"
Leer m[i,j]
FinPara
Escribir sin saltar "ingrese el requerimiento diario", i, ":"
Leer m[i,n+1]
Finpara
Escribir ""
Para i<-1 hasta n con paso 1 Hacer
si m[i,i]=0 Entonces
Escribir "error: division entre cero."
Escribir ""
FinSi
Para k<-1 hasta n con paso 1 Hacer
si k<>i Entonces
termino <- m[k,i]/m[i,i]
para j<-1 hasta n+1 con paso 1 Hacer
m[k,j] <- m[k,j]-termino*m[i,j]
FinPara
FinSi
FinPara
FinPara
Escribir "solucion"
Escribir ""
para i<-1 hasta n con paso 1 Hacer
termino <- m[i,n+1]/m[i,i]
escribir literales[i], "=",termino "Kg"
FinPara
FinProceso

B.
Proceso COSTOTAL
Escribir
Leer a
Escribir
Leer b
Escribir
Leer c
Escribir
Leer d

"Inserte costo de maz"


"Inserte costo de desperdicio"
"Inserte costo de alfalfa"
"Inserte costo de Cebada"

CT<-(1.85*a)+(1.03*b)+(0.61*c)+(0.74*d);
Escribir "Costo total de la mezcla de ingredientes que satisfacen el requerimiento
diario =", CT;

FinProceso

2.
Proceso Absorbancia
Escribir Sin Saltar "ingrese el numero de absorbancias molares(n):"
Leer n
Dimension M[n,n+1]
Dimension literales[n]
Para i<-1 hasta n con paso 1 hacer
Escribir sin saltar "Ingrese la letra a asignar al renglon ", i, ":"
Leer literales[i]
FinPara
Para i<-1 hasta n con paso 1 hacer
Para j<-1 hasta n con paso 1 Hacer
Escribir Sin Saltar "ingrese el valor de la variable"," " literales[j] " ",
"del renglon", i, ":"
Leer m[i,j]
FinPara
Escribir sin saltar "ingrese el requerimiento diario", i, ":"
Leer m[i,n+1]
Finpara
Escribir ""
Para i<-1 hasta n con paso 1 Hacer
si m[i,i]=0 Entonces
Escribir "error: division entre cero."
Escribir ""
FinSi
Para k<-1 hasta n con paso 1 Hacer
si k<>i Entonces
termino <- m[k,i]/m[i,i]
para j<-1 hasta n+1 con paso 1 Hacer
m[k,j] <- m[k,j]-termino*m[i,j]
FinPara
FinSi
FinPara
FinPara

Escribir "solucion"
Escribir ""
para i<-1 hasta n con paso 1 Hacer
termino <- m[i,n+1]/m[i,i]
escribir literales[i], "=",termino
FinPara

FinProceso