Está en la página 1de 5

Algoritmo

Mtodo a desarrollar: falsa posicin


Herramienta de trabajo: Excel
Pasos a seguir:
1)Definir la ecuacin
2)La ecuacin esta igualada a Y?
Si: siga
No: fin (igualar la ecuacin y volver al paso 1)
3)La ecuacin es de una incgnita?
Si: siga
No: fin
4)Definir el rango de trabajo
5)La ecuacin es continua en el rango?
Si: siga
No: fin intentar con otro rango
6)El resultado de ambos rangos son de signos
contrarios?
Si: siga
No: fin
7)Crear una tabla en un libro nuevo de Excel que
contenga los siguientes datos. (pueden estar
ordenados de diferente forma)
a

ok

intera
c.

f(x)

F(a)

F(b)

8)En la columna donde se ponga interacciones se


pondrn nmeros del 0 en adelante por cada fila
llenando para abajo
9)En la columna donde se escriba X ser donde se
ponga la formula (a*f(b)-b*f(a))/(f(b)-f(a)) que es
nuestra formula de falsa posicin para que
funcione es necesario escribirla dentro del cuadro
de esta forma:

=((C1*C3)-(C2*C4))/(C3-C4)
Donde: C1= Coordenada de donde se escribi el
dato a
C2= Coordenada de donde se escribi el
dato b
C3= Coordenada de donde se escribi el
dato F(a)
C4= Coordenada de donde se escribi el
dato F(b)
Una vez introducida la formula de esta forma te
dar un resultado instantneo
Por ejemplo si tu dato a est en la coordenada
A1, tu dato b est en la coordenada B1, al igual
que F(a) en C1 y F(b) en la coordenada D1 la
formula se escribira:
=((A1*D1)-(B1*C1))/(D1-C1)
Nota: los datos de esta frmula deben de estar
siempre en la misma fila
10)
En la columna donde se escriba F(x) se
introducir la ecuacin deseada de la siguiente
forma:
=Ecuacin
Donde cada incgnita es la coordenada de tu X
sobre la misma fila.
Nota: en donde se ponga F(a) y F(b) se
pondr la misma ecuacin solo que esta vez la
incgnita de la ecuacin ser el dato a o b
(como corresponda) de la misma fila
11)
En la columna donde se escriba ese ser
el error que se tenga de aproximacin y su
frmula es valor absoluto de el ltimo resultado
de X dado menos el anterior:
|valor actual valor anterior|

Y se escribe de la siguiente manera


=ABS(valor actual valor anterior)
Nota: el primer error es la diferencia entre los
rangos mayor rango menor rango
12)
La columna OK es opcional es solo para
saber cuando se cumple la condicin de error
mnimo y la formula es la siguiente:
=SI(error<valor minimo,"SI","NO")
El error es tu resultado de la columna en la
misma fila, el valor mnimo es que tan acercado
del valor real se requiera por ejemplo: si tu
fuera de .0001 y estuviera en las coordenadas G1
seria:
=SI(G1<0.0001,"SI","NO")
Nota: El SI y NO son tus respuestas, la
primera es si tu condicin se cumple y la segunda
si no se cumple, pueden ser cambiadas a gusto.
13)
En la columna donde se escriba a en la
primera fila se tendr que poner el valor del
rango que en su resultado sea negativo, en la
segunda fila de arriba hacia abajo empezando por
donde se escribi a ser necesario colocar una
condicin que dice que, si el valor de F(x) en
esa fila es negativo el valor resultante de X ser
puesto en su lugar, de no ser de esta forma se
pondr el valor de la fila de arriba, para esto es
necesario poner la siguiente frmula:
=SI(valor de F(x)<0,valor de X,valor anterior)
Ejemplo: si tu valor de F(x) se encuentra en G1,
tu valor de xm se encuentra en C1 y tu valor
anterior en A1 t formula debe estar:

=SI(G1<0,C1,A1)
14)
En la columna donde se escriba b en la
primera fila se tendr que poner el valor del
rango que en su resultado sea positivo, en la
segunda fila de arriba hacia abajo empezando por
donde se escribi b ser necesario colocar una
condicin que dice que, si el valor de F(x) en
esa fila es positivo el valor resultante de xm
ser puesto en su lugar, de no ser de esta forma
se pondr el valor de la fila de arriba, para esto es
necesario poner la siguiente frmula:
=SI(valor de F(x)>0,valor de xm,valor
anterior)
Ejemplo: si tu valor de F(x) se encuentra en G1,
tu valor de xm se encuentra en C1 y tu valor
anterior en B1 t formula debe estar:
=SI(G1>0,C1,B1)
15)
Para cuando se hayan cumplid todos los
pasos anteriores correctamente se tendr algo
como:
a

ok

V
C

V
C

intera
c
0
1

f(x)

F(a)

F(b)

Donde: V=valor
C=condicin
F=formula
E=ecuacin
Para poder hacer todas tus interacciones, repetir
los pasos sera muy tardado por eso es necesario
seleccionar los recuadros que se usan una vez y

jalarlos desde una esquina con un cuadro negro


hacia abajo y quede:
a

ok

V
C

V
C

F
F

C
C

intera
c
0
1

f(x)

F(a)

F(b)

F
F

E
E

E
E

E
E

De esta forma podr jalar la segunda columna


entera hasta que encuentre su raz
Nota: una vez salte un si en la columna OK el
valor de X de esa fila ser tu raz