Está en la página 1de 45

1)

En Excel 2003 Evaluar Frmula se encuentra en el men Herramientas,


Auditora de Formulas, Evaluar Frmula.

2)

En Excel 2007 Evaluar Formula se encuentra en el Grupo Auditora de


Formula en la solapa Frmulas

3)
4)
5)
6)
7)

Este problema fue inicialmente presentado en el podcast 842 de Mr Excel

Ene
Semana1
Impuesto
Impuesto
Impuesto
Impuesto
Impuesto

1
2
3
4
5

Ene
Semana2
1
2
2
2
2

Ene

Ene
Semana3
2
2
1
2
1

Feb

Ene
Semana4
1
1
2
1
1

Mar

2
1
2
2
2
Abr

Ene
Semana5

Feb
Semana6
2
1
1
1
1

May

Feb
Semana7
2
2
1
2
1

Jun

Feb
Semana8
2
2
1
2
2

Jul

Feb
Semana9
1
1
2
2
1

Ago

2
1
2
1
2
Sep

Mar
Mar
Semana10 Semana11
1
1
1
2
2
2
2
1
2
2
Oct

Nov

Mar
Mar
Abr
Abr
Abr
Abr
May
Semana12 Semana13 Semana14 Semana15 Semana16 Semana17 Semana18
2
1
1
2
1
1
1
1
2
1
1
1
2
1
2
2
2
1
2
1
1
1
2
2
1
1
2
1
2
1
1
1
1
1
2
Dic

May
May
May
Jun
Jun
Jun
Jun
Semana19 Semana20 Semana21 Semana22 Semana23 Semana24 Semana25
2
1
1
1
1
2
1
2
2
2
1
1
2
1
2
2
2
1
2
1
1
1
2
1
2
2
1
1
1
2
2
1
2
1
2

Jul
Jul
Jul
Jul
Ago
Ago
Ago
Semana26 Semana27 Semana28 Semana29 Semana30 Semana31 Semana32
2
2
1
2
1
2
2
2
2
1
2
2
2
2
2
2
1
2
2
2
1
2
1
2
1
2
2
1
2
1
2
2
2
1
1

Ago
Sep
Sep
Sep
Sep
Oct
Oct
Semana33 Semana34 Semana35 Semana36 Semana37 Semana38 Semana39
1
1
1
1
2
1
1
2
1
1
2
1
2
2
2
2
2
2
2
2
2
1
1
1
1
1
1
2
1
1
2
1
2
2
1

Oct
Oct
Nov
Nov
Nov
Nov
Dic
Semana40 Semana41 Semana42 Semana43 Semana44 Semana45 Semana46
2
2
1
2
1
1
1
1
2
1
1
1
2
2
1
1
1
2
2
1
2
1
2
2
2
2
2
2
1
1
1
2
1
1
2

Dic
Dic
Dic
Dic
Dic
Dic
Semana47 Semana48 Semana49 Semana50 Semana51 Semana52
2
1
2
2
2
2
2
1
2
1
1
1
1
2
1
2
1
1
2
2
2
2
1
1
2
1
2
1
1
2

1)

En Excel 2007, una consulta web de divisas se p


cono "Conexiones Existentes" en el Grupo "Obten
la solapa Datos, luego has click en "Mercado
MoneyCentral Investor"

2)

En Excel 2003, una consulta web de divisas se p


men Datos, "Obtener Datos Externos", "Importar
en el archivo "MSN MoneyCentral Investor

3)

La funcin CARACTER entrega 255 caracteres ASCII a celda


CARACTER(65) es la letra A y CARACTER(100

4)

Para ms info de la funcin MONEDA mir

5)

Para ms info de Consulta Web de Divisas

=MONEDA(BUSCARV($A10,$A$23:$C$66,COLUMN
=CHAR(F10)&VLOOKUP($A10,$

Name
United States Dollar
United Kingdom Pound - United States Dollar
China Yuan - United States Dollar
Euro - United States Dollar

In US$

Per US$

lta web de divisas se puede encontrar en el


es" en el Grupo "Obtener Datos Externos" en
has click en "Mercado de Divisas de MSN
oneyCentral Investor"

lta web de divisas se puede encontrar en el


s Externos", "Importar Datos", luego has click
MoneyCentral Investor Currency Rates"

255 caracteres ASCII a celdas o frmulas. Por ejemplo,


la letra A y CARACTER(100) es la letra d

a funcin MONEDA mir este video:

nsulta Web de Divisas mir este video

Excel Facil Truco #28: Funcion MONEDA


Excel Facil Truco #27: BUSCARV con consulta web

$A$23:$C$66,COLUMNA(),0),4)&" / "&CARACTER(F10)&"1"
F10)&VLOOKUP($A10,$A$23:$C$66,COLUMN(),0)&" / "&DOLLAR(1,0)
$

36
239
239
239

MONEDA
RV con consulta web

1)

EXTRAE saca partes de lneas de texto de las lneas de texto o

2)

HALLAR (No diferencia entre maysculas y minsculas) o ENCONTRAR (S diferencia entre mays
ordinal de una lnea de texto dentro de otra lnea de texto y para nuestro caso particular 2) En
posicin numerica entre todos los caracteres de la lnea de text

3)

LARGO nos dice 1) Cuantos caracteres hay en una lnea de texto y para nuestro caso particular 2)
texto "Verdi" 3) Entonces esto es cuantos caracteres hay que extraer desde la posicin

4)

En Excel 2003, para agregar Formato Condicional, debes ir al men Formato, luego Formato Con
primer cuadro de texto.

5)
6)
7)

En Excel 2007, para agregar Formato Condicional, debes ir al grupo Estilos en la solapa Inicio y
Nueva Regla, y luego click en "Utilice una frmula..." al final d
Atajo de teclado que funciona en 2003 y 2007 es Alt + F
La frmula es =EXTRAE(B9;HALLAR(F$10;B9);LARGO(F$
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El
El

Verdo GRUDGK
Verdo BLKTTQ
Verdo KMVQBG
Verde MREYSJ
Verde TDHDKZ
Verdo QXWNOG
Verdo ALFVLS
Verdo AWMRLH
Verdo DMZFUK
Verde YDPQLZ
Verde XCOALM
Verde LDSINL
Verdo DJFYTQ
Verdo OAGKJZ
Verdi ZEIXZB
Verde DMJWTG
Verdo HCOKAF
Verdi GTVVQI
Verdo HRVLOH
Verdi BGXJQO
Verdi SLEKIK
Verdo XEDFGT
Verdo TITHUO
Verdi BDNFLN
Verdi DLTOIG
Verdo JORRPB
Verdo VIXIHQ
Verdi HGAQFO
Verdi QMFLWD
Verdo QDPCNF
Verdo QZOVCP

Qu texto pintar
Verdi

El
El
El
El
El
El
El
El
El
El
El
El
El
El

Verde LSUBXY
Verde IVALWF
Verdo QSUTRX
Verdi CCVFUD
Verde GLKOYA
Verde NJCKZI
Verde UZULAQ
Verde IQBGOS
Verdo LAOOCO
Verde UCZUMS
Verdi IPOIHC
Verdi MSHWBZ
Verdo LLHHGA
Verdo AWOUJB

e las lneas de texto originales.

ferencia entre maysculas y minsculas) nos dicen: 1) la posicin


caso particular 2) En que caracter comenzar la extraccin (una
es de la lnea de texto original).

ro caso particular 2) cuenta el nmero de caracteres en la lnea de


raer desde la posicin de comienzo que nos dio HALLAR

o, luego Formato Condicional, y luego seleccionar "Frmula" en el


texto.

en la solapa Inicio y seleccionar Formato Condicional, luego ir a


a frmula..." al final de la lista.
03 y 2007 es Alt + F + M
(F$10;B9);LARGO(F$10))
Frmula usada para generar el texto:
="El "&ELEGIR(ALEATORIO.ENTRE(1;3);"Verde";"Verdi";"Verdo")&" "&CARACTER(ALEATORIO.ENTRE(65

ARACTER(ALEATORIO.ENTRE(65;65+25))&CARACTER(ALEATORIO.ENTRE(65;65+25))&CARACTER(ALEATORIO.EN

5))&CARACTER(ALEATORIO.ENTRE(65;65+25))&CARACTER(ALEATORIO.ENTRE(65;65+25))&CARACTER(ALEATOR

;65+25))&CARACTER(ALEATORIO.ENTRE(65;65+25))&CARACTER(ALEATORIO.ENTRE(65;65+25))

RE(65;65+25))

1)

Para ms sobre Validacin de Datos, Lista, ver


este video:

Selecciona A o B de las listas


desplegables en las celdas verdes
1
2
3
4
5
6
7
8
9
Total para J
Total para C

1
2
3
4
5
6
7
8
9

A
C
J
C
J
J
C
J
C
C

Excel Facil Truco #5: Lista de validac

B
J
C
J
C
C
J
C
J
J

Letras
J
C

co #5: Lista de validacion de datos y BUSCARV

=SI(C4="","",BUSCARV(B4,$F$4:$H$12,SI(C4=$H$3,3,2),0))

{=SUMA(($D$4:$D$12=J4)*1)}

Nmeros
25
26
27
28
29
30
31
32
33
34
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67

Min
Incremento
Piso
25
35
45
55
65
75
85
95
105

25
10
Techo
35
45
55
65
75
85
95
105
115

Categora
25 A 35
35 A 45
45 A 55
55 A 65
65 A 75
75 A 85
85 A 95
95 A 105
105 A 115

Frecuencia

Acumulado
10
9
10
10
10
10
7
8
5

68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
87
88
89
90
92
94
96
97
98
99
100
101
102
104
105
106
107
108
109

% Acumulado
10
19
29
39
49
59
66
74
79

0.1265823
0.2405063
0.3670886
0.4936709
0.6202532
0.7468354
0.835443
0.9367089
1

1) Para ms sobre del smbolo de concatenacin, Et, ver este video:


2)
3)
4)
5)
6)

Azul = Ttulos; Rojo = Datos V


Verde = Frmula
Das del prstamo
0
31
46
Fecha de inicio del prstamo
Perodo mximo del prstamo
Prstamo

Fecha de Pago
Nmero de das que el prstamo
est pendiente de pago
Deuda por intereses
Total adeudado

Excel Facil Truco #9: Unir 2 celdas en 1

Rojo = Datos Variables;


e = Frmula
Das del prstamo

Tasa
30
45
90

0.03
0.035
0.05

9/1/2013
90 Das
400,000.00

="La tasa de interes es "&TEXTO(H10,"0.0%")&" Si el pres

9/22/2013

=G22-G16
=SI(G21<F11,G17,SI(G21<F12,G18,SI(G21<=G15,G19,"D
=SI(G22="Defecto","Defecto",G22+G16)

10,"0.0%")&" Si el prestamo se paga en menos de "&F11&" das"

,SI(G21<=G15,G19,"Defecto")))

1)

Para ver ms sobre funciones ES, ver este video:

En 2007, para usar la funcin


IMPORTARDATOSDINAMICOS, has click en el botn de
Office, luego Opciones de Excel, luego Frmulas en el
men de la izquierda, y luego marca la opcin para usar
2)
la funcin GetPivotData.
En 2003, para usar la funcin
IMPORTARDATOSDINAMICOS, botn derecho en
CUALQUIER BARRA DE HERRAMIENTAS, CLICK EN
Personalizar, Click en la solapa Comandos, de la lista de
la izquierda "Datos" y de la lista de la derecha buscar
"Generar GetPivotData", luego arrastrarla a alguna
barra de herramientas. Esto te permite encender o
3)
apagar la funcin.

Vendedor
Juan
Marcos
Susana

Susana
Susana
Mauro
Juan
Susana
Marcos
Marcos
Juan
Mauro
Marcos
Juan
Susana
Marcos
Juan
Juan
Carlos
Juan

Ventas
5
8
9
Suma de Ventas

6
8
10
9
10
7
9
9
8
5
10
9
10
5
8
5
8

Vendedor
Carlos
Juan
Marcos
Mauro
Susana
Total general

Total
5
54
39
18
42
158

Excel Facil Truco #34: Funcione

cel Facil Truco #34: Funciones ES

A quin quieres
buscar?
Mauro
Marcos

Sumar Ventas de
Mauro y Marcos

Pos a Encontrar
Ejemplo 1
Num
-6
9
-8
8
18
8
-6
-2
17
8
-10
16
-6
-9
20
3
16
16
14
-3
-1

2
Ejemplo 2
Num

2do nro pos


0
0
0
1
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

-6
9
-8
8
18
8
-6
-2
17
8
-10
16
-6
-9
20
3
16
16
14
-3
-1

2do nro pos


0
0
0
1
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0
0

Usa, =Y(CONTAR.SI($E$4:$E4,"
de nicamente, =CONTAR.SI($
que encuentre slamente el
ejemplo 1 con el

=Y(CONTAR.SI($E$4:$E4,">0")=2,$E4>0), en vez
nicamente, =CONTAR.SI($B$4:$B4,">0")=2, para
ue encuentre slamente el primero. Compara el
ejemplo 1 con el ejemplo 2

Juego
Hold 'Em Heads-UP $0-$5
Hold 'Em Heads-UP $5-$10
Hold 'Em Heads-UP $10-$20
Hold 'Em Heads-UP $20-$+
Hold 'Em STT 9-10 Jugadores
Hold 'Em STT 3-6 Jugadores
Hold 'Em Multi-table
Hold 'Em Cash Game Blinds $.25-$.50
Hold 'Em Cash Game Blinds $.50-$1

Monto
4.75
100
70
990
360
0
0
0
0

Mejor Juego

1)

Bsqueda invertida de doble entrada con duplicados

2)
3)
4)
5)
6)

Para ms informacin de Validacin de Datos, ver este video:


La funcin FILA nos dice en que fila estamos
La funcin FILAS nos dice cuantas filas hay.
La funcin COLUMNA nos dice en que columna estamos
La funcin COLUMNAS nos dice cuantas columnas hay

{=SI(COLUMNAS($D$10:D10)<=$C10;TEXTO(INDICE($H$10:$K$10;;K.ESI
MO.MENOR(SI($H$10:$K$15=$B10;COLUMNA($H$10:$K$10)7)
COLUMNA($H$10)+1);COLUMNAS($D$10:D10)));"d/m/a");"")}

Nombres de Nro. De
Pacientes
Citas
Nombre 1
Nombre 2
Nombre 3
Nombre 4
Nombre 5
Nombre 6
Nombre 7
Nombre 8
Nombre 9
Nombre 10
Nombre 11
Nombre 12
Nombre 13

Cita 1
2
0
0
1
0
0
0
0
0
0
0
0
1

Cita 2

Hora/Fecha
8:00 AM
9:00 AM
10:00 AM
11:00 AM
12:00 PM
1:00 PM

Excel Facil Truco #5: Lista de validacion de datos y BUSCARV

9/16/2013
Nombre 4

9/17/2013

9/18/2013
Nombre 13

Nombre 1
Nombre 1

9/19/2013

1)
2)

Bsqueda invertida de doble entrada con duplicados


Para ms informacin de Validacin de Datos, ver este video:

3)

La funcin FILA nos dice en que fila estamos

4)

La funcin FILAS nos dice cuantas filas hay.

5)
6)

La funcin COLUMNA nos dice en que columna estamos


La funcin COLUMNAS nos dice cuantas columnas hay

{=SI(COLUMNAS($D$10:D10)<=$C10;TEXTO(INDICE($H$10:$K$10;;K.ESI
MO.MENOR(SI($H$10:$K$15=$B10;COLUMNA($H$10:$K$10)7)
COLUMNA($H$10)+1);COLUMNAS($D$10:D10)));"d/m/a");"")}

Nombres de Nro. De
Pacientes
Citas
Nombre 1
Nombre 2
Nombre 3
Nombre 4
Nombre 5
Nombre 6
Nombre 7
Nombre 8
Nombre 9
Nombre 10
Nombre 11
Nombre 12
Nombre 13

Cita 1
Cita 2
2
9/17/2013
0
0
1
0
0
0
0
0
0
0
0
1

Hora/Fecha
8:00 AM
9:00 AM
10:00 AM
11:00 AM
12:00 PM
1:00 PM

Excel Facil Truco #5: Lista de validacion de datos y BUSCARV

9/16/2013
Nombre 4

9/17/2013

9/18/2013
Nombre 13

Nombre 1
Nombre 1

9/19/2013

1)
2)
3)

La funcin NO convierte un FALSO en un VERDADERO


ESNOD devuelve VERDADERO si hay un error N/A
=ESNUMERO(COINCIDIR(B6,E$6:E$14,0)) or =CONTAR.SI(B$6:B$18,E6)>0 son formulas
que van a verificar si un tem se encuentra en otra lista
Aladin
djquackquack
Lista 1
En Lista 2?
Lista 2
En Lista 1
4

1
5
10

fred
1
3
2
Mendoza
0
1
3
5
6

Mendoza
0
10
5

ADERO
N/A

$18,E6)>0 son formulas


tra lista
3)

=NO(ISNOD(INDICE($E$6:$E$14,COINCIDIR(B6,$E$6:$E$14,0)))) te dir si el
valor est en otra tabla
links:

1
1
1
0
1
1
1
0
1

aladin @ Mr Excel Message Board


djquackquack @ excelisfun comment section

14,0)))) te dir si el