Está en la página 1de 3

Ensenme

Objetivos
Configurar los parmetros iniciales en un dispositivo de red que utiliza el software Cisco IOS.
Los estudiantes utilizarn y reforzarn sus conocimientos de la CLI de Cisco IOS al explicarla a otros
estudiantes; asimismo, buscarn diferentes maneras de explicar el significado de comandos individuales.
Los estudiantes buscarn el grupo ptimo de comandos que se deba utilizar al configurar un dispositivo,
a fin de minimizar la cantidad necesaria de cambios de modos durante la configuracin.

Informacin bsica/Situacin
(Los estudiantes trabajarn de a dos. En esta actividad, se requiere el uso de Packet Tracer).
Suponga que un colega nuevo le pidi que lo oriente sobre la CLI de Cisco IOS. Este colega nunca trabaj
con dispositivos Cisco.
Usted le explica los comandos y la estructura bsicos de la CLI, porque desea que su colega comprenda que
la CLI es un lenguaje de comandos simple pero eficaz que se puede comprender y navegar fcilmente.
Utilice Packet Tracer y una de las actividades disponibles en este captulo como modelo de red simple
(por ejemplo, la actividad de laboratorio 2.3.3.5. Prctica de laboratorio: Configuracin de una direccin de
administracin del switch). Cntrese en estas reas:

Si bien los comandos son tcnicos, se asemejan a enunciados del lenguaje corriente?

Cmo se organiza el conjunto de comandos en subgrupos o modos? Cmo sabe un


administrador qu modo est utilizando?
Cules son los comandos individuales para configurar los parmetros bsicos de un
dispositivo Cisco? Cmo explicara este comando en un lenguaje sencillo? Establezca paralelos
con la vida real cuando sea adecuado.
Sugiera cmo agrupar distintos comandos segn sus modos de manera que se necesite una cantidad
mnima de desplazamientos entre modos.

Recursos necesarios

Packet Tracer

Cualquier actividad del modelo de red simple disponible del captulo 2

Reflexin

1. Despus de completar el captulo 2, considera que comprende concretamente lo que Cisco IOS hace

y cmo funciona? Si Cules fueron algunas de las dificultades que encontr al explicar los comandos y la
estructura bsicos de la CLI a su colega?En que no conocia los terminos.
Si fuera un colega nuevo, cules seran algunas de las dificultades que tendra al aprender los comandos
y la estructura bsicos de la CLI? Que los trminos estn en ingls.

2. Responda las siguientes preguntas y analice las respuestas con toda la clase:
a) Si bien los comandos son tcnicos, se asemejan a enunciados del lenguaje corriente?
Si. Las palabras clave como lo es enable, shutdown, IP address y password por ejemplo que en la
CLI su significado se adapta correctamente, aunque siguen teniendo gran relevancia en su uso
habitual.
b) Cmo se organiza el conjunto de comandos en subgrupos o modos? Cmo sabe un
administrador qu modo est utilizando?
2014 Cisco y/o sus filiales. Todos los derechos reservados. Este documento es informacin pblica de Cisco.

Pgina 1 de 3

Ensenme
Primero, el nivel de acceso a la CLI puede ser un nivel de usuario o un nivel de administrador. En el
nivel de administrador, se puede acceder al modo de configuracin que est dividido internamente en
modo de configuracin global, modo de configuracin de lnea, modo de configuracin de interfaz y
otros modos, segn sea necesario.
El modo actual se informa al administrador a travs de la peticin de entrada, donde el smbolo >
representa el nivel de acceso del usuario; # representa el nivel de acceso del administrador, y las
palabras clave optativas entre parntesis designan el modo de configuracin y los submodos
posibles.
c) Cules son los comandos individuales para configurar los parmetros bsicos de un
dispositivo Cisco? Cmo explicara este comando en un lenguaje sencillo? Establezca paralelos
con la vida real cuando sea adecuado.
enable: tener autorizacin para ejercer el control total sobre un dispositivo, entrar en modo
suerusuario.
configure terminal: iniciar el editor de configuracin y aceptar los cambios que provienen de la
terminal.
hostname: asignar un nombre a un dispositivo.
service password encryption: hace que el dispositivo oculte todas las contraseas introducidas en la
configuracin.
line con 0: introducir la configuracin de la lnea, o el socket, que tiene la etiqueta CONSOLE 0 en
el dispositivo y que se utiliza para administrar el dispositivo.
line vty 0 4: introducir la configuracin de cinco sockets virtuales que permitan la administracin
remota del dispositivo a travs de la red.
password: configurar una contrasea.
login: proteger el acceso mediante un procedimiento de inicio de sesin que requiere una contrasea
definida mediante el comando password.
exit: salir del modo actual para ir al modo ubicado en un nivel superior.
enable secret: frase secreta que protege el uso del comando enable.
banner: mensaje que se muestra a un usuario que intenta acceder el dispositivo.
interface Vlan 1: ingresar al modo de configuracin de la interfaz denominada Vlan1.
description: asignar un comentario.
ip address: asignar una direccin IP numrica a una interfaz.
no shutdown: eliminar el comando shutdown y, de esta manera, crear una interfaz activa.
end: salir del editor de configuracin.
d) Con la ayuda de su colega, intente sugerir cmo agrupar diversos comandos segn sus
modos, de manera que sea necesario realizar una cantidad mnima de desplazamientos entre
modos.
enable
configure terminal
hostname S1
service password-encryption
banner login ^
Access to this device permitted only to authorized personnel!

2014 Cisco y/o sus filiales. Todos los derechos reservados. Este documento es informacin pblica de Cisco.

Pgina 2 de 3

Ensenme
enable secret hola1234
line con 0
password 1234a
login
exit
line vty 0 4
password 1234a
login
exit
interface Vlan 1
ip address 192.168.2.1 255.255.255.0
no shutdown
end

2014 Cisco y/o sus filiales. Todos los derechos reservados. Este documento es informacin pblica de Cisco.

Pgina 3 de 3