Está en la página 1de 22

COMANDOS CCNA ROUTING & SWITCHING V5

Switch> show versin

Mostrar la versin de la imagen del


IOS del switch

Switch# clock set 15:08:00 Oct 26 2012

Configurar el reloj

Switch# show clock

verificar los parmetros del reloj

Switch> enable

Ingresa al modo EXEC privilegiado


Entra al modo de configuracin

Switch# configure terminal


Switch(config)# hostname S1

Paso 1: Asignar un nombre al switch


S1(config)# no ip domain-lookup
S1(config)# enable secret class
S1(config)# line con 0
S1(config-line)# password cisco
S1(config-line)# login
S1(config-line)# exit
S1(config)# banner motd #SOLO ACCESO AUTORIZADO#

S1# copy running-config startup-config

S1# show running-config


S1# show ip interface brief
R1# show ip interface brief
Switch# show flash
Switch# delete vlan.dat
Switch# erase startup-config
Switch# reload
Switch# enable secret class
S1#(config)# interface vlan 1
S1(config-if)# ip address 192.168.1.2
255.255.255.0

Evitar bsquedas de DNS no deseadas


Proteccin por consola. Configuracin
y login de acceso local.

Introducir un mensaje MOTD (mensaje


del da) de inicio de sesin
guardar la configuracin en ejecucin
en el archivo de inicio de la memoria
de acceso aleatorio no voltil
(NVRAM)
Mostrar la configuracin actual
Mostrar el estado de las interfaces
conectadas en el switch y en un
router
Ver los archivos almacenados en la
memoria flash
Borrar las VLANs de un switch
Borrar el archivo de configuracin de
inicio
Recargar el switch
Contrasea modo privilegiado
protegida
configurar la direccin IP de la SVI
para permitir la administracin
remota de switch.
1

COMANDOS CCNA ROUTING & SWITCHING V5


S1(config-if)# no shut
S1(config-if)# exit
S1(config)# line
S1(config-line)#
S1(config-line)#
S1(config-line)#

vty 0 4
password cisco
login
end

S2# show mac address-table


S2# clear mac address-table dynamic
R1(config)# service password-encryption
R1(config)# int g0/0
R1(config-if)# description Connection to PC-B.
R1(config-if)# ip address 192.168.0.1
255.255.255.0
R1(config-if)# no shut

No shutdown sirve para levantar las


interfaces.
Configurar la lnea de terminal
virtual (VTY) para que el switch
permita el acceso por Telnet

Visualizar la tabla de direcciones


MAC del switch
Borrar la tabla de direcciones MAC
Encriptar las contraseas de texto no
cifrado
Configurar IPv4, describir y levantar
una interfaz.

R1(config)# interface g0/0


R1(config-if)# ipv6 address 2001:db8:acad:a::1/64
R1(config-if)# no shutdown

Configurar IPv6 y levantar una


interfaz.

R1# show ipv6 interface brief

verificar que se asign la direccin


IPv6 unicast correcta a cada interfaz
Ver informacin detallada de la
interfaz
Configurar una direccin IPv6 de
enlace local.

R1# show ipv6 interface g0/0


R1(config)# interface g0/0
R1(config-if)# ipv6 address fe80::1 link-local
R1(config)# ipv6 unicast-routing

Habilitar el enrutamiento IPv6

S1# traceroute 192.168.3.3

Verificar la ruta que siguen los


paquetes
Probar conectividad hacia equipo
remoto
Pasos para configurar y habilitar
SSH.
Configurar hostname
Configurar dominio
Crear el par de claves rsa
Crear usuario con privilegios
de enable y contrasea
protegida
Ingresar a las lneas VTY

S1# ping 192.168.3.3

Router(config)# hostname R1
R1(config)# ip domain-name ccna-lab.com
R1(config)# crypto key generate rsa modulus 1024
R1(config)# username admin privilege 15 secret
adminpass
R1(config)# line vty 0 4
R1(config-line)# transport input telnet ssh
R1(config-line)# login local
R1(config-line)# end

S1# ssh -l admin 192.168.1.1

Habilitar slo SSH en estas


lneas
Habilitar el login a la base de
datos local
Ingresar por SSH al router

COMANDOS CCNA ROUTING & SWITCHING V5


R1(config)# security passwords min-length 10
R1(config)# line
R1(config-line)#
R1(config-line)#
R1(config-line)#
R1(config-line)#

console 0
exec-timeout 5 0
line vty 0 4
exec-timeout 5 0
exit

R1(config)# login block-for 30 attempts 2 within


120
R1# show login
R1(config)# interface loopback 0
R1(config-if)# ip address 209.165.200.225
255.255.255.224
R1(config-if)#
R1(config-if)#
255.255.255.0
R1(config-if)#
R1(config-if)#

int g0/1
ip address 192.168.1.1

Habilita un mnimo de 10 caracteres


para todas las contraseas
Cierra la sesin de la lnea despus
de cinco minutos de inactividad

Si alguien falla en dos intentos en


un perodo de 120 segundos, el router
bloquea los intentos de inicio de
sesin por 30 segundos
para ver el estado de inicio de
sesin
Crear y configurar interfaz loopback

Configurar direcionamiento en la
interfaz giga, levantarla y
describirla

no shut
description Connected to LAN

S1(config)# ip default-gateway 192.168.1.1


R1(config)# interface GigabitEthernet0/1
R1(config-if)# duplex auto
R1(config-if)# speed auto

Configurar el gateway predeterminado


en el switch
Configurar duplex y velocidad
automtica

R1(config)# interface GigabitEthernet0/1


R1(config-if)# duplex full
R1(config-if)# speed 100

Configurar duplex y velocidad manual

S1# copy running-config tftp:


Address or name of remote host []? 192.168.1.3
Destination filename [s1-confg]?

Respaldo del archivo de ejecucin en


un servidor TFTP

S1# copy tftp: running-config


Address or name of remote host []? 192.168.1.3
Source filename []? Switch1-confg.txt
Destination filename [running-config]?

Cargar el archivo desde un servidor


TFTP al archivo de ejecucin local
(RAM)

R1# show file systems

Mostrar los sistemas de archivo del


router
Respaldar el archivo de ejecucin en
la memoria flash
Ver desde el router el archivo de
ejecucin
Cargar desde la flash a la RAM el
archivo de ejecucin

R1# copy running-config flash:


R1# more flash:R1-running-config-backup
Router# copy flash:R1-running-config-backup
running-config

COMANDOS CCNA ROUTING & SWITCHING V5


1.
Establecer una conexin de terminal con el
router utilizando Tera Term u otro emulador de
terminal como SecureCRT (no Putty).
2.
Arrancar en modo ROMMON, ya sea por medio de
eliminar la memoria flash y reiniciar, o
presionando Alt-b durante el reinicio.
3.
Escribir confreg 0x2142 en la peticin de
entrada de ROMMON.
4.
Escribir reset en la siguiente peticin de
entrada de ROMMON.
5.
Escribir no en el cuadro de dilogo de
configuracin inicial.
6.
Escribir enable en la peticin de entrada
del router.
7.
Escribir copy startup-config running-config
para cargar la configuracin de inicio.
8.
Escribir show running-config.
9.
Registrar una contrasea de enable sin
encriptar. Restablecer una contrasea de enable
encriptada con enable secret cisco.

Recuperacin de contrasea y archivo


de inicio de un router

10.
En el modo de configuracin, escribir
config-register 0x2102.
11.
En el modo privilegiado, escribir copy
running-config startup-config para guardar la
configuracin.
12.
Utilizar el comando show version para
verificar los parmetros del registro de
configuracin.
R1#show arp

Ver cach arp

R1#show protocols
R1#show ip route

Verificar si el enrutamiento IP est


habilitado
Ver la tabla de enrutamiento

S1#show vlan

Ver informacin de VLAN

R1#show interface

Ver estado y protocolo de interfaces


incluyendo otra informacin
Ver informacin de IOS, interfaces,
registro de configuracin y otra.

R1#show version

COMANDOS CCNA ROUTING & SWITCHING V5

COMANDOS BSICOS DE SWITCH


S1# configure terminal
S1(config)# vlan 99
S1(config-vlan)# exit
S1(config)# interface vlan99
%LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan99,
changed state to down

S1(config-if)# ip address 192.168.1.2


255.255.255.0
S1(config-if)# no shutdown
S1(config)# interface range f0/1 24,g0/1 - 2
S1(config-if-range)# switchport access vlan 99
S1(config-if-range)# exit

S1(config)# ip default-gateway 192.168.1.1


S1(config)# line
S1(config-line)#
S1(config-line)#
S1(config-line)#

con 0
password cisco
login
logging synchronous

Ingresa modo de configuracin global


al switch
Por defecto la VLAN asociada a la
interfaz de administracin es la VLAN
1. Por seguridad se recomienda
cambiar esta a cualquier otra.
Ac se crea la VLAN 99 y se configura
con IP una SVI (Switching Virtual
Interface) para administrar
remotamente el switch.
Asignar un rango de puertos a una
VLAN.
En este caso se seleccion de la F0/1
a la F0/24 y adems la G0/1 a la G0/2
y se asignaron a la VLAN 99.
Para que el switch sea administrado
desde una red remota se le debe
agregar un gateway por defecto.
Configuramos contrasea en la
consola.
El logging synchronous sirve para que
un mensaje (log) no nos corte el
comando que estamos ingresando.

S1(config-line)# exit
S1(config)# line
S1(config-line)#
S1(config-line)#
S1(config-line)#

vty 0 15
password cisco
login
end

S1# show mac address-table dynamic


S1# clear mac address-table dynamic
S1(config)# mac address-table static
0050.56BE.6C89 vlan 99 interface fastethernet 0/6

Configuramos contrasea en las lneas


de terminal virtual (VTY).
Los switch tienen 16 lneas (0-15)

Para visualizar la tabla de


direcciones MAC. En este caso para
ver las aprendidas de forma dinmica.
Para limpiar la tabla de direcciones
MAC.
Para agregar una direccin de forma
manual y esttica a una interfaz

Switch# delete vlan.dat


Switch# erase startup-config
Switch# reload
Proceed with reload? [confirm]
System configuration has been modified. Save?
[yes/no]: no

Para borrar las VLANs y el archivo de


inicio de un switch.
Si pregunta por guardar las
modificaciones le decimos que no.

S1(config)# vlan 99

Crear y nombrar una VLAN.

COMANDOS CCNA ROUTING & SWITCHING V5


S1(config-vlan)# name Management
S1(config-vlan)# exit
S1(config)# interface f0/5
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 99

Configurar una interfaz de acceso y


asociarla a una VLAN.

S1(config)# ip domain-name CCNA-Lab.com


S1(config)# username admin privilege 15 secret
sshadmin
S1(config)# line vty 0 15
S1(config-line)# transport input ssh
S1(config-line)# login local
S1(config-line)# exit
S1(config)# crypto key generate rsa modulus 1024

Configuracin y habilitacin de SSH


en las lneas VTY de un switch.

S1(config)# ip ssh time-out 75

La sesin se cierra si el switch se


deja desatendido por 75 segundos

S1(config)# ip ssh authentication-retries 2


S1(config)# ip ssh version 2

Permite slo dos reintentos.


Cambio a la versin segura de SSH (2)

S1(config)# interface range f0/1 4


S1(config-if-range)# shutdown

Bajar un rango de interfaces

S1(config)# interface f0/5


S1(config-if)# switchport port-security
S1(config-if)# switchport port-security macaddress xxxx.xxxx.xxxx
S1(config-if)# switchport port-security macaddress sticky
S1# show port-security
S1# show port-security address

Habilitacin de seguridad de puerto


Agregar de forma esttica y manual
una MAC a una interfaz.
Agregar una MAC a una interfaz de
forma dinmica.
Verificacin de la configuracin de
port-security

COMANDOS DE VLAN Y TRONCAL (SWITCH)


S1(config)# vlan
S1(config-vlan)#
S1(config-vlan)#
S1(config-vlan)#

10
name Student
vlan 20
end

Crear y nombrar una VLAN.

S1(config)# interface f0/6


S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 10

Configuracin y asociacin a VLAN


de un puerto de acceso.

S1(config)# interface f0/6


S1(config-if)# switchport mode access
S1(config-if)# switchport port-security
S1(config-if)# switchport port-security maximum 1
S1(config-if)# switchport port-security mac-address
sticky
S1(config-if)# switchport port-security violation
shutdown

Configuracin y asociacin de
seguridad a una VLAN de un Puerto
de acceso.
Asigna para que solo se conecte 1
pc.
Asigna para que conozca direc. Mac
dinamicamente.
Asigna para que cuando haya alguna
violacion se deshabilite el
Puerto.

COMANDOS CCNA ROUTING & SWITCHING V5


S1# show vlan
S1# show vlan brief

Verificacin de VLANs

S1(config)# interface vlan 99


S1(config-if)# ip address 192.168.1.11
255.255.255.0
S1(config-if)# end

Configuracin de la VLAN
de administracin.

S1# show ip interface brief

Verificacin de estado e IP
de interfaces
6

COMANDOS CCNA ROUTING & SWITCHING V5


S1(config)# interface range f0/11-24
S1(config-if-range)# switchport mode access
S1(config-if-range)# switchport access vlan 10
S1(config-if-range)# end

Configurar un rango de interfaces


como acceso y asociarlas a una VLAN.

S1(config)# interface f0/24


S1(config-if)# no switchport access vlan
S1(config-if)# end

Eliminar una asignacin de VLAN.

S1(config)# no vlan 30

Eliminar una VLAN

S1(config)# interface f0/1


S1(config-if)# switchport mode dynamic desirable

Usar DTP (negociacin) para iniciar


un enlace troncal.

S1(config)# interface f0/1


S1(config-if)# switchport mode trunk

Configurar manualmente la interfaz


como troncal

S2# show interfaces trunk

Verificar la configuracin de los


enlaces troncales
Modificar la VLAN nativa. Esto se
debe hacer en los dos extremos del
enlace.
Deshabilitar la negociacin DTP en la
interfaz.

S1(config)# interface f0/1


S1(config-if)# switchport trunk native vlan 99
S1(config)# interface f0/1
S1(config-if)# switchport nonegotiate
S1(config)# interface f0/1
S1(config-if)# switchport trunk allowed vlan 10,99

Restringir las VLAN permitidas en un


enlace troncal.

COMANDOS DE CONFIGURACIN BASICA DE ROUTER


Router(config)# hostname R1

Ingresar al modo de configuracin


global
Asignar nombre al router

R1(config)# no ip domain-lookup

Deshabilitar la bsqueda DNS

R1(config)# security passwords min-length 10

Establecer el requisito de largo de


contraseas
Asignar contrasea privilegiada
protegida

Router# config terminal

R1(config)# enable secret cisco12345


R1(config)# line
R1(config-line)#
R1(config-line)#
R1(config-line)#
R1(config-line)#
R1(config-line)#

con 0
password ciscoconpass
exec-timeout 5 0
login
logging synchronous
exit

R1(config)# line
R1(config-line)#
R1(config-line)#
R1(config-line)#
R1(config-line)#

vty 0 4
password ciscovtypass
exec-timeout 5 0
login
logging synchronous

Asignar la contrasea a la consola.


Establecer un tiempo de espera por
una sesin.

Evita que los logs o alertas corten


el comando que se est ingresando.
Asignar contrasea a las lneas VTY
(TELNET, SSH).
Establecer un tiempo de espera por
una sesin.
Evita que los logs o alertas corten
el comando que se est ingresando.

COMANDOS CCNA ROUTING & SWITCHING V5


R1(config)# service password-encryption

Cifrar las contraseas no protegidas

R1(config)# banner motd #INGRESO NO AUTORIZADO#

Crear aviso de advertencia al que


accede.
Describir y configurar una interfaz y
luego activarla.

R1(config)# int g0/0


R1(config-if)# description Connection to PC-B
R1(config-if)# ip address 192.168.0.1
255.255.255.0
R1(config-if)# no shutdown
R1(config)# ip domain-name CCNA-lab.com
R1(config)# username admin privilege 15 secret
adminpass1
R1(config)# line vty 0 4
R1(config-line)# transport input ssh
R1(config-line)# login local
R1(config-line)# exit
R1(config)# crypto key generate rsa modulus 1024
R1(config)# exit

Crear dominio.
Crear usuario con privilegios de
enable

Habilitacin de SSH en las lneas VTY


Autenticacin local
Generar la clave RSA

COMANDOS DE DIRECCIONAMIENTO IPV6 ROUTER


R1(config)# interface g0/0
R1(config-if)# ipv6 address 2001:db8:acad:a::1/64
R1(config-if)# ipv6 address fe80::1 link-local
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# ipv6 unicast-routing

Asignar IPv6 global a la interfaz


Asignar IPv6 de link local

Habilitar enrutamiento IPv6 unicast


Verificar direccionamiento IPv6 y
estado de las interfaces

R1#show ipv6 int brief

COMANDOS PARA ACCESO HTTP, HTTPS, CCP Y SDM


R1(config)# ip http server
R1(config)# ip http secure-server
R1(config)# username admin privilege 15 secret
adminpass1

Habilita servicio http (puerto 80 de


TCP)
Habilita servicio https (puerto 443
de TCP)
Crear usuario con privilegios de
enable y contrasea protegida (MD5).

COMANDOS ENRUTAMIENTO ENTRE VLAN. ROUTE ON A STICK


R1(config)# interface g0/1.1

Creacin de las subinterfaces

R1(config-subif)# encapsulation dot1Q 1

Encapsulamiento de la subinterfaz, se
asocia a la VLAN correspondiente con
el nmero de la VLAN.

R1(config-subif)# ip address 192.168.1.1


255.255.255.0

Asignacin de IP a la subinterfaz

RUTAS ESTTICAS
R1(config)# ip route 192.168.1.0 255.255.255.0
10.1.1.2

Ruta esttica con IP de router de


siguiente salto
8

COMANDOS CCNA ROUTING & SWITCHING V5


R3(config)# ip route 192.168.0.0 255.255.255.0
s0/0/0

Ruta esttica con interfaz de salida

R1(config)# ip route 0.0.0.0 0.0.0.0 s0/0/1

Ruta por defecto con interfaz de


salida
Ruta por defecto con IP de siguiente
salto
Ruta esttica con interfaz de salida

R1(config)# ip route 0.0.0.0 0.0.0.0 10.1.1.2


R1(config)# ipv6 route 2001:DB8:ACAD:B::/64 serial
0/0/1
R1(config)# ipv6 route 2001:DB8:ACAD:B::/64
FC00::2

Ruta esttica con IP de router de


siguiente salto

R1(config)# ipv6 route ::/0 serial 0/0/1

Ruta por defecto con interfaz de


salida
Ruta por defecto con IP de siguiente
salto
Verificar tabla de enrutamiento

R1(config)# ipv6 route ::/0 FC00::2


ISP# show ipv6 route

Verificar interfaces por estado y


configuracin de IPv6

BRANCH# show ipv6 interface brief

COMANDOS RIPV2 Y RIPNG


R1(config)# router
R1(config-router)#
R1(config-router)#
R1(config-router)#
R1(config-router)#
R1(config-router)#
R2(config-router)#

rip
version 2
passive-interface g0/1
network 172.30.0.0
network 10.0.0.0
no auto-summary
default-information originate

Ingresar a la configuracin RIP.


Cambiar a la versin 2.
Evita que actualizaciones RIP se
enven por esa interfaz
Declarar las redes directamente
conectada.

R1# show ip protocols

Desactiva a sumarizacin automtica


Redistribucin de rutas por defecto
Confirma el protocolo configurado

R2# debug ip rip

Examinar actualizaciones RIP

R1(config)# ipv6 router rip Test1


R1(config)# interface g0/1
R1(config-if)# ipv6 rip Test1 enable
R1(config)# interface s0/0/0
R1(config-if)# ipv6 rip Test1 enable

Configuracin de RIPng

R1# show ipv6 protocols

Verificar el protocolo configurado.

R1# show ipv6 rip Test1

Verificar el proceso RIP configurado.

R2(config)# int s0/0/0


R2(config-if)# ipv6 rip Test2 default-information
originate

Redistribucin de una ruta por


defecto dentro de la interfaz.

COMANDOS OSPF
R1(config)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255
area 0

Ingresar al modo de configuracin de


OSPF
Declaracin de las redes con sus
correspondientes wildcard.
9

COMANDOS CCNA ROUTING & SWITCHING V5


R1(config-router)# network 192.168.12.0 0.0.0.3
area 0
R1(config-router)# network 192.168.13.0 0.0.0.3
area 0
R1# show ip ospf

Verificacin del proceso OSPF

R1# show ip ospf interface brief


R1# show ip ospf neighbor

Ver vecinos OSPF

R1# show ip ospf neighbor


R1(config)# router ospf 1
R1(config-router)# router-id 11.11.11.11
Reload or use "clear ip ospf process" command, for this
to take effect

R1(config)# end
R1# show ip ospf interface g0/0
R1(config)# router ospf 1
R1(config-router)# passive-interface g0/0

Configurar el ID de router OSPF.


Si el router ya tiene un ID va a
pedir reiniciar el proceso OSPF con
el comando "clear ip ospf process"
Para ver detalles de OSPF dentro de
la interfaz, por ejemplo los timers.
Pone todas las interfaces como
pasivas

R2(config)# router ospf 1


R2(config-router)# passive-interface default

Configurar como pasiva una interfaz.

R2# show ip route ospf

Ver la tabla de enrutamiento OSPF.

R1(config)# router ospf 1


R1(config-router)# auto-cost reference-bandwidth
10000

Modificar la frmula de clculo de


los costos. Usar cuando se usen
interfaces de mayor ancho de banda
que 100Mbps.
Esto, adems de modificar el valor
del ancho de banda, cambia el costo
de la interfaz OSPF.
Cambia el costo a un valor
especfico.

R1(config)# interface s0/0/0


R1(config-if)# bandwidth 128
R1(config)# int s0/0/1
R1(config-if)# ip ospf cost 1565
R1(config)# ipv6 router ospf 1
R1(config-rtr)# router-id 1.1.1.1
R1(config)# interface g0/0
R1(config-if)# ipv6 ospf 1 area 0

Configuracin de OSPF V3 (IPv6)


Se debe agregar un ID de router en
formato IPv4
Habilitar las interfaces para OSPF
IPv6

R2# show ipv6 ospf

Verificar el proceso OSPF V3

R1# show ipv6 ospf neighbor

Ver los vecinos OPSF IPv6

R1# show ipv6 protocols

Ver los protocolos de enrutamiento


IPv6 configurados
Ver las interfaces activas para OSPF
V3

R1# show ipv6 ospf interface


R1# show ipv6 ospf interface brief
R2# show ipv6 route
R2# show ipv6 route ospf

Ver la tabla de enrutamiento IPv6

R1# show ipv6 ospf interface g0/0

Ver informacin detallada de una


interfaz OSPF
Poner pasiva una interfaz OSPF

R1(config)# ipv6 router ospf 1

10

COMANDOS CCNA ROUTING & SWITCHING V5


R1(config-rtr)# passive-interface g0/0
R2(config)# ipv6 router ospf 1
R2(config-rtr)# passive-interface default

Poner todas las interfaces pasivas


por defecto

R2(config-rtr)# no passive-interface s0/0/1

Activar una interfaz que era pasiva


para OSPF

LISTAS DE ACCESO
R3(config)# access-list 1 remark Allow R1 LANs
Access
R3(config)# access-list 1 permit 192.168.10.0
0.0.0.255
R3(config)# access-list 1 deny any
R3(config)# interface g0/1
R3(config-if)# ip access-group 1 out

Describir la ACL numerada estndar


(1-99).
Permitir una red completa
Denegar todo el resto
Se aplica a una interfaz de entrada o
de salida

R3# show access-lists 1


R3# show access-lists

Verificar la configuracin de las


ACL.

R3# show ip interface g0/1


R3# show ip interface

Para ver dnde se aplic la ACL

R1(config)# ip access-list standard BRANCH-OFFICEPOLICY


R1(config-std-nacl)# permit host 192.168.30.3
R1(config-std-nacl)# permit 192.168.40.0 0.0.0.255

Crea la ACL estndar nombrada

R1(config)# interface g0/1


R1(config-if)# ip access-group BRANCH-OFFICEPOLICY out

Se aplica a una interfaz de salida o


entrada.

R1#(config)# ip access-list standard BRANCHOFFICE-POLICY


R1(config-std-nacl)# 30 permit 209.165.200.224
0.0.0.31
R1(config-std-nacl)# 40 deny any
R1(config-std-nacl)# end

Las ACL nombradas se pueden editar


indicando la posicin de ella.

R1(config)# ip access-list standard ADMIN-MGT


R1(config-std-nacl)# permit host 192.168.1.3
R1(config)# line vty 0 4
R1(config-line)# access-class ADMIN-MGT in
R1(config-line)# exit

Crear una lista de acceso para ser


aplicada para controlar los accesos a
las lneas VTY.
Especificar el o los hosts.
Ingresar las lneas VTY.
Aplicar la ACL de entrada a las
lneas VTY.
Describir la ACL extendida (100-199)
numerada.

R1(config)# access-list 100 remark Allow Web & SSH


Access
R1(config)# access-list 100 permit tcp host
192.168.10.3 host 10.2.2.1 eq 22
R1(config)# access-list 100 permit tcp any any eq
80

Permite un nico host.


Permite una red completa

Permite a una IP origen a una IP


destino y un puerto destino TCP 22
(SSH).

11

COMANDOS CCNA ROUTING & SWITCHING V5


Permite cualquier origen a cualquier
destino al puerto destino TCP 80
(HTTP).
Se aplica de entrada o salida en una
interfaz.

R1(config)# int s0/0/0


R1(config-if)# ip access-group 100 out
R3(config)# ip access-list extended WEB-POLICY
R3(config-ext-nacl)# permit tcp 192.168.30.0
0.0.0.255 host 10.1.1.1 eq 80
R3(config-ext-nacl)# permit tcp 192.168.30.0
0.0.0.255 209.165.200.224 0.0.0.31 eq 80
R3(config-ext-nacl)# int S0/0/1
R3(config-if)# ip access-group WEB-POLICY out
R1(config)# ipv6 access-list RESTRICT-VTY
R1(config-ipv6-acl)# permit tcp
2001:db8:acad:a::/64 any
R1(config-ipv6-acl)# permit tcp any any eq 22
R1(config-ipv6-acl)# line vty 0 4
R1(config-line)# ipv6 access-class RESTRICT-VTY in
R1(config-line)# end
R1(config)# ipv6 access-list RESTRICTED-LAN
R1(config-ipv6-acl)# remark Block Telnet from
outside
R1(config-ipv6-acl)# deny tcp any
2001:db8:acad:a::/64 eq telnet
R1(config-ipv6-acl)# permit ipv6 any any
R1(config-ipv6-acl)# int g0/1
R1(config-if)# ipv6 traffic-filter RESTRICTED-LAN
out
R1(config-if)# end

Crear una ACL extendida nombrada.


Permite a una red ir a un host al
puerto destino TCP 80.
Permite a una red ir a una subred al
puerto destino TCP 80.
Se aplica de entrada o salida a una
interfaz.
Crear una ACL nombrada IPv6.
Permite tcp a una red a cualquier
destino.
Permite SSH de cualquier origen a
cualquier destino.
Se aplica la ACL de entrada en las
lneas VTY.
Crear la ACL IPv6.
Describirla.
Denegar que desde una red se haga
telnet.
Se permite el resto.
Se aplica de salida a una interfaz.

R1# show ipv6 access-lists RESTRICTED-LAN

Verificar la ACL

R1# clear ipv6 access-list RESTRICTED-LAN

Limpia los contadores de


coincidencia.

DHCP
R2(config)# ip dhcp excluded-address 192.168.0.1
192.168.0.9

Excluye un rango de direcciones IP a


asignar.

R2(config)# ip dhcp pool R1G1


R2(dhcp-config)# network 192.168.1.0 255.255.255.0
R2(dhcp-config)# default-router 192.168.1.1
R2(dhcp-config)# dns-server 209.165.200.225
R2(dhcp-config)# domain-name ccna-lab.com
R2(dhcp-config)# lease 2

Crea el pool del DHCP.


A la red a la cual le va asignar
direccionamiento
Define el gateway por defecto de la
red.
Define el DNS de la red.
Algn servidor de dominio de la red.
El tiempo de reserva de una IP
Si el servidor DHCP est en otra red,
se convierten los broadcast en

R1(config)# interface g0/0

12

COMANDOS CCNA ROUTING & SWITCHING V5


R1(config-if)# ip helper-address 192.168.2.254

direcciones unicast. La IP del


servidor DHCP remoto.

CONFIGURACIN CON ESTADO (DHCP) Y SIN ESTADO (SLAAC)IPV6


S1(config)# interface vlan 1
S1(config-if)# ipv6 address autoconfig

Para obtener una IPv6 a travs de


SLACC

R1(config)# ipv6 dhcp pool IPV6POOL-A


R1(config-dhcpv6)# domain-name ccnastatelessDHCPv6.com

Configurar un servidor DHCP IPv6.


Se crea el pool DHCP.
Se asigna un nombre al pool. Este
DHCP es sin estado.

R1(config-dhcpv6)# dns-server
2001:db8:acad:a::abcd

Asigna una direccin del servidor


DNS.
Agrega un prefijo de red al pool.
Se asigna el pool a una interfaz

R1(config)# interface g0/1


R1(config-if)# ipv6 dhcp server IPV6POOL-A

Permite la deteccin de redes con


paquetes de descubrimiento de vecinos
(ND) en una interfaz
Para configurar un DHCP con estado.
Para definir una direccin de
asignacin.

R1(config-if)# ipv6 nd other-config-flag


R1(config-dhcpv6)# address prefix
2001:db8:acad:a::/64
R1(config-dhcpv6)# domain-name ccnaStatefulDHCPv6.com
R1# show ipv6 dhcp binding
R1# show ipv6 dhcp pool

Verificar asignacin de IP e
informacin del pool DHCP.

R1(config)# interface g0/1


R1(config-if)# shutdown
R1(config-if)# ipv6 nd managed-config-flag
R1(config-if)# no shutdown
R1(config-if)# end

Para permitir que la interfaz enve


mensajes RA (Router Advertisment)

S1(config)# interface vlan 1


S1(config-if)# ipv6 address autoconfig

Permite a la interfaz VLAN obtener


una direccin IPv6 a travs de SLAAC.

NAT
Gateway(config)# ip nat inside source static
192.168.1.20 209.165.200.225
Gateway(config)# interface g0/1
Gateway(config-if)# ip nat inside
Gateway(config-if)# interface s0/0/1
Gateway(config-if)# ip nat outside

Configura un NAT esttico.

Define la interfaz que va a la red


interna

Gateway# show ip nat translations

Define la interfaz que va a la red


externa
Verifica la traduccin

Gateway# show ip nat statics

Verificar estadsticas de NAT

Gateway# clear ip nat translation *


Gateway# clear ip nat statistics

Limpta la tabla y estadsticas

13

COMANDOS CCNA ROUTING & SWITCHING V5

NAT DINMICO
Gateway(config)# access-list 1 permit 192.168.1.0
0.0.0.255

Permite que se traduzca la red


especificada

Gateway(config)# ip nat pool public_access


209.165.200.242 209.165.200.254 netmask
255.255.255.224

Define el conjunto de direcciones


pblicas utilizables a traducir.

Gateway(config)# ip nat inside source list 1 pool


public_access

Define la lista origen interna que se


va a traducir al conjunto externo.

NAT CON SOBRECARGA


Gateway(config)# access-list 1 permit 192.168.1.0
0.0.0.255

Permitir que esas direcciones se


traduzcan

Gateway(config)# ip nat pool public_access


209.165.200.225 209.165.200.230 netmask
255.255.255.248

Define el conjunto de direcciones IP


pblicas utilizables.

Gateway(config)# ip nat inside source list 1 pool


public_access overload

Define el NAT desde la lista origen


al conjunto de IPs externas
sobrecargado.
NAT con sobrecarga sin definir el
pool externo, sino que la interfaz de
salida.
Identifica las interfaces inside y
outside.

Gateway(config)# ip nat inside source list 1


interface serial 0/0/1 overload
Gateway(config)# interface g0/1
Gateway(config-if)# ip nat inside
Gateway(config-if)# interface s0/0/1
Gateway(config-if)# ip nat outside

14

COMANDOS CCNA ROUTING & SWITCHING V5

CCNA3 Routing and Switching: Scaling Networks


COMANDOS PARA SPANNING-TREE
S1# show spanning-tree
S1(config)# interface f0/2
S1(config-if)# spanning-tree cost 18
S1(config)# interface f0/2
S1(config-if)# no spanning-tree cost 18

S2(config)# spanning-tree vlan 1,10,99 root


primary

S1(config)# spanning-tree vlan 1,10,99 root


secondary

Muestra la instancia del spanningtree en el switch.


Cambia el costo de un puerto para el
clculo del spanning-tree.
En este caso se cambia el costo de la
interfaz f0/2 a 18.
Remueve el costo de un puerto
para el clculo del spanningtree, ocasionando que regrese a
su valor por defecto.
En este caso se quita el costo de 18
previamente asignado a la interfaz
f0/2.
Asigna al switch como root bridge
primario para las VLANs
especificadas.
En este caso, se indica que S2 ser
root bridge primario para las VLANs
1, 10 y 99.
Asigna al switch como root
bridge secundario para las
VLANs especificadas.
En este caso, se indica que S1 ser
root bridge secundario para las VLANs
1, 10 y 99.

S3# debug spanning-tree events


S3(config)# interface f0/1
S3(config-if)# shutdown
*Mar 1 00:58:56.225: STP: VLAN0001 new root port
Fa0/3, cost 38
*Mar 1 00:58:56.225: STP: VLAN0001 Fa0/3 ->
listening
*Mar 1 00:58:56.225: STP[1]: Generating TC trap
for port FastEthernet0/1

Permite observer el debug de spanningtree.


En este caso, desactivamos la interfaz
f0/1 en S3, y vamos observando gracias
al debug la seleccin de un Nuevo root
port y los estados por los que va
transitando.

S3# no debug spanning-tree events

Detiene el debug de spanning-tree.

S1(config)# spanning-tree mode rapid-pvst

Activa el protocol Rapid PVST+ en el


switch.
Configura un puerto como PortFast,
para que ste se transicione
inmediatamente al estado
forwarding.
En este caso, se configure a f0/6
como portfast.
Previene que un puerto configurado
como portfast permita el paso de
BPDUs.
En este caso, se configure a f0/6
con BPDU Guard.

S1(config)# interface f0/6


S1(config-if)# spanning-tree portfast

S1(config)# interface f0/6


S1(config-if)# spanning-tree bpduguard enable

COMANDOS CCNA ROUTING & SWITCHING V5

S3(config)# spanning-tree portfast default


S3(config)# spanning-tree portfast bpduguard
default

Configura a todos los puertos (no


troncales) del switch como portfast.
Configura a todos los puertos (no
troncales) del switch con BPDU Guard.

COMANDOS PARA ETHERCHANNEL (PAgP)


S1(config)# interface range f0/3-4
S1(config-if-range)# channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1
S1(config-if-range)# no shutdown
S3(config)# interface range f0/3-4
S3(config-if-range)# channel-group 1 mode auto
Creating a port-channel interface Port-channel 1
S3(config-if-range)# no shutdown
*Mar 1 00:09:12.792: %LINK-3-UPDOWN: Interface
FastEthernet0/3, changed state to up
*Mar 1 00:09:12.792: %LINK-3-UPDOWN: Interface
FastEthernet0/4, changed state to up

Configura el rango de puertos


indicado por Port Aggregation
Protocol, en modo desirable.
En este caso, los puertos f0/3 y f0/4
forman un solo puerto lgico en modo
desirable de PAgP.
Configura el rango de puertos
indicado por Port Aggregation
Protocol, en modo auto.
En este caso, los puertos f0/3 y f0/4
forman un solo puerto lgico en modo
auto de PAgP.
*observe que una vez creados (y
levantados) los port-channel tanto en
S1 como S3, se establece la conexin.

S1# show etherchannel summary

Verifica las configuraciones


Etherchannel en el switch.
*Funciona tanto para PAgP como para
LACP.

S1(config)# interface port-channel 1


S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk native vlan 99

Asigna al port-channel indicado como


troncal, y a su correspondiente vlan
administrative.

S3(config)# interface port-channel 1


S3(config-if)# switchport mode trunk
S3(config-if)# switchport trunk native vlan 99

*observe que port-channel 1 se forma


de la unin de S1 y S2, por lo que en
ambos switches se hace la asignacin
a puerto troncal.

COMANDOS PARA ETHERCHANNEL (LACP)


S1(config)# interface range f0/1-2
S1(config-if-range)# switchport mode trunk
S1(config-if-range)# switchport trunk native vlan
99
S1(config-if-range)# channel-group 2 mode active
Creating a port-channel interface Port-channel 2
S1(config-if-range)# no shutdown

Configura el rango de puertos


indicado por Link Aggregation Control
Protocol, en modo active.
En este caso, los puertos f0/1 y f0/2
forman un solo puerto lgico en modo
active de LACP.
*observe que en este caso, se decide
preasignar los puertos como troncales
antes de formar el port-channel 2.

COMANDOS CCNA ROUTING & SWITCHING V5


S2(config)# interface range f0/1-2
S2(config-if-range)# switchport mode trunk
S2(config-if-range)# switchport trunk native vlan
99
S2(config-if-range)# channel-group 2 mode passive
Creating a port-channel interface Port-channel 2
S2(config-if-range)# no shutdown

Configura el rango de puertos


indicado por Link Aggregation Control
Protocol, en modo passive.
En este caso, los puertos f0/1 y f0/2
forman un solo puerto lgico en modo
passive de LACP.
*observe que en este caso, se decide
preasignar los puertos como troncales
antes de formar el port-channel 2.

COMANDOS CCNA ROUTING & SWITCHING V5

COMANDOS PARA FIRST HOP REDUNDANCY (HSRP)


R1(config)# interface g0/1
R1(config-if)# standby 1 ip 192.168.1.254
R1(config-if)# standby 1 priority 150
R1(config-if)# standby 1 preempt

Configura una default gateway


redundante mediante Hot Standby
Routing Protocol.
En este caso, se indica que la
interfaz g0/1 en R1 forma parte del
router virtual (192.168.1.254) con
una prioridad de 150.
*con el commando standby 1 preempt,
R1 se vuelve el router activo.

R3(config)# interface g0/1


R3(config-if)# standby 1 ip 192.168.1.254

Configura una default gateway


redundante mediante Hot Standby
Routing Protocol.
En este caso, se indica que la
interfaz g0/1 en R3 forma parte del
router virtual (192.168.1.254).
Muestra la configuracin de HSRP en
el
router,
principalmente
si
el
router est activo o en standby.
Muestra la configuracin resumida de
HSRP en el router.

R3# show standby


R3# show standby brief
R1(config)# interface g0/1
R1(config-if)# no standby 1

Deshabilta la configuracin de HSRP en


la interfaz indicada.

COMANDOS PARA FIRST HOP REDUNDANCY (GLBP)


R1(config)# interface
R1(config-if)# glbp 1
R1(config-if)# glbp 1
R1(config-if)# glbp 1
R1(config-if)# glbp 1

g0/1
ip 192.168.1.254
preempt
priority 150
load-balancing round-robin

R3(config)# interface g0/1


R3(config-if)# glbp 1 ip 192.168.1.254
R3(config-if)# glbp 1 load-balancing round-robin

R3# show glbp brief

Configura una default gateway


redundante mediante Ciscos Gateway
Load Balancing Protocol.
En este caso, se indica que la
interfaz g0/1 en R1 forma parte del
router virtual (192.168.1.254) con
una prioridad de 150.
*con el commando glbp 1 loadbalancing round-robin , se indica el
mtodo para el balanceo de carga que
se desea usar.
Configura una default gateway
redundante mediante Ciscos Gateway
Load Balancing Protocol.
En este caso, se indica que la
interfaz g0/1 en R3 forma parte del
router virtual (192.168.1.254).
Muestra la configuracin resumida de
GLBP en el router.

OSPF AVANZADO (aplica tanto a OSPFv2 como OSPFv3)


R4(config)# interface g0/1
R4(config-if)# ip ospf priority 255

Configura en la interfaz que se


indique la prioridad que se usar
para la eleccin de DR/BDR.
En este caso, g0/1 de R1 se le
asigna una prioridad de 255
(valor ms alto posible, asegura
ser DR).

COMANDOS CCNA ROUTING & SWITCHING V5


R2# debug ip ospf adj
OSPF adjacency debugging is on

Permite observer el debug de las


adyacencias en OSPF.

R1(config)# interface s0/0/0


R1(config-if)# ip ospf message-digest-key 1 md5
MD5KEY
R1(config-if)# ip ospf authentication messagedigest
*Mar 19 00:03:18.187: OSPF-1 ADJ
Se0/0/0: Rcv pkt
from 192.168.12.1 : Mismatched Authentication type.
Input packet specified type 2, we use type 0
R2# undebug all

Aplica autenticacin MD5 a nivel


interfaz.
En este caso, la interfaz s0/0/0 de
R1 se le asigna la KEY de MD5KEY, y
como es a nivel interfaz, tambin se
activa.
*note que como el debug est
activado, se refleja la prdida de
la adyacencia porque el otro router
no tiene autenticacin configurada.
Se desactiva el debug con el comando
undebug all.

R1(config)# router ospf 1


R1(config-router)# area 0 authentication messagedigest
R1(config)# interface s0/0/1
R1(config-if)# ip ospf message-digest-key 1 md5
MD5KEY

Aplica autenticacin MD5 a nivel


rea.
En este caso, en el proceso 1 de
OSPF en R1 se active la
autenticacin para el area 0 y a la
interfaz s0/0/1 de R1 se le asigna
la KEY de MD5KEY.
*tenga en cuenta que para OSPFv3 la
forma de ingresar al proceso de ospf
sera con el commando ipv6 router
ospf 1.

OSPFv2 Multiarea
R1# show ip protocols

R1#

show ip ospf database

R1(config)# router ospf 1


R1(config-router)# area 1 range 192.168.0.0
255.255.252.0

Muestra opciones de OSPF en el router,


como el tipo de router y las redes
asignadas a cada rea.
Muestra la Link State Data Base para
todas las reas que existen en el
router consultado.
Configura una ruta sumarizada para
anunciarse por OSPF.
En este caso, se seala que en el area
1 se anuncien como una sola red todas
las direcciones que se encuentren en
la red 192.168.0.0/22.

OSPFv3 Multiarea
R2# show ipv6 ospf

Verifica parmetros de OSPF, como


el router id.

R1(config)# interface lo0


R1(config-if)# ipv6 ospf 1 area 1
R1(config-if)# ipv6 ospf network point-to-point

Cambia el tipo de red OSPFv3


default a point-to-point.
En este caso, se crea la Loopback
0, se seala que participle en
ospf, y se seala que se tome como
una red point-to-point.
Verifica el status de OSPFv3.
Muestra la LSDB para las reas que
existen en el router consultado.

R1# show ipv6 protocols


R1# show ipv6 ospf database
R1(config)# ipv6 router ospf 1
R1(config-rtr)# area 1 range 2001:DB8:ACAD::/62

Configura manualmente la
sumarizacin interarea de IPv6.

COMANDOS CCNA ROUTING & SWITCHING V5

EIGRP para IPv4


R1(config)# router eigrp 10

Crea el proceso EIGRP en el router y


se asigna al Sistema autnomo
indicado.
En este caso, se asigna al AS 10.

R1(config-router)# network 10.1.1.0 0.0.0.3

Aade una red para que sta sea


anunciada por EIGRP.

R1# show ip eigrp neighbors

Verifica las adyacencias establecidas


por medio de EIGRP.

R1# show ip route eigrp

Muestra las rutas disponibles en la


tabla de enrutamiento que fueron
aprendidas por EIGRP.
Muestra la topologa completa de
EIGRP, incluyendo aquellas rutas que
no estn en la table de enrutamiento.

R1# show ip eigrp topology

R1(config)# interface s0/0/0


R1(config-if)# ip summary-address eigrp 1
192.168.1.0 255.255.255.240
R1(config)# router eigrp 1
R1(config-rtr)# redistribute static

Anuncia una ruta sumarizada de EIGRP


en la interfaz que se indique.

R1(config)# interface s0/0/0


R1(config-if)# ip bandwidth-percent eigrp 1 75

Asigna un porcentaje de utilizacin


del ancho de banda del que dispone la
interfaz.
*tambin aplica para IPv6, colocando
ipv6 bandwidth-percent.

R1(config)# interface s0/0/0


R1(config-if)# ip hello-interval eigrp 1 50
R1(config-if)# ip hold-time eigrp 1 150

Asigna nuevos valores (en segundos)


para los prametros de hello y
hold, en la interfaz que se
indique.
*tambin aplica para IPv6,
colocando ipv6 en vez de ip.

R1(config)# key chain EIGRPKEY


R1(config-keychain)# key 1
R1(config-keychain-key)# key-string cisco123

Crea una keychain y una key que


sern usadas para autentificar la
conexin entre dos routers.
*tambin aplica para EIGRP en IPv6.

R1(config)# interface s0/0/0


R1(config-if)# ip authentication mode eigrp 1 md5
R1(config-if)# ip authentication key-chain eigrp 1
EIGRPKEY

Coloca la autenticacin por MD5 en


la interfaz que se indique
utilizando la keychain previamente
creada.
*tambin aplica para IPv6,
colocando ipv6 en vez de ip.

Redistribuye una ruta esttica a


travs de EIGRP.
*tambin aplica para IPv6, ingresando
con el comando ipv6 router eigrp 1.

COMANDOS CCNA ROUTING & SWITCHING V5

EIGRP para IPv6


R1(config)# ipv6 router eigrp 1

Comienza la configuracin de EIGRP


para IPv6 en el AS que se indique.
En este caso, se usa el AS 1.

R1(config-rtr)# eigrp router-id 1.1.1.1

Asigna un Router ID para el AS de


EIGRP.
*importante recordar que mientras
que este commando es opcional en
EIGRP para IPv4, en EIGRP para IPv6
es obligatorio.
Activa EIGRP para IPv6.
*este comando no se utiliza en
EIGRP para IPv4.
Hace participar a la interfaz en
EIGRP del AS especificado.

R1(config)# ipv6 router eigrp 1


R1(config-rtr)# no shutdown
R1(config)# interface g0/0
R1(config-if)# ipv6 eigrp 1
R1# show ipv6 eigrp neighbors

Verifica las adyacencias


establecidas por medio de EIGRP.

R1# show ipv6 route eigrp

Muestra las rutas disponibles en la


tabla de enrutamiento que fueron
aprendidas por EIGRP.

R1#

Muestra la topologa completa de


EIGRP, incluyendo aquellas rutas
que no estn en la table de
enrutamiento.

show ipv6 eigrp topology

R1(config)# interface s0/0/0


R1(config-if)# ipv6 summary-address eigrp 2
2001:DB8:ACAD::/48

Anuncia una ruta sumarizada de EIGRP


en la interfaz que se indique.