Está en la página 1de 19

CAPITULO III

III.1. Los Sistemas de Ecuaciones.


La necesidad de tener mtodos eficientes para resolver sistemas de ecuaciones algebraicas
lineales, es ms importante an, que la solucin de ecuaciones no lineales. Esto es debido a
que en muchos casos los problemas de matemticas aplicadas se reducen a un conjunto de
ecuaciones que constituyen un sistema lineal. Por este motivo puede decirse con razn que
la principal tarea del anlisis numrico es la solucin de sistemas de ecuaciones lineales.
Se ha desarrollado una extraordinaria coleccin de algoritmos para llevar a cabo la solucin
de los sistemas lineales, lo que indica que es engaoso el aparente carcter elemental del
problema. En forma semejante a las ecuaciones no lineales, cuyos mtodos de solucin se
estudiaron en el captulo anterior, los sistemas lineales pueden resolverse por medio de
mtodos exactos y de aproximaciones sucesivas. Antes de establecer estos mtodos, se
recordarn algunos conceptos fundamentales sobre las matrices y los sistemas lineales.
III.2. Antecedentes.
MATRICES. Una matriz es un arreglo de la forma:
a11
a
21
a31

...
a m1

a12

a13

a 22

a 23

a32
...

a33
...

am2

a m3

... a1n
... a 2 n
... a3n

... ...
... a mn

Mtodos Numricos

Para toda matriz cuadrada A (m = n) cuyo determinante es distinto de cero, existe una
matriz (denotada A-1) que satisface la relacin que siguiente:
A A-1 = A-1 A = I
donde I es una matriz identidad.
TRANSFORMACIONES ELEMENTALES DE FILAS. Toda matriz puede ser
transformada en otra aplicando las llamadas transformaciones elementales de filas:
1. Multiplicar una fila por un escalar no nulo.
2. Sumar a una fila un mltiplo de otra fila.
3. Intercambiar dos filas.
Se puede demostrar (lo cual se estudiar aqu) que aplicar una transformacin elemental de
filas a una matriz A es igual a aplicar esa transformacin a una matriz I y multiplicarla por
A. As, comprobando con un ejemplo, se tiene la siguiente matriz:
a11
A = a 21
a31

a12
a 22
a32

a13
a 23
a33

aplicndole la segunda transformacin se tiene:


a11 + ka31
B = a 21
a31

a12 + ka32
a 22
a32

lo anterior equivale a:
1 0 0
I = 0 1 0
0 0 1

transformada en:

E1+k3

1 0 k
= 0 1 0
0 0 1

35

a13 + ka33
a 23
a 33

Mtodos Numricos

NOTA: La matriz E es una matriz I a la cual se le ha practicado una transformacin. El


subndice indica el tipo de transformacin; as, 1 + k3 significa que a la primera
fila se le suma la tercera multiplicada por k.
y multiplicando:
1 0 k a11
E1+k3 A = 0 1 0 a 21
0 0 1 a31

a12
a 22
a32

a13
a 23
a33

se obtiene B:
a11 + ka31
a
21

a31

a12 + ka32
a 22
a32

a13 + ka33
a 23
a 33

Dada una matriz A no singular (| A | 0) de orden n, siempre es posible encontrar tantas


matrices de la forma, E tales que al aplicarlas a A la conviertan en matriz identidad. As:
E1 E2 E3 . . . Er A = I
Si en la igualdad anterior se multiplican ambos miembros por A-1:
E1 E2 E3 . . . Er A A-1 = I A-1
efectuando los productos se obtiene:
E1 E2 E3 . . . Er I = I A-1
Lo anterior indica que si se parte de una matriz identidad, se puede llegar a la inversa de
una matriz, efectuando los mismos pasos que se efectuaron para llegar a la matriz I a partir
de la matriz original. Para lograr lo anterior, trabjese con la matriz ampliada (A, I),
transformando la parte izquierda de esta en I:
Ejemplo: Calcular A-1 de:
2 4 6
A = 3 2 1
4 2 3

Si el determinante es distinto de cero, la matriz tiene inversa:

36

Mtodos Numricos

2 4 6
| A | = 3 2 1 = (12 + 16 + 36) (48 + 4 + 36) = 64 88 = - 24 0
4 2 3

Trabajando la matriz ampliada:

2 4 6 1 0 0

A = 3 2 1 0 1 0
4 2 3 0 0 1
1 2 3 1 / 2 0 0 f 1 2

A = 0 4 8 3 / 2 1 0 f 2 + 3 f 1
0 6 9 2 0 1 f 3 4 f 1

1 0 1 1 / 4 1 / 2 0 f 1 + 2 f 2

A = 0 1 2 3 / 8 1 / 4 0 f 2 (4)
0 0 3 1 / 4
3 / 2 1 f 3 6 f 2
1 0 0 1 / 6
0 1/ 3 f 1 + f 3

A = 0 1 0 5 / 24 3 / 4 2 / 3 f 2 + 2 f 3
0 0 1 1 / 12 1 / 2 1 / 3 f 3 3
Para la obtencin de la matriz identidad, se siguieron las transformaciones de filas en el
siguiente orden:
1.
2.
3.
4.

Eleccin de un PIVOTE como un elemento sobre la diagonal principal.


Divisin de la fila del PIVOTE entre el PIVOTE.
Eleccin de un ANULADOR como un elemento sobre la columna del PIVOTE.
Resta, a la fila del ANULADOR, la fila del PIVOTE multiplicada por el
ANULADOR.
5. Repeticin de los pasos 3 y 4 hasta que la columna del pivote se anule.
6. Repeticin de los pasos 1, 2, 3 y 4, hasta que la matriz se hace unitaria.

ECUACIN ALGEBRAICA LINEAL. Una ecuacin algebraica lineal es una ecuacin


en donde en cada trmino de esta aparece nicamente una variable o incgnita elevada a la
primera potencia, por ejemplo:

a1 x1 + a2 x2 + . . . + an xn = b

37

Mtodos Numricos

es una ecuacin algebraica lineal en las variables x1, x2, . . ., xn. Se admite que los
coeficientes a1, a2, . . ., an y el trmino independiente b, de la ecuacin, son constantes
reales.
SISTEMAS DE ECUACIONES. Un sistema de ecuaciones es un conjunto de ecuaciones
que deben resolverse de manera simultnea. En lo sucesivo se considerarn nicamente
sistemas de ecuaciones algebraicas lineales; o sea, conjuntos de ecuaciones de la siguiente
forma:

a11 x1 + a12 x2 + a13 x3 + . . . + a1n xn = b1


a21 x1 + a22 x2 + a23 x3 + . . . + a2n xn = b2
a31 x1 + a32 x2 + a33 x3 + . . . + a3n xn = b3
...

...

...

...

...

...

am1 x1 + am2 x2 + am3 x3 + . . . + amn xn = bn


Aplicando la definicin de producto entre matrices, este sistema de ecuaciones puede
escribirse en la forma:
a11
a
21
a31

...
a m1

a12

a13

a 22

a 23

a 32
...

a33
...

am 2

a m3

... a1n x1 b1
... a 2 n x 2 b2
... a3n x3 = b3

... ... ... ...
... a mn x n bn

El sistema de ecuaciones puede escribirse simblicamente como A X = B, en donde A se


llama matriz del sistema. La matriz formada por A, a la que se le ha agregado el vector de
trminos independientes ( B ) como ltima columna, se le llama la matriz ampliada del
sistema y se representa con (A, B).
SOLUCION DE UN SISTEMA DE ECUACIONES. La solucin de un sistema de
ecuaciones es un conjunto de valores de las incgnitas que satisfacen simultneamente a
todas y cada una de las ecuaciones del sistema.

De acuerdo con su solucin, un sistema puede ser: compatible, si admite solucin,


incompatible, si no lo admite.
Un sistema compatible puede ser: determinado, si la solucin es nica, indeterminado, si
tiene soluciones infinitas.
TEOREMAS SOBRE RANGOS. El rango de una matriz es el orden del determinante no
nulo de mayor orden que se puede obtener de esa matriz. El rango de la matriz A se
representa con la notacin r(A) y el de la matriz ampliada, por r(A, B).

En lgebra se demuestra que:

38

Mtodos Numricos

( a ) Para cualquier sistema r(A) r(A, B).


( b ) si r(A) < r(A, B) el sistema es incompatible.
( c ) si r(A) = r(A, B) el sistema de ecuaciones es compatible.
( c.1. ) si r(A) = n, el sistema es determinado.
( c.2. ) si r(A) < n, el sistema es indeterminado (siendo n el nmero de
variables en el sistema).
Por ejemplo, para el sistema de ecuaciones:
3 x1 + 2 x2 = 5
2 x1 + 4 x2 = 6
los valores x1 = 1 y x2 = 1, en las incgnitas, lo satisfacen completamente; luego es una
solucin de l, y puede afirmarse que el sistema es compatible. Para este problema puede
demostrarse que r(A) = r(A, B) = 2, por lo que el sistema es compatible, como se indic,
y adems determinado; o sea, que la solucin mencionada es la nica admisible.
En el caso de:
3 x1 + 2 x2 = 5
3 x1 + 2 x2 = 10
no existe ningn par de valores para x1 y x2 que hagan que 5 sea igual a 10, por lo que el
sistema es incompatible. Para este sistema puede demostrarse que r(A) =1 y que r(A,B) = 2.
Para el sistema:
3 x1 + 2 x2 = 5
6 x1 + 4 x2 = 10
se puede observar que x1 = 1 y x2 = 1 es solucin del sistema, por lo que es compatible.
Tambin, x1 = 0, x2 = 5/2 es solucin del sistema, por lo que es indeterminado.
5 3 x1
Fcilmente puede verse que cualquier par de valores x1 y x2 que cumplan que x2 =
2
es solucin del sistema. Para este sistema se demuestra que r(A) = r(A, B) 1 < 2; es
decir, el sistema es compatible indeterminado como se indic. La solucin numrica de un
sistema de ecuaciones siempre debe sustituirse en las ecuaciones originales, para garantizar
la validez de la solucin obtenida.
III.3. Los Mtodos.

Se presentan a continuacin cuatro mtodos para solucionar Sistemas de Ecuaciones


Lineales. Dos de ellos son iterativos y utilizan el criterio de Cauchy para la convergencia.

39

Mtodos Numricos

III.3.1. Mtodo de Gauss Jordan.

Este mtodo es aplicable a sistemas de ecuaciones compatibles y permiten la extraccin de


la solucin por medio de las transformaciones elementales de filas. Las transformaciones
de filas convierten al sistema en otro equivalente; esto es, un sistema distinto con la misma
solucin.
Recordando que: dada la matriz del sistema A, no singular (| A | 0), siempre es posible
encontrar tantas matrices de la forma E, tales que al aplicarlas a A la conviertan en
identidad. As:
E1 E2 E3 . . . Er A = I
y partiendo de la igualdad A X = B, multiplquense ambos miembros de la igualdad por E1
E2 E3 . . . Er:
E1 E2 E3 . . . Er A X = E1 E2 E3 . . . Er B
efectuando los productos, se obtiene:
( E1 E2 E3 . . . Er A ) X = E1 E2 E3 . . . Er B
I X = E1 E2 E3 . . . Er B
X = E1 E2 E3 . . . Er B
Esto es, para hallar la matriz X de soluciones, se debe aplicar a B las mismas
transformaciones que se le aplicaron a la matriz A para convertirla en identidad.
Este mtodo, conocido como mtodo de Gauss Jordan, trabaja la matriz ampliada (A, B)
y obtiene la matriz (I, X).
A continuacin se presenta el algoritmo para las transformaciones de las filas en un
sistema:
Algoritmo Gauss-Jordan
Leer n
m=n+1
Para i = 1 hasta n
Para j = 1 hasta m
Leer aij
fin_para
fin_para
Para i = 1 hasta n
Pivote = aii
Para j = 1 hasta m
aij = aij/pivote
fin_para

40

Mtodos Numricos

Para k = 1 hasta n
Si k i entonces
cero = aki
Para j = 1 hasta m
akj = akj - cero * aij
fin_para
fin_si
fin_para
fin_para
Para i = 1 hasta n
Imprimir aim
fin_para
Terminar

Ejemplo 1. Resolver por Gauss Jordan el siguiente sistema:


2 x1 + x2 x3 = - 3
- x1 + 5 x2 4 x3 = 2
3 x1 2 x2 + 23 x3 = 4
Solucin:
2
1 1 3

1 5 4 2
3 2 23 4
pivote = 2; anuladores = -1, 3.
1 1 / 2 1 / 2 3 / 2

0 11 / 2 9 / 2 1 / 2 f 2 + f 1
0 7 / 2 49 / 2 17 / 2 f 3 3 f 1
pivote = 11/2; anuladores = 1/2, - 7/2.
1 0 1 / 11 17 / 11 f 1 + 1 / 2 f 2

0 1 9 / 11 1 / 11
0 0 238 / 11 97 / 11 f 3 + 7 / 2 f 2
pivote = 238/11; anuladores = - 9/11, - 1/11.

41

Mtodos Numricos

1 0 0 359 / 238 f 1 + 1 / 11 f 3

0 1 0 101 / 238 f 2 + 9 / 11 f 3
0 0 1 97 / 238
As:
x1 = - 359/238 = - 1.5084034
x2 = 101/238 = 0.4243697
x3 = 97/238 = 0.4075630

(Sistema Compatible Determinado)

Ejemplo 2. Resolver por Gauss Jordan el siguiente sistema:


2 x1 - x2 + x3 = - 4
x1 + 2 x2 x3 = - 1
3 x1 + x2
= 4
Solucin:
2 1 1 4

1 2 1 1
3 1
0 3
pivote = 2; anuladores = 1, 3.
1 1 / 2 1 / 2 2

0 5 / 2 3 / 2 3 f 2 f 1
0 5 / 2 3 / 2 3 f 3 3 f 1
Como f2 = f3, hgase f3 = f2 f3.
1 1 / 2 1 / 2 2

0 5 / 2 3 / 2 3
0
0
0 0
De aqu r(A) = r(A, B) < n, el sistema tiene infinitas soluciones.
soluciones, se extrae el sistema de la ltima matriz:

Para obtener las

x1 x2 + x3 = 2
5/2 x2 3/2 x3 = - 3
Igulese alguna incgnita a un valor de a (con a en R); por ejemplo, X2 = a y despjese las
otras incgnitas para dejarlas en trminos de a.
42

Mtodos Numricos

x1 = 1 a/3
x2 = a
x3 = 2 + 5/3 a

(Sistema Compatible Indeterminado)

Ejemplo 3. Resolver por Gauss Jordan el siguiente sistema.


x1 +
x3 x4 = - 1
2 x1 3 x2 + x3 x4 = 2
- x1 + x2 2 x3 + x4 = 3
x1 + x2
- x4 = 0
Solucin:
1
0
1 1 1

2 3 1 1 2
1 1 2 1 3

1
0 1 0
1

pivote = 1, anulador = 2, - 1, 1
1 0
1 1 1

0 3 1 1 0 f 2 2 f 1
0 1 1 0 2 f 3 + f 1

0 1 1 0 1 f 4 f 1

pivote = - 3, anulador = - 1, - 1
1

0
0

1 1
f1

1 1/ 3 1/ 3 0
0 4 / 3 1/ 3 2 f 3 f 2

0 4 / 3 1 / 3 1 f 4 f 2
0

pivote = - 4/3, anulador = 1, 1/3, - 4/3


1

0
0

0 0 3 / 4 1/ 2 f 1 f 3

1 0 1 / 4 3 / 2 f 2 1 / 3 f 31
0 1 1 / 4 3 / 2

1 f 4 4 / 3 f 3
0 0
0

As, r(A) < r(A, B); no hay solucin

(Sistema Incompatible)

43

Mtodos Numricos

III.3.2. Mtodo de Jacobi.

Este es un mtodo alterno e iterativo en la bsqueda de soluciones de sistemas de


ecuaciones y utiliza el criterio de Cauchy como criterio de paro. Para derivar la frmula del
mtodo, hgase A = D + R; esto es, la matriz del sistema se divide en dos, de las cuales la
matriz D es una matriz diagonal y R, por el contrario, es tal que slo la diagonal principal
tiene elementos cero. As,
a11
a
21
a31

...
a m1

a12

a13

a 22

a 23

a32
...

a33
...

am2

a m3

... a1n a11


... a 2 n 0
... a3n = 0

... ... ...
... a mn 0

...

a 22
0
...

...

a33
...

...
...

...

0 0
0 a 21
0 + a31

... ...
a mn a m1

a12
0

a13

a 32
...

a 23
0
...

am 2

a m3

... a1n
... a 2 n
... a3n

... ...
... 0

Derivando la frmula:
AX = B
(D + R) X = B
DX+RX = B
DX = BRX
X = B D-1 R X D-1

forma matricial del sistema


sustituyendo A
quitando los parntesis
despejando
multiplicando por D-1

De lo anterior se observa lo siguiente: para calcular el valor de X se requiere conocer el


valor de X. Esto no es una contradiccin, sino que de aqu se manifiesta la naturaleza
iterativa del mtodo: se requiere dar una primera aproximacin a la matriz X para acercarse
al valor real segn una preestablecida. As, la frmula general del mtodo es:
Xi+1 = B D-1 R D-1 Xi
Se puede demostrar que este mtodo converge siempre que cada elemento sobre la diagonal
principal sea mayor, en valor absoluto, que la suma de los otros elementos de la fila, en
valor absoluto.
De la frmula iterativa, se tiene:
Xi+1 = D-1 (B R Xi)
Esto equivale a despejar del sistema las xi de la i - sima ecuacin, en forma matemtica:
xi =

1
aii

bi aij x j

j =1

44

con j i

Mtodos Numricos

Este mtodo requiere de un valor inicial para X (por simplicidad se toma el vector cero) y
se detiene el proceso hasta que se cumpla que |Xi+1 Xi| < (ntese que X es el vector de
soluciones; esto es, TODOS los valores de x deben cumplir con lo anterior).
A continuacin se presenta el algoritmo para el mtodo de Jacobi:
Algoritmo Jacobi:
Leer n,
Para i = 1 hasta n
Para j = 1 hasta n+1
Leer aij
fin_para
fin_para
Para i = 1 hasta n
xi = 0
fin_para
Repetir
fin = verdadero
Para i = 1 hasta n
yi = ai,n+1
Para j = 1 hasta n
Si i j entonces
yi = yi aij*xj
fin_si
fin_para
yi = yi/aii
delta = |xi yi|
Si delta > entonces
fin = falso
fin_si
fin_para
Para i = 1 hasta n
xi = yi
fin_para
hasta fin
Para i = 1 hasta n
Imprimir xi
fin_para
Terminar

Ejemplo: Calcular la solucin ( = 0.001) del siguiente sistema:


4 x1 x2 + x3 = 3
- x1 + 4 x2 + x3 = - 2
2 x1 + x2 + 5 x3 = 3

45

Mtodos Numricos

Comprobando si el mtodo es adecuado para el sistema:


(a)

(b)

| 4 |> | - 1 | + | 1 |
| 4 |> | - 1 | + | 1 |
| 5 |> | 2 | + | 1 |
4

1 1

1
2

4
1

1 0
5

Los elementos sobre la diagonal principal, en valor absoluto, fueron mayores que la suma
de los dems elementos de la fila, tambin en valor absoluto. Si esto no se cumpliera, se
pueden reordenar las ecuaciones para que esto se d. Si ningn reordenamiento permite
que esto se cumpla, se determinara que el mtodo no es apropiado para el sistema.
Despejando las xi de las i simas ecuaciones:
3 + x 2 x3
4
2 + x1 x3
x2 =
4
3 2 x1 x 2
x3 =
5
x1 =

Por facilidad se toma X1 = {0, 0, 0} y sustituyendo en las ecuaciones despejadas, se


obtiene:
x1 = 0.7500
x2 = - 0.5000
x3 = 0.6000
Sustituyendo estos nuevos valores se obtiene:
x1 = 0.4750
x2 = - 0.4625
x3 = 0.4000

| 0.4750 0.7500 | >


| - 0.4625 + 0.5000 | >
| 0.4000 0.6000 | >

Sustituyendo estos nuevos valores se obtiene:


x1 = 0.5343
x2 = - 0.4812
x3 = 0.5025

| 0.5343 - 0.4750 | >


| - 0.4812 + 0.4625 | >
| 0.5025 - 0.4000 | >

Sustituyendo estos nuevos valores se obtiene:

46

Mtodos Numricos

x1 = 0.5040
x2 = - 0.4920
x3 = 0.4825

| 0.5040 0.5343 | >


| - 0.4920 + 0.4812 | >
| 0.4825 0.5025 | >

Sustituyendo estos nuevos valores se obtiene:


x1 = 0.5063
x2 = - 0.4946
x3 = 0.4967

| 0.5063 0.5040 | >


| - 0.4946 + 0.4920 | >
| 0.4967 0.4825 | >

Sustituyendo estos nuevos valores se obtiene:


x1 = 0.5022
x2 = - 0.4976
x3 = 0.4963

| 0.5022 0.5063 | >


| - 0.4976 + 0.4946 | >
| 0.4963 0.4967 | >

Sustituyendo estos nuevos valores se obtiene:


x1 = 0.5015
x2 = - 0.4985
x3 = 0.4986

| 0.5015 0.5022 | >


| - 0.4985 + 0.4976 | >
| 0.4986 0.4963 | >

Sustituyendo estos nuevos valores se obtiene:


x1 = 0.5007
x2 = - 0.4992
x3 = 0.4991

| 0.5007 0.5015 | <


| - 0.4992 + 0.4985 | <
| 0.4991 0.4986 | <

Finalmente:
x1 = 0.5007
x2 = - 0.4992
x3 = 0.4991
III.3.3. Mtodo de Gauss Seidel.

Este mtodo es en general idntico al de Jacobi; la diferencia consiste en que una vez
calculada la componente xi, de la k sima iteracin, se usa inmediatamente en esta misma.
Por esta razn el mtodo de Gauss Seidel tambin se llama de iteraciones parciales o
desplazamientos sucesivos.
Por esta razn, este mtodo converge ms rpido que el de Jacobi y puede convergir cuando
el de Jacobi no lo hace. Se presenta a continuacin el algoritmo estructurado para este
mtodo, en el cual se puede apreciar la diferencia entre uno y otro:

47

Mtodos Numricos

Algoritmo Gauss - Seidel:


Leer n,
Para i = 1 hasta n
Para j = 1 hasta n+1
Leer aij
fin_para
fin_para
Para i = 1 hasta n
xi = 0
fin_para
Repetir
fin = verdadero
Para i = 1 hasta n
y = ai,n+1
Para j = 1 hasta n
Si i j entonces
y = y aij*xj
fin_si
fin_para
y = y/aij
delta = |xi y|
Si delta > entonces
fin = falso
fin_si
xi = y
fin_para
hasta fin
Para i = 1 hasta n
Imprimir xi
fin_para
Terminar

Ejemplo: Calcular la solucin ( = 0.001) del siguiente sistema:


4 x1 x2 + x3 = 3
- x1 + 4 x2 + x3 = - 2
2 x1 + x2 + 5 x3 = 3
Comprobando si el mtodo es adecuado para el sistema:
(a)

| 4 |> | - 1 | + | 1 |
| 4 |> | - 1 | + | 1 |
| 5 |> | 2 | + | 1 |

48

Mtodos Numricos

(b)

1 1

1
2

4
1

1 0
5

Los elementos sobre la diagonal principal, en valor absoluto, fueron mayores que la suma
de los dems elementos de la fila, tambin en valor absoluto. Si esto no se cumpliera, se
pueden reordenar las ecuaciones para que esto se d. Si ningn reordenamiento permite
que esto se cumpla, se determinara que el mtodo no es apropiado para el sistema.
Despejando las xi de las i simas ecuaciones:
3 + x 2 x3
4
2 + x1 x3
x2 =
4
3 2 x1 x 2
x3 =
5
x1 =

Por facilidad se toma X1 = {0, 0, 0} y sustituyendo en las ecuaciones despejadas, se


obtiene:
x1 = 0.7500
x2 = - 0.3125
x3 = 0.3625
Sustituyendo estos nuevos valores se obtiene:
x1 = 0.58120
x2 = - 0.4453
x3 = 0.4565

| 0.5812 0.7500 | >


| - 0.4453 + 0.3125 | >
| 0.4565 0.3625 | >

Sustituyendo estos nuevos valores se obtiene:


x1 = 0.5245
x2 = - 0.4830
x3 = 0.4867

| 0.5245 - 0.5812 | >


| - 0.4830 + 0.4553 | >
| 0.4867 - 0.4565 | >

Sustituyendo estos nuevos valores se obtiene:


x1 = 0.5075
x2 = - 0.4948
x3 = 0.4959

| 0.5075 0.5245 | >


| - 0.4948 + 0.4830 | >
| 0.4959 0.4867 | >

Sustituyendo estos nuevos valores se obtiene:

49

Mtodos Numricos

x1 = 0.5023
x2 = - 0.4984
x3 = 0.4987

| 0.5023 0.5075 | >


| - 0.4984 + 0.4948 | >
| 0.4987 0.4959 | >

Sustituyendo estos nuevos valores se obtiene:


x1 = 0.5007
x2 = - 0.4995
x3 = 0.4996

| 0.5007 0.5023 | >


| - 0.4995 + 0.4984 | >
| 0.4996 0.4987 | >

Sustituyendo estos nuevos valores se obtiene:


x1 = 0.5002
x2 = - 0.4998
x3 = 0.4998

| 0.5002 0.5007 | <


| - 0.4998 + 0.4995 | <
| 0.4998 0.4996 | <

Finalmente:
x1 = 0.5002
x2 = - 0.4998
x3 = 0.4998
Si bien es cierto que se produjo el ahorro de una sola iteracin con respecto al mtodo de
Jacobi, es de notar que la solucin se encuentra ms cercana a su valor real (x1 = 0.5; x2 = 0.5; x3 = 0.5). Por otro lado, la convergencia est muy relacionada con los valores de inicio
para el vector X.
III.3.4. Mtodo de Montante.

Este mtodo es relativamente nuevo (apareci al principio de la dcada de los setentas) y


fue diseado por el Ing. Ren Mario Montante Pardo en la Universidad Autnoma de
Nuevo Len. Se utiliza para obtener la inversa de una matriz, resolver un sistema de n
ecuaciones con n incgnitas, encontrar la matriz adjunta y calcular el determinante. Tiene
las siguientes ventajas sobre el mtodo de Gauss Jordan:
El Mtodo de Montante trabaja exclusivamente con nmeros enteros. Por
consiguiente, evita los errores por truncamiento y redondeo y
reduce
considerablemente las operaciones y la complejidad de las mismas.
El Mtodo de Montante calcula la inversa de una matriz, resuelve un sistema de
ecuaciones, encuentra la matriz adjunta y calcula el determinante, al mismo
tiempo.
El Mtodo de Montante es aplicable en otras reas en las cuales se manejen
sistemas de ecuaciones y es fcilmente adaptable a tales reas.

50

Mtodos Numricos

PROCEDIMIENTO:

( 1 ) Elegir un PIVOTE como un elemento sobre la diagonal principal.


( 2 ) Mantener la fila del PIVOTE sin cambios.
( 3 ) Convertir a ceros todos los elementos desde la primera columna hasta la
columna del PIVOTE, excepto los elementos de la diagonal principal, los
cuales sern iguales al PIVOTE.
( 4 ) Calcular los elementos restantes, segn la frmula:
aik aij
si aij est por arriba de la fila del PIVOTE
a kk a kj
a kk

a kj

aik

aij

si aij est por debajo de la fila del PIVOTE

( 5 ) Dividir estos entre el PIVOTE anterior. Para la primera iteracin, se toma


como la unidad.
( 6 ) El procedimiento se repite hasta obtener por el lado izquierdo de la matriz
aumentada, una matriz diagonal.
NOTAS:

( a ) Si se trabaja una matriz aumentada (A, B) se obtiene una matriz (D, Y), donde D
es una matriz diagonal cuyos elementos son iguales al determinante de A y Y/d
es la solucin del sistema.
( b ) Si se trabaja una matriz aumentada (A, I) se obtiene una matriz (D, Adj), donde
Adj es la matriz adjunta de A y Adj/d es la inversa de esta.
( c ) Si no quiere trabajar los determinantes de los signos contrarios, puede utilizar la
siguiente frmula:
aij = aij * PIVOTE akj * aik
Esta frmula ya contempla el signo para cuando el elemento buscado est arriba de la
fila del PIVOTE.
Finalmente, el algoritmo para este mtodo:
Algoritmo Montante:
Leer n
Para i = 1 hasta n
Para j = 1 hasta n+1
Leer aij
fin_para
fin_para
pivotant = 1
Para k = 1 hasta n
Para i = 1 hasta n

51

Mtodos Numricos

Si i k entonces
Para j = k+1 hasta n+1
aij = (aij*akk aik*akj)/pivotant
fin_para
fin_si
fin_para
pivotant = ak,k
fin_para
Para i = 1 hasta n
Imprimir ai,n+1/ann
fin_para
Terminar

Ejemplo: Resolver el siguiente sistema por el Mtodo de Montante.


4 x1 x2 + x3 = 3
- x1 + 4 x2 + x3 = - 2
2 x1 + x2 + 5 x3 = 3
Solucin:
4 1 1 3

1 4 1 2
2 1 5 3
4 1 1 3

0 15 5 5
0 6 18 6
15 0 5 10

0 15 5 5
0 0 60 30
60 0 0 30

0 60 0 30
0 0 60 30
As:
x1 = 0.5
x2 = - 0.5
x3 = 0.5
52