Está en la página 1de 14

FACULTAD DE INGENIERIA

CURSO: ALGORITMOS Y ESTRUCTURA


DE DATOS

EJERCICIOS DE ESTRUCTURA
SELECTIVA O CONDICIONAL
AUTORES:
Valuis Ramrez Axel
Huertas Aguirre Alexis
Alegre Obregn Jorge
Rosas Alegre ngelo
Castillo Solrzano Tony (NO TRABAJO)
Fajardo Tueros Lisandro (NO TRABAJO)

CHIMBOTE 2016

1. Hallar la suma de los 100 primeros nmeros enteros positivos.


DIAGRAMA DE FLUJO

DIAGRAMA N - S
Ejercicio 01

Inicio

C, suma=0,
C=C+1

Suma = suma + C
Leer (nmero)
C < 100
Escribir (La suma de los 100 primeros nmeros positivos es, suma)

Fin

PSEUDOCODIGO
Algoritmo Ejercicio_01
Var
Entero: c, suma
Inicio
c=0
suma = 0
mientras (c < 100) hacer
c=c+1
suma = suma + c
fin_mientras
Escribir (La suma de los 100 primeros nmeros positivos es, suma)
Fin

PROGRAMA DE JAVA

2. Hallar la suma y promedio de los 50 primeros nmeros enteros


positivos pares.
DIAGRAMA DE FLUJO

DIAGRAMA N S
Ejercicio 02

Inicio

C, suma, par,
C=C+1
Suma = suma + C
Leer (nmero)
C < 50

Prom = suma/50
Escribir (La suma de los 50 primeros nmeros positivos pares es, suma)
Escribir (El promedio de los 50 primeros nmeros positivos pares es, prom)

Fin

PSEUDOCODIGO
Algoritmo Ejercicio_02
Var
Entero: c, suma, par
Real: prom
Inicio
c=0
suma = 0
par = 0
mientras (c < 50) hacer
c=c+1
par = par +2
suma = suma + c
fin_mientras
prom = suma/50
Escribir (La suma de los 50 primeros nmeros positivos pares es, suma)
Escribir (El promedio de los 50 primeros nmeros positivos pares es, prom)
Fin

PROGRAMA DE JAVA

3. Hallar la suma y promedio de los 100 primeros nmeros enteros


positivos impares.
DIAGRAMA DE FLUJO

DIAGRAMA N - S
Ejercicio 03

Inicio

C, suma, impar, prom

C=C+1
impar = impar +2
Suma = suma + C
Leer (nmero)
C < 100
Prom = suma/100
Escribir (La suma de los 100 primeros nmeros positivos impares es, suma)
Escribir (El promedio de los 100 primeros nmeros positivos impares es, prom)

Fin

PSEUDOCODIGO
Algoritmo Ejercicio_03
Var
Entero: c, suma, par
Real: prom
Inicio
c=0
suma = 0
impar = -1
mientras (c < 100) hacer
c=c+1
impar = impar +2
suma = suma + c
fin_mientras
prom = suma/100
Escribir (La suma de los 100 primeros nmeros positivos impares es, suma)
Escribir (El promedio de los 100 primeros nmeros positivos impares es, prom)
Fin

PROGRAMA EN JAVA

4. Hallar la suma y promedio de los nmeros enteros positivos


comprendidos entre 500 y 1000.
DIAGRAMA DE FLUJO

DIAGRAMA N S
Ejercicio 04
Inicio C, suma, prom,

c=c+1
Suma = suma + C
Leer (nmero)
C < 100
Prom = suma/501
Escribir (La suma de los nmeros comprendidos entre 500 y 100 es, suma)
Escribir (El promedio de los nmeros comprendidos entre 500 y 100 es, prom)

Fin

PSEUDOCODIGO
Algoritmo Ejercicio_04
Var
Entero: c, suma
Real: prom
Inicio
c=0
suma = 0
mientras (c < 100) hacer
c=c+1
suma = suma + c
fin_mientras
prom = suma/501
Escribir (La suma de los nmeros comprendidos entre 500 y 100 es, suma)
Escribir (El promedio de los nmeros comprendidos entre 500 y 100 es, prom)
Fin

PROGRAMA EN JAVA

5. Hallar la suma de los nmeros enteros positivos pares e impares


comprendidos entre 501 y 999.
DIAGRAMA DE FUJO

DIAGRAMA N S
Ejercicio 05
C, sumapar, sumaimpar,
Inicio

c=c+1
Suma = suma + C
(c mod 2 = 0)

Sino sumaimpar = sumaimpar + c


Escribir (La suma de los nmeros pares comprendidos entre 501 y 999 es, sumapar)
Escribir (La suma de los nmeros impares comprendidos entre 501 y 999 es, sumaimpar)

Fin

PSEUDOCODIGO
Algoritmo Ejercicio_05
Var
Entero: c, sumapar, sumaimpar
Inicio
c = 500
sumapar = 0
sumaimpar = 0
mientras (c<999) hacer
c=c+1
si ( c mod 2 = 0) entonces
sumapar = sumapar + c
sino
sumaimpar = sumaimpar + c
Escribir (La suma de los nmeros pares comprendidos entre 501 y 999 es, sumapar)
Escribir (La suma de los nmeros impares comprendidos entre 501 y 999 es, sumaimpar)
Fin

PROGRAMA EN JAVA

6. Leer n nmero enteros y obtener el promedio de los positivos y


el promedio de los negativos.
DIAGRAMA DE FLUJO

DIAGRAMA N -S

PSEUDOCODIGO

PROGRAMA DE JAVA

DATOS POSITIVOS

DATOS NEGATIVOS