Está en la página 1de 5

GUA DE PRCTICA 04

Seccin : ___________________________
Asignatura
: Computacin
Docente :

Instrucciones
:

Apellidos : ____________________________
Nombres : ____________________________
Fecha
: __________ Duracin: 150
min.

Lea detenidamente cada enunciado y desarrolle lo solicitado.


Antes de iniciar la presente gua crear una carpeta en la unidad
Alumno con sus apellidos y nombres, Luego guarde este archivo
dentro de la misma tambin con sus apellidos y nombres.
Utilizar el software PseInt para el diseo de los algoritmo

Desarrolle en Pseudocdigo y Diagrama de Flujo los algoritmos para dar solucin a:


1. Un vendedor que tiene su sueldo base, recibe una comisin del 10% del total de
las ventas del mes y debe pagar S/. 200 por un prstamo. Se pide:
a. Ingresar el sueldo bruto y el monto de las ventas del mes.
b. Calcular monto de su sueldo neto.

2. Cinco personas deciden invertir su dinero para formar una empresa. Cada una de
ellas invierte una cantidad distinta. Hacer un algoritmo que imprima el porcentaje
que cada quien invierte con respecto al total de la inversin.

Vive tu propsito

3. Si un dlar equivale a 3.45 soles. Hacer un algoritmo que imprima en dlares una
cantidad X de soles.

4. Un alumno tiene 3 notas, luego se le da la opcin de rendir un examen para


remplazar la nota menor se pide:
a. El promedio del alumno con las 3 notas iniciales.
b. El promedio del alumno con la nueva nota que reemplaza a la ms baja

Vive tu propsito

5. Ingresar 5 nmeros y reportar:


a. Cantidad de nmeros positivo
b. Cantidad de nmeros negativos
c. Cantidad de nmeros mayores a 15
d. Cantidad de nmeros menores a -6
Proceso Ejemplo
CantPos=0;
CantNeg=0;
CantMay15=0;
CantMen_6=0;
Escribir "Ing. numero1 :"
Leer N1;
//cantidades
Si N1>=0 Entonces
CantPos=CantPos+1;
Sino
CantNeg=CantNeg+1;
Fin Si

Vive tu propsito

Si
FinSi
Si
FinSi

N1<-6 entonces
CantMen_6=CantMen_6+1;
N1>=15 entonces
CantMay15=CantMay15+1;

Escribir "Ing. numero 2 :"


Leer N2;
//cantidades
Si N2>=0 Entonces
CantPos=CantPos+1;
Sino
CantNeg=CantNeg+1;
Fin Si
Si
FinSi
Si
FinSi

N2<-6 entonces
CantMen_6=CantMen_6+1;
N2>=15 entonces
CantMay15=CantMay15+1;

Escribir "Ing. numero 3 :"


Leer N3;
//cantidades
Si N3>=0 Entonces
CantPos=CantPos+1;
Sino
CantNeg=CantNeg+1;
Fin Si
Si
FinSi
Si
FinSi

N3<-6 entonces
CantMen_6=CantMen_6+1;
N3>=15 entonces
CantMay15=CantMay15+1;

Escribir "Ing. numero 4 :"


Leer N4;
Si N4>=0 Entonces
CantPos=CantPos+1;
Sino
CantNeg=CantNeg+1;
Fin Si
Si
FinSi
Si

N4<-6 entonces
CantMen_6=CantMen_6+1;
N4>=15 entonces
CantMay15=CantMay15+1;

FinSi

Vive tu propsito

Escribir "Ing. numero 5 :"


Leer N5;
Si N5>=0 Entonces
CantPos=CantPos+1;
Sino
CantNeg=CantNeg+1;
Fin Si
Si
FinSi
Si

N5<-6 entonces
CantMen_6=CantMen_6+1;
N5>=15 entonces
CantMay15=CantMay15+1;

FinSi
Escribir
Escribir
Escribir
Escribir

"Cant.
"Cant.
"Cant.
"Cant.

Positivos :", CantPos;


Negativos :", CantNeg;
>15 :", CantMay15;
<-6 :", CantMen_6;

FinProceso

Vive tu propsito