Está en la página 1de 7

1

Inicio
Entero: peso ,n =0
Leer peso
Mientra (peso<>0)
Si (peso>=1000)entonces
Peso

peso-1000
N

n+1

Caso contrario
Si (peso>=500) entonces
Peso

peso-500
N

n+1

Caso contrario
Si (peso>=100) entonces
Peso

peso-100
N

n+1

Caso contrario
Si (peso>=500) entonces
Peso

peso-500
N

n+1

Caso contrario
Si (peso>=200)entonces
Peso

peso-200
N

n+1

Caso contrario
Si (peso>=100)entonces
Peso

peso-100
N

n+1

Caso contrario
Si (peso>=50)entonces

Peso

peso-50
N

n+1

Caso contrario
Si (peso>=20) entonces
Peso

peso-20
N

n+1

Caso contrario
Si (peso>=10) entonces
Peso

peso-10
N

n+1

Caso contrario
Si (peso>=5) entonces
Peso

peso-5
N

n+1

Caso contrario
Si (peso>=2) entonces
Peso

peso-2
N

n+1

Caso contrario
Si (peso>=1)entonces
Peso

peso-1
N

n+1

Fin_si
Fin_mientra
Imprimir nuimero de pesas
fin

2
INICIO

Entero =lado , permetro;


Reales=altura,rea;
Leer lado
Permetro=3*lado;
Altura=(3^(1/2)*lado)/2
rea=(3^(1/2)*lado^2)/4
Imprimir permetroreaaltura
Fin

3
Inicio
Entero : horas ,pago _horas,horas _extras ,monto=0
Leer horas , pago_horas
Si horas >40 entonces
Horas extras =horas 40
Si horas _extras <=8 entonces
Monto=hora*pago_horas+2*horas_extras*pago_horas
Caso contrario
Monto=horas *pago_horas +2*horas
extras+3*(horas_extras -8)*pago horas
Fin_si
Caso _contrario
Monto=horas * pago _horas
Fin _si
Imprimir monto
Fin

6
INICIO
ENTERO: mcm ,mcd,a,b,i;
Leer a ,b
I=2
Mientras (a>=i)&&(b>=i)

entonces

Si (a%i==0)&&(b%i==0) entonces
Mcd=i
Fin _si
I=i+1
Fin _mientras
Imprimir mcd

I=2;
Mientras(a>=i)&&(b>=i)

entonces

Si (a%i==0)&&(b%i==0) entonces
Mcm=i
Fin _si
I=i+1
Fin _mientras
Imprimie mcm
fin

7:
Trabajemoslo con un vercto
Entero: nota-men,nota-may

Para i desde 0 hasta i<40, incrementa i++


Leer a[i]
Fin_para
Para i desde 0 hasta i<40,i++ hacer
Si i == 0 entonces
Nota-may =a[i],
Sino
Si a[i] >nota-may entonces
Nota-may =a[i],
Fin_si
Fin_si
Fin_ para
Para i desde 0 hasta i<40 hacer i++
Si i==0 entonces
Nota-men=a[i],
Sino
Si a[i] <nota-men entonces
Nota-men = a[i]
Fin_si
Fin_si
Fin_para
Imprimir . Nota-may'nota-men
fin

10.

Los vectores seran reales y el verctor c tmb sera real


Enteros:i,j

Para i desde 0 ; hasta i<10 incrementar i++ hacer


Leer a [i]
Fin _ para
Para i desde 0 hasta i<10 incrementar i++ hacer
Leer b[i]
Fin_ para
Para i desde 0 hasta i<10 incrementar i++ hacer
C[i] = a[i] + b[10-(i+1)];
Fin para
Para i desde 0 hasta i < 10 incrementar i++ hacer
Escribir. C[i];
fIn _ para
Imprimir vector c

A el vector c lo inicias vacio

11.
Varibles e[1][1]........e[m][n],
Enteros: m,n ,i,j,suma-ne,suma-po,can-ceros'can-neg'can-pos
Leer m,n
Si n*m<=10310 entonces
Para i desde 0 hasta.<m incrementa,i++ hacer
Para j desde 0 hasta j<n,incrementa j++ hacer
Leer e[i][j]
Fin para
Fin para

Para i desde 0 hasta i<m,incrementa i++ hacer


Para j desde 0 hasta j<n incrementa ,j++ hacer
Si e[i][j] == 0 entonces
Can-ceros= can-ceros +1;
Sino
Si e[i][j] <0 entonces
Can-neg=can-neg+1;
Suma-neg=suma-neg+e[i][j];
Sino
Can-pos = can-pos+1;
Suma-pos=suma-pos + e[i][j];
Fin si
Fin si
Fin para
Fin para
Sino
Escribri ingrese otros valores para m y n
Fin si
Imprimir

Can-ceros,can-pos'can-neg,suma-pos,suma-neg

fin

Las sumas y las cantidades inicialisalas en cero