Está en la página 1de 28

INSTITUTO TECNOLGICO DE SALINA CRUZ

MATERIA:
REDES DE COMPUTADORA

CARRERA:
ING. EN TICS
SEMESTRE: 6

GRUPO: E

ALUMNO:
ESTEBAN EDUARDO GARCIA OJEDA
EDWIN SANCHEZ GARCIA

ACTIVIDAD:
COMANDOS PARA CONFIGURACION DE ROUTER CISCO

CATEDRTICO:
SUSANA MONICA ROMAN NAJERA

SALINA CRUZ, OAX. A 08 DE FEBRERO DE 2016

COMANDOS PARA LA CONFIGURACION DE ROUTERS CISCO


1. ACCESO A LA CONSOLA DE LOS ROUTERS
Existen diversas formas de acceder a un router CISCO para su configuracin:
Mediante un terminal asncrono (por ejemplo, un PC con un software de
emulacin de terminales como HyperTerminal o Teraterm) conectado al puerto
serie (consola) del router.

Mediante protocolos o aplicaciones TCP/IP desde otra mquina accesibles


desde alguna de las redes a las que est conectado el router. En particular, se
puede configurar utilizando telnet, un navegador web o mediante el protocolo de
gestin SNMP.

En el laboratorio tambin es posible usar la primera opcin (terminal asncrono) si


bien de forma indirecta: las consolas de todos los routers estn conectadas a un
"servidor de terminales". Se trata de una mquina que tiene una serie de puertos
cada uno de ellos conectados fsicamente a la consola de un router. El servidor de
terminales es accesible desde la red mediante telnet y, segn el puerto TCP al que
se haga telnet, nos dar acceso a la consola de un router u otro.

de redes
Por ejemplo, como aparece en la figura, el CISCO11 est conectado a un puerto del
servidor de terminales "puerto5", y dicho puerto est asociado al puerto TCP 911.
Por tanto, para acceder a la consola de CISCO11 se deber ejecutar el siguiente
comando:
telnet puerto5.lab.dit.upm.es 911
Nota: si se trabaja desde el sistema operativo Windows, se recomienda utilizar como
cliente de telnet Putty o TeraTerm, ambos instalados en todos los ordenadores
del laboratorio.
Consulte en los enunciados de las prcticas los datos sobre los servidores y puertos
de consolas a utilizar para acceder a cada equipo.

2. MODOS DE CONFIGURACION
Para acceder a la consola del router haga un telnet al servidor de consolas y puerto
que corresponda. Por ejemplo:
> telnet puerto5.lab.dit.upm.es 903
User Access Verification Password:
Si el router est ya configurado y tiene una direccin IP accesible, puede hacer un
telnet directo. Por ejemplo:
> telnet 192.168.12.1 User
Access Verification Password:
Si se lo pide, teclee a continuacin el password de acceso (pisco en los routers del
laboratorio) y obtendr el "prompt" del modo no-privilegiado de configuracin (si el
control de acceso no est activado le aparecer directamente):
Cisco2>
En este modo es posible consultar informacin sobre el router, pero no es posible
cambiar la configuracin del mismo. Teclee "help" o ? en la lnea de comandos
para obtener ayuda sobre los comandos disponibles. Pruebe, por ejemplo, el
comando "show version", que muestra la configuracin hardware y las versiones del
software del router; o el comando "show interface", que muestra informacin sobre
los interfaces de red del router.
El interfaz de configuracin de un CISCO mediante lnea de comandos es similar a
la interfaz que ofrece una "shell" de UNIX. Esto es, es posible recuperar los
comandos introducidos previamente mediante el uso de las flechas arriba/abajo, y
editarlos mediante las flechas derecha/izquierda. Adems, no es necesario teclear
el nombre completo de los comandos; pueden dejarse incompletos, tecleando
nicamente las primeras letras; o bien completarse automticamente mediante la
tecla "Tab". Por ejemplo, el comando "show version" puede abreviarse en "sh ver".
El router ofrece una ayuda muy completa, que permite consultar los parmetros de
cada comando. Por ejemplo, si tecleamos "show ?", nos mostrar todas las opciones
del comando "show". Si escogemos la opcin "ip" de dicho comando, podremos
consultar las distintas opciones sin ms que teclear: "show ip ?".
Para acceder al modo privilegiado de configuracin, el cual permite modificar la
configuracin del router, es necesario teclear:
Cisco2> enable Password:
Tras introducir el password ("pisco"), el "prompt" cambiar a:
Cisco2#
para indicarnos que estamos en modo privilegiado (si el control de acceso no est
activado, entraremos en el modo privilegiado directamente, sin necesidad de teclear
la clave). Si tecleamos "help" en este modo, apreciaremos que el nmero de

comandos disponibles ha aumentado sensiblemente. Teclee, por ejemplo, "show


running-conf" para ver la configuracin completa del router.

3. MODIFICACIN DE LA CONFIGURACIN
Para cambiar la configuracin del router desde el modo privilegiado, es necesario
utilizar el comando "configure":
Cisco2# configure
Configuring from terminal, memory or network [terminal]?
Teclee "terminal" o directamente retorno de carro para configurar desde terminal:
Enter configuration commands, one per line. End with CNTL/Z
Cisco2(config)#
A partir de este momento es posible introducir nuevos comandos de configuracin.
Por ejemplo, si quisiramos aadir una ruta IP, teclearamos:
Cisco2(config)#
ip
route
138.4.3.0
255.255.255.192
138.4.3.1
Cisco2(config)# ^Z Cisco2#
El control-Z final nos permite salir del modo de configuracin (ntese el cambio del
"prompt"). Tambin se puede salir de dicho modo tecleando "end" o exit.
Para borrar un comando de configuracin se utiliza el mtodo anterior, pero
anteponiendo al comando la palabra "no". Por ejemplo, para borrar la ruta anterior
teclearamos el siguiente comando:
Cisco2(config)# no ip route 138.4.3.0 255.255.255.192 138.4.3.1
Los cambios realizados a la configuracin se aplican siempre sobre la configuracin
almacenada en memoria voltil (denominada running-config). Para almacenar
los cambios en la configuracin guardada en memoria no voltil (denominada
startup-config) y que no se pierdan al rearrancar el router, es necesario utilizar el
comando "write" (o alternativamente copy running-config startup-config):
Cisco2# write
Building configuration...
[OK]
Cisco2#
Los comandos de configuracin de un router CISCO se clasifican en dos tipos:
Comandos generales, que afectan al router en su conjunto. Por ejemplo, el comando
"ip route ...", y
Comandos particulares de interfaz, que afectan nicamente a un interfaz del router.
Por ejemplo, si queremos asignar una direccin IP al interfaz ethernet0 de un router,
debemos teclear:

Cisco2# conf term


Enter configuration commands, one per line. End with CNTL/Z
Cisco2(config)# interface ethernet0
Cisco2(config-if)# ip address 10.1.1.1 255.255.255.0
Cisco2(config-if)# ^Z
Es decir, es necesario introducir el nombre del interface (en este caso: ethernet0 o,
de forma abreviada, e0) correspondiente antes de teclear el comando.
4. BORRADO DE LA CONFIGURACIN DEL ROUTER
Se describe a continuacin el procedimiento de borrado de la configuracin de un
router y carga de la configuracin inicial para comenzar a trabajar con l. Una vez
haya accedido a la consola de configuracin del router y est en modo privilegiado:
Borre la configuracin del mismo utilizando el comando: erase startup-config. A
continuacin, rearranque el router mediante reload. Conteste NO en caso de que
se le pregunte "System configuration has been modified. Save? [yes/no]". Adems,
no teclee el comando "write" antes de rearrancar, ya que ello provocara que la vieja
configuracin se grabase a la configuracin de inicio.
Al arrancar de nuevo (tras 3 o 4 minutos), conteste NO a la pregunta sobre si quiere
entrar en el asistente de ayuda a la configuracin.
Configure el nombre del router utilizando el comando hostname <name>
Introduzca el comando no ip domain-lookup para evitar retardos debidos a
consultas al DNS en caso de teclear comandos errneos.
Introduzca el comando "ip subnet-zero"
Introduzca el comando "ip classless"
Configure una clave de acceso para poder entrar en el router va telnet. Para ello,
aada los comandos (pisco ser la clave de acceso):
enable password pisco
line vty 0 4 password 0
pisco
login

NOTA IMPORTANTE: asegrese de teclear correctamente los comandos relativos


a la clave de acceso y no introduzca ninguna clave distinta de la propuesta (pisco).
De hacerlo imposibilitara el acceso al equipo a los siguientes alumnos.
5. RECOMENDACIONES GENERALES
Asegrese de que nadie ms est utilizando los routers que ha reservado. Para ello
puede utilizar el comando show users, que muestra los usuarios actualmente
conectados al router va telnet.

6. COMANDOS DE INTERS
Se enumeran a continuacin algunos comandos de inters. Para una referencia ms
completa, consultar http://www.lab.dit.upm.es/~labrst/config/manuales-cisco.
show: muestra informacin del sistema. Por ejemplo:
o show running-config: muestra la configuracin actual del router.
o

show startup-config: muestra la configuracin del router almacenada en


la memoria no voltil (NVRAM).

show ip route: muestra las tablas de encaminamiento del router. o


show arp: muestra el contenido de la tabla cach de ARP.

show interfaces: muestra informacin sobre los interfaces de red del


router.

show ip traffic: muestra estadsticas sobre el trfico IP cursado por el


router.

show version: muestra informacin general sobre el hardware (modelo,


interfaces, memoria, etc) y software (versin) del router.

clear
o

clear arp: borra el contenido de la tabla cach de ARP. o

clear

ip redirect: borra el contenido de la tabla cach de redirecciones.


clear ip route *: borra las entradas en las tablas de encaminamiento
aprendidas mediante RIP u otro protocolo de encaminamiento dinmico.
o clear counters: borra los contadores de estadsticos de los interfaces.

debug: permite activar las trazas de depuracin del router. MUY IMPORTANTE:
para visualizar dichas trazas en pantalla cuando se est conectado mediante
telnet, es necesario teclear previamente el comando "terminal monitor". Para
desactivar las trazas utilice el comando "undebug". Si quiere desactivar todas
las trazas de una vez, utilice "undebug all". o debug ip packets: muestra trazas
sobre los paquetes IP que son encaminados por el router. o debug ip icmp:
muestra trazas sobre los mensajes ICMP enviados o recibidos por el router.
debug isdn *: muestra trazas sobre la actividad del interfaz RDSI. o
debug ip rip: muestra trazas sobre la actividad del protocolo de
encaminamiento RIP.

configure: permite cambiar la configuracin del router.


ip route "destination" "mask" "router": permite aadir una nueva
entrada a las tablas de encaminamiento. o ip address "address" "mask"
secondary: permite aadir una direccin IP secundaria a uno de los
interfaces.

ping: permite realizar un ping desde el router.

traceroute: permite realizar un traceroute desde el router.

7. CONFIGURACIN BSICA DE INTERFACES ETHERNET


Consiste bsicamente en darle direccin IP, mscara, y habilitarla Se debe entrar
en el modo de configuracin, y una vez ah en la configuracin de la interfaz.
cisco11#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
cisco11(config)#interface
fastethernet0/0
cisco11(config-if)#ip
address <direccinIP> <mscara> cisco11(config-if)#no shutdown

8. CONFIGURACIN DE INTERFACES RSDI


Para configurar un router CISCO de forma que acceda a otra mquina a travs de
RDSI, se deben utilizar los siguientes comandos de configuracin:
access-list 101 permit ip any any dialer-list 1
protocol ip list 101
interface bri0 isdn switchtype
basic-net3
encapsulation ppp
ppp authentication pap callin
ppp pap sent-username liryst00 password liryst00
ip address 192.168.4.20X 255.255.255.0 dialer
map ip 192.168.4.1 YYY dialer-group 1 no
shutdown
Siendo 192.168.4.20X la direccin IP asignada al interfaz RDSI (en nuestro caso,
201 para el CISCO1, 202 para el CISCO2, etc); e YYY el nmero RSDI al que se
llamar (en nuestro caso, la extensin RDSI del servidor LUBINA). IMPORTANTE:
el nombre del interfaz (bri0 en el ejemplo) puede variar de un router CISCO a otro
(por ejemplo, bri0/0). Utilizad el comando show interfaces para conocer el nombre
de los interfaces de un router concreto.
Para activar el protocolo "Multilink PPP" y permitir as el establecimiento de los dos
canales B simultneamente, se deben aadir los siguientes comandos de
configuracin:
interface bri0 ppp multilink
dialer idle-timeout 40 dialer
load-threshold 60
Los dos ltimos comandos permiten regular la forma en que se establece el segundo
canal B. El primero de ellos (idle-timeout) especifica el Plazo de Inactividad, esto es,

el nmero de segundos que un canal B debe permanecer inactivo (sin trfico) antes
de que sea desconectado. El segundo (load-threshold) especifica el umbral de
trfico medio (en porcentaje) que provoca el establecimiento del segundo canal B.
9. CONFIGURACIN DE INTERFACES FRAME-RELAY
Para configurar el interfaz WAN de un CISCO con el objeto de acceder a una red
Frame-Relay, entre en el modo de configuracin del router y teclee:
cisco3(config)#interface serial 0
cisco3(config-if)#encapsulation
frame-relay
ietf
cisco3(config-if)#no shutdown cisco3(config-if)#
Mediante estos comandos, se especifica que el interfaz "serial 0" encapsular sobre
Frame Relay conforme a la RFC1490 del IETF.
Sobre un interfaz FR se pueden establecer varias conexiones simultneas (PVC),
utilizando distintos DLCI (identificadores de circuito). Conceptualmente cada
conexin define un subinterfaz o interfaz virtual, que se nombra aadiendo un dgito
ms al nombre del interfaz (esto es, "serial 0.1" para el primer circuito; "serial 0.2"
para el segundo, etc).
Para cada circuito (PVC) es necesario configurar:
el DLCI del mismo (en el "salto" entre el router y el equipo de la red FR al que
est directamente conectado), y

la direccin IP y la mscara de subred que se va a asignar al subinterfaz, para


el caso de trfico IP.

Por ejemplo, supongamos que en la red FR se tiene ya configurado un PVC desde


un PC dotado de interfaz FR hasta el puerto de un conmutador FR al que est
conectado el router cisco3. En ese puerto, el DLCI es 30. Para configurar el
subinterfaz en cisco3 para acceder al circuito FR y tener conectividad con el PC, se
deberan aadir los siguientes comandos:
cisco3(config-if)#interface
serial
0.1
point-to-point
cisco3(config-subif)#ip address 192.168.3.3 255.255.255.0
cisco3(config-subif)#frame-relay
interface-dlci
30
cisco3(config-fr-dlci)#no shutdown cisco3(config-if)# ^Z
En cada caso habra que elegir la direccin IP y la mscara adecuados.
Para comprobar la correcta configuracin se pueden utilizar los siguientes
comandos:
1. Configuracin del interfaz FR. Para comprobarla, teclee:
cisco3#show interface serial 0
y

verifique que aparecen los siguientes mensajes: "Serial0 is up, line protocol
is up" y "Encapsulation FRAME-RELAY IETF".

2.

Configuracin de la conexin (subinterfaz). Para comprobarla, teclee:


cisco3#show interface serial 0.1
Serial0.1
is up, line protocol is up
Hardware is
QUICC Serial
Internet address is 192.168.3.3/24
MTU 1500 bytes, BW 1544 Kbit, DLY 20000
usec,
rely 255/255, load 1/255
Encapsulation
FRAME-RELAY IETF
y verifique la correccin de la direccin IP elegida, dependiendo del router con
el que se est trabajando.

3.

Establecimiento del circuito. Para ver el estado de los PVCs de FR, teclee:
cisco3#show fr pvc
La configuracin correspondiente a cada conexin establecida (a cada DLCI en
uso) comenzar con una lnea similar a:
DLCI = 30, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE
= Serial0.1
Pueden aparecer ms lneas, correspondientes a DLCIs configurados en el
equipo FR al que se conecte el router y que son conocidos en el mismo mediante
sealizacin. Al no estar configuradas estas conexiones en el router, la lnea de
comienzo tendr el siguiente aspecto:
DLCI = 45, DLCI USAGE = UNUSED, PVC STATUS = ACTIVE, INTERFACE
= Serial0

Finalmente, para cambiar el DLCI que utiliza una conexin, se debe eliminar el DLCI
en uso y aadir uno nuevo. Por ejemplo, para utilizar el DLCI 35 en lugar del 30 en
la conexin del ejemplo anterior se deben emplear las siguientes rdenes:
cisco3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
cisco3(config)#interface serial 0.1
cisco3(config-subif)#no frame-relay interface-dlci 30
cisco3(config-subif)#frame-relay
interface-dlci
35
cisco3(config-fr-dlci)#no shutdown cisco3(config-if)#^Z
cisco3#
Se puede comprobar a continuacin, mediante "show fr pvc", que en este caso el
DLCI en uso es el 35.

10. CONFIGURACIN DEL CONFORMADO DE TRFICO EN EL ROUTER


A continuacin se detallan los pasos a seguir para la configuracin de la funcin de
conformado de trfico en una conexin FR en un router CISCO. Para ello se supone
que ya existe una conexin configurada, correspondiente al subinterfaz serial 0.1.
Como medida de precaucin, se debe empezar siempre por anular cualquier
configuracin de conformado de trfico presente en el subinterfaz. Para verlo, en
modo privilegiado, ejecutar:
cisco3#show traffic-shape serial 0.1
Access Target Byte Sustain Excess Interval Increment Adapt
I/F
List Rate
Limit bits/int bits/int (ms)
(bytes) Active Se0.1
56000 7875 56000 56000 125
875
BECN
Para eliminar todas las configuraciones de conformado de trfico presentes en el
interfaz, teclee:
cisco3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
cisco3(config)#interface serial 0.1
cisco3(config-subif)#no
traffic-shape
rate
cisco3(config-subif)#no
shutdown
cisco3(config-subif)#^Z
cisco3#show traffic-shape serial 0.1 Traffic
shaping not configured on Serial0.1 cisco3#
Existen varias formas de configurar el conformado de trfico para que acte sobre
el trfico saliente en la conexin asociada al subinterfaz serial 0.1. Para ver las
distintas opciones y parmetros que se admiten, teclee:
cisco3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
cisco3(config)#interface serial 0.1 cisco3(config-subif)#traffic-shape ?
adaptive Enable Traffic Shaping adaptation to BECN
fecn-adapt Enable Traffic Shaping reflection of FECN as BECN group
configure token bucket: group <access-list> CIR (bps) [Bc
(bits) [Be (bits)]] rate
configure token bucket: CIR
(bps) [Bc (bits) [Be (bits)]]
En nuestro caso, usaremos la ltima opcin ("rate"), que permite fijar CIR, Bc y Be.
Tenga en cuenta que CIR y Bc determinan el intervalo de observacin. Por ejemplo,
si utilizamos un Bc de 16000 bits (2000 bytes) con un intervalo de observacion (T)
de 1 segundo, esto nos determina que el CIR sea 16000 bps. Si, adems utilizamos
un Be de 0, el comando de configuracin a utilizar ser el siguiente:

cisco3(config-subif)#traffic-shape rate 16000 16000 0


cisco3(config-subif)#no shutdown cisco3(config-subif)#^Z
cisco3#show traffic-shape serial 0.1
Access Target Byte Sustain Excess Interval
Increment Adapt
I/F
List Rate
Limit bits/int bits/int (ms)
(bytes) Active
Se0.1
16000 2000 16000 0
1000
2000
- cisco3#

Como se ve, el intervalo se ha fijado en 1000 ms (1 segundo), como se pretenda.


11. CONFIGURACIN BSICA DE OSPF
La configuracin de OSPF en un router CISCO requiere dos pasos fundamentales:
1. Arranque del proceso OSPF mediante el comando:
(Config)# router ospf 1
siendo 1 el identificador del proceso ospf (puede ser cualquier valor, incluso
distinto en cada router de la red; nicamente se utiliza para distinguir procesos
OSPF en el caso de que existan varios arrancados simultneamente en el
mismo router).
2. Definicin del rea en la que se encuentra cada interfaz del router que participa
en OSPF. Para ello se utiliza el comando network, mediante el cual se
especifica la asociacin entre direcciones de interfaces e identificadores de
reas. Por ejemplo:
(config)# router ospf 1
(config-router)# network 131.108.20.0 0.0.0.255 area 0
(config-router)# network 131.109.10.0 0.0.0.255 area 1
La primera lnea especifica que todos los interfaces del router cuya direccin
comience por 131.108.20.0/24 pertenecen al rea 0. Asimismo, la segunda
declara que los interfaces cuya direccin comience por 131.109.10.0/24
pertenecen al rea 1.
IMPORTANTE: el comando network NO especifica el rango de direcciones
accesibles dentro de un rea de OSPF. Esto es, en el ejemplo anterior los
comandos network no especifican que los prefijos 131.108.20.0/24 y
131.109.10.0/24 estn accesibles en las reas 0 y 1 respectivamente. El
comando network es nicamente un mtodo (confuso en cierto modo) de
definir localmente en cada router las reas a las que pertenece cada interfaz.
En el caso de los routers frontera de rea (ABR), es necesario adems definir cmo
se realiza el flujo de informacin de encaminamiento entre las reas y el backbone:

1.

Si no se especifica nada en el ABR, los prefijos de las reas se redistribuyen al


backbone y viceversa sin modificaciones (no hay agregacin ni rutas por
defecto).

2.

Para realizar agregacin desde las reas hacia el backbone se puede utilizar el
comando area range, que permite definir el/los prefijo/s que el ABR exportar
hacia el backbone, independientemente de los que se hayan distribuido en el
interior del rea. Por ejemplo:
(config)# router ospf 109
(config-router)# network 131.108.20.0 0.0.0.255 area 0
(config-router)# network 131.109.1.0 0.0.0.255 area 1
(config-router)# area 1 range 131.109.0.0 255.255.248.0

En este caso el ABR exportar hacia el backbone el prefijo 131.109.0.0/21.


3. En caso de que el rea solo tenga una salida hacia el backbone y no se quiera
que los prefijos del backbone se distribuyan hacia el interior del rea, se puede
utilizar el comando:
(config-router)# area 5 stub no-summary
Al definirse un rea de tipo stub, se inyecta al interior del rea una ruta por
defecto. Si, adems se incluye el parmetro no-summary, se evita que los
prefijos del backbone llegen al interior del rea.
Nota: si un rea es de tipo stub, se debe definir como tal en todos los routers
del rea. En caso contrario, no se establecern las vecindades adecuadamente.
Otros comandos de inters relacionados con OSPF son los siguientes:

show ip ospf. Muestra informacin general sobre un proceso OSPF.

show ip ospf interfaces. Muestra los interfaces del router que participan en
OSPF.

show ip ospf neighbors. Muestra la lista de routers que mantienen una


relacin de vecindad con el router en el que se ejecuta el comando.

show ip ospf database. Muestra informacin sobre el contenido de la base de


datos de encaminamiento OSPF de un router.

router-id ip-address. Permite definir el identificador de un router utilizado por


OSPF. Si no se incluye, el router escoge una de sus direcciones IP como
identificador.

debug ip ospf. Permite activar el trazado de eventos de OSPF. Teclear


debug ip ospf ? para ver las distintas opciones que ofrece.
Para una referencia completa sobre los comandos OSPF de CISCO se puede
consultar:
http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122cgcr/fiprrp_r/1
rfospf.

htm
12. CONFIGURACIN BSICA DE CIRCUITOS VIRTUALES PERMANENTES
ATM
La configuracin bsica de ATM en un router Cisco equipado con un mdulo 1-Port
ATM-25 consta de los siguientes pasos:
Configuracin IP de la interfaz. Se debe entrar en el modo de configuracin, y una
vez ah en la configuracin de la interfaz.
cisco11#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
cisco11(config)#interface atm1/0
cisco11(config-if)#ip address 192.168.200.X 255.255.255.0 cisco11(configif)#no shutdown
Activacin de la sealizacin ILMI en la interfaz. Dentro del modo de configuracin
de la interfaz ATM se debe hacer:
cisco11(config-if)#atm ilmi-enable cisco11(config-if)#atm ilmikeepalive
Configuracin de un circuito virtual permanente asociado a la interfaz. Dentro del
modo de configuracin de la interfaz ATM se debe hacer:
cisco11(config-if)#atm pvc vcd vpi vci aal-encap [[midlow midhigh]
[peak average burst]] [oam seconds] [inarp minutes]
Los parmetros entre corchetes son opcionales. En la prctica del laboratorio no se
pide conformado de trfico y se va a trabajar con el encapsulado de IP clsico sobre
ATM, por lo que la lnea anterior se puede simplificar a:
cisco11(config-if)#atm pvc vcd vpi vci aal5snap inarp
cisco11(config-if)#no shutdown cisco11(config-if)#exit
Siendo VCD un nombre asociado al descriptor del circuito virtual que se est
creando, VPI es el identificador de camino virtual de ATM (en las prcticas se
supone siempre 0), y VCI es el identificador de canal virtual de ATM.
Configuracin de la asociacin entre una direccin IP destino y el circuito virtual
permanente creado. Supone dos puntos, el primero es la creacin de una lista de
asociaciones en la que se incluye la correspondencia entre la IP destino y el PVC
que comunica con dicho destino. Este primer punto se realiza en modo de
configuracin, pero no de la configuracin de interfaz sino de la general (debe hacer
exit del modo de configuracin de interfaz):
cisco11(config)#map-list nombre-de-lista
cisco11(config-map-list)#ip ip-address atm-vc vcd [broadcast] cisco11(configmap-list)#exit

Siendo VCD el nombre del descriptor del PVC que se ineic en el apartado 3, y
siendo nombre-de-lista un nombre que se le va a dar a la lista creada y que ser
usado en el segundo punto expuesto a continuacin.
El segundo punto a configurar es completar la configuracin de la interfaz ATM para
indicar que se debe usar la lista creada. Se debe volver por tanto al modo de
configuracin de interfaz.
cisco11(config)#interface atm1/0 cisco11(config-if)#map-group
nombre-de-lista cisco11(config-if)#no shutdown

Etapa 1: Implementacin
Equipo necesario

Un router Cisco

Dos PC (representado las redes)

El cable de consola proporcionado con el router

Esquema de pirmide

Configuracin IP de los PC
PC 1:

Direccin IP/Mascara: 192.168.1.254/24

Puerta de enlace: Ser la direccin IP de la interfaz del router a la cual est conectada
el PC

PC 2:

Direccin IP/Mascara: 10.0.0.254/8

Puerta de enlace: Ser la direccin IP de la interfaz del router a la cual est conectada
el PC

Etapa 2: Cableado de la red, uso del cable de consola


Las dos redes ya estn conectadas al router. Sin embargo, no hay comunicacin entre ellas.
Comenzaremos por conectar el cable de consola (cable azul) entre el router y el PC que se
va a utilizar para la configuracin.

Inicialmente, utilizaremos HyperTerminal (de Microsoft) para efectuar las operaciones


necesarias.
Etapa 3: Configuracin del router con los comandos IOS
IOS
IOS es el acrnimo de Internetworks Operating System", en espaol Sistema operativo
para la interconexin de redes.
Este sistema puede ser administrado en lnea de comandos, propios a los equipos de
Cisco Systems.
Los diferentes modos de usuarios
Modo usuario: Permite consultar toda la informacin relacionada al router sin poder
modificarla. El shell es el siguiente:
Router >

Usuario privilegiado: Permite visualizar el estado del router e importar o exportar


imgenes de IOS. El shell es el siguiente:

Router #

Modo de configuracin global: Permite utilizar los comandos de configuracin generales


del router. El shell es el siguiente:

Router (config) #

Modo de configuracin de interfaces: Permite utilizar comandos de configuracin de


interfaces (Direcciones IP, mascaras, etc.). El shell es el siguiente:

Router (config-if) #

Modo de configuracin de lnea: Permite configurar una lnea (ejemplo: acceso al router
por Telnet). El shell es el siguiente:

Router (config-line) #

Modo espacial: RXBoot Modo de mantenimiento que puede servir, especialmente, para
reinicializar las contraseas del router. El shell es el siguiente:

rommon >

Poner una contrasea al acceso Privilegiado


Esta parte explica como poner una contrasea al usuario privilegiado.

Lo primero que hay que hacer es conectarse en modo privilegiado, luego en modo de
configuracin global para efectuar esta manipulacin:

Router > enable


Router # configure terminal
Router (config) #
Una vez en modo de configuracin global, tan solo hay que ingresar un comando para
poner una contrasea:
Router (config) # enable password contrasea

La prxima vez que un usuario intente conectarse en modo usuario privilegiado, le ser
solicitada una contrasea.

Hasta aqu, se recomienda guardar regularmente la configuracin utilizando el siguiente


comando (en modo privilegiado):

copy running-config startup-config

Configuracin de las interfaces Ethernet del router


Ahora, debemos hacer que se comuniquen las dos redes conectadas al router.
Supongamos que el nombre de la interfaz conectada a PC1 es fa0/0 y el de la conectada a
PC2 es fa0/1 y que estamos en modo de configuracin global.

A continuacin los comandos a ingresar:

Interfaz fa0/0:
Router (config) # interface fa0/0
Router (config-if) # ip address 192.168.1.1 255.255.255.0
Router (config-if) # no shutdown
Router (config-if) # exit
Interfaz fa0/1:

Router (config) # interface fa0/1


Router (config-if) # ip address 10.0.0.1 255.0.0.0
Router (config-if) no shutdown
Router (config-if) exit
Esto es todo en relacin a la configuracin de las interfaces. Las dos redes deberan ahora
comunicarse entre ellas. Podemos comprobarlo con un comando ping de un PC de una red
hacia un PC de otra red.

No olvides guardar tu configuracin actual utilizando el comando apropiado.


Configuracin del acceso Telnet al router
Ya que la configuracin con el cable de consola y HyperTerminal no es prctico, se puede
permitir que los administradores se conecten al router va una sesin Telnet desde cualquier
PC de una de las dos redes.

Pasamos primero en modo de configuracin global, luego en modo de configuracin de


lnea VTY:

Router > enable


Password?:

Router # configure terminal


Router (config) # line vty 0 4

configurar la posibilidad de 5 sesiones telnet simultneas en este router.


Llegamos ahora al prompt de configuracin de lnea. Para activar Telnet, no hay ms que
poner una contrasea a la lnea:

Router (config-line) # password contrasea


Router (config-line) # exit

Guardamos la configuracin

Hemos terminado con la configuracin bsica del router. Ahora vamos a hacer un resumen
de los diferentes comandos utilizados y que pueden ser utilizados en el caso precedente.
Importante: antes de conectarnos va una sesin Telnet debemos haber definido una
contrasea para el modo privilegiado. Si no es as, el router rechazar la conexin.

Paso entre los diferentes modos de usuarios:

Usuario normal: Ningn comando a ejecutar, es en este modo que comienza una
sesin.

Usuario privilegiado (a ejecutar desde el modo normal):

Router > enable

Router > en

Modo de configuracin global (a ejecutar desde el modo Privilegiado):

Router # configure Terminal


Router # conf t

Modo de configuracin de interfaz (a ejecutar desde el modo de configuracin global):

Router (config) # interface nombre_interfaz

Router (config) # int nombre_interfaz

Modo de configuracin de lnea (a ejecutar desde el modo de configuracin global):


Router (config) # line nombre_de_la_linea
Comandos de informacin
Los comandos de informacin permiten mostrar la informacin relativa al router. Todos
comienzan con el prefijo show o sh. La mayora deben ser ejecutados desde el modo
privilegiado.

Mostrar el archivo de configuracin actual del router:

show running-config
show run
sh run
Mostrar informacin sobre la configuracin de hardware del sistema y sobre el IOS:
show version
sh version
Mostrar los procesos activos:
show processes
Mostrar los protocolos configurados de la capa 3 del modelo OSI:
show protocols

Mostrar las estadsticas de memoria del router:


show memory
Mostrar informacin y estadsticas sobre una interfaz:

show interfaces nombre_interfaz


sh interfaces nombre_interfaz
sh int nombre_interfaz
*Mostrar la tabla de enrutamiento IP:
<code>sh ip ruta

Comandos de interfaz
Estos comandos estn ligados a la configuracin de la interfaz del router. La mayora
deben ser ejecutados desde el modo de configuracin de interfaz.
Asignacin de una direccin IP a una interfaz:

ip address @IP mascara


Activacin de la interfaz:
no shutdown

Comandos para hacer una copia de seguridad de la configuracin actual


Estos comandos permiten hacer una copia de seguridad de la configuracin actual para
restaurarla automticamente en caso de reinicio del router. Estos se ejecutan en
modoPrivilegiado.
Copia de seguridad con solicitud de confirmacin:
copy running-config startup-config
copy run start
Copia de seguridad sin solicitud de confirmacin:
write

Comando de anulacin
Este comando permite regresar a la ltima configuracin guardada, anulando todas las
modificaciones que han sido hechas despus a la configuracin. Se ejecuta en
modo Privilegiado.

copy startup-config running-config

copy start run

Anulacin de un comando en particular


Para anular un comando en particular, utilizaremos el prefijo no delante del comando que
se ejecuto anteriormente.
Ejemplo: anular la configuracin de una interfaz:

no ip address

Cambiar el nombre del router


El nombre del router puede ser modificado a fin de poder diferenciarlo en la red o redes. El
comando ser ejecutado en modo de configuracin global.

host NuevoNombre
Un nombre diferente aparecer en el prompt en sesiones HyperTerminal o Telnet.

Antes:

Router >

Despus:

NuevoNombre >
Poner una contrasea al usuario privilegiado
Estos comandos deben ser ejecutados en modo de configuracin global:

Asignacin normal:

enable password contrasea

Asignacin encriptada: enable secret contrasea

COMANDOS ROUTER CISCO


MODO EXEC USUARIO
Comando

Descripcin

connect {direccin_ip|nombre}

Permite conectarse remotamente a un host

disconnect conexin

Desconecta una sesin telnet establecida desde el router

enable

Ingresa al modo EXEC Privilegiado

logout

Sale del modo EXEC

ping {direccin_ip|nombre}

Enva una peticin de eco para diagnosticar la conectividad


bsica de red
resume conexin
Resume una sesin telnet interrumpida con la secuencia
CTRL+SHIFT+6 y X
Muestra el intervalo entre publicaciones CDP, tiempo de validez y
show cdp
versin de la publicacin
show cdp entry [*|nombre_dispositivo] Muestra informacin acerca de un dispositivo vecino registrado
[protocol|version]}
en una tabla CDP
show cdp interfaces [tipo nmero]
Muestra informacin acerca de las interfaces en las que CDP
est habilitado
show cdp neighbors [tipo nmero]
Muestra los resultados del proceso de descubrimiento de CDP
[detail]
show clock
Muestra la hora y fecha del router
show history

Muestra el historial de comandos ingresados

show hosts

Muestra una lista en cach de los nombres de host y direcciones

show ip interface brief

Muestra un breve resumen de la informacin y del estado de una


direccin IP
Muestra el contenido de la base de datos privada de RIP

show ip rip database

show sessions

Muestra el contenido de la tabla de enrutamiento IP. El parmetro


direccin permite acotar la informacin que se desea visualizar,
exclusivamente a la direccin ingresada. El parmetro protocolo
permite indicar la fuente de aprendizaje de las rutas que se desean
visualizar, como por ejemplo rip, igrp, static y connected
Muestra las conexiones Telnet establecidas en el router

show version

Muestra informacin sobre el Cisco IOS y la plataforma

telnet {direccin_ip|nombre}

Permite conectarse remotamente a un host

terminal editing

Reactiva las funciones de edicin avanzada

terminal history size numero_lneas

Establece el tamao del buffer del historial de comandos

show ip route [direccin |protocolo]

terminal no editing

Deshabilita las funciones de edicin avanzada

traceroute direccin_ip

Muestra la ruta tomada por los paquetes hacia un destino

MODO EXEC PRIVILEGIADO


Comando

Descripcin

clear cdp counters

Restaura los contadores de trfico CDP a cero

clear cdp table

Elimina la tabla CDP de informacin de los vecinos

clear counters

Despeja los contadores de las interfaces

configure memory

Carga informacin de configuracin de la NVRAM

MODO DE CONFIGURACIN GLOBAL


Comando

Descripcin

access-list Nro_ACL {permit|deny}


Origen

Crea o agrega una sentencia de condicin a la ACL que permitir


o denegar los paquetes que llegan desde un Origen. Este ltimo
parmetro puede ser una direccin IP ms una mscara
wildcard, la palabra host ms una direccin IP o el wildcard any
access-list Nro_ACL {permit|deny}
Crea o agrega una sentencia de condicin a la ACL que
permitir o denegar los paquetes que lleguen desde un Origen
Proto Origen Destino [Operador
y vayan hacia un Destino. Proto identifica el protocolo a verificar.
Nro_puerto]
Origen y Destino pueden ser una direccin IP ms una mscara
[established][echo |echo-reply]
wildcard, la palabra host ms una direccin IP o el wildcard any.
Operador puede ser lt (menor que), gt (mayor que), eq (igual a)
o neq (distinto a). Nro_puerto indica el puerto TCP o UDP. El
parmetro established permite el paso de trfico cuando hay una
sesin establecida. En el caso del protocolo ICMP se puede
utilizar echo o echo-reply.
Banner motd #mensaje del da#
Configura un cartel con un mensaje del da. Ej: banner motd
#Bienvenido#
boot
system
flash Especifica que el router cargue el IOS desde la Flash
[nombre_imagen_IOS]
Ej: boot system flash c2500-IOS
boot system rom
Especifica que el router cargue el IOS desde la ROM
boot system tftp
nombre_imagen_IOS
dir_IP_server_tftp
cdp run

Especifica que el router cargue el IOS desde un servidor TFTP.


Ej: boot system tftp c2500-IOS 24.232.150.1

clock set hh:mm:ss mes da ao

Modificar la fecha y hora del router. Ej: clock set 12:31:00 July
12 2004
Cambia los valores del registro de configuracin.
Ej: config-register 0x2142

config-register
valor_registro_configuracin

Habilita CDP globalmente en el router

enable password contrasea


enable secret contrasea
hostname nombre
interface tipo nmero
ip access-list { tandard|extended}
Nombre

ip classless

ip default-network direccin_red
ip domain-lookup
ip host nombre_host dir_ip1 .
Dir_ip8
ip http server
ip name-server dir_ip1 . Dirip6
Ip route direccin_red mscara
dir_ip_salto
[distancia_administrativa]
line tipo nmero

router protocolo_de_enrutamiento
[nro_AS]
service password-encryption

Establece una contrasea local para controlar el acceso a los


diversos niveles de privilegio. Ej: enable password class
Especifica una capa de seguridad adicional mediante el comando
enable password. Ej: enable secret class
Modifica el nombre del router. Ej: hostname Lab_A
Configura un tipo de interfaz y entra al modo de
configuracin de interfaz. Ej: interface ethernet 0
Permite crear una ACL nombrada. Se debe indicar el tipo. Este
comando ingresa al router al submodo de configuracin que
puede reconocerse por el prompt
Router(config-ext-nacl)#
Permite que el router no tome en cuenta los lmites con definicin
de clases de las redes en su tabla de enrutamiento y
simplemente transmita hacia la ruta por defecto
Establece una ruta por defecto. Ej: ip default-network
210.32.45.0
Habilita la conversin de nombre a direccin en el router
Crea una entrada de nombre a direccin esttica en el archivo de
configuracin del router. Ej: ip host Lab_A 192.168.5.1
210.110.11.1
Permite que el router acte como servidor Web http limitado
Especifica las direcciones de hasta seis servidores de nombres
para su uso para la resolucin de nombres y direcciones.
Establece rutas estticas.
Ej: ip route 210.42.3.0 255.255.255.0 211.1.2.1
Identifica una lnea especfica para la configuracin e inicia el
modo de reunin de comandos de configuracin. Ej: line console
0 line vty 0 4
Inicia un proceso de enrutamiento definiendo en primer lugar un
protocolo de enrutamiento IP. Ej: router rip router igrp 120
Habilita la funcin de cifrado de la contrasea

SUBMODO DE CONFIGURACIN DE INTERFAZ


Comando

Descripcin

bandwidth Kbps

Establece un valor de ancho de banda para una interfaz. Ej:


bandwidth 64
Habilita Cisco Discovery Protocol en una interfaz

cdp enable
cdp holdtime segundos

Especifica el tiempo de espera antes de ser enviada la siguiente


actualizacin CDP
cdp timer segundos
Especifica la frecuencia con que son envadas actualizaciones
CDP
clock rate velocidad
Configura la velocidad de reloj para las conexiones de hardware
en interfaces seriales, como mdulos de interfaz de red y
procesadores de interfaz a una velocidad de bits aceptable. Ej:
clock rate 56000
description descripcin
Agrega una descripcin a la interfaz.
Ej: description Conectada a Internet
ip access-group Nro_ACL [in|out]
Asigna la ACL indicada a la interfaz, ya sea para que verifique los
paquetes entrantes (in) o los salientes (out)
ip address direccin_ip mascara_red Asigna una direccin y una mscara de subred e inicia el
procesamiento IP en una interfaz. Ej: ip address 192.168.52.1
255.255.255.0
no ip route-cache
Para deshabilitar el balanceo de carga por destino, que est
habilitado por defecto
no ip split-horizon
Deshabilita el horizonte dividido en la interfaz, que por defecto se
encuentra habilitado. Para volver habilitarlo utilice el comando ip
split-horizon
no shutdown
Reinicia una interfaz desactivada
shutdown

Inhabilita una interfaz

SUBMODO DE CONFIGURACIN DE LINEA


Comando

Descripcin

access-class Nro_ACL in

En las lneas VTY, asigna una lista de control de acceso a las


conexiones establecidas via Telnet
Habilita la verificacin de contrasea en el momento de la
conexin.
Asigna la contrasea a ser solicitada en el momento de la
conexin

login
password contrasea

SUBMODO DE CONFIGURACIN DEL PROTOCOLO DE ENRUTAMIENTO


Comando

Descripcin

maximum-paths valor

Permite modificar el mximo de rutas sobre las que balancear


la carga
Permite modificar los valores de las constantes utilizadas para el
clculo de las mtricas de las rutas en el protocolo de
enrutamiento IGRP. Los valores por defecto son: tos (tipo de servicio)= 0; k1= 1; k2= 0; k3= 1; k4= 0 y
k5= 0
Como RIP es un protocolo de tipo broadcast, el administrador
de la red podra tener que configurarlo para que intercambie
informacin de enrutamiento en redes no broadcast, como en el
caso de las redes Frame Relay. En este tipo de redes, RIP
necesita ser informado de otros routers RIP vecinos
Asigna una direccin de rd a la cual el router se encuentra
directamente conectado, lo que hara que se envi y reciba
publicaciones de enrutamiento a travs de esa interfaz, adems
de que dicha sea publicada a los routers vecinos.
Ej: network 210.45.2.0
Regresa los temporizadores a los valores por defecto

metric weights tos k1 k2 k3 k4 k5

neighbor direccin_ip

network direccin_red

no timers basic
passive-interface tipo nmero

redistribute static

timers basic Actualizacin Invlida


Espera Purga [Suspensin]

variance valor

El router no enviar informacin de enrutamiento por la interfaz


indicada.
Ej: passive-interface serial 0
Si se asigna una ruta esttica a una interfaz que no est
definida en el proceso RIP o IGRP, mediante el comando
network, no ser publicada la ruta a menos que se especifique
este comando
Indica la frecuencia con la que RIP o IGRP envan
actualizaciones y los intervalos de los temporizadores.
Actualizacin: intervalo en segundos a la que se envan las
actualizaciones (RIP: 30 seg; IGRP: 90 seg).
Invlida: Intervalo de tiempo en segundos despus del cual una
ruta se declara no vlida. Sin embargo, la ruta todava se utiliza
para el envo de paquetes (RIP: 180 seg; IGRP: 270 seg).
Espera: Intervalo en segundos durante el cual se suprime la
informacin de enrutamiento que se refiere a las mejores rutas
(RIP: 180 seg; IGRP: 280 seg). Purga: Intervalo de tiempo en
segundos que debe transcurrir antes de que la ruta se elimine
de la tabla de enrutamiento (RIP: 240 seg; IGRP: 630 seg).
Suspensin: Intervalo en milisegundos en que se posponen las
actualizaciones de enrutamiento de cuando se produce una
actualizacin flash. Slo IGRP
El valor de variacin determina si IGRP aceptar rutas de costo
desigual. Slo aceptar rutas iguales a la mejor mtrica local
para el destino multiplicado por el Valor de variacin. El valor
puede variar de 1 (por defecto) a 128

Teclas / Comando

COMANDOS DE EDICIN y OTROS


Descripcin

Ctrl+A

Permite desplazarse al principio de la lnea de comandos

Esc+B

Permite desplazarse una palabra hacia atrs

Ctrl+B (o Flecha Izquierda)

Permite desplazarse un carcter hacia atrs

Ctrl+E

Permite desplazarse hasta el final de la lnea de comandos

Ctrl+F (o Flecha Derecha)

Permite desplazarse un carcter hacia delante

Ctrl+P (o Flecha Arriba)

Muestra el ltimo comando ingresado

Ctrl+N (o Flecha Abajo)

Muestra el comando ms reciente

<Tab> (tecla Tabulador)

Completa el comando ingresado parcialmente

Ctrl+Z (o end)

Estando en cualquier modo de configuracin regresa al modo


EXEC Privilegiado
Cancela la ejecucin del Dialogo de configuracin inicial o Setup

Ctrl+C
Ctrl+Shift+6
exit

Permite interrumpir intentos de ping, traceroute y traducciones de


nombres
Estando en el modo de configuracin global o cualquiera de sus
submodos regresa al modo anterior. Estando en los modos
EXEC Usuario o EXEC Privilegiado, cierra la sesin

COMANDOS ROUTER
Cambiar el nombre del host: (config)#hostname
Borrar la configuracin del router: #erase nvram: (debe confirmarse con enter una
segunda vez)
Salvar la configuracin del router: #copy running-config startup-config
Reiniciar el enrutador:
(Es normal que pida salvar los cambios de configuracin no guardados)
#reload
#Proceed with reload? [confirm]
Asignar ip a una interfaz
(config)#interface
(config-if)#ip address
Ejemplo:
(config)#interface serial 0/0
(config-if)#ip address 10.1.1.1 255.255.255.252
Asignar reloj a una interfaz:
(config-if)#clock rate
Ejemplo: (config-if)#clock rate 64000

Habilitar enrutamiento:
(config)#router [id de proceso]
(config-router)#network [wildcard]
Ejemplo 1:
(config)#router rip
(config-router)#network 172.16.0.0
exclusivo para rip (habilitar enrutamiento que soporte subredes de mscara variable)
(config-router)#version 2
Ejemplo 2:
(config)#router ospf 1
(config-router)#network 172.16.4.0 0.0.3.255 area 0.0.0.0
Visualizar la configuracin del router: #show running-config
Visualizar la tabla de enrutamiento de un router: #show ip route
Visualizar el estado de todas las interfaces: #show interfaces
Visualizar el estado de una interfaz: #show interface <#>
Ejemplo: #show interface serial 0/0/0
Agregar una ruta esttica (config)#ip route [metrica]
Ejemplo: (config)#ip route 0.0.0.0 0.0.0.0 192.168.4.5 10
Propagar rutas estticas por el protocolo de enrutamiento: (config-router)#redistribute
static
Establecer el password del modo enable: (config)#enable password
Establecer el password encriptado:(Es normal que arroje una alerta si se establece la
misma clave para el enable password)
(config)#enable secret
Habilitar la encripcin de claves en el archivo de configuracin: (config)#service
password-encriyption
Habilitar las terminales virtuales: (config)#line vty <#1> <#1>
(config-line)#password
(config-line)#login
Ejemplo:
(config)#line vty 0 4
(config-line)#password cisco
(config-line)#login