Está en la página 1de 5

ALGORITMOS

UNIDAD 2

RUBEN DARIO PRIETO DAZA

CODIGO: 1.144.136.698

GRUPO: 301303_128

CEAD: PALMIRA

UNIVERSIDAD NACIONAL ABIERTA A DISTANCIA

UNAD

2015

DESARROLLO DE LA ACTIVIDAD

2. EJERCICIOS PSeint A WORD O PDF

1. Se pide desarrollar el algoritmo del juego Adivina un Nmero, con las siguientes
caractersticas:
a) El nmero debe estar en el rango de 1 a 1000 (generado aleatoriamente)
Debe tener dos niveles nivel bsico y nivel experto, el nivel bsico no tendr
restricciones en nmero de oportunidades, adems se le dar indicaciones como
Caliente, Frio. El Nivel experto solo tendr 5 oportunidades con mensajes de
ayuda lejos, cerca
b) Al finalizar debe informar el nmero de intentos realizados antes de
encontrar la respuesta correcta.

PSeudocdigo:
Proceso ADIVINA_NUMERO
//Nombre del Autor: Ruben Dario Prieto Daza
//Fecha:10/10/15
//Doy fe que este ejercicio es de mi autora,
//en caso de encontrar plagio la nota de todo
//mi //trabajo debe ser de CERO adems de
//las respectivas sanciones a que haya lugar
Escribir "Adivina el numero"
Escribir "Seleccione una opcion"
Escribir "1. Nivel Basico"
Escribir "2. Nivel Experto"
Leer oportunidades
Segun oportunidades Hacer
1:
intentos<-10000
numero_secreto <- azar(1000)+1
Escribir "A escogido nivel Basico"

Escribir "Digite un numero"


Leer num_ingresado
Mientras numero_secreto<>num_ingresado Y intentos>1 Hacer
Si numero_secreto>num_ingresado Entonces
Escribir "Caliente"
Sino
Escribir "frio"
Fin Si
intentos<-intentos-1
Escribir "le quedan ", intentos, " intentos restantes"
Leer num_ingresado
Fin Mientras
Si numero_secreto=num_ingresado Entonces
Escribir "Felicitaciones!!! Usted adivino en ",10001-intentos," intentos."
Sino
Escribir "El numero era: ",numero_secreto
FinSi
2:
intentos<-5
numero_secreto <- azar(1000)+1
Escribir "A escogido nivel experto"
Escribir "Digite un numero"
Leer num_ingresado
Mientras numero_secreto<>num_ingresado Y intentos>1 Hacer
Si numero_secreto>num_ingresado Entonces
Escribir "lejos"
Sino
Escribir "cerca"
Fin Si
intentos<-intentos-1
Escribir "le quedan ", intentos, " intentos restantes"
Leer num_ingresado
Fin Mientras
Si numero_secreto=num_ingresado Entonces

Escribir "Felicitaciones!!! Usted adivino en ",11-intentos," intentos."


Sino
Escribir "El numero era: ",numero_secreto
FinSi
Fin Segun
FinProceso

DIAGRAMA PSeint

PANTALLA DE EJECUCION DEL PROGRAMA.


Programa ejecutndose correctamente.