Está en la página 1de 22

ALGORITMOS

UNIDAD 2

RUBEN DARIO PRIETO DAZA

CODIGO: 1.144.136.698

GRUPO: 301303_128

CEAD: PALMIRA

UNIVERSIDAD NACIONAL ABIERTA A DISTANCIA

UNAD

2015

DESARROLLO DE LA ACTIVIDAD

1. Ejercicios de DFD a PSeint.

1. Desarrolle un diagrama de flujo que de las instrucciones para preparar un


plato tpico de su regin que sea suficiente para 4 invitados.
PSeudocdigo:
Proceso plato_tipico
//Nombre del Autor: Ruben Dario Prieto Daza
//Fecha:9/10/15
//Doy fe que este ejercicio es de mi autora,
//en caso de encontrar plagio la nota de todo
//mi //trabajo debe ser de CERO adems de
//las respectivas sanciones a que haya lugar

Escribir "ingrese el numero de invitados"

Leer c
Escribir 'Porcin definida para un invitado (medidas en kilos): 1/2 de Papa, 1/2 de tomate,
1/2 de yuca, 1/2 de arroz, 1/2 de gallina'
pa<-1/2
to<-1/2
yu<-1/2
arr<-1/2
ga<-1/2
pp<-pa
tt<-to
yy<-yu
aa<-arr
gg<-ga
Escribir "Desea realizar algun cambio en las porciones?, Escriba 1 para si, 2 para no."
Leer n

Si n=1 Entonces
Escribir 'Cantidad de papa en kilos'
Leer pa
Si pa!=pp Entonces
Escribir 'Has cambiado la porcion de papa'
Sino

Fin Si
Escribir 'Cantidad kilos de tomate'
Leer to
Si to!=tt Entonces
Escribir 'Has cambiado la porcion de tomate'
Sino
Fin Si
Escribir 'Cantidad en kilos de yuca'
Leer yu
Si yu!=yy Entonces
Escribir 'Has cambiado la porcion de yuca'
Sino
Fin Si
Escribir 'Cantidad en kilos de arroz'
Leer arr
Si arr!=aa Entonces
Escribir 'Has cambiado la porcion de arroz'
Sino
Fin Si
Escribir 'Cantidad de gallina'
Leer ga
Si ga!=gg Entonces

Escribir 'Has cambiado la porcion de gallina'


Sino
Fin Si
ttt<-to*c

yyy<-yu*c
aaa<-arr*c
ggg<-ga*c
ppp<-pa*c
Escribir 'La cantidad de porciones para ', c, ' invitados es: ', ppp, ' kilos de papa ', ttt, ' kilos
de tomate ', yyy, ' kilos de yuca ',aaa,' kilos de arroz ', ggg, ' kilos de gallina'
Sino
ttt<-to*c
yyy<-yu*c
aaa<-arr*c
ggg<-ga*c
ppp<-pa*c
Escribir 'La cantidad de porciones para ', c, ' invitados es: ', ppp, ' kilos de papa ', ttt, ' kilos
de tomate ', yyy, ' kilos de yuca ',aaa,' kilos de arroz ', ggg, ' kilos de gallina'
Fin Si
FinProceso

DIAGRAMA PSeint

PANTALLA DE EJECUCION DEL PROGRAMA.


Programa ejecutndose correctamente.

2 Desarrolle un Diagrama que permita leer dos valores y escribir la suma,


resta, multiplicacin y divisin de estos nmeros.

Pseudocdigo:
Proceso suma_resta_division_multiplicacion
//Nombre del Autor: Ruben Dario Prieto Daza
//Fecha:9/10/15
//Doy fe que este ejercicio es de mi autora,
//en caso de encontrar plagio la nota de todo
//mi //trabajo debe ser de CERO adems de
//las respectivas sanciones a que haya lugar

Escribir 'ingrese 2 numeros para sumar, restar, multiplicar y dividir'


Leer a,b

suma<-a+b
resta<-a-b
multipli<-a*b
division<-a/b
Escribir 'la suma es ',a, '+' ,b,' = ',suma
Escribir 'la resta es ',a, '-' ,b,' = ',resta
Escribir 'la multiplicacion es ',a, ' x ' ,b,' = ',multipli
Escribir 'la division es ',a, '/' ,b,' = ',division
FinProceso

DIAGRAMA PSeint

PANTALLA DE EJECUCION DEL PROGRAMA.


Programa ejecutndose correctamente.

7. Desarrollar un diagrama que permita ingresar un valor en millas y lo convierta a


kilmetros, centmetros y yarda.
Pseudocdigo:
Proceso millas_a_km_cm_yd
//Nombre del Autor: Ruben Dario Prieto Daza
//Fecha:9/10/15
//Doy fe que este ejercicio es de mi autora,
//en caso de encontrar plagio la nota de todo
//mi //trabajo debe ser de CERO adems de
//las respectivas sanciones a que haya lugar
Escribir "digite el valor en millas que desea convertir"
Leer millas
km<-millas*1.609
cm<-millas*1609340
yd<-millas*1760
Escribir millas, " millas equivalen a: ", km, " kilometros, ", cm, " centimetros, ", yd, " yardas."
FinProceso

DIAGRAMA PSeint

PANTALLA DE EJECUCION DEL PROGRAMA.


Programa ejecutndose correctamente.

10. Desarrollar un diagrama que convierta un valor dado en metros cuadrados


(M2), en hectreas y Centmetros cuadrados.

Pseudocdigo:
Proceso m2_a_cm2_hm2
//Nombre del Autor: Ruben Dario Prieto Daza
//Fecha:9/10/15
//Doy fe que este ejercicio es de mi autora,
//en caso de encontrar plagio la nota de todo
//mi //trabajo debe ser de CERO adems de
//las respectivas sanciones a que haya lugar

Escribir "Conversor de metros cuadrados a Hectareas y Centimetros cuadrados"


Escribir "Escriba un valor en metros cuadrados que desea convertir"
Leer m2
hm2<-m2/10000

cm2<-m2*10000
Escribir m2, " metros cuadro equivalen a: ", hm2, " hectareas, ", cm2, " centimetros
cuadrados."
FinProceso

DIAGRAMA PSeint

PANTALLA DE EJECUCION DEL PROGRAMA.


Programa ejecutndose correctamente.

12. Desarrollar un diagrama que permita determinar si un valor cualquiera es


positivo o negativo.
Pseudocdigo:
Proceso averiguar_si_es_positivo_negativo
//Nombre del Autor: Ruben Dario Prieto Daza
//Fecha:9/10/15
//Doy fe que este ejercicio es de mi autora,
//en caso de encontrar plagio la nota de todo
//mi //trabajo debe ser de CERO adems de
//las respectivas sanciones a que haya lugar
Escribir "ingrese un numero para saber si es positivo o negativo"
Leer numer
Si numer > 0 Entonces
Escribir numer, " es un numero positivo"
Sino
Escribir numer, " es un numero negativo"
Fin Si
FinProceso

DIAGRAMA PSeint

PANTALLA DE EJECUCION DEL PROGRAMA.


Programa ejecutndose correctamente.

13. Desarrollar un diagrama que permia determinar sin un valor cualquiera es par
o impar.
Pseudocdigo:
Proceso par_impar
//Nombre del Autor: Ruben Dario Prieto Daza
//Fecha:9/10/15
//Doy fe que este ejercicio es de mi autora,
//en caso de encontrar plagio la nota de todo
//mi //trabajo debe ser de CERO adems de
//las respectivas sanciones a que haya lugar
Escribir 'ingrese un numero'
Leer nume
Si nume Es Multiplo De 2 Entonces
Escribir 'el numero es par'
Sino
Escribir 'el numero es impar'
Fin Si
FinProceso

DIAGRAMA PSeint

PANTALLA DE EJECUCION DEL PROGRAMA.


Programa ejecutndose correctamente

18. Disee un diagrama que permita leer dos nmeros N1 y N2 e indicar si uno de
los dos divide exactamente al otro.
Pseudocdigo:
Proceso divide_exacto
//Nombre del Autor: Ruben Dario Prieto Daza
//Fecha:9/10/15
//Doy fe que este ejercicio es de mi autora,
//en caso de encontrar plagio la nota de todo
//mi //trabajo debe ser de CERO adems de
//las respectivas sanciones a que haya lugar
Escribir "ingrese 2 numeros para saber si uno de los 2 divide exactamente al otro"
Leer num1,num2
resul<-num1/num2
Si num1 mod num2 = 0 Entonces
Escribir "su resultado es " resul, " por lo tanto ", num1, " es divisible de ",num2
Sino
Si num2 mod num1 =0 Entonces
Escribir "su resultado es " resul, " por lo tanto ", num2, " es divisible de ",num1
Sino
Escribir "su resultado es " resul, " por lo tanto ", num1, " y ",num2 " no son
divisibles exactos"
Fin Si
Fin Si
FinProceso

DIAGRAMA PSeint

PANTALLA DE EJECUCION DEL PROGRAMA.


Programa ejecutndose correctamente

20. Desarrollar un diagrama que permita el ingreso de 3 nmeros Num1, Num2,


Num3 e indicar si la suma de los 3 nmeros es par o impar.
Pseudocdigo:
Proceso Suma_de_3_numeros_con_resultado_par_o_impar
//Nombre del Autor: Ruben Dario Prieto Daza
//Fecha:9/10/15
//Doy fe que este ejercicio es de mi autora,
//en caso de encontrar plagio la nota de todo
//mi //trabajo debe ser de CERO adems de
//las respectivas sanciones a que haya lugar

Escribir "ingresa 3 numeros para sumarlos y luego saber si el resultado es par o impar"
Leer num1,num2,num3
suma<-num1+num2+num3
Si suma mod 2= 0 Entonces
Escribir "su resultado ", suma, " es par"
Sino
Escribir "su resultado ", suma, " es impar"
Fin Si
FinProceso

DIAGRAMA PSeint

PANTALLA DE EJECUCION DEL PROGRAMA.


Programa ejecutndose correctamente

23. Desarrolle un diagrama que permita determinar la nota mnima que usted debe
sacar en el examen final del curso Algoritmos de acuerdo a las condiciones actuales
75% y 25%(final), esta nota debe estar representada tanto en puntos y en nota
(0..5.0).

Pseudocdigo:
Proceso calcule_su_nota_final
//Nombre del Autor: Ruben Dario Prieto Daza
//Fecha:9/10/15

//Doy fe que este ejercicio es de mi autora,


//en caso de encontrar plagio la nota de todo
//mi //trabajo debe ser de CERO adems de
//las respectivas sanciones a que haya lugar

Escribir "Calcule su nota final"


Escribir 'Ingrese la calificacion de RECONOCIMIENTO... No debe ser mayor que 25 puntos
"
Leer reco
Escribir 'Ingrese la calificacion de la FASE 1... No debe ser mayor de 100 puntos '
Leer fase1
Escribir 'Ingrese la calificacion de la FASE 2... No debe ser mayor de 125 puntos '
Leer fase2
Escribir 'Ingrese la calificacion de la FASE 3... No debe ser mayor de 125 puntos '
Leer fase3
Escribir 'Ingrese la calificacion de la FASE FINAL... No debe ser mayor de 125 puntos '
Leer fasefin
pro<-reco+fase1+fase2+fase3
prom<-pro*5/375
proyec<-fasefin*5/125
curso<-prom*0.75
evaluacion<-proyec*0.25
puntos<-pro+fasefin
nota<-curso+evaluacion
minimo<-300-puntos
Si PUNTOS >= 300 Entonces
Escribir 'Usted obtubo: ' , puntos , ' puntos y su calificaion final es: ' , nota
Sino
Escribir 'Usted obtubo: ', puntos, ' puntos .Usted necesita minimo: ' , minimo , '
puntos, para pasar la materia.'
Fin Si
FinProceso

DIAGRAMA PSeint

PANTALLA DE EJECUCION DEL PROGRAMA.


Programa ejecutndose correctamente

25. Desarrollar un diagrama de flujo que permita determinar la fecha un da


despus a un fecha ingresada (tenga en cuenta meses de 30, 31, 28 das, cambio
de ao, ejemplo 31-12-2004 el da siguiente ser 1-1-2005).
Pseudocdigo:

Proceso Dia_despues
//Nombre del Autor: Ruben Dario Prieto Daza
//Fecha:9/10/15
//Doy fe que este ejercicio es de mi autora,
//en caso de encontrar plagio la nota de todo
//mi //trabajo debe ser de CERO adems de
//las respectivas sanciones a que haya lugar
Escribir "Ingrese Fecha en el formato DD/MM/AAAA"
Escribir "Ingrese Dia"
Leer Dia
Escribir "Ingrese Mes"
Leer Mes
Escribir "Ingrese Ao"
Leer Ao
Segun Mes Hacer
Caso 1,3,5,7,8,10:
Si Dia=31 Entonces
Escribir "Si la Fecha ingresada es:",Dia,"/",Mes,"/",Ao
Escribir "El dia siguiente a la fecha ingresada sera:1/",Mes+1,"/",Ao
Sino
Escribir "Si la Fecha ingresada es:",Dia,"/",Mes,"/",AO
Escribir "El dia siguiente a la fecha ingresada sera:" ,Dia+1,"/",Mes,"/",Ao
FinSi

Caso 4,6,9,11:
Si Dia=30 Entonces
Escribir "Si la Fecha ingresada es:",Dia,"/",Mes,"/",Ao
Escribir "El dia siguiente a la fecha ingresada sera:1/",Mes+1,"/",Ao
Sino
Escribir "Si la Fecha ingresada es:",Dia,"/",Mes,"/",Ao
Escribir "El dia siguiente a la fecha ingresada sera:" ,Dia+1,"/",Mes,"/",Ao
Finsi
Caso 2:
Si Ao mod 4=0 Entonces
Si Dia=28 Entonces
Escribir "Si la Fecha ingresada es: ",Dia, "/", Mes ,"/",Ao
Escribir "El dia siguiente a la fecha ingresada
sera:1/",Mes+1,"/",Ao
Sino
Escribir "Si la Fecha ingresada es:",Dia,"/",Mes,"/",Anho
Escribir "El dia siguiente a la fecha ingresada sera:"
,Dia+1,"/",Mes,"/",Ao
Finsi
Sino
Si Dia=29 Entonces
Escribir "Si la Fecha ingresada es:",Dia,"/",Mes,"/",Ao
Escribir "El dia siguiente a la fecha ingresada
sera:1/",Mes+1,"/",Ao
Sino
Escribir "Si la Fecha ingresada es:",Dia,"/",Mes,"/",Ao
Escribir "El dia siguiente a la fecha ingresada sera:"
,Dia+1,"/",Mes,"/",Ao
FinSi
FinSi
Caso 12:

Si Dia=31 Entonces

Escribir "Si la Fecha ingresada es:",Dia,"/",Mes,"/",Ao


Escribir "El dia siguiente a la fecha ingresada sera:1/",1,"/",Ao+1
Sino
Escribir "Si la Fecha ingresada es:",Dia,"/",Mes,"/",Ao
Escribir "El dia siguiente a la fecha ingresada sera:" ,Dia+1,"/",Mes,"/",Ao
FinSi

FinSegun
FinProceso

DIAGRAMA PSeint

PANTALLA DE EJECUCION DEL PROGRAMA.


Programa ejecutndose correctamente