Está en la página 1de 32

PROGRAMACIN

gpacurucur@ups.edu.ec/ Genaro Pacurucu


Contenidos:

Conceptos bsicos

Ciclo de vida del software

Tipos de lenguaje de programacin

Algoritmos

Ejercicios

Introduccin a la programacin orientado a objetos

Clases

Atributos

Mtodos

Propiedades

U.M.L.

Programacin JAVA (Netbeans)


Bibliografa:
Web

La web del programador

Programacin en castellano

Oracle

Universidad de Navarro.
Libros

Thinking in JAVA, Bruce Eckel

Manual de programacin JAVA 2 McGRaw Hill

Object Oriented Programming, Meter Coad Hill Incola PRENTICE HALL


CONCEPTOS BSICOS:
La programacin en general surge mediante la ejecucin de cdigos que responden a una secuencia lgica. Se
pretende realizar operaciones.
CONSTANTE.- Valor que no cambia
VARIABLES.- Valor que cambia en el tiempo
CICLO DE VIDA DEL SOTFWARE
Paradigma o modelo que se est siguiendo para confeccionar el software:

Recopilacin de la informacin (Ingeniera de la informacin)

Anlisis de la situacin actual y de la propuesta (factibilidad)

Diseo de la solucin (Estrategias)

Implementacin del software

Pruebas (Beta)

Lanzamiento (Relcese)
GENERACINES DE LA PROGRAMACIN
Lenguaje de bajo nivel (0-1). Lenguaje de maquina
Lenguaje Assembler (Ensamblador) Microprocesadores
Compiladores Lenguajes en base. Lenguaje natural. Ej.: Fortlan, Cobal, Pascal, C
Lenguajes de programacin tipo grfico. Ej: Visual Basic, Visual C, Visual C ++. Son solo eventos. Ej. Comandos de
Windows.
Lenguajes orientado a objetos
JAVA (Son Microsystem)
Delphi (Borland)
C. Net (Microsoft: web, Escritorio)
Visual.net (Microsoft: web, Escritorio)
PHP Sotware libre Web
ALGORITMOS
Surgen de la necesidad de realizar secuencias lgicas
Es una secuencia lgica, ordenada, finita y eficiente de pasos o instrucciones que se debe seguir en la resolucin de
in problema.
Ej.: Para ingreasr a la U
1. Aprobar 1er nivel
2. Matricula por internet
3. Pago en el banco
4. Legalizar

SIMBOLO

SEUDOCDIGO
Inicio

Inicio

Fin

Fin

Si

A>B

No

A=B Asignacin de Procesos


Impresin o
Salida de Datos

Control de
Lectura

Si (Se cumple la condicin)


Si (Ejecutar 1)
No (Ejecutar 2)
Operaciones
Mostrar respuesta

Leer dato

Sumar 2 nmeros diferentes de 0.


1. Inicio
2. Leer A
3. Si (A>0)
VALIDACIN

Si, ir a 4

No, ir a 2
4. Leer B
5. Si (B>0)
VALIDACIN

Si, ir a 6

No, ir a 4
6. Suma=A+B
7. Mostrar la Suma
8. Fin
Inicio

Leer A

No

A>0
Si

Leer B

No

B>0
Si
Suma=A+B
Suma

Fin

Algoritmo y Diagrama de Flujo: Formula


*1ra SOLUCIN
=b2-4ac
>02 soluciones

=0= nica Solucin


<0=No existe races
1. Inicio
2. Leer a
3. Leer b
4. Leer c
5. Discriminante Calcular: D=b^2*a*c
6. Si (D>0)

Si, ir a 7

No ir 8
7. X1, X2Imprimir
8. Si (D=0)

Si, ir a 9

No ir 10
9. X1Imprimir
10. Si (D<0)

Si, ir a 11

No ir 12
11. No hay solucin Imprimir
12. Fin
*2da SOLUCIN:
1. Inicio
2. Leer a
3. Leer b
4. Leer c
5. D=b^2*a*c
6. Si (D>0)

Si, ir a 7

No ir 8
7. Si (D=0)

Si, ir a 9

No ir 10
8. Mostrar Mltiples races
9. Mostrar nica raz
10. Mostrar No tiene races
11. Fin
Inicio
a
b
c
D=b^2-4ac
Si

Multiples
raizes

D>0

No

Si

D=0

Raiz
nica

Fin

No
No tiene
Raicez

A un trabajador le pagan sus horas y una tarifa de pago por horas. Si la cantidad de horas trabajadas es mayor a 40
horas, la tarifa se incrementa en un 50% para las horas extras. Calcular el salario del trabajador dadas las horas
trabajadas y la tarifa.
1. Inicio
2. Leer horas
3. Leer tarifa
4. Si (Horas>40)

Si, ir a 5

No, ir a 10
5. Sueldo=40*Tarifa
6. Hora_extra=Horas-40
7. Incremento=Tarifa*0.5
8. Tarifa_total=Tarifa+incremento
9. Sueldo_total=Sueldo+(Hora_extra*Tarifa_total)
10. Sueldo_total=Horas*Tarifa
11. Mostrar: Sueldo_total
12. Fin
Inicio

Horas
Tarifa
Si

Horas>40
No

No

Sueldo=40*Tarifa
Hora_extra=Horas-40
Incremento=Tarifa*0.05

Sueldo_total=Horas*Tarifa

Tarifa_total=Tarifa+incremento
Sueldo_total=Sueldo+Hora_extra+Tarifa_total

A
Fin

Horas
52
40

Tarifa
4
4

Sueldo
160

Hora_extra
12

Incremento
2

Tarifa_total
6

Sueldo_total
232
160

A un trabajador le descuentan de su sueldo el 10% si sueldo es menor o igual a 1000, si gana entre 1000 y 2000 el
5% del adicional y si gana ms de 2000 el 3% del adicional. Calcular el descuento y el sueldo neto que recibe el
trabajador.
Gana
1200-1000=200adicionalde aqu el 5%
2500-2000=500adicionalde aqu el 3%
1. Inicio
2. Leer valor del sueldo (variable x)
3. Leer sueldo
4. Si x <=1000

Si, ir a 5

No, ir a
5. A = [1000-1000(10%)]
6. Mostrar sueldo neto = A

7.

Si x >1000 y x <2000

Si, ir a 8

No, ir a
8. B = (x-1000)*(5%)
9. Mostrar = Sueldo neto = sueldo-B
10. C = (x-2000)*(3%)
11. Mostrar = Sueldo neto = sueldo-c
12. Fin
Inicio
Sue
Si

Sue<=1000

No
1000<Sue<2000

Desc=Sue*0.1
Sue_A=Sue-desc

Sue_A

Si

No

Desc=(Sue-1000)0.05

Desc=(Sue-2000)0.03

Sue_B=Sue-desc

Sue_C=Sue-desc

Sue_B

Sue_C

Fin

Leer 2 valores distintos y determinar cual de los 2 valores es mayor.


1. Inicio
2. Leer A
3. Ller B
4. Si A=B

Si, ir a 2

No, ir a 5
5. Si A>B

Si, ir a 6

No, ir a 7
6. Mostrar A es mayor
7. Mostrar B es mayor
8. Fin

Inicio

A
B

Si

No

A=B

A>B

No

Si

Fin

Desarrollar un algoritmo y el diagrama de flujo que permita leer 3 valores y almacenarlos en las variables A,B,C
respectivamente. El algoritmo debe imprimir cual es el menor y cual es el mayor. Recuerde constatar que los 3
valores introduciodos sean distintos. Presente un mensaje de alerta en caso de que se presenten valores iguales.
A=8
B=7
C=6
A=6
B=7
C=8
A
B
C
Aux
8
7
6
7
7
8
7
6
6
7
8
7
a.

Si (A>B)

Si, ir a b

No ,ir a c
b. Aux=B
c. B=A
d. A=Aux
e. Si (A>C)

Si, ir a f

No ,ir a i
f. Aux=C
g. C=A
h. A=Aux
i.
Si (B>C)

Si, ir a j

No ,ir a m
j.
Aux=C
k. C=B
l.
B=Aux
m. Mostrar: A menor, C mayor
1.
2.
3.
4.
5.

Inicio
Leer A
Leer B
Leer C
Si (A=B) y (A=C)

Si, ir a 6

No ir a 8

6.
7.
8.

9.
10.
11.
12.

13.
14.
15.
16.

17.
18.
19.
20.
21.

Mostrar: Valores iguales


Ir a 2
Si (A>B)

Si, ir a 9

No ir a 12
Aux=B
B=A
A=Aux
Si (A>C)

Si, ir a 13

No ir a 16
Aux=C
C=A
A=Aux
Si (B>C)

Si, ir a 17

No ir a 20
Aux=C
C=B
B=Aux
Mostrar A es es el menor y C es el mayor
Fin
Inicio

A=B y
A=C

No
A>B

No

Si
Si
Valores
Iguales

A>C

No

Aux=B
Si

B>C

B=A
Aux=C

Si

C=A

Aux=C

A=Aux

C=B

A=Aux

B=Aux

A es <
B es >

Fin

CICLOS DE REPETICION

No

Secuencias de pasos ordenados de pasos hasta que se cumpla la condicin o hasta que se deje de cumplir.
REPETIR

MIENTRAS (Do While) (Hacer Mientras)


Repetir
Paso A
Paso B

Paso N
Mientras (Se cumple la condicin)
*Por lo menos una vez se va ejecutar

Si

Lectura

Cond

No

MIENTRAS

(While)
Mientras (Se cumple la condicin)
Paso A
Paso B

Paso N

Cond

No

Si
Lectura
AUTOMTICO

PARA (For)
Para (Desde valor inicial; Hasta valor final; incremento)
Paso A
Paso B

Paso N
Val_in;Val_fin;Inc

Lectura

Obtener la suma de los 5 primeros nmeros naturales excluido el cero (1+2+3+4+5)


1. Inicio
2. Suma=0Acucumaldor
3. Contador=1
4. Para (Contador; Contador<=5;Contador=Contador+1=
5. Suma=Suma+Contador
6. Mostrar: Suma
7. Fin
Leer un n numero y que imprima la frase Hola hasta que el numero ingresado sea el 0
While (1ra Forma)
1. Inicio
2. N=1 (Por lo menos voy a ejecutar una vez)

3.
4.
5.
6.
7.

Mientras (N<>0) (diferente)


Leer N
Mostrar Hola
Fin Mientras
Fin
Inicio

N=1

N<>0

No

Si
N
Hola
Fin

Do While (2da Forma)


1. Inicio
2. Repetir
3. Leer N
4. Mostrar. Hola
5. Mientras (N<>0)
6. Finalizar
Inicio

A
Si

Hola

N<>0

No

Fin

Algoritmo: Para 5*4=20 en base a suma. Ej.: 5+5+5+5=20


While (1ra Forma)
1. Inicio
2. Leer A
3. Leer B
4. Contador=1 (Si esto es 0)
5. Suma=0
6. Mientras (Contador<= B) (esto sera solo <)
7. Suma=Suma+A
8. Contador=Contador+1
9. Fin Mientras
10. Mostrar: Suma
11. Fin

Inicio

A
B
Con=1
Suma=0

Con<=B

No

Si

Suma

Suma=Suma+A

Con=Con+1
Fin

FOR (2da Forma)


1. Inicio
2. Leer A
3. Leer B
4. Suma=0
5. Para(contador=1;contador<=B; contador=contador+1)
6. Suma=Suma+A
7. Fin Para
8. Mostrar Suma
9. Fin

Inicio

B
Suma=0

Con=1;Con>=
B; Con=Con+1

Suma=Suma+A

Suma
Fin

Hacer con el Do While


Realizar un algoritmo para cuando tenemos. Ej.: N=55 4 3 2 1
1era Forma
1. Inicio
2. Leer N
3. Mientras (N<>0)
4. Mostrar N
5. N=N-1
6. Fin mientras
7. Fin
Inicio

N<>0

Si
N

No

Fin

N=N-1

2da Forma
1. Inicio
2. Leer N
3. Contador=1
4. Mientras(Contador<=N)
5. Mostar Contador
6. Contador=Contador+1
7. Fin Mientras
8. Fin

Inicio
N
Con=1

Con<=N
No

Si
Con

Fin

Con=Con+1

3era Forma
1. Inicio
2. Leer N
3. Para(i=N;i>=1;i=i-1)
4. Mostrar N
5. Fin Para
6. Fin
Inicio

N
i=N;i>=1;i=N-1
N

Fin

Hacer un algoritmo cuando 23=8, en base a 2*2*2=8 o 42=4*4=16


1.
2.
3.
4.
5.
6.
7.
8.
9.
10.
11.

Inicio
Leer A
Leer B
P=1
C=1
Mientras (C<=B)
P=P*A
C=C+1
Fin mientras
Mostrar P
Fin
A
B
C
P
3
4
1
1
2
3
3
9
4
27
5
8
5
0
1
1

Inicio

A
B
Pot=1
Con=1

Con<=B

No

Si

Pot

Pot=Pot*A

Con=Con+1
Fin

A
3

B
4

Con
1
2
3
4
5
1

Pot
1
3
9
27
8
1

Estructura de Datos
Dinmicas:
Estticas: (Arrays)
Unidimensionales: Vectores
Bidimensionales: Matrices
Forma
Vectores

Matricez

Dim A [5] = A=
5
4
1

1
2
3

Vector de 5 posiciones
Quiere decir:
A[1]=5
A[2]=4
A[3]=1
A[4]=0
A[5]=3
A[1]=X

Algoritmo para llenar los 5 primeros nmeros naturales en un vector


1. Inicio
2. Dim A[5]
3. Para(i=1;i<=5;i=i+1)
4. A[i]=1
5. Fina Para
6. Fin
Inicio
Dim A[5]

i=1;i<=5;i=i+1

A[i]=i

Fin

A[5]=

i
1
2
3
4
5

A[i]
1 A[1]
2 A[2]
3 A[3]
4 A[4]
5 A[5]

Algoritmo que permita leer 5 nmeros cualquiera y luego obtener el promedio


1. Inicio
2. Dim A[5]
3. S=0
4. Para(i=1;i<=5;i=i+1)
5. Leer A[i]
6. S=S+A[i]
7. Fina Para
8. Promedio=(S/5)
9. Mostrar Promedio
10. Fin

Inicio
Dim A[5]

S=0

i=1;i<=5;i=i+1

A[i]

S=S+A[i]

Pro=S/5
Prom

Fin

i
1
2
3
4
5

S
15
32
52
62
69

A[i]
15
17
20
10
7

P
13.8

Operador
5 mod(2)=1
5/2=1
Mod: Da el residuo de una divisin entera
Leer 5 nmeros. Solamente permite almacenar nmeros pares
1. Inicio
2. Dim A[5]
3. Para (i=1;i<=5;i=i+1)
4. Leer N
5. Si (N mod(2)=0)

Si, ir a 6

No, ir a 7
6. A[i]=N
7. A[i]=0
8. Fin Para
9. Fin

Inicio

Dim A[5]

i=1;i<=5;i=i+1
N

Nmod(2)=0
Si

No

A[i]=N

A[i]=0

Fin

Algoritmo para dimensionar un vector segn solicite el usuario. Y luego realizar el promedio
1. Inicio
2. Leer N
3. Dim A [n]
4. S=0
5. Para(i=1;i<=N;i=i+1)
6. Leer A [i]
7. S=S+A[i]
8. Fin Para
9. Prom=S/N
10. Mostrar Prom
11. Para(i=1;i<=N;i=i+1)
12. MOstara A[i]
13. Fin Para
14. Fin

Inicio
N
A[N]
S=0
i=1;i<=N;i=i+1
A[i]
S=S+A[i]

Prom=S/N

Prom

i=1;i<=N;i=i+1

A[i]

Fin

1.
2.
3.
4.
5.
6.
7.
8.
9.

10.
11.
12.
13.
14.
15.
16.
17.
18.

Ordenamiento ascendente de un vector


Inicio
Leer D
Dim [D]
Para (i=1;i<=D; i=i+1)
Leer A[i]
Fin Para
Para (i=1;i<=D-1; i=i+1)
Para (j=i+1; j<=D;j=j+1)
Si A[i]>A[j]

Si, ir a 10

No, ir a 13
Aux=A[j]
A[j]=A[i]
A[i]=Aux
Fin Para
Fin Para
Para (i=1;i<=D; i=i++)
Mostrar A[i]
Fin Para
Fin

Inicio
D
Dim A[D]
i=N;i<=D;i=i+1
A[i]

i=1;i<=D-1;i=i+1
i=i+1;i<=D;i=i+1

A[i]>A[j]

Aux=A[j]
A[j]=A[i]
A[i]=Aux

i=1;i<=D;i=i++
A[i]

Fin

D
5

i
1
2
3
4
5
1

Aux

2
3
4
5

A[i]
5 A[1]i
1 A[2]j
2
7
9
1
5
2
7
9
1
2
5
7
9

3
4
5

MATRICES
A[M,N]

M1

j
N1
1

j
N2
2

j
N3
3

j
N4
4

i
i
i

M2
M3
M4

1.
2.
3.
4.
5.

Inicio
Dim [4,4]
Para (i=1;i<=4;i=i+1)
Para (j=1;j<=4;j=j+1)
Si (i=1)
Si, ir a 6
No, ir a 7
A[i,j]=j
A[i,j]=A[i-1,j]+4
Fin Para
Fin Para
Para (i=1;i<=4;i=i+1)
Para (j=1;j<=4;j=j+1)
Mostrar A[i,j]
Fin Para
Fin Para
Fin

6.
7.
8.
9.
10.
11.
12.
13.
14.
15.

5
9
13

6
10
14

Inicio
Dim[4,4]
i=1; i<=4;i=i+1
i=1; i<=4;i=i+1
i=1
Si

No

A[i,i]=j

A[i,j]+4

i=1; i<=4;i=i+1
i=1; i<=4;i=i+1
A[i,j]

Fin

Ejercicio: Visualizar
*
*
*
*
*

*
0
0
0
*
1.
2.
3.
4.

*
0
0
0
*

*
0
0
0
*

*
*
*
*
*

Inicio
Dim [5,5]
Para (i=1;i<=5;i=i+1)
Para (j=1;j<=5;j=j+1)

7
11
15

8
12
16

5.
6.
7.
8.
9.
10.

11.
12.

13.
14.
15.
16.
17.
18.
19.
20.
21.

A[i,j]=0
Fin Para
Fin Para
Para (i=1;i<=5;i=i+1)
Para (j=1;j<=5;j=j+1)
Si ((i=1) or (i=5))

Si, ir a 11

No, ir a 12
A[i,j]=*
Si ((j=1) or (j=5))

Si, ir a

No, ir a
A[i,j]=*
Fin Para
Fin Para
Para (i=1;i<=5;i=i+1)
Para (j=1;j<=5;j=j+1)
Mostrar A[i,j]
Fin Para
Fina Para
Fin

Inicio
Dim A[5,5]

i=1;i<=5;i=i+1
j=1;i<=5;j=j+1
A[i,j]=0

i=1;i<=5;i=i+1

j=1;i<=5;j=j+1

Si

i=1or i=5

A[i,j]=*

Si

No

j=1or j=5

No

A[i,j]=*

i=1;i<=5;i=i+1
j=1;i<=5;j=j+1

A[i,j]

Fin

Matrices: Llenar en una matriz de ceros y las diagonales con *


*
0
0
0
*

0
*
0
*
0
1.
2.
3.
4.
5.
6.

0
0
*
0
0

0
*
0
*
0

*
0
0
0
*

Inicio
Dim [5,5]
Para (i=1;i<=5;i=i+1)
Para (j=1;j<=5;j=j+1)
A[i,j]=0
Si (i=1&&j=1)
Si ir a 6
No ir a 7

7.
8.

9.
10.

11.
12.

13.
14.

15.
16.

17.
18.

19.
20.

21.
22.

23.
24.
25.
26.
27.
28.
29.
30.
31.

A [i,j]=*
Si (i=1&&j=5)
Si ir a 8
No ir a 9
A [i,j]=*
Si (i=2&&j=2)
Si ir a 10
No ir a 11
A [i,j]=*
Si (i=2&&j=4)
Si ir a 12
No ir a 13
A [i,j]=*
Si (i=3&&j=3)
Si ir a 14
No ir a 15
A [i,j]=*
Si (i=4&&j=2)
Si ir a 16
No ir a 17
A [i,j]=*
Si (i=4&&j=4)
Si ir a 18
No ir a 19
A [i,j]=*
Si (i=5&&j=1)
Si ir a 20
No ir a 21
A [i,j]=*
Si (i=5&&j=5)
Si ir a 22
No ir a 23
A [i,j]=*
Fin Para
Fin Para
Para (i=1;i<=5;i=i+1)
Para (j=1;j<=5;j=j+1)
Fin Para
Fin Para
Fin
Fin

Leer 2 vectores de igual dimensin y en un 3er vector almacenar el valor del producto de cada posicin de los
vectores ledos
1. Inicio
2. Leer N
3. Dim A[N]
4. Dim B[N]
5. Dim C[N]
6. Para (i=1; i<=N; i=i+1
7. Leer A[i]
8. Leer B[i]
9. Fin Para
10. Para (i=1; i<=N; i=i+1)
11. C[i]=A[i]*B[i]
12. Fin Para
13. Para (i=1;i<=N;i=i+1)
14. Mostrar C[i]
15. Fin Para
16. Fin

Inicio
N
Dim A[N]
Dim B[N]
Dim C[N]

i=1;i<=N;i=i+1

A[i]
B[i]

i=1;i<=N;i=i+1

C[i]=A[i]*B[i]

i=1;i<=N;i=i+1

C[i]

Fin

Ordenar descendentemente los elementos de un vector


1. Inicio
2. Leer N
3. Dim [N]
4. Para (i=1;i<=N; i=i+1)
5. Leer A[i]
6. Fin Para
7. Para (i=1;i<=N; i=i+1)
8. Para (j=i+1; j<=N-1;j=j+1)
9. Si A[i]<A[j]

Si, ir a 10

No, ir a 13
10. Aux=A[i]
11. A[i]=A[j]
12. A[j]=Aux
13. Fin Para
14. Fin Para
15. Para (i=1;i<=N; i=i+1)
16. Fin Para
17. Fin

Inicio
N
Dim A[N]

i=1;i<=N;i=i+1

A[i]

i=1;i<=N;i=i+1

j=i+1;j<=N-1;j=j+1

Si

A[i]<A[j]

Aux=A[i]
A[i]=A[j]
A[j]=Aux

i=1;i<=N;i=i+1
A[i]

Fin

Que permita invertir los valores


1. Inicio
2. Leer N
3. Dim A[N]
4. Para(i=1; i<=N; i=i+1)
5. Leer A[i]
6. Fin Para
7. Para(i=1; i<=N; i=i+1)
8. J=N
9. Aux[i]=Aux[j]
10. j=j-1
11. Fin Para
12. Para(i=1; i<=N; i=i+1)
13. A[i]=Aux[i]
14. Mostra A[i]
15. Fin Para
16. Fin

No

Inicio
N
Dim A[N]

i=1;i<=N;i=i+1

A[i]

i=1;i<=N;i=i+1

j=N
Aux[i]=Aux[j]
j=j-1

i=1;i<=N;i=i+1
A[i]=Aux[i]
A[i]

Fin

Que permita llenar de * la diagonal principal


1. Inicio
2. Leer N
3. Dim[N,N]
4. Para(i=1; i<=N; i=i+1)
5. Para (j=1; j<=N; j=j+1)
6. Si (i=j)

Si, ir a 7

No, ir a 8
7. A[i,j]=*
8. Fin Para
9. Fin Para
10. Para (i=1; i<=N; i=i+1)
11. Para (j=1; j<=N; j=i+1)
12. Mostrar A[i,j]
13. Fin Para
14. Fin Para
15. Fin

Inicio
N
Dim A[5,5]
i=1;i<=N;i=i+1
j=1;i<=N;j=j+1

Si

No

i=j

A[i,j]=*

i=1;i<=N;i=i+1
j=1;i<=N;j=j+1

A[i,j]

Fin

Si son pares sumar 2 nmeros; si son impares el producto, caso contrario efectuar la resta

Inicio
A
B
Amod(2)=0
Bmod(2)=0

Amod(2)=1
Bmod(2)=1

No

Si

No

Si

Si

R=A+B

R=A*B

R=A-B

R
Fin

Leer el nmero de tems de una factura, luego leer el valor de cada tem para obtener el valor del subtotal. Calcular
el IVA y finalmente el total de la factura

Inicio
N

Dim A[N]
S=0
i=1;i<=1;i=i+1
A[i]

S=S+A[i]

IVA=S*0.12
T=S+IVA
T

Fin

Inicio
S=0

i=1

i<=N

No

Si
Valor
S=S+Valor
IVA=S*0.12
T=S+IVA
i=i+1

Fin

Obtener el mayor valor de un vector de N posiciones.

Inicio
D
Dim A[D]
i=N;i<=D;i=i+1
A[i]

i=1;i<=D-1;i=i+1
i=i+1;i<=D;i=i+1

A[i]>A[j]

Aux=A[i]
A[i]=A[j]
A[j]=Aux

i=1;i<=D;i=i++
A[N]

Fin

Que permita leer N valores y realizar la suma nicamente de los valores pares de un vector

Inicio

i=1;i<=N;i=i+1

A[i]

i=1;i<=N;i=i+1

Si

A[i]mod(2)=0

No

S=S+A[i]

Fin

ALGORITMO
Inicio
Declaracin: Dar nombre a una variable y definir el tipo de variable
Tipos
Numrica. Ej.: Nota
Alfabtica. Ej.: Nombre
Alfanumrica. Ej.: Placa
Asignacin: Dar un valor a una variable X
Tipos:
Directa. Ej.: Nota=30
Por teclado. Ej.:(Ingrese su nota)
Partes:
Mensaje
Lectura(Leer)
Proceso: Serie ordenada y concatenada de operaciones para resolver un problema
Ej.: Promedio=(Nota1+Nota2)/2
Visualizacin: Visualiza los resultados obtenidos en el proceso
Partes
Mensaje + Variable
Ej.: Su promedio es, variable
Fin
Realizar un algoritmo para calcular el promedio de 3 notas, asuma que las notas son ingresadas indirectamente
Inicio
Declaracin:
Nota1, Nota2, Nota3Nmerica
PromedioNmerica
Asignacin:
Imprimir (Ingrese su Nota 1)
Leer (Nota1)
Imprimir (Ingrese su Nota 2)
Leer (Nota2)
Imprimir (Ingrese su Nota 3)
Leer (Nota3)
Proceso:
Promedio=(Nota1+Nota2+Nota3)/3

Visualizacin:
Imprimir (Su promedio es, Promedio)
Fin

Realizar un algoritmo para determinar el nombre, el apellido de un estudiante y si aprueba o


reprueba el nivel, considerando que la nota final es el promedio de 4 aportes
Inicio
Declaracin:
NOM, APEAlfabetica
NOTFIN, PROM, SUMANmerica
MENSAJEAlfabetica
APOR1, APOR2, APOR3, APOR4Nmerica
Asignacin:
Imprimir (Ingrese su nombre)
Leer (NOM)
Imprimir (Ingrese su apellido)
Leer (APE)
Imprimir (Ingrese su aporte 1)
Leer (APOR1)
Imprimir (Ingrese su aporte 2)
Leer (APOR2)
Imprimir (Ingrese su aporte 3)
Leer (APOR3)
Imprimir (Ingrese su aporte 4)
Leer (APOR4)
Proceso:
SUMA=( APOR1+APOR2+ APOR3+ APOR4)
PROM=SUMA/4
NOTFIN=PROM
Si (NOTFIN<=70)Entonces
MENSAJE=APRUEBA
Caso Contrario
MENSAJE=REBRUEBA
Fin si
Visualizacin:
Imprimir (El estudiante, NOMB, APE, MENSAJE, con, NOTFIN, puntos)
Fin
Realizar un algoritmo para calcular el total a pagar por la compa de 3 artculos. Considere que la tienda factura IVA
Inicio
Declaracin:
IVA, TOTPAG, PRECIO1, PRECIO2, PRECIO3 Nmerica
Asignacin:
Imprimir (Ingrese el precio del primer artculo)
Leer (PRECIO1)
Imprimir (Ingrese el precio del segundo artculo)
Leer (PRECIO2)
Imprimir (Ingrese el precio del tercer artculo)
Leer (PRECIO3)
Proceso:
SUMA=( PRECIO1+ PRECIO2+ PRECIO3)
IVA=SUMA*0.12
TOTPAG=SUMA+IVA
Visualizacin:
Imprimir (El valor a cancelar es: , TOTPAG, dlares)
Fin
Realizar un algoritmo para calcular el pago, el IVA, el descuento, y cancelar por la compa de 5 artculos. Considere
que la tienda ofrece un descuento del 30% s el total de la compra supera los 1000 dlares.

Inicio

Declaracin:
DESC, IVA, TOTPAG, PRECIO1, PRECIO2, PRECIO3, PRECIO4, PRECIO5 Nmerica
Asignacin:
Imprimir (Ingrese el precio del primer artculo)
Leer (PRECIO1)
Imprimir (Ingrese el precio del segundo artculo)
Leer (PRECIO2)
Imprimir (Ingrese el precio del tercer artculo)
Leer (PRECIO3)
Imprimir (Ingrese el precio del cuarto artculo)
Leer (PRECIO4)
Imprimir (Ingrese el precio del quinto artculo)
Leer (PRECIO5)
Proceso:
SUMA=( PRECIO1+ PRECIO2+ PRECIO3+PRECIO4+PRECIO5)
IVA=SUMA*0.12
TOTPAG=SUMA+IVA
Si (TOTPAG>1000) Entonces
DESC=TOTPAG*0.3
TOTPAG2=TOTPAG-DES
Caso Contrario
TOTPAG2=TOTPAG
Visualizacin:
Imprimir (El valor a cancelar es: , TOTPAG2, dlares)
Fin