Está en la página 1de 12

2015

Reporte
Prctica Final
Tpicos Avanzados de Redes

Joel Barranco Jimnez

Planteamiento
Se configurar la siguiente red (Figura 10). Dicha red estar dividida en 4 subredes:
vlan1 Administrativa de las VLAN 192.168.70.0 /26. Todos los switchs pertenecen a la
vlan 1.
vlan2 Administracin 192.168.70.64 /26. Los Host A y B
vlan3 Produccin 192.168.70.128 /26. Los Host C y D
vlan4 Ingeniera 192.168.70.192 /26. Los Host E y F

Figure 1: Diagrama de la Red


Ademas de esto, se usaran dos redes con servidores para el uso de servicios como DNS,DHCP,
Correo Electrnico, Internet entre otros. Se necesitara un protocolo de enrutamiento, que en
mi caso usar EIGRP.
Se necesita establecer ciertas polticas en la empresa por lo que se har uso de Access-List
para realizar las siguientes condiciones en la red:
Los equipos de cada departamento no pueden compartir informacin entre equipo de
otros departamentos, solo podrn tener comunicacin los equipos A1,B1,C1,D1,E1 Y F1
que son equipos destinados a jefes de rea.
No se debe poder hacer ping a cada uno de los servidores.
El acceso al servidor de ADMINISTRACION esta permitido solo para miembros del departamento y los jefes de rea.
Topicos Avanzados de Redes

Page 1

El acceso al servidor de INGENIERIA esta permitido solo para los miembros del departamento y los jefes de rea.
Los equipos del departamento de produccin no tienen acceso a internet solo los equipos
C1 y D1 que son equipos destinados a los jefes de rea.
Desde internet solo se tiene acceso HTTP a los servidores generales company(uv.com)
y workgroup(fiuv.com).
Desde internet solo se tiene acceso Telnet al router principal por parte del equipo PC0
ubicado en la red de internet.

Configuraciones
Configuracion de los Switch
Todos los Switch
enable
conf terminal
vlan 1 - exit
vlan 2
name Administracion - exit
vlan 2
name Produccion - exit
vlan 3
name Ingenieria
int vlan 1
ip add 192.168.70.6 255.255.255.192 (ip a cada switch)
no shut

Interfaces conectadas a hosts


int range fa0/1 - 5
switchport mode access
switchport access vlan 1 (El numero de la vlan a la que corresponde)
spanning-tree portfast
no shut

Topicos Avanzados de Redes

Page 2

Interfaces conectadas a Switchs


int range fa0/23 - 24
switchport mode trunk
switchport trunk native vlan 1
spanning-tree portfast trunk
no shut
Switch Central
enable
conf terminal
int range gi0/1 - 2
switchport trunk native vlan 1
spanning-tree portfast trunk
no shut - exit
int fa0/1
switchport trunk encapsulation dot1q
switchport mode trunk
switchport trunk native vlan 1
spanning-tree portfast trunk
spanning-tree vlan 1 priority 4096

Configuracion de los Routers

Topicos Avanzados de Redes

Page 3

Interfaz de salida a la red


enable
conf terminal
int fa0/1.1
encapsulation dot1Q 1 native (native solo va en la vlan 1)
ip add 192.168.70.1 255.255.255.192
no shut - exit
int fa0/1.2
encapsulation dot1Q 2
ip add 192.168.70.65 255.255.255.192
no shut - exit
int fa0/1.3
encapsulation dot1Q 3
ip add 192.168.70.129 255.255.255.192
no shut - exit
int fa0/1.4
encapsulation dot1Q 4
ip add 192.168.70.193 255.255.255.192
no shut - exit
Interfaz de salida al servidor
int fa0/0
ip add 173.16.0.1 255.255.0.0
no shut
Configuracion Serial e EIGRP
int se0/0/0
clock rate 64000
ip add 10.0.0.1 255.0.0.0
no shut - exit
router eigrp 1
network 192.168.70.0
network 193.16.2.0
network 172.16.2.0
network 10.0.0.0

Configuracion de los Host


Los host se les asign una ip de acuerdo al rango de la subred en la que se encuentran, y las
pcs exteriores se configurarion mediante el servicio DHCP.
Topicos Avanzados de Redes

Page 4

PC A1
ipconfig /ip 192.168.70.66 255.255.255.192
ipconfig /dg 192.168.70.65
PC C1
ipconfig /ip 192.168.70.130 255.255.255.192
ipconfig /dg 192.168.70.129
PC E1
ipconfig /ip 192.168.70.194 255.255.255.192
ipconfig /dg 192.168.70.193

Configuracion de Servicios en los servidores

(a) Configuracion en el Servidor

(b) Configuracion en la PC

Figure 2: Configuracin del servicio Email

(a) Configuracion en el Servidor

(b) Configuracion en la PC

Figure 3: Configuracin del servicio DHCP

Topicos Avanzados de Redes

Page 5

(a) Configuracion en el Servidor

(b) Configuracion en la PC

Figure 4: Configuracin del servicio DNS

(a) Configuracion en el Servidor

(b) Configuracion en el Router

Figure 5: Configuracin del servicio TFTP

Prueba de los Servicios

(a) Email

(b) DNS

Figure 6

Topicos Avanzados de Redes

Page 6

(a) TFTP

(b) Ping entre PCs

Figure 7

Comfiguracion Access-List
Las listas de acceso se configuraron en el Router2 ya que es el puente entre la red local y la
salida a internet, y por donde transita todo el trafico dentro de la misma LAN. Los permisos
fueron especificados al comienzo del reporte y quedaron de la siguiente manera:
En la subinterfaz fa0/1.2
1.- Denegamos la comunicacion hacia el server de la vlan 2
access-list 111 deny icmp any host 192.168.70.74
2.- Permitimos la comunicacion de los hosts C1,D1,E1,F1 a la vlan 2
access-list 111 permit ip host 192.168.70.130 192.168.70.64 0.0.0.63
access-list 111 permit ip host 192.168.70.134 192.168.70.64 0.0.0.63
access-list 111 permit ip host 192.168.70.194 192.168.70.64 0.0.0.63
access-list 111 permit ip host 192.168.70.198 192.168.70.64 0.0.0.63
3.- Se niega la vlan 3,vlan 4 a vlan 2
access-list 111 deny ip 192.168.70.128 0.0.0.63 192.168.70.64 0.0.0.63
access-list 111 deny ip 192.168.70.192 0.0.0.63 192.168.70.64 0.0.0.63
4.- Permitimos todo lo demas
access-list 111 permit ip any any
Agregamos la lista a la interfaz:
int fa0/1.2
ip access-group 111 out

Topicos Avanzados de Redes

Page 7

En la subinterfaz fa0/1.3
1.- Permitimos la comunicacion de los hosts A1,B1,E1,F1 a la vlan 3
access-list 112 permit ip host 192.168.70.66 192.168.70.128 0.0.0.63
access-list 112 permit ip host 192.168.70.70 192.168.70.128 0.0.0.63
access-list 112 permit ip host 192.168.70.194 192.168.70.128 0.0.0.63
access-list 112 permit ip host 192.168.70.198 192.168.70.128 0.0.0.63
2.- Se niega la vlan 2,vlan 4 a vlan 3
access-list 112 deny ip 192.168.70.64 0.0.0.63 192.168.70.128 0.0.0.63
access-list 112 deny ip 192.168.70.192 0.0.0.63 192.168.70.128 0.0.0.63
3.- Permitimos todo lo demas
access-list 112 permit ip any any
1.- Negamos ping al servidor
access-list 116 deny icmp any host 172.16.2.3
2.- Permitimos a C1 y D1 acceder a internet
access-list 116 permit ip host 192.168.70.130 198.32.16.0 0.0.0.255
access-list 116 permit ip host 192.168.70.134 198.32.16.0 0.0.0.255
3.- Negar la salida a internet a la vlan 3
access-list 116 deny ip 192.168.70.128 0.0.0.63 198.32.16.0 0.0.0.255
4.- Permitimos todo lo demas
access-list 112 permit ip any any
Agregamos la lista a la interfaz:
int fa0/1.3
ip access-group 112 out
ip access-group 116 in
En la subinterfaz fa0/1.4
1.- Denegamos la comunicacion hacia el server de la vlan 4
access-list 113 deny icmp any host 192.168.70.2024
2.- Permitimos la comunicacion de los hosts C1,D1,A1,B1 a la vlan 2
access-list 111 permit ip host 192.168.70.130 192.168.70.64 0.0.0.63
Topicos Avanzados de Redes

Page 8

access-list 111 permit ip host 192.168.70.134 192.168.70.64 0.0.0.63


access-list 113 permit ip host 192.168.70.66 192.168.70.192 0.0.0.63
access-list 113 permit ip host 192.168.70.70 192.168.70.192 0.0.0.63
3.- Se niega la vlan 2,vlan 3 a vlan 4
access-list 113 deny ip 192.168.70.64 0.0.0.63 192.168.70.192 0.0.0.63
access-list 113 deny ip 192.168.70.128 0.0.0.63 192.168.70.192 0.0.0.63
4.- Permitimos todo lo demas
access-list 113 permit ip any any
Agregamos la lista a la interfaz:
int fa0/1.4
ip access-group 113 out
En la subinterfaz fa0/1.1
1.- Negar ping al servidor
access-list 114 deny icmp any host 192.168.70.15
2.- Permitimos todo lo demas
access-list 114 permit ip any any
Agregamos la lista a la interfaz:
int fa0/1.1
ip access-group 114 out
En la subinterfaz fa0/1
1.- Negar ping al servidor
access-list 115 deny icmp any host 193.168.70.2
2.- Permitimos todo lo demas
access-list 115 permit ip any any
Agregamos la lista a la interfaz:
int fa0/1
ip access-group 115 out

Topicos Avanzados de Redes

Page 9

Figure 8: Prueba de las Listas de acceso

(a) Ping entre pcs de distintas vlans

(b) Ping a un sevidor fuera de a vlan

Figure 9: Pruebas de Lista de acceso

Configuracion PAT
En el router 2
int fa 0/1.1
ip nat inside
int fa 0/1.2
ip nat inside
int fa 0/1.3
ip nat inside
int fa 0/1.4
ip nat inside
int se0/0/0
ip nat outside
access-list 1 permit any
interface serial 0/0/0 overload

Topicos Avanzados de Redes

Page 10

Figure 10: Tabla de traducciones nat

Conclusiones
Esta practica se subneteo una red en 4 subredes de las cuales se usaron 3 para el control de
las distintas areas de la empresa. La administracin de las vlans se hizo a travsde un switch
Central y la vlan 1 de administracion. Se asignaron los puertos troncales en los switch y ademas
los puertos para cada vlan. Despus se agrego en el router el protocolo IEEE 802.1Q para el
encapsulamiento de los datos. Se configuraron las sub-interfaces de las vlans permitiendo
pasar informacin de distintas Vlan por el mismo medio fsico. Ademas del correcto subneto,
se hizo uso de distintos servicios en los servidores, tales como DHCP, DNS, EMAIL y TFTP
para un completo uso de toda la red. Se agrego tambin restricciones mediante el uso de
Listas de control de acceso para llevar un mejor control de la administracin dentro de la red,
asi como el uso de PAT para convertir las direcciones IP internas, privadas, en una direccin
pblica externa para salir a internet.

Experiencia
Fue una practica muy completa que abarco que muchos aspectos que se aplican en la realidad,
el crear sub-redes en una empresa y que los servidores proporcionen servicios de email y paginas web a su usuarios. Este mismo servidor se uso para crear respaldos de configuracin de
los routers, y ademas con un compaero, dividimos la red en dos y mediante un cable cruzado
conectamos fsicamente dos maquinas para simular una configuracin va telnet. Aprend el
uso de las Listas de control de acceso, as que como la traduccin de direcciones privadas a
publicas mediante el uso de NAT y PAT.
Me voy muy satisfecho con lo aprendido durante todo el curso y se que en futuro me servir
todo lo aplicado en este trabajo final.

Topicos Avanzados de Redes

Page 11