Está en la página 1de 3

TAREA

1.- DETERMINAR SI UN NUMERO INGRESADO ES PAR


Anlisis

Enunciado del problema: determinar si un nmero es par


Solucin del problema: un nmero es par cuando su residuo es 0

Diseo
1 Descripcin sencilla del algoritmo
Se debe de dividir el nmero entre 2 y si su residuo es 0 el nmero ser
par
2 Consideraciones iniciales
a
b

Ingresar un nmero
Utilizar la condicin si para determinar que si el residuo es 0 ser
par

3 Algoritmo
1
2
3
4
5
6
7
8
9

Inicio
N
Leer N
Si (N mod 2) =0 entonces
Imprimir ES PAR
Sino
Imprimir ES IMPAR
Fin Si
Fin

Comentarios:

En la lnea 3 leer el numero ingresado


En la lnea 4 se emplea el mod para que nos del residuo y si es igual a 0
En la lnea 5 se imprimir es par

2.- DETERMINAR SI UN NMERO INGRESADO ES PRIMO


Anlisis

Enunciado del problema: determinar si el nmero es primo


Solucin del problema: Para determinar si el nmero es primo el
numero debe de ser solamente divisible por el 1 y su mismo nmero y
con la ayuda de un contador se lograra llegar al resultado
Diseo
1 Descripcin sencilla del algoritmo
Con el ciclo mientras se har que el nmero ingresado pueda dividirse
con los dems nmeros anteriores a l y as saber si ese es nmero tiene
2 divisores o ms para as con el contador poder determinar si es un
nmero primo o no
2 Consideraciones iniciales
a Ingresar un numero positivo
b Emplearemos la condicin Mientras(While) que nos ayudara a
hacer el conteo y la divisin con los nmeros divisibles del numero
ingresado
c Con el contador se calculara q solo tenga dos divisores el numero
ingresado para que sea un numero primo sino cumple no sera un
numero primo
3 Algoritmo
1 Inicio
2 N,I1,C0
3 Leer N,I,C
4 Mientras(I<=N)haga
5 Si N Mod I=0 entonces
6 CC+1
7 Fin si
8 II+1
9 Fin mientras
10 Si C=2 entonces
11 Imprimir ES PRIMO
12 Sino
13 Imprimir NO ES PRIMO
14 Fin si
15 Fin
Comentarios:
En la lnea 4 se utiliza la condicin Mientras que la variable sea menor
que el numero ingresado entonces en la lnea 5 con la condicin si se
har q el numero ingresado se divida con la variable que aumentara
progresivamente como se le indica en la lnea 8
En la lnea 6 si cumpla la condicin de la lnea 5 el contador aumentara
en 1
En la lnea 10 si el contador tiene 2 divisores entonces ser un numero
primo

3.- OBTENER LA EQUIVALENCIA EN DLARES Y EUROS DE UNA CANTIDAD EN


SOLES (DLAR= S/ 2.67, EURO=S/ 3.49)
Anlisis

Enunciado del problema: obtener la equivalencia de soles en dlares


y euros
Solucin del problema: la cantidad de soles se divide por el tipo de
cambio de dlares y euros para cada uno de su equivalencia

Diseo
1 Descripcin sencilla del algoritmo
Para hallar la equivalencia se debe de dividir la cantidad ingresada de
soles entre el tipo de cambio de dlares y euros para determinar cada
una de su equivalencia en soles
2 Consideraciones iniciales
a Ingresar Cantidad de soles
b Para hallar la equivalencia de dlares Dividiremos la cantidad de
soles entre el tipo de cambio de dlares
c Para hallar la equivalencia de euros Dividiremos la cantidad de
soles entre el tipo de cambio de euros
3 Algoritmo

1
2
3
4
5
6
7

Inicio
S,D,E
Leer soles
Dsoles/2.67
Esoles/3.49
imprimir D,E
fin

Comentarios:

en la lnea
en la lnea
dlares
en la lnea
euros
en la lnea

3 se ingresa los soles


4 se divide la cantidad en soles entre el tipo de cambio de los
5 se divide la cantidad en soles entre el tipo de cambio de
6 se imprime la equivalencia de soles en dlares y euros