Está en la página 1de 14

Funciones de Fecha, Texto y

Decisin
El objetivo de esta sesin de aprendizaje es el de
conocer y aplicar las funciones Decisin de Excel, las
formas de utilizar las funciones de forma correcta
para obtener los resultados esperados.

Competencias a desarrollar:
Aprender correctamente a aplicar la Funciones de Fecha y Hora
Aprende correctamente a aplicar la funcin Y.
Aprende correctamente a aplicar la funcin O.
Aprende correctamente a aplicar la funcin SI.
Aprende correctamente a aplicar la funcin SI anidada.

Aplicar la funcin lgica SI anidada para valores que poseen ms de dos argumentos.
Aplicar la funcin ESERROR para comprobar si una expresin o valor genera un error.
Aplicar la funcin SI.ERROR para evaluar expresiones o valores y devolver un valor.
Aplicar las funciones de texto para operar celdas que contienen textos.

Funcin SIFECHA
El Sifecha es una funcin que nos permite obtener el nmero de das, meses y aos que han
transcurrido entre dos fechas determinadas. Es una funcin que no es de Excel con lo cual no la
vamos a encontrar en el asistente de funciones pero que si que podremos utilizar escribindola
directamente en la celda.
Sintaxis:
=SIFECHA(F_INICIAL;F_FINAL;Parmetro)
Donde:
El parmetro a utilizar en la ltima parte de la formula puede ser:

D si queremos obtener los das que han transcurrido

M si queremos obtener los meses

Y si queremos obtener los aos

YM si queremos obtener los meses sin tener en cuanta los aos

MD si queremos obtener los das sin tener en cuanta los meses

Ejemplo 6: Calcular la edad expresada en aos, meses y das.

D4: =SIFECHA(C4;HOY();"y")
E4: =SIFECHA(C4;HOY();"m")
F4: =SIFECHA(C4;HOY();"d")

Sesin 03

MOSM - Ing. Edilberto Chvez Fernndez

FUNCIONES DE DECISIN
Funcin Y
Devuelve VERDADERO si todos los argumentos son VERDADEROS; devuelve FALSO si algn
argumento es FALSO.
Sintaxis

:
=Y(valor_lgico1,valor_lgico2,...)

valor_lgico

Son entre 1 y 30 condiciones que se desea comprobar y que pueden ser


VERDADERO o FALSO.

Ejemplo 1:
Calcular el importe de aumento y nuevo sueldo para los empleados de la Empresa Minera
ANDOSMAR

Aumento: =SI(Y(D5>=600,D5<=900),10%,0)*D5
Nuevo sueldo: =D5+E5

FUNCIN O
Devuelve VERDADERO si alguno de los argumentos es VERDADERO; devuelve FALSO si todos los
argumentos son FALSOS.
Sintaxis

:
=Y(valor_lgico1,valor_lgico2,...)

Sesin 03

MOSM - Ing. Edilberto Chvez Fernndez

valor_lgico

Son entre 1 y 30 condiciones que se desea comprobar y que pueden ser


VERDADERO o FALSO.

Ejemplo 2:
El jefe de personal desea calcular el aumento para los empleados de la empresa, de la siguiente
manera, si el rea es VENTAS o COMPRAS el porcentaje aplicado es de 10%, de lo contrario el
porcentaje ser de 8%, aplicndolo sobre el sueldo.

Aumento: =SI(O(D5="VENTAS",D5="COMPRAS"),10%,8%)*E5
Nuevo Sueldo: =E5+F5

Funcin SI
Comprueba si se cumple una condicin y devuelve un valor si se evala como VERDADERO y otro
valor si se evala como FALSO.
Sintaxis

:
=SI(prueba_lgica, valor_si_verdadero,valor_si_falso)

Prueba_lgica

Expresin Lgica que se desea evaluar como VERDADERO o FALSO.

Valor_si_verdadero Es el valor que se devolver si prueba_lgica es VERDADERO.


Valor_si_falso

Es el valor que se devolver si prueba_lgica es FALSO.

Ejemplo 3:
Evaluar cada una de las celdas del rango A2:A9, para conocer si su contenido es igual a 0 (prueba
lgica). Si cumple dicha prueba escribir la palabra Verdadero, de lo contrario escribir Falso.

Sesin 03

MOSM - Ing. Edilberto Chvez Fernndez

Ejemplo 4:
Determinar el estado de cada alumno, de la siguiente manera: Si el promedio es mayor que 10, el
estado es Aprobado, de lo contrario Desaprobado.

Estado: =SI(C3>10,"Aprobado","Desaprobado")

Funcin SI Anidada
Cuando se evala una condicin y se tiene ms de dos alternativas de solucin, entonces es
necesario utilizar una funcin SI dentro de otra, a esto se le llama anidamiento.
Ejemplo 5:
Si el promedio es mayor que 18, el estado es EXCELENTE, si el promedio es mayor que 15 y menor
o igual que 18; el estado es BUENO, si el promedio es mayor que 10 y menor o igual que 15; el
estado es REGULAR, caso contrario MALO.

Sesin 03

MOSM - Ing. Edilberto Chvez Fernndez

NIVEL =SI(C3>18,"EXCELENTE",SI(C3>15,"BUENO",SI(C3>10,"REGULAR","MALO")))
Observacin: Tambin se puede calcular de las siguientes maneras:

SI(C3<=10,"MALO",SI(C3<=15,"REGULAR",SI(C3<=18,"BUENO","EXCELENTE")))

SI(Y(C3>=0,C3<=10),"MALO",SI(Y(C3>10,C3<=15),"REGULAR",SI(Y(C3>15,C3<=18),"BUENO"
,"EXCELENTE")))

Ejemplo 6:
Determinar el Aumento y Nuevo Sueldo de cada Empleado, teniendo en cuenta que la tasa de
Aumento (% Aumento) se asigna en funcin de la Zona en donde trabaja.
La frmula para calcular el Aumento es igual a Sueldo actual * % Aumento
Nuevo sueldo es igual Sueldo Actual ms Aumento.

Sesin 03

MOSM - Ing. Edilberto Chvez Fernndez

Aumento: =SI(B7=$A$2,$B$2,SI(B7=$A$3,$B$3,$B$4))*C7
Nuevo sueldo: =C7+D7

Sesin 03

MOSM - Ing. Edilberto Chvez Fernndez

ANIDAMIENTO Y FUNCIONES DE TEXTO


I. FUNCIN SI ANIDADA
La funcin SI evala argumentos o expresiones lgicas que tienen dos estados,
valor_si_verdadero o valor_si_falso. Ahora qu pasara si la expresin (o condicin) lgica tiene
ms de dos estados, entonces se tendra que anidar varias funciones SI, cuidando el sentido
lgico de la expresin resultante.
Ejemplo: Supongamos que se desea calcular la comisin por ventas, teniendo en cuenta que si
las ventas son mayores a 2000, el vendedor debe percibir un 20% de sus ventas, y si las ventas
son menores a 1000 no tiene comisin, y 10% para ventas comprendidas entre 1000 y 2000.

El siguiente esquema nos ayudar a comprender el procedimiento lgico a seguir para obtener
la comisin.

V: Verdadero
F: Falso

VENTAS>20
00

20%*C
3

V
VENTAS<10
00

10%*C
3

Sesin 03

MOSM - Ing. Edilberto Chvez Fernndez

PROCEDIMIENTO
Seleccionar la celda D3 e insertar la funcin
lgica SI y luego seguir la secuencia de los
nmeros en crculo mostrado en la figura
adjunta.
1. En Prueba_lgica ingresar: C3>2000

2. En Valor_si_verdadero ingresar: 20%*C3


3. Se debe hacer clic dentro del cuadro
Valor_si_falso para anidar la siguiente
funcin SI.

4. Se debe hacer clic en la lista desplegable

del cuadro de nombres para activar otra


funcin SI.

5. En la siguiente ventana de la funcin SI


completar la informacin requerida y dar
clic en Aceptar

El
resultado
de
todo
el
procedimiento
anterior
=SI(C3>2000;20%*C3;SI(C3<1000;0;10%C3))
Para obtener el Total Pago se debe sumar Ventas + Comisin.

da

la

frmula:

II. FUNCIN ESERROR


Esta funcin comprueba si un valor es un error o no. Los valores como respuesta son:
VERDADERO o FALSO.
Sintaxis:

=ESERROR(Valor)

Ejemplo:

Sesin 03

MOSM - Ing. Edilberto Chvez Fernndez

Se desea obtener el costo unitario de los Productos A y B. El procedimiento es obtener el Costo


total (materiales + mano de obra + costos de fabricacin) y luego dividir entre las unidades
producidas.

Procedimiento:
1. Obtener el costo total para cada
producto:
En la celda B5: =SUMA(B2:B4)
Copiar la celda B5 a la celda C5
2. Obtener el costo unitario para
cada producto:
En la celda B7: =B5/B6
Copiar la celda B7 a la celda C7
3. Evaluar el rango B7:C7 para
identificar las celdas que tienen
error.
En la celda B9: =ESERROR(B7)
Copiar la celda B9 a la celda C9.

Los errores que maneja Excel son 7:


#DIV/0!

Indica que la frmula de la celda est intentando dividir entre una celda vaca o
cero.

#N/A

Este error indica que la frmula no puede dar un resultado correcto.

#NOMBRE?

Este error aparecer cuando Excel no reconoce un nombre en una frmula.

#NULO

Este error se da en casos muy concretos: cuando utiliza el operador de


interseccin en dos rangos que no tienen celdas en comn.

#NUM

Este error nos indica que hay un problema con un nmero en la frmula.

#REF

Este error indica que la frmula contiene una referencia no vlida.

#VALOR

Este error indica que hemos utilizado un argumento incorrecto.

III. FUNCIN SI.ERROR

Sesin 03

MOSM - Ing. Edilberto Chvez Fernndez

Si una expresin o frmula genera un error, est frmula regresa el valor resultado de error
(como una cadena nula o un mensaje de error); de otra forma esto regresa el resultado
expresin.
Sintaxis:
=SI.ERROR(valor; valor_si_error)
donde:
-

Valor

: la expresin que puede generar error.

Valor_si_error : el valor que se muestra si valor retorna un error.

Ejemplos:
=SI.ERROR(5/0;no existe)

Devuelve la cadena no existe

=SI.ERROR(10/5;no existe)

Devuelve el valor 2

Caso aplicado:
En el siguiente ejemplo, se debe obtener el costo unitario de cada producto. Por lo tanto se
debe generar la expresin B5/B6 (Costo total unidades producidas). Sin embargo se debe
tener en cuenta para divisiones entre cero dejar la celda vaca.

Como no hay error,


se ejecuta la
expresin B5/B6

La expresin C5/C6 da error


(#DIV/0!), por lo tanto no se
ejecuta la expresin y la celda
queda vaca.

Procedimiento

Sesin 03

MOSM - Ing. Edilberto Chvez Fernndez

1. Seleccionar la celda B7
2. En la ficha Frmulas, abrir el botn de funciones lgicas y luego
hacer clic en la funcin SI.ERROR
3. Se abre la ventana de la funcin SI.ERROR

Y se debe ingresar lo siguiente:


Valor

: B5/B6

Valor_si_error :

(expresin que permite obtener el costo unitario)


(colocar dos comillas juntas para mostrar celda vaca, si la

expresin ingresada en el cuadro valor tiene error).


La frmula que se obtiene es: =SI.ERROR(B5/B6;)

4. Copiar la celda B7 a la celda C7.

IV.FUNCIONES DE TEXTO
Excel posee varias funciones que permite manipular campos de texto. En la siguiente tabla: se
resume algunas de ellas as como su sintaxis y ejemplos.

Funcin

Descripcin

=DERECHA(texto;Nm_caracteres)

Devuelve

Ejemplo
un

nmero =DERECHA("Csar

Resultado
Vallejo

Texto: es el texto del que se va a determinado de caracteres Vallejo";7)


extraer partes de texto.

empezando por el lado

Nm_caracteres: es el nmero de derecho del texto.


caracteres que se desea extraer,
empezando por el lado derecho.

Sesin 03

MOSM - Ing. Edilberto Chvez Fernndez

=IZQUIERDA(texto;Nm_caracteres)

Devuelve

un

nmero =IZQUIERDA("Csar

Csar

Texto: es el texto del que se va a determinado de caracteres Vallejo";5)


empezando por el lado

extraer partes de texto.

Nm_caracteres: es el nmero de izquierdo del texto.


caracteres que se desea extraer,
empezando por el lado izquierdo.
=EXTRAE(texto;Posicin_incial;Nm_cara

Devuelve

un

nmero =EXTRAE("Mundo

cteres)

determinado de caracteres feliz";7;6)

feliz

Texto: es el texto del que se va a empezando por cualquier


posicin en el texto.

extraer partes de texto.


Posicin_inicial: es la posicin del
carcter

por

la

que

quiere

empezar a extraer los caracteres.


Nm_caracteres: es el nmero de
caracteres que se desea extraer.
=HALLAR(Texto_buscado;Dentro_del_tex

Esta funcin devuelve la =HALLAR(t;Gastos

to;Nm_inicial)

posicin de la primera ;1)

Texto_buscado: es el texto que se aparicin

del

carcter

(despus de la posicin del

quiere buscar.

Dentro_del_texto: es el texto en carcter del nmero inicial)


del texto buscado dentro

la que se quiere mirar.

Nm_inicial: es la posicin del del texto.


carcter

por

el

que

quiere

empezar a amirar. (por defecto,


es el 1).
=LARGO(Texto)

Devuelve el nmero de =LARGO(La

11

caracteres de una cadena Libertad)


de texto.
=MAYUSC(Texto)

Convierte una cadena de =MAYUSC(trujillo)

TRUJILLO

texto en letras maysculas.


=MINUSC(Texto)

Sesin 03

Convierte una cadena de =MINUSC(TRUJILLO

trujillo

MOSM - Ing. Edilberto Chvez Fernndez

texto en letras minsculas.


=NOMPROPIO(Texto)

Convierte una cadena de =NOMPROPIO(la

La

texto en maysculas o libertad)

Libertad

minsculas,

segn

corresponda; la primera
letra de cada palabra en
maysculas y las dems
letras en minsculas.
=CONCATENAR(Texto 1; Texto2; )

Sesin 03

Une varios elementos de =CONCATENAR(Javi

JavierMe

texto en uno solo.

dina

er;Medina)

MOSM - Ing. Edilberto Chvez Fernndez