Está en la página 1de 6

Ejercicios de programacin pseudocdigo

Asignatura: Programacin
Algoritmo que pida la estatura (en metros) y sexo (V/M) de un
nmero indeterminado de personas (mientras el operador quiera).
Posteriormente escribir la estatura media de los varones y la
estatura media de las mujeres.
Var

Est, suma1,suma2: real


Ct1, Ct2: Entero
S, N: Carcter

Inicio
Suma1 0
Suma2 0
Ct1 0
Ct2 0
Repetir
Inicio
Escribir (Ingrese estatura:)
Leer (Est)
Escribir (Ingrese Sexo V/M:)
Leer (S)
En caso de S hacer
Caso V: Suma1 Suma1 +Est
: Ct1 Ct1 +1
Caso M: Suma2 Suma2 +Est
: Ct2 Ct2 +1
Otros casos: Escribir ( Smbolo No valido)
Fin de caso
Escribir (Para finalizar ingreso de datos presione F)
Leer (N)
Fin
Hasta (N=F)
Prom1 Suma1/Ct1
Prom2 Suma2/Ct2
Escribir (La estatura promedio de los varones es:, Prom1)
Escribir (La estatura promedio de las mujeres es:, Prom2)
Fin
Escribir
Estatura(Es Sexo
t)
(S)

Repetir hasta N='F'


En caso hacer S
Caso 'V'

1,5 M
1,6 L
1,9 V

Caso 'M' Otro caso


1,5+0=1
,5
1+0=1
Simbolo no
valido

1,9+0=1,9
1+0=1

Escribir
Finaliza
r
Prom 1
3,55/2=1,
.
77

..

Prom 2
1,5/1=1,5

1,63 V

1,63+1,9=3,
55
1+1=2

N=F

Algoritmo que pida un nmero entero por teclado y diga si es primo o


no
Var

N: Entero

Inicio
Ct 0
Escribir (Ingrese un nmero)
Leer (N)
Si (N=1) entonces
Escribir ( El numero ,N,no es primo)
Caso contrario
Para I=1 hasta N en saltos de 1 hacer
Inicio
Si (nmodI) = 0 entonces
Ct Ct +1
Fin si
Fin para
Si Ct 2 entonces
Escribir ( El numero ,N,es primo)
Caso contrario
Escribir ( El numero ,N,no es primo)
Fin si
Fin
si n=1
entonces

caso
para I desde
Escribir N N=1
1hasta n
si (Nmod
No es primo i)=0
Ct
1+0
6 .
6/1
=1
1+1
6/2
=2
2+1
6/3
=3
3+1
6/6
=4
1+0
3
3/1
=1
1+1
3/3
=2
1+0
23 ..
23/1
=1
1+1
23/23
=2

contrario
si Ct=2

Ct <>2

es primo

no es primo

el numero 6
no es primo

el nmero
3 es
primo
el nmero
23 es
primo

Hacer un algoritmo que calcule el n-esimo trmino de la serie de


Fibonacci definida por:
A1=1
A2=1
A3= A1+A2
A4= A2+A3
A5= A3+A4
. An= An-2+An-1 (Para n > 3)
Algoritmo Fibonacci
Var N: entero
Inicio
X1 0
X2 1
Ac 0
Escribir (Ingrese un nmero)
Leer (N)
Si N>3 Entonces
Repetir
Inicio para
X3 X1+ X2
X1 X2
X2 X3
Ac Ac +1
Hasta (Ac = N)
Escribir (El n-simo termino es: X2)
Caso contrario
Escribir (Ingrese un nmero mayor que 3)
Fin
n

4
3

X3=X1+X2
1=0+1
2=1+1
3=2+1
5=2+3

Ac=Ac+1
1=0+1
2=1+1
3=2+3
4=3+1

Ac=n
1=4
2=4
3=4
4=4

..
1=0+1
2=1+1
3=2+1
5=2+3
8=3+5

1=0+1
2=1+1
3=2+3
4=3+1
5=4+1

..
1=5
2=5
3=5
4=5
5=5

"El n-esimo nmero es"


3
Ingrese nmero mayor
que 3
5

En una empresa cada empleado debe teclear un cdigo identificador de 3


cifras en la entrada. Escribir un algoritmo que muestre por pantalla la categora del
empleado teniendo en cuenta que:
a. Si el cdigo es divisible por 2, por 3 y por 5, la categora del empleado
es Director general
b. Si el cdigo es divisible por 3 y por 5 pero no por 2, la categora del
empleado es Directivo
c. Si el cdigo es divisible por 2, pero no por 3 ni por 5, la categora del
empleado es Staff
d. Si el cdigo no es divisible por 2, ni por 3 ni por 5, la categora del
empleado es Seguridad

Algoritmo de categora
Var N: entero
Inicio
Escribir (introducir cdigo)
Leer (N)
Si ((Nmod3)=0) entonces
Si ((Nmod5)=0 entonces
Si ((Nmod2)=0) entonces
Escribir (La categora del empleado es:
director general)
Caso contrario
Escribir (La categora del empleado es:
Directivo)
Fin si
Fin si
Caso contrario
Si ((Nmod2)=0) entonces
Si ((Nmod3)<>0) entonces
Si ((Nmod5)<>0 entonces
Escribir (La categora del empleado es:
Staff)
Caso contrario
Si ((Nmod2)<>0) entonces
Si ((Nmod3)<>0) entonces
Si ((Nmod5)<>0 entonces
Escribir (La categora del
empleado es: seguridad)
Fin si
Fin si
Fin
cdigo
690
532

((Nmod3)=0
)
((690mod3)=
0)
((532mod3)=
0)

((Nmod5) ((Nmod2)=0
=0)
)
((960mod5) ((960mod2)=
=0)
0)
((532mod5) ((532mod2)=
=0)
0)

Categora
Director
General
Staff

615
161

((615mod3)=
0)
((161mod3)=
0)

((615mod5) ((615mod2)=
=0)
0)
((161mod5) ((161mod2)=
=0)
0)

Directivo

seguridad

También podría gustarte