Está en la página 1de 9

LUIS CARLOS QUIONES DIAZ

JUAN NICOLAS AMEZQUITA


lquinonesdi@uniminuto.edu.co

juan-no-00@hotmail.com
CONFIGURACION ENRUTAMIENTO ESTATICO
RESUMEN

En el siguiente trabajo estudiaremos la


configuracin e implementaremos el protocolo
DHCP RELAY en diferentes redes, usaremos el
enrutamiento esttico para la comunicacin de
toda las redes que se encuentran en el escenario
1, de igual manera se desarrollara la compresin
bsica de este mtodo de routing.
INTRODUCIN
El objetivo que se realiza en este laboratorio es
implementar el escenario 1. Se lograra la
asignacin de direcciones IP desde el router R1
bajo el concepto DHCP Agente Relay a todos los
host de las redes. Se configurara cada dispositivo
para que la conectividad entre los nodos, routers
se comuniquen.
El servicio dhcp se implementa en redes extensas
donde haiga un nmero de host tan grande el cual
complique la asignacin esttica a cada nodo, de
igual forma que si llega un nuevo equipo o se sale
de la red se tendra que estar mirando que ip est
desocupada para asignar.

DISEO DE LA RED

Figura 1: Diseo de la red

En la figura 1 observamos el diseo de la red, el


cual costa de una red cuya direccin es 192.168.1.0
/ 24 y de 3 Vlan las cuales constan de las
direcciones 192.168.30.128 /25, 192.168.30.64/26
y la 192.168.30.32 / 224, llamadas vlan 2, vlan 3,
vlan 4 respectivamente.
Se consta de 3 router, el R1, R2 y R3. Estos se
encuentran configurado de manera que el R1
preste los servicios DHCP a las diferentes VLAN y
LAN que se encuentran en la red. Los R2, R3 estn
configurado de manera que cumplan la funcin de
agentes RELAY.
En este diseo se implementa el enrutamiento
esttico para la comunicacin entre los diferentes
nodos, sin importar en que red o vlan se
encuentren.
Configuracin dispositivos
Configuracin para el Switch
Switch>enable
Switch# configure terminal
-Creacin de las Vlans

Switch (config) #vlan 2


Switch (config-vlan) #vlan 3
Switch (config-vlan) #vlan 4
Switch(config-vlan)#exit
Switch(config)#interface fastEthernet 0/2
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 2
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/3
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 3
Switch(config-if)#exit
Switch(config)#interface fastEthernet 0/4
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan 4
Switch(config-if)#exit
Switch(config)#interface gigabitEthernet 0/1
Switch(config-if)#switchport mode trunk
Switch(config-if) #exit
Configuracin para el Router 3 (R3)
R3>enable
R3#configure terminal
R3(config)#interface gigabitEthernet 0/1
R3(config-if)#no shutdown
R3(config-if)#exit
R3(config)#interface gigabitEthernet 0/1.2
R3(config-subif)#encapsulation dot1Q 2
R3(config-subif)#ip
address
192.168.30.129
255.255.255.128
R3(config-subif)#exit
R3(config)#interface gigabitEthernet 0/1.3
R3(config-subif)#encapsulation dot1Q 3
R3(config-subif)#ip
address
192.168.30.64
255.255.255.192
R3(config-subif)#exit
R3(config)#interface gigabitEthernet 0/1.4
R3(config-subif)#encapsulation dot1Q 4
R3(config-subif)#ip
address
192.168.30.33
255.255.255.224
R3(config-subif)#exit
-Asignacin de la ip y encendido del puerto serial
R3(config)#interface serial 0/0/1
R3(config-if)#ip address 10.0.0.2 255.255.255.252
R3(config-if)#no shutdown

R3(config-if)#exit
R3(config)#ip route 20.0.0.0 255.255.255.252
10.0.0.1
R3(config)#ip route 192.168.1.0 255.255.255.0
10.0.0.1
R3(config)#interface gigabitEthernet 0/1.2
R3(config-subif)#ip helper-address 10.0.0.1
R3(config-subif)#exit
R3(config)#interface gigabitEthernet 0/1.3
R3(config-subif)#ip helper-address 10.0.0.1
R3(config-subif)#exit
R3(config)#interface gigabitEthernet 0/1.4
R3(config-subif)#ip helper-address 10.0.0.1
R3(config-subif)#exit
R3(config)#line console 0
R3(config-line)#password LUISR3
R3(config-line)#exit
R3(config)#enable password LUISR3
R3(config)#line vty 0 5
R3(config-line)#password LUISR3
R3(config-line)#exit
Configuracin de Router 1 (R1)
R1>enable
R1#configure terminal
R1(config)#interface serial 0/0/0
R1(config-if)#ip address 20.0.0.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface serial 0/0/1
R1(config-if)#ip address 10.0.0.1 255.255.255.252
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#ip
route
192.168.30.128
255.255.255.128 10.0.0.2
R1(config)#ip route 192.168.30.64 255.255.255.192
10.0.0.2
R1(config)#ip route 192.168.30.32 255.255.255.224
10.0.0.2
R1(config)#ip route 192.168.1.0 255.255.255.0
20.0.0.2
R1(config)#ip
dhcp
excluded-address
192.168.30.129 192.168.30.140
R1(config)#ip dhcp pool VLAN2

R1(dhcp-config)#network
192.168.30.128
255.255.255.128
R1(dhcp-config)#default-router 192.168.30.129
R1(dhcp-config)#exit
R1(config)#ip dhcp excluded-address 192.168.30.65
192.168.30.70
R1(config)#ip dhcp pool VLAN3
R1(dhcp-config)#network
192.168.30.64
255.255.255.192
R1(dhcp-config)#default-router 192.168.30.65
R1(dhcp-config)#exit
R1(config)#ip dhcp excluded-address 192.168.30.33
192.168.30.40
R1(config)#ip dhcp pool VLAN4
R1(dhcp-config)#network
192.168.30.32
255.255.255.224
R1(dhcp-config)#default-router 192.168.30.33
R1(dhcp-config)#exit
R1(config)#ip dhcp excluded-address 192.168.1.1
192.168.1.10
R1(config)#ip dhcp pool LAN1
R1(dhcp-config)#network
192.168.1.0
255.255.255.0
R1(dhcp-config)#default-router 192.168.1.1
R1(dhcp-config)#exit
R1(config)#line console 0
R1(config-line)#password LUISR1
R1(config-line)#exit
R1(config)#enable password LUISR1
R1(config)#line vty 0 5
R1(config-line)#password LUISR1
R1(config-line)#EXIT

R2(config)#ip route 192.168.30.64 255.255.255.192


20.0.0.1
R2(config)#ip route 192.168.30.32 255.255.255.224
20.0.0.1
R2(config)#interface gigabitEthernet 0/1
R2(config-if)#ip helper-address 20.0.0.1
R2(config-if)#exit
R2(config)#line console 0
R2(config-line)#password LUISR2
R2(config-line)#exit
R2(config)#enable password LUISR2
R2(config)#line vty 0 5
R2(config-line)#password LUISR2
R2(config-line)#EXIT
Tablas de direcciones para dhcp
LAN 1
Direccin 192.168.1.0 /24
Rango excluido
192.168.1.1 -192.168.30.10
Rango Asigancion por DHCP
192.168.1.11-192.168.1.254

VLAN 2
Direccin 192.168.30.128 /25
Rango excluido
192.168.30.129 -192.168.30.140
Rango Asigancion por DHCP
192.168.30.141-192.168.30.254

VLAN 3
Configuracin Router 2 (R2)
R2(config)#interface gigabitEthernet 0/1
R2(config-if)#ip address 192.168.1.1 255.255.255.0
R2(config-if)#no shutdown
R2(config)#interface serial 0/0/0
R2(config-if)#ip address 20.0.0.2 255.255.255.252
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#ip route 10.0.0.0 255.255.255.252
20.0.0.1
R2(config)#ip
route
192.168.30.128
255.255.255.128 20.0.0.1

Direccin 192.168.30.64 /26


Rango excluido
192.168.65 -192.168.30.70
Rango Asigancion por DHCP
192.168.30.71-192.168.30.126

VLAN 4
Direccin 192.168.30.32 /27
Rango excluido
192.168.30.33 -192.168.30.40
Rango Asigancion por DHCP
192.168.30.41-192.168.30.62

En esta tabla nos muestra las interface serial 0/0/1


se le asigno la direccin 10.0.0.2 y est activada.
Observamos de igual manera que la interface
gigabitEthernet 0/1 est dividida para varis vlan.

Pruebas de configuraciones y resultado de los


comandos
Show ip interface Brief en R1

Para la Vlan 2 la direccin asignada al router o de


direccin de Gateway es la 192.168.30.129 y est
activada, para la vlan 3 la direccin asignada es
192.168.30.65 y se encuentra activada y por ultimo
tenemos la vlan 4, a esta se le asigno la direccin
192.168.30.33 y el estado de la interface esta activada.

Tenemos as:

Show ip interface Brief Router 2 (R2)

Figura 2: ejecucin del comando show ip interface brief

En esta tabla nos muestra las interface seriales


0/0/0 se le asigno la direccin ip 20.0.0.1 y que est
en estado up es decir activada, igualmente la
interface serial 0/0/1 se le asigno la direccin
10.0.0.1 y est activada. Observamos que las
dems interface como las gigabitEthernet no estn
activada y no se le han asignado direccin.
Show ip interface para R3

Figura 3: ejecucin del comando show ip interface brief

Figura 4: ejecucin del comando show ip interface brief

En la grfica 6 observamos que tenemos la interface


Giga Ethernet 0/1 esta activada y tiene asignada la
direccin 192.168.1.1 que es la Gateway de la red LAN
1, adems vemos que la interface s0/0/1 del router 2
est conectada a una red 20.0.0.0 con la direccin
20.0.0.2.

Show running-config Router 2

Figura 5: ejecucin del comando show running-config

Para el router 2 podemos ver que la interface giga


Ethernet 0/1 tiene la direccin IP asignada con su
respectiva mascara de red, en la lnea 2 resaltada vemos
que el router est operando como un agente relay esto
se conoce debido a que tiene la configuracin IP
hellper-address y va hacia el R1 que tiene en una de sus
interfaces serial la direccin 20.0.0.1 se dirige hacia l
ya que el R1 es el que presta el servicio de DHCP.
En la parte inferior en el cuadro encerrado observamos
las direcciones de red agregadas a la tabla de
direcciones de red, esto se hace con el fin de que el
router reconozca hacia donde debe enviar un paquete
que sea enviado hacia esa red un ejemplo que podemos
ver es la direccin 192.168.30.32 255.255.255.224 la
cual es la red de la vlan 4 con su mscara, y la direccin
que vemos al lado la 20.0.0.1 es por donde se tiene que
ir o cual es el siguiente salto que debe tomar el paquete
para poder llegar a su destino si va para la vlan 4.

Show running-config Router 1

Figura 6: ejecucin del comando show running-config

En esta imagen observamos en la zona 1 vemos las


direcciones excluidas, es decir las que no podr asignar
el servicio dhcp por ejemplo para la vlan 2 se excluyeron
la direcciones desde la 192.168.129 hasta la
192.168.30.140, de igual manera se muestra el rango
excluido para cada VLAN Y LAN.
En la parte inferior encerrados podemos conocer el
nombre de la red que se le est brindando el servicio
dhcp, por comodidad se le asigna el mismo nombre que
tiene la red, observamos que muestra la direccin de la
red con su respetiva mascara en la lnea 2 y en la 3 lnea
vemos la direccin de Gateway de la red.
Por ejemplo

En este ejemplo vemos que el nombre asignado es


LAN1, la red es 192.68.1.0 con una mscara
255.255.255.0 y tiene una direccin Gateway de
192.168.1.1

Show running-config Router 3

Figura 7: ejecucin del comando show running-config


Figura 8: ejecucin del comando show running-config

En el router 1 ejecutando el mismo comando anterior


podemos ver que la interfaces serial 0/0/0 tiene la
direccin 20.0.0.1 con mascara 255.255.255.252 y la
serial 0/0/1 10.0.0.1 con mascara 255.255.255.252.
Como no est conectado nada a las interfaces giga no
se muestra ninguna direccin IP.
En la parte inferior en el cuadro encerrado observamos
las direcciones de red agregadas a la tabla de
direcciones de red, esto se hace con el fin de que el
router reconozca hacia donde debe enviar un paquete
que sea enviado hacia esa red un ejemplo que podemos
ver es la direccin 192.168.30.32 255.255.255.224 la
cual es la red de la vlan 4 con su mscara, y la direccin
que vemos al lado la 10.0.0.2 es por donde se tiene que
ir o cual es el siguiente salto que debe tomar el paquete
para poder llegar a su destino si va para la vlan 4.

Para el R3 tenemos activado varias vlan y una interface,


de igual forma este router est configurado como
agente relay para poder pedir el servicio dhcp al R1.
Por ejemplo

En este ejemplo vemos que la interface giga 0/1 tiene la


vlan 2, que se usa el estndar 802.1q para comunicar las
vlan entre s,
que tiene asignada la direccin
192.168.30.129 con mascara 255.255.255.128, la ltima
lneas observamos el comando ip helper-address que
significa lo dicho anteriormente que este router acta
como agente relay y que va hacia la direccin 10.0.0.1
que es una de las direcciones asignadas a la interface
serial del Router 1.
En la parte inferior en el cuadro encerrado observamos
las direcciones de red agregadas a la tabla de
direcciones de red, esto se hace con el fin de que el
router reconozca hacia donde debe enviar un paquete
que sea enviado hacia esa red un ejemplo que podemos
ver es la direccin 192.168.1.0 255.255.255.0 la cual es
la red de la LAN 1 con su mscara, y la direccin que
vemos al lado la 10.0.0.1 que es por donde se tiene que
ir o cual es el siguiente salto que debe tomar el paquete
para poder llegar a su destino si va para la LAN 1.

Show ip route R1

nos mostraba la mscara. Donde se encuentra los


chulitos son las direcciones asignadas con su prefijo.
En la parte inferior se muestra las redes que conoce el
router y cuanto salto tiene que hacer y porque va se
tiene que ir, recordemos que en el enrutamiento
esttico el nmero de saltos que se dan es de 1.
Show ip dhcp binding

Figura 9: ejecucin del comando show ip route

Figura 12: ejecucin del comando show ip dhcp binding

Figura 10: ejecucin del comando show ip route

Con este comando no muestra la direccin asignado a


cada pc que se encuentre en la red, no muestra el ID del
cliente es decir la MAC del pc, como en esta ocasin no
se mostr el rango de expiracin no observamos nada y
por ltima columna tenemos el type que es la forma
como se asignada, el servicio dhcp d las direcciones de
forma automtica.
Por ejemplo observamos la direccin 192.168.30.141
que se asign a una pc que tiene la Mac
0010.1102.8B62 y el tipo es de manera automtica.
Esta asignacin comienza desde la direccin
192.168.1.11 hasta la 192.168.1.254 porque dentro de
las excluidas esta desde la .1 hasta la .10 por esta razn
comienza la asignacin desde esta direccin.

Figura 11: ejecucin del comando show ip route

Con este comando nos muestra de forma breve las


direcciones asignadas a cada interface y los prefijos que
tiene red, que a diferencia de los comandos anteriores

Comando ping

direccin que se le hizo el tracert que en este caso es


192.168.1.11 que est en la red LAN 1.
Verificacin Telnet

Figura 13: ejecucin de un ping del pc0 al pc1

Se realiz un ping desde el Pc0 de la red LAN 1 hasta el


Pc1 de la VLAN 2, el cual no muestra conectividad
exitosamente, se enviaron 4 paquetes de solicitud y se
3, lo que significa que se perdi 1, esto pasa cuando se
est reconociendo la red, es normalmente cuando se
comunican por primera vez los nodos.
Comando tracert

Figura 15: comprobacin de telnet al R3 y al R1

En el primer recuadro se le realizo telnet al router 3 el


cual nos pidi la contrasea de acceso al router y
posteriormente intentamos entrar al modo de
privilegiado del router y digitando la contrasea
concedi el acceso, se realiz esta primera prueba con
el router que esta localmente conectado a esta red.
En el siguiente recaudo de color amarillo solicitamos
telnet al router 1 y de igual forma no dio acceso
despus de ingresar la contrasea. Lo cual demuestra el
acceso remoto desde una pc a los diferentes router.
Comprobacin del servicio de DHCP en los host

Figura 14: ejecucin de un tracert del pc2 al pc pc0

Este comando no muestra la ruta que toma el paquete


para llegar a su destino. Aqu vemos que pasa por 4
partes la primera como se observa en la imagen es la
Gateway que tiene la vlan 3, de ah sale y llega al router
1 que es la direccin 10.0.0.1, del router 1 pasa al router
2 a la interfaces 20.0.0.2 y de ah al pc que tiene la

En la anterior figura observamos que la direccin ip del


pc0 es asignada por el servicio dhcp, este le asigna la
primera direccin til y despus del rango de
direcciones excluidas. El pc0 pertenece a la red
192.168.1.0 con mascara de 255.255.255.0 y su
direccin asignada es la 192.168.1.11.

La configuracin que se establece est expuesta


a errores o equivocacin, se da ms cuando se
emplea en redes extensas.
Si se cambia algn punto o se modifica algo en
la parte de la red se debe intervenir tambin a
la configuracin de sus rutas, es decir estar en
constante cambio de la informacin de las
rutas.
Si la red va en crecimiento se torna muy
complicado su configuracin y de igual manera
su mantenimiento.
Para realizar algn cambio en la red se debe
tener un estricto conocimiento de la red, de no
ser as va ser algo muy complicado agregar o
realizar algn cambio en la red.
Conclusiones
La conectividad con el servicio DHCP funciona de
acuerdo a la configuracin que se le asign a las VLANS
para el correcto uso de este servicio en los routers.

El pc 1 que pertenece a la Vlan 2, que tiene como


direccin de red 192.168.30.128 y las direcciones
excluidas son desde la .129 hasta la .140, y la asignada
al pc es la 192.168.30.141 es decir direccin que se
puede utilizar.
Enrutamiento esttico

Para realizar el estudio de cmo es la configuracin y


cmo funciona el protocolo dhcp se realizar una
simulacin en Packet-Tracer, lo cual nos ayudara a
comprender y estudiar los diferentes comando que se
necesitan y como estos, de igual manera se realizaron
unas pruebas de conectividad las cuales fueron exitosas.
Esta simulacin se encuentra adjunta a este trabajo.

Los beneficios que nos ofrece el enrutamiento esttico


son:
Seguridad en la red, esto se da gracias a que con
esta manera de enrutamiento las rutas que
toman los paquetes no se anuncian a travs de
la red.
Cuando se usan rutas estticas el flujo en la red
es menor que cuando usamos protocolos de
routing dinmico, ya que no se est evaluando
cada momento que ruta sera la mejor para el
envi de paquetes.
Otro beneficio que se tiene con este mtodo es
que tiene conocimiento de la ruta que debe
coger el paquete para llegar a su destino esto es
muy til cuando uno de los puntos colapso o se
daa.
Las razones por la cuales no se debe usar o no es muy
conveniente emplear esta forma de routing son:

BIBLIOGRAFIA:
https://sites.google.com/site/ccnacruzcalderonand
rea/3-1-introduccion-y-ventajas
https://cisco.com

También podría gustarte