Está en la página 1de 22

Pseudocodigo

1) Desarrolle un pseudocodigo y diagrama de flujo que permita determinar si un nmero dado es


par, impar o cero.
Inicio
Escribir x
Leer x
Si x = 0 Entonces
Imprimir x " es cero"
Sino
Si x mod 2 = 0 Entonces
Imprimir x " es Par"
Sino
Imprimir x " es Impar"
Fin Si
Fin Si
Fin
2) Desarrolle un pseudocodigo y diagrama de flujo que permita determinar de una serie de
nmeros cuntos son par, impar o cero.
Inicio
Escribir "ingresa el numero total de la serie"
leer n
Escribir "ingresa un nmero"
cer=0
par=0
imp=0
total = n
Mientras total > 0 Hacer
leer x
Si x=0 Entonces
cer=cer+1
Sino
Si x mod 2 = 0 Entonces
par=par+1
Sino
imp=imp+1
Fin Si
Fin Si
total=total-1
Fin Mientras
Imprimir par " numeros pares que hay en la serie de numeros"
imprimir imp " numeros impares que hay en la serie de numeros"
Imprimir cer " numeros ceros que hay en la serie de numeros"
Fin

3) Desarrolle un pseudocodigo y diagrama de flujo que lea un nmero, y si es negativo que lo


imprima.
Inicio
Escribir "ingresa un numero"
Leer x
Si x<0 Entonces
imprimir x " es negativo"
Sino
Imprimir " no es negativo"
Fin Si
Fin
4) Desarrolle un pseudocodigo y diagrama de flujo que lea una serie de nmeros, imprima el
nmero si es negativo y el positivo del mismo.
Inicio
Escribir "escriba el numero de la serie"
leer n
Escribir "ingrese un numero"
serie=n
Mientras serie>0 Hacer
leer x
Si x < 0 Entonces
Imprimir x " es negativo y su valor positivo es " x *(-1)
Sino
imprimir x " es positivo "
Fin Si
serie=serie-1
Fin Mientras
Fin
5) Desarrolle un pseudocodigo y diagrama de flujo que le permita leer el nombre, la edad, el sexo
y el estado civil de cualquier persona e imprima el nombre de la persona si es un hombre casado
y mayor de 40 aos o una mujer soltera menor de 50 aos.
Inicio
Escribir "nombre"
leer nombre
Escribir "sexo 1 masculino, 2 femenino"
leer sexo
Escribir "estado civil 1 casado, 2 soltero"
leer estado
Escribir "edad"
leer edad
si sexo = 1 Entonces
si estado = 1 entonces
si edad > 40 Entonces
Imprimir "nombre es" nombre

FinSi
FinSi
FinSi
si (sexo = 2) Entonces
si (estado = 2) Entonces
si (Edad < 50) Entonces
Imprimir "nombre es:" nombre
FinSi
FinSi
FinSi
FinProceso
6) Desarrolle un pseudocodigo y diagrama de flujo que le permita leer las notas de las materias
que ha cursado un estudiante hasta el momento, saque su promedio e imprima su nombre,
nmero de carnet y el promedio.
Inicio
escribir "nombre"
leer nombre
escribir "matricula"
leer matricula
escribir "total de notas"
leer n
Escribir "nota"
nota=nota
totalnotas=n
suma=0
Mientras totalnotas>0 Hacer
leer nota
suma= suma+nota
nota=suma
totalnotas=totalnotas-1
Fin Mientras
Imprimir nombre matricula, promedio nota/n
Fin
7) Desarrolle un pseudocodigo y diagrama de flujo para leer el nombre de un empleado, el
salario bsico por hora y el nmero de horas trabajadas durante una semana. Calcule el salario
neto, teniendo en cuenta que si el nmero de horas trabajadas durante la semana es mayor de
48 horas, esas horas dems se consideran horas extras y tienen un recargo del 35%. Imprima el
nombre del empleado y su salario neto.
8) Desarrolle un pseudocodigo y diagrama de flujo que le permita determinar dadas tres cajas
cada una con 15 nmeros, en cul caja est un nmero dado.

9) Desarrolle un pseudocodigo y diagrama de flujo que le permita determinar el nmero medio


de tres nmeros. El nmero medio es aquel que no es el mayor ni el menor.
10) Desarrolle un pseudocodigo y diagrama de flujo que le permita obtener la sucesin de
Fibonacci 0,1,1,2 etc. Recuerde que la serie de Fibonacci se genera empezando con los nmeros
0 y 1 y calculando cada nuevo miembro como la suma de dos miembros precedentes en la
sucesin. Imprima los primeros n trminos de la sucesin.
Inicio
x=0
n=1
Escribir " ingresa el numero final de la serie"
num=0
leer num
Para I <-0 Hasta num Con Paso 1 Hacer
Imprimir x
suma= x + n
n=x
x=suma
Fin Para
Fin
11) La compaa de telefona Acme, desea calcular el monto a cobrar a sus clientes. Si se conoce
para un cliente el nmero de telfono, el total de llamadas realizadas en el mes y el total de
minutos consumidos en esas llamadas. Elaborar un pseudocodigo y diagrama de flujo que
permita calcular el monto a cobrar, el cual viene dado por la siguiente tabla
Minutos Bs.
0 50 100
51 100 120
101 200 150
201 300 200
> 300 250
Adicionalmente, se realiza un descuento, el cual depende del total de llamadas realizadas y
viene dado en la siguiente tabla:
Total llamadas Dscto
0 20 5%
21 100 7%
101 200 9%
> 201 10%
Inicio
definir m,ll, t ,tp como entero;
definir des , ttp como real ;
des<-0;
ttp<-0;

escribir " INGRESE EL NUMERO DE TELEFONO ";


LEER t;
escribir " INGRESE TOTAL DE LLAMADAS REALIZADAS EN EL MES ";
LEER ll;
escribir " INGRESE EL TOTAL DE MINUTOS EN ESAS LLAMDAS ";
LEER m;

Si m>=0 y m<50 Entonces


tp<-100;
fin si
si m>=51 y m<=100 entonces
tp<-120;
FinSi
Si m>=101 y m<=200 entonces
tp<-150;
FinSi
si m>=201 y m<=300 entonces
tp<-200;
FinSi
si m>300 entonces
tp<-250;
FinSi
si ll>=0 y ll<=20 entonces
des<-tp*0.05;
ttp<-tp-des;
FinSi
si ll>=21 y ll<=100 entonces
des<-tp*0.07;
ttp<-tp-des;
FinSi
si ll>=101 y ll<=200 entonces
des<-tp*0.09;
ttp<-tp-des;
FinSi
si ll>201 entonces
des<-tp*0.10;
ttp<-tp-des;
FinSi
Imprimir t
Imprimir "EL MONTO A PAGAR ES DE : ", tp;
Imprimir "EL DESCUENTO ES DE : " des;
escribir " EL TOTAL A PAGAR ES DE: ",ttp;
Fin

12) El Banco para el Pueblo est prximo a abrir sus puertas, por esta razn necesita con suma
urgencia la elaboracin y mantenimiento de un programa que le permita mantener los saldos y
movimientos de las cuentas que manejar el banco.
El banco conoce para cada cuenta a aperturar, el nmero de cuenta, la cdula del cliente, el
nombre del cliente, el tipo de cuenta (1- Ahorro, 2- Corriente, 3 Fal y 4 Prstamo) y por ltimo,
el saldo en cuenta.
Se desea elaborar un pseudocodigo y diagrama de flujo, el cual permita leer los datos del cliente,
calcular el inters y mostrar la siguiente informacin:
Para cada cliente:
1. Cedula, nombre y tipo de cuenta
2. Monto a pagar de inters, dado por la siguiente tabla
a. Para cuentas tipo 1 (ahorro) el 10%
b. Para cuentas tipo 2 (corriente) el 8%
c. Para cuentas tipo 3 (fal) el 12%
d. Para cuentas tipo 4 (prestamos) 0%
3. Saldo actual
4. Saldo nuevo con los intereses
Para el banco:
1. Total clientes por cada tipo de cuenta
2. Total monto inters pagado
3. Total saldos nuevos en el banco
4. Cliente con mayor saldo nuevo
5. Cliente con menor saldo nuevo

13) La SHCP ha establecido un nuevo impuesto a las compras de productos, el cual est
determinado por el tipo de artculo a facturar, segn la siguiente tabla:
Tipo de producto Tasa impuesto
Exclusivo 30%
Lujo 20%
Econmico 10%
Accesible 5%
Para cada compra se conoce, monto de la compra y el tipo de producto.
Se desea elaborar el pseudocodigo y diagrama de flujo que nos permita para cada compra
realizada, calcular el impuesto que deber cancelar el cliente y el monto total de la factura, a la
cual se le realiza un descuento, cuyo porcentaje es conocido.
14) Elabore un pseudocodigo y diagrama de flujo que dado un valor X, calcule
Para X positivo:
F(x) = (x - 2) 2 + (x - 4) 4 + (x - 6) 6
246
Para X negativo:
F(x) = (x + 2) 2 + (x + 4) 4 + (x + 6) 6
246

Inicio
Escribir "Ingrese X"
Leer x
Si x > 0 Entonces
res = ((x - 2)* 2) + ((x - 4)* 4) + ((x - 6)* 6)
Sino
res = ((x + 2)* 2) + ((x + 4)* 4) + ((x + 6)* 6)
Fin Si
Imprimir "El resultado es:" res
Fin
15.- Suponga que se leen los datos de tres artculos comprados en una tienda donde para cada
artculo se conoce el nombre del artculo, la cantidad a comprar del artculo y el precio del
mismo. Calcule el monto total a pagar por el articulo si adicionalmente se desea cobrar el
impuesto sobre la venta de 14.5%, en aquellas compras cuyo monto supera los 50.000Bs.
16.-Elabore un pseudocodigo y diagrama de flujo, que calcule el aumento de sueldo de un
trabajador, conociendo del mismo, su nombre, tipo de trabajador, su sueldo y la cantidad de
hijos que tiene. El porcentaje de aumento del sueldo viene dado por el tipo de trabajador que es:
Tipo de trabajador
V 10%
G 15%
E 20%
O 30%
Adicionalmente se le paga una prima del 5% de su sueldo por cada hijo .
17.-Hacer un pseudocodigo y diagrama de flujo que imprima los nmeros del 1 al 100.
Inicio
x =0
mientras

x <=100

Imprimir x
x=x+1
FinMientras
Fin
18.-Hacer un pseudocodigo y diagrama de flujo que imprima los nmeros del 100 al 0, en orden
decreciente.
Inicio
x =100
mientras x >=0
Imprimir x
x=x-1
FinMientras
Fin

19.-Hacer un pseudocodigo y diagrama de flujo que imprima los nmeros pares entre 0 y 100.
Inicio
x=2
mientras x <= 101
Imprimir x
x=x+2
FinMientras
FinProceso
20.-Hacer un programa que imprima la suma de los 100 primeros nmeros.
Inicio
x=1
suma=0
mientras x <= 100
suma = suma + x
x=x+1
FinMientras
Imprimir suma
Fin
21.-Hacer un pseudocdigo que imprima los nmeros impares hasta el 100 y que imprima
cuantos impares hay.
Inicio
x=1
imp=0
mientras x <= 100
x=x+2
imp= imp+1
FinMientras
Imprimir "son" imp "numeros impares"
Fin
22.-Hacer un pseudocodigo y diagrama de flujo que imprima todos los nmeros naturales que
hay desde la unidad hasta un nmero que introducimos por teclado.
Inicio

Escribir "ingrese un numero"


Leer n
x=1
mientras x <= n
Imprimir x
x=x+1
FinMientras
Fin
22.-Introducir un numero por teclado. Que nos diga si es positivo o negativo.
Inicio
Escribir "ingrese un numero"
Leer x
Si x > 0 Entonces
Imprimir x " es positivo"
Sino
Imprimir x " es negativo"
Fin Si
Fin
23.-Introducir un numero por teclado. Que nos diga si es par o impar.
Inicio
Escribir "ingrese un numero"
Leer x
Si x mod 2 = 0 Entonces
Imprimir x " es par"
Sino
Imprimir x " es impar"
Fin Si
Fin
24.-Imprimir y contar los mltiplos de 3 desde la unidad hasta un nmero que introducimos por
teclado.
Proceso sin_titulo
Escribir "ingrese un numero"
Leer n
x=1
total =0
Mientras x <= n

Si x mod 3 = 0 Entonces
Imprimir x
Total = total +1
Fin Si
x= x+1
FinMientras
Imprimir "total de multiplos es:" total
Fin
25.-Hacer un pseudocodigo y diagrama de flujo que imprima los nmeros del 1 al 100. Que
calcule la suma de todos los nmeros pares por un lado, y por otro, la de todos los impares.
Inicio
x= 1
sumapar = 0
sumaimp = 0
mientras x <= 100
imprimir x
Si x mod 2 = 0 Entonces
sumapar= sumapar + x
Sino
Sumaimp= sumaimp + x
Fin Si
x=x+1
FinMientras
Imprimir "la suma de los pares es:" sumapar
Imprimir "la suma de los impares es:" sumaimp
FinProceso
26.-Imprimir y contar los nmeros que son mltiplos de 2 y de 3 que hay entre 1 y 100.
Inicio
x= 1
multi2 = 0
multi3 = 0

mientras x <= 100


Si x mod 2 = 0 Entonces
Imprimir x
multi2= multi2 + 1
Sino
si

x mod 3 = 0 Entonces
Imprimir x
multi3 = multi3 + 1

FinSi
Fin Si
x=x+1
FinMientras
Imprimir "los numero mltiplos de 2 son:" multi2
Imprimir "los nmeros mltiplos de 3 son:" multi3
Fin
27.-Hacer un pseudocodigo y diagrama de flujo que imprima el mayor y el menor de una serie de
cinco nmeros que vamos introduciendo por teclado.
Inicio
Escribir "Ingresa un numero"
serie = 5
maximo = 0
minimo = 9999
Mientras serie > 0
leer x
si x > maximo Entonces
maximo = x
FinSi
si x < minimo Entonces
minimo = x
FinSi
serie= Serie - 1
FinMientras
Escribir "El numero mayor es:" maximo
Escribir "El numero menor es:" minimo
Fin

28.-Introducir dos nmeros por teclado. Imprimir los nmeros naturales que hay entre ambos
nmeros empezando por el m s pequeo, contar cuantos hay y cuntos de ellos son pares.
Calcular la suma de los impares.
Inicio
Escribir "ingresa un numero"
leer x
Escribir "ingrese otro numero"
leer z
sumanat = 0
sumapar = 0
sumaimp = 0
inter=0
Si x > z Entonces
inter = x
x=z
z = inter
Fin Si
mientras x <= z
Imprimir x
sumanat = sumanat + 1
Si x mod 2 = 0 Entonces
sumapar = sumapar + 1
Sino
sumaimp = sumaimp + x
Fin Si
x=x+1
Fin
Imprimir "los numeros naturales que hay son:" sumanat
Imprimir "los numero pares son:" sumapar
Imprimir "La suma de los impares es:" sumaimp
Fin
29.-Imprimir diez veces la serie de nmeros del 1 al 10.
Inicio
serie = 10
mientras serie > 0
x=1
Mientras x <= 10
Imprimir x
x=x+1
FinMientras

serie = serie - 1
FinMientras
Fin
30.-Imprimir, contar y sumar los mltiplos de 2 que hay entre una serie de nmeros, tal que el
segundo nmero solicitado sea mayor o igual que el primero.
Inicio
Escribir "Ingrese un numero"
Leer x
Escribir "Ingrese un numero mayor o igual al primero"
leer z
sum = 0
so = 0
Mientras x <= z
Imprimir x
Si x mod 2 = 0 Entonces
so = so + 1
sum = sum + x
Fin Si
x=x+1
FinMientras
Imprimir "Los numeros pares que hay en la serie son:" so
Imprimir "La suma de los numeros pares es:" sum
Fin
31.-Hacer un pseudocodigo y diagrama de flujo que simule el funcionamiento de un reloj digital y
que permita ponerlo en hora.
Inicio
hor = 00
min = 00
seg = 00
n = "s"
Escribir "horas"
leer hor
Escribir "minutos"
leer Min
Escribir "segundos"
leer seg

Mientras n = "s"
Mientras hor < 24 Hacer
Mientras min < 60 Hacer
Mientras seg < 60 Hacer
Escribir hor ":" min ":" seg
seg= seg + 1
Esperar 1 Segundo
FinMientras
min = min + 1
seg = 0
FinMientras
hor = hor + 1
min = 0
FinMientras
hor = 0
FinMientras
FinProceso
32.-Calcular el factorial de un nmero, mediante subprogramas.
33.-Hacer un programa que calcule independientemente la suma de los pares y los impares de
los nmeros entre 1 y 100.
Inicio
x=1
serie = 100
sumpar = 0
sumimp = 0
Mientras serie > 0 Hacer
Si x MOD 2 = 0 Entonces
sumapar = sumapar + x
Sino
sumaimp = sumaimp + x
Fin Si
x=x+1

serie = serie - 1
Fin Mientras
Imprimir "La suma de los pares es:" sumapar
Imprimir "La suma de los impares es:" sumaimp
Fin
34.-Introducir una frase por teclado. Imprimirla cinco veces en filas consecutivas, pero cada
impresin ir desplazada cuatro columnas hacia la derecha.
Inicio
Escribir "ingrese una frase"
Leer frase;
serie= 1
Mientras serie <= 5
imprimir frase
frase = "

" + frase

serie = serie + 1;
FinMientras
Fin
35.-Hacer un pseudocodigo y diagrama de flujo que imprima los nmeros del 0 al 100,
controlando las filas y las columnas.
36.-Comprobar si un nmero mayor o igual que la unidad es primo o no.
Inicio
Escribir "ingresa un numero"
Leer x
z=2
si x >= 1 Entonces
Mientras (x mod z <> 0)
z=z+1
Finmientras
Si (x = z) Entonces
Imprimir x " es primo"
Sino

Imprimir x " no es primo"


FinSi
Finsi
Fin
37.-Introducir un nmero menor de 100 y pasarlo a nmero romano.
Inicio
Escribir "ingresa un numero"
leer num
si num <= 100 Entonces
SI num = 100 Entonces
Imprimir "M" Sin Saltar
num = num - 100
FinSi
SI num >= 90 Entonces
Imprimir "XC" Sin Saltar
num = num - 90
FinSi
SI num >= 50 Entonces
Imprimir "L" Sin Saltar
num = num - 50
FinSi
SI num >= 40 Entonces
Imprimir "XL" Sin Saltar
num = num - 40
FinSi
SI num >= 30 Entonces
Imprimir "XXX" Sin Saltar
num = num - 30
FinSi
SI num >= 20 Entonces
Imprimir "XX" Sin Saltar
num = num - 20

FinSi
SI num >= 10 Entonces
Imprimir "X" Sin Saltar
num = num - 10
FinSi
SI num = 9 Entonces
Imprimir "IX" Sin Saltar
num = num - 9
FinSi
SI num >= 5 Entonces
Imprimir "V" Sin Saltar
num = num - 5
FinSi
SI num >= 4 Entonces
Imprimir "IV" Sin Saltar
num = num - 4
FinSi
Mientras num > 0
Imprimir "I" Sin Saltar
num = num - 1
FinMientras
FinSi
Fin
38.-Introducir una frase por teclado. Imprimirla en el centro de la pantalla.
Inicio
escribir "ingresa palabra"
leer pal
Imprimir "

",pal,"

"

Fin
39.-Realizar la tabla de multiplicar de un nmero entre 0 y 10.

Inicio
Escribir "ingrese un numero 0 a 10"
leer x
z=0
Mientras z <= 10
Imprimir x "x" z "=" x*z
z=z+1
FinMientras
Fin
40.-Simular el lanzamiento de una moneda al aire e imprimir si ha salido cara o cruz.
Inicio
Escribir "Lanzar Moneda S/N"
Leer Lan
Mientras Lan= "S"
moneda = azar (2)
si

moneda= 1
Imprimir "cara"

Sino
Imprimir "cruz"
FinSi
Leer Lan
FinMientras
Fin
41.-Simular cien tiradas de dos dados y contar las veces que entre los dos suman 10.
Inicio
tiradas = 100
dad = 0
Mientras Tiradas > 0
dado1 = azar(6)
dado2 = azar(6)
suma = dado1 + dado2
si suma = 10 Entonces

dad = dad + 1
FinSi
tiradas = tiradas - 1
FinMientras
Imprimir "Dados que suman 10 es:" dad
Fin
42.-Simular una carrera de dos caballos si cada uno tiene igual probabilidad de ganar.
Inicio
Dimension avance[7]
Ganador=0
para i=1 Hasta 6 - 1 Hacer
avance[i]=' '
FinPara
Repetir
Borrar Pantalla
Escribir '- 10m - 20m - 30m - 40m - 50m - 60m - 70m - 80m - 90m - 10m META'
Para i=1 Hasta 3 - 1 Hacer
Escribir
Escribir
Escribir
Escribir

avance[i] ' o '


avance[i] '-{',i,']-'
avance[i] ' / \ '
''

Si avance[i] = '
ganador = i
FinSi
Si Azar(2) > 0 Entonces
avance[i] = avance[i] + " "
Fin Si
FinPara
Hasta Que ganador <> 0
Escribir ' '
Escribir ' '
Escribir '

El corredor Ganador es el:' ganador

' Entonces

Fin
43.-Introducir tres nmeros por teclado y calcule su suma, su resta, su multiplicacin y la divisin
del primero entre el segundo y del tercero entre el resultado de la primera divisin.
Inicio
Dimension num[3]
Para i = 1 Hasta 3 Con Paso 1 Hacer
Escribir " Ingrese numero ",i, ":"
Leer num[i]
FinPara
Para i = 1 Hasta 1 Con Paso 1 Hacer
suma = num[i] + num[i+1] + num[i+2]
resta = num[i] - num[i +1] - num[i+2]
multi = num[i] * num[i +1] * num[i+2]
div = (num[i] / num[i+1]) / num[i+2]
FinPara
Imprimir " La Suma de los numeros es:" suma
Imprimir " La Resta de los numeros es:" resta
Imprimir " La Multiplicacion de los numeros es:" multi
Imprimir " La Divicion de los numeros es:" div
Fin
44.-Hacer un programa que nos permita introducir un nmero por teclado y sobre l se realicen
las siguientes operaciones: comprobar si es primo, hallar su factorial e imprimir su tabla de
multiplicar.
Inicio
Escribir "ingresa un numero"
Leer x
num=1
Factorial= 1
z=0
n=2
si x >= 1 Entonces
Mientras (x mod n <> 0)
n=n+1

Finmientras
Si (x = n) Entonces
Imprimir x " es primo"
Sino
Imprimir x " no es primo"
FinSi
Finsi
Mientras num <= x Hacer
factorial = factorial * num
num = num +1
FinMientras
Imprimir " El factorial es: " factorial
Mientras z <= 10
Imprimir x "x" z "=" x*z
z=z+1
FinMientras
Fin
45.-Crear un array unidimensional de 20 elementos con nombres de personas. Visualizar los
elementos de la lista debiendo ir cada uno en una fila distinta.
Inicio
dimension nombres[20]
Para i = 1 Hasta 5 Con Paso 1 Hacer
Escribir " Ingrese nombre ",i, ":"
Leer nombres[i]
FinPara
Para i=1 Hasta 5 Con Paso 1 Hacer
Imprimir Nombres[i] " " Sin Saltar
FinPara
Fin

46.-Hacer un programa que lea las calificaciones de un alumno en 10 asignaturas, las almacene
en un vector y calcule e imprima su media.
Inicio
Dimension vec[10]
x=1
Suma = 0
Para i = 1 Hasta 10 Con Paso 1 Hacer
Escribir "ingrese calificacion",i,":"
Leer num
suma = suma + num
vec[x] = num
Fin Para
media = suma / x
Escribir "la media es: " vec[x]
Fin
47.-Usando el segundo ejemplo, hacer un programa que busque una nota en el vector.
48.-Generar una matriz de 4 filas y 5 columnas con nmeros aleatorios entre 1 y 100, e
imprimirla.
Inicio
Dimension caja[4,5]
Para i<-1 Hasta 4 Hacer
Para j<-1 Hasta 5 Hacer
caja[i,j] = Azar(100)
Fin Para
Fin Para
Para i<-1 Hasta 4 Hacer
Para j<-1 Hasta 5 Hacer
Imprimir caja[i,j]
Fin Para
Fin Para
Fin