Está en la página 1de 14

Apunte de Configuracin de Router

Mdulo 1 CCNA

Principios Bsicos de Configuracin de Router Cisco


El router es un dispositivo intermediario de Capa 3 del Modelo OSI que cumple el objetivo de redirigir
los paquetes hacia los destinos, analizando la informacin del encabezado de Capa de Red que se
agrega al segmento.
Para tomar las decisiones de renvo de paquetes a travs de la red, los routers construyen una tabla
que les permiten reconocer hacia donde se encuentran las redes de destino. Dicha tabla se denomina
tabla de enrutamiento y la mantienen y almacenan en la memoria RAM (memoria de acceso
aleatoria).
El router es un dispositivo que posee los siguientes elementos para desarrollar sus tareas (Figura 1):

Figura 1. Elementos del Router.

1. CPU. Microprocesador que ejecuta las instrucciones del Sistema Operativo (IOS, Internetwork
Operative System de Cisco), como la inicializacin del sistema, las funciones de enrutamiento y
el control de las interfaces.
2. Memoria ROM. Memoria de solo lectura cuyo contenido es fijo y no puede ser borrado. Su
contenido fue grabado por el fabricante y no puede ser alterado. Contiene 3 tipos de micro
cdigos que cumplen objetivos distintos:
a) Bootstrap. Micro cdigo o programa que inicia el router una vez encendido ste y guarda
un log o registro de lo que sucedi durante su partida.
b) POST. Sigla que corresponde a la frase Power On Self Test (Prueba de encendido de s
mismo). Este programa verifica, durante el inicio del router, que todas sus partes estn
funcionando correctamente (memorias e interfaces).
c) Versin Reducida de IOS. Es utilizado cuando existe una ausencia del IOS completo
totalmente operativo. Por ejemplo, ante un borrado del Sistema Operativo.
3. Memoria FLASH. Aloja el sistema operativo de Cisco, Cisco IOS, completo y funcional. Es una
memoria no voltil (no pierde su contenido despus de apagado el equipo) y elctricamente
borrable. Puede ser de tipo SIMM o PCMCIA.
4. Memoria NVRAM (No Voltil RAM). Es una memoria de acceso aleatorio no voltil que no
pierde su contenido despus que se corta la energa del router. Almacena el archivo de

Documento preparado por Eduardo Vega

Pgina 1

Apunte de Configuracin de Router

Mdulo 1 CCNA

configuracin llamado startup-config que se genera durante la configuracin del router y la


posterior grabacin de ella.
5. Memoria RAM. Memoria de tipo voltil, que pierde su contenido cuando se apaga el router.
Almacena lo siguiente:
a) El sistema operativo totalmente funcional que es copiado desde la Memoria FLASH.
b) Archivo de configuracin en ejecucin. Obtenido de la copia del archivo startup-config en
el archivo llamado running-config.
c) Tabla de Enrutamiento IP. Archivo que guarda las redes remotas y directamente
conectadas conocidas por el router.
d) Cach ARP. Tabla que almacena las asignaciones de direcciones IP (Capa 3 de OSI) a las
direcciones MAC (Capa 2) cuando el router cuenta con interfaces Ethernet.
e) Buffer de Paquetes. Area de almacenamiento temporal de paquetes en espera a ser
procesados, que han sido recibidos de una o ms interfaces.
6. Interfaz. Se refiere a un conector fsico cuyo objetivo principal es recibir y enviar paquetes.
Tambin se le conoce como puerto fsico. Algunos tipos de interfaces son: Ethernet (referida a
un puerto de mximo 10 Mbps), FastEthernet (mximo 100 Mbps), GigabitEthernet (1000
Mbps), Serial (por defecto 1,544 Mbps), BRI (144 Kbps), etc.
Dependiendo del tipo de interfaz, sta construye y procesa tramas de diferentes estructuras. Si
estas interfaces se configuran con IP, cada una de ellas pertenece a una red o subred diferente
y un dominio de broadcast distinto.

Interfaz de Lnea de Comandos (CLI)


Para preparar el router para que desarrolle sus funciones principales, enrutar y conmutar paquetes, se
puede acceder a un interfaz de texto amistosa para realizar su configuracin, conocida como Interfaz
de Lnea de Comando (CLI).
Para ingresar a esta modalidad de configuracin en ambiente de texto, se de establecer una conexin
desde el equipo del administrador o configurador del router y una interfaz fsica del router llamada
Console, generalmente rotulada con un color celeste en el backplane (parte posterior) del equipo. Para
esta conexin fsica se utiliza un cable de consola y el puerto serial del equipo terminal del
administrador.
Para las tareas de configuracin, se utiliza un software para esos fines, donde los ms conocidos son
hyperterminal, putty, teraterm, procom, etc. LA Figura 2 muestra la configuracin y uso del software
putty.

Documento preparado por Eduardo Vega

Pgina 2

Apunte de Configuracin de Router

Mdulo 1 CCNA

Figura 2. Configuracin y uso de Putty.

La CLI tiene dos modos generales de acceso a la configuracin del router:


a) Modo Usuario (o EXEC Usuario). Permite comprobar el estado del router aunque no modifica
su configuracin. Se le reconoce porque en el prompt del sistema aparece el smbolo >, esto
es:
Router>
b) Modo Privilegiado (o EXEC Privilegiado). Permite al usuario realizar cambios de configuracin
del router e incluso borrar toda la configuracin existente y el sistema operativo si se desea. El
prompt que lo identifica el smbolo #, es decir:
Router#
Para pasar del modo usuario al modo privilegiado, se utiliza el comando enable:
Router> enable
Router#
Cuando se configura por primera vez o se ha borrado recientemente el router, pasar de un modo al
otro es simple. Sin embargo, si el router ya tiene una configuracin y, en especial, alguna seguridad, se
debiera pedir el ingreso de una clave:
Router> enable
Password:
Router#
Para volver nuevamente al modo usuario desde el privilegiado, utilice los comandos disable o exit:

Documento preparado por Eduardo Vega

Pgina 3

Apunte de Configuracin de Router

Mdulo 1 CCNA

Router# disable o exit


Router>

NOTA: Los comandos en la CLI se pueden abreviar y el router reconoce la abreviacin siempre y
cuando los caracteres digitados impliquen la identificacin de un nico comando. Por ejemplo: sh
por show, ena por enable, etc.

La CLI tiene un sistema de ayuda fcil y simple. Se accede a l utilizando el carcter ?, como se
muestra a continuacin:
Router# ?
Exec commands:
<1-99>
Session number to resume
auto
Exec level Automation
clear
Reset functions
clock
Manage the system clock
configure Enter configuration mode
connect
Open a terminal connection
copy
Copy from one file to another
debug
Debugging functions (see also 'undebug')
delete
Delete a file
dir
List files on a filesystem
disable
Turn off privileged commands
disconnect Disconnect an existing network connection
enable
Turn on privileged commands
erase
Erase a filesystem
exit
Exit from the EXEC
logout
Exit from the EXEC
mkdir
Create new directory
more
Display the contents of a file
no
Disable debugging informations
ping
Send echo messages
reload
Halt and perform a cold restart
resume
Resume an active network connection
rmdir
Remove existing directory
setup
Run the SETUP command facility
show
Show running system information
ssh
Open a secure shell client connection
telnet
Open a telnet connection
terminal Set terminal line parameters
traceroute Trace route to destination
undebug Disable debugging functions (see also 'debug')
write
Write running configuration to memory, network, or terminal
Router#

Documento preparado por Eduardo Vega

Pgina 4

Apunte de Configuracin de Router

Mdulo 1 CCNA

Al digitar el carcter ?, inmediatamente se despliegan los comandos que se pueden ejecutar en el


modo actual en dos columnas. La primera columna corresponde al comando o accin y la segunda es
una breve descripcin de l.
El smbolo ? tambin sirve como comodn, igual que el carcter * (asterisco) en el antiguo DOS o
Windows. Es decir, puede remplazar uno ms caracteres durante la bsqueda de un comando u opcin
de un comando.
En la Figura 3, se muestra paso a paso la configuracin de fecha y hora del sistema. Observe la
utilizacin del smbolo ?, que sirve para mostrar ayuda de la opcin que sigue a continuacin cuando
se desea ejecutar el comando.

Router#
Router#cloc?
clock
Router#clock ?
set Set the time and date
Router#clock set ?
hh:mm:ss Current Time
Router#clock set 21:27:00 ?
<1-31> Day of the month
MONTH Month of the year
Router#clock set 21:27:00 5 ?
MONTH Month of the year
Router#clock set 21:27:00 5 may ?
<1993-2035> Year
Router#clock set 21:27:00 5 may 2012 ?
<cr>
Router#clock set 21:27:00 5 may 2012
Router#
Figura 3. Configuracin de la fecha y hora del sistema.

El comando termina cuando en las opciones aparece <cr>, que significa carrier return o el
equivalente a presionar la tecla enter.

Primeras tareas de Configuracin del Router


Cuando se configura un router se deben realizar las siguientes tareas bsicas:

Asignar un nombre al router.


Establecer las contraseas: Acceso al modo privilegiado; acceso a la interfaz de consola y a la
conexin va Telnet o SSH (terminales virtuales).

Documento preparado por Eduardo Vega

Pgina 5

Apunte de Configuracin de Router

Mdulo 1 CCNA

Configurar un mensaje que se despliegue al ingresar al modo de configuracin del router.


Configurar la interfaces que participarn del proceso de enrutamiento (FastEthernet, Seriales,
etc.)
Guardar los cambios de la configuracin en la NVRAM
Verificar la configuracin bsica y las operaciones del router.

Veamos cada una de estas tareas paso a paso.


a) Asignar un nombre al router.
El router debe contar con un nombre ad-hoc, esto significa que su nombre debe representar su
ubicacin o finalidad por ejemplo. Esto se realiza ingresando al modo de configuracin global,
utilizando el comando configure terminal, apareciendo en el prompt (config). Los parntesis y
lo que est dentro de ellos representa el modo o submodo donde se encuentra posicionado en
el momento.
Router# configure terminal
Router(config)# hostname Plaza_Oeste
Plaza_Oeste(config)# exit
(para volver al modo anterior)
Los nombres de equipo no pueden llevar espacios entre palabras porque cortara el nombre a
la primera palabra. Si se desea agregar un espacio, ste se debe simular con el carcter _
(guion bajo o underline), como se muestra en el ejemplo anterior.

NOTA: La mayora de los comandos en la CLI se ejecutan a parir del modo de configuracin global,
representado en el prompt por (config).

b) Establecer las contraseas de acceso.


Las contraseas se fijan como mecanismo de seguridad para evitar los accesos no autorizados
al router. Recurdese que el router es un dispositivo crtico y de alta demanda, por lo tanto se
deben asegurar todos medios de accesos.

Fijar la contrasea de ingreso al Modo Privilegiado.


La contrasea de acceso a modo privilegiado utiliza el algoritmo de cifrado MD5
(Message Digest 5) para los routers Cisco.
Plaza_Oeste# configure terminal
Plaza_Oeste(config)# enable secret duoc
Plaza_Oeste(config)# exit

NOTA: Las palabras en negrilla representan las palabras reservadas o los comandos mismos, las
palabras en letra cursiva corresponden a las opciones que debe crear el usuario.

Documento preparado por Eduardo Vega

Pgina 6

Apunte de Configuracin de Router

Mdulo 1 CCNA

Configurar la contrasea de acceso a la interfaz de consola (interfaz de lnea). Se


aconseja en esta tarea agregar siempre el comando logging synchronous para
cuando se desplieguen mensajes de advertencia por la pantalla no moleste y
entreguen siempre una lnea en blanco para digitar los comandos.
Plaza_Oeste# configure terminal
Plaza_Oeste(config)# line console 0
Plaza_Oeste(config-line)# password cisco
Plaza_Oeste(config-line)# login
Plaza_Oeste(config-line)# logging synchronous
Plaza_Oeste(config-line)# exit

Definir la contrasea de acceso a Telnet a travs de la interfaz virtual (interfaz de


lnea). Las interfaces virtuales se numeran comenzando con 0 y hasta 4 (es decir 5
terminales virtuales para acceder al mismo tiempo desde 5 equipos distintos). Sin
embargo, hay modelos de router Cisco que soportan hasta 16 (0 a 15).
Plaza_Oeste# configure terminal
Plaza_Oeste(config)# line vty 0 4
Plaza_Oeste(config-line)# password cisco
Plaza_Oeste(config-line)# login
Plaza_Oeste(config-line)# exit

Hasta el momento, el router tiene un nombre y todos los medios de acceso al modo privilegiado estn
asegurados por la solicitud de una contrasea.
c) Configurar un mensaje que se despliegue al ingresar al router, conocido como mensaje del
da
Como complemento del punto anterior, cunado se ingresa a cualquiera de los modos de
ingreso al modo privilegiado, es aconsejable definir un mensaje de advertencia que indique
que el router es un dispositivo asegurado y que se debe tener presente que los accesos no
autorizados pueden ser penalizados. El mensaje se define entre delimitadores #.
Plaza_Oeste(config)# banner motd #ADVERTENCIA: Sistema asegurado. Solo acceso a personal
autorizado#
Este mensaje se desplegar al ingresar a travs de la interfaz de consola y, si se desea que
tambin aparezca cuando se accede va Telnet, se debe realizar lo siguiente:
Plaza_Oeste(config)# line vty 0 4
Plaza_Oeste(config-line)# motd-banner

d) Configurar interfaces del router.


Las interfaces o puertos fsicos son el medio de comunicacin entre el router y las redes. Cada
interfaz del router es como un host ms dentro de esa red, por lo tanto, posee una direccin

Documento preparado por Eduardo Vega

Pgina 7

Apunte de Configuracin de Router

Mdulo 1 CCNA

fsica de Capa 2 o direccin MAC y se le debe definir una direccin de Capa de Red, en este
caso IP. Finalmente, se debe emitir el comando no shutdown que levanta o activa la interfaz.
La sintaxis de los comandos es la siguiente:
Plaza_Oeste# configure terminal
Plaza_Oeste(config)# interface <tipo> <slot/mdulo/nmero>
Plaza_Oeste(config-if)# ip address <direccin IP> <mscara>
Plaza_Oeste(config-if)# no shutdown
Vemoslo con un ejemplo:
Plaza_Oeste# configure terminal
Plaza_Oeste(config)# interface fastethernet 0/0
(o simplemente f0/0)
Plaza_Oeste(config-if)# ip address 192.168.1.1 255.255.255.0
Plaza_Oeste(config-if)# no shutdown
Es aconsejable ingresar una descripcin en cada interfaz para ayudar a documentar la
informacin de la red y a solucionar problemas de mal funcionamiento por ejemplo. El texto
descriptivo est limitado a 240 caracteres.
Plaza_Oeste(config-if)# description Conexin a Red LAN Ingenieria Piso 5
En el caso de una interfaz serial sera lo siguiente:
Plaza_Oeste# configure terminal
Plaza_Oeste(config)# interface serial 0/0/0
(o simplemente s0/0/0)
Plaza_Oeste(config-if)# ip address 10.1.1.1 255.255.255.0
Si la interfaz serial se conecta al Equipo de Circuito de Datos (como un mdem o el cable
simula un mdem) se debe configurar la seal de sincronizacin en bits por segundo. Si se usa
un cable que simula la presencia de un mdem, y se desea saber si el extremo de un cable es
DCE, utilizar el siguiente comando:
Plaza_Oeste# show controllers s 0/0/0
La salida del comando de visualizacin sera algo como se muestra en la Figura 4.

Router# show controllers s 0/0/0


Interface Serial0/0/0
Hardware is PowerQUICC MPC860
DTE V.35 TX and RX clocks detected
idb at 0x81081AC4, driver data structure at 0x81084AC0
Figura 4. Resultado del comando para visualizar el tipo de interfaz serial
Siguiendo con la configuracin de la interfaz serial, tenemos:

Documento preparado por Eduardo Vega

Pgina 8

Apunte de Configuracin de Router

Mdulo 1 CCNA

Plaza_Oeste(config-if)# clock rate 125000


Plaza_Oeste(config-if)# description Conexin a Red WAN Proveedor
Plaza_Oeste(config-if)# no shutdown

e) Guardar la configuracin realizada.


Hasta el momento se ha configurado un router y ha quedado registrado en la memoria RAM.
Como esta memoria es de tipo voltil, si se apaga el router se perdera toda la configuracin.
Para evitar esta prdida, se debera configurar, a travs del siguiente comando, la forma de
respaldar lo realizado en una memoria de tipo no voltil como los es la NVRAM:
Plaza_Oeste# copy running-config startup-config
Este comando copia toda la configuracin que se ha realizado en la memoria RAM o memoria
de trabajo (ello significa que cada comando que se registra es de ejecucin inmediata).
Recurdese que el archivo running-config reside en la memoria RAM y el archivo startupconfig se encuentra alojado en la memoria NVRAM (ver punto 5 letra b de es documento).

f)

Verificar la configuracin bsica y la operacin del router.


Tanto en el modo usuario como el privilegiado existen comando de visualizacin que permiten
verificar cmo el router est configurado. Estos comandos son los show, por ejemplo:
Plaza_Oeste# show ip route
Este comando show despliega la tabla de enrutamiento que, hasta el momento, conoce el
router. En la Figura 5 se detalla la salida de emitir el comando descrito anteriormente.

Plaza_Oeste# sh ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/24 is subnetted, 1 subnets
C 10.1.1.0 is directly connected, Serial0/0/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
Plaza_Oeste#

Documento preparado por Eduardo Vega

Pgina 9

Apunte de Configuracin de Router

Mdulo 1 CCNA

Figura 5. Resultado de la salida del comando show ip route.

Plaza_Oeste# show running-config


La salida de este comando se muestra en la Figura 6. La configuracin de las interfaces se
muestra por secciones dependiendo del tipo de sta: FastEthernet y Serial. La informacin de
seguridad para las interfaces de lnea como la Consola y el acceso va Telnet (terminales
virtuales) se muestran al final del archivo de la Figura 6.

Current configuration : 782 bytes


!
version 12.2
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
!
hostname Plaza_Oeste
!
!
enable secret 5 $1$mERr$XJb4G5SUnVMAh07D5zybq0
!
!
interface FastEthernet0/0
description Conexion a Red LAN Ingenieria Piso 5
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
shutdown
!
interface Serial0/0
description Conexion a Red WAN Proveedor
ip address 10.1.1.1 255.255.255.0
clock rate 125000
!
ip classless
!
!
banner motd ^CADVERTENCIA: Sistema Asegurado. Solo acceso a personal autorizado^C
!
!
line con 0

Documento preparado por Eduardo Vega

Pgina 10

Apunte de Configuracin de Router

Mdulo 1 CCNA

password cisco
logging synchronous
login
line vty 0 4
password cisco
login
!
!
end

Figura 6. Resultado de la salida de un archivo de configuracin running-config

Otro comando show que permite desplegar un resumen breve de la configuracin de las
interfaces IP es el siguiente:
Plaza_Oeste# show ip interface brief
Este comando que se muestra en la Figura 7, describe por medio de la columna Status el estado
de la Capa Fsica (up significa que la interfaz est activa y existe un cable la une con la del equipo
vecino; down significa que la interfaz est desactivada y no hay cable que la una con la del
vecino) y la columna Protocol indica la capa Enlace de datos del Modelo OSI, en particular, que
se ha configurado un protocolo comn entre la interfaz con el vecino.

Plaza_Oeste# show ip interface brief


Interface
IP-Address OK? Method

Status Protocol

FastEthernet0/0

192.168.1.1

YES manual

up

FastEthernet0/1

unassigned

YES unset administratively down

down

Serial0/0/0
Plaza_Oeste#

10.1.1.1

YES manual

up

up

up

Figura 7. Resultado de la salida del comando Show ip interface brief.

Configuracin de Redes Remotas


La configuracin bsica de un router conectado en una topologa fsica, implica que solo tiene
conocimiento de las redes directamente conectadas, es decir, aquellas que se gestan desde sus
propias interfaces activas. Inicialmente, en la tabla de enrutamiento aparecen las redes
directamente conectadas, identificadas con la letra C en la primera columna de dicha tabla
(ver Figura 5). Por lo tanto, para que el router aprenda redes remotas, lo puede hacer por de las
siguientes formas:

Documento preparado por Eduardo Vega

Pgina 11

Apunte de Configuracin de Router

Mdulo 1 CCNA

Esttica o manualmente
Dinmica o automticamente

En el presente documento, solo se tratar la primera opcin. Para ello, consideremos la


siguiente topologa:

Figura 8. Topologa Fsica.


De la Figura 8 se concluye que la red 200.1.1.0/30 se compone de 2 direcciones IP utilizables,
200.1.1.1 que se asignar a la interfaz S0/0 del router Plaza_Oeste y la direccin 200.1.1.2 que
se destinar a la interfaz S0/1 del router Maip.
Luego de realizar la configuracin bsica completa que se trat en los puntos anteriores, si se
emite el comando show ip route en uno de los router, por ejemplo Maip, se vera algo
parecido a la Figura 9.

Figura 9. Resultado de la emisin del comando show ip route en el router Maip.


De la Figura 9 se desprende que el router Maip solo conoce las red locales 10.1.1.0 /24 (LAN)
y 200.1.1.0/24 (WAN). Sin embargo, el router Maip no conoce la red LAN 192.168.1.0/24 del
router Plaza_Oeste y, por ende, el router Plaza_Oeste no conoce la red LAN 10.1.1.0/24 que
tiene directamente conectada Maip. Es decir, son redes remotas a ambos routers y las vamos
a configurar para que sean conocidas.

Documento preparado por Eduardo Vega

Pgina 12

Apunte de Configuracin de Router

Mdulo 1 CCNA

Las redes remotas se configuran estticamente segn la sintaxis del siguiente comando, ruta
esttica:
Maipu# configure terminal
Maipu(config)# ip route <red_remota> <mscara_red_remota> <interfaz saliente | IP Prx. Salto>
Donde:
<red_remota> =

Red que el router no tiene directamente conectada. Ejemplo, 192.168.1.0 para el


router Mip.

<mscara_red_remota>= Corresponde a la mscara de la red remota indicada en el parmetro


anterior. Ejemplo, 25.255.255.0 para el router Maip.
<interfaz saliente | IP Prx. Salto> = Para declarar la ruta esttica se puede especificar la interfaz
saliente del router local por donde se debe enviar los paquetes a la red de destino
(en el caso de esta configuracin, la S0/1 de Maip), o la IP del router vecino en
direccin a la red de destino (en el ejemplo, la IP 200.1.1.1).
Entonces, la configuracin para el router Maip sera:
Maipu# configure terminal
Maipu(config)# ip route 192.168.1.0 255.255.255.0 s0/1
o
ip route 192.168.1.0 255.255.255.0 200.1.1.1
Y, para el router Plaza_Oeste:
Plaza_Oeste# configure terminal
Plaza_Oeste(config)# ip route 10.1.1.0 255.255.255.0 s0/0
o
ip route 10.1.1.0 255.255.255.0 200.1.1.2
Luego de estas configuraciones la tabla de enrutamiento para el router Maip quedara como se
muestra en la Figura 10. Del mismo modo, la tabla de enrutamiento del router Plaza_Oeste se detalla
en la Figura 11.

Documento preparado por Eduardo Vega

Pgina 13

Apunte de Configuracin de Router

Mdulo 1 CCNA

Figura 10. Resultado de la emisin del comando show ip route en el router Maipu.

Figura 11. Resultado de la emisin del comando show ip route en el router Plaza_Oeste.
Las rutas estticas configuradas en ambos router aparecen en la tabla de enrutamiento con la
identificacin de la letra S en la primera columna de dicha tabla.
Luego de esto se puede probar conectividad total ejecutando el comando utilitario ping.

Documento preparado por Eduardo Vega

Pgina 14