Está en la página 1de 2

Las posibilidades de SUMAPRODUCTO en Excel.

Hoy voy a hablar sobre algunas de las funciones ms empleadas en nuestras hojas
de Excel, las funciones SUMAR.SI y SUMAR.SI.CONJUNTO (de las que se han
hablado largo y tendido en este blog); pero sobre todo de una funcin alternativa a
estas, con multitud de ventajas, la funcin SUMAPRODUCTO.
En muchas ocasiones al elaborar nuestros clculos nos hemos dado cuenta de las
limitaciones de esas funciones SUMAR.SI o SUMAR.SI.CONJUNTO, que aunque muy
potentes, nos restringen las operaciones al criterio Y, es decir, funcionan
nicamente con sumas acumulativas de registros que cumplen condiciones
simultneas. Por ejemplo:
=SUMAR.SI.CONJUNTO(A1:A10;B1:B10;>100;C1:C10;"a")
que sumara los importes del rango A1:A10 slo en los casos en que la cantidad de
B1:B10 correspondiente sea mayor a 100 y al mismo tiempo en C1:C10 contenga el
texto "a".

Pero, y qu podemos hacer si en lugar del criterio Y deseamos aplicar el criterio


O?. Aqu es donde comienza la potencia de SUMAPRODUCTO.
Si buscamos en la ayuda de Excel esta funcin leeremos: SUMAPRODCUTO
Multiplica los componentes correspondientes de las matrices suministradas y
devuelve la suma de esos productos.; y efectivamente este sera el uso ms
habitual, sin embargo es mucho ms interesante observar los argumentos de la
funcin, en la Sintxis:
SUMAPRODUCTO(matriz1; [matriz2]; [matriz3]; ...)
Lo especial de esta funcin es que permite trabajar u operar con Rangos o
matrices!!!, lo que es poco frecuente, excepto con las funciones matriciales. Es,
sobre este punto, sobre el que incidir.
Esta forma parecida a la matricial de trabajar de nuestra funcin es la que ocupar
nuestra entrada del da; ya que con ella podremos operar empleando ambos
criterios lgicos Y y O (AND y OR); esto lo conseguiremos empleando los
operadores * y +:
para el operador lgico Y usaremos *
para el operador lgico O usaremos +
En esencia conseguiremos que Excel evale las condiciones que le vamos a dar,
empleando estos operadores, para que nos devuelva VERDADERO o FALSO (1 0
en valor numrico respectivamente), todo ello sin emplear la forma matricial de
ejecutar las funciones.
Veremos, como siempre, algunos ejemplos de este uso especial de
SUMAPRODUCTO. Partiremos de la siguiente base de datos, al que hemos asignado
ciertos Nombres definidos para trabajar de una forma ms visual:
Comercial =Hoja2!$A$2:$A$14
Importe =Hoja2!$D$2:$D$14

Unidades =Hoja2!$C$2:$C$14
Zona =Hoja2!$B$2:$B$14

Un primer ejemplo servira para sustituir a las funciones SUMAR.SI o


SUMAR.SI.CONJUNTO.
=SUMAR.SI.CONJUNTO(Importe;Comercial;"Pepe";Unidades;">60")
puede ser sustituido por
=SUMAPRODUCTO(Importe*(Comercial="Pepe")*(Unidades>60))
En ambos casos nos indica cunto suman los importes para el comercial 'Pepe'
cuando las Unidades vendidas superan las 60.
Notemos como las dos condiciones de SUMAR.SI.CONJUNTO son equivalentes al
operador * (que implica el criterio lgico Y).