Está en la página 1de 4

Configuracin dinmica de las opciones del servidor DHCP

Contenidos
Introduccin
Requisitos previos
Requisitos
Componentes utilizados
Convenciones
Configurar
Diagrama de la red
Configuraciones
Verifique
Resolucin de problemas
Comandos para resolucin de problemas

Introduccin
DHCP le permite asignar automticamente las direcciones IP reutilizables a clientes DHCP. En este documento se ofrece un ejemplo de cmo
configurar opciones de DHCP tales como las direcciones del Sistema de nombres de dominio (DNS) y del Servicio de nombres de Internet de
Windows (WINS), para responder a las solicitudes de DHCP de los clientes locales detrs de las instalaciones del cliente (CPE).
Previamente, los administradores de red tenan que manualmente configurar el server IOS DHCP de Cisco en cada dispositivo que fuera
habilitado con esta funcion. Despus de que se instalaba un router, ir a cada ubicacin y realizar modificaciones es una tarea trabajosa, costosa y
que requiere tiempo.
Por consiguiente, el servidor Cisco IOS DHCP se ha optimizado para permitir que los datos de configuracin se actualicen automticamente. Los
administradores de red pueden configurar uno o ms servidores DHCP centralizados para actualizar opciones DHCP especficas dentro de los
agrupamientos DHCP. Los servidores remotos pueden solicitar o importar, de los servidores centralizados, estos parmetros de opciones.

Requisitos previos
Requisitos
Cisco recomienda que los lectores de este documento tengan conocimientos sobre los siguientes temas:
DHCP
Sistema de nombres de dominio (DNS)
Servicio de nombres de Internet de Windows (WINS)

Componentes utilizados
Esta configuracin fue desarrollada y probada con las siguientes versiones de software y hardware:
Versin 12.2(27) del software Cisco IOS
Dos routers Cisco 3660 con NM-1E usados para la conexin de PC y clientes
La informacin que contiene este documento se ha creado a partir de los dispositivos en un ambiente de laboratorio especfico. Todos los
dispositivos que se utilizan en este documento se han puesto en funcionamiento con una configuracin despejada (predeterminada). Si la red est
funcionando, asegurese de entender el impacto potencial de cualquier comando.
Nota:: La funcin Servidor Cisco IOS DHCP se ha introducido en la versin 12.0(1)T del software Cisco IOS. Es necesaria la versin 12.0(2)T o
posterior del software Cisco IOS para su uso con los routers Cisco de la serie 1700. Si desea ms informacin sobre los routers compatibles con
la funcin Servidor DHCP, consulte la seccin Plataformas soportadas del documento Servidor Cisco IOS DHCP.

Convenciones
Si desea ms informacin sobre convenciones de documentos, consulte las Convenciones sobre consejos tcnicos de Cisco.

Configurar
En esta seccin, se presenta la informacin para configurar las opciones del servidor DHCP para DNS y WINS. El router 'Central' est
configurado para estas opciones de Servidor, y el router 'Remoto' importa dichas opciones. El PC o cliente remoto recibe estas opciones
importadas del router 'Remoto' durante su etapa DHCPACK.
Nota: Si desea ms informacin sobre los comandos que se utilizan en este documento, consulte el documento Comandos DHCP o use la
herramienta de bsqueda de comandos (solamente clientes registrados).

Diagrama de la red
Este documento utiliza la configuracin de red que se muestra en este diagrama:

Configuraciones
Este documento usa estas configuraciones:
Central (3660)
Central# show running-config
Building configuration...
.
.
.
ip dhcp excluded-address 10.0.0.1 10.0.0.5
!--- No se debe asignar este rango a clientes DHCP.
!
ip dhcp pool Central
network 10.0.0.0 255.255.255.0
!--- Especifique el nmero y la mscara de red para los clientes DHCP.
domain-name Central
!--- Especifique el nombre de dominio del cliente.
dns-server 10.0.0.2
!--- Especifique el servidor DNS que desee que responda a los clientes
!--- DHCP que necesiten correlacionar el nombre de host con
!--- la direccin IP.
netbios-name-server 10.0.0.2
!--- Especifique el Sistema bsico de entrada/salida de red (NetBIOS)
!--- Servidor WINS (para los clientes DHCP de Microsoft)
!
.
.
!
interface FastEthernet0/0
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
.
.
!
end

Remoto (3660)
Remote# show running-config
Building configuration...
.
.
.
ip dhcp excluded-address 192.168.1.1
!--- No se debe asignar esta direccin IP a clientes DHCP.

!
ip dhcp pool Client
import all
!--- Importe los parmetros de opcin DHCP a la base de datos.
network 192.168.1.0 255.255.255.248
!--- Especifique el nmero y la mscara de red para los clientes DHCP.
default-router 192.168.1.1
!--- Especifique la gateway predeterminada de los clientes DHCP.
!
.
.
!
interface FastEthernet0/0
ip address dhcp
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.1.1 255.255.255.248
duplex auto
speed auto
!
end

Verifique
En esta seccin encontrar informacin que puede utilizar para comprobar que su configuracin funciona correctamente.
Ciertos comandos show son compatibles con la herramienta intrprete de resultados (solamente clientes registrados) lo cual le permite ver un anlisis
de resultados de estos comandos show.
show ip dhcp import: Muestra los parmetros de opcin importados a la base de datos del servidor DHCP.
Remoto#show ip dhcp import
Address Pool Name: Client
Domain Name Server(s): 10.0.0.2
NetBIOS Name Server(s): 10.0.0.2
Domain Name Option: Central

show ip dhcp server statistics: Muestra los datos estadsticos del servidor DHCP.
Central#show ip dhcp
Memory usage
Address pools
Database agents
Automatic bindings
Manual bindings
Expired bindings
Malformed messages

server statistics
13906
1
1
1
0
0
0

Message
BOOTREQUEST
DHCPDISCOVER
DHCPREQUEST
DHCPDECLINE
DHCPRELEASE
DHCPINFORM

Received
0
1
1
0
0
0

Message
BOOTREPLY
DHCPOFFER
DHCPACK
DHCPNAK

Sent
0
1
1
0

show ip dhcp binding: Muestra las vinculaciones de direcciones guardadas en el servidor Cisco IOS DHCP.
Central#show ip dhcp binding
IP address
Client-ID/Hardware address
10.0.0.6
0063.6973.636f.2d30.
3036.302e.3563.6634.
2e61.3961.382d.4574.
30

Lease expiration
Apr 25 2005 12:30 AM

Type
Automatic

Resolucin de problemas
En esta seccin encontrar informacin que puede utilizar para solucionar problemas de configuracin.

Comandos para resolucin de problemas


Nota: Antes de ejecutar comandos debug, consulte Informacin importante sobre los comandos de depuracin.
debug ip dhcp server packet: Decodifica las recepciones y transmisiones DHCP.
El resultado tomado de un PC o cliente que tenga un sistema operativo Microsoft Windows con el comando ipconfig /all da los valores de
configuracin de TCP/IP configurados por DHCP.
C:\>ipconfig /all
Windows 2000 IP Configuration
Host Name . . . . . . . . . . . .
Primary DNS Suffix . . . . . . .
Node Type . . . . . . . . . . . .
IP Routing Enabled. . . . . . . .
WINS Proxy Enabled. . . . . . . .
DNS Suffix Search List. . . . . .

:
:
:
:
:
:

PC
cisco.com
Hybrid
No
No
cisco.com

Ethernet adapter Local Area Connection :


Connection-specific DNS Suffix . : Central
Description . . . . . . . . . . : 3Com EtherLink XL 10/100 PCI TX NIC(3C905B-TX)
Physical Address. . . . . . . . : 00-10-5A-86-5A-CA
DHCP Enabled. . . . . . . . . . : Yes
Autoconfiguration Enabled . . . : Yes
Direccin IP. . . . . . . . .: 192.168.1.2
Mscara de subred . . . . . .: 255.255.255.248
Gateway predeterminada . . . : 192.168.1.1
Servidor DHCP . . . . . . . .: 10.0.0.6
Servidores DNS . . . . . . . : 10.0.0.2
Servidor WINS primario . . . : 10.0.0.2
Lease Obtained. . . . . . . . . : Tuesday, April 26, 2005 6:04:29 PM
Lease Expires . . . . . . . .. . : Wednesday, April 27, 2005 6:04:29 PM

1992-2014 Cisco Systems Inc. Todos los Derechos Reservados.


Fecha de Generacin del PDF: 29 Abril 2008
http://www.cisco.com/cisco/web/support/LA/7/75/75853_dhcp_ser.html