Está en la página 1de 2

Materia:DFPRUnidad2Actividad3Diseodeunalgoritmoconestructurasrepetitivas

Disea un algoritmo en pseudocdigo y diagrama de flujo que resuelva el siguiente problema.


Trabajas en un edificio de N pisos que en cada piso cuenta con dos secciones localiza
tu oficina.
A continuacin anexo mi propuesta para la resolucin del problema, en esta actividad me revolv un poco por no
utilizar la estructura repetitiva adecuada, replanteando el problema encontr mi error y he aqu el resultado final.
Ejecucion del programa.

Caso 1, se coloca numero errneo de seccin, se


corrige y se ejecuta el programa indicando cuando
se ha llegado a la oficina.

Caso 2, se coloca numero errneo de piso, se


corrige y se ejecuta el programa indicando cuando
se ha llegado a la oficina.

Pseudocodigo
Proceso Oficina
Escribir "Bienvenido al Elevador Inteligente UnAD"
Escribir 'Usted esta en el Piso 0, Seccion 0 - Lobby'
Mientras s_piso=0 Hacer
Escribir 'Ingresar el piso de tu oficina'
Leer s_piso
FinMientras
Mientras (s_seccion=0) O (s_seccion>2) Hacer
Escribir 'Ingresar la seccion de tu oficina 1 o 2'
Leer s_seccion
FinMientras
seleccion=s_piso*s_seccion
piso=1
seccion=0
Repetir
seccion=seccion+1
Mientras seccion>2 Hacer
seccion=1
piso=piso+1
FinMientras
actual=piso*seccion
Escribir "Piso=",piso," Seccion=",seccion
Hasta Que actual=seleccion
Escribir 'Usted ha llegado a su oficina'
FinProceso

Pgina 1 de 2

Materia:DFPRUnidad2Actividad3Diseodeunalgoritmoconestructurasrepetitivas
Diagrama de Flujo

Pgina 2 de 2