Está en la página 1de 11

Procedimiento de programacin en Excel

Objetivo: Que el programa determine el valor de Q (transferencia de calor) y de h (coeficiente de


transferencia de calo por conveccin)
Paso 1
1.-Designar las casillas para las propiedades que ya debemos conocer

*En la seccin del acomodo, solo podemos poner 1 o 2


De acuerdo a las casillas que ocupan:
Ts

ST

SL

NL

NT

Velocid
ad

acomo
do

C2

E2

E2

F2

G2

H2

I2

J2

A2

B2

2.-Integramos la tabla de propiedades del aire a 1 ATM.


2.- Calcular la temperatura de pelcula Tf= (T S-T )/2 , y las propiedades de la misma.

3.- Calcular la temperatura de pelcula Tf= (T S-T )/2 , y las propiedades de la misma.
Para designar las propiedades, se hace una tabla con una hilera para la informacin
correspondiente a la temperatura menor o igual ms cercana a Ts, otra para la informacin ms
cercana a Ts y otra para la informacin mayor ms cercana a Ts.
La Tf deseada vendra siendo =(A2+B2)/2, esas cantidad se posicionara en la casilla C13.

Para designar la temperatura Tf ms cercana igual o menor, ponemos


=BUSCARV(C13,B73:B113,1) en C12. Esto quiere decir que tiene que buscar el valor de Tf (C13)
requerido en la columna de temperaturas de la matriz, que es la columna B.El 1 quiere decir que
el valor a buscar puede ser aproximado, no necesariamente exacto.
Una vez sabida la temperatura de C12, asignamos el nmero de fila a la que corresponde a ella.
En A12 escribo =COINCIDIR(C12,B73:B113)
Ya sabiendo la fila a la que pertenece, utilizaremos la funcin
INDICE(rango de columna deseado, fila deseada)

Para calcular la densidad igual o menor para Tf, ponemos en la casilla D12,
=INDICE(C73:C113,A12)

Para calcular Calor esp. igual o menor para Tf, ponemos en la casilla E12,
=INDICE(D73:D113,A12)

Para calcular la k igual o menor para Tf, ponemos en la casilla F12,


=INDICE(E73:E113,A12)

Para calcular la

igual o menor para Tf, ponemos en la casilla G12,

=INDICE(F73:F113,A12)

Para calcular la

igual o menor para Tf, ponemos en la casilla H12,

=INDICE(G73:G113,A12)

Para calcular la

igual o menor para Tf, ponemos en la casilla I12,

=INDICE(H73:H113,A12)

Para calcular el Pr igual o menor para Tf, ponemos en la casilla J12,


=INDICE(I73:I113,A12)

Para hacer lo mismo en la fila de la temperatura mayor ms cercana a la Tf, ponemos en la


casilla de la fila ubicada (A14), =A12+1.
Si nos encontramos que la Tf es igual a 2000, ese es un valor que no incluye nuestra tabla por lo
que pondremos que diga Nada en las propiedades subsecuentes.
Para la temperatura mayor cercana aTf, pondr en la casilla C14,
=SI(C13=2000,NADA,INDICE(B73:B113,A14))

Para la densidad mayor cercana a Tf, pondr en la casilla D14,


=SI(C13=2000,NADA,INDICE(C73:C113,A14))

Para el cp mayor cercana aTf, pondr en la casilla E14,


=SI(C13=2000,NADA,INDICE(D73:D113,A14))

Para la K mayor cercana a Tf, pondr en la casilla F14,


=SI(C13=2000,NADA,INDICE(E73:E113,A14))

Para la

mayor cercana a Tf, pondr en la casilla G14,

=SI(C13=2000,NADA,INDICE(F73:F113,A14))

Para la

mayor cercana a Tf, pondr en la casilla H14,

=SI(C13=2000,NADA,INDICE(G73:G113,A14))

Para la Visc. Cinematica mayor cercana a Tf, en la casilla I14,


=SI(C13=2000,NADA,INDICE(H73:H113,A14))

Para Pr mayor cercano a Tf, pondr en la casilla J14,


=SI(C13=2000,NADA,INDICE(I73:I113,A14))

4.- para interpolar los datos ya obtenidos para los valores mayores y menores de Tf en caso de
no encontrarse exactas en la tabla.
La frmula de interpolacin es y=y0+((x-x0)/(x1-x1))(y1-y0), x vendran siendo las
temperaturas en todos los casos y las propiedades corexpondientes seran las y. En caso de que
salga 2000 la Tf, debe quedar directo a lo que dice la parte de arriba.
Para la densidad a Tf , en la casilla D13,=SI(C13=2000,D12,D12+(((C13-C12)/(C14-C12))*(D14D12)))

Para el cp a Tf , en la casilla E13,=SI(C13=2000,E12,E12+(((C13-C12)/(C14-C12))*(E14-E12)))

Para la K a Tf , en la casilla F13=SI(C13=2000,F12,F12+(((C13-C12)/(C14-C12))*(F14-F12)))

Para la

a Tf , en la casilla G13,=SI(C13=2000,G12,G12+(((C13-C12)/(C14-C12))*(G14-G12)))

Para la

a Tf , en la casilla H13=SI(C13=2000,H12,H12+(((C13-C12)/(C14-C12))*(H14-H12)))

Para la

a Tf , en la casilla I13,=SI(C13=2000,I12,I12+(((C13-C12)/(C14-C12))*(I14-I12)))

Para Pr densidad a Tf , en la casilla J13,=SI(C13=2000,J12,J12+(((C13-C12)/(C14-C12))*(J14J12)))

5.- Obtencin del Prs asease, Pr a Ts.


La casilla C17 es la que tendr la temperatura del solido

Para proceder a interpolar, en la casilla C16, poner =BUSCARV(C17,B73:B113,1), en la casilla


A16 poner =COINCIDIR(C16,B73:B113). Una vez obtenida la casilla D17 poner
=INDICE(I73:I113,A16).
Para la casilla A18, es necesario poner la una fila de ms que la del Ts menor o igual, poner
=A16+1.
Para obtener la temperatura mayor ms cercana a Ts poner en la casilla C18, poner
=SI(C17=2000,NADA,INDICE(B73:B113,A18)). Ya obtenida esa temperatura, poner en la casilla
de al lado, poner =INDICE(I73:I113,A16).
6.- Definir SD
SD se pondr en la casilla B19. En esa casilla poner =((F2^2)+((0.5*E2)^2))^0.5
7.- Definir en una casilla la velocidad a usar para alineados y en otra la de escalonados.

En la casilla B20 poner la de velocidad alineada y si no aplica dependiendo si en J2 dice 1 (para


alineada) o 2 (para escalonados).
=SI(J2=1,((E2)/(E2-D2))*(I2),No aplica)
Para la velocidad en escalonados, ponerla en la casilla B23:
=SI(J2=2,(SI(B19<(0.5*(E2+D2)),((E2/(2*(B19-D2)))*I2),((E2)/(E2-D2))*(I2))),No aplica)

7.- Calcular ReD: Usare la formula


Ponerla en la casilla E20:
=SI(B23=No aplica,((D2)*(B20)*(D13))/(H13),((D2)*(B23)*D13)/(H13))
8.-Calular NuD:

=0.9*((E20)^0.4)*((J13)^0.36)*(J13/D17)^0.25

=0.52*((E20)^0.5)*((J13)^0.36)*(J13/D17)^0.25

=0.27*((E20)^0.63)*((J13)^0.36)*(J13/D17)^0.25

=0.033*((E20)^0.8)*((J13)^0.4)*(J13/D17)^0.25

=1.04*((E20)^0.4)*((J13)^0.36)*(J13/D17)^0.25

=0.71*((E20)^0.5)*((J13)^0.36)*(J13/D17)^0.25

=0.35*((E2/F2)^0.2)*((E20)^0.6)*((J13)^0.36*(J13/D17)^0.25)

=0.031*((E2/F2)^0.2)*((E20)^0.8)*((J13)^0.36*(J13/D17)^0.25)

NL
Alineado
s
Escalona
dos

1
0.7

2
0.8

0.6
4

0.7
6

3
0.8
6
0.8
4

4
0.9
0.8
9

5
0.9
3
0.9
3

6
0.94
5
0.94
5

7
0.9
6
0.9
6

8
0.96
6
0.96
6

9
0.97
3
0.97
3

10
0.9
8
0.9
8

11
0.98
3
0.98
3

12
0.98
6
0.98
6

13
0.9
9
0.9
9

14
1.01
41
1.01
91

15
1.03
83
1.04
83

16
1.06
25
1.07
75

Para poder escoger el NuD correcto, pondr los diferentes rangos de ReD, poniendo si aplica o no
para el ReD obtenido, de forma que solo se logre una sola cantidad numrica, para alineados y
escalonados.
NuD (Columna B) NuD (Columna C)
Alineado
51 RED VA DE 0-100

=SI(Y(0<E20,E20<100), D30,NO APLICA)


=SI(Y(100<=E20,E20<=500),D31,NO
52 RED VA DE 100-500
APLICA)
=SI(Y(500<=E20,E20<1000),D31,NO
53 RED VA DE 500-1000 APLICA)
54 RED VA DE 1000=SI(Y(1000<=E20,E20<200000),D32,NO
20000
APLICA)
=SI(Y(200000<=E20,E20<=2000000),D33,
55 RED VA DE 200000-2000000 NO APLICA)

Escalonado
=SI(Y(0<E20,E20<100),D37,NO APLICA)
=SI(Y(100<=E20,E20<500),D37,NO
APLICA)
=SI(Y(500<=E20,E20<1000),D38,NO
APLICA)
=SI(Y(1000<=E20,E20<200000),D39,NO
APLICA)
=SI(Y(200000<=E20,E20<=2000000),D40,
NO APLICA)

Para poder designar el valor a usar en los alineados buscare el nmero mayor, ya que solo habr
una cantidad por columna y las otras dirn no aplica.

=MAX(B51:B55)

=MAX(C51:C55)

Para designar el factor que hay que usar ser 1 si NL es mayor de 16 y si no habr que usar los
que correspondan de acuerdo a la tabla 7-3.
=SI(G2>16,1,INDICE(B43:Q43,G2))

=SI(G2>16,1,INDICE(B44:Q44,G2))

Los valores ya con todo y el factor, solo seran cuestin de multiplicar las casillas =B56*B57 y
=C56*C57, poniendo esas ecuaciones en las casillas B58 Y C58 respectivamente.

Para escoger el valor final de NuD, usamos un condicional, dependiendo si es alineado o no.
Pondremos en la casilla B63
= SI(J2=1,B58,C58)
8.- Determinar h
Escogi que la celda G4 tuviera ese valor siendo = (B63*F13)/D2. Eso es ( NuD*k)/ dimetro.
9.-Para determinar el Q transfererido, ocupo las siguientes propiedades

Propiedad
As
Flujo
msico
Te

Tml
N

casill
a
A8
B8

Formula

C8

=A2-(A2-B2)*(EXP((-A8*G4)/
(B8*E13)))
=((A2-C8)-(A2-B2))/(LN((A2-C8)/(A2B2)))
=G2*H2

D8
E8

=E8*(PI())*D2*C2
=D13*I2*(H2*E2*C2)

9.- Obtener Q
Ya con las propiedades poner en la casilla G5, =As*h* Tml, ==G4*A8*D8.