Está en la página 1de 199

Voz y Video sobre IP

(TEVV03)

Voz y Video sobre IP (TEVV03)

Profesor:

Luis Flores

Profesor: Luis Flores Ingeniero en Telecomunicaciones, Conectividad y Redes CCNA (Cisco Certified Network Associate) CCIP

Ingeniero en Telecomunicaciones, Conectividad y Redes

CCNA (Cisco Certified Network Associate) CCIP (Cisco Certified Internetwork Professional)

CSCO10657424

20 años de experiencia en Telecomunicaciones.

luis.flores63@inacapmail.cl

DESCRIPCIÓN DE LA ASIGNATURA:

DESCRIPCIÓN DE LA ASIGNATURA: Asignatura práctica de especialidad cuyo propósito es desarrollar aprendizajes en la

Asignatura práctica de especialidad cuyo propósito es desarrollar aprendizajes en la instalación, operación de sistemas de telecomunicaciones integrados de voz y video.

La asignatura entrega conocimientos en hardware y software destinados a la codificación de voz y video para su aplicación en sistemas de telefonía y video sobre redes IP.

Estas capacidades permitirán además, dar asistencia y asesoramiento técnico a la comercialización de soluciones de este tipo a clientes; así como también, la documentación técnica asociada.

La metodología considera actividades prácticas, clases expositivas con demostraciones, implementación de servicios de voz y video y solución de ejercicios y problemas.

COMPETENCIAS:

COMPETENCIAS: Instala hardware, software y conexiones asociadas, mediante el uso de instructivos, manuales, normas

Instala hardware, software y conexiones asociadas, mediante el uso de instructivos, manuales,

normas técnicas y herramientas de instalación; a través de pruebas y corrección de fallas de funcionamiento satisface las solicitudes de usuarios o clientes; contribuyendo, en caso de ser

necesario, con la investigación de problemas y fallas relacionadas con la instalación.

  UNIDADES 1 Fundamentos de tecnologías y servicios de comunicaciones de voz y video 25
 

UNIDADES

1

Fundamentos de tecnologías y servicios de comunicaciones de voz y video

25 %

2

Componentes y equipos para soluciones de voz y video sobre red IP.

25%

3

Instalación y operación de sistemas de telefonía y video sobre redes IP.

25

%

4

Asistencia técnica a la comercialización de soluciones de telefonía y video sobre redes IP. Asistencia

25

%

Voz IP

Voz IP

Voz IP

Códec

Códec La voz debe codificarse para poder ser transmitida por la red IP. Para ello se

La voz debe codificarse para poder ser transmitida por la red IP.

Para ello se hace uso de códecs que garantizan la codificación y compresión del audio o del

video para su posterior decodificación y descompresión antes de poder generar un sonido o imagen utilizable.

Estos Codecs tienen los siguientes anchos de banda de codificación:

antes de poder generar un sonido o imagen utilizable. Estos Codecs tienen los siguientes anchos de

Códecs

Códecs
Códecs

Requisitos de una Red :

1)

Ancho de Banda

2)

Latencia < 150ms

3)

Jitter < 100ms

4)

Pérdida de paquetes < 1%

Estándar de QoS y SLA.

Protocolos y señalización: H248, H323 y SIP.

4) Pérdida de paquetes < 1%  Estándar de QoS y SLA.  Protocolos y señalización:

Requisitos de una Red

SIP (Session Initiation Protocol )

Requisitos de una Red SIP (Session Initiation Protocol ) El protocolo SIP se concentra en el

El protocolo SIP se concentra en el establecimiento, modificación y terminación de las sesiones.

Las funciones básicas del protocolo incluyen:

Determinar la ubicación de los usuarios, aportando movilidad. Establecer, modificar y terminar sesiones multipartitas entre usuarios.

Los servidores, por defecto, utilizan el puerto 5060 en TCP (Transmission Control

Protocol) y UDP (User Datagram Protocol) para recibir las peticiones de los clientes

SIP. En caso de mandar la señalización encriptada, SIP usa el puerto 5061.

Funcionamiento del SIP

1.

Agentes de Usuario

2.

Servidores de Registro o Registrar

3.

Servidores Proxy y de Redirección

SIP 1. Agentes de Usuario 2. Servidores de Registro o Registrar 3. Servidores Proxy y de

El Cliente

El Cliente El cliente establece y origina las llamadas voz, esta información se recibe a través

El cliente establece y origina las llamadas voz, esta información se recibe a través del micrófono del usuario (entrada de información )se codifica, se encapsula y, de la misma forma, esta información se decodifica.

Un cliente puede ser:

ATAs (Adaptadores de teléfonos analógicos)

Teléfonos IP

Softphones

información se decodifica. Un cliente puede ser: ATAs (Adaptadores de teléfonos analógicos) Teléfonos IP Softphones

Los Gateways

Los Gateways Brindan un puente de comunicación entre todos los usuarios, su función principal es la

Brindan un puente de comunicación entre todos los usuarios, su función principal es

la de proveer interfaces con la telefonía tradicional adecuada, la cual funcionara

como una plataforma para los usuarios (clientes) virtuales.

con la telefonía tradicional adecuada, la cual funcionara como una plataforma para los usuarios (clientes) virtuales.

Los Servidores

Los Servidores Los servidores se encargan de manejar operaciones de base de datos, realizado en un

Los servidores se encargan de manejar operaciones de base de datos, realizado en

un tiempo real como en uno fuera de él.

Entre estas operaciones: el enrutamiento, la administración y control del servicio, el registro de los usuarios.

de él. Entre estas operaciones: el enrutamiento, la administración y control del servicio, el registro de

Solución de Voz IP

Solución de Voz IP
Solución de Voz IP

Voz y Video sobre IP

Voz y Video sobre IP

IP

IP Una dirección IP es una etiqueta numérica que identifica, de manera lógica y jerárquica, a

Una dirección IP es una etiqueta numérica que identifica, de manera lógica y

jerárquica, a una interfaz de un dispositivo.

Direcciones IPv4

Las direcciones IPv4 se expresan por un número binario de 32 bits, permitiendo un espacio de direcciones de hasta 4.294.967.296 (2 32 ) direcciones posibles.

binario de 32 bits, permitiendo un espacio de direcciones de hasta 4.294.967.296 (2 3 2 )

Direcciones IPv6

Direcciones IPv6 La función de la dirección IPv6 es exactamente la misma que la de su

La función de la dirección IPv6 es exactamente la misma que la de su predecesor IPv4,

pero dentro del protocolo IPv6.

Está compuesta por 128 bits y se expresa en una notación hexadecimal de 32 dígitos.

Ejemplo: 2001:0123:0004:00ab:0cde:3403:0001:0063

Datagrama IPv6

Head

Datagrama IPv6 Head
Datagrama IPv6 Head

Cuales son los requisitos de la red para Voz IP ?

Cuales son los requisitos de la red para Voz IP ?

Ancho de Banda:

Ancho de Banda: En telecomunicaciones, es el bit rate o tasa de transferencia que define el

En telecomunicaciones, es el bit rate o tasa de transferencia que define el número de bits que se transmiten por unidad de tiempo a través de un

dispositivo.

kbit/s o kbps (kb/s, kilobit/s o mil bits por segundo)

Mbit/s o Mbps(Mb/s, Megabit/s o un millón de bits por segundo)

Gbit/s o Gbps (Gb/s, Gigabit, mil millones de bits)

Ancho de Banda:

Tasas de bits de compresión a MP3:

Ancho de Banda: Tasas de bits de compresión a MP3: 4 kbit/s Mínimo para reconocer el

4 kbit/s Mínimo para reconocer el habla.

8 kbit/s Calidad telefónica convencional

32 kbit/s Radio AM

96 kbit/s Radio FM 128 kbit/s Sonido calidad semi CD, muy común en MP3

192 kbit/s Sonido calidad CD en formato MP3

320 kbit/s Máxima calidad para formato MP3

Ancho de Banda:

Netflix

Ancho de Banda: Netflix 0,5 megabits por segundo: velocidad de conexión de banda ancha requerida 1,5

0,5 megabits por segundo: velocidad de conexión de banda ancha requerida

1,5 megabits por segundo: velocidad de conexión de banda ancha recomendada

3 megabits por segundo: velocidad recomendada para calidad de DVD

5 megabits por segundo: velocidad recomendada para calidad HD

7.0 megabits por segundo: velocidad recomendada para calidad Super HD

12 megabits por segundo: velocidad recomendada para calidad 3D

Calidad de video HD

Las películas y series disponibles en alta definición se reproducen en 720p, o una

calidad superior, con una conexión a Internet suficientemente rápida.

Latencia (Delay):

Latencia (Delay): La “latencia” se refiere a cualquier tipo de periodos de inactividad y retrasos producidos

La “latencia” se refiere a cualquier tipo de periodos de inactividad y retrasos producidos durante la transmisión de paquetes de datos y el procesamiento de

datos recibidos o preparados para ser enviados.

A menudo se puede encontrar también la noción de 'lag' ('retraso' en ingles), muy

popular en los círculos de aficionados a los juegos.

Latencia (Delay):

Juegos de ordenador .

Latencia (Delay): Juegos de ordenador . La experiencia demuestra que un retraso de 100 milisegundos es

La experiencia demuestra que un retraso de 100 milisegundos es todavía aceptable,

no obstante por encima de ese límite, especialmente en el caso de los juegos de

acción rápida, tales retrasos pueden dificultar el juego.

Video - ver películas en línea, como por ejemplo mediante el servicio de YouTube

requiere un nivel de la velocidad de transmisión relativamente alto.

Latencia de 300-500 milisegundos podría resultar en las interrupciones de la película, la pérdida de sincronización entre imagen y sonido, o en algunos casos

causar la distorsión de imagen.

Jitter:

Jitter: Se denomina jitter en ingles fluctuación, a la variabilidad temporal durante el envío de señales

Se denomina jitter en ingles fluctuación, a la variabilidad temporal durante el

envío de señales digitales.

El jitter suele considerarse como una señal de ruido no deseada.

En las telecomunicaciones se denomina jitter a la variabilidad del tiempo de

ejecución de los paquetes.

Este efecto es especialmente molesto en aplicaciones multimedia en Internet

como radio por Internet o telefonía IP, ya que provoca que algunos paquetes

lleguen demasiado pronto o tarde para poder entregarlos a tiempo.

El efecto puede reducirse con un búfer de jitter, un búfer de datos, pero a costa de un tiempo de ejecución mayor.

Si el jitter es demasiado grande, no puede asegurarse que las informaciones

críticas de proceso lleguen a tiempo.

Jitter:

Jitter:
Jitter:

Packet loss:

Packet loss:
Packet loss:

Requerimientos.

Requerimientos. 1) Empresa ACME necesita habilitar VoIP para 40 usuarios. 2) Actualmente tiene un enlace de

1)

Empresa ACME necesita habilitar VoIP para 40 usuarios.

2)

Actualmente tiene un enlace de 10Mbps

3)

40 computadores que cada uno utiliza de ancho de banda 600Kbps para Internet.

4)

1 Servidores web que utiliza de ancho de banda 1Mbps

Es necesario aplicar Calidad de Servicio?

Si es si,

Cuanto de ancho de banda es necesario para 20 teléfonos IP utilizando simultáneamente el servicio de voz con el Códec G.711?

Cuanto es el ancho de banda que quedarían los computadores tomando en

cuenta que también hay que asegurar el ancho de banda al Servidor?

Con cuantas colas QoS (Queue) quedaría la solución.?

Requerimientos.

Requerimientos. 1) Empresa ACME necesita habilitar VoIP para 50 usuarios. 2) Actualmente tiene un enlace de

1)

Empresa ACME necesita habilitar VoIP para 50 usuarios.

2)

Actualmente tiene un enlace de 20Mbps

3)

50 computadores que cada uno utiliza de ancho de banda 630Kbps para Internet.

4)

5 Servidores web que utiliza de ancho de banda 2,5Mbps

5)

Tambien se transmite un canal institucional en calidad HD.

Es necesario aplicar Calidad de Servicio?

Si es si,

Cuanto de ancho de banda es necesario para asegurar el correcto funcionamiento Del servicio de voz para 50 teléfonos IP, pero solo 25 usuarios hablando a la vez

con el Códec G.711 ?

Cuanto es el ancho de banda necesario para asegurar el correcto funcionamiento del canal institucional ?

Con cuantas colas QoS (Queue) quedaría la solución.?

QoS

Calidad de Servicio

QoS Calidad de Servicio Voz 2.5 Mbps y priorizamos Canal de videos (streaming) 5 Mbps Servidores,
QoS Calidad de Servicio Voz 2.5 Mbps y priorizamos Canal de videos (streaming) 5 Mbps Servidores,

Voz 2.5 Mbps y priorizamos

Canal de videos (streaming)

5 Mbps

Servidores, Intranet 2,5 Mbps

Best Effort

QoS

Calidad de Servicio

QoS Calidad de Servicio Asterisk Voz 2.5 Mbps y priorizamos Canal de videos (streaming) 5 Mbps

Asterisk

Voz 2.5 Mbps y priorizamos Canal de videos (streaming) 5 Mbps Servidores, Intranet 2,5 Mbps
Voz 2.5 Mbps
y priorizamos
Canal de videos (streaming)
5 Mbps
Servidores, Intranet
2,5 Mbps
Best Effort
Router
ACME
100 Mbps
20 Mbps
MPLS
F0/1.10
F0/1.20
100 Mbps
Vlan de voz
Vlan de datos
20
Internet
10

Servidor

Streaming

Mbps Vlan de voz Vlan de datos 20 Internet 10 Servidor Streaming IP Multicast 224.10.10.10 10.10.10.0/24

IP Multicast

224.10.10.10

10.10.10.0/24

Servidores

QoS

QoS

Calidad de Servicio

Interfaces

class-map match-all voz

interface FastEthernet0/0

match input-interface FastEthernet0/1.20

description WAN_MPLS

class-map match-all datos match input-interface FastEthernet0/1.10

ip address 200.200.200.10 255.255.255.0 service-policy output QoS duplex auto

speed auto

class-map match-all servidores

!

match access-group 10

interface FastEthernet0/1

class-map match-all video match access-group 20

no ip address duplex auto speed auto

!

shutdown

policy-map QoS

!

auto speed auto ! shutdown policy-map QoS ! Acces-list access-list 10 permit 10.10.10.0 0.0.0.255

Acces-list

access-list 10 permit 10.10.10.0 0.0.0.255 access-list 20 permit host 224.10.10.10

class voz

interface FastEthernet0/1.10

priority 2500

description vlan_datos

class video

encapsulation dot1Q 10

bandwidth 5000

ip address 1.1.1.1 255.255.255.0

class servidores

!

bandwidth 2500

interface FastEthernet0/1.20

class datos

description vlan_voz encapsulation dot1Q 20

IP ROUTE 0.0.0.0. 0.0.0.0 200.200.200.100

!

ip address 2.2.2.1 255.255.255.0

!

interface FastEthernet1/0

description Servidores

ip address 10.10.10.1 255.255.255.0

duplex auto

speed auto

Cisco IOS IP SLAs

Cisco IOS IP SLAs Delay (both round-trip and one-way) Packet sequencing (packet ordering) Jitter (directional)
Cisco IOS IP SLAs Delay (both round-trip and one-way) Packet sequencing (packet ordering) Jitter (directional)

Delay (both round-trip and one-way)

Packet sequencing (packet ordering)

Jitter (directional)

Path (per hop)

Packet loss (directional)

Connectivity (directional)

 

Server or website download time

Cisco IOS IP SLAs

Cisco IOS IP SLAs
Cisco IOS IP SLAs

Cisco IOS IP SLAs

Switch(config)# ip sla 12

Cisco IOS IP SLAs Switch(config)# ip sla 12 Switch(config-ip-sla)# icmp-echo 172.29.139.134 Switch(config-ip-sla-echo)#

Switch(config-ip-sla)# icmp-echo 172.29.139.134

Switch(config-ip-sla-echo)# frequency 30

Switch(config-ip-sla-echo)# exit

Switch(config)# ip sla schedule 5 start-time now life forever

Switch(config)# end

QoS

Calidad de Servicio

QoS Calidad de Servicio Asterisk Voz 2.5 Mbps y priorizamos Canal de videos (streaming) 5 Mbps

Asterisk

Voz 2.5 Mbps y priorizamos Canal de videos (streaming) 5 Mbps Servidores, Intranet 2,5 Mbps
Voz 2.5 Mbps
y priorizamos
Canal de videos (streaming)
5 Mbps
Servidores, Intranet
2,5 Mbps
Best Effort
Router
ACME
100 Mbps
20 Mbps
MPLS
F0/1.10
F0/1.20
100 Mbps
Vlan de voz
Vlan de datos
20
Internet
10

Servidor

Streaming

Mbps Vlan de voz Vlan de datos 20 Internet 10 Servidor Streaming IP Multicast 224.10.10.10 10.10.10.0/24

IP Multicast

224.10.10.10

10.10.10.0/24

Servidores

class-map match-all voz

match access-group name VOZ

class-map match-all datos match access-group name DATOS

class-map match-all servidores match access-group 10

class-map match-all video

match access-group 20

!

policy-map QoS

class voz

priority 2500

class video bandwidth 5000

class servidores

bandwidth 2500

class datos

!

Cisco IOS QoS

VoIP

servidores bandwidth 2500 class datos ! Cisco IOS QoS VoIP access-list 10 permit 10.10.10.0 0.0.0.255 access-list

access-list 10 permit 10.10.10.0 0.0.0.255

access-list 20 permit host 224.10.10.10 ip access-list standard VOZ

permit 2.2.2.0 0.0.0.255

ip access-list standard DATOS permit 1.1.1.0 0.0.0.255

interface FastEthernet0/0 description WAN_MPLS

bandwidth 20000

ip address 200.200.200.1 255.255.255.0 service-policy output QoS

duplex auto speed auto

!

interface FastEthernet0/1 no ip address

duplex auto

speed auto

!

Cisco IOS QoS VoIP

no ip address duplex auto speed auto ! Cisco IOS QoS VoIP interface FastEthernet0/1.10 description vlan_datos

interface FastEthernet0/1.10

description vlan_datos

encapsulation dot1Q 10

ip address 1.1.1.1 255.255.255.0

!

interface FastEthernet0/1.20

description vlan_voz

encapsulation dot1Q 20

ip address 2.2.2.1 255.255.255.0

!

interface FastEthernet1/0

description Servidores

ip address 10.10.10.1 255.255.255.0

duplex auto speed auto

1.1.1.0/24 2.2.2.0/24 Red Datos Red Voz SW 4 F0/1.10 F0/1.10 F0/1.10 F0/1.10 F0/1.10 F0/1.20 F0/1.20
1.1.1.0/24
2.2.2.0/24
Red Datos
Red Voz
SW 4
F0/1.10
F0/1.10
F0/1.10
F0/1.10
F0/1.10
F0/1.20
F0/1.20
F0/1.20
F0/1.20
F0/1.20

.10

F0

.11

F0

.12

F0

.13

F0

.14

F0

200.200.200.0/24

Red Wan

SW 3

RTP/RTCP RTP Real-time Transport Protocol.

RTP/RTCP RTP Real-time Transport Protocol. Es un estándar creado por la IETF para la transmisión confiable

Es un estándar creado por la IETF para la transmisión confiable de voz y video a través de Internet.

RTP es transportado usando UDP.

RTP implementa dos mecanismos principales para garantizar una transmisión de voz:

El uso de Número de secuencia y un Registro de tiempo.

RTP/RTCP RTP Real-time Transport Protocol.

RTP/RTCP RTP Real-time Transport Protocol. Los campos más importantes en el encabezado RTP son los siguientes:

Los campos más importantes en el encabezado RTP son los siguientes:

Número de secuencia: de 2 bytes, es un número que se incrementa por cada paquete enviado.

Es usado para determinar pérdida de paquetes y recuperar correctamente la secuencia de voz.

Registro de tiempo: Mejor conocido como Timestamp, es un campo de 32 bits asignado en el momento del envío con base en un reloj del sistema.

El valor inicial es seleccionado aleatoriamente para evitar confusión con otras secuencias RTP

presentes.

Existe la posibilidad de sincronizar los relojes de envío y recepción usando el protocolo NTP.

RTP/RTCP RTP Real-time Transport Protocol.

RTP/RTCP RTP Real-time Transport Protocol.
RTP/RTCP RTP Real-time Transport Protocol.

RTP/RTCP RTP Real-time Transport Protocol.

RTP/RTCP RTP Real-time Transport Protocol.
RTP/RTCP RTP Real-time Transport Protocol.

RTP/RTCP RTP Real-time Transport Protocol.

RTP/RTCP RTP Real-time Transport Protocol.
RTP/RTCP RTP Real-time Transport Protocol.
En aplicaciones de Voz sobre IP los protocolos utilizados son: RTP: es el protocolo responsable

En aplicaciones de Voz sobre IP los protocolos utilizados son:

RTP: es el protocolo responsable de la transmisión de los datos.

CODEC : Realiza digitalización y compresión de la voz y el video

SIP: Para el manejo de señalización o establecimiento de llamada existe.

Requerimientos.

1) Empresa Interec necesita habilitar VoIP para 50 usuarios.

1) Empresa Interec necesita habilitar VoIP para 50 usuarios. 2) Actualmente tiene un enlace de 25Mbps

2) Actualmente tiene un enlace de 25Mbps

3) 50 computadores que cada uno utiliza de ancho de banda 615Kbps para Internet. 4) 5 Servidores web que utiliza de ancho de banda 2,5Mbps

5) Tambien se transmite un canal institucional en calidad FULL HD.

Es necesario aplicar Calidad de Servicio?

Si es si,

Cuanto de ancho de banda es necesario para asegurar el correcto funcionamiento Del servicio de voz para 50 teléfonos IP, pero solo 30 usuarios hablando a la vez con el Códec G.711 ?

Cuanto es el ancho de banda necesario para asegurar el correcto

funcionamiento del canal institucional ?

Con cuantas colas QoS (Queue) quedaría la solución.?

Solución

Solución Voz 3Mbps y priorizamos Canal de videos (streaming) 7 Mbps Servidores, Intranet 2,5 Mbps Datos

Voz 3Mbps

y priorizamos

Canal de videos (streaming)

7 Mbps

Servidores, Intranet

2,5 Mbps

Datos

Best Effort

Solución Voz 3Mbps y priorizamos Canal de videos (streaming) 7 Mbps Servidores, Intranet 2,5 Mbps Datos

Solución

Solución Asterisk Gateway Voz 3Mbps y priorizamos Servidor Streaming y Video Canal de videos (streaming) 5
Asterisk Gateway Voz 3Mbps y priorizamos Servidor Streaming y Video Canal de videos (streaming) 5
Asterisk
Gateway
Voz 3Mbps
y priorizamos
Servidor
Streaming y Video
Canal de videos (streaming)
5 Mbps
Servidores, Intranet
2,5 Mbps
Datos
Best Effort
Router
IP Multicast
ACME
200.200.200.0/24
224.10.10.10
100 Mbps
25 Mbps
MPLS
100.100.100.0/24
F0/1.10
F0/1.20
100 Mbps
Vlan de datos ID 10
10.10.10.0/24
Servidores
Vlan de voz ID 20
20.20.20.0/24
Internet

Solución

Pasos para configurar QoS:

1.

Listas de acceso

2.

Class Map

3.

Policy Map

4.

Aplicar QoS

Solución Pasos para configurar QoS: 1. Listas de acceso 2. Class Map 3. Policy Map 4.

1. Lista de accesos

ip access-list standard VOZ

permit 20.20.20.0 0.0.0.255

ip access-list standard DATOS permit 10.10.10.0 0.0.0.255

ip access-list standard SERVIDORES permit 100.100.100.0 0.0.0.255

ip access-list standard CANAL

permit host 224.10.10.10

Solución

standard SERVIDORES permit 100.100.100.0 0.0.0.255 ip access-list standard CANAL permit host 224.10.10.10 Solución
standard SERVIDORES permit 100.100.100.0 0.0.0.255 ip access-list standard CANAL permit host 224.10.10.10 Solución

2. Class Map

Solución

2. Class Map Solución class-map match-all voz match access-group name VOZ class-map match-all datos match access-group

class-map match-all voz

match access-group name VOZ

class-map match-all datos match access-group name DATOS

class-map match-all servidores match access-group name SERVIDORES

class-map match-all video match access-group name CANAL

match-all servidores match access-group name SERVIDORES class-map match-all video match access-group name CANAL

3. Policy Map

policy-map QoS class voz priority 3000

class video bandwidth 5000

class servidores

bandwidth 2500

class datos

Solución

policy-map QoS class voz priority 3000 class video bandwidth 5000 class servidores bandwidth 2500 class datos
policy-map QoS class voz priority 3000 class video bandwidth 5000 class servidores bandwidth 2500 class datos

4. Aplicar QoS

Solución

interface FastEthernet0/0

description WAN_MPLS

bandwidth 25000 ip address 200.200.200.1 255.255.255.0

service-policy output QoS

duplex auto speed auto

!

WAN_MPLS bandwidth 25000 ip address 200.200.200.1 255.255.255.0 service-policy output QoS duplex auto speed auto !

Ejercicio en Clases

Ejercicio en Clases 1. Cuales son los protocolos necesarios para VoIP e indique sus características? 2.

1.

Cuales son los protocolos necesarios para VoIP e indique sus características?

2.

Indique los Códec para VoIP y sus características.

3.

Cuales son los parámetros necesarios o requisitos para asegurar la VoIP en una red?

4.

Indique los pasos para configurar QoS en un router

5.

Indique las diferencias de unicast y multicast

6.

Indique el Wilcard:

192.168.123.128 255.255.255.128

192.168.123.0 255.255.255.0

192.168.123.0 255.255.255.248

192.168.123.16 255.255.255.240

Cisco Call Manager (CCM),

Cisco Call Manager (CCM), Es un software basado en un sistema para administrar telefonía sobre IP,

Es un software basado en un sistema para administrar telefonía sobre IP, desarrollado

por Cisco Systems.

Manager (CCM), Es un software basado en un sistema para administrar telefonía sobre IP, desarrollado por

Cisco Call Manager Express

Cisco Call Manager Express
Cisco Call Manager Express

DATOS VLAN 10

10.10.10.0/25

VOZ VLAN 20

20.20.20.0/25

192.168.123.10/24

192.168.123.1/24

LAB PT

VoIP

192.168.123.4/24

EIGRP 123

192.168.123.2/24

. 1 6 8 . 1 2 3 . 4 / 2 4 EIGRP 123 192.168.123.2/24

DATOS VLAN 10

10.10.10.128/25

VOZ VLAN 20

20.20.20.128/25

IPTV La Televisión sobre el Protocolo IP o IPTV video-streaming Es una tecnología que permite
IPTV La Televisión sobre el Protocolo IP o IPTV video-streaming Es una tecnología que permite
IPTV
IPTV

La Televisión sobre el Protocolo IP o IPTV video-streaming

Es una tecnología que permite que los servicios de televisión sean

emitidos a través de la banda ancha de una red de paquete de

datos privados, usando el protocolo IP.

IPTV La Televisión sobre el Protocolo IP o IPTV Por otra parte, la Televisión por
IPTV La Televisión sobre el Protocolo IP o IPTV Por otra parte, la Televisión por
IPTV
IPTV

La Televisión sobre el Protocolo IP o IPTV

Por otra parte, la Televisión por Internet o Televisión

Online (Internet TV) es un servicio de transmisión de televisión

distribuido a través de la Internet.

Muchas veces la IPTV es confundida con la emisión de la Televisión por Internet.

IPTV TV Cable Banda Ancha TV Online Internet Multicast Unicast Decodificador digital Pc, Tablet;
IPTV TV Cable Banda Ancha TV Online Internet Multicast Unicast Decodificador digital Pc, Tablet;
IPTV
IPTV

TV Cable Banda Ancha

TV Online Internet

Multicast

Unicast

Decodificador digital

Pc, Tablet; Smartphone

Red Privada del Proveedor

Internet

Pago

Gratis

Calidad de Servicio

Sin Calidad de Servicio

IPTV Podemos diferenciar dos tipos de canal: Definición estándar SDTV 1.5 Mbps Alta definición HDTV.
IPTV Podemos diferenciar dos tipos de canal: Definición estándar SDTV 1.5 Mbps Alta definición HDTV.
IPTV
IPTV

Podemos diferenciar dos tipos de canal:

Definición estándar SDTV

1.5 Mbps

Alta definición HDTV.

8 Mbps

IPTV Para Habilitar el servicio se necesita: 1. Adquisición de la señal de video 2.
IPTV Para Habilitar el servicio se necesita: 1. Adquisición de la señal de video 2.
IPTV
IPTV

Para Habilitar el servicio se necesita:

1.

Adquisición de la señal de video

2.

Almacenamiento y servidores de video

3.

Distribución de contenido

4.

Equipo de acceso y suscriptor

5.

Software

IPTV
IPTV
IPTV Los formatos empleados por IPTV más usualmente son: H.261 : Se utilizó para videoconferencia y

Los formatos empleados por IPTV más usualmente son:

H.261: Se utilizó para videoconferencia y video telefonía y sirve como base para otros.

MPEG-1: Logra calidad similar a VHS y además es compatible con todos los ordenadores y

casi todos los DVD.

MPEG-2: Es el usado en los DVD y permite imagen a pantalla completa con buena calidad.

H.263: Permite bajas tasas con una calidad aceptable. Usado en especial para videoconferencia y videotelefonía.

MPEG-4 parte 2: Calidad mejorada respecto a MPEG-2

MPEG-4 parte 10: También llamado H264. Es el más usado actualmente por una gran

variedad de aplicaciones.

WMV: Se utiliza tanto para video de poca calidad a través de internet con conexiones lentas, como para video de alta definición. Mientras que MPEG-4 está respaldado por

JVT* el formato WMV es un formato de compresión de video propietario de Microsoft.

(JVT) Joint Video Team es la unión de ITU-T Video Coding Experts Group (VCEG) y de

ISO/IEC Moving Picture Experts Group (MPEG).

IPTV
IPTV

Los servidores deben realizar:

IPTV Los servidores deben realizar: 1. Almacenamiento y respaldo de los contenidos 2. Gestión del video

1. Almacenamiento y respaldo de los contenidos

2. Gestión del video bajo demanda

1. Streaming de alta velocidad

IPTV
IPTV
IPTV Los servidores utilizan IP, basados en los sistemas operativos que permiten enviar distintos flujos de

Los servidores utilizan IP, basados en los sistemas operativos que permiten enviar distintos flujos de video a la vez.

IPTV
IPTV
IPTV
IPTV
IPTV
IPTV
IPTV 1 1 Televisor SDTV Televisor HDTV Canal 13 Youtube VoIP
1 1
1
1

Televisor SDTV

Televisor HDTV

Canal 13

Youtube

VoIP

PBX Asterisk

Asterisk
Asterisk
PBX Asterisk Asterisk Asterisk es una aplicación que controla y gestiona comunicaciones de cualquier tipo, ya

Asterisk es una aplicación que controla y gestiona comunicaciones de cualquier tipo, ya sean analógicas, digitales o VoIP mediante todos los protocolos VoIP que implementa.

Asterisk es Open Source basada en GPL y por lo tanto con las ventajas que ello

representa, lo que lo hace libre para desarrollar sistemas de comunicaciones profesionales de gran calidad, seguridad y versatilidad.

Funciona como una central telefónica (PBX), es decir que permite conectar

terminales telefónicas de forma independiente al proveedor de telefonía.

De esta forma se consigue que todas las llamadas internas de una misma empresa

sean conmutadas directamente sin necesidad de salir al exterior por la red pública de

telefonía.

Licencias

Asterisk
Asterisk
Licencias Asterisk Los programas de ordenador suelen distribuirse con licencias propietarias o cerradas. Estas licencias

Los programas de ordenador suelen distribuirse con licencias propietarias o cerradas.

Estas licencias son intransferibles y no exclusivas, es decir, no eres propietario del programa, sólo tienes derecho a usarlo en un ordenador o tantos como permita expresamente la licencia y no puedes modificar el programa ni distribuirlo.

La licencia GPL o General Public License, desarrollada por la FSF o Free Software Foundation, es completamente diferente.

Puedes instalar y usar un programa GPL en un ordenador o en tantos como te

apetezca, sin limitación.

También puedes modificar el programa para adaptarlo a lo que tu quieras que haga.

Además, podrás distribuir el programa GPL tal cual o después de haberlo modificado.

Asterisk
Asterisk

PBX Private Branch Exchange

PABX

Private Automatic Branch Exchange

Asterisk PBX Private Branch Exchange PABX Private Automatic Branch Exchange
Asterisk PBX Private Branch Exchange PABX Private Automatic Branch Exchange
Asterisk Funcionamiento: Dispositivos físicos que administran el tráfico de llamadas, contabiliza las llamadas para uso

Asterisk

Asterisk Funcionamiento: Dispositivos físicos que administran el tráfico de llamadas, contabiliza las llamadas para uso

Funcionamiento:

Dispositivos físicos que administran el tráfico de llamadas, contabiliza las llamadas para

uso financiero y de facturación.

Generalmente el usuario conecta el PBX por un único enlace digital, como E1 ó T1 hacia la Central Publica del proveedor de Telefonia.

E1:

El formato de la señal E1 lleva datos en una tasa de 2,048 millones de bits por segundo y

puede llevar 32 canales de 64 Kbps * cada uno, de los cuales treinta y uno son canales

activos simultáneos para voz o datos en SS7 (Sistema de Señalización Número 7).

T1

Una conexión T1 es un paquete compuesto por 24 canales de multiplexado por división de tiempo (TDM) de 64 kbps (DS0) a través de circuito de cobre de cuatro hilos.

Esto crea un ancho de banda total de 1.544 mbps.

Asterisk Funcionamiento: 1. Llamadas entrantes Acceso por número único Acceso directo a extensiones 2. Llamadas

Asterisk

Asterisk Funcionamiento: 1. Llamadas entrantes Acceso por número único Acceso directo a extensiones 2. Llamadas

Funcionamiento:

1. Llamadas entrantes

Acceso por número único

Acceso directo a extensiones

2. Llamadas salientes

3. Llamadas internas

Asterisk Asterisk soporta muchos protocolos VoIP comop ueden ser SIP, H.323, IAX y MGCP, entre

Asterisk

Asterisk Asterisk soporta muchos protocolos VoIP comop ueden ser SIP, H.323, IAX y MGCP, entre otros.

Asterisk soporta muchos protocolos VoIP comop ueden ser SIP, H.323, IAX y MGCP, entre

otros.

Características Asterisk pese a ser una aplicación software ofrece las mismas características que un PBX hardware:

Reducción de costos no solo por realizar las llamadas sobre la misma red de datos, si no

por ser una aplicación de código abierto.

Facilita la integración y desarrollo de nuevos servicios.

Compatible con una gran cantidad de protocolos VoIP y códecs.

Asterisk SIP Acrónimo de “ Session Initiation Protocol ”. Este protocolo considera a cada conexión

Asterisk

Asterisk SIP Acrónimo de “ Session Initiation Protocol ”. Este protocolo considera a cada conexión como

SIP

Acrónimo de “Session Initiation Protocol”.

Este protocolo considera a cada conexión como un par y se encarga de negociar las

capacidades entre ellos.

Tiene una sintaxis simple, similar a HTTP o SMTP.

Posee un sistema de autenticación de pregunta/respuesta.

Tiene métodos para minimizar los efectos de DoS.

No tiene un adecuado direccionamiento de información para el funcionamiento con NAT.

Asterisk IAX Acrónimo de “Inter Asterisk eXchange ”. IAX es un protocolo abierto, es decir

Asterisk

Asterisk IAX Acrónimo de “Inter Asterisk eXchange ”. IAX es un protocolo abierto, es decir que

IAX

Acrónimo de “Inter Asterisk eXchange”.

IAX es un protocolo abierto, es decir que se puede descargar y desarrollar libremente.

Aún no es un estándar.

Es un protocolo de transporte, que utiliza el puerto UDP 4569 tanto para señalización de

canal como para RTP (Protocolo de transporte en tiempo real).

Puede encapsular o empaquetar múltiples sesiones dentro de un flujo de datos, así requiere de menos ancho de banda y permite mayor número de canales entre

terminales.

En seguridad, permite la autenticación, pero no hay cifrado entre terminales.

El IAX puede usar cifrado (aes128), siempre sobre canales con autentificación MD5.

Asterisk H.323 Originalmente fue diseñado para el transporte de vídeo conferencia. Su especificación es compleja.

Asterisk

Asterisk H.323 Originalmente fue diseñado para el transporte de vídeo conferencia. Su especificación es compleja. H.323

H.323

Originalmente fue diseñado para el transporte de vídeo conferencia.

Su especificación es compleja.

H.323 es un protocolo relativamente seguro, ya que utiliza RTP.

Tiene dificultades con NAT, por ejemplo para recibir llamadas se necesita direccionar el puerto TCP 1720 al cliente, además de direccionar los puertos UDP para la media de RTP y los flujos de control de RTCP.

Para más clientes detrás de un dispositivo NAT se necesita gatekeeper en modo proxy.

Asterisk MGCP Acrónimo de “Media Gateway Control Protocol ”. Inicialmente diseñado para simplificar en lo

Asterisk

Asterisk MGCP Acrónimo de “Media Gateway Control Protocol ”. Inicialmente diseñado para simplificar en lo posible

MGCP

Acrónimo de “Media Gateway Control Protocol”.

Inicialmente diseñado para simplificar en lo posible la comunicación con terminales como los teléfonos.

MGCP utiliza un modelo centralizado (arquitectura cliente-servidor), de tal forma que un

teléfono necesita conectarse a un controlador antes de conectarse con otro teléfono, así la comunicación no es directa.

Tiene tres componentes un MGC (Media Gateway Controller), uno o varios MG (Media

Gateway) y uno o varios SG (Signaling Gateway), el primero también denominado

dispositivo maestro controla al segundo también denominado esclavo.

No es un protocolo estándar.

Asterisk SCCP Acrónimo de “ Skinny Call Control Protocol ” (en algunas fuentes se enuncia

Asterisk

Asterisk SCCP Acrónimo de “ Skinny Call Control Protocol ” (en algunas fuentes se enuncia como

SCCP

Acrónimo de “Skinny Call Control Protocol” (en algunas fuentes se enuncia como "Skinny

Client Control Protocol).

Es un protocolo propietario de Cisco.

Es el protocolo por defecto para terminales con el servidor Cisco Call Manager PBX que

es el similar a Asterisk PBX.

El cliente Skinny usa TCP/IP para transmitir y recibir llamadas.

Para el audio utiliza RTP, UDP e IP.

Los mensajes Skinny son transmitidos sobre TCP y usa el puerto 2000.

Asterisk Asterisk está formado por un núcleo principal encargado de gestionar todo el sistema PBX.

Asterisk

Asterisk Asterisk está formado por un núcleo principal encargado de gestionar todo el sistema PBX. Sus

Asterisk está formado por un núcleo principal encargado de gestionar todo el sistema

PBX.

Sus funciones principales son:

Interconectar de forma automática cada llamada entre los usuarios tomando en cuenta

el tipo de protocolo utilizado por cada terminal.

Lanzar los servicios cuando sean necesarios.

Traducir y adaptar cada códec a cada terminal involucrado en la comunicación

Asterisk Codificadores de audio: La señal de audio ha de ser digitalizada, comprimida y codificada

Asterisk

Asterisk Codificadores de audio: La señal de audio ha de ser digitalizada, comprimida y codificada antes

Codificadores de audio:

La señal de audio ha de ser digitalizada, comprimida y codificada antes de ser transmitida

por la red IP.

Para ello se utilizan algoritmos matemáticos implementados en software llamados códecs.

Existen diferentes modelos de códecs de audio utilizados en VoIP, y dependiendo del algoritmo escogido en la transmisión, variara la calidad de la voz.

Algunos de los códecs más utilizados son los siguientes

escogido en la transmisión, variara la calidad de la voz. Algunos de los códecs más utilizados
Asterisk Protocolo de señalización La señalización en VoIP tiene un papel muy importante en la

Asterisk

Asterisk Protocolo de señalización La señalización en VoIP tiene un papel muy importante en la red,

Protocolo de señalización

La señalización en VoIP tiene un papel muy importante en la red, ya que es la encargada

de establecer, mantener, administrar y finalizar una conversación entre dos puntos.

Además de ofrecer funciones de supervisión, marcado y QoS en cada canal de

transmisión.

Asterisk A continuación se describen los protocolos de señalización más usados actualmente. PROTOCOLO

Asterisk

Asterisk A continuación se describen los protocolos de señalización más usados actualmente. PROTOCOLO

A continuación se describen los protocolos de señalización más usados actualmente.

PROTOCOLO

CARACTERISTICAS

SIP

Protocolo para el control de llamas multimedia y la implementación de

servicios telefónicos avanzados.

Está basado en HTTP adoptando las características más importantes de este estándar como son la sencillez de sus sintaxis y una estructura

cliente/servidor.

El gran potencial de SIP reside en su flexibilidad

IAX

Fue desarrollado por Digium para la comunicación entre centralitas Asterisk aunque actualmente se ha implementado clientes que también soportan este protocolo.

Su principal objetivo es minimizar el ancho de banda utilizado en la

transmisión de voz y video a través de la red IP

Asterisk • RedHat • NetBSD • Suse • OpenBSD • Debian • Ubuntu • Centos

Asterisk

Asterisk • RedHat • NetBSD • Suse • OpenBSD • Debian • Ubuntu • Centos
Asterisk • RedHat • NetBSD • Suse • OpenBSD • Debian • Ubuntu • Centos
Asterisk • RedHat • NetBSD • Suse • OpenBSD • Debian • Ubuntu • Centos

RedHat

NetBSD

Suse

OpenBSD

Debian

• Debian

Ubuntu

Centos

Asterisk

Asterisk

Asterisk
Asterisk
Asterisk Maquina Virtual

Asterisk Maquina Virtual

Asterisk Maquina Virtual
Asterisk Maquina Virtual
Asterisk Maquina Virtual

Asterisk Maquina Virtual

Asterisk Maquina Virtual
Asterisk Maquina Virtual
Asterisk Maquina Virtual

Asterisk Maquina Virtual

Asterisk Maquina Virtual
Asterisk Maquina Virtual
Asterisk Maquina Virtual

Asterisk Maquina Virtual

Asterisk Maquina Virtual
Asterisk Maquina Virtual
Asterisk Maquina Virtual

Asterisk Maquina Virtual

Asterisk Maquina Virtual
Asterisk Maquina Virtual
Asterisk Maquina Virtual

Asterisk Maquina Virtual

Asterisk Maquina Virtual
Asterisk Maquina Virtual
Asterisk Maquina Virtual

Asterisk Maquina Virtual

Asterisk Maquina Virtual
Asterisk Maquina Virtual
Asterisk Maquina Virtual

Asterisk Maquina Virtual

Asterisk Maquina Virtual
Asterisk Maquina Virtual
Asterisk Maquina Virtual

Asterisk Maquina Virtual

Asterisk Maquina Virtual
Asterisk Maquina Virtual
Asterisk Maquina Virtual

Asterisk Maquina Virtual

Asterisk Maquina Virtual
Asterisk Maquina Virtual
Asterisk Maquina Virtual

Asterisk Maquina Virtual

Asterisk Maquina Virtual
Asterisk Maquina Virtual
Asterisk Maquina Virtual

Asterisk Maquina Virtual

Asterisk Maquina Virtual
Asterisk Maquina Virtual
Asterisk

Asterisk

Asterisk
Asterisk
Asterisk
Asterisk

Asterisk

Asterisk
Asterisk

Asterisk

Asterisk
Asterisk
Asterisk

Asterisk

Asterisk
Asterisk
Asterisk

Asterisk

Asterisk
Asterisk
Asterisk

Asterisk

Asterisk
Asterisk
Asterisk

Asterisk

Asterisk
Asterisk
Asterisk

Asterisk

Asterisk
Asterisk
SSID: Laboratorio Cisco Clave: a1b2c3d4f5 X-Lite SoftPhone ASTERISK ASTERISK LAB 3CX, SmartPhone

SSID: Laboratorio Cisco

Clave: a1b2c3d4f5

X-Lite SoftPhone

SSID: Laboratorio Cisco Clave: a1b2c3d4f5 X-Lite SoftPhone ASTERISK ASTERISK LAB 3CX, SmartPhone
ASTERISK
ASTERISK
SSID: Laboratorio Cisco Clave: a1b2c3d4f5 X-Lite SoftPhone ASTERISK ASTERISK LAB 3CX, SmartPhone

ASTERISK LAB

3CX, SmartPhone

SSID: Laboratorio Cisco Clave: a1b2c3d4f5 X-Lite SoftPhone ASTERISK ASTERISK LAB 3CX, SmartPhone
SSID: Laboratorio Cisco Clave: a1b2c3d4f5 X-Lite SoftPhone ASTERISK ASTERISK LAB 3CX, SmartPhone
Entronque entre PBX Asterisk ASTERISK Ip: 192.168.1.x ASTERISK Ip: 192.168.1.x Trunk IAX RTP SIP SIP

Entronque entre PBX Asterisk

Entronque entre PBX Asterisk ASTERISK Ip: 192.168.1.x ASTERISK Ip: 192.168.1.x Trunk IAX RTP SIP SIP 201

ASTERISK

Ip: 192.168.1.x

ASTERISK

Ip: 192.168.1.x

Asterisk ASTERISK Ip: 192.168.1.x ASTERISK Ip: 192.168.1.x Trunk IAX RTP SIP SIP 201 Codec G711 Cliente
Asterisk ASTERISK Ip: 192.168.1.x ASTERISK Ip: 192.168.1.x Trunk IAX RTP SIP SIP 201 Codec G711 Cliente

Trunk

IAX

RTP

192.168.1.x ASTERISK Ip: 192.168.1.x Trunk IAX RTP SIP SIP 201 Codec G711 Cliente ip: 192.168.1.x 301

SIP

SIP
SIP
ASTERISK Ip: 192.168.1.x Trunk IAX RTP SIP SIP 201 Codec G711 Cliente ip: 192.168.1.x 301 Codec
ASTERISK Ip: 192.168.1.x Trunk IAX RTP SIP SIP 201 Codec G711 Cliente ip: 192.168.1.x 301 Codec

201

Codec G711

Cliente

ip: 192.168.1.x

301

Codec G711

Cliente

ip: 192.168.1.x

Entronque entre PBX Asterisk IAX (Inter-Asterisk eXchange protocol) es uno de los protocolos utilizado por

Entronque entre PBX Asterisk

Entronque entre PBX Asterisk IAX (Inter-Asterisk eXchange protocol) es uno de los protocolos utilizado por Asterisk

IAX (Inter-Asterisk eXchange protocol) es uno de los protocolos utilizado por

Asterisk

Es utilizado para manejar conexiones VoIP entre servidores Asterisk, y entre servidores y clientes que también utilizan protocolo IAX.

El protocolo IAX ahora se refiere generalmente al IAX2, la segunda versión del protocolo IAX.

El protocolo original ha quedado obsoleto en favor de IAX2.

Entronque entre PBX Asterisk El principal objetivo de IAX ha sido minimizar el ancho de

Entronque entre PBX Asterisk

Entronque entre PBX Asterisk El principal objetivo de IAX ha sido minimizar el ancho de banda

El principal objetivo de IAX ha sido minimizar el ancho de banda utilizado en la transmisión de voz y vídeo a través de la red IP.

Soporte nativo para ser transparente a NAT. La estructura básica de IAX se

fundamenta en la multiplexación de la señalización y del flujo de datos sobre un simple puerto UDP entre dos sistemas.

Entronque entre PBX Asterisk IAX vs SIP Las principales diferencias ente IAX y SIP son

Entronque entre PBX Asterisk

Entronque entre PBX Asterisk IAX vs SIP Las principales diferencias ente IAX y SIP son las

IAX vs SIP

Las principales diferencias ente IAX y SIP son las siguientes:

Ancho de banda. IAX utiliza un menor ancho de banda que SIP ya que los mensajes son codificados de forma binaria mientras que en SIP son mensajes de texto. Asimismo, IAX intenta reducir

al máximo la información de las cabeceras de los mensajes reduciendo también el

ancho de banda

NAT En IAX la señalización y los datos viajan conjuntamente con lo cual se evitan los

problemas de NAT que frecuentemente aparecen en SIP. En SIP la señalización y los

datos viajan de manera separada y por eso aparecen problemas de NAT en el flujo de audio cuando este flujo debe superar los routers y firewalls. SIP suele necesitar un

servidor STUN para estos problemas

Entronque entre PBX Asterisk IAX vs SIP Estandarización SIP es un protocolo estandarizado por la

Entronque entre PBX Asterisk

Entronque entre PBX Asterisk IAX vs SIP Estandarización SIP es un protocolo estandarizado por la IETF

IAX vs SIP

Estandarización SIP es un protocolo estandarizado por la IETF (Internet Engineering Task Force) hace bastante tiempo y que es ampliamente implementado por todos los fabricantes de equipos y

software.

IAX está aun siendo estandarizado y es por ello que no se encuentra en muchos

dispositivos existentes en el mercado.

Utilización de puertos IAX utiliza un solo puerto (4569) para mandar la información de señalización y los datos

de todas sus llamadas. Para ello utiliza un mecanismo de multiplexión o "trunking".

SIP, sin embargo utiliza un puerto (5060) para señalización y 2 puertos RTP por cada

conexión de audio (como mínimo 3 puertos).

Por ejemplo para 100 llamadas simultaneas con SIP se usarían 200 puertos (RTP) más el

puerto 5060 de señalización. IAX utilizaría sólo un puerto para todo (4569)

Entronque entre PBX Asterisk IAX vs SIP Flujo de audio al utilizar un servidor En

Entronque entre PBX Asterisk

Entronque entre PBX Asterisk IAX vs SIP Flujo de audio al utilizar un servidor En SIP

IAX vs SIP

Flujo de audio al utilizar un servidor En SIP si utilizamos un servidor la señalización de control pasa siempre por el servidor

pero la información de audio (flujo RTP) puede viajar extremo a extremo sin tener que

pasar necesariamente por el servidor SIP.

En IAX al viajar la señalización y los datos de forma conjunta todo el tráfico de audio debe pasar obligatoriamente por el servidor IAX. Esto produce una aumento en el uso

del ancho de banda que deben soportar los servidores IAX sobretodo cuando hay

muchas llamadas simulataneas.

Entronque entre PBX Asterisk IAX vs SIP Internet Trunk IAX IAX Trunk

Entronque entre PBX Asterisk

Entronque entre PBX Asterisk IAX vs SIP Internet Trunk IAX IAX Trunk

IAX vs SIP

Internet Trunk IAX
Internet
Trunk
IAX
Entronque entre PBX Asterisk IAX vs SIP Internet Trunk IAX IAX Trunk
Entronque entre PBX Asterisk IAX vs SIP Internet Trunk IAX IAX Trunk
IAX
IAX

Trunk

Entronque entre PBX Asterisk IAX vs SIP Internet Trunk IAX IAX Trunk
Entronque entre PBX Asterisk IAX vs SIP Internet Trunk IAX IAX Trunk
Trabajo en Clases 1) Que es IPTV? 2) Cual es la diferencia entre IPTV y

Trabajo en Clases

Trabajo en Clases 1) Que es IPTV? 2) Cual es la diferencia entre IPTV y TV

1)

Que es IPTV?

2)

Cual es la diferencia entre IPTV y TV Online Internet?

3)

Para IPTV cual es el ancho de banda para SDTV y HDTV?

4)

Cuales son los formatos para IPTV e indique cual es el mas utilizado y porque?

5)

Los Servidores para IPTV que deben realizar?

6)

Asterisk que tipo de licencia tiene?

7)

Que tipo de enlaces digitales se conecta entre la PBX y la central publica?

8)

Asterisk bajo que SO funciona?

9)

Indique cuales son los Códec que necesitan licencia?

10)

Porque es necesario desconfigurar el NAT para utilizar SIP?

ASTERISK Completar diagrama de conexión Asterisk ASTERISK Ip: 192.168.1.56 ASTERISK Ip: 192.168.1.55 Trunk IAX SIP

ASTERISK Completar diagrama de conexión Asterisk

ASTERISK Completar diagrama de conexión Asterisk ASTERISK Ip: 192.168.1.56 ASTERISK Ip: 192.168.1.55 Trunk IAX SIP SIP

ASTERISK

Ip: 192.168.1.56

ASTERISK

Ip: 192.168.1.55

Asterisk ASTERISK Ip: 192.168.1.56 ASTERISK Ip: 192.168.1.55 Trunk IAX SIP SIP RTP 201 Codec G711 Cliente
Asterisk ASTERISK Ip: 192.168.1.56 ASTERISK Ip: 192.168.1.55 Trunk IAX SIP SIP RTP 201 Codec G711 Cliente

Trunk

IAXASTERISK Ip: 192.168.1.56 ASTERISK Ip: 192.168.1.55 Trunk SIP SIP RTP 201 Codec G711 Cliente ip: 192.168.1.10

SIP
SIP
Ip: 192.168.1.56 ASTERISK Ip: 192.168.1.55 Trunk IAX SIP SIP RTP 201 Codec G711 Cliente ip: 192.168.1.10
SIP
SIP
Ip: 192.168.1.56 ASTERISK Ip: 192.168.1.55 Trunk IAX SIP SIP RTP 201 Codec G711 Cliente ip: 192.168.1.10

RTPIp: 192.168.1.56 ASTERISK Ip: 192.168.1.55 Trunk IAX SIP SIP 201 Codec G711 Cliente ip: 192.168.1.10 301

201 Codec G711 Cliente ip: 192.168.1.10
201
Codec
G711
Cliente
ip: 192.168.1.10

301

Codec G711

Ip: 192.168.1.55 Trunk IAX SIP SIP RTP 201 Codec G711 Cliente ip: 192.168.1.10 301 Codec G711

Cliente

ip: 192.168.1.20

ASTERISK Completar diagrama de conexión Asterisk ASTERISK Ip: 192.168.1.56 Call Manager Cisco Ip: 192.168.1.55 Trunk

ASTERISK Completar diagrama de conexión Asterisk

ASTERISK Completar diagrama de conexión Asterisk ASTERISK Ip: 192.168.1.56 Call Manager Cisco Ip: 192.168.1.55 Trunk IAX

ASTERISK

Ip: 192.168.1.56

Call Manager Cisco

Ip: 192.168.1.55

Ip: 192.168.1.56 Call Manager Cisco Ip: 192.168.1.55 Trunk IAX SIP SIP RTP 201 Codec G711 Cliente

Trunk

IAXIp: 192.168.1.56 Call Manager Cisco Ip: 192.168.1.55 Trunk SIP SIP RTP 201 Codec G711 Cliente ip:

192.168.1.56 Call Manager Cisco Ip: 192.168.1.55 Trunk IAX SIP SIP RTP 201 Codec G711 Cliente ip:
SIP
SIP
Call Manager Cisco Ip: 192.168.1.55 Trunk IAX SIP SIP RTP 201 Codec G711 Cliente ip: 192.168.1.10
SIP
SIP
Call Manager Cisco Ip: 192.168.1.55 Trunk IAX SIP SIP RTP 201 Codec G711 Cliente ip: 192.168.1.10

RTPCall Manager Cisco Ip: 192.168.1.55 Trunk IAX SIP SIP 201 Codec G711 Cliente ip: 192.168.1.10 301

201 Codec G711 Cliente ip: 192.168.1.10
201
Codec
G711
Cliente
ip: 192.168.1.10

301

Codec G711

Ip: 192.168.1.55 Trunk IAX SIP SIP RTP 201 Codec G711 Cliente ip: 192.168.1.10 301 Codec G711

Cliente

ip: 192.168.1.20

Entronque entre PBX Asterisk IAX vs SIP Internet Trunk Trunk IAX IAX

Entronque entre PBX Asterisk

Entronque entre PBX Asterisk IAX vs SIP Internet Trunk Trunk IAX IAX

IAX vs SIP

Internet Trunk Trunk IAX IAX
Internet
Trunk
Trunk
IAX
IAX
Entronque entre PBX Asterisk IAX vs SIP Internet Trunk Trunk IAX IAX
Entronque entre PBX Asterisk IAX vs SIP Internet Trunk Trunk IAX IAX
Entronque entre PBX Asterisk IAX vs SIP Internet Trunk Trunk IAX IAX
Entronque entre PBX Asterisk IAX vs SIP Internet Trunk Trunk IAX IAX
Entronque entre PBX Asterisk Arquitectura VoIP Publica Privada PSTN E1 NGN (Internet o MPLS) IP

Entronque entre PBX Asterisk

Arquitectura VoIP

Entronque entre PBX Asterisk Arquitectura VoIP Publica Privada PSTN E1 NGN (Internet o MPLS) IP SWITH

Publica

Privada

PSTN E1
PSTN
E1
NGN (Internet o MPLS)
NGN
(Internet o MPLS)

IP

SWITH LAN

LAYER 2

Teléfono IP

VoIP Publica Privada PSTN E1 NGN (Internet o MPLS) IP SWITH LAN LAYER 2 Teléfono IP
VoIP Publica Privada PSTN E1 NGN (Internet o MPLS) IP SWITH LAN LAYER 2 Teléfono IP
VoIP Publica Privada PSTN E1 NGN (Internet o MPLS) IP SWITH LAN LAYER 2 Teléfono IP

PBX-IP

ASTERISK

VoIP Publica Privada PSTN E1 NGN (Internet o MPLS) IP SWITH LAN LAYER 2 Teléfono IP
FXO
FXO
VoIP Publica Privada PSTN E1 NGN (Internet o MPLS) IP SWITH LAN LAYER 2 Teléfono IP
VoIP Publica Privada PSTN E1 NGN (Internet o MPLS) IP SWITH LAN LAYER 2 Teléfono IP

GATEWAY

PSTN
PSTN
Entronque entre PBX Asterisk FXS (Foreing Exchange Station) es una interfaz de un dispositivo que

Entronque entre PBX Asterisk

Entronque entre PBX Asterisk FXS (Foreing Exchange Station) es una interfaz de un dispositivo que permite

FXS (Foreing Exchange Station) es una interfaz de un dispositivo que permite conectar un teléfono análogo

FXO (Foreign Exchange Office) es una interfaz del dispositivo que permite conectar la

central publica telefónica.

NGN (Next Generation Networking ) refiere a la evolución de la actual infraestructura de

redes de telecomunicación y acceso telefónico con el objetivo de lograr la convergencia

tecnológica de los nuevos servicios multimedia (voz, datos, video.)

Trabajo de investigación y exposición sobre proveedores de VoIP y Videoconferencia (09 de mayo) Equipos
Trabajo de investigación y exposición sobre proveedores de VoIP y Videoconferencia (09 de mayo) Equipos

Trabajo de investigación y exposición sobre proveedores de VoIP y Videoconferencia

(09 de mayo)

Equipos utilizados, marca , modelo, arquitectura, QoS, clientes (residencial,pyme,empresas)

Debe incluir características y especificaciones técnicas de los equipos.

Grupo

Integrantes

Empresa

1

   

2

   

3

   

4

   

5

   

6

   

7

   

8

   

9

   

10

   
LAB Entronque PBX Asterisk PBX-IP Buccioni 192.168.1.50 PBX-IP Villalon 192.168.1.51 SIP SIP 741 10 741

LAB Entronque PBX Asterisk

PBX-IP Buccioni

192.168.1.50

PBX-IP Villalon

192.168.1.51

PBX-IP Buccioni 192.168.1.50 PBX-IP Villalon 192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A
PBX-IP Buccioni 192.168.1.50 PBX-IP Villalon 192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A
SIP
SIP

SIP

Buccioni 192.168.1.50 PBX-IP Villalon 192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A X
Buccioni 192.168.1.50 PBX-IP Villalon 192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A X

741 10

741 11

PBX-IP Villalon 192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A X SIP 741
PBX-IP Villalon 192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A X SIP 741

SIP

Trunk

IAX

SIP
SIP
192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A X SIP 741 20 741

741 20

741 21

Extensiones

741 10 741 19

Extensiones

741 20 741 29

LAB Entronque Configuración Nombre PBX-IP Buccioni PBX-IP Villalón ip 192.168.1.50 192.168.1.51

LAB Entronque Configuración

LAB Entronque Configuración Nombre PBX-IP Buccioni PBX-IP Villalón ip 192.168.1.50 192.168.1.51

Nombre

PBX-IP Buccioni

PBX-IP Villalón

ip

192.168.1.50

192.168.1.51

Rango extensión

741 10 741 19

741 20 741 29

LAB Entronque Configuración de Trunk Crear Trunk en PBX-IP Buccioni

LAB Entronque Configuración de Trunk

Crear Trunk en PBX-IP Buccioni

LAB Entronque Configuración de Trunk Crear Trunk en PBX-IP Buccioni
LAB Entronque Configuración de Trunk Crear Trunk en PBX-IP Buccioni
LAB Entronque Configuración de Trunk

LAB Entronque Configuración de Trunk

LAB Entronque Configuración de Trunk
LAB Entronque Configuración de Trunk
LAB Entronque Configuración de Trunk
LAB Entronque Configuración de Trunk

LAB Entronque Configuración de Trunk

LAB Entronque Configuración de Trunk
LAB Entronque Configuración de Trunk
Componentes H.323 H.323 establece los estándares para la compresión y descompresión de audio y vídeo

Componentes H.323

Componentes H.323 H.323 establece los estándares para la compresión y descompresión de audio y vídeo ,

H.323 establece los estándares para la compresión y descompresión de audio y vídeo, asegurando que los equipos de distintos fabricantes se intercomuniquen.

Así, los usuarios no se tienen que preocupar de cómo el equipo receptor actúa,

siempre y cuando cumpla este estándar.

Por ejemplo, la gestión del ancho de banda disponible para evitar que la LAN se

colapse con la comunicación de audio y vídeo también está contemplada en el

estándar, esto se realiza limitando el número de conexiones simultáneas.

Componentes H.323 También la norma H.323 hace uso de los procedimientos de señalización de los

Componentes H.323

Componentes H.323 También la norma H.323 hace uso de los procedimientos de señalización de los canales

También la norma H.323 hace uso de los procedimientos de señalización de los canales

lógicos contenidos en la norma H.245, en los que el contenido de cada uno de los

canales se define cuando se abre.

Componentes H.323 El estándar define un amplio conjunto de características y funciones, algunas son necesarias

Componentes H.323

Componentes H.323 El estándar define un amplio conjunto de características y funciones, algunas son necesarias y

El estándar define un amplio conjunto de características y funciones, algunas son necesarias y otras opcionales.

Pero el H.323 define mucho más que las funciones, este estándar define los siguientes

componentes más relevantes:

· Terminal

· GateWay

· Gatekeeper

· Unidad de Control Multipunto

· Controlador Multipunto

· Procesador Multipunto

· Proxy H.323

Componentes H.323

Componentes H.323

Componentes H.323
Componentes H.323
Componentes H.323 1. Terminal Un terminal H.323 es un extremo de la red que proporciona

Componentes H.323

Componentes H.323 1. Terminal Un terminal H.323 es un extremo de la red que proporciona comunicaciones

1. Terminal

Un terminal H.323 es un extremo de la red que proporciona comunicaciones

bidireccionales en tiempo real con otro terminal H.323, gateway o unidad de control

multipunto (MCU).

Esta comunicación consta de señales de control, indicaciones, audio, imagen en color en movimiento y /o datos entre los dos terminales.

Conforme a la especificación, un terminal H.323 puede proporcionar sólo voz, voz y

datos, voz y vídeo, o voz, datos y vídeo.

Componentes H.323 Un terminal H.323 consta de las interfaces del equipo de usuario, el códec

Componentes H.323

Componentes H.323 Un terminal H.323 consta de las interfaces del equipo de usuario, el códec de

Un terminal H.323 consta de las interfaces del equipo de usuario, el códec de video, el

códec de audio, el equipo telemático, la capa H.225, las funciones de control del sistema y la interfaz con la red por paquetes.

a. Equipos de adquisición de información:

Es un conjunto de cámaras, monitores, dispositivos de audio (micrófono y

altavoces) y aplicaciones de datos, e interfaces de usuario asociados a cada uno de

ellos.

b. Códec de audio:

Todos los terminales deberán disponer de un códec de audio, para codificar y

decodificar señales vocales (G.711), y ser capaces de transmitir y recibir ley A y ley

μ. Un terminal puede, opcionalmente, ser capaz de codificar y decodificar señales

vocales.

El terminal H.323 puede, opcionalmente, enviar más de un canal de audio al

mismo tiempo, por ejemplo, para hacer posible la difusión de 2 idiomas.

Componentes H.323 c. Códec de video: En los terminales H.323 es opcional. d. Canal de

Componentes H.323

Componentes H.323 c. Códec de video: En los terminales H.323 es opcional. d. Canal de datos:

c. Códec de video: En los terminales H.323 es opcional.

d. Canal de datos: Uno o más canales de datos son opcionales. Pueden

ser unidireccionales o bidireccionales.

e. Retardo en el trayecto de recepción: Incluye el retardo añadido a las

tramas para mantener la sincronización, y tener en cuenta la fluctuación

de las llegadas de paquetes. No suele usarse en la transmisión sino en recepción, para añadir el retardo necesario en el trayecto de audio para, por ejemplo, lograr la sincronización con el movimiento de los labios en una videoconferencia.

f. Unidad de control del sistema: Proporciona la señalización necesaria para el funcionamiento adecuado del terminal. Está formada por tres bloques principales: Función de control H.245, función de señalización de llamada H.225 y función de señalización RAS.

Componentes H.323 2. Gateway Un gateway H.323 es un extremo que proporciona comunicaciones bidireccionales en

Componentes H.323

2. Gateway

Componentes H.323 2. Gateway Un gateway H.323 es un extremo que proporciona comunicaciones bidireccionales en tiempo

Un gateway H.323 es un extremo que proporciona comunicaciones bidireccionales en

tiempo real entre terminales H.323 en la red IP y otros terminales o gateways en una

red conmutada.

En general, el propósito del gateway es reflejar transparentemente las características

de un extremo en la red IP a otro en una red conmutada y viceversa.

Componentes H.323 3. Gatekeeper El gatekeeper es una entidad que proporciona la traducción de direcciones

Componentes H.323

3. Gatekeeper

Componentes H.323 3. Gatekeeper El gatekeeper es una entidad que proporciona la traducción de direcciones y

El gatekeeper es una entidad que proporciona la traducción de direcciones y el control

de acceso a la red de los terminales H.323, gateways y MCUs.

El gatekeeper puede también ofrecer otros servicios a los terminales, gateways y MCUs, tales como gestión del ancho de banda y localización de los gateways.

otros servicios a los terminales, gateways y MCUs, tales como gestión del ancho de banda y
Componentes H.323 4. MCU La Unidad de Control Multipunto está diseñada para soportar la conferencia

Componentes H.323

Componentes H.323 4. MCU La Unidad de Control Multipunto está diseñada para soportar la conferencia entre

4. MCU

La Unidad de Control Multipunto está diseñada para soportar la conferencia entre tres o más puntos, bajo el estándar H.323, llevando la negociación entre terminales para

determinar las capacidades comunes para el proceso de audio y vídeo y controlar la

multidifusión.

5. CONTROLADOR MULTIPUNTO Un controlador multipunto es un componente de H.323 que provee capacidad de

negociación con todos los terminales para llevar a cabo niveles de comunicaciones.

También puede controlar recursos de conferencia tales como multicasting de vídeo. El Controlador Multipunto no ejecuta mezcla o conmutación de audio, vídeo o datos.

Componentes H.323 6. PROCESADOR MULTIPUNTO Un procesador multipunto es un componente de H.323 de hardware

Componentes H.323

Componentes H.323 6. PROCESADOR MULTIPUNTO Un procesador multipunto es un componente de H.323 de hardware y

6. PROCESADOR MULTIPUNTO

Un procesador multipunto es un componente de H.323 de hardware y software

especializado, mezcla, conmuta y procesa audio, vídeo y / o flujo de datos para los

participantes de una conferencia multipunto de tal forma que los procesadores del terminal no sean pesadamente utilizados. El procesador multipunto puede procesar un flujo medio único o flujos medio múltiples dependiendo de la conferencia soportada.

7. PROXY H.323

Un proxy H.323 es un servidor que provee a los usuarios acceso a redes seguras de unas a

otras confiando en la información que conforma la recomendación H.323.El Proxy H.323 se comporta como dos puntos remotos H.323 que envían mensajes call set up, e

información en tiempo real a un destino del lado seguro del firewall.

Componentes H.323

Componentes H.323

Componentes H.323
Call Signalling Q.931 Protocolo de control de conexiones ISDN. No provee control de flujo ni

Call Signalling Q.931

Call Signalling Q.931 Protocolo de control de conexiones ISDN. No provee control de flujo ni realiza

Protocolo de control de conexiones ISDN. No provee control de flujo ni realiza

retransmisiones.

Es una recomendación de la ITU. Q.931 no provee control de flujo ni retransmisión.

Q.931 define múltiples mensajes como:

1.

SETUP: indica el establecimiento de una conexión.

2.

CALL PROCEEDING: indica que la llamada está siendo procesada por la terminal

destino.

3.

ALERTING: indica que la terminal destino está llamando.

4.

CONNECT: indica a la parte que llama, que el destino esperado ha contestado la

llamada.

5.

RELEASE COMPLETE: indica que la llamada ha sido terminada. Lo puede enviar tanto

la fuente como el destino.

Call Signalling Q.931

Call Signalling Q.931

Call Signalling Q.931
Directorios de Asterisk Los directorios que utiliza Asterisk para su funcionamiento son los siguientes: /etc/asterisk:

Directorios de Asterisk Los directorios que utiliza Asterisk para su funcionamiento son los siguientes:

/etc/asterisk: directorio donde se alojan todos los ficheros de configuración del servicio.

/usr/lib/asterisk/modules: contiene todos los módulos que podrá cargar Asterisk para añadir funcionalidades. Algunos de ellos son format_wav.so, codec_alaw.so, chan_sip.so entre muchos otros.

/var/lib/asterisk: directorio que contiene las claves, música en espera y todos los sonidos que vienen por defecto con Asterisk.

/var/spool/asterisk: almacena los mensajes grabados en el buzón de voz, las

conferencias grabadas, etc.

/var/run/asterisk: contiene el fichero pid del proceso Asterisk en ejecución.

/var/log/asterisk: directorio de almacenamiento de ficheros de logs del servicio.

Ficheros de configuración /etc/asterisk/ asterisk.conf : el fichero de configuración donde se configuran todos los
Ficheros de configuración /etc/asterisk/ asterisk.conf : el fichero de configuración donde se configuran todos los

Ficheros de configuración /etc/asterisk/

asterisk.conf: el fichero de configuración donde se configuran todos los

componentes de Asterisk (ficheros de log, ficheros de configuración, etc). También es posible configurar parámetros generales en Asterisk.

sip.conf: es el fichero donde configuraremos los clientes SIP que podrán

conectarse a nuestra centralita Asterisk.

extensions.conf: uno de los ficheros más utilizados y más importantes en

Asterisk. En resumidas cuentas, es donde configuraremos el comportamiento de

nuestra centralita, por eso es uno de los más importantes.

voicemail.conf: donde configuraremos el buzón de voz para cada uno de nuestros clientes SIP.

meetme.conf: nos permite configurar salas de conferencias, es decir, podremos

crear una sala donde haya varios participantes.

Asterisk Centos

Asterisk

Asterisk Centos

Centos

Asterisk Centos
Asterisk Centos
Asterisk Centos
Asterisk Centos
GNU/Linux GNU/Linux es uno de los términos empleados para referirse a la combinación del núcleo

GNU/Linux

GNU/Linux GNU/Linux es uno de los términos empleados para referirse a la combinación del núcleo o

GNU/Linux es uno de los términos empleados para referirse a la combinación del núcleo

o kernel libre similar a Unix denominado Linux con el sistema GNU.

empleados para referirse a la combinación del núcleo o kernel libre similar a Unix denominado Linux
GNU/Linux Su desarrollo es uno de los ejemplos más prominentes de software libre; todo su

GNU/Linux

GNU/Linux Su desarrollo es uno de los ejemplos más prominentes de software libre; todo su código

Su desarrollo es uno de los ejemplos más prominentes de software libre; todo su código

fuente puede ser utilizado, modificado y redistribuido libremente por cualquiera bajo los términos de la GPL (Licencia Pública General de GNU, en inglés: General Public License) y

otra serie de licencias libres.

de la GPL (Licencia Pública General de GNU, en inglés: General Public License) y otra serie
de la GPL (Licencia Pública General de GNU, en inglés: General Public License) y otra serie
GNU/Linux

GNU/Linux

GNU/Linux
GNU/Linux
GNU/Linux
GNU/Linux Particiones y sistemas de archivos en Linux Particionar un disco es como dividirlo en

GNU/Linux

Particiones y sistemas de archivos en Linux

GNU/Linux Particiones y sistemas de archivos en Linux Particionar un disco es como dividirlo en discos
GNU/Linux Particiones y sistemas de archivos en Linux Particionar un disco es como dividirlo en discos

Particionar un disco es como dividirlo en discos más

pequeños contenidos dentro de la misma carcasa.

Las particiones pueden ser de dos tipos: primarias ó

lógicas, las particiones lógicas se crean dentro de una partición primaria especial llamada extendida.

primarias ó lógicas, las particiones lógicas se crean dentro de una partición primaria especial llamada extendida.
GNU/Linux Sistemas de archivos en Linux Existen diferentes sistemas de archivos y cada sistema operativo

GNU/Linux

Sistemas de archivos en Linux

GNU/Linux Sistemas de archivos en Linux Existen diferentes sistemas de archivos y cada sistema operativo soporta

Existen diferentes sistemas de archivos y cada sistema operativo soporta diferentes sistemas de ficheros, algunos de ellos son los siguientes:

Ext2 el primer sistema de archivos diseñado expresamente para Linux.

Ext3 versión mejorada de Ext2, ampliamente utilizada en distribuciones Linux

Ext4nuevo sistema de ficheros para Linux evolucionado de Ext3 algunas de sus ventajas

con respecto a este último son:

Aumento del tamaño del sistema de ficheros a 1 Exabay = 2^20 Terabyte y del tamaño máximo por archivo (16 Tb).

Número ilimitado de directorios frente a los 32.000 de Ext3

Mayor velocidad en la creación y borrado de ficheros

GNU/Linux Sistemas de archivos en Linux XFS Implementado para sistemas Unix, rápido acceso para grandes

GNU/Linux

Sistemas de archivos en Linux

GNU/Linux Sistemas de archivos en Linux XFS Implementado para sistemas Unix, rápido acceso para grandes cantidades

XFS Implementado para sistemas Unix, rápido acceso para grandes cantidades de datos

y altas velocidades, pero lento en ficheros pequeños. Se utiliza en grandes servidores y donde se maneje mucha información.

ReiserFS Sistema de archivos diseñado e implementado por la empresa Namesys,

liderado por Hans Reiser. Es soportado por Linux y otros sistemas operativos (algunos a

través de implementaciones muy inestables).

Fat16/Fat32 Sistemas Dos/Windows 95, Windows 98, este sistema de archivos produce una gran fragmentación del disco.

NTFS sistema de archivos implementado para los sistemas operativos Windows Xp/2000/2003 server y Vista.

GNU/Linux Sistemas de archivos en Linux

GNU/Linux Sistemas de archivos en Linux

GNU/Linux Sistemas de archivos en Linux
GNU/Linux Sistemas de archivos en Linux
GNU/Linux Directorios Linux

GNU/Linux Directorios Linux

GNU/Linux Directorios Linux
GNU/Linux Directorios Linux
GNU/Linux Directorios Linux

GNU/Linux Directorios Linux

GNU/Linux Directorios Linux
GNU/Linux Directorios Linux
GNU/Linux Directorios Linux

GNU/Linux Directorios Linux

GNU/Linux Directorios Linux
GNU/Linux Directorios Linux
GNU/Linux Directorios Linux

GNU/Linux Directorios Linux

GNU/Linux Directorios Linux
GNU/Linux Directorios Linux
GNU/Linux Directorios Linux

GNU/Linux Directorios Linux

GNU/Linux Directorios Linux
GNU/Linux Directorios Linux
GNU/Linux Directorios Linux Asterisk

GNU/Linux Directorios Linux Asterisk

GNU/Linux Directorios Linux Asterisk
GNU/Linux Directorios Linux Asterisk
GNU/Linux Directorios Linux Asterisk

GNU/Linux Directorios Linux Asterisk

GNU/Linux Directorios Linux Asterisk
GNU/Linux Directorios Linux Asterisk
Trunk IAX Solucionado

Trunk IAX Solucionado

Trunk IAX Solucionado
Trunk IAX Solucionado
LAB Entronque PBX Asterisk PBX-IP 1 PBX-IP 2 192.168.1.50 192.168.1.51 SIP SIP 741 10 741

LAB Entronque PBX Asterisk

PBX-IP 1

PBX-IP 2

192.168.1.50

192.168.1.51

PBX-IP 1 PBX-IP 2 192.168.1.50 192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A
PBX-IP 1 PBX-IP 2 192.168.1.50 192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A
SIP
SIP

SIP

1 PBX-IP 2 192.168.1.50 192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A X
1 PBX-IP 2 192.168.1.50 192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A X

741 10

741 11

2 192.168.1.50 192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A X SIP 741
2 192.168.1.50 192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A X SIP 741

SIP

Trunk

IAX

SIP
SIP
192.168.1.51 SIP SIP 741 10 741 11 SIP Trunk I A X SIP 741 20 741

741 20

741 21

Extensiones

741 10 741 19

Buzon de Voz

Extensiones

741 20 741 29

Buzon de Voz

Asterisk es el líder mundial en plataformas de telefonía de código abierto. Asterisk es un
Asterisk es el líder mundial en plataformas de telefonía de código abierto. Asterisk es un

Asterisk es el líder mundial en plataformas de telefonía de código abierto.

Asterisk es un software que puede convertir un ordenador de propósito general en un sofisticado servidor de comunicaciones VoIP.

Es un sistema de centralita IP utilizado por empresas de todos los tamaños para mejorar

su comunicación, incluyendo a Google, Yahoo, IBM, e incluso el Ejército de EE.UU.

Asterisk: Principales ventajas Funcionalidad Asterisk dispone de todas las funcionalidades de las grandes centralitas

Asterisk: Principales ventajas

Asterisk: Principales ventajas Funcionalidad Asterisk dispone de todas las funcionalidades de las grandes centralitas

Funcionalidad Asterisk dispone de todas las funcionalidades de las grandes centralitas propietarias (Cisco,

Avaya, Alcatel, Siemens, etc). Desde las más básicas (desvios, capturas, transferencias, multi-

conferencias, …) hasta las más avanzadas (Buzones de voz, IVR, CTI, ACD…).

Escalabilidad El sistema puede dar servicio desde 10 usuarios en una sede de una pequeña empresa, hasta

10.000 de una multinacional repartidos en múltiples sedes.

Competitividad en costo

No solo por ser un sistema de código abierto (Open Source) sino gracias a su arquitectura hardware: utiliza plataforma servidor estándar (de propósito no específico) y tarjetas PCI

para los interfaces de telefonía, que por la competencia del mercado se han ido abaratando

progresivamente.

Asterisk: Funcionalidades básicas y avanzadas Funciones básicas: Transferencias (directa o consultiva): Permite

Asterisk: Funcionalidades básicas y avanzadas

Asterisk: Funcionalidades básicas y avanzadas Funciones básicas: Transferencias (directa o consultiva): Permite

Funciones básicas:

Transferencias (directa o consultiva): Permite transferir una llamada en curso a otra extensión.

Existen dos formas:

Transferencia atendida: consultando al nuevo destino si quiere que le pasen la llamada.

Transferencia directa: pasando la llamada sin consultar al destinatario.

Desvíos: Permiten la transferencia automática de una llamada entrante hacia un número

determinado (interno o externo) cuando se cumplen determinadas condiciones: por ejemplo si el número esta ocupado, si no contesta, etc.

Capturas (de grupo o de extensión): La captura permite coger una llamada que se esta

recibiendo en una extensión desde otra distinta.

Asterisk: Funcionalidades básicas y avanzadas Captura de grupo: se predefinen unos deteminados grupos de extensiones

Asterisk: Funcionalidades básicas y avanzadas

Asterisk: Funcionalidades básicas y avanzadas Captura de grupo: se predefinen unos deteminados grupos de extensiones de

Captura de grupo: se predefinen unos deteminados grupos de extensiones de modo que al marcar un coódigo de asterisk - por defecto el *8 - cualquier llamada que esté recibiendo el grupo en el que estamos.

Conferencia múltiple: En función del modelo de terminal se podrá establecer una

comunicación entre múltiples usuarios de la PBX

Llamada directa a extensión: Si además del número de cabecera disponemos de diferentes números públicos , podremos enrutar directamente la llamada entrante a uno de los anexos,

a una extensión de la PBX

Ring groups: grupos de llamadas. Una llamada entrante podrá ser dirigida directamente a un

ring group, que es un grupo de extensiones que sonaran de acuerdo a una determinada

estrategia previamente establecida.

DND (Do not disturbe): Opción de no molestar, que podrá ser configurado en Asterisk mediante un código o directamente en el terminal.

Asterisk: Funcionalidades básicas y avanzadas Funciones avanzadas: Correo Vocal (Voicemail) integrado con correo

Asterisk: Funcionalidades básicas y avanzadas

Asterisk: Funcionalidades básicas y avanzadas Funciones avanzadas: Correo Vocal (Voicemail) integrado con correo

Funciones avanzadas:

Correo Vocal (Voicemail) integrado con correo electrónico. En caso de que el usuario no pueda atender una llamada, se puede programar que se transfiera a un sistema de buzón de

voz. En caso de que se deje un mensaje, se enviará un correo electrónico avisando del mismo

al usuario destinatario.

Operadora Automática (IVR): Una operadora automática o IVR es una aplicación de telefonía que permite interactuar con el usuario que realiza la llamada, de forma que éste pueda

pulsar opciones previamente anunciadas y acceder de forma automática a los destinos

programados.

Música en espera con archivos WAV: Asterisk nos permite introducir categorías de música

en espera basadas en archivos .wav y mp3. De este modo podremos poner diferentes

melodías para ser reproducidas como música en espera.

Asterisk: Funcionalidades básicas y avanzadas Colas de Llamadas (ACD) : Un sistema de colas o

Asterisk: Funcionalidades básicas y avanzadas

Asterisk: Funcionalidades básicas y avanzadas Colas de Llamadas (ACD) : Un sistema de colas o ACD

Colas de Llamadas (ACD) : Un sistema de colas o ACD es una aplicación que distribuye las llamadas entrantes a un grupo específico de agentes de acuerdo a una determinada estrategia. Si la llamada no puede ser descolgada, no se pierde y puede ser transferida a otro destino.

Salas de Audio-Conferencias: Una sala de audioconferencias es un sistema que permite conectar a multiples usuarios en una misma conversación telefonica. Los usuarios pueden

acceder a la sala desde una extensión interna, o bien desde el exterior (a traves de un número directo o bien a traves de un IVR). Es un sistema muy útil para hacer reuniones

internas (por ejemplo seguimiento de ventas) o bien con clientes o proveedores.

Informes detallados de llamadas (CDR): Detalle de llamadas realizadas/recibidas por

extensión, para realizar cobros, por cliente o incluso para facturación.

Integración CTI: Integración de la telefonía con sistemas informatizados de gestión comercial

o de atención a cliente (CRM). Estos sistemas permiten por ejemplo ejecutar una llamada desde el PC o bien recibir información sobre una llamada entrante en la pantalla.

Soporte Ingeniería
Soporte
Ingeniería
Soporte Ingeniería Ventas Conexión Empresarial PBX-IP ASTERISK VoIP PSTN E1 27410100 27410200 INTERNET NGN

Ventas

Soporte Ingeniería Ventas Conexión Empresarial PBX-IP ASTERISK VoIP PSTN E1 27410100 27410200 INTERNET NGN
Soporte Ingeniería Ventas Conexión Empresarial PBX-IP ASTERISK VoIP PSTN E1 27410100 27410200 INTERNET NGN
Soporte Ingeniería Ventas Conexión Empresarial PBX-IP ASTERISK VoIP PSTN E1 27410100 27410200 INTERNET NGN
Soporte Ingeniería Ventas Conexión Empresarial PBX-IP ASTERISK VoIP PSTN E1 27410100 27410200 INTERNET NGN
Soporte Ingeniería Ventas Conexión Empresarial PBX-IP ASTERISK VoIP PSTN E1 27410100 27410200 INTERNET NGN
Soporte Ingeniería Ventas Conexión Empresarial PBX-IP ASTERISK VoIP PSTN E1 27410100 27410200 INTERNET NGN

Conexión Empresarial

PBX-IP

ASTERISK

VoIP PSTN
VoIP
PSTN
Ventas Conexión Empresarial PBX-IP ASTERISK VoIP PSTN E1 27410100 27410200 INTERNET NGN SoftSwitch PSTN

E1

27410100

27410200

INTERNET
INTERNET

NGN

SoftSwitch

Empresarial PBX-IP ASTERISK VoIP PSTN E1 27410100 27410200 INTERNET NGN SoftSwitch PSTN Sucursales DMZ Server DHCP
PSTN Sucursales
PSTN
Sucursales
DMZ
DMZ
Empresarial PBX-IP ASTERISK VoIP PSTN E1 27410100 27410200 INTERNET NGN SoftSwitch PSTN Sucursales DMZ Server DHCP
Empresarial PBX-IP ASTERISK VoIP PSTN E1 27410100 27410200 INTERNET NGN SoftSwitch PSTN Sucursales DMZ Server DHCP

Server

DHCP

Si no marca ninguna opción debe volver al menú IVR ASTERISK 0211 solo una vez
Si no marca ninguna opción debe volver al menú
IVR ASTERISK
0211
solo una vez mas.
Si nadie contesta en Soporte o están ocupados
Soporte
PBX-IP
reenviar la llamada a Soporte de la PBX
0212
de su compañero.
Si nadie contesta en Ventas o están ocupados
0213
reenviar la llamada a Ventas de la PBX
de su compañero.
0214
Entronque
Si nadie contesta en Ingeniería poner grabación
IAX
Ingeniería
0215
PBX-IP
Entronque
27410210 - 27410219
SIP
Menu IVR
0216
Bienvenidos
0217
1.
Marque 1 para Ventas
Ventas
2.
Marque 2 para Ingeniería
NGN
0218
3.
Marque 3 para Soporte
0219

27410200

IVR ASTERISK ANEXO Nombre       2741 0010 19 Claudio Andreas Buccioni Tor  

IVR ASTERISK

ANEXO Nombre
ANEXO

ANEXO

Nombre

 
     
   

2741

0010

19

Claudio Andreas Buccioni Tor

 
     
   

2741

0020

29

Fernando Esteban Villalon Ca

 
     
   

2741

0030

39

Samuel Fabrizio Sbraga Rodri

 
     
   

2741

0040

49

Juan Alberto Caceres Lopez

 
     
   

2741

0050

59

Giordano Antonio Leita Santi

 
     
   

2741

0060

69

Hernan Alexander Ponce Con

 
     
   

2741

0070

79

Edgardo Alfredo Marin Barra

 
     
   

2741

0080

89

Claudio Abel Huerta Perez

 
     
   

2741

0090

99

Daniel Ignacio Pinto Irarraza

 
     
   

2741

0100

109

Airon Brian Veliz Diaz

 
     
   

2741

0110

119

Hernan Ignacio Lineros Araya

 
     
   

2741

0120

129

Cristobal Sebastian Saavedra

 
     
   

2741

0130

139

Franco Jordano Vicencio Roja

 
     
   

2741

0140

149

Fernando Javier Lopez Casan

 
     
   

2741

0150

159

Alex Mauricio Andaur Osorio

 
     
   

2741

0160

169

Patricio Alejandro Rojas Carr

 
     
   

2741

0170

179

Matias Ignacio Vera Caballer

 
     
   

2741

0180

189

Pablo Ignacio Torres Rojas

 
     
   

2741

0190

199

Vicente Antonio Gutierrez R

IVR ASTERISK   Anexo Nombre 2751 0010 19 Pedro Andrés Guzman Rojas 2751 0020 29

IVR ASTERISK

 

Anexo

Nombre

2751

0010

19

Pedro Andrés Guzman Rojas

2751

0020

29

Alejandro Ignacio Toro Alvarez

2751

0030

39

Cristobal Aleksandar Lenac Belmar

2751

0040

49

Angel Patricio Carvajal Flores

2751

0050

59

Cesar Alejandro Velasquez Avila

2751

0060

69

Franco Eduardo Aros Alfaro

2751

0070

79

Patricio Alejandro Rojas Carreras

2751

0080

89

Francisco Alberto Salas Acuna