Comandos de configuración IOS Cisco.

Switch:
 Ingresar modo privilegiado.
Switch> enable
Switch#

Borrar las configuraciones del switch.

Switch# erase startup-config
Switch# delete flash:vlan.dat
Switch# reload

Ingresa modo configuración global.

Switch# configure terminal
Switch(config)#

Asigna el nombre del switch.

Switch(config)# hostname S1

Configura cifrado de password.

S1(config)# service password-encryption

Asigna contraseña class para acceder a modo EXEC privilegiado

S1(config)# enable secret class

Previene resolución DNS.

S1(config)# no ip domain-lookup

Configura un banner MOTD.

S1(config)# banner motd #Acceso no autorizado está estrictamente
prohibido#

 Configura SVI para administrar remotamente al switch
Crear VLAN.
S1(config)# vlan 99
S1(config-vlan)# exit
S1(config)# interface vlan99
S1(config-if)# ip address 192.168.1.2 255.255.255.0
S1(config-if)# no shutdown
S1(config-if)# exit

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 1

 Asigna une puerto a VLAN.
S1(config-if)# interface f0/6
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 99
S1(config-if)# end
 Asigna un rango de puertos a VLAN.
S1(config)# interface range f0/1 – 24,g0/1 - 2
S1(config-if-range)# switchport mode access
S1(config-if-range)# switchport access vlan 99
S1(config-if-range)# exit
 Verificar VLAN y asignación de puertos a VLANs.
S1# show vlan brief
Configura Gateway por defecto.
S1(config)# ip default-gateway 192.168.1.1

Configuración de protección de consola y evitar que logs rompan el
comando ingresado.
S1(config)# line con 0
S1(config-line)# password cisco
S1(config-line)# login
S1(config-line)# logging synchronous
S1(config-line)# exit
 Habilitación y protección de líneas de terminal virtual, VTY.
S1(config)# line vty 0 15
S1(config-line)# password cisco
S1(config-line)# login
S1(config-line)# end

Guardar las configuraciones en la NVRAM
S1# copy running-config startup-config

Verificar las MAC aprendidas por el switch
S1# show mac address-table

Borrar MACs aprendidas dinámicamente.
S1# clear mac address-table dynamic
 Ver contenido de la flash.
Switch# show flash

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 2

 Crear y nombrar VLAN.
S1(config)# vlan 99
S1(config-vlan)# name Management
S1(config-vlan)# exit
 Configura SSH en un switch.
S1(config)# ip domain-name duoc.cl
S1(config)# username admin privilege 15 secret tupass
S1(config)# crypto key generate rsa modulus 1024
S1(config)# line vty 0 15
S1(config-line)# transport input ssh
S1(config-line)# login local
S1(config-line)# exit

Opcionales para SSH. Cambia a la version 2, cambia el tiempo de inactividad
a 75 segundos y los reintentos a 2.
S1(config)# ip ssh version 2
S1(config)# ip ssh time-out 75
S1(config)# ip ssh authentication-retries 2
 Configura seguridad de Puerto en un switch.
S1(config)# interface f0/5
S1(config-if)# switchport port-security
S1(config-if)# switchport port-security mac-address sticky
S1(config-if)# switchport port-security maximum 1
S1(config-if)# switchport port-security violation shutdown
 Configurar Puerto troncal.
S1(config)# interface f0/1
S1(config-if)# switchport mode trunk
 Permitir VLAN en los puertos troncales.
S1(config)# interface f0/1
S1(config-if)#switchport trunk allowed vlan 1,10,2,30
 Modificar VLAN nativa en los troncales.
S1(config)# interface f0/1
S1(config-if)#switchport trunk native vlan 30

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 3

Router:
 Ingresa a modo privilegiado
Router> enable
Router#

Borrar las configuraciones del switch.

Router# erase startup-config
Router# reload
System configuration has been modified. Save? [yes/no]: no

 Ingresa a modo de configuración global.
Router# config terminal
Router(config)#
 Configura nombre del router.
Router(config)# hostname R1
 Deshabilita búsqueda DNS.
R1(config)# no ip domain-lookup
 Requiere que el largo mínimo de contraseña se a de 10 caracteres.
R1(config)# security passwords min-length 10
 Configura contraseña modo privilegiado protegida.
R1(config)# enable secret cisco12345
 Configura contraseña para el ingreso de la consola.
R1(config)# line con 0
R1(config-line)# password ciscoconpass
R1(config-line)# exec-timeout 5 0
R1(config-line)# login
R1(config-line)# logging synchronous
R1(config-line)# exit

 Configura contraseña para las líneas VTY.
R1(config)# line vty 0 4
R1(config-line)# password ciscovtypass
R1(config-line)# exec-timeout 5 0
R1(config-line)# login
R1(config-line)# logging synchronous
R1(config-line)# exit

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 4

 Cifra las contraseñas.
R1(config)# service password-encryption
 Configura un banner de mensaje.
R1(config)# banner motd #Accesos no autorizados están prohibidos#
 Configura y describe una interfaz para IPv4 e IPv6.
R1(config)# int g0/0
R1(config-if)# description Connection to PC-B
R1(config-if)# ip address 192.168.0.1 255.255.255.0
R1(config-if)# no shutdown
R1(config)# interface g0/0
R1(config-if)# ipv6 address 2001:db8:acad:a::1/64
R1(config-if)# ipv6 address fe80::1 link-local
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# ipv6 unicast-routing
R1(config)# exit

Configura el reloj del router.
R1# clock set 17:00:00 18 Feb 2013

Guarda las configuraciones en la NVRAM.
R1# copy running-config startup-config
 Configura SSH en el router.
R1(config)# ip domain-name duoc.cl
R1(config)# username admin privilege 15 secret micontraseña
R1(config)# line vty 0 4
R1(config-line)# transport input ssh
R1(config-line)# login local
R1(config-line)# exit
R1(config)# crypto key generate rsa modulus 1024
R1(config)# exit
 Configurar enrutamiento inter-VLAN con subinterfaces de routers.
Crear la subinterfaz y asociarla a la VLAN correcta.
R1(config)# interface g0/1.10
R1(config-subif)# encapsulation dot1Q 10
R1(config-subif)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# no shutdown

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 5

 Configuración de interfaces seriales.
R3(config)# interface s0/0/0
R3(config-if)# ip address 10.1.1.2 255.255.255.252
R3(config-if)# clock rate 128000
R3(config-if)# no shutdown
 Configurar una Ruta estática recursiva.
R1(config)# ip route 192.168.1.0 255.255.255.0 10.1.1.2
 Configurar una ruta estática directamente conectada.
R3(config)# ip route 192.168.0.0 255.255.255.0 s0/0/0
 Configurar una ruta estática por defecto.
R1(config)# ip route 0.0.0.0 0.0.0.0 s0/0/1
R1(config)# ip route 0.0.0.0 0.0.0.0 10.1.1.2
IPv6
 Habilitar enrutamiento Ipv6.
R1(config)# ipv6 unicast-routing
 Configurar direccionamiento IPv6 en una interfaz.
R1(config)# interface g0/1
R1(config-if)# ipv6 address 2001:DB8:ACAD:A::/64 eui-64
R1(config-if)# no shutdown
R1(config-if)# interface serial 0/0/1
R1(config-if)# ipv6 address FC00::1/64
R1(config-if)# no shutdown
R1(config-if)# exit
 Configurar ruta estática IPv6
R1(config)# ipv6 route 2001:DB8:ACAD:B::/64 serial 0/0/1
R1(config)# ipv6 route 2001:DB8:ACAD:B::/64 FC00::2
 Configurar ruta por defecto IPv6
R1(config)# ipv6 route ::/0 serial 0/0/1

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 6

 Configurando RIPv2
R1# config t
R1(config)# router rip
R1(config-router)# version 2
R1(config-router)# passive-interface g0/1
R1(config-router)# network 172.30.0.0
R1(config-router)# network 10.0.0.0
R1(config-router)# no auto-summary
 Configurando RIPng
R1(config)# ipv6 rip Test1
R1(config)# interface g0/1
R1(config)# ipv6 rip Test1 enable
 Configuración de ruta estática y redistribución de ella.
R2(config)# ipv6 route ::0/64 2001:db8:acad:b::b
R2(config)# int s0/0/0
R2(config-rtr)# ipv6 rip Test2 default-information originate

 Configurando OSPF
R1(config)# router ospf 1
R1(config-router)# network 192.168.1.0 0.0.0.255 area 0
 Crear interfaz loopback, usado para el router ID.
R1(config)# interface lo0
R1(config-if)# ip address 1.1.1.1 255.255.255.255
R1(config-if)# end
 Configuración de Router ID
R1(config)# router ospf 1
R1(config-router)# router-id 11.11.11.11
 Configuración de interfaces pasivas.
R1(config)# router ospf 1
R1(config-router)# passive-interface g0/0
 Alternativa.
R2(config)# router ospf 1
R2(config-router)# passive-interface default
R2(config-router)# no passive-interface s0/0/0

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 7


R1#
R1#
R1#
R1#
R1#
R1#

Verificar OSPF.
show ip ospf neighbor
show ip route
show ip protocols
show ip ospf
show ip ospf interface brief
show ip ospf interface

Modificar ancho de banda de referencia, usado para el cálculo de costo
OSPF.
R1(config)# router ospf 1
R1(config-router)# auto-cost reference-bandwidth 10000
 Modificar ancho de banda de interfaz para modificar el costo
R1(config)# interface s0/0/0
R1(config-if)# bandwidth 128
 Modificar el costo de una interfaz.
R1(config)# int s0/0/1
R1(config-if)# ip ospf cost 1565
 Redistribuir ruta por defecto en OSPF.
R1(config)#ip route 0.0.0.0 0.0.0.0 s0/0/0
R1(config)#router ospf 1
R1(config-router)#default-information originate

Modificar temporizadores OSPF.

R1(config)#interface serial0/0/0
R1(config-if)#ip ospf hello-interval 5
R1(config-if)#ip ospf dead-interval 20

Modificar prioridad OSPF para influenciar la elección de DR y BDR.

R1(config)#interface fastEthernet0/0
R1(config-if)#ip ospf priority 255
R1(config-if)#end

Sumarización OSPF en el ABR, o sea, entre áreas.

R1(config-router)#area 1 range 192.168.1.0 255.255.255.0

Sumarización OSPF en el ASBR, o sea, redes externas.

R1(config-router)#summary-address 192.168.1.0 255.255.255.0

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 8

Autenticación OSPF.

R1(config)#interface Serial0/1/0
R1(config-if)#ip address 172.16.34.3 255.255.255.0
R1(config-if)#ip ospf authentication message-digest
R1(config-if)#ip ospf message-digest-key 1 md5 cisco

 OSPFV3
R1(config)#ipv6 unicast-routing
R1(config)# ipv6 router ospf 1
R1(config-rtr)# router-id 1.1.1.1
R1(config)# interface g0/0
R1(config-if)# ipv6 ospf 1 area 0

R1#
R1#
R1#
R1#
R2#

Verificación.
show ipv6 ospf neighbor
show ipv6 protocols
show ipv6 ospf interface
show ipv6 ospf interface brief
show ipv6 route

 Configurar interfaces pasivas.
R1(config)# ipv6 router ospf 1
R1(config-rtr)# passive-interface g0/0
 Alternativa.
R2(config)# ipv6 router ospf 1
R2(config-rtr)# passive-interface default
R2(config-rtr)# no passive-interface s0/0

 EIGRP.
R1(config)#ipv6 unicast-routing
R1(config)# ipv6 router eigrp 100
R1(config-rtr)# router-id 1.1.1.1
R1(config-rtr)# no shutdwon
R1(config)# interface g0/0
R1(config-if)# ipv6 eigrp 100

 Túnel.
R1(config)# interface
R1(config-if)# tunnel
R1(config-if)# tunnel
R1(config-if)# tunnel

tunnel0
mode ipv6ip
source serial0/0/0
destination 172.16.23.3

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 9

R1(config-if)# ipv6 address FEC0::13:1/112
R3(config)# interface tunnel0
R3(config-if)# tunnel mode ipv6ip
R3(config-if)# tunnel source serial0/0/1
R3(config-if)# tunnel destination 172.16.12.1
R3(config-if)# ipv6 address FEC0::13:3/112

 Creación y aplicación de una ACL estándar numerada.
R3(config)# access-list 1 remark Allow R1 LANs Access
R3(config)# access-list 1 permit 192.168.10.0 0.0.0.255
R3(config)# access-list 1 permit 192.168.20.0 0.0.0.255
R3(config)# access-list 1 deny any
R3(config)# interface g0/1
R3(config-if)# ip access-group 1 out
 Verificar ACL.
R3# show access-list 1
 Creación de ACL estándar nombrada.
R1(config)# ip access-list standard NOMBREACL
R1(config-std-nacl)# permit host 192.168.30.3
R1(config-std-nacl)# permit 192.168.40.0 0.0.0.255
R1(config-std-nacl)# end
R1(config)# interface g0/1
R1(config-if)# ip access-group NOMBREACL out
 Modificar una ACL nombrada.
R1#(config)# ip access-list standard NOMBREACL
R1(config-std-nacl)# 30 permit 209.165.200.224 0.0.0.31
R1(config-std-nacl)# 40 deny any
R1(config-std-nacl)# end
 Crear una ACL para proteger las líneas VTY.
R1(config)# ip access-list standard ADMIN-MGT
R1(config-std-nacl)# permit host 192.168.1.3
R1(config-std-nacl)# permit 192.168.1.4 0.0.0.3
R1(config-std-nacl)# deny any
R1(config-std-nacl)# exit
R1(config)# line vty 0 4
R1(config-line)# access-class ADMIN-MGT in
R1(config-line)# exit

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 10

 Verificar ACL.
R1# show ip access-lists
 Habilitar servicio web.
R1(config)# ip http server
R1(config)# ip http authentication local
R1(config)# username admin privilege 15 secret class

 Crear y aplicar ACL extendida numerada.
R1(config)# access-list 100 remark Permite Web & acceso SSH
R1(config)# access-list 100 permit tcp host 192.168.10.3 host
10.2.2.1 eq 22
R1(config)# access-list 100 permit tcp any any eq 80
R1(config)# int s0/0/0
R1(config-if)# ip access-group 100 out
 Crear y aplicar ACL extendida nombrada.
R3(config)# ip access-list extended POLITICA-WEB
R3(config-ext-nacl)# permit tcp 192.168.30.0 0.0.0.255 host
10.1.1.1 eq 80
R3(config-ext-nacl)# permit tcp 192.168.30.0 0.0.0.255
209.165.200.224 0.0.0.31 eq 80
R3(config-ext-nacl)# int S0/0/1
R3(config-if)# ip access-group POLITICA-WEB out

 Modificar una ACL numerada.
R1(config)# ip access-list extended 100
R1(config-ext-nacl)# 30 permit ip 192.168.10.0 0.0.0.255
192.168.30.0 0.0.0.255
R1(config-ext-nacl)# end
 Modificar una ACL nombrada.
R3(config)# ip access-list extended WEB-POLICY
R3(config-ext-nacl)# 30 permit ip 192.168.30.0 0.0.0.255
192.168.10.0 0.0.0.255
R3(config-ext-nacl)# end
 Creación y aplicación de ACL IPv6 para proteger acceso VTY.
R1(config)# ipv6 access-list RESTRICT-VTY
R1(config-ipv6-acl)# permit tcp 2001:db8:acad:a::/64 any
R1(config-ipv6-acl)# permit tcp any any eq 22
R1(config-ipv6-acl)# line vty 0 4
R1(config-line)# ipv6 access-class RESTRICT-VTY in

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 11

R1(config-line)# end
 Creación y aplicación de una ACL IPv6 para restringir TELNET.
R1(config)# ipv6 access-list RESTRICTED-LAN
R1(config-ipv6-acl)# remark Block Telnet from outside
R1(config-ipv6-acl)# deny tcp any 2001:db8:acad:a::/64 eq telnet
R1(config-ipv6-acl)# permit ipv6 any any
R1(config-ipv6-acl)# int g0/1
R1(config-if)# ipv6 traffic-filter RESTRICTED-LAN out
R1(config-if)# end

Verificar ACL IPv6.
R1# show ipv6 access-lists RESTRICTED-LAN
 Editar una declaración de ACL.
R1(config)# ipv6 access-list RESTRICTED-LAN
R1(config-ipv6-acl)# permit tcp 2001:db8:acad:b::/64 host
2001:db8:acad:a::a eq 23 sequence 15

 Configuración de EIGRP.
R1(config)# router eigrp 1
R1(config-router)# network 192.168.0.0 0.0.0.255
R1(config-router)# network 192.168.1.0 0.0.0.255
R1(config-router)# network 192.168.2.252 0.0.0.3
R1(config-router)# no auto-summary

Sumarización manual EIGRP.

R3(config)# interface Serial 0/0/1
R3(config-if)# ip summary-address eigrp 100 192.168.0.0
255.255.224.0
 Redistribución de ruta estática o por defecto.
R2(config)# ip route 0.0.0.0 0.0.0.0 209.165.200.225
R2(config)# router eigrp 1
R2(config-router)# network 192.168.2.252 0.0.0.3
R2(config-router)# redistribute static
R2(config-router)# exit
 Redistribución de una red directamente conectada.
R2(config)# router eigrp 1
R2(config-router)# redistribute conected
R2(config-router)# exit

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 12

 Sumarizar redes en EIGRP.
R3(config)#interface serial0/0/0
R3(config-if)#ip summary-address eigrp 1 192.168.0.0 255.255.252.0
 Desactivar actualizaciones EIGRP en una interfaz.
R2(config)#router eigrp 1
R2(config)#passive-interface FastEthernet0/0
 Configurar DHCP.
R2(config)# ip dhcp excluded-address 192.168.1.1 192.168.1.9
R2(config)# ip dhcp pool R1G1
R2(dhcp-config)# network 192.168.1.0 255.255.255.0
R2(dhcp-config)# default-router 192.168.1.1
R2(dhcp-config)# dns-server 209.165.200.225
R2(dhcp-config)# domain-name ccna-lab.com
R2(dhcp-config)# lease 2
R2(dhcp-config)# exit
 Configurar DHCP relay o forward.
R1(config)# interface g0/0
R1(config-if)# ip helper-address 192.168.2.254
R1(config-if)# exit

R2#
R2#
R2#
R2#

Verificar DHCP.
show ip dhcp binding
show ip dhcp server statistics
show ip dhcp pool
show run | section dhcp

 Configurar DHCPV6.
R1(config)# ipv6 dhcp pool IPV6POOL-A
R1(config-dhcpv6)# address prefix 2001:db8:acad:a::/64
R1(config-dhcpv6)# dns-server 2001:db8:acad:a::abcd
 Configurar NAT estático.
Gateway(config)# ip nat inside source static 192.168.1.20
209.165.200.225
Gateway(config)# interface g0/1
Gateway(config-if)# ip nat inside
Gateway(config-if)# interface s0/0/1
Gateway(config-if)# ip nat outside
 Configurar NAT dinámico.
Gateway(config)# access-list 1 permit 192.168.1.0 0.0.0.255

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 13

Gateway(config)# ip nat pool public_access 209.165.200.242
209.165.200.254 netmask 255.255.255.224
Gateway(config)# ip nat inside source list 1 pool public_access
 Verificar NAT.
Gateway# show ip nat translations
Gateway# show ip nat statics
Gateway# show ip nat statistics

 Configurar NAT sobrecargado (overload o PAT)
Gateway(config)# access-list 1 permit 192.168.1.0 0.0.0.255
Gateway(config)# ip nat inside source list 1 interface serial 0/0/1
overload
Gateway(config)# interface g0/1
Gateway(config-if)# ip nat inside
Gateway(config-if)# interface s0/0/1
Gateway(config-if)# ip nat outside

Configurar ppp

R1(config)# interface Serial0/0/0
R1(config)# encapsulation ppp

Autenticación PAP (El router vecino se llama R2)

R1(config)#username R2 password cisco
R1(config)# interface Serial0/0/0
R1(config-if)# ppp authentication pap
R1(config-if)# ppp pap sent-username R1 password cisco

Autenticación CHAP

R1(config)#username R2 password cisco
R1(config)# interface Serial0/0/0
R1(config-if)# ppp authentication chap

Frame-Relay

R1(config)# interface Serial0/0/0
R1(config-if)#no ip address
R1(config-if)#encapsulation frame-relay
R1(config)# interface Serial0/0/0.100 point-to-point
R1(config-if)# frame-relay interface-dlci 100

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 14

Opcionales Frame-Relay

R1(config)# interface Serial0/0/0
R1(config-if)# encapsulation frame-relay ietf
R1(config-if)# frame-relay lmi-type ansi

Realizado por: Nicolás Contador. DuocUC Viña del Mar

Página 15

Sign up to vote on this title
UsefulNot useful