Está en la página 1de 7

UNIVERSIDAD NACIONAL DE CHIMBORAZO

FACULTAD DE INGENIERA
ESCUELA DE SISTEMAS Y COMPUTACIN

TEMA: Configuracin de redes MPLS


Materia:
Redes de Computadoras III

Nombre:
Carlos Fernando Martnez Cceres

QUINTO SEMESTRE

PERIODO ACADMICO
Septiembre 2014 Marzo 2015

1. INTRODUCCIN
MPLS (Multiprotocol Label Switching):
Es un mecanismo de transporte de datos estndar creado por la IETF (Internet
Engineering Task Force). Opera entre la capa de enlace de datos y la capa de red del
modelo OSI. Puede ser utilizado para transportar diferentes tipos de trfico,
incluyendo trfico de voz y de paquetes IP.
La conmutacin de etiquetas multiprotocolo est remplazando a frame relay y ATM
como tecnologa nueva para llevar datos de alta velocidad y voz digitad en una sola
conexin, presta una mayor fiabilidad y un mayor rendimiento. La capacidad que
tiene MPLS para trasportar trfico de voz hace que sea la solucin para las llamadas
VoIP.
Actualmente Cisco implementa MPLS basndose en la tecnologa CEF (Cisco
Express Forwarding) que es un nuevo esquema de encaminamiento utilizando
soporte hardware para una conmutacin rpida. La idea de CEF es que la tabla de
rutas en cada router permita asignar las interfaces de salida para cada paquete sin
tener que consultar la tabla de rutas tradicional, de forma que se ahorra tiempo. Se
puede decir que el proceso de encaminamiento se hace utilizando hardware
especfico, evitando la consulta lenta en las tablas de rutas tradicionales.

2. OBJETIVOS
GENERAL
El objetivo de esta gua es presentar la prctica de configuracin de una red
MPLS con una topologa de routers CISCO
ESPECFICOS
Configurar routing IP con OSPF en los routers.
Configurar en los routers protocolos de distribucin de etiquetas (TDP y
LDP)
Ajustar el tamao de Maximum Trasmission Unit (MTU) para ser
compatible con los requisitos de funcionamiento de MPLS
Verificar el comportamiento de MPLS en la red, as como la comprobacin
de las variables (tablas) utilizadas por MPLS en su funcionamiento.

3. MARCO TERICO

Topologa para implementar MPLS

Inicializacin de los routers


Router>enable
Router#configure terminal
Router(config)#hostname R1
R1(config)#no ip domain-lookup
R1(config)#exit

Configuracin del direccionamiento IP


Configura las interfaces de todos los routers con las direcciones de la figura,
tanto las interfaces fsicas (Ethernet y serie) como las de Loopback. Utiliza en
cada caso el nombre asignado a cada interfaz tal como viste en el paso
anterior.
En las interfaces serie adems aade el comando clock rate y habiltalas
con el comando no shutdown.
Esta es la configuracin necesaria para R1, R2 y R3 respectivamente:
R1(config)# interface loopback 0
R1(config-if)# ip address 172.16.1.1 255.255.255.0
R1(config-if)# no shutdown
R1(config-if)# interface ethernet 0/0
R1(config-if)# ip address 172.16.12.1 255.255.255.0
R1(config-if)# no shutdown

R2(config)# interface loopback 0


R2(config-if)# ip address 172.16.2.1 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# interface ethernet 0/0
R2(config-if)# ip address 172.16.12.2 255.255.255.0
R2(config-if)# no shutdown
R2(config-if)# interface serial 0/0
R2(config-if)# ip address 172.16.23.2 255.255.255.0
R2(config-if)# clockrate 64000
R2(config-if)# no shutdown
R3(config)# interface loopback 0
R3(config-if)# ip address 172.16.3.1 255.255.255.0
R3(config-if)# no shutdown
R3(config-if)# interface serial 0/0
R3(config-if)# ip address 172.16.23.3 255.255.255.0
R3(config-if)# clockrate 64000
R3(config-if)# no shutdown

Configura OSPF en todos los routers


Configura OSPF en los 3 routers de la topologa en el rea 0. Para ello
configura la clase mayor de las diferentes subredes utilizadas, dado que los
routers anunciarn solamente las subredes que tienen directamente
conectadas.
R1(config)# router ospf 1
R1(config-router)# network 172.16.0.0 0.0.255.255 area 0
R2(config)# router ospf 1
R2(config-router)# network 172.16.0.0 0.0.255.255 area 0
R3(config)# router ospf 1
R3(config-router)# network 172.16.0.0 0.0.255.255 area 0

Comprobacin de la conectividad IP y del funcionamiento de CEF


(Cisco Express Forwarding)
R1#show ip route
R2#show ip route
R3#show ip route

En cada router se pone ese codigo y para poder comprobar que los routers esten
aprendiendo las direciones tiene que salir de la siguiente manera las lookback sale
con /32
O
C
C
O
O

172.16.0.0/16 is variably subnetted, 5 subnets, 2 masks


172.16.23.0/24 [110/74] via 172.16.12.2, 00:04:08, Ethernet0/0
172.16.12.0/24 is directly connected, Ethernet0/0
172.16.1.0/24 is directly connected, Loopback0
172.16.3.1/32 [110/75] via 172.16.12.2, 00:04:08, Ethernet0/0
172.16.2.1/32 [110/11] via 172.16.12.2, 00:04:08, Ethernet0/0

Habilita MPLS en todas las interfaces fsicas


Configura MPLS en todas las interfaces fsicas (no en las interfaces
virtuales o de loopback) de los routers de la figura .
R1(config)# interface ethernet0/0
R1(config-if)# mpls ip
R2(config)# interface ethernet0/0
R2(config-if)# mpls ip
*Mar

1 00:42:34.996: %LDP-5-NBRCHG: TDP Neighbor 172.16.1.1:0 is UP

R2(config-if)# interface serial0/0


R2(config-if)# mpls ip
R3(config)# interface serial0/0
R3(config-if)# mpls ip
*Mar

1 00:44:44.164: %LDP-5-NBRCHG: TDP Neighbor 172.16.2.1:0 is UP

Verifica la configuracin de MPLS


Para comprobar el funcionamiento de MPLS utilizamos el siguiente comando
show mpls interface y as sabremos qu tipo de protocolo de intercambio
de etiquetas est usando.

R1# show mpls interfaces


Interface
Ethernet0/0

IP
Tunnel
Yes (tdp)No

Operational
Yes

R2# show mpls interfaces


Interface
Ethernet0/0
Serial0/0

IP
Tunnel
Yes (tdp)No
Yes (tdp)No

Operational
Yes
Yes

R3# show mpls interfaces


Interface
Serial0/0

IP
Tunnel
Yes (tdp)No

Operational
Yes

Migrando de TDP a LDP


TDP es un subconjunto de LDP. Vamos a modificar la configuracin de MPLS
en los routers para utilizar LDP en lugar de TDP.
Esto se puede hacer en todos los routers es opcional.
En el router R2 aade en modo global:
R2 (config)# mpls label protocol ldp

Modifica el tamao de MTU para MPLS


Vamos a modificar los MTU de los routers R1 y R2 ya que por defecto viene
1500 bits y cambindole vamos a permitir que los dos routers soporten
hasta 2 cabeceras. Para modificar MTU usamos los siguientes comandos.
R1(config)# interface fastethernet 0/0
R1(config-if)# mpls mtu 1508
R2(config)# interface fastethernet0/0
R2(config-if)# mpls mtu 1508

Para verificar que se haya efectuado el cambio ingresamos el siguiente


comando en cada router.
R1# show mpls interface fastethernet 0/0 detail
Interface FastEthernet0/0:
IP labeling enabled (ldp):
Interface config
LSP Tunnel labeling not enabled
BGP tagging not enabled
Tagging operational
Fast Switching Vectors:
IP to MPLS Fast Switching Vector
MPLS Turbo Vector
MTU = 1508

Comprobamos la conexin de MPLS


Intentamos hacer ping entre todos los routers. Si no hoy como hacer ping
verificamos la configuracin de los routers.

4. CONCLUSIONES
MPLS emplea un mecanismo de asignacin de etiquetas para una ruta especfica,
evitando de esta manera las consultas repetitivas con el cual el proceso se
simplifica a un intercambio de etiquetas.
La configuracin de MPLS no es complicada ya que igual que frame relay
necesitamos un protocolo de enrutamiento que en este caso se utiliz OSPD.

5. Recomendaciones

Se recomienda tener cuidado si se trabaja con TDP y LDP.

Se recomienda tener cuidado al momento de modificar MTU.

Observa bien si todos los router estn aprendiendo el enrutamiento OSPF

6. Bibliografa
http://es.wikipedia.org/wiki/Multiprotocol_Label_Switching
http://datatracker.ietf.org/wg/mpls/charter/
http://eia.udg.es/~perev/pdf_versions/sgbp.pdf