Está en la página 1de 7

comandos de configuracion de ccna3

Comandos de Configuracin CCNA 3


CREACIN DE VLANS
S(config)#vlan (ID vlan)
S(config-vlan)#name (nombre)

ASIGNACIN DE VLAN DE ADMINISTRACIN
S(config)#interface vlan (ID vlan)
S(config if)#ip address (direccin ip) (mascara de red)
S(config-if)#no shutdown

ASIGNACIN DE PUERTOS PARA VLANS
S(config-if)#interface range fastethernet (rango de puertos) ej. (fa0/1-5)
S(config-if-range)#switchport mode access activacin de puerto en modo de acceso
S(config-if-range)#switchport access vlan (No. de vlan)
En caso de que solo se le asigne una interface a la vlan y no un rango de interfaces,
entonces la configuracin
sera:
S(config)#interface fastethernet (ID interfaz)
S(config-if)#switchport mode access activacin de puerto en modo de acceso
S(config-if)#switchport access vlan (No. de vlan)

DESACTIVAR MODO DE ACCESO EN PUERTO
S(config-if)#no switchport mode access
S(config-if)#no switchport access vlan (ID vlan)

CONFIGURACIN DEL MODO DE VOZ
S(config)#interface fastethernet (ID interfaz)
S(config-if)#mls qos trust cos garantiza trfico que el trfico de voz se identifique como
trfico prioritario
S(config-if)#switchport voice vlan (No. de vlan)

CONFIGURACIN DE VLAN NATIVA Y ENLACE TRONCAL
S(config)#interface fastethernet (No. de puerto)
S(config-if)#switchport mode trunk
S(config-if)#switchport trunk native vlan (ID vlan)
S(config-if)#switchport trunk allowed vlan (ID vlan) forzar comando de enlace troncal
Comandos de Configuracin CCNA 3
S#show interface trunk muestra informacion de enlaces troncales
Activacin de protocolo de enlace troncal dinmico (DTP)
S(config-if)#switchport mode dynamic auto enlace troncal autodinamico
S(config-if)#switchport mode dynamic desirable enlace troncal dinamico deseado
S(config-if)#switchport nonegotiate desactivacin de DTP
S#show dtp interface ver configuraciones actuales de DTP
S#show vlan brief muestra contenidos de vlan.dat
S#show vlan id (No vlan)
S#show vlan name (nombre)
S#show interfaces fastethernet (ID interfaz) switchport muestra informacion de puerto
S#show interfaces vlan (ID vlan)
S(config)#no vlan (ID vlan) eliminar vlan

LIMPIEZA DEL SWITCH
S#delete flash:vlan.dat
S#erase startup-config borrar informacin de la NVRAM
S#reload

S(config)#banner login mensaje mensaje de aviso, para quitarlo se antepone la palabra
no en el comando
S#copy running-config startup-config copiar informacin a la NVRAM
S#show history ver comandos ingresados recientemente
S#terminal history size 20 establecer tamao del historial
S#terminal history habilitar historial
S#terminal no history size reestablece historial en 10
S#terminal no history deshabilitar el historial
S(config)# ip default-gateway (direccion IP) establecer ip por defaul

CONFIGURACIN DE DUPELX Y VELOCIDAD EN INTERFAZ
S(config-if)#speed 100
S(config-if)#duplex full
S(config-if)#duplex auto duplex automatico
S(config-if)#speed auto velocidad automatica

HABILITACIN DE INTERFAZ WEB
S(config)#ip http authentication enable
S(config)#ip http server
BJD-CCNA3

Comandos de Configuracin CCNA 3
S#show mac-address-table muestra las
direcciones MAC registradas en el switch
S(config)#mac-address-table static (direccin MAC) vlan {1-4096, ALL} interface
(Iddeinterfaz). Asignacin
esttica de MAC, para eliminar una asignacin, solo se le antepone la palabra no al
comando.
S(config)#clear mac-address-table dynamic elimina todas las direcciones MAC que el
switch ha aprendido de
forma dinmica.
Si se desean mantener varios archivos de configuracin de inicio en el dispositivo, se
puede copiar la
configuracin en archivos de distinto nombre utilizando el comando copy con la siguiente
sintxis:
S# copy startup-config flash:filename
La restauracin de una configuracin consiste en copiar la configuracin guardada sobre
la configuracin actual.
S# copy flash:config.bak1 startup-config

COPIA SEGURIDAD DE CONFIGURACIN EN UN SERVIDOR TFTP



S#copy system:running-config tftp:[[[//ubicacin]/directorio]/nombre del archivo]
S#copy nvram:startup-config tftp:[[[//ubicacin]/directorio]/nombre del archivo].

PASOS PARA RECUPERACION DE CONTRASEA EN EL SWITCH














Paso 1. Establecer conexin con el puerto de consola.
Paso 2. Apague el switch. Vuelva a conectar el cable de alimentacin al switch y, en no
ms de 15
segundos, presione el botn Mode mientras la luz verde del LED del sistema est
parpadeando. Siga
presionando el botn Mode hasta que el LED del sistema cambie al color mbar durante
unos segundos
y luego verde en forma permanente. Suelte el botn Mode.
Paso 3. Inicialice el sistema de archivos Flash a travs del comando flash_init.
Paso 4. Cargue
archivos helper mediante el comando load_helper.
Paso 5. Visualice el contenido de la memoria Flash a travs del comando dir flash: Se
mostrar el
sistema de archivos del switch, por ejemplo:
Directory of flash:/
13 drwx 192 Mar 01 1993 22:30:48 c2960-lanbase-mz.122-25.FX
11-rwx 5825 Mar 01 1993 22:31:59 config.text
18 -rwx 720 Mar 01 1993 02:21:30 vlan.dat
16128000 bytes total (10003456 bytes free)
Paso 6. Cambiar el nombre del archivo de configuracin por config.text.old, que contiene
la definicin
de la contrasea, con el comando
rename flash:config.text flash:config.text.old.
Paso 7. Reinicie el sistema con el comando boot.
Paso 8. Se solicitar que ejecute el programa de configuracin inicial contestar N.
Paso 9. Ingresar a modo privilegiado.
Paso 10. Cambie el nombre del archivo de configuracin y vuelva a colocarle el nombre
original
mediante el comando rename flash:config.text.old flash:config.text.
Comandos de Configuracin CCNA 3








Paso 11. Copie el archivo de configuracin en la memoria a travs del comando copy
flash:config.text
system:running-config. Despus de ingresar este comando, se mostrar el siguiente texto
en la consola:
Source filename [config.text]?
Destination filename [running-config]?
Presione Return en respuesta a las solicitudes de confirmacin.
Paso 12. Ingrese al modo de configuracin global.
Paso 13. Cambie la contrasea mediante el comando enable secret password
Paso 14. guarde la configuracin en el modo privilegiado, con el comando copy running-
config startupconfig.
Paso 15. Reinicie el
switch mediante el comando reload.

S(config-line)#transport input telnet habilitar telnet
S(config-line)#transport input all habilita todos los protocolos de transporte

CONFIGURACIN PARA SEGURIDAD EN PUERTO
S(config-if)#switchport mode access
S(config-if)#switchport port-security activar seguridad en puerto
S(config-if)#switchport port-security maximum 2 comando para que acepte solo 2
dispositivos
S(config-if)#switchport port-security mac-address sticky comando para que el switch
aprenda direcciones
mac en forma dinmica.
S(config-if)#switchport port-security violation protect comando para que bloquee el
trfico de hosts invlidos
en caso de violacin.
INDICARLE AL SWITCH LA CAPACIDAD DE APRENDER SLO UNA DIRECCIN EN
SU PUERTO Y QUE SI OTRO DISPOSITIVO SE CONECTA EL PUERTO SE
DESACTIVE.
S(config-if)#switchport port-security maximum 1
S(config-if)#switchport port-security violation shutdown
S#show port-security interface (ID interfaz) verificar la seguridad del puerto
S#show port-security address verificar las direcciones MAC seguras

CONFIGURACIN DE VTP
S(config)#vtp mode server configuracin en modo servidor
S(config)#vtp mode client configuracin en modo cliente
S(config)#vtp mode transparent configuracin en modo transparente
S(config)#vtp domain (nombre) asignar un nombre
S(config)#vtp password (clave) asignar contrasea
S#show vtp status ver el estado de configuracin de vtp
Comandos de Configuracin CCNA 3
CONFIGURACIN DE STP (SPANNING-TREE PROTOCOL)
S(config-if)#spanning-tree cost 25
establecer costo de puerto
S(config-if)#no spanning-tree cost reestablecer el costo
s#show spanning-tree muestra informacin de STP

S(config-if)#spanning-tree portfast configuracin de portfast
S(config-if)#no spanning-tree portfast deshabilitar portfast
S(config)#spanning-tree vlan 10 root primary establecer al switch como raz principal en
la determinada vlan,
en este caso es la 10.
S(config)#spanning-tree vlan 10 root secondary establecer al switch como raz
secundaria
S(config)#spanning-tree vlan 20 priority 4096 establecer la mnima prioridad posible
s#show spanning-tree active verificar

CONFIGURACIN DE PVST+RPIDO
S(config)#spanning-tree mode rapid-pvst
S(config)#interface (ID interfaz)
S(config-if)#spanning-tree link-type point-to-point establecer un enlace punto a punto
S#clear spanning-tree detected-protocols borrar todos los STP detectados

ENRUTAMIENTO ENTRE VLANS
ENRUTAMIENTO UTILIZANDO router-on-a-stick
En un Router conectado a la Red, se ponen los siguientes comandos:
R(config)#interface fastethernet 0/0.10 se crea una subinterfaz (el numero despus del
punto indica la vlan,
en este caso es la nmero 10)
R(config-subif)#encapsulation dot1q 10
R(config-subif)#ip address (direccin ip) (mascara de subred)
Cuando se termine de configurar todas las subinterfaces, se ingresa al modo de
configuracin especfica de
interfaz y se pone el comando para levantar el puerto donde fueron configuradas las
subinterfaces, en este caso
el puerto es el fa0/0
R(config)#interface fastethernet 0/0
R(config-if)#no shutdown