Está en la página 1de 4
FUNCIONES ANIDADAS DIANA E. LOPEZ IMITOLA FUNCIONES ANIDADAS En algunos casos, puede que deba utilizar

FUNCIONES ANIDADAS

FUNCIONES ANIDADAS DIANA E. LOPEZ IMITOLA FUNCIONES ANIDADAS En algunos casos, puede que deba utilizar una

DIANA E. LOPEZ IMITOLA

FUNCIONES ANIDADAS

En algunos casos, puede que deba utilizar una función como uno de los argumentos (argumento: valores que utiliza una función para llevar a cabo operaciones o cálculos. El tipo de argumento que utiliza una función es específico de esa función. Los argumentos más comunes que se utilizan en las funciones son números, texto, referencias de celda y nombres.) de otra función. Por ejemplo, la siguiente fórmula utiliza una función anidada PROMEDIO y compara el resultado con el valor 50.

anidada PROMEDIO y compara el resultado con el valor 50. Resultados válidos Cuando se utiliza una

Resultados válidos

Cuando se utiliza una función anidada como argumento, deberá devolver el mismo tipo de valor que el que utilice el argumento. Por ejemplo, si el argumento devuelve un valor VERDADERO o FALSO, la función anidada deberá devolver VERDADERO o FALSO. Si éste no es el caso, Microsoft Excel mostrará el valor de error #¡VALOR!

Límites del nivel de anidamiento:

Una fórmula puede contener como máximo siete niveles de funciones anidadas. Si la Función B se utiliza como argumento de la Función A, la Función B es una función de segundo nivel. Por ejemplo, la función PROMEDIO y la función SUMA son ambas funciones de segundo nivel porque son argumentos de la función SI. Una función anidada dentro de la función PROMEDIO será una función de tercer nivel, etc.

Referencias en las fórmulas

Una referencia identifica una celda o un rango de celdas en una hoja de cálculo e indica a Microsoft Excel en qué celdas debe buscar los valores o los datos que desea utilizar en una fórmula. En las referencias se puede utilizar datos de distintas partes de una hoja de cálculo en una fórmula, o bien utilizar el valor de una celda en varias fórmulas. También puede hacerse referencia a las celdas de otras hojas en el mismo libro y a otros libros. Las referencias a celdas de otros libros se denominan vínculos.

Ejemplo 1:

En el siguiente ejemplo, si el valor de la celda A2 es 100, la prueba lógica será verdadero, y se calculara la suma total del rango A2:A7. De lo contrario, si la prueba_lógica es Falso, se devolverá una cadena de texto vacía (“”), se borrara el contenido de la celda que contenga la función Si:

Prueba lógica = A2=100

Valor_Si_Verdadero sumatoria del rango

Valor_Si_Falso: Cadena de texto vacía (“”)

1. Inserte en una hoja de Excel los siguientes datos, tal como se indica en la columna A y B respectivamente

 

A

B

 

VALORES

SUMA

1

100

 

2

80

 

3

100

 

4

100

 

5

88

 

6

100

 

2. Haga clic en la celda B2 para activarla y escriban la siguiente función:

=SI(A2=100;SUMA($A$2:$A$7)

3. Arrastre el cursor para ver los resultados

Ejemplo 2

Objetivo venta

30000

Precio promedio Minino

15

Comisión 1

5%

Comisión 2

15%

A

B

C

D

VENDEDOR

VENTAS

PRECIO PROMEDIO

COMISIÒN

CARLOS MARTINEZ

36000

16

 

ANDRES CARDONA

38000

18

 

JORGE SANTOS

40000

19

 

MARTA GUERRERO

25000

12

 
 

0

0

 

Se dese saber la formula que permita hallar la comisión que corresponda.

Se va armar la formula para la celda D7 siguiendo el esquema de arriba

Lo primero es resolver si se cumplen las dos condiciones así:

Y(B7>$C$1;C7>C2)

o

B7: Ventas del vendedor 1

o

$C$1: Objetivos de ventas (referencias fijas porque no cambiara los distintos vendedores)

o

C7: Precio promedio vendedor.

o

$C$2: Objetivos de precio.

Ya tenemos la primera parte de la función:

SI(se cumplen ambas condiciones; 15% de comisión(valor_si_verdadero); <Acá necesitamos armar la otra condición del segundo cuadrado azul del diagrama)

=SI(Y(B7>$C$1;C7>$C$2);$C$4;<Valor si falso>) [1]

Ahora debemos armar la parte de la derecha del diagrama, cuando NO se cumplen ambas condiciones.

O(B7>$C$1;C7>$C$2)

Si la función da verdadero, corresponde el segundo nivel de comisión (que definimos en la celda C3). La única forma en que la evaluación da FALSO, es si ninguna de las condiciones se cumple. Por lo tanto, corresponde 0% de comisión.

=SI(O(B7>$C$1;C7>$C$2);$C$3;0%) [2]

Al incluir esta última fórmula en la fórmula [1], tenemos para la celda D7:

=SI(Y(B7>$C$1;C7>C2);$C$3;SI(O(B7>$C$1;C7>C2);$C$4;0%))

TALLER A DESARROLLAR

Funciones lógicas Y O se utilizan anidadas dentro de la función SI, para obtener un resultado con sentido.

Ejercicio 1

1. Cree la siguiente tabla en Excel

2. Si el porcentaje de inasistencia es menor e igual que 25 y la nota es mayor que igual que 4, debe mostrar aprobado, de lo contrario desaprobado.

3. Si el porcentaje de inasistencia es menor e igual que 25 o la nota es mayor que igual que 4, debe mostrar aprobado, de lo contrario desaprobado.

ALUMNOS

% DE

NOTA

SI - Y

SI - O

INASISTENCIAS

A

25

7

   

B

30

6

   

C

12

10

   

D

10

4

   

E

45

5

   

F

8

7

   

G

20

5