Está en la página 1de 4

- Các chức năng của RIPng (RIP next generation) trong IPv6 tương tự như chức năng

của RIP trong IPv4. Các gói tin update sử dụng địa chỉ multicast của tất cả các router
chạy RIP.
- Mỗi quá trình RIPng duy trì một bảng định tuyến cục bộ RIB (Routing Information
Database). Bảng RIB này chứa một bộ các đường đi tốt nhất học được từ các thiết bị lân
cận.
Yêu cầu:
- Router R1, R2 sử dụng RIPng để quảng bá thông tin định tuyến
- Các PC ping được toàn bộ địa chỉ trong mạng
Các bước thực hiện:
Bước 1: Đặt địa chỉ IPv6 cho các PC
PC A: netsh interface ipv6 set address “local area connection” 2001::a
PC B: netsh interface ipv6 set address “local area connection” 2003::b
Bước 2: Cấu hình địa chỉ IPv6 cho các interface của router R1, R2
Đối với R1:
R1(config)#ipv6 enable
R1(config)#ipv6 unicast-routing
R1(config)#interface E0/0
R1(config-if)#ipv6 enable
R1(config-if)#ipv6 address 2001::1/64
R1(config-if)#no shutdown
R1(config-if)#exit
R1(config)#interface S0/1
R1(config-if)# clock rate 64000
R1(config-if)# ipv6 address 2005::1/64
R1(config-if)#no shutdown
R1(config-if)#^Z
Đối với R2:
R2(config)#ipv6 enable
R2(config)#ipv6 unicast-routing
R2(config)#interface E0/0
R2(config-if)#ipv6 enable
R2(config-if)#ipv6 address 2003::1/64
R2(config-if)#no shutdown
R2(config-if)#exit
R2(config)#interface S0/1
R2(config-if)#ipv6 address 2005::2/64
R2(config-if)#no shutdown
R2(config-if)#^Z
Bước 3: Cho các interface trên R1, R2 tham gia vào quá trình định tuyến RIPng
Trên R1:
R1(config)#ipv6 router rip cisco /*đặt tên cho process
RIPng là cisco*/
R1(config-rtr)#exit
R1(config)#interface E0/0
R1(config-if)#ipv6 rip cisco enable /*cho phép RIPng
process “cisco” chạy trên E0/0*/
R1(config)#interface S0/1
R1(config-if)#ipv6 rip cisco enable /*cho phép RIPng
process “cisco” chạy trên E0/0*/
Có thể cấu hình số đường đi tối đa cùng metric mà RIPng hỗ trợ. Giá trị này trong
khoảng từ 1 đến 64, mặc định cho RIP tối đa là 4 đường.
R1(config)#ipv6 router rip cisco
R1(config-rtr)#maximum-paths 1
R1(config-rtr)#exit
Trên R2: cấu hình tương tự như R1
Cấu hình tham khảo:
R1#show run
!
hostname R1
no ip domain-lookup
!
ipv6 unicast-routing
!
interface Ethernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001::1/64
ipv6 rip cisco enable
!
interface Serial0/1
no ip address
clock rate 64000
ipv6 address 2005::1/64
ipv6 rip cisco enable
!
ipv6 router rip cisco
!
end
Chú ý: tên của process-id chỉ mang ý nghĩa cục bộ trong một router
R2#show run
!
hostname R2
!
no ip domain-lookup
!
ipv6 unicast-routing
!
interface Ethernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2003::1/64
ipv6 rip cisco enable
!
interface Serial0/1
no ip address
ipv6 address 2005::2/64
ipv6 rip cisco enable
!
ipv6 router rip cisco
!
end
Bước 4: Kiểm tra cấu hình
- Xem bảng định tuyến bằng lệnh show ipv6 route, hoặc show ipv6 route rip để xem các
đường đi học từ RIPng. Các đường đi học từ RIPng sẽ được đánh dấu bằng chữ R như
trong RIP của IPv4.
R2#show ipv6 interface brief
Ethernet0/0 [up/up]
FE80::218:18FF:FE9C:A7A0
2003::1
Serial0/1 [up/up]
FE80::218:18FF:FE9C:A7A1
2005::2
- Xem process-id của RIPng, các interface nào chạy RIPng
R1#show ipv6 rip
RIP process "cisco", port 521, multicast-group FF02::9, pid
32
Administrative distance is 120. Maximum paths is 16
Updates every 30 seconds, expire after 180
Holddown lasts 0 seconds, garbage collect after 120
Split horizon is on; poison reverse is off
Default routes are not generated
Periodic updates 69, trigger updates 40
Interfaces:
Serial0/1
Ethernet0/0
Redistribution:
None
- Có thể xem cơ sở dữ liệu của RIPng bằng lệnh show ipv6 rip database
R1#show ipv6 rip database
RIP process "cisco", local RIB
2003::/64, metric 2, installed
Ethernet0/0/FE80::218:18FF:FE9C:A7A0, expires in 155 secs
2005::/64, metric 2
FastEthernet0/1/FE80::218:18FF:FE9C:A7A1, expires in 155
secs
- Từ R1 hoặc R2 ping được các địa chỉ trên mạng
R1#ping 2003::b
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2003::B, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max =
0/0/4 ms
- Có thể dùng lệnh debug ipv6 packet [detail] để xem quá trình gói tin đi từ R1 đến PC B
R1#ping 2003::b
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2003::B, timeout is 2
seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max =
0/1/4 ms
R1#
*Dec 24 07 16.651: IPv6: SAS picked source 2005::1 for
2003::B (Serial0/1)
*Dec 24 07 16.655: IPv6: nexthop FE80::218:18FF:FE9C:A7A1,
*Dec 24 07 16.655: IPV6: source 2005::1 (local)
*Dec 24 07 16.655: dest 2003::B (Serial0/1)
*Dec 24 07 16.655: traffic class 0, flow 0x0, len 100+0,
prot 58, hops 64, originating
*Dec 24 07 16.655: IPv6: Sending on Serial0/1
*Dec 24 07 16.655: IPV6: source 2003::B (Serial0/1)
*Dec 24 07 16.655: dest 2005::1
*Dec 24 07 16.655: traffic class 0, flow 0x0, len 100+14,
prot 58, hops 63, forward to ulp