Está en la página 1de 5

1

Comandos para la configuracin de equipos Cisco en el


laboratorio de Redes de Computadores de Ingeniera Civil
Informtica
1


Material preparado por Gabriel Astudillo
Escuela de Ingeniera Civil Informtica, Universidad de Valparaso.
1 Comandos estndar para equipos cisco (switch, router y firewall)
Entrar a modo privilegiado
! switch>enable
Entrar a modo de configuracin
! switch#configure terminal
Borrar configuracin inicial (switch y router)
! switch#erase startup-config
! switch#reload
Reinicie el dispositivo
! firewall#write erase
! firewall#reload
Guardar configuracin
! switch#copy running-config startup-config o switch#wr
Velocidad y modo de puertos
! switch(config)#iinterface fastethernet 0/X Configuraremos el puerto X del equipo
! switch(config-if)#speed <10,100,1000,auto> 10mbps,100mbps,1000mbps, auto-negociacin,
etc.
! switch(config-if)#duplex <half,full,auto> full duplex, half duplex, auto-negociacin
tiles
! switch#show <opcin>
muestra por pantalla <opcin>.
! switch#show ?
muestra todos los comandos que se pueden ingresar despues de show, ? muestra la
lista de comandos que pueden ser ingresados.
! switch#configure <tab>
el tabulador completa el comando ingresado, si existe ms de una opcin , muestra una
lista.
! switch#no <comando>
hace lo contrario al comando ingresado, por ejemplo, shutdown apaga una interfaz,
no shutdown la enciende.


1
Este material est basado en el documento original creado por Alexis Gaete (alexisgaete@gmail.com)

2
2 Comandos para switch
2.1 STP
Visualizar el estado de spanning-tree en el equipo
switch#show spanning-tree
Cambiar prioridad a un equipo
switch(config)#spanning-tree vlan 1 priority <prioridad>
Configurar guard root en una interfaz
switch(config-if)# spanning-tree root guard

2.2 RSTP
Habilitar Rapid Spanning-tree
switch# spanning-tree mode rstp

2.3 VLAN
Creacin de Vlan
switch(configure)#vlan <id>
switch(config-vlan)# name vlan de prueba
Configuracin de puertos en modo access y modo trunk
switch(configure)#interface fastethernet 0/x
ingreso al puerto x del switch
switch(config-if)#switchport mode access
Configura el puerto en modo access
switch(config-if)#switchport access vlan <id>
Configura el puerta para darle acceso a la vlan <id>
switch(configure)#interface fastethernet 0/y
switch(config-if)#switchport mode trunk
Configura el puerto y como troncal
switch(config-if)#switchport trunk allowed vlan 1,2,25,...100
Indica que vlans son las autorizadas a ser cursadas por el troncal

2.4 Link aggregation
Asignar interfaces al channel-group
switch(configure)#interface fastethernet 0/x
switch(configure-if)#channel-group 1 mode active
switch(configure-if)#exit
switch(configure)#interface fastethernet 0/y
switch(configure-if)#channel-group 1 mode active
Con esto el puerto x e y forman a ser un solo enlace lgico (port-channel 1) que posee
BW del puerto (x+y)

3
3 Comandos para Router
Asignacin de ip a una interfaz fsica.
Router(config)#interface fastethernet 0/0
Router(config-if)#ip address 10.0.0.1 255.0.0.0
Se le asigna ip a la interfaz con la respectiva mscara.
Router(config-if)#no shutdown

Creacin de interfaces virtuales y vlan encapsulation, se crearn 2 interfaces virtuales sobre un
puerto fsico, cada uno de ellos formarn parte de una vlan.

Router(config)#interface fastethernet 0/0.10
Se crea la interfaz 10 sobre el puerto fsico 0
Router(config-subif)#encapsulation dot1q 10
La interfaz se configura para ser parte de la vlan 10, encapsulation dot1q
<vlan id>
Router(config-subif)#ip address 192.168.0.1 255.255.255.0
Asigna una IP a la interfaz con la respectiva mscara.
Router(config-subif)#no shutdown
Se activa la interfaz

Cabe destacar que para que una interfaz virtual funcione correctamente, la interfaz fsica
debe estar encendida (no shutdown) y no debe tener asignada una ip (no ip address).

3.1 Default gateway
Si el default gateway del router es la ip 200.1.21.1, la configuracin es la siguiente.
router(config)#ip route 0.0.0.0 0.0.0.0 200.1.21.1

3.2 Ruteo esttico
! router(config)#ip route <nombre_red_destino> <mscara_destino> <next_hop>
Ejemplo:
Supongamos que para llegar a la red 192.168.2.0/24 se debe enviar el trfico al router con ip
192.168.3.1 (suponiendo que nuestro router puede lograr conectividad con la ip 192.168.3.1).
! router(config)#ip route 192.168.2.0 255.255.255.0 192.168.3.1




4
3.3 Ruteo dinmico
!"!"# $%&'(
Supongamos que nuestro equipo se encuentra conectado a las redes 192.168.3.0/24, 192.168.4.0/24
y 10.2.10.0/24.

! router(config)#router rip
! router(config-router)#version 2
! router(config-router)#network 192.168.3.0
! router(config-router)#network 192.168.4.0
! router(config-router)#network 10.2.10.0

!"!"( *+&,
! router(config)#interface fastethernet 0/x
! router(config-if)#ip address 192.168.2.1 255.255.255.0
! router(config-if)#no shutdown
! router(config-if)#exit
! router(config-if)#interface fasethernet 0/y
! router(config-if)#ip address 192.168.3.1 255.255.255.0
! router(config-if)#no shutdown
! router(config-if)#exit
! router(config)#router ospf <id>
el id es un identificador del proceso ospf, es un valor nmerico
! router(config-router)#network 192.168.2.0 255.255.255.0 area 0
Con esto la interfaz 0/x es parte del area 0
! router(config-router)#network 192.168.3.0 255.255.255.0 area 1
Con esto la interfaz 0/y es parte del area 1

En el caso de realizar summarization:
! router(config)#router ospf <id>
! router(config-router)#area area-id range address_sum mask_sum
Address y mask es la red que incluye las redes resumidas

3.4 Listas de acceso
! router(config)#ip access-list extended <id>
! router(config-ext-nacl)#<permit|deny> <protocolo> <red_origen> <mask_origen>
<red_destino> <mask_destino> <opciones>
! router(config)#interface fastethernet 0/x
! router(config-if)#ip access-group <id> <in|out>


5
Ntese que para que un access-list quede ligada a un access-group, los <id> deben ser los mismos, por
ejemplo access-list 101 con access-group 101

4 Comandos para Firewall
4.1 Configuracin de interfaces
! Firewall(config)#interface ethernet x
! Firewall(config-if)#nameif <name>
! Firewall(config-if)#ip address <ip> <mask>
! Firewall(config-if)#security-level <num>
! Firewall(config-if)#no shutdown

4.2 Default Gateway
Suponiendo que nuestra interfaz hacia internet tiene por nombre outside.
! Firewall(config)#route outside 0 0 <next_hop>

4.3 Protocolos de Ruteo
Los algoritmos de ruteo dinmicos funcionan de igual forma que en el router.

4.4 NAT, PAT
! firewall(config)#nat (inside) id 0 0
! firewall(config)#global (outside) id <ip_publica_a_mapear>

-"-"# ./0 12343567
! firewall(config)#static (real_interface,mapped_interface) <mapped_ip> <real_ip> netmask
<mask>
! firewall(config)#static (inside,outside) ip_publica ip_privada netmask mscara

-"-"( 8594:567
! firewall(config)#nat (inside) 1 10.0.0.0 255.0.0.0 0 0
! firewall(config)#global (outside) 1 209.165.201.3-209.165.201.30 netmask 255.255.255.224

4.5 ACL
! firewall(config)#access-list <id> extended <permit|deny> <protocolo> <ip_origen>
<mask_origen> <ip_destino> <mask_destino> <opciones>
! firewall(config)#access-group <id> <in|out> interface <inside|outside>