Está en la página 1de 5

25.- Dado N y X calcular: x1/1+x3/3+x5/5+...........+x(2n)-1?

variables
I,N

inicio
leer N
I_1
mientras 1<=2*n hacer
si I mod 2=0 entonces
imprimir I
fin si
I_I+1
fin mientras
fin

26.- A una fiesta asistieron personas de diferentes edades y sexos.
Contruir un algoritmos dadas las edades y sexos de las personas.?
calcular :
-Cuantas personas asistieron a la fiesta
-Cuantos hombres y cuantas mujeres
-Promedio de edades por sexo
-La edad de la persona ms joven que asistio
-No se permiten menores de edad a la fiesta
-Ingresar datos hasta que se ingrese una edad a cero

variables
sev-suma de edades de varones
sem-suma de edades de mujeres
a-asistentes
v-varones
m-mujeres
e-edades
s-sexo

inicio
sev_0
sem_0
a_0
v_0
e_1
menor_200
mientras e<>0 hacer
leer e,s
si e>=18 entonces
a_a+1
si s="m" entonces
m_m+1
sem_sem+e
sino
v_v+1
sev_sev+e
finsi
si e<menor entonces
menor_e
finsi
sino
imprimir "menor de edad"
finsi
fin mientras
pm_sem\m
pv_sev\v
imprimir pm,pv,menor,a,m,v
fin

27.- Dada las horas trabajadas de 20 personas y la tarifa de pago
calcular el salario?

variables
horas
tarifa
salario

inicio
i_1
mientras i<=20 hacer
leer horas , tarifa
salario_ horas *tarifa
imprimir salario
i_i+1
fin mientras


28.- De una lista de 10 nmeros calcular la media y determinar cuantos
son mayores que 10.5, cuantos son iguales y cuntos son menores.

Inicio
Real Num
S <- 0.00
M <- 0.00;
Entero I, C1 = 0, C2 = 0, C3 = 0;
Para i = 1 ; i = 10
Leer Num
Fin_Para
Para i = 1 ; i = 10
S <- S + Num
Fin_Para
M <- 10
Para i = 1; i = 10
Si Num = 10.5 entonces
C1 <- C1 + 1
Fin_Si
Si Num > 10.5
C2 <- C2 + 1
Fin_Si
Si Num < 10.5 entonces
C3 <- C3 + 1
Fin_Si
Fin_Para
Escribir "Media" , M ;
Escribir "Iguales que l10.5" , C1 ;
Escribir "Mayores que 10.5", C2 ;
Escribir "Menores que 10.5" , C3;
Fin

29.- Elaborar un algoritmo, que permita el ingreso de 100 nmeros
enteros.
El programa debe sumar todos los nmeros que sean mltiplos de 3.

Inicio
Dimensionar numero[100]
x<-1
mientras x<=100 hacer
leer numero[x]
x<-x+1
fin - mientras
x<- 1
s<- 0
mientras x<=100 hacer
Si (numero[x] mod 3 = 0) entonces
s<- s+numero[x]
Fin_Si
x<-x+1
Fin_mientras
Mostrar s
Fin

30.- Mostrar las 30 primeras potencias de 3 y la suma de ellos.

Inicio
Dimensionar nmero[30]
x<-0
n<-3
t<-0
s<-0
mientras x<=29 hacer
t<- n^(x+1)
Mostrar t
s <- s + t
x <- x+1
fin_mientras
Mostrar s
Fin

31.- Leer 100 nmeros y obtener cuantos son positivos, negativos e
iguales a cero.

Inicio
N : entero
C1 0; C2 0; C3 0: entero
Repetir
Leer N
Si (N > 0) entonces
Hacer C1 C1 + 1
Si (N < 0) entonces
Hacer C2 C2 + 1
Si (N = 0) entonces
Hacer C3 C3 + 1
Fin_Si
Fin_Si
Fin_Si
Hasta (C1+C2+C3=100)
Fin

32.- Disear un algoritmo que me permita determinar si un numero
ingresado desde el teclado es un numero par o impar.

Inicio
A : entero
Repetir
Ingresar A
Hasta (A > 0)
Si (A mod 2 = 0) entonces
Mostrar "A es par"
Sino
Mostrar "A es impar"
Fin_Si
Fin

33.- Se desea calcular independientemente la suma de los nmeros pares e
impares comprendidos entre 1 y 50.

Inicio
B, i: entero
S1 0; S2 0 : real
Para(i=1; i<50; i++)
Repetir
Ingresar B
Hasta (B mod 2 = 0)
Hacer S1 S1 + B
Mostrar"S1"
Hasta (B mod 2 <> 0)
Hacer S2 S2 + B
Mostrar"S2"
Fin_Para
Fin

34.- Determinar la media aritmtica de una lista de nmeros positivos.

Inicio
N, S 0, C 0, :entero
Media : real
Leer N
Si(N > 0) entonces
Hacer C C + 1
Hacer S S + N
Fin_Si
Media S / C
Mostrar "Media"
Fin

35.- Averiguar si dado dos nmeros, uno es divisor de otro.

Inicio
N1, N2 :entero
Leer N1, N2
Si(N1 > N2) entonces
Mostrar N2 "es divisor de " N1
Fin_Si
Si(N1 = N2) entonces
Mostrar "Son divisores"
Fin_Si
Si(N1 < N2) entonces
Mostrar N1 "es divisor de " N2
Fin_Si
Fin

36.- Disear un algoritmo que calcule los 5 primeros nmeros impares que
preceden a un numero N ingresado por teclado.

Inicio
N 0, C 0 :entero
Leer N
Repetir
Hacer N N - 1
Si(N mod 2 <> 0) entonces
Hacer C C + 1
Mostrar N
Fin_Si
Hasta (C = 5)
Fin

37.- Disear un algoritmo que me permita calcular los 5 primeros nmeros
perfectos (un numero es perfecto, cuando la suma de sus divisores, sin
incluirlo al numero es exactamente el mismo numero). El 6 es un numero
perfecto por sus divisores son 1,2 y 3.

Inicio
N 0, P 0, C 0 :entero
Repetir
Hacer N N + 1
Para (i = 1; i< N; i++)
Si(N mod i = 0) entonces
Hacer C C + 1
Fin_Si
Fin_Para
Si(C = N) entonces
Hacer P P + 1
Fin_Si
Hasta (P = 5)
Fin